Importar y exportar archivos COLLADA

COLLADA es un esquema basado en XML que te permite transferir datos entre herramientas de creación de contenido digital 3D, como SketchUp, Maya, 3ds Max y Rhino. Los archivos COLLADA usan la extensión de archivo .dae, que significa "intercambio de activos digitales".

En SketchUp puedes importar y exportar fácilmente archivos COLLADA.

Nota: SketchUp admite la especificación y el esquema de COLLADA 1.4. Para obtener más información sobre COLLADA, visita Collada.org.

Importar un archivo COLLADA

Para importar un archivo COLLADA a SketchUp, sigue estos pasos:

  1. Selecciona File > Import (Archivo > Importar).
  2. En el cuadro de diálogo que aparece, busca y selecciona el archivo .dae que quieres importar. Si no ves el archivo que estás buscando, asegúrate de haber seleccionado el tipo de archivo correcto en la lista desplegable de la parte inferior derecha.
  3. Haz clic en el botón Options (Opciones). Aparece el cuadro de diálogo DAE Import Options (Opciones de importación DAE).
  4. (Opcional) De forma predeterminada, la casilla Validate COLLADA File (Validar archivo COLLADA) está seleccionada para que SketchUp verifique que tu archivo sea un archivo COLLADA 1.4.1 válido. Si el archivo no es válido, SketchUp te preguntará si aún quieres importar el archivo. Ten en cuenta que un archivo COLLADA no válido puede producir resultados inesperados. Desmarca esta opción si no quieres que SketchUp verifique la validez del archivo.
  5. (Opcional) De forma predeterminada, la casilla Merge Coplanar Faces (Unir caras coplanarias) está seleccionada para que SketchUp elimine automáticamente las aristas de las caras coplanarias que comparten el mismo material. Esta función es útil al importar datos 3D de programas que usan solo caras triangulares, que pueden ser tediosas de limpiar a mano en SketchUp. Desmarca esta opción si quieres conservar las caras triangulares.
  6. Haz clic en Aceptar en el cuadro de diálogo de opciones de importación DAE.
  7. De vuelta en el cuadro de diálogo principal, haz clic en Open (Abrir) (Microsoft Windows) o Import (Importar) (Mac OS X) y SketchUp comenzará a importar tu archivo COLLADA.
Consejo: Si no puedes ver el modelo importado, haz clic en la herramienta Zoom Extents (Extensión de zoom) (Extensión de zoom) para que el modelo llene el área de dibujo de SketchUp.
Consejo: También puedes arrastrar y soltar archivos importables en el área de dibujo. Cuando sueltes el archivo, se abrirá un cuadro de diálogo de importación para que elijas las opciones que prefieras.

Exportar un archivo COLLADA

Antes de exportar un modelo 3D de SketchUp a un archivo COLLADA, debes saber que COLLADA no es compatible con todas las funciones de SketchUp. Si tu modelo de SketchUp incluye los elementos siguientes, no esperes verlos en el archivo COLLADA exportado:

  • Líneas de coordenadas
  • Acotaciones
  • Líneas guía y puntos guía
  • Fotos coincidentes
  • Ubicaciones de guías fijas de materiales
  • Opciones de renderizado
  • Escenas
  • Planos de sección
  • Cortes de sección
  • Sombras
  • Texto

Para exportar tu modelo de SketchUp a un archivo COLLADA .dae, sigue estos pasos:

Windows

  1. Selecciona File > Export > 3D Model (Archivo > Exportar > Modelo 3D). Aparece el cuadro de diálogo Export Model (Exportar modelo).
  2. Ve a la ubicación a la que quieras exportar tu archivo COLLADA.
  3. En el menú desplegable Export Type (Tipo de exportación), selecciona COLLADA File (*.dae) (Archivo COLLADA (*.dae)).
  4. (Opcional) De forma predeterminada, SketchUp asigna al archivo COLLADA el mismo nombre que tu modelo de SketchUp, pero puedes cambiar el nombre si escribes uno nuevo en el cuadro File Name (Nombre de archivo).
  5. (Opcional) Haz clic en el botón Options (Opciones) para abrir el cuadro de diálogo DAE Export Options (Opciones de exportación DAE). Selecciona las opciones que desees, que se explican en la lista siguiente, y haz clic en Aceptar para volver al cuadro de diálogo Exportar modelo.
  6. Haz clic en el botón Export (Exportar) y el archivo exportado se guardará en la ubicación seleccionada.

MacOS

  1. Selecciona File > Export > 3D Model (Archivo > Exportar > Modelo 3D). Aparece el cuadro de diálogo Export (Exportar).
  2. Ve a la ubicación a la que quieras exportar tu archivo COLLADA.
  3. En el menú desplegable Format (Formato), selecciona COLLADA File (*.dae) (Archivo COLLADA (*.dae)).
  4. (Opcional) De forma predeterminada, SketchUp asigna al archivo COLLADA el mismo nombre que tu modelo de SketchUp, pero puedes cambiar el nombre si escribes uno nuevo en el cuadro Save As (Guardar como).
  5. (Opcional) Haz clic en el botón Options (Opciones) para abrir el cuadro de diálogo Export Options (Opciones de exportación). Selecciona las opciones que desees, que se explican en la lista siguiente, y haz clic en Aceptar para volver al cuadro de diálogo Exportar.
  6. Haz clic en el botón Export (Exportar) y el archivo exportado se guardará en la ubicación seleccionada.

Cuando exportas un archivo COLLADA, la mayoría de las opciones te permiten determinar cómo se exportará la geometría, pero también tienes opciones para materiales y créditos. En la lista siguiente se explica cada casilla del cuadro de diálogo Opciones de exportación DAE:

  • Export Two-Sided Faces (Exportar caras con dos lados): Cuando se selecciona esta opción, SketchUp exporta caras dos veces: una para el frente y otra para la parte trasera. SketchUp une los vértices de las caras delanteras y los vértices de las caras traseras. Esta opción duplica el número de polígonos del archivo .dae generado y puede ralentizar el procesamiento. Sin embargo, esta opción garantiza que, en otros programas compatibles con COLLADA, tu modelo se parezca más a la forma como luce en SketchUp. Se renderizarán siempre ambas caras y se conservarán los materiales aplicados a las caras delantera y trasera.
  • Export Edges (Exportar aristas): Cuando se selecciona esta opción, el archivo exportado mantiene la apariencia de un modelo de SketchUp con aristas visibles. Ten en cuenta que las aristas independientes siempre se exportan.
  • Triangulate All Faces (Triangular todas las caras): Cuando se selecciona esta opción, todas las superficies se dividen en triángulos en lugar de caras de varios lados. Usa esta opción cuando planees usar tu archivo COLLADA con un programa que solo admita caras triangulares.
  • Export Only Selection Set (Exportar solo el conjunto de selección): Si seleccionas geometría antes de comenzar el proceso de exportación, puedes seleccionar esta casilla para exportar solo la geometría que esté seleccionada en ese momento en el área de dibujo de SketchUp. Si no seleccionas nada en tu modelo o no seleccionas esta opción, todo el modelo de SketchUp se exportará a tu archivo COLLADA.
  • Export Hidden Geometry (Exportar geometría oculta): Si tu modelo de SketchUp contiene geometría oculta, al seleccionar esta casilla SketchUp exportará esa geometría.
  • Preserve Component Hierarchies (Conservar las jerarquías de componentes): Como se explica en Organizar un modelo, puedes crear jerarquías de grupos y componentes. Cuando seleccionas esta casilla, las jerarquías de componentes también aparecen en el archivo .dae exportado. Cuando esta opción no está seleccionada, la jerarquía de componentes se aplana y las instancias de componentes se convierten en objetos únicos en lugar de instancias de un solo componente. Para obtener información sobre las instancias de componentes, consulta Añadir componentes prediseñados y componentes dinámicos.
  • Export Texture Maps (Exportar mapas de textura): Cuando se selecciona esta opción, las texturas aplicadas a tu modelo se exportan con su archivo .dae.
  • Preserve Credits (Conservar créditos): Selecciona esta opción si has agregado uno o más créditos al creador de un modelo en el cuadro de diálogo Información del modelo y deseas exportar esos créditos. Esta función es especialmente útil si deseas compartir tu archivo exportado en 3D Warehouse.