Añadir componentes prediseñados y componentes dinámicos

Los componentes de SketchUp te permiten reutilizar objetos. Por ejemplo, prácticamente todos los edificios tienen por lo menos una puerta y ventana. En lugar de modelar estos objetos comunes, puedes insertar un componente que otra persona ya haya hecho.

Al igual que toda la geometría de SketchUp, un componente está hecho de aristas y caras. Las aristas y las caras simplemente forman parte de un grupo especial de componentes. (También puedes crear componentes para reutilizar tu propia geometría, pero eso se aborda en Desarrollar componentes y componentes dinámicos.)

Introducción a los componentes

Antes de empezar a insertar componentes, debes saber que cada componente tiene una definición y una instancia:

  • Una definición de componente nos brinda un plano de cómo aparecen y se comportan todos los componentes de un tipo específico en el área de dibujo.
  • Al insertar un componente en un modelo, se crea una instancia de componente, que se basa en su definición.

Por ejemplo, supongamos que quieres usar un componente prediseñado denominado Media puerta enmarcada con panel doble. La definición del componente describe el aspecto de esa puerta, y puedes insertar todas las instancias que quieras de dicho componente. En el modelo siguiente, puedes ver dos instancias de Media puerta enmarcada con panel doble. En la sección Insertar componentes, incluida más adelante en este artículo, se explica cómo insertar una o más instancias de un componente.

Consejo: Todo este tema acerca de la definición y las instancias es importante, porque, cuando editas entidades dentro de la instancia de componente, también editas la definición. Si cambias el vidrio de la puerta, cambiará también el cristal en todas las instancias de componente. Si cambias del panel doble a un panel sencillo, todas las puertas de tu modelo tendrán también un panel sencillo. Sin embargo, podrás escalar, rotar y voltear un componente completo sin cambiar las otras instancias. En la sección Editar componentes se explica cómo editar las entidades de un componente o el componente en su conjunto.

También puedes sustituir todas las instancias de un componente por otro componente. Si ya no te gusta la media puerta enmarcada con panel doble (o si al cliente ya no le gusta), puedes cambiar fácilmente ese componente por otro diferente. Consulta Sustituir componentes más adelante en este artículo para ver más información.

Los componentes dinámicos tienen aún más funciones que los componentes regulares. Si un componente es dinámico, tiene al menos uno de los elementos siguientes:

  • Valores limitados: Por ejemplo, un componente dinámico de la puerta de un gabinete puede tener un marco limitado a 3 pulgadas. Independientemente de que el panel dentro del marco tenga 12 x 24 pulgadas o 24 x 48 pulgadas, o cualquier otra dimensión, el marco seguirá siendo de 3 pulgadas de anchura alrededor de la puerta, como se muestra en la figura siguiente.
  • Elementos repetitivos: Un componente dinámico puede tener subcomponentes que se repiten a medida que se ajusta la escala del componente. Por ejemplo, un componente dinámico repetitivo podría agregar escalones a una escalera, cojines al sofá, barrotes a una cerca, montantes a la estructura de la construcción, etc.
  • Valores configurables: Un componente dinámico puede tener un conjunto predefinido de valores que puedes configurar, como la longitud de un sofá o el espacio entre los barrotes de una cerca.
  • Funciones de animación: Un componente dinámico animado se mueve al hacer clic en él con la herramienta Interactuar (). Con componentes dinámicos animados, el modelo puede tener puertas y ventanas que se abran. En la sección Interactuar con componentes, que aparece más adelante en este artículo, se explica cómo abrir y cerrar los componentes animados.

Puedes encontrar algunos componentes de muestra en el panel Componentes de SketchUp, pero la verdadera casa de los componentes es 3D Warehouse, una herramienta en línea para buscar y descargar modelos en 3D creados en SketchUp. En este artículo encontrarás información útil para navegar en el panel Componentes y empezar a buscar componentes en 3D Warehouse a través de las herramientas disponibles en SketchUp.

Cuando te sientas cómodo con la inserción y edición de componentes, puedes utilizar componentes de 3D Warehouse o los que sean creación tuya. Para que tus componentes favoritos estén a la mano y organizados, crea colecciones en el panel Componentes.

En el video siguiente verás una breve introducción a los componentes, cómo se diferencian de los grupos y de qué manera puedes editarlos. Aunque este video se creó para una versión más antigua de SketchUp, los aspectos básicos del comportamiento y las características de los componentes son iguales en las versiones actuales de SketchUp. En las secciones siguientes, encontrarás información detallada básica sobre cómo insertar componentes y componentes dinámicos, y cómo trabajar con ellos.

Insertar componentes

Puedes insertar una instancia de componente en el modelo de tres maneras:

  • Selecciona o descarga un componente mediante el panel Componentes.
  • Importa un archivo de SketchUp (con .skp como extensión de archivo).
  • Arrastra un archivo de SketchUp desde el explorador de archivos (Microsoft Windows) o la ventana del Finder (Mac OS X) hasta tu modelo.

Los componentes prediseñados se insertan con mayor frecuencia desde el panel Componentes en un modelo. Sigue estos pasos:

  1. De forma predeterminada, el panel Componentes se abre en la colección Componentes de muestra, como se indica en la figura.
  2. Puedes seleccionar uno de los componentes de muestra y continuar con el paso siguiente. Sin embargo, la selección de la muestra es limitada en comparación con la amplia selección de 3D Warehouse. Para probar 3D Warehouse, escribe un término de búsqueda en el cuadro de búsqueda de 3D Warehouse. (En la sección Buscar componentes, que aparece más adelante en este artículo, se explican otras formas de buscar en 3D Warehouse). Para navegar entre las colecciones, haz clic en la flecha hacia abajo situada junto al ícono de En el modelo () y selecciona una colección. (Consulta Organizar colecciones de componentes para obtener detalles sobre las colecciones existentes y sobre cómo crear las tuyas). Después de que hayas seleccionado o descargado un componente, SketchUp cargará el componente al cursor Mover.
  3. Haz clic en el área de dibujo para colocar el componente en tu modelo.
Consejo: Si tienes problemas para ver los componentes en el panel Componentes, intenta cambiar las opciones de vista. Haz clic en el botón Opciones de vista () y elige entre Imágenes pequeñas, Imágenes grandes, Detalles o Lista.
Nota: Después de descargar un componente desde 3D Warehouse, puede que el creador lo actualice. Para actualizar rápidamente tu versión local del componente, haz clic en el componente de tu modelo y selecciona Volver a cargar en el menú contextual que aparece. Aparece la página de detalles de componentes en 3D Warehouse, donde podrás descargar la versión nueva y así volver a cargar el componente En el modelo con la última versión de 3D Warehouse. Si quieres conservar el componente antiguo, pero también añadir la versión nueva al modelo, abre el menú contextual y selecciona Ver detalles. Verás la página de detalles del componente, pero en lugar de volver a cargar el componente antiguo, la nueva versión se añadirá a tu modelo como una nueva instancia de componente.

Si tienes un modelo de SketchUp guardado en tu disco duro, puedes importar ese modelo como un componente en otro modelo. Sigue estos pasos:

  1. Abre el modelo en el que quieres importar un archivo de SketchUp.
  2. Selecciona Archivo > Importar.
  3. En el cuadro de diálogo Abrir, ve al archivo de SketchUp. Si no ves tu archivo, en la lista desplegable Archivos de tipo, selecciona Archivos de SketchUp (.skp).
  4. Selecciona el archivo de SketchUp y haz clic en Abrir. SketchUp carga el componente al cursor Mover.
  5. Haz clic en el área de dibujo para colocar el componente en tu modelo.

Al arrastrar un archivo de SketchUp desde el explorador de archivos (Microsoft Windows) o desde la ventana del Finder (Mac OS X) a un modelo abierto, también se carga el archivo de SketchUp al cursor Mover. Basta con hacer clic para colocar el componente en el modelo.

Consejo: Cuando cargues el componente al cursor de la herramienta Mover, la herramienta Mover estará anclada al punto de origen del eje del componente. Si esto no funciona en tu caso, cambia la ubicación del origen del eje del componente antes de insertar el componente. Al hacerlo, se cambiará el punto de inserción predeterminado. Consulta Ajustar el punto de inserción de un componente más adelante en este artículo para ver más información.

Sustituir componentes

A todos nos gusta ver diferentes opciones, y cambiamos de opinión todo el tiempo. Si estás indeciso o aún no tienes una idea clara de tu diseño, debes saber que puedes sustituir fácilmente un componente por otro. El proceso consiste en lo siguiente:

  1. Añade a tu modelo el componente nuevo. Si no tienes dónde ponerlo, colócalo en un área vacía en tu modelo mediante los pasos de la sección anterior. Al colocar el componente en algún lugar del modelo, el componente aparecerá en la colección En el modelo. (Incluso si eliminas el componente por ahora, el componente permanecerá en la colección En el modelo hasta que purgues los componentes no usados).
  2. En el panel Componentes, haz clic en el ícono En el modelo () para ver tu colección En el modelo.
  3. Selecciona el componente o los componentes que quieras sustituir.
    Consejo: Para seleccionar todas las instancias de un componente, abre el menú contextual del componente en el panel Componentes y elige Seleccionar instancias, como se muestra en la figura.
  4. En el panel Componentes, abre el menú contextual del componente que quieras usar en lugar del existente y elige Sustituir selección en el menú contextual. En este ejemplo, el componente es Puerta de panel grande. La puerta antigua ahora quedó sustituida por la nueva, como se muestra en la figura siguiente.
Consejo: Los usuarios de SketchUp Pro cuentan con una herramienta adicional: el comando Intercambiar componente, que funciona con los componentes dinámicos.

PRO Para intercambiar una serie de componentes dinámicos en SketchUp Pro, sigue estos pasos:

  1. Selecciona los componentes dinámicos que quieras sustituir. Los componentes se resaltarán en la ventana de dibujo.
  2. Abre el menú contextual de un componente y selecciona Componentes dinámicos > Intercambiar componente. Se muestra el cuadro de diálogo Seleccionar un SKP.
  3. Selecciona el archivo de SketchUp que contiene el componente dinámico que sustituirá los componentes seleccionados en ese momento.
  4. Haz clic en el botón Abrir. El nuevo componente dinámico sustituirá los componentes dinámicos seleccionados previamente.

Interactuar con componentes dinámicos

Tu capacidad de interactuar con un componente dinámico depende de las variables del componente. En la figura siguiente, verás un edificio básico con dos instancias del componente dinámico de una puerta.

Para activar la animación del componente, selecciona la herramienta Interactuar () en la barra de herramientas Componentes dinámicos o selecciona Herramientas > Interactuar. La puerta se abrirá al hacer clic en la puerta con el cursor de la herramienta Interactuar, como se muestra en la figura siguiente.

Este componente dinámico también tiene valores configurables. Para ver estos valores, haz clic en la herramienta Opciones de componentes () en la barra de herramientas Componentes dinámicos o selecciona Ventana > Opciones de componentes. En la ventana Opciones de componentes, que se muestra en la figura siguiente, puedes elegir entre opciones predefinidas para la anchura del marco, la altura del marco, el tipo de puerta y más opciones.

Buscar componentes

Puedes buscar componentes en el panel Componentes o en 3D Warehouse.

En el panel Componentes, en la pestaña Seleccionar, puedes utilizar las siguientes funciones para buscar componentes o navegar por ellos:

  • Ícono En el modelo: Haz clic en el ícono En el modelo () y verás la colección En el modelo, la cual muestra todos los componentes guardados en ese momento con tu modelo. Ten en cuenta que un componente no tiene que aparecer en tu modelo para guardarse con él.
  • Menú desplegable En el modelo: Haz clic en la flecha hacia abajo situada junto al ícono En el modelo; en la lista que aparece, puedes seleccionar colecciones prediseñadas como Arquitectura, Paisaje, Personas y Transporte. En este menú también se pueden mostrar las colecciones que hayas creado, las que hayas designado como favoritas o las que hayas visitado recientemente. (En la sección Organizar colecciones de componentes, que aparece más adelante en este artículo, se explica cómo crear y administrar colecciones).
    Consejo: Si tu modelo está geolocalizado, el panel Componentes te permite buscar modelos cercanos. Busca componentes en el cuadro de búsqueda. Luego, en el menú desplegable En el modelo, selecciona Modelos cercanos para filtrar los resultados de la búsqueda de modo que muestre modelos cercanos.
  • Cuadro de búsqueda de Warehouse 3D: Escribe un término de búsqueda en el cuadro y presiona Intro (Microsoft Windows) o Retorno (Mac OS X) para ver una lista de componentes de 3D Warehouse. Para conectarse a 3D Warehouse, tu computadora debe tener una conexión a Internet. Si la búsqueda muestra varios resultados, puedes hacer clic en las flechas de la parte inferior del panel Componentes para ver más resultados. Es posible que te parezca más fácil buscar en 3D Warehouse en una ventana completa del explorador que en el panel Componentes, que es demasiado pequeño para mostrar muchos detalles en las miniaturas de los componentes.

Para acceder a 3D Warehouse directamente desde SketchUp, haz clic en la herramienta Obtener modelos (), que encontrarás en las siguientes partes de la interfaz de SketchUp:

  • Barra de primeros pasos
  • Barra de herramientas Warehouse

También puedes seleccionar Archivo > 3D Warehouse > Obtener modelos.

Independientemente del método que uses, se abrirá 3D Warehouse, como se muestra en la figura siguiente. Desde la pantalla de apertura, puedes navegar por los modelos destacados, los catálogos destacados de fabricantes, las colecciones destacadas y los modelos recientes. Sin embargo, lo más sencillo es usar el cuadro Buscar en la parte superior. Escribe un término de búsqueda y haz clic en el botón Buscar.

Consejo: Empieza con el término de búsqueda más específico. Por ejemplo, si estás buscando una ventana que es un componente dinámico con un plano de corte que hace un agujero en el modelo, escribe un término de búsqueda como ventana de componente dinámico corta cara. Si no encuentras un componente que te guste, haz que el término de búsqueda sea menos específico.

Cuando encuentres un resultado que te interese, haz clic en él para abrir su página de detalles. Haz clic en el botón Descargar en la parte superior derecha para descargar el componente en tu modelo. Luego vuelve a SketchUp, donde el cursor Mover se carga con el componente. Haz clic en el área de dibujo para colocar el componente en tu modelo.

Ajustar el punto de inserción de un componente

Un componente tiene su propio punto de origen de eje, que define el punto de inserción del componente, o el punto que se carga al cursor Mover cuando colocas un componente en el modelo.

Si el componente tiene forma de cuadro (como un tocador, gabinete o algún otro objeto), el punto de inserción por lo general es la esquina delantera inferior izquierda, como se muestra en la figura. Dicha ubicación funciona muy bien, a menos que tengas que colocar el componente contra otros componentes o trabajar en torno a la geometría existente.

Independientemente de las razones para mover el punto de inserción, a continuación se explica cómo restablecer el origen del eje de un componente:

  1. Selecciona el componente de tu modelo.
  2. Abre el menú contextual del componente y selecciona Cambiar ejes.
  3. Con el cursor de la herramienta Ejes que aparece, restablece el origen del eje. Consulta Ajustar los ejes de dibujo para obtener más información sobre cómo trabajar con la herramienta Ejes. La única diferencia es que estás configurando el origen del eje para un componente, no para el modelo entero.
Consejo: Tras colocar un componente en tu modelo, puedes mover el componente según tus preferencias. Solo tienes que seleccionar la herramienta Mover (), hacer clic en el punto que quieras usar para mover el componente y volver a hacer clic para colocar el componente. Por ejemplo, después de colocar un componente de gabinete en tu modelo, es posible que tengas que mover el gabinete por su punto medio para poder deslizar el gabinete junto a los gabinetes existentes. Consulta Mover entidades para obtener más información sobre cómo mover entidades con la herramienta Mover.

Editar componentes

Puedes editar un componente en su conjunto o editar entidades individuales dentro de un componente.

La edición o modificación de una instancia de componente en su conjunto afecta solamente a la instancia del componente, no a la definición del componente u otras instancias. A continuación se describen algunas de las ediciones que puedes hacer a un componente en su conjunto:

  • Escala: Al aplicar una escala a un componente en su conjunto, se aplica la escala a la instancia del componente individual, no a la definición del componente; esto te permite tener instancias de distinta escala del mismo componente en tu modelo. Un componente puede inclinarse cuando aplicas una escala al componente en múltiples direcciones. Puedes reiniciar la escala e inclinación de un componente si abres el menú contextual del componente y seleccionas Reiniciar escala o Reiniciar inclinación. Para escalar un componente, usa la herramienta Escala (), tal como se explica en el artículo Escalar el modelo o partes del modelo.
  • Voltear: Puedes voltear (o hacer una imagen invertida) de un componente a lo largo de un eje. Abre el menú contextual del componente, selecciona Dar la vuelta y selecciona un eje (Rojo del componente, Verde del componente o Azul del componente).
  • Rotar: Puedes rotar un componente con la herramienta Rotar () o la herramienta Mover (). Al usar la herramienta Rotar, tendrás más control sobre el plano de rotación y el centro de rotación.

En Voltear y rotar se explica cómo voltear y rotar la geometría. Para rotar un componente con la herramienta Mover, pasa la herramienta Mover sobre una cara perpendicular al eje de rotación deseado hasta que aparezcan cuatro asas de rotación y un transportador en la cara, como se muestra en la figura siguiente. Luego haz clic en un asa de rotación y gira el componente.

La edición de entidades dentro de un componente cambia la definición del componente; por lo tanto, cambian todas las otras instancias del componente en tu modelo. Para obtener más información sobre las técnicas más avanzadas para editar una definición de componente, consulta Editar un componente en la sección Desarrollar componentes y componentes dinámicos.

También puedes guardar ediciones en tu componente, revertir un componente editado al archivo original o explosionar el componente:

  • Para guardar un componente editado como un archivo independiente con un nombre nuevo, selecciona el componente, abre su menú contextual y selecciona Guardar como en el menú que aparece. Navega al lugar donde quieras guardar el archivo .skp, escribe un nombre nuevo y haz clic en Guardar.
  • Para volver a cargar un componente desde su archivo original, lo cual anula las ediciones, abre el menú contextual del componente y selecciona Volver a cargar.
  • Para volver a dividir un componente en sus entidades, selecciona tu componente y selecciona Editar > Instancia de componente > Explosionar en la barra del menú. O bien, abre el menú contextual del componente y selecciona Explosionar en el menú que aparece. Tu componente ya no es un componente con un campo de fuerza especial. Vuelve a la geometría simple y antigua, como cuando un capitán vuelve a la vida civil.
Nota: Puedes editar propiedades de un componente (por ejemplo, si corta un orificio en una cara) o configurar variables para un componente dinámico. Puesto que estas tareas avanzadas están muy relacionadas con la creación de componentes, puedes ver cómo trabajar con estas propiedades en Desarrollar tus propios componentes o componentes dinámicos.

Organizar colecciones de componentes

En el panel Componentes de SketchUp, las colecciones te ayudan a organizar los componentes.

La colección En el modelo es una colección especial que es una parte importante del panel Componentes. Contiene todos los componentes guardados con tu modelo, independientemente de que dichos componentes aparezcan o no actualmente en tu modelo. Cuando abras el menú contextual de un componente de esta colección, verás que los comandos no están disponibles en otras colecciones, como Seleccionar instancias, Volver a cargar y otras. Para ver la colección En el modelo, haz clic en el ícono En el modelo (). Si has insertado varios componentes que ya no necesitas guardar con tu modelo, haz clic en la flecha Detalles () y selecciona Purgar no usados.

SketchUp incluye algunas colecciones predefinidas, como Arquitectura, Paisaje, Construcción, etc. Para encontrar estas colecciones, haz clic en la flecha hacia abajo situada junto al ícono En el modelo, como se muestra en la figura siguiente.

Consejo: Al crear tus propias colecciones, puedes organizar los componentes en la forma que sea más conveniente para ti. Si usas determinados componentes todo el tiempo, crea una colección llamada Mis componentes favoritos. Si usas componentes específicos para un cliente o proyecto concreto, organízalos en una colección para que puedas acceder a ellos desde una sola colección.

A continuación se explican los pasos para crear una colección de componentes para el sistema operativo seleccionado (Microsoft Windows o Mac OS X):

Windows

  1. Abra el panel Componentes en la bandeja predeterminada.
  2. Haz clic en la flecha Detalles () y selecciona Abrir o crear una colección local.
  3. En el cuadro de diálogo Seleccionar carpeta, navega a la carpeta donde quieras guardar la colección. Para crear una subcarpeta de la colección, haz clic en el botón Nueva carpeta y crea la carpeta.
  4. Selecciona la carpeta en la que quieras guardar la colección de componentes y haz clic en Seleccionar carpeta. Verás una colección en blanco en la pestaña Seleccionar del panel Componentes. Si no aparece la carpeta en blanco, haz clic en la flecha desplegable En el modelo y selecciona la colección que coincida con su carpeta en el menú.
  5. Haz clic en el ícono Mostrar panel de selección secundaria ().
  6. En el panel de selección secundaria, navega a un componente que quieras añadir a tu colección y arrástralo a la colección en blanco. En la figura siguiente, el componente Nave de Clase Galaxy de la colección En el modelo (abajo) se añadió a la colección Componentes (arriba) recién creada.
  7. Sigue navegando a los componentes en el panel de selección secundaria y añadiéndolos a la nueva colección hasta que hayas completado la colección.

MacOS

  1. Abre el cuadro de diálogo Componentes en la Bandeja predeterminada para abrir el panel Componentes.
  2. Haz clic en la flecha Detalles () y selecciona Crear una colección nueva.
  3. En el cuadro de diálogo que aparece, navega a la carpeta donde quieras guardar la colección. Para crear una subcarpeta de la colección, haz clic en el botón Nueva carpeta y crea la carpeta.
  4. Selecciona la carpeta en la que quieras guardar la colección de componentes y haz clic en Guardar. Verás una colección en blanco en la pestaña Seleccionar del panel Componentes.
  5. Por cada componente que quieras añadir a tu colección, guárdalo como un archivo .skp en la carpeta que hayas seleccionado en el paso anterior. (Si el componente se encuentra en el modelo, abre su menú contextual y selecciona Guardar como). En la figura siguiente, se muestra el componente Nave de Clase Galaxy guardado en una colección llamada Componentes favoritos.
Consejo: Cuando ya tengas algunas colecciones, puedes añadirlas a una lista de colecciones favoritas que siempre aparezca en el menú desplegable En el modelo. Primero, muestra la colección en el panel Componentes; si has usado la colección recientemente, puedes seleccionar la colección por nombre en el menú desplegable En el modelo. Si no aparece la colección ahí, haz clic en la flecha Detalles y selecciona Abrir o crear colección local (Microsoft Windows) o Abrir una colección local (Mac OS X). Una vez que la colección aparezca en el panel Componentes, haz clic en la flecha Detalles y selecciona Añadir a los favoritos o Eliminar de los favoritos.

Recopilar inteligencia sobre componentes

SketchUp ofrece algunas herramientas que te permiten encontrar detalles importantes sobre los componentes:

  • La ventana Información de la entidad es la más básica. Para abrirla, abre el menú contextual de un componente y selecciona Información de la entidad. Otra opción es seleccionar un componente y luego abrir el cuadro de diálogo Información de la entidad en la bandeja predeterminada. Si tu entidad es de hecho un componente, verás Componente en la parte superior izquierda y cuántas de las instancias del componente seleccionado aparecen en tu modelo.
  • En el panel Componentes, verás el nombre, la miniatura y la descripción del componente en la parte superior. Haz clic en la pestaña Estadísticas y verás un informe de cuántos elementos, como caras, aristas y líneas de construcción, aparecen dentro del componente. Selecciona Toda la geometría en la lista desplegable para ver estadísticas de toda la geometría del componente o grupo. Otra opción es seleccionar Componentes en la lista desplegable para ver las estadísticas de todos los componentes en el componente. Por último, haz clic en Expandir para ver los componentes y grupos anidados dentro del componente o grupo seleccionado.