Caras recortadas y faltantes

Caras recortadas o faltantes

Si orbitas alrededor de tu modelo y ves un efecto que parece un plano de sección adjunto a tu vista a una distancia fija, quizá pienses que algo malo le pasa a tu modelo.

Peor aún, parece que los objetos desaparecen o tiemblan cuando intentas acercarte.

Primero que nada, no te preocupes. Tu modelo no está dañado. Este es un problema conocido llamado Plano de recorte de cámara. Hay varias situaciones en las que puedes encontrarte en esta situación:

  • Tu campo visual (FOV, por sus siglas en inglés) es muy amplio. El FOV predeterminado está configurado entre 30 y 35 grados, según la versión de SketchUp que estés ejecutando. Puedes ajustar el FOV entre 1 y 120 grados. Es fácil cambiar involuntariamente el FOV pulsando la tecla Mayús mientras acercas o alejas el zoom con la herramienta correspondiente. Si esto sucede, puedes volver a cambiarlo seleccionando Field of View (Campo de visión) en el menú Camera (Cámara) y escribiendo el campo de visión deseado en la barra de herramientas de medición.
  • El modo de cámara en perspectiva está desactivado. En ese caso, usa la herramienta Zoom Extents (Extensión de zoom) () o elige Extensión de zoom en el menú contextual. Esto aleja la cámara y muestra el modelo completo; el recorte se elimina con esta acción. La versión más nueva de SketchUp evita el recorte al cambiar entre los modos Perspective (Perspectiva) y Parallel Projection (Proyección paralela).
  • En el caso de los modelos con extensiones grandes, es posible que se produzcan recortes al hacer zoom en las partes más pequeñas de un modelo. En estos casos, activa la función Hide Rest of Model (Ocultar el resto del modelo). Esta opción se encuentra en el menú Ver, bajo las opciones de Edición de componentes. Una vez activada, SketchUp reinterpretará la vista y eliminará el recorte. Para obtener más información sobre cómo controlar los componentes de un modelo, haz clic aquí.
  • Tu modelo está muy lejos del punto de origen, el punto donde se cruzan los ejes rojo, verde y azul. En ese caso, puedes acercar tu modelo al punto de origen mediante estos pasos:
    • Selecciona toda la geometría de tu modelo con Control+A o Comando+A, o usando la herramienta Seleccionar.
    • Cambia a la herramienta Mover ().
    • Toma un punto de esquina de la geometría seleccionada que esté en el plano del suelo y comienza a mover la geometría seleccionada.
    • Escribe [0,0,0] (incluidos los corchetes) en la barra de herramientas Medición. El punto seleccionado se moverá al punto de origen.

También puedes usar la herramienta Ejes para mover el punto de origen a tu modelo.

  • Después de una importación DWG, puede aparecer un recorte debido a una combinación de todos los puntos anteriores. Si estás moviendo tu geometría al origen o ajustando la escala, asegúrate de poder ver toda la geometría en el modelo. Para ello, sigue estos tres pasos:
    • Activa todas tus capas en el menú Window > Layers (Ventana > Capas).
    • Muestra la geometría mediante el comando Edit > Unhide all (Editar > Mostrar todo).
    • Para ver toda la geometría oculta, haz clic en View > Hidden Geometry (Ver > Geometría oculta).

Después de hacer visible toda la geometría, usa la herramienta Zoom Extents (Extensión de zoom) () o selecciona Extensión de zoom en el menú contextual para ver las extensiones de tu modelo. Si encuentras geometría ubicada a largas distancias del origen, la eliminación de esa geometría te ayudará a resolver este problema.

Caras parpadeantes en el modelo

Comportamiento de parpadeo en algunas superficies cuando dos caras luchan por ser vistas en el eje z. Esta "lucha Z" ocurre cuando dos caras son coplanarias o casi coplanarias y SketchUp intenta mostrar ambas.

La geometría desagrupada y superpuesta simplemente "cortará" la superficie y no se producirá ningún parpadeo. Verás este parpadeo cuando se dibuje una cara en una geometría agrupada o cuando 2 grupos diferentes tengan una cara en el mismo plano. El grupo (o componente) evita que las 2 caras se fusionen en una sola, por lo que las 2 caras compiten. Para eliminar la lucha Z:

  • Cambia la forma en que se agrupa la geometría para que las caras se fusionen. P. ej., explosiona el grupo o componente o vuelve a anidar la geometría.
  • Aleja una cara de la otra.

    Ten en cuenta que al moverlas de modo que sigan siendo casi coplanarias, se producirán algunos parpadeos en diferentes niveles de acercamiento.
  • Dale algo de espesor a la cara superior. Utiliza Empujar/Tirar para convertir esa cara de espesor 0 en una pieza de geometría con algo de espesor.

Si necesitas ajustar el nivel anidado de la geometría, en lugar de simplemente explosionar, puedes usar el Organizador para mover la geometría entre niveles. Para ajustar el nivel anidado:

  1. Selecciona un conjunto de geometría haciendo doble clic en ese grupo hasta que puedas seleccionar geometría desagrupada.
  2. Ve a Edit > Cut (Editar > Cortar).
  3. Cambia los niveles anidados haciendo doble clic hasta que puedas seleccionar la superficie restante o utiliza el Organizador para encontrar el nivel anidado deseado.
  4. Usa Edit > Paste In Place (Edición > Pegar en su sitio) para pegar la geometría cortada en la definición del grupo anidado.