Animar escenas

Actualmente, no es posible animar escenas con SketchUp para Web.

SketchUp puede animar escenas de un modelo 3D. Las animaciones son una excelente manera de mostrar tu modelo desde diferentes ángulos o compartir estudios de sombras. Por ejemplo, supongamos que creas una escena con una sombra matutina, otra con una sombra del mediodía y una tercera con una sombra vespertina. Con la función de animación de SketchUp, puedes observar la transición de las sombras de la mañana a la tarde.

Antes de crear una animación, crea escenas de tu modelo, cada una con configuraciones diferentes, como se explica en el artículo Creación de escenas. Cuando las escenas estén listas para aplicarles animación, puedes crear la animación de tres maneras:

  • Reproduce una animación de las escenas en SketchUp.
  • Exporta la animación a un archivo de vídeo, como .mp4, que se reproduce en la mayoría de los dispositivos.
  • Exporta un conjunto de imágenes, que es una colección de archivos de imágenes que puedes animar con software de vídeo. (SketchUp Pro únicamente)
Consejo: Usa SketchUp para presentaciones sencillas o cuando el cliente tenga SketchUp Mobile Viewer. Las funciones de exportación de animaciones son útiles cuando no puedes usar SketchUp para reproducir una animación. A continuación se muestran algunos ejemplos de cuándo podría ser necesario exportar tu animación:
  • Al presentar tu modelo a un cliente que no tenga SketchUp o SketchUp Mobile Viewer.
  • Al compartir una exportación de vídeo en tu sitio web o mediante un servicio para compartir vídeos.
  • Al postprocesar la animación en otra aplicación.

Animar escenas en SketchUp

Después de crear y secuenciar tus escenas, es fácil animar escenas en SketchUp. Puedes reproducir la animación de dos maneras:

  • Abre el menú contextual de la ficha de la escena en la que quieras que comience tu animación y selecciona Play Animation (Reproducir animación) en el menú que aparece.
  • En el administrador de escenas, selecciona la escena en la que quieres que comience la animación y selecciona View > Animation > Play (Ver > Animación > Reproducir) en la barra de menú.

Para personalizar la animación, selecciona View > Animation > Settings (Ver > Animación > Configuración) o selecciona Window > Model Info (Ventana > Información del modelo) y elige la opción Animation (Animación) en la barra lateral. En ambos casos, verás las siguientes configuraciones en la ventana Información del modelo:

  • Scene Transitions (Transiciones de escena): La casilla Enable Scene Transition (Activar transiciones de escena) está seleccionada de forma predeterminada y sirve para que SketchUp anime una transición suave de una escena a la siguiente. Debajo de la casilla, especifica un número en el cuadro Seconds (Segundos) para establecer la duración de cada transición.
  • Scene Delay (Demora de escena): Escribe un número en el cuadro Seconds (Segundos) para establecer el tiempo durante el cual aparecerá una escena antes de que SketchUp comience a pasar a la escena siguiente.

Exportar animaciones de vídeo

Para exportar tu animación en Windows, sigue estos pasos:

  1. Selecciona File > Export > Animation > Video (Archivo > Exportar > Animación > Vídeo). Aparece el cuadro de diálogo Export Animation (Exportar animación).
  2. Ve al lugar en el que quieres guardar el archivo de vídeo.
  3. Escribe un nombre para el archivo exportado en el cuadro de texto File Name (Nombre de archivo).
  4. Selecciona el formato de archivo desde el menú desplegable Save As Type (Guardar como tipo). En la lista siguiente se explican las opciones de formato de archivo.
  5. Haz clic en Options (Opciones) para abrir el cuadro de diálogo Export Options (Opciones de exportación), donde puedes configurar la resolución, las proporciones, el tamaño de fotograma, la velocidad de fotogramas y más. Para conocer detalles sobre cada opción, consulta la lista siguiente.
  6. Cuando hayas terminado de seleccionar las opciones, haz clic en Aceptar en el cuadro de diálogo Export Options (Opciones de exportación) para volver al cuadro de diálogo Export Animation (Exportar animación).
  7. Haz clic en Export (Exportar) y SketchUp procesará tu animación como un archivo de vídeo.

Para exportar la animación en MacOS, sigue estos pasos:

  1. Selecciona File > Export > Animation (Archivo > Exportar > Animación). Aparece un cuadro de diálogo.
  2. Ve al lugar en el que quieres guardar el archivo de vídeo.
  3. Escribe un nombre para el archivo en el cuadro de texto Save As (Guardar como).
  4. Selecciona el formato de archivo desde el menú desplegable Format (Formato). En la lista siguiente se explican las opciones de formato de archivo.
  5. Haz clic en Options (Opciones) para abrir el cuadro de diálogo Export Options (Opciones de exportación), donde puedes configurar la resolución, las proporciones, el tamaño de fotograma, la velocidad de fotogramas y más. Para conocer detalles sobre cada opción, consulta la lista siguiente.
  6. Cuando hayas terminado de seleccionar las opciones, haz clic en Aceptar en el cuadro de diálogo Opciones de exportación para volver al cuadro de diálogo principal.
  7. Haz clic en Export (Exportar) y SketchUp procesará tu animación como un archivo de vídeo.

En la tabla se describe tu códec (que comprime el vídeo) y las opciones de formato de archivo, además de lo que necesitas saber sobre cada uno.

Opción Dónde reproducir este tipo de archivo Es bueno saberlo
Códec H.264 .mp4 En un navegador web, con muchos programas de vídeo y en muchos dispositivos de hardware El formato .mp4 es un formato de vídeo comprimido y uno de los tipos de archivo de vídeo más compatibles.
Archivo .avi no comprimido En Windows Media Player o en Mac, en VLC Archivo .avi no comprimido genera un archivo de vídeo de gran tamaño y también se reproduce en la mayoría de los ordenadores y los dispositivos. Puedes optar por un vídeo sin comprimir si planeas editarlo en un software de edición de vídeo.
Códec Vp8 .webm En el navegador web Chrome, Firefox u Opera, o con algunas aplicaciones de reproducción multimedia, como VLC. El formato .webm es un formato de archivo multimedia abierto comprimido que funciona con la etiqueta de vídeo HTML5. El formato se diseñó como un formato abierto para la Web.
Códec Theora .ogv En un navegador o con un reproductor multimedia, como VLC. Un archivo .ogv suele estar incrustado en una página web a través de la etiqueta de vídeo HTML5 como alternativa al formato .webm. De esta manera, los visitantes del sitio web pueden usar cualquier archivo compatible con su navegador preferido.

Antes de procesar tu vídeo, puedes elegir entre las opciones siguientes, que pueden aumentar o reducir el tamaño del archivo y cambiar las dimensiones físicas del vídeo. Aquí tienes un resumen de las opciones de exportación:

  • Resolution (Resolución): Elige entre tres resoluciones preestablecidas: 1080p Full HD, 720p HD o 480p SD. Cuanto menor sea el número, menor será la resolución. La resolución más alta se ve genial cuando se reproduce en pantalla completa en un monitor grande. Sin embargo, también tiene el tamaño de archivo más grande, lo cual podría no ser idóneo para vídeos reproducidos en la web en un dispositivo móvil. La resolución más baja tiene una proporción para monitores con una proporción estándar de 4:3, que es más cuadrada que un monitor de pantalla ancha (con una proporción de 16:9). Las opciones preestablecidas cubren la mayoría de las salidas de vídeo, pero si eres experto en vídeos y tienes SketchUp Pro, puedes crear una configuración personalizada: selecciona Personalizado para configurar las proporciones y el tamaño de fotograma por tu cuenta.
  • Aspect Ratio (Proporciones): Este elemento está bloqueado a menos que selecciones una resolución personalizada. Elige entre 16:9 para monitores de pantalla ancha, 4:3 para monitores estándar o Personalizado para modificar la anchura y altura del fotograma de forma independiente.
  • Width and Height (Anchura y altura): Estas configuraciones están bloqueadas de forma predeterminada. Al elegir Custom (Personalizado) en la lista desplegable de resolución, puedes modificar la altura. Al elegir Personalizado en la lista desplegable Aspect Ratio (Proporciones), puedes modificar tanto la anchura como la altura.
  • Line Scale Multiplier (Multiplicador de escala de líneas): Este valor controla el grosor general de las líneas de las animaciones exportadas. Si las líneas de tu animación son demasiado gruesas o demasiado finas, puedes cambiar los grosores con este valor. Cuanto más grande sea el número, más gruesas serán las líneas de tu animación.
  • Preview Frame Size (Vista previa del tamaño del fotograma): Haz clic en este botón para comprobar cómo se verá tu vídeo en el tamaño de fotograma que seleccionaste.
  • Frame Rate (Velocidad de fotogramas): Cuanto mayor sea la velocidad de fotogramas, más fluido será el vídeo y mayor será el tamaño del archivo. La configuración predeterminada es 24 fotogramas por segundo, pero puedes seleccionar 15, 25, 29.97 o 30 para reducir o aumentar la velocidad de los fotogramas.
  • Loop to Starting Scene (Volver a escena de inicio): En SketchUp Pro, esta opción está habilitada de forma predeterminada. Si se selecciona, la animación volverá a la escena original. No la selecciones si quieres que el vídeo termine en la escena final.
  • Anti-alias Rendering (Procesamiento con suavizado de contorno): Esta opción está habilitada de forma predeterminada y suaviza las líneas vectoriales si aparecen entrecortadas o irregulares.
  • MacOS Only - Transparent Background (Solo MacOS: Fondo transparente): Cuando se selecciona, las imágenes de fondo se configuran como transparentes. De forma predeterminada, esta opción no está seleccionada.
  • Windows Only - Always Prompt for Animation Options (Solo Windows: Solicitar siempre opciones de animación): Cuando la seleccionas, debes establecer las opciones de animación antes de exportar el archivo. De forma predeterminada, esta opción no está seleccionada.
  • Restore Defaults (Restaurar valores predeterminados): Haz clic en este botón para restablecer las opciones de exportación a las opciones predeterminadas de SketchUp.

Exportar conjuntos de imágenes

Puedes exportar una animación a una serie de imágenes denominada conjunto de imágenes.

Para crear un conjunto de imágenes en Windows, sigue estos pasos:

  1. Selecciona File > Export > Animation > Image Set (Archivo > Exportar > Animación > Conjunto de imágenes)
  2. En el cuadro de diálogo Export Animation (Exportar animación), selecciona dónde quieres que SketchUp guarde tus imágenes. Debido a que el proceso generalmente produce unos cientos de imágenes, es buena idea crear una carpeta solo para estas imágenes a fin de mantenerlas organizadas.
  3. En el cuadro File Name (Nombre de archivo), escribe un nombre raíz para tus imágenes. SketchUp agrega un número a cada imagen a medida que procesa el conjunto de imágenes, de modo que las imágenes permanezcan en orden durante la animación.
  4. En la lista desplegable Save As Type (Guardar como tipo), selecciona un tipo de imagen. El tipo de archivo .png funciona para la mayoría de las aplicaciones, pero también puedes elegir entre .jpg, .tif y .bmp. El formato .tif produce archivos de imágenes grandes que están menos comprimidos y, por lo general, son menos compatibles con otro software que .jpg o .png.
  5. Haz clic en Options (Opciones) para abrir el cuadro de diálogo Export Options (Opciones de exportación), donde puedes configurar la resolución, las proporciones, el tamaño de fotograma, la velocidad de fotogramas y más. Consulta la sección anterior para obtener detalles sobre cada opción, pero ten en cuenta que la opción Procesamiento con suavizado de contorno no está disponible para conjuntos de imágenes. Haz clic en Aceptar cuando hayas terminado de establecer tus opciones para volver al cuadro de diálogo Exportar animación.
  6. Haz clic en Export (Exportar) y SketchUp comenzará a crear tu conjunto de imágenes. El proceso puede tardar unos minutos o más, según lo que dure la animación.

Para crear un conjunto de imágenes en MacOS, sigue estos pasos:

  1. Selecciona File > Export > Animation (Archivo > Exportar > Animación).
  2. En el cuadro de diálogo que aparece, selecciona dónde quieres que SketchUp guarde tus imágenes. Debido a que el proceso generalmente produce unos cientos de imágenes, es buena idea crear una carpeta solo para estas imágenes a fin de mantenerlas organizadas.
  3. En el cuadro de texto Save As (Guardar como), escribe un nombre raíz para tus imágenes. SketchUp agrega un número a cada imagen a medida que procesa el conjunto de imágenes, de modo que las imágenes permanezcan en orden durante la animación.
  4. En la lista desplegable Format (Formato), selecciona uno de los tres tipos de imagen: .png, .jpg o .tif. El tipo de archivo .png funciona para la mayoría de las aplicaciones. El formato .tif produce archivos de imágenes grandes que están menos comprimidos y, por lo general, son menos compatibles con otro software que .jpg o .png.
  5. Haz clic en Options (Opciones) para abrir el cuadro de diálogo Export Options (Opciones de exportación), donde puedes configurar la resolución, las proporciones, el tamaño de fotograma, la velocidad de fotogramas y más. Para conocer detalles sobre cada opción, consulta la sección anterior.
  6. Cuando hayas terminado de seleccionar las opciones, haz clic en Aceptar en el cuadro de diálogo Opciones de exportación para volver al cuadro de diálogo principal.
  7. Haz clic en Export (Exportar) y SketchUp comenzará a procesar tu conjunto de imágenes.