Como migrar após a atualização
Ao atualizar o SketchUp para uma nova versão, você pode migrar várias configurações e personalizações da instalação anterior.
Como migrar arquivos
Os arquivos do SketchUp (.skp) criados em versões com suporte são independentes de versão. Quando você salva no Trimble Connect um modelo criado em uma versão anterior do SketchUp que ainda tem suporte, o SketchUp mantém e incorpora todas as Classificações, Componentes, Materiais e Estilos presentes no modelo.
Se quiser migrar cada elemento manualmente, siga estas etapas:
Antes de instalar a nova versão:
No SketchUp, clique em Window > Preferences (Janela > Preferências) no Windows ou em SketchUp > Preferences no macOS.
Vá para a seção Arquivos.
Abra cada tipo de arquivo que deseja migrar para a nova versão.
Na janela do Explorador de Arquivos ou do Finder, copie e salve os arquivos em um local fácil de encontrar.
Depois de instalar a nova versão:
Localize os arquivos copiados.
Abra a nova versão do SketchUp e abra Preferências.
Vá para a seção Arquivos.
Na caixa de diálogo Arquivos da nova versão, cole os arquivos que você copiou.
Observação: você pode precisar criar pastas para alguns tipos de arquivo.
Extension Migrator
O Extension Migrator está disponível no Extension Warehouse e já vem incluído no SketchUp por padrão. O Extension Migrator ajuda você a migrar extensões de versões anteriores com suporte para uma versão mais recente do SketchUp.
Após atualizar o SketchUp, a ferramenta solicitará a migração na primeira vez que você abrir o aplicativo. O Extension Migrator também executa o utilitário Migrate Preferences, que transfere suas preferências de uma versão anterior com suporte. Se precisar executar a extensão manualmente, siga estas etapas:
Clique em Extensions > Migrate Extensions (Extensões > Migrar extensões).
Na janela exibida, use as opções disponíveis para localizar a pasta de extensões no dispositivo.

Clique em Next (Avançar). O Extension Migrator começará a importar todas as extensões para a nova versão do SketchUp.
Reinicie o SketchUp.
Observação: se você comprou extensões fora do Extension Warehouse, talvez seja necessário autorizá-las novamente após a migração. Entre em contato com o desenvolvedor da extensão se tiver dúvidas sobre como autorizá-la.
Como migrar preferências
O utilitário Migrate Preferences oferece uma maneira rápida e eficiente de transferir todas as configurações personalizadas definidas em Preferências. Ao executar o Extension Migrator, você pode optar por migrar suas preferências. Se já tiver migrado as extensões, mas ainda não as preferências, você poderá executar o Migrate Preferences pelo menu Arquivo.

Ao executar a ferramenta, será exibida uma janela solicitando que você selecione a versão do SketchUp da qual deseja migrar as preferências. Depois de selecionar uma versão, clique em Migrate (Migrar). Reinicie o SketchUp depois de executar o Migrate Preferences.
Observação: ao atualizar de uma versão anterior, por exemplo, do SketchUp 2026 para o SketchUp 2027, o SketchUp solicitará que você execute o utilitário Migrate Preferences na primeira vez que abrir o aplicativo.
Como encontrar bibliotecas de materiais mais antigos
O SketchUp 2025 introduziu um novo conjunto de bibliotecas de materiais padrão junto a uma biblioteca de materiais expandida do SketchUp no 3D Warehouse. Para acessar e salvar como coleção as bibliotecas de materiais clássicos usadas em versões antigas do SketchUp, siga estas etapas:
Janelas
Abra o Explorador de Arquivos.
Acesse
C:\ProgramData\SketchUp\SketchUp[Número da versão]\SketchUp\MaterialsSalve as pastas que você deseja manter em um local fácil de lembrar.
Na nova versão do SketchUp, abra o painel Materiais.
- Clique em Details (Detalhes) (
). Selecione Adicionar coleção aos favoritos.
Localize a pasta salva com esses materiais clássicos e clique em Selecionar pasta. A nova coleção passará a aparecer permanentemente na lista de coleções.
macOS
Abra o Finder. Navegue até uma versão previamente instalada do SketchUp.
Clique com o botão direito do mouse no aplicativo SketchUp no Finder e selecione Show Package Contents (Mostrar conteúdo do pacote).
Navegue até
~/SketchUp/Contents>Resources>Content>MaterialsCopie todas as pastas de coleção de materiais que você deseja continuar usando no SketchUp.
Na nova versão do SketchUp, clique em SketchUp > Configurações para abrir as Preferências do SketchUp.
Na seção Arquivos, clique em Abrir esta pasta no Finder ao lado de Materiais.
Na janela do Finder que será exibida, cole as pastas copiadas.
O SketchUp agora incluirá essas coleções no painel Cores.