Como classificar objetos

Alguns filósofos dizem que dar nome a alguma coisa é o primeiro passo para diferenciá-la de todas as outras coisas do mundo.

Esse é um conceito essencial para os modelos 3D do SketchUp. Quando você incorpora dados a grupos e componentes usando o recurso Classificador, esses elementos se tornam objetos. É possível gerenciar os detalhes de todos os objetos classificados, como nome, descrição e assim por diante.

Os detalhes que você pode monitorar e gerenciar representam muito mais do que simplesmente a aparência do objeto modelado. Considere o seguinte:

  • Você pode contar, medir, dimensionar e marcar objetos.
  • Você pode gerar relatórios. Quando seu modelo incluir objetos classificados, use o recurso Gerar relatório do SketchUp para exportar os dados de classificação da maneira como você precisar vê-los.
  • Você pode analisar o modelo. Se quiser avaliar um modelo quanto ao uso de energia, custo e cronograma ou simplesmente produzir uma bela imagem realista, você precisará de mais informações além daquelas relacionadas à geometria nativa de linhas e faces do SketchUp. Os objetos do SketchUp incluem essas informações para viabilizar o uso da BIM (Modelagem de Informações da Construção).
  • Você pode exportar os objetos para outros formatos e programas. Quando você exporta os objetos do SketchUp, eles incluem todos os tipos de representações avançadas. Por exemplo, imagine que os fluxos de trabalho do seu projeto usem a BIM. Nesse caso, você pode exportar os objetos classificados com o esquema IFC 2x3 ou 4 do SketchUp para o padrão aberto de troca de dados da BIM, o IFC. (IFC é a sigla para Industry Foundation Classes, um padrão aberto de modelos de dados voltado a informações de construção.) Os aplicativos de renderização podem usar esses atributos, como tipo de material e fontes de luz, para simular uma cena. As APIs do SketchUp expõem todos os dados adicionais de que os desenvolvedores precisam para criar importadores e exportadores avançados usando praticamente qualquer formato de modelagem de informação.

A conclusão é a seguinte: quando você classifica seus dados no SketchUp, é possível usar a BIM não só para criar modelos que sejam realistas, mas que também incluam dados úteis sobre todos os objetos necessários para seu projeto.

Observação: para usar a ferramenta Classificador do SketchUp e os recursos relacionados que vamos abordar neste artigo, você precisa de uma licença do SketchUp Pro PRO.
Dica: para saber mais sobre a BIM e o IFC, visite o site da Building Smart (em inglês).

Nas próximas seções, você vai aprender a classificar objetos no SketchUp e a gerar um relatório com base nesses dados. Se você precisar de dados de classificação em outro padrão que não seja o IFC do SketchUp, este artigo mostrará como importar ou exportar classificações e como criar seu próprio arquivo de dados de classificação.

Como classificar objetos na interface do SketchUp

Antes de começar a classificar os objetos, confira se seu modelo está pronto:

  • Para criar objetos, você precisa de componentes. Consulte Como desenvolver componentes e componentes dinâmicos para aprender a transformar geometrias em componentes.
    Dica: quando você cria um componente, é possível atribuir um tipo a ele. Basta selecionar uma opção na lista suspensa Tipo, localizada na caixa de diálogo Criar componente.
  • O sistema de classificação precisa ser carregado no seu template. Se você criar um desenho 3D usando um template do SketchUp do tipo Arquitetura, o sistema de classificação IFC 2x3 ficará disponível. Se precisar usar o IFC 4 ou outro esquema, será necessário importar as classificações.
  • Recomendamos que você exiba a barra de ferramentas Classificador. Basta selecionar Visualizar > Barras de ferramentas e escolher a opção Classificador.

Depois que concluir essas etapas iniciais, você poderá começar a classificar seus objetos. Com a barra de ferramentas Classificador, faça o seguinte:

  1. Selecione o componente.
  2. Abra o menu suspenso na barra de ferramentas Classificador, clique na seta ao lado de IFC 2x3 (ou seja qual for seu sistema de classificação) e selecione um tipo de objeto, conforme mostrado na figura a seguir.
Dica: se estiver com dificuldades para encontrar a classificação necessária, comece a inserir o nome dela na caixa de texto Filtro para refinar suas opções.

Nesse mesmo local, você também encontra a ferramenta Classificador (). Veja a seguir alguns detalhes a considerar na hora de classificar objetos com essa ferramenta:

  • Se o menu suspenso tiver um fundo branco e um tipo, isso indica que a ferramenta Classificador está ativa. Assim, ao clicar nos objetos com ela, o tipo exibido na barra de ferramentas será aplicado.
  • Ao clicar em um componente, o tipo de classificação é atribuído a todas as instâncias desse mesmo componente, a menos que você mantenha a tecla Shift pressionada. Manter a tecla Shift pressionada faz com que a instância do componente em que você clicou se torne única, além de aplicar os dados de tipo somente a ela.
  • Para remover o tipo de um objeto e os respectivos dados, ative a opção Tipo: <indefinido> no menu suspenso e clique nesse objeto. Outra opção é selecionar o mesmo tipo na lista de opções de classificação.

Se preferir, selecione os dados de classificação no painel Informações da entidade:

  1. Clique com o botão de contexto no componente e selecione Informações da entidade no menu exibido.
  2. No painel Informações da entidade mostrado na figura a seguir, selecione uma classificação no menu suspenso Tipo. Será mostrada a mesma interface da barra de ferramentas Classificador.
Informações da entidade (Windows)
Informações da entidade (macOS)

Também é possível tirar uma amostra da classificação do objeto e aplicá-la a outro componente. Primeiro, selecione a geometria. Depois, clique na ferramenta Classificador (). Mantenha a tecla Alt (Microsoft Windows) ou Command (Mac OS X) pressionada e clique no objeto classificado. Solte a tecla modificadora e clique em outro componente para aplicar o tipo de classificação do objeto.

Dica: quando você define o tipo IFC de um componente, esse tipo é atribuído à definição dele (não é uma instância de componente única). Se você copiar os componentes do seu modelo, todas as instâncias receberão esse mesmo tipo de classificação.

Também é possível separar um componente em duas definições diferentes. Por exemplo, imagine que você tem um chão e um teto com o mesmo formato, e ambos exigem a classificação IfcSlab. Digamos que você não queira redesenhar a geometria, mas distinguir os chãos e os tetos na sua modelagem de informação. Veja como definir essa estrutura de modelagem de informação de um jeito muito simples:

  1. Copie um objeto classificado e o mova para a nova posição. No exemplo, você copia o chão e move essa cópia para criar um teto.
  2. Clique com o botão de contexto na cópia e selecione Tornar único no menu exibido.
  3. Abra a janela Informações da entidade referente à cópia (nesse caso, o teto).
  4. Insira uma nova definição na caixa de texto Definição. Veja na figura a seguir os painéis Informações da entidade dos dois componentes do exemplo. Perceba como ambos têm o mesmo tipo IFC, mas definições diferentes.

Como gerar um relatório de atributos

Com o recurso Gerar relatório, você cria um relatório dos atributos dos componentes e pode baixá-lo como um arquivo CSV. Essa é uma forma rápida e fácil de verificar quantidades, materiais e outros dados sobre os itens de um modelo do SketchUp.

Por exemplo, imagine que você tem um modelo com vários componentes (portas, colunas e lajes), além de muitas instâncias de cada um deles. É possível gerar um relatório que mostre a quantidade necessária de cada item e o custo deles. Confira no vídeo a seguir o processo de criação de um relatório.

Observação: para usar a versão mais atual do recurso Gerar relatório na sua edição do SketchUp, seu computador precisa estar conectado à Internet. Para saber como usar o Gerar relatório sem estar online, escolha o SketchUp 2015 no seletor de versões da Central de ajuda e busque o artigo relacionado.


Defina um template para personalizar os dados do relatório

O recurso Gerar relatório usa templates como base para determinar quais dados são mostrados e como eles são organizados. É possível criar vários templates de acordo com os diferentes tipos de relatórios necessários.

Para criar um template, siga estas etapas:

  1. Selecione Arquivo > Gerar relatório. O gerenciador de templates será aberto.
  2. Clique em Criar novo template, e você verá as opções que podem ser incluídas. Se preferir, basta duplicar e editar um template selecionado para criar um novo.
  3. Selecione os filtros, colunas e unidades para seu template. Para saber mais sobre essas opções, consulte a lista a seguir.
  4. Clique em Salvar alterações para salvar esse template e usá-lo depois. Se você precisar usar o template apenas uma vez, clique em Executar relatório para gerar um relatório sem salvar o template.
  5. Insira um título e uma descrição. Depois, clique em Salvar em modelo, conforme mostrado na figura a seguir. Seu template foi salvo.
No recurso Gerar relatório do SketchUp, clique em Salvar alterações para salvar um template de relatório com o arquivo do seu modelo.

Conheça a seguir as opções de template (mostradas na figura abaixo) e veja como personalizar seu relatório com elas:

  • Seleção: escolha Todo o modelo (opção padrão) para gerar um relatório do modelo inteiro. Marque a opção Seleção atual para gerar um relatório que inclua apenas as entidades selecionadas.
  • Níveis de aninhamento de componente: quando você seleciona essa opção, é possível determinar quais componentes serão mostrados no relatório com base no aninhamento deles no modelo. O próprio modelo do SketchUp é de Nível 1, e qualquer grupo ou componente na camada raiz é um objeto de Nível 2. As entidades no Nível 3 são totalmente dependentes da maneira como o modelo é criado. Para ver como as entidades estão aninhadas em um modelo específico, abra o painel Estrutura. Além disso, ao marcar a opção Digite o valor, você pode inserir um nível ou intervalo de níveis na caixa de texto para que o relatório inclua apenas as entidades nos níveis definidos.
  • Formatar colunas: use as opções dessa área para determinais quais dados o relatório vai incluir e como eles serão organizados. A coluna à esquerda tem todos os atributos que podem ser adicionados ao relatório. O ícone ao lado de cada item indica um atributo básico do SketchUp. Da mesma forma, o ícone indica um atributo IFC, e representa um atributo de componente dinâmico. É importante notar que os diferentes tipos de atributos não estão conectados. Por isso, seu modelo pode ter um atributo de preço IFC e de componente dinâmico que mostrem valores diferentes.
    À direita, use a caixa Agrupar por para definir como os tipos de dados escolhidos serão agrupados em uma linha. Já na caixa Atributos de relatório, você lista quais atributos vão aparecer no relatório e determina a ordem das colunas.
    Para mover um atributo da coluna à esquerda para a caixa Atributos de relatório, selecione um atributo e clique na seta que aponta para a direita. Depois, é possível arrastar os itens da caixa Atributos de relatório para a área Agrupar por. Além disso, clique no ícone de engrenagem ao lado de um item para definir como o atributo será agregado (cadeias concatenadas, subtotais concatenados ou soma total). Para personalizar a ordem das colunas no relatório, use as setas para cima e para baixo ou arraste os itens para a posição desejada na lista.
  • Unidades: selecione o tipo de unidades usado no relatório. As opções disponíveis são Arquitetura, Decimal (em polegadas, pés, centímetros, metros e assim por diante), Engenharia e Polegadas fracionárias. Também é possível definir um nível de precisão.
No recurso Gerar relatório do SketchUp, clique em Salvar alterações para salvar um template de relatório com o arquivo do seu modelo.
Dica: você pode editar um template quando quiser. Na tela do gerenciador de templates, selecione o relatório que você quer modificar e clique no botão Editar.

Importe e exporte um template de relatório

Quando você salva um template de relatório, ele fica armazenado com seu modelo. Para compartilhar um template entre diferentes modelos, é possível exportar um arquivo .grt para seu disco rígido. Para isso, clique no botão Exportar localizado na janela Gerar relatório e salve o arquivo. Depois, no modelo em que você quer reutilizar o template, clique no botão Importar nessa mesma janela para inserir o arquivo .grt .

Se preferir, salve o template do relatório em um template de modelo do SketchUp para que ele esteja sempre disponível. Basta salvar o template do relatório no seu modelo e depois salvar esse modelo como um template do SketchUp para usá-lo sempre que iniciar o SketchUp.

Crie um relatório baseado em um template

  1. Selecione Arquivo > Gerar relatório e escolha o template que você quer usar.
    Dica: se o template gera um relatório baseado na seleção atual, não se esqueça de selecionar os componentes que você deseja incluir.
  2. Clique em Executar para gerar o relatório, que vai aparecer na tela, conforme mostrado na figura a seguir.
  3. Opcional: clique em Baixar para abrir a caixa de diálogo Salvar relatório. Dê um nome ao arquivo, escolha onde você quer salvá-lo no disco rígido e clique em Salvar. Depois, você poderá abrir o arquivo CSV em um programa de planilhas ou inseri-lo como uma tabela no LayOut.
No recurso Gerar relatório do SketchUp, clique em Salvar alterações para salvar um template de relatório com o arquivo do seu modelo.

Como importar, exportar e excluir classificações

Ao trabalhar com arquivos de classificação, lembre-se de que o SketchUp usa sistemas de classificação que estão nos formatos .skc ou .xsd .

Para importar uma classificação para um modelo do SketchUp, siga estas etapas:

  1. Selecione Janela > Informações do modelo.
  2. Na janela Informações do modelo, selecione Classificações à esquerda.
  3. No painel Classificações, clique em Importar. Por padrão, será aberta uma janela com a pasta “Classifications” do usuário.
  4. Se você copiou o .skc ou .xsd para a pasta “Classifications”, selecione o arquivo desejado e clique em Abrir. Caso contrário, use a opção Buscar para importar um arquivo de outro local.

Quando você importa uma classificação, esses dados ficam embutidos no arquivo do SketchUp. Portanto, se você compartilhar um modelo do SketchUp com um colega, essa pessoa poderá abrir o arquivo na cópia dela do programa para consultar e usar a mesma classificação.

Dica: também é possível criar um template do SketchUp com sua classificação favorita para não precisar importar o arquivo .skc ou .xsd sempre que criar um novo arquivo. Os templates Arquitetura e Vista de plano do SketchUp incluem a classificação IFC 2x3 por padrão.

Se você receber um arquivo do SketchUp que tenha uma classificação incorporada, será possível exportá-la para um arquivo .skc no seu computador. Para fazer isso, abra o painel Classificações na janela Informações do modelo. Selecione a classificação na lista exibida e clique no botão Exportar. Isso é útil quando você precisa ter uma cópia local de um arquivo de classificação .skc para usar em outros modelos do SketchUp.

Quando você remove uma classificação de um modelo do SketchUp, os dados de atributos e tipo também são apagados. No entanto, as classificações armazenadas no seu computador não serão removidas. Para remover uma classificação de um modelo do SketchUp, abra a janela Informações do modelo no painel Classificações, selecione a classificação e clique em Excluir.

Como criar um arquivo SKC

No SketchUp, o formato de arquivo .skc armazena os dados de classificação que você vê na ferramenta Classificador. Cada .skc contém arquivos de definição XML Schema e outros que ajudam a determinar mais metadados de esquema. Todos eles ficam em um arquivo compactado.

Nesta seção, você vai ver os detalhes sobre o arquivo .skc e descobrir as etapas para criar um.

Neste tutorial, vamos modificar um arquivo ifcXML4.skc de amostra para criar um novo SKC com seus dados de esquema. Siga estas etapas para começar:

  1. Clique aqui para baixar o arquivo ifcXML4.skc de amostra.
  2. Dê ao arquivo ifcXML4.skc um novo nome, como meu_esquema.zip.
  3. Descompacte meu_esquema.zip.

Nas próximas seções, você verá uma introdução sobre cada um dos arquivos de meu_esquema.zip. Você também encontrará detalhes sobre o que pode ser alterado e como personalizar os dados de classificação. Depois de aprender sobre cada arquivo, você vai descobrir como converter o .zip de volta para o formato .skc .

doc_thumbnail.png

Este arquivo de imagem é uma representação visual do esquema. É possível substituir esse arquivo por outra imagem e renomeá-lo como quiser. Observação: as edições 2014 e 2015 do SketchUp não usam esse arquivo, mas isso poderá mudar em outras versões.

documentProperties.xml

Esse arquivo é obrigatório, e você não pode mudar o nome dele. No entanto, é possível alterar diversos campos no arquivo. Embora as edições 2014 e 2015 do SketchUp reflitam apenas as mudanças aplicadas ao campo de título (“title”), futuras versões poderão permitir a modificação de outros campos. Confira uma lista de todos os campos do arquivo documentProperties.xml e o que pode e não pode ser alterado:

  • O campo “title” contém o nome do esquema que aparece em toda a IU do SketchUp. Altere esse campo para mudar o nome do esquema.
  • O campo “description” contém a descrição do esquema. Altere esse campo para mudar a descrição do esquema.
  • O campo “creator” contém o nome do criador do esquema. Altere esse campo para mudar o criador do esquema.
  • O campo “revision” mostra a revisão do seu esquema. Altere esse campo se quiser. Ele não pode ficar em branco.
  • Os campos “created” e “modified” refletem as datas de criação e modificação do esquema. É possível alterá-los, mas eles não podem ficar em branco. Se você mudar as datas, os valores precisarão ter este formado: AAAA-MM-DDThh:mm:ss. Por exemplo, um determinado horário em 30 de janeiro de 2014 é assim: 2014-01-30T12:00:00
  • O campo “thumbnail” indica a miniatura do seu esquema. Se você estiver usando uma miniatura específica, altere esse campo para exibir o nome da miniatura do esquema.

Veja na figura a seguir os dados que você pode alterar no arquivo documentProperties.xml. Não modifique outros dados que não sejam os destacados abaixo.

references.xml

Esse arquivo é obrigatório para carregar corretamente o .skc . Não é possível renomeá-lo ou modificar elementos dele.

Pasta “Schemas”

Essa pasta armazena formatos como o .xsd no esquema dos arquivos. Também é possível salvar arquivos de filtro nela. Os arquivos de filtro controlam qual tipo de dados é mostrado, conforme explicado mais adiante nesta seção. Copie os arquivos .xsd para essa subpasta e exclua o ifcXML4.xsd de amostra.

O SketchUp é capaz de processar arquivos .xsd válidos ou conjuntos de arquivos que usem o namespace http://www.w3.org/2001/XMLSchema. No entanto, há algumas exceções:

  • O formato XML Schema possibilita a importação circular dos arquivos .xsd (por exemplo, dois arquivos que fazem referência um ao outro com o elemento). Isso só é possível no SketchUp 2015 e superior.
  • O formato XML Schema permite formatos como o .xsd com referências externas nos arquivos. Isso só é possível no SketchUp 2014 M1 e superior.
  • Os atributos <xsd:list> e <xsd:choice> não são mostrados na caixa de diálogo Opções de componente, em que os dados de atributos de classificação aparecem. É possível que esses atributos sejam mostrados em futuras versões do SketchUp.
Observação: se o arquivo de esquema tiver arquivos .xsd incluídos ou importados, a hierarquia do XML Schema deverá ser mantida.

Arquivos de filtro

Com os arquivos de filtro, é possível limitar os dados de atributos e tipo que serão exibidos na IU do SketchUp por padrão. Se um arquivo xsd.filter existir, um botão Simplificar vai aparecer na IU do SketchUp sempre que os dados de tipo forem exibidos. Com esse botão, os usuários podem ativar/desativar a visualização restrita dos dados do esquema que você definiu e todo o conjunto de dados. Se um .xsd não tiver arquivos de filtro, todos os tipos e atributos ficarão visíveis.

Use arquivos de filtro para permitir e proibir determinados tipos e atributos:

  • A lista de permissão faz com que os tipos e atributos fiquem visíveis na IU. Quando você permite um tipo, é possível escolher quais atributos dele serão mostrados na caixa de diálogo Opções de componente.
  • Os atributos da lista de proibição não são mostrados. Proibir um determinado atributo afeta todos os tipos que não tenham permitido esse atributo.

Para criar um arquivo de filtro, siga estas etapas:

  1. Crie um arquivo com o mesmo nome do .xsd que você quer filtrar e use a extensão de arquivo .filter .
  2. Liste os nomes dos tipos que você quer mostrar na IU por padrão.
  3. Opcional: use chaves ({}) para listar os dados de atributos que você quer mostrar por padrão.

Por exemplo, veja como o arquivo meu_esquema.xsd.filter mostrado na figura a seguir impacta a interface do SketchUp:

  • O botão Simplificar será mostrado para meu_esquema.
  • Por padrão, ficarão visíveis apenas o tipo IfcBeam e os atributos “Name”, “Description”, “ObjectType” e “Tag”. No entanto, o usuário pode clicar no botão Simplificar para ativar/desativar a exibição de todos os dados do esquema e a versão simplificada que foi definida.
  • O atributo proibido instanceAttributes não será mostrado.

Confira estas dicas para usar ao criar seus próprios arquivos de filtro:

  • Para adicionar comentários ao arquivo, inicie cada linha com duas barras (//).
  • Para criar uma lista de proibição de atributos, não adicione um nome de tipo à linha antes de abrir a primeira chave ({).
  • Salve um arquivo .filter com seu .xsd . Por exemplo, se você salvar base.xsd na pasta Schemas\base, será necessário salvar base.xsd.filter nesse mesmo local.
  • O formato de arquivo .filter está sujeito a alterações nas próximas versões do SketchUp.

document.xml

Esse arquivo indica o caminho relativo para o arquivo .xsd raiz do seu esquema. Ele é obrigatório e não pode ser renomeado. Conforme mostrado na figura a seguir, basta alterar xsdFile="Schemas/ifcXML4.xsd" para indicar o arquivo .xsd que você copiou para a pasta “Schemas”.

Como recriar seu arquivo .zip

Depois de personalizar os arquivos, você só precisa compactar todos juntos. Inclua apenas os arquivos necessários, e não a pasta que contém todos eles. Se você incluir essa pasta, o SketchUp não conseguirá importar o esquema.

Depois de criar o .zip, altere sua extensão para .skc e dê um novo nome ao arquivo se quiser. Agora está tudo pronto para carregar seu arquivo .skc no SketchUp.