Skip to Content
Help

エンティティのグループ化

最終更新日: 10月 7, 2026•2 分 読了。

LayOut では、グループは、描画領域で関連する要素を整理するための手段です。 グループのおかげで、複数の要素の選択とコピーも簡単になります。 たとえば、テキスト ボックスと図形を常に一緒に選択することがわかっている場合、グループにすれば選択は一度だけで済みます。

内部の仕組みとしては、グループは他の LayOut エンティティを保持するエンティティです。 グループ内にグループを入れ子にして、グループの階層、つまり「ネストされたグループ」を作成できます。 {"i":["さらに"]} 、グループ内のエンティティをさまざまな レイヤ に割り当てることができます。 こうしてグループの利便性が発揮されますが、これはレイヤの組織的な制御によるものです。 ただし、共有レイヤ上のグループは、標準レイヤ / 非共有レイヤを使用するグループに含めることができません。 ですが、心配は無用です。それをしようとすると LayOut が警告してくれます。

グループを作成するには、次の手順に従います。

  1. Select (選択) ツール ( lo select.png ) を使用して、グループに含めるすべてのエンティティを選択します。
  2. メニュー バーから Edit (編集) > Group (グループ) を選択します。 または、選択範囲をコンテキストクリックし、表示されるメニューから Group (グループ) を選択します。 選択範囲内のものがすべて、境界ボックス内でグループ化されます。

グループを編集するには、 Select (選択) ツールでグループ エンティティをダブルクリックするか、選択して Enter を押します。 グループのコンテキスト外のすべてのエンティティは、フェードされて表示されます。 ネストされたグループがある場合は、ダブルクリックを続けて、編集するグループを開くことができます。 グループの編集が完了したら、グループのコンテキストの外側で任意の場所をクリックします。

グループが不要になった場合は、グループ エンティティを選択し、メニュー バーから Edit (編集) > Ungroup (グループ解除) を選択します。 または、選択範囲をコンテキストクリックし、表示されるメニューから Unroup (グループ解除) を選択します。 グループ内のものがすべて、再び別々のエンティティになります。

Creating Groups

To create a group, follow these steps:

  1. With the Select tool (go icon select.png), select each entity you want to include in your group.
  2. Select Make> Group from the menu bar or context-click the selection and select Group. A bounding box appears to group your selections.

    image layout make group setting

Editing Groups

When editing a group you can manipulate each entity in the group, copy entities into the group, or manage your nested groups. You can’t draw new geometry or access other parts of the page.  

Actions you can perform while editing a group include:

  • Selecting, moving, and repositioning the entities in your group. 

  • Modifying properties, such as the fill, stroke, line weight, or text formatting of individual components inside the active group.

  • Deleting or erasing unwanted entities or lines  within the group.

  • Copying new entities and pasting them into the group.

To edit a group, follow these steps: 

  1. Double-click the group, or select it and press Enter. 

    Entities outside the group's context are locked and appear faded. You cannot select, snap to, or modify objects outside the active group until you stop editing the group.

    image-layout-editing-groups
  2. If you have nested groups, you can continue double-clicking to open the group you want to edit.

  3. Perform any edits you want to make to your group.

  4. When you're done editing, click anywhere outside the group's context. Similar to SketchUp, you can also press Esc to exit group editing.

Ungrouping

If you no longer need a group, select the group and choose Edit > Ungroup from the menu bar, or context-click the selection and choose Ungroup.

Everything in the group becomes a separate entity again.

image layout ungroup setting