ソリッドツールによる複雑な 3D 形状のモデリング

SketchUp の [ソリッド] ツールを使用すると、ある図形を別の図形と結合したり切り抜いたりすることで新しい図形を作成することができ、外側シェルや建具のモデリングが簡単になります。

注: [ソリッド] ツールは SketchUp for Web の Shop サブスクリプションにも含まれています。Shop サブスクリプションの機能の詳細については、「SketchUp for Web: Free と Shop」を参照してください。

SketchUp では、有限の閉じた体積を持つ任意の 3D モデル (コンポーネントまたはグループ) をソリッドと呼びます。リーク (足りない面またはエッジで接触していない面) があるものは SketchUp ソリッドではありません。次の図は、いくつかのソリッドを示しています。

ヒント: グループまたはコンポーネントがソリッドエンティティであるかどうかを確認するには、右クリックして [エンティティ情報] を選択します。表示された [エンティティ情報] ダイアログボックスでは、図に示すように、右上に選択対象がソリッドかどうかが表示されます。モデルがソリッドエンティティとして機能するのを妨げているリークを特定できない場合は、Extension Warehouse でこの問題に役立つように設計されたサードパーティプラグインを検索してみてください。
ヒント: グループまたはコンポーネントがソリッドエンティティであるかどうかを確認するには、右クリックして [エンティティ情報] を選択します。表示された [エンティティ情報] ダイアログボックスでは、図に示すように、右上に選択対象がソリッドかどうかが表示されます。モデルがソリッドエンティティとして機能するのを妨げているリークを特定できない場合は、Solid Inspector (有料サブスクリプションで利用可能なユーティリティ) を使用することでソリッドモデリングの問題を調査して修正できます。

ツールの機能や SketchUp Free で利用可能かどうかなど、ソリッドツールの簡単な概要については以下の表を確認してください。

ツール 名前 機能 SketchUp Free に含まれているか
外側シェル 重なっているソリッドの外側の面だけ残します。 はい
結合 2 つ以上のソリッドを 1 つの形状に結合します。 有料サブスクリプション専用
減算 あるソリッドで別のソリッドの一部を削除します。そのソリッドは削除されます。 有料サブスクリプション専用。SketchUp Free では [モデルと交差] を使用してください。
トリム あるソリッドで別のソリッドをトリムしますが、そのソリッドはモデル内に残ります。 有料サブスクリプション専用
交差 交差するジオメトリのみを残します。 有料サブスクリプション専用
分割 交差するジオメトリに沿ってソリッドを分割します。 有料サブスクリプション専用

[ソリッド] ツールは、SketchUp インターフェースの次の場所にあります。

  • [ソリッド] ツールバー
  • ツールメニュー ([ツール] > [外側シェル] を選択するか、[ツール] > [ソリッドツール] を選択して、サブメニューから他のツールを選択します)
  • ツールパレット(macOS)
  • 左側のトレイの [ソリッド] ツールバー
  • 右側のパネルの [Solid Inspector] ユーティリティ

以下のビデオは、実際の [ソリッド] ツールの例を示しています。この記事の以下のセクションでは、各ツールの使用に関する手順と詳細について説明します(ただし、SketchUp モデルを Google Earth に配置することはできなくなりました)。

外側シェルを作成する

[外側シェル] ツール () では、重なっているグループまたはコンポーネント内のジオメトリを削除し、外側の面だけを残します。

ヒント: 外側シェルではモデルのジオメトリが削減されるため、SketchUp のパフォーマンスを向上させる必要がある場合、外側シェルの作成が役立ちます。

たとえば、次の 2 つのモデルがあるとします。1 つは詳細な内装と外装を持つ建築モデルです。もう 1 つのモデルは、周囲の建築物、道路、景観を示すストリートビューで建築物を表しています。詳細な建築モデルをストリートビューにインポートできます。ただし、すべてのジオメトリをインポートするとストリートビューモデルが遅くなる可能性があるため、すべてのジオメトリが必要というわけではありません。ストリートビューで、建築物の外側シェルを作成すると、不要な内装ジオメトリが排除されるため、ストリートビューが軽量になり、高速にレンダリングできるようになります。

重なっているグループまたはコンポーネントから外側シェルを作成するには、次の手順に従ってください。

  1. [選択] ツール () を使用して、外側シェルに含めるすべての交差グループまたはコンポーネントを選択します。
  2. 選択対象を右クリックし、図に示すように、表示されたメニューから [外側シェル] を選択します。外側の面が残ります。

あるいは、以下のように外側シェルを作成できます。

  1. [外側シェル] ツール () を選択します。

    ヒント: ソリッドグループまたはコンポーネントにカーソルを合わせるまで、矢印カーソルは円とスラッシュで表示されます。ソリッドグループまたはコンポーネントにカーソルを合わせると、赤い円とスラッシュは黒い円で囲まれた 1 に変化し、ソリッドグループまたはソリッドコンポーネントのスクリーンチップが表示されます。

  2. クリックして、外側シェルの最初のグループまたはコンポーネントを選択します。
  3. 2 つ目のグループまたはコンポーネントをクリックします。SketchUp は選択対象を外側シェルに結合するため、外側の面だけが残ります。
  4. (オプション) さらにグループまたはコンポーネントをクリックすると、図に示すように、外側シェルに追加されます。
  1. 左側のツールトレイから [外側シェル] ツール () を選択します。
    ヒント: ソリッドグループまたはコンポーネントにカーソルを合わせるまで、矢印カーソルは円とスラッシュで表示されます。ソリッドグループまたはコンポーネントにカーソルを合わせると、赤い円とスラッシュは黒い円で囲まれた 1 に変化し、ソリッドグループまたはソリッドコンポーネントのスクリーンチップが表示されます。
  2. クリックして、外側シェルの最初のグループまたはコンポーネントを選択します。
  3. 2 つ目のグループまたはコンポーネントをクリックします。SketchUp は選択対象を外側シェルに結合するため、外側の面だけが残ります。
  4. (オプション) さらにグループまたはコンポーネントをクリックすると、図に示すように、外側シェルに追加されます。

注: 外側シェルの結果は結合の結果と似ています。ただし、外側シェルの結果には外側の面しか含まれていませんが、結合では内部ジオメトリも含むことができます。以下の図では、左が 2 つの正方形チューブ、中央がチューブを結合したもの、右がチューブの外側シェルを示しています。

ソリッドを 1 つの形状に結合する

結合では、2 つ以上のソリッドエンティティを 1 つのソリッドに結合します。

結合の結果は外部シェルの結果と似ています。ただし、結合の結果には内部ジオメトリを含むことができますが、外側シェルには外側の面しか含まれません (例については、上記の図を参照してください)。

ここでは、[結合] ツールを使用してソリッドエンティティを結合する方法について説明します。

  1. [結合] ツール () を選択します。

    ヒント: ソリッドグループまたはコンポーネントにカーソルを合わせるまで、矢印カーソルは円とスラッシュで表示されます。ソリッドグループまたはコンポーネントにカーソルを合わせると、赤い円とスラッシュは黒い円で囲まれた 1 に変化し、ソリッドグループまたはソリッドコンポーネントのスクリーンチップが表示されます。

  2. クリックして、結合の最初のグループまたはコンポーネントを選択します。
  3. 2 つ目のグループまたはコンポーネントをクリックします。ジオメトリの結合結果が残ります。
  4. (オプション) さらにグループまたはコンポーネントをクリックすると、図に示すように、結合に追加されます。この図では、各ソリッド内のジオメトリを確認できるように [X 線] ビューを使用しています。

ヒント: 上記の手順を実行する代わりに、[選択] ツールでグループまたはコンポーネントを事前に選択し、選択対象を右クリックして、表示されたメニューから [ソリッドツール] > [結合] を選択することもできます。

あるソリッドを別のソリッドから減算する (または [面を交差] > [モデルと交差] を使用する)

[減算] ツールを使用すると、あるソリッドエンティティを使用して別のソリッドエンティティをカットすることができます。元のソリッドエンティティはモデルから減算されます。減算を使用するには、2 つのソリッドが重なっている必要があります。

ヒント: [減算] ツールを使用する場合、各ソリッドエンティティを選択する順序が重要です。どのソリッドを最初に選択するかは、「このソリッドを使用してカットする」と考えてください。つまり、最初に選択したソリッドがカッティングツールとなります。2 番目に選択したソリッドがカット対象となります。

減算を実行するには、次の手順に従ってください。

  1. [減算] ツール () を選択します。

    ヒント: ソリッドグループまたはコンポーネントにカーソルを合わせるまで、矢印カーソルは円とスラッシュで表示されます。ソリッドグループまたはコンポーネントにカーソルを合わせると、赤い円とスラッシュは黒い円で囲まれた 1 に変化し、ソリッドグループまたはソリッドコンポーネントのスクリーンチップが表示されます。

  2. クリックして、カッティンググループまたはコンポーネントを選択します。ここで示す例では、最初にペグを選択してボードに穴を開けます。選択すると、カーソルの隣の 1 が 2 になります。
  3. カットするグループまたはコンポーネントをクリックします。カッティンググループは消えますが、2 番目に選択したグループまたはコンポーネントに穴が空きます。この例では、ボードにペグサイズの穴が空きました。

ヒント: 上記の手順を実行する代わりに、ソリッドエンティティを事前に選択し、選択対象を右クリックして、メニューから [ソリッドツール] > [減算] を選択することもできます。SketchUp では、カッティングエンティティがどれか、カットするエンティティはどれかを判断するのに、各ソリッドエンティティを選択した順番を使用します。

SketchUp Free を使用している場合、[モデルと交差] コマンドを使用することで、減算の結果を得ることができます。[モデルと交差] を使用する場合、2 つの図形はソリッドエンティティである必要はありません。(実際は、図形がソリッドの場合、[モデルと交差] では異なる結果が得られます。それについては、本セクションの少し後で説明します)。ただし、[モデルと交差] コマンドで減算を実行する場合、SketchUp Pro の [減算] ツールによるプロセスよりも、少し多くのステップが必要になります。

ここでは、[モデルと交差] コマンドで減算を実行する方法について説明します。

  1. ボックスや円柱などの 2 つの異なるボリュームを作成します (ヘルプについては、「基本図形の描画」と「3D への図形のプッシュとプル」を参照してください)。
  2. [選択] ツール () を使用して、カッティングオブジェクトとなる最初のボリュームをトリプルクリックします。この例では、図に示すように、カッティングオブジェクトは円柱です。
  3. カットする図形と交差するようにカッティング図形を移動および回転させます (ヘルプについては、「エンティティの移動」および「反転と回転」を参照してください)。図に示すように、カッティング図形は選択したままにします。
  4. カッティング図形を右クリックし、表示されたメニューから [面と交差] > [モデルと交差] を選択します。このコマンドは、2 つの図形が交差する場所にエッジを作成するよう SketchUp に指示します。
  5. [消しゴム] ツール () を使用して、残したくないジオメトリを消去または移動させます。以下の図では、円柱が消去された後にボックス図形がどのように変化するかが示されています。

    ヒント: マウスホイールを押したままにするか、一時的に [オービット] ツールに切り替えると、周りを確認して削除したいすべてのジオメトリを探すことができます ([消しゴム] ツールの詳細については、「消去と元に戻す」を参照してください)。

[モデルと交差] では、現在のコンテキストにエッジが作成されます。図形がグループまたはコンポーネントである場合、グループ内またはグループ外に交差する線を作成できます。グループのコンテキスト外に交差する線を作成すると、以下の図のように、SketchUp が作成したエッジから元の図形を簡単に分離できます。グループの詳細については「モデルの編成」を、グループとコンポーネントの概要については「既成のコンポーネントと動的コンポーネントの追加」を参照してください。

あるソリッドを別のソリッドでトリミングする

[トリム] ツールでは、減算のように、あるソリッドエンティティを別のソリッドエンティティでカットできます。ただし、[トリム] ツールを使用する場合、モデル内にカッティングソリッドが残ります。そのため、ペグを使用してボードをトリムすると、ボードをカットした後もペグが残ります。すべての [ソリッド] ツールと同様に、[トリム] ツールは 2 つのソリッドエンティティが重なっている場合にのみ機能します。

ヒント: [トリム] ツールを使用する場合、各ソリッドエンティティを選択する順序が重要です。どのソリッドを最初に選択するかは、「このソリッドを使用してカットする」と考えてください。つまり、最初に選択したソリッドがカッティングツールとなります。2 番目に選択したソリッドがカット対象となります。

トリムを実行するには、次の手順に従ってください。

  1. [トリム] ツール () を選択します。

    ヒント: ソリッドグループまたはコンポーネントにカーソルを合わせるまで、矢印カーソルは円とスラッシュで表示されます。ソリッドグループまたはコンポーネントにカーソルを合わせると、赤い円とスラッシュは黒い円で囲まれた 1 に変化し、ソリッドグループまたはソリッドコンポーネントのスクリーンチップが表示されます。

  2. クリックして、カッティンググループまたはコンポーネントを選択します。ここで示す例では、最初にペグを選択してボードに穴を開けます。選択すると、カーソルの隣の 1 が 2 になります。
  3. カットするグループまたはコンポーネントをクリックします。カッティンググループは残りますが、2 番目に選択したグループまたはコンポーネントに穴が空きます。最初は結果がわかりづらくなっています (図 1 参照)。ペグを穴の外に移動させると、図 2 のように、ボードに穴が空いていることがわかります。

交差するジオメトリのみを残す

SketchUp Pro の [交差] ツール () を使用して 2 つ以上の重なっているソリッドエンティティを選択すると、交差しているジオメトリのみが残されます。

交差を実行するには、次の手順に従ってください。

  1. [交差] ツール () を選択します。

    ヒント: ソリッドグループまたはコンポーネントにカーソルを合わせるまで、矢印カーソルは円とスラッシュ () で表示されます。ソリッドグループまたはコンポーネントにカーソルを合わせると、赤い円とスラッシュは黒い円で囲まれた 1 に変化し、ソリッドグループまたはソリッドコンポーネントのスクリーンチップが表示されます。

  2. 交差に使用するソリッドエンティティを選択します。
  3. 最初に選択したソリッドエンティティに重なる追加のソリッドを 1 つ以上選択します。結果として、交差しているジオメトリが残ります。この例では、ボックスと球の交差 (図 1) によって、丸みを帯びた塊 (図 2) が作成されます。

ヒント: 別の方法として、交差させるソリッドを事前に選択することもできます。選択対象を右クリックして、表示されたメニューから [ソリッドツール] > [交差] を選択します。

モデルを分割する

[分割] ツール () を使用すると、交差しているエッジに沿って、重なっているソリッドエンティティを分割できます。分割を実行するには、次の手順に従ってください。

  1. [分割] ツール () を選択します。

    ヒント: ソリッドグループまたはコンポーネントにカーソルを合わせるまで、矢印カーソルは円とスラッシュで表示されます。ソリッドグループまたはコンポーネントにカーソルを合わせると、赤い円とスラッシュは黒い円で囲まれた 1 に変化し、ソリッドグループまたはソリッドコンポーネントのスクリーンチップが表示されます。

  2. ソリッドエンティティをクリックします。
  3. 最初に選択したソリッドエンティティと交差するソリッドエンティティをクリックします。SketchUp は選択したソリッドが交差するエッジに沿ってすべてのジオメトリを分割します。たとえば、以下の図では、左に示す 2 つのグループが、右のように 3 つのグループに分割されます。

Solid Inspector でモデルを修正する

ジオメトリが複雑になるにつれて、小さなエラーがモデルの多様性を制限するようになることがあります。SketchUp for Web の Solid Inspector は、SketchUp がモデルをソリッドとして分類できなくなるような問題を検出および修正することで 3D 印刷用のモデルを準備するのに役立つユーティリティです。この検査は、[ソリッドツール] の操作用に 3D モデルを修正するのにも役立ちます。

注: Solid Inspector は有料サブスクリプションで利用できます。SketchUp Pro では、Solid Inspector 拡張機能が同様の働きをします。

Solid Inspector のアクティベート

Solid Inspector ユーティリティは SketchUp for Web の右側のパネルメニューの下部にあります。ユーティリティをアクティベートすると、グループまたはコンポーネントを選択するように求められます。オブジェクトを選択し、[インスペクタを実行] をクリックして続行します。エラーが見つかった場合、その名前をクリックして詳細を確認します。矢印アイコンを使用すると、SketchUp カメラがモデル内の個々の問題に移動します。

注: グループ化されていないジオメトリは検査できません。

自動的に修正可能なエラー

Solid Inspector で検出されるエラーの一部は自動的に修正できます。Solid Inspector エラーは赤く強調表示されたジオメトリで識別されるため、Solid Inspector が自動的にエラーを修正する前に詳しく確認することができます。自動的に修正可能なエラーは以下のとおりです。

  • 反転した面: Solid Inspector は、面の法線が外側を向いていることを確認するための便利なユーティリティでもあります。
  • 浮遊エッジ: 面を定義していない余剰エッジジオメトリ。
  • 内側面と外側面: モデルの内側または外側にある浮遊ジオメトリ。
  • 面の穴: 外面に空いている穴。Solid Inspector で簡単に修正できます。

手動で修正可能なエラー

一部のエラーは Solid Inspector で自動的に修正することができず、SketchUp の描画 (または消しゴム) ツールを使用して手動で修正する必要があります。手動でいくつかのエラーを修正した後は、Solid Inspector を再実行して、変更によって自動修正するのに十分な程度モデルが整ったことを確認してください。手動で修正可能なエラーは以下のとおりです。

  • 境界の穴: これらの穴は少なくとも 1 つのエッジをソリッドの面と共有しています。これらのエラーは、強調表示されているジオメトリを描画し直すか消去することで手動で修正できます。作業中、Solid Inspector を再実行して、Solid Inspector がモデルの残りの部分を自動修正するのに十分な修正が完了しているかどうかを確認してください。
  • ネストされたグループ/コンポーネント: グループまたはコンポーネント内のネストされたオブジェクトは、3D プリンタ用の STL エクスポートで混乱を発生させる可能性があります。Solid Inspector ではこれらを修正しませんが、Solid Inspector を使用してネストされた各インスタンスを確認し、削除するかジオメトリをモデルに分解するかを決定することができます。
  • 画像エンティティ: SketchUp にインポートされた画像を STL ファイルにエクスポートすることはできません。[ソリッドツール] の操作も禁止されています。Solid Inspector はこれらのエラーについてプロンプトを表示しますが、これらの削除は手動で行う必要があります。画像エンティティをコンポーネントにすることを検討してください。そういう意味では、モデル内から画像エンティティを一時的に削除することは簡単です。また、画像テクスチャを持つ面をペイントしても、ソリッド性には影響がありません。
  • 短いエッジ: ジオメトリが非常に小さいと、3D 印刷またはソリッド操作で問題が発生する可能性があります。これらの問題は予測不可能であり、SketchUp では短いエッジをソリッドとして不適格なオブジェクトとみなすことができないため、Solid Inspector はこれらのエラーを自動的には修正しません。ただし、Solid Inspector はこれらの問題領域を見つけて評価する素晴らしい方法です。

エラーの表示

自動的に修正できないエラーが複数ある場合、[エラーの表示] コマンドを使用すると、手動で修正する必要がある個々の問題間を移動できます。左右の矢印を使用すると、Solid Inspector が識別した特定のタイプのエラーすべてを確認することができ、SketchUp のカメラが問題領域にズームします。

ヒント: 作業中は、[スタイル] または [表示] オプションを変更すると便利です。[X 線] スタイルに切り替えたり、[隠しジオメトリ] をオンにしたりすると、モデルの修正に役立ちます。
TAGS