マテリアルを使用した色とテクスチャの追加

モデルにディティールとリアリティを追加するため、SketchUp では面のマテリアルをペイントできます。マテリアルとは、色やオプションのテクスチャ (イメージ ファイル内で定義) を持つペイントのことです。たとえば以下の図では、屋根のマテリアルの色は青く、テクスチャは金属の屋根をシミュレートしています。また、壁と草も色とテクスチャを持つマテリアルです。

モデルにこのようなマテリアルを適用すると、SketchUp のマテリアル用特殊機能によって、以下のことが可能になります。

  • マテリアルを別のマテリアルに置き換える: たとえば、屋根板ではなく金属屋根を表示したい場合、屋根板のマテリアルを簡単かつ迅速に入れ替えられます。
  • マテリアルを編集する: 色とテクスチャは別々であるため、互いに独立して変更できます。たとえば壁の色を変更 (黄色はいかがですか?) してテクスチャを維持することができます。また、マテリアルの不透明度を編集して、マテリアルの不透明度や透明度を制御できます。
  • 必要なマテリアルの量を計算する: SketchUp ではすべての屋根や壁の面積を計算できます。もちろん、この計算を活用するには、数値がモデルの実際のサイズを反映するように正確なモデルを作成する必要があります。
ヒント: SketchUp には、カーペット、タイル、グラウンドカバー、ガラス、木など、複数のマテリアルのコレクションが含まれています。ただし、必要な特定のマテリアルがない場合は、独自のマテリアルを作成できます。この機能は、クライアントに正確な仕上げを示す必要がある装飾業や建設業の場合、特に便利です。

SketchUp インターフェースで、[ペイント] ツール () と [マテリアル] パネル (Microsoft Windows) または [色] パネル (macOS) を使用してマテリアルをモデリングします。[マテリアル] または [色] パネルでは、マテリアルを表示、管理、整理できます。[マテリアル] または [色] パネルでは、モデル内のマテリアルが追跡され、プロジェクトまたはワークフローに固有のマテリアル コレクションを作成できます。

注: Microsoft Windows が実行されているコンピュータと macOS が実行されているコンピュータを切り替える場合、[マテリアル] パネル インターフェースと [色] パネル インターフェースがそれぞれのオペレーティング システムに固有のものであることに注意してください。以下のセクションではヘルプ センターのいずれかのページのドロップダウン リストから、選択したオペレーティング システムに応じて、Microsoft Windows 用または macOS 用の手順が表示されます。

以下のビデオでは、マテリアルを適用する方法や、マテリアルを別のマテリアルに置き換えるなどのいくつかの一般的な変更の方法について紹介します。マテリアルの使用方法の詳細な説明については、以下のセクションを参照してください。

マテリアルを適用する

モデルにマテリアルを適用するのは簡単です。面 (複数可) を選択し、目的のマテリアルを選択します。グループやコンポーネントをペイントする場合は、このセクションの最後にあるヒントを確認してください。これにより、マテリアルの適用がさらに簡単になります。

SketchUp のインターフェースの以下の部分にある [ペイント] ツール () を使用して、モデルにマテリアルを適用します。

    Windows
  • 基本ツールバー
  • ラージ ツール セット ツールバー
  • 主要ツールバー
  • メニュー バーの [ツール] > [ペイント]

モデルにマテリアルを適用するには、以下の手順を実行します。

  1. [ペイント] ツール ()を選択します。
  2. 表示された [マテリアル] パネルで [選択] タブをクリックします。[マテリアル] パネルがトレイに表示されない場合、ダイアログ ボックスが非表示トレイに存在する場合があります。この場合、非表示トレイ タブにカーソルを合わせます。これにより、トレイが展開されます。[マテリアル] パネルがトレイに表示されます。
  3. ドロップダウン リストから、マテリアル コレクションを選択します。
  4. 使用するマテリアルをクリックします。
    ヒント: すでにモデルに存在するマテリアルをサンプリングするには、Alt キーを押したままにすることで、[サンプル] ツールに一時的に切り替えます。[サンプル] ツールのスポイト カーソルを使用して、サンプリングするマテリアルの面をクリックします。Alt キーを離すと、[ペイント] ツールに戻ります。
  5. 描画エリアに戻り、マテリアルを適用する面 (複数可) をクリックします。

Windows 版 SketchUp でマテリアルを適用する

ヒント: デフォルトの色に戻すには、前述の手順を実行します。ただし、マテリアルをクリックするのではなく、右上の [ペイントするマテリアルをデフォルトに設定する] () をクリックして、デフォルトの色を適用するモデルの面をクリックします。

    MacOS
  • ラージ ツール セット ツールバー
  • メニュー バーの [ツール] > [ペイント]
  • ツール パレット

モデルにマテリアルを適用するには、以下の手順を実行します。

  1. [ペイント] ツール ()を選択します。表示された [色] パネルでは、4 つのカラー ピッカー タブのいずれかで色を選択したり、マテリアル コレクションを使用したりできます。
  2. マテリアル コレクションを参照するには、レンガ アイコンの [テクスチャ パレット] タブをクリックします(色を選択するための他のタブの使用については、「カラー ピッカーで色を混ぜる」を参照してください)。
  3. ドロップダウン リストから、マテリアル コレクションを選択します。以下の図では、[屋根] コレクションが選択されています。
  4. モデルに適用するマテリアルをクリックします。
    ヒント: すでにモデルに存在するマテリアルをサンプリングするには、[テクスチャ パレット] タブの下部にある [スポイト] ツールをクリックします。大きな円形のカーソルを使用して、サンプリングするマテリアルの面をクリックします。これにより、マテリアルがサンプル見本に読み込まれ、再度 [ペイント] カーソルが表示されます。
  5. 描画エリアに戻り、マテリアルを適用する面 (複数可) をクリックします。

または、[テクスチャ パレット] タブのメイン エリアからマテリアルの見本をクリックし、モデルの面にドラッグします(macOS の [色] パネルの下部のパレットから見本をドラッグすることはできません。これらの保存済み見本の使用については、「カラー ピッカーで色を混ぜる」を参照してください)。

ヒント: デフォルトの色に戻すには、[モデル内の色] コレクションの [デフォルト] 見本を選択します。

ヒント: 面をクリックしても選択されたマテリアルが表示されない場合、モデルではテクスチャを表示しないスタイルが使用されている可能性があります。これを確認するには、 [スタイル] パネルを開き、[編集] タブを選択して、[面設定] アイコンをクリックします。[スタイル] エリアで、[テクスチャを使用したシェーディングを表示] オプションが選択されていることを確認します。

スタイルにテクスチャが表示されている場合、モデルにマテリアルを表示するためのメモリが不足している可能性があります。ヘルプについては、「SketchUp の問題の修正」を参照してください。

一度に複数の面やエッジをペイントできます。実行するには、[選択] ツール () を使用してペイントするエッジや面を選択します。その後、[ペイント] ツールに切り替えてマテリアルを適用します(選択のヒントについては、「ジオメトリを選択する」を参照してください)。

一度に複数の面にマテリアルを適用するときは以下の点に注意してください。

  • 面には表側と裏側の 2 つの側があります。選択されたすべての面の表側または裏側をペイントすることはできますが、組み合わせてペイントすることはできません。ペイントされる側は、[ペイント] カーソルでクリックした側によって決まります。以下の図では、2 つの表面と 2 つの裏面が見えていますが、面の表側をクリックすることで、選択したすべての表面をペイントしています。
  • スタイルを使用して裏側エッジの外観を制御します。面とすべてのエッジを選択し、面の表側をペイントすると、選択したすべてのエッジがペイントされます。ただし、裏面をペイントすると、エッジはペイントされません。マテリアルを使用して裏側エッジをブレンドするには、[スタイル] パネルを開き、[編集] タブをクリックして、[エッジ設定] アイコンをクリックし、[色] ドロップダウン リストから [マテリアル別] を選択します。

グループまたはコンポーネント全体にマテリアルを適用したり、グループまたはコンポーネント内の特定のジオメトリにマテリアルを適用したりすることができます。

  • グループまたはコンポーネント全体をペイントするには、グループまたはコンポーネント全体を選択してマテリアルを適用します。グループまたはコンポーネントを選択してマテリアルを適用すると、デフォルト マテリアルの面だけがペイントされます。
  • グループまたはコンポーネント内のジオメトリをペイントするには、ジオメトリをダブルクリックしてコンテキスト メニューを開きます。マテリアルを使用してペイントする面を選択します。

以下のビデオでは、コンポーネントにマテリアルを適用するためのヒントをいくつか紹介しています。あるいは、コンポーネントのすべてまたは一部をペイントする手順をご確認ください。

ヒント: マテリアルのバリエーションをすばやく簡単にモデリングするには、コンポーネントのすべてと一部をペイントするためのテクニックを組み合わせます。

このヒントの仕組みを確認しましょう。木のフレームと 2 つのクッションで構成されるイスをモデリングしているとします。そしてあなたはクッションの色を 4 種類を見てみたいとします。以下の [アウトライン表示] は、イスの各要素 (フレームと 2 つのクッション) がグループであり、それらすべてがグループにネストされており、さらにコンポーネントにネストされていることを示しています(アウトライン表示の詳細については、「モデルの整理」を参照してください)。

以下の手順では、マテリアルを適用して 4 種類の色オプションを確認する最も簡単な方法を説明します。

  1. フレームはどのイスでも同じであるため、以下のようにフレームのグループを選択し、木のマテリアルを適用します。
  2. 各クッション カラーごとにコピーを作成します(「作成済みのオブジェクトをコピーする」で詳細を説明しています)。
  3. コンポーネントを選択し、クッション カラー マテリアルを適用します。フレームはすでにペイントされていますが、クッションはまだデフォルト カラーのままであるため、クッションだけがカラー マテリアルでペイントされます。フレームのマテリアルは木のままです。
  4. 各カラー オプションに対して上記の手順を繰り返します。結果は以下の図のようになります。

ヒント: 複数のグループまたはコンポーネントが他のグループおよびコンポーネントにネストされている場合、一番上のグループまたはコンポーネントをクリックしてもペイントできない場合があります。この問題が発生した場合は、階層の下位にネストされたグループまたはコンポーネントにマテリアルを適用してください。[アウトライン表示] では、選択した項目が階層内のどこにあるかを確認できます。

マテリアルを別のマテリアルに置き換える

SketchUp では、マテリアルを別のマテリアルに置き換えることができるため、マテリアルをすばやく簡単に試すことができます。キッチンでは、黒い花崗岩、青いタイル、白い複合材など、さまざまなカウンター マテリアルをプレビューできます。家の塗装色を選択する場合、黄色の壁やダーク グリーンのトリムをネイビーの壁やクリーム色のトリムと比較できます。修飾キーを知っているとプロセスが楽になります。以下の表をご確認ください。

マテリアルを置き換える対象 修飾キー (Microsoft Windows) 修飾キー (macOS)
隣接する面 Ctrl Option
現在のコンテキスト内のすべての面 (同じグループやコンポーネントなど) Shift Shift
連結されたすべての面 Ctrl+Shift Option+Shift

以下の例では、各ショートカットの動作を示します。2 つの別々の壁の抽象的な壁画の色を選択するとします。以下の図は、[色名] コレクションのマテリアルでモックアップされた壁画を示しています。

赤色を緑色に置き換えるには、[ペイント] ツールを選択し、[マテリアル] パネル (Microsoft Windows) または [色] パネル (macOS) から緑色を選択します。Ctrl または Option キーを押しながら左上の赤い三角形をクリックすると、以下の図のように、隣接する赤色マテリアルの面のみが緑色に置き換えられます。

代わりに Shift キーを押しながらクリックすると、赤色のすべての面が緑色になります。

Ctrl+Shift キーまたは Option+Shift キーを押しながらクリックすると、左側の壁の赤色の面のみが緑色になります。

マテリアルを編集する

SketchUp ではマテリアルを編集できます。変更を加えると、編集したマテリアルでペイントされた面が自動的に更新されます。各マテリアルには色とテクスチャ (オプション) があるため、色とテクスチャを個別に編集できます。


SketchUp でのマテリアルの編集は、複数の面に 1 つのマテリアルが適用されている場合に特に便利です。1 つの面でマテリアルを入れ替えるのではなく、マテリアルを編集することで、編集するマテリアルでペイントされている面が自動的に更新されます。各マテリアルには色とテクスチャ (オプション) があるため、色とテクスチャを個別に編集できます。

注: マテリアルの編集は、SketchUp for Web アプリケーションの有料サブスクリプションに含まれています。SketchUp for Schools ユーザーも利用可能です。

マテリアルを編集するには、マテリアルをモデルと共に保存する必要があります。モデルと共に保存されたマテリアルを表示するには、画面右側のユーティリティ トレイで [マテリアル] パネルを開きます。

マテリアルを編集するには、[ホーム] アイコンの下の [モデル内] マテリアルから選択するか、[スポイト] ツールを使用してモデリング ウィンドウからサンプリングします ([マテリアル] パネルでマテリアルが自動的に選択されます)。マテリアルを選択したら、マテリアル サムネイルの隣の [編集] アイコンをクリックします。

マテリアルの編集中は以下を設定できます。

  • マテリアル名: マテリアルの新しい名前を入力して、編集対象のマテリアルの名前を変更します。
  • 色: SketchUp のカラー ピッカーを使用するか、特定の RGB、HSL、HEX 値を入力することで、マテリアルの色を手動でカスタマイズできます。色を変更すると、編集がリアルタイムで反映されます。
  • 画像: マテリアルに関連付ける画像テクスチャを追加または変更します。画像テクスチャを追加または変更すると、マテリアルの色の選択が上書きされる場合があります。[X] をクリックして、マテリアルから画像テクスチャを完全に削除することもできます。
  • マテリアル サイズ: 面に画像テクスチャを適用すると、テクスチャ画像がタイル表示され、面が塗りつぶされます。[幅] または [高さ] ボックスに値を入力し、テクスチャ タイルのサイズを変更します。デフォルトでは、画像のアスペクト比は保持されます。そのため、幅寸法ボックスに 2 を入力すると、アスペクト比が維持されるように高さボックスも自動的に更新されます。鎖アイコンをクリックして鎖を外す (Fleetwood Mac さん、すみません) と、自由にアスペクト比を変更できます。結果が気に入らない (そして二度と使わない) 場合、メニュー下部の [キャンセル] をクリックするか、CTRL/Command + Z キーを押して変更を元に戻すことができます。
  • 不透明度: マテリアルが透明か不透明かを編集することもできます。不透明度スライダーを右に動かすと不透明度が大きくなり、100 で完全に不透明になります。スライダーを左に動かすと透明度が大きくなり、0 で完全に透明になります。または、[不透明度] フィールドに 0 ~ 100 の数値を入力します。

注: すべてのマテリアルの編集は、マテリアルの編集中に [マテリアルの編集] パネルの下部の [キャンセル] をクリックすることで破棄できます。マテリアル編集の変更を受け入れる場合、[元に戻す] および [やり直し] コマンドを使用して、元のマテリアルと編集済みマテリアルを行き来できます。

Windows

マテリアルを編集するには、マテリアルをモデルと共に保存する必要があります。モデルと共に保存されたマテリアルを表示するには、[マテリアル] パネルを開き、[モデル内] アイコン () クリックして、以下の図のように [モデル内] コレクションを表示します。

編集するマテリアルに [モデル内] コレクションが表示されない場合、現在モデル内の面にマテリアルが適用されているかどうかにかかわらず、[モデル内] コレクションを使用してマテリアルを保存できます。[モデル内] コレクションにマテリアルを追加するには、以下の手順を実行します。

  1. [マテリアル] パネルの右上の [第 2 選択ペインを表示] アイコン () をクリックします。
  2. 下部の第 2 ペインで、編集するマテリアルのコレクションを参照します。
  3. [モデル内] コレクションにマテリアル見本をドラッグします。

マテリアルを編集するには、以下の図のように、[モデル内] コレクションを選択し、[編集] タブをクリックします。

マテリアルの色を編集するためのすべてのツールについて、簡単な説明を以下に示します。

  • [ピッカー] ドロップダウン リスト: ピッカー ドロップダウン リストを使用して、HLS (色相、輝度、彩度)、HSB (色相、彩度、明度)、RGB (赤、緑、青)、色相環カラー ピッカーから選択します。カラー ピッカーの詳細については、「カラー ピッカーで色を混ぜる」を参照してください。
  • [色の変更を元に戻す] 見本: この見本をクリックして、編集セッション中に行ったすべての色変更を元に戻します。
  • [モデル内のオブジェクトの色にマッチング] ボタン: このボタンをクリックすると、カーソルがスポイトになります。スポイト カーソルを使用して、色をサンプリングするエンティティをクリックし、その色を編集中のマテリアルに適用します。
    ヒント: テクスチャが適用されているマテリアルをサンプリングする場合、テクスチャのバリエーションによってマテリアルの色が少し変わって表示されます。[画面上の色にマッチング] ボタンを使用してテクスチャから特定の色をサンプリングすると、結果が改善されます。
  • [画面上の色にマッチング] ボタン: このボタンをクリックし、スポイト カーソルで画面上の任意の場所をクリックすると、ピクセル カラーがサンプリングされます。SketchUp はその色を現在選択されているマテリアルに適用します。

以下のツールを使用すると、マテリアルのテクスチャを編集できます。

  • [テクスチャ画像を使用] チェックボックス: このチェックボックスを選択すると、テクスチャを表す画像ファイルを含めることができます。チェックボックスをクリアすると、テクスチャ画像ファイルが削除されます(チェックボックスを再度選択しても画像ファイルは復元されないことに注意してください。代わりに、新しい画像ファイルを選択するように求められます)。
  • テクスチャ画像ファイルと [参照] ボタン: テクスチャ ファイル フィールドには、(存在する場合) 現在のマテリアルに関連付けられているテクスチャを表す画像ファイルの名前が含まれます。テクスチャを変更するには、このフィールドに画像ファイルをドラッグするか、[参照] ボタンをクリックして、[画像を選択] ダイアログ ボックスを開きます。ここでは、ハード ドライブの画像ファイルを参照できます。テクスチャを適用した後、モデル上でテクスチャがどのようにタイル化されるかを調整することもできます。詳細については、後半の「テクスチャを再配置する」セクションを参照してください。
  • [外部エディタでテクスチャ画像を編集] ボタン: このボタンをクリックすると、デフォルトの画像エディタでテクスチャ画像ファイルが開かれます。
    注: 画像エディタは、[アプリケーション] パネルの [SketchUp 環境設定] ダイアログ ボックスで定義されます。この環境設定の詳細については、「ワークスペースをカスタマイズする」を参照してください。画像エディタを指定していない場合、SketchUp はオペレーティング システムにデフォルトで搭載されているエディタか、画像表示アプリケーションを起動します。
  • [着色] チェックボックス: このチェックボックスを選択すると、テクスチャ全体に同じ色相が適用されます。色は [編集] タブの [色] エリアで定義されます。このオプションは、適切な色が表示されていないファイルに有効です。
  • [色のリセット] 見本: この色見本をクリックすると、マテリアルがテクスチャ画像ファイルの色にリセットされます。
  • [寸法] フィールド: 面のテクスチャをペイントすると、テクスチャ画像がタイル表示され、面が塗りつぶされます。[幅] または [高さ] ボックスに値を入力し、テクスチャ タイルのサイズを変更します。デフォルトでは、画像のアスペクト比は保持されます。そのため、幅寸法ボックスに 2 を入力すると、アスペクト比が維持されるように高さボックスも自動的に更新されます。鎖アイコンをクリックして鎖を外す (Fleetwood Mac さん、すみません) と、アスペクト比を変更できます。結果が気に入らない (そして二度と使わない) 場合、横および縦の矢印ボタンをクリックして、幅と高さの設定を元に戻します。
  • [不透明度] スライダー: 不透明度とは、画像が透明か不透明かを示すものです。不透明度スライダーを右に動かすとテクスチャの不透明度が大きくなり、100 で完全に不透明になります。スライダーを左に動かすとテクスチャの透明度が大きくなり、0 で完全に透明になります。または、[不透明度] フィールドに 0~100 の数値を入力します。

MacOS

マテリアルを編集するには、マテリアルをモデルと共に保存する必要があります。モデルと共に保存されたマテリアルを表示するには、[ウィンドウ] > [マテリアル] を選択し、[色] パネルを開きます。以下の図のように、[テクスチャ パレット] タブ (レンガ アイコン) で [モデル内の色] アイコン () をクリックするか、ドロップダウン リストから [モデル内の色] を選択して [モデル内の色] コレクションを表示します。

編集するマテリアルが [モデル内の色] コレクションに表示されない場合、モデル内の面にそのマテリアルを適用します(後でマテリアルを置き換える場合、使用していないマテリアルを完全に削除するまで、元のマテリアルは [モデル内の色] コレクションに残ります)。

マテリアルを編集する準備ができたら、以下の手順を実行します。

  1. [テクスチャ パレット] タブ (レンガ アイコン) で [モデル内の色] コレクションを開きます。
  2. 編集するマテリアルを選択します。
  3. [色] ドロップダウン リストから [編集] を選択します。または、Ctrl キーを押しながらマテリアルをクリックし、表示されたメニューから [編集] を選択します。
  4. 以下の図のように、表示された [マテリアルの編集] パネルで必要な編集を選択します。
  5. 完了したら [閉じる] ボタンをクリックします。

[マテリアルの編集] パネルのオプションについての概要を以下に示します。

  • 名前: マテリアルの新しい名前を入力して、編集対象のマテリアルの名前を変更します。
  • 外部エディタでテクスチャ画像を編集: このボタンをクリックすると、デフォルトの画像エディタまたはプレビュー プログラムでテクスチャの画像ファイルが開かれます。編集してファイルに保存すると、変更がマテリアルに反映されます。
  • テクスチャ ドロップダウン メニュー: このドロップダウン メニューのオプションを使用すると、SketchUp でテクスチャを編集できます。テクスチャ用の新しい画像を選択するには、[ロード] を選択します。テクスチャ画像ファイルを削除するには、[削除] を選択します(テクスチャ画像を削除すると、削除された画像の近似色が表示されます)。テクスチャに色付けしている場合、[色をリセット] を選択して色を削除します。[編集] を選択すると、デフォルトの画像エディタまたはプレビュー プログラムでテクスチャ画像ファイルが開かれます。テクスチャを適用した後、モデル上でテクスチャがどのようにタイル化されるかを調整することもできます。詳細については、後半の「テクスチャを再配置する」セクションを参照してください。
  • 幅と高さ: 面のテクスチャをペイントすると、テクスチャ画像がタイル表示され、面が塗りつぶされます。[幅] または [高さ] ボックスに値を入力し、テクスチャ タイルのサイズを変更します。デフォルトでは、画像のアスペクト比は保持されます。そのため、幅寸法ボックスに 2 を入力すると、アスペクト比が維持されるように高さボックスも自動的に更新されます。鎖アイコンをクリックして鎖を外す (Fleetwood Mac さん、すみません) と、自由にアスペクト比を変更できます。結果が気に入らない (そして二度と使わない) 場合、元の画像寸法に戻すには、元の寸法を覚えておいて手動で入力する必要があります。
  • 色付け: [マテリアルの編集] パネルが表示されたら、テクスチャ ファイルを色付けできます。[色] タブのいずれかを使用して色を選択し、[マテリアルの編集] パネルのマテリアル プレビューに適用します。または [色] パネルの下部のスポイト ツールをクリックして、モデルまたは [テクスチャ パレット] (レンガ) タブのマテリアルをクリックします。
    ヒント: 色付けはマテリアルの色のバリエーションを試すのに最適な方法です。
  • 不透明度: [マテリアルの編集] パネルが表示されると、マテリアルの不透明度 (画像が透明か不透明かを示します) を編集できます。不透明度スライダーを右に動かすとテクスチャの不透明度が大きくなり、100 で完全に不透明になります。スライダーを左に動かすとテクスチャの透明度が大きくなり、0 で完全に透明になります。または、[不透明度] フィールドに 0~100 の数値を入力します。

テクスチャを再配置する

3D モデルの 1 つ以上の面にテクスチャを適用した後、面全体でテクスチャがどのようにタイル化されるかを調整できます。そのためには、[テクスチャを配置] ツールを使用します。このツールには 2 つのモードがあります。

  • [固定ピン] モード: このモードでは、テクスチャを移動、回転、拡大/縮小、変形できます。たとえば、このモードでは、建物の 2 つの壁面など、ある面のテクスチャを調整し、別の面の同じテクスチャと並べることができます。
  • [自由ピン] モード: テクスチャを伸縮する必要がある場合、[自由ピン] モードを使用します。

[固定ピン] モードでテクスチャを調整する方法を以下に示します。

  1. マテリアルを右クリックし、表示されたメニューから [テクスチャ] > [配置] を選択します。テクスチャの個々のタイルを表す点線のマトリックスが表示されます。カーソルも手の形になり、4 つのピンが表示されます。
  2. 以下の図のように 4 色のピンが表示されたら、次のステップに進みます。表示されない場合、マテリアルを右クリックし、[固定ピン] を選択します。
  3. 手のカーソルやピンを使用して、テクスチャを調整します。この例では、キャビネット上部の木材の方向が壁と一致するように緑色のピンを移動させることが目標です。すべてのオプションの概要を以下に示します。
    • 手のカーソルでマテリアルをクリックしてドラッグし、テクスチャ全体を再配置します。
    • ピンをクリックして選択し、もう一度クリックしてテクスチャ上の他の場所にピンをドロップします。
    • ピンをドラッグしてテクスチャを変更します。青色のピンをドラッグすると、テクスチャを拡大/縮小または傾けることができます。黄色のピンをドラッグすると、テクスチャを変形できます。緑色のピンをドラッグすると、テクスチャを拡大/縮小したり、移動ピンを軸にして回転させたりできます。赤色のピン (移動ピン) をドラッグすると、テクスチャを移動できます。
    ヒント: [固定ピン] モードでは、テクスチャを右クリックして、テクスチャを上下または左右に反転したり、テクスチャを 90 度単位で回転させたりする追加のオプションを表示することもできます。リセット オプションではテクスチャを元の状態に戻すことができますが、[元に戻す] オプションでは最後のコマンドだけが取り消されます。操作を元に戻すと、[やり直し] もオプションとして表示されます。
  4. テクスチャの変更が完了したら、テクスチャを右クリックして、[完了] を選択します。または、テクスチャの外側をクリックして、[固定ピン] モードを終了します。

[自由ピン] モードでは、モデルを基準としたテクスチャ タイルのサイズを設定します。手順は以下のとおりです。

  1. マテリアルを右クリックし、表示されたメニューから [テクスチャ] > [配置] を選択します。デフォルトは [固定ピン] モードです。
  2. テクスチャを右クリックし、[固定ピン] オプションの選択を解除すると、[自由ピン] モードに切り替わります。[自由ピン] モードでは、以下の図のように 4 つの白色のピンが表示されます。
  3. ピンをクリックして選択し、もう一度クリックしてピンを新しい場所に配置します。4 つすべてのピンに対してこれを行い、テクスチャ タイルの角が表示される場所を設定します。長方形ではない構成でピンを配置すると、テクスチャが歪みます。
  4. 完了したら、テクスチャを右クリックして、[完了] を選択します。または、テクスチャの外側をクリックして、[自由ピン] モードを終了します。
ヒント: [自由ピン] モードでは、選択された面についてのみテクスチャ タイルのサイズが表示されます。モデル全体でテクスチャ タイルのサイズを変更するには、[マテリアル] パネル (Microsoft Windows) または [色] パネル (macOS) を使用します。詳細については、前半のセクション「マテリアルを編集する」を参照してください。

自動的でマテリアルの面積を計算する

SketchUp にマテリアルでペイントされた表面積を計算させる場合、マテリアルを右クリックし、[面積] > [マテリアル] を選択します。Windows では、[マテリアル] パネルのマテリアルを右クリックし、メニューから [面積] を選択することもできます([面積] メニュー項目が灰色の場合、マテリアルはどの面にも適用されていません)。

いずれの場合も、選択されたマテリアルが適用されている面の総面積は、[面積] ダイアログ ボックスに表示されます。単位 (平方フィートや平方メートルなど) は、テンプレートで指定されている単位によって異なります。デフォルト単位の変更の詳細については、「テンプレートを設定する」を参照してください。

IFC 分類を使用する場合、モデル全体のマテリアルに関するレポートを生成できます。詳細については、「オブジェクトを分類する (特に「レポートを生成する」のセクション)」を参照してください。

マテリアルを管理および整理する

[マテリアル] パネル (Microsoft Windows) または [色] パネル (macOS) は、マテリアルの検索と整理に役立ちます。以下のリストでは、ヘルプ センターで選択したオペレーティング システムでマテリアルを管理する方法について説明します。

Windows

  • 含まれているコレクションを参照: [選択] タブで、ドロップダウン リストからコレクションを選択してマテリアルを表示します。
  • モデル内のマテリアルを追跡: [モデル内] アイコン () をクリックし、モデルに適用されているすべてのマテリアルを表示します。
  • 不要なマテリアルを消去: マテリアルを別のマテリアルに置き換えたことにより、元のマテリアルがモデルに表示されなくなっても、右クリックして [削除] を選択することで削除するまで、元のマテリアルは [モデル内] コレクションに残ります。モデル内の使用されていないすべてのマテリアルを削除するには、[モデル内] コレクションが選択されていることを確認します。その後、[詳細] 矢印 () をクリックし、[不要アイテムを完全に削除] を選択します。あるいは、[すべて削除] を選択すると、モデルと [モデル内] コレクションからすべてのマテリアルを削除できます。
  • 独自のコレクションを作成する: 特定のプロジェクト用にコレクションを作成したり、特定の配色、布見本、ランドスケープ オプションなど、繰り返し使用するために作成したマテリアルのコレクションを作成したりすることができます。[選択] タブで、[詳細] 矢印 () をクリックし、[コレクションを開くか作成する] を選択します。[コレクション フォルダを選択するか新規作成する] ダイアログ ボックスで、コレクションを保存するフォルダに移動します。[新しいフォルダ] ボタンをクリックし、フォルダ名 (コレクションの名前になります) を指定して、[フォルダを選択] をクリックします。コレクションを作成したら、フォルダに移動してコレクションを開きます。コレクションにマテリアルを追加するには、第 2 選択ペインからコレクションにドラッグするか、作成するマテリアルをコレクションに保存します。
  • よく使用するコレクションをお気に入りに追加: [選択] タブで、[詳細] 矢印をクリックし、[コレクションをお気に入りに追加] を選択します。現在選択しているコレクションがドロップダウン リストの一番下のお気に入りリストに表示されます。お気に入りリストのコレクションが不要になったら、コレクションを選択し、[詳細] 矢印をクリックして、[お気に入りからコレクションを削除] を選択します。
    注: [詳細] 矢印をクリックすると、マテリアルを小、中、大、特大のタイルで表示できます。[リスト] オプションを選択すると、プレビュー見本の代わりにマテリアル名が表示されます。

MacOS

  • 同梱されているコレクションを参照: レンガとクラッディング、フェンス、屋根、半透明、木材など、SketchUp に同梱されているマテリアルを表示するには、[テクスチャ パレット] アイコン (レンガ) をクリックし、ドロップダウン メニューのコレクションから選択します。コレクション内の各マテリアルは、[ペイント] カーソルでクリックしてモデルに適用できる見本として表示されます。
  • モデル内のマテリアルを追跡: [色] パネルには、[モデル内の色] という特別なマテリアル コレクションが含まれています。これには、モデル内で現在使用されているすべてのマテリアルが含まれています。このコレクションのコンテンツは、SketchUp モデルにマテリアルを追加したときに自動的に生成されます。このコレクションを表示するには、マテリアル コレクション ドロップダウン メニューから [モデル内の色] を選択するか、[モデル内の色] アイコン () をクリックするだけです。
  • 不要なマテリアルを消去: マテリアルを別のマテリアルに置き換えたことにより、元のマテリアルがモデルに表示されなくなっても、右クリックして [削除] を選択することで削除するまで、元のマテリアルは [モデル内の色] コレクションに残ります。モデル内の使用されていないすべてのマテリアルを削除するには、[モデル内の色] コレクションが選択されていることを確認します。その後、[リスト] > [不要アイテムを完全に削除] を選択します。あるいは、[すべて削除] を選択すると、モデルと [モデル内の色] コレクションからすべてのマテリアルを削除できます。
  • 独自のコレクションを作成する: 特定のプロジェクト用にコレクションを作成したり、特定の配色、布見本、ランドスケープ オプションなど、繰り返し使用するために作成したマテリアルのコレクションを作成したりすることができます。[リスト] > [新規] を選択します。表示された [リスト名] ボックスで、名前を入力し、[OK] をクリックします。コレクションのドロップダウン リストに、入力された名前が表示されるようになります。
    マテリアルを新しいコレクションに追加するには、[色] パネル下部のスポイト ツールの隣にある見本を、新しいコレクションの見本ペインにドラッグします。または、新しいテクスチャを作成してコレクションに保存します。コレクションを削除するには、[リスト] > [削除] を選択します。
注: Windows の [マテリアル] パネルの使用に慣れている場合、macOS の [色] パネルでは、よく使用するコレクションをお気に入りリストに追加できないことに注意してください。

独自のマテリアルを作成する

SketchUp に同梱されているマテリアルは、初めてマテリアルを使用してその仕組みを確認するのに役立ちます。独自のデザインや建物に固有のマテリアルを適用するには、おそらく独自のマテリアルを作成することになるでしょう。そのプロセスは非常に簡単で、画像からテクスチャ タイルを作成し、必要に応じて色を指定するだけです。

Windows

独自のファイルまたはカラー コードから新しいマテリアルを作成するには、以下の手順を実行します。

  1. [マテリアル] パネルで、右上の [マテリアルの作成] アイコン () をクリックします。
  2. 表示された [マテリアルの作成] ダイアログ ボックスで、上部のテキスト フィールドに新しいマテリアルの名前を入力します。
  3. 新しいマテリアルの色、テクスチャ、不透明度オプションを選択します。オプションは [編集] パネルと同じように機能します。詳細については、前述のセクション「マテリアルを編集する」を参照してください。また、色オプションの詳細については、「カラー ピッカーで色を混ぜる」を参照してください。
  4. [OK] をクリックします。新しいマテリアルは、[モデル内] コレクションで選択済みと表示されます。

MacOS

新しいマテリアル (テクスチャ) を作成するには、以下の手順を実行します。

  1. [色] パネルで、[テクスチャ パレット] タブ (レンガ アイコン) をクリックします。
  2. 新しいマテリアルを表示するコレクションを選択します。
  3. [色] > [新しいテクスチャ] を選択します。
  4. 表示されたダイアログ ボックスで、テクスチャの画像ファイルを選択します。
  5. 表示されたパネルで、テクスチャの名前を入力し、タイル サイズの幅と高さを設定して、[OK] をクリックします。テクスチャに色を付ける場合は、前述のセクション「マテリアルを編集する」の手順を実行します。

特定の色をマテリアルとして保存する方法は以下のとおりです。

  1. [色] タブのいずれかを使用して目的の色を作成します。これは、[色] パネルの下部の色見本に表示されます。詳細については、「カラー ピッカーで色を混ぜる」を参照してください。
  2. [テクスチャ パレット] タブ (レンガ アイコン) を選択します。
  3. 色を保存するコレクションに移動します。
  4. [色] パネルの下部からコレクションの見本エリアに色見本をドラッグします。
ヒント: マテリアルをダウンロードしてマテリアル コレクションを拡張することもできます。詳細については、SketchUpdate ブログのこの投稿を確認してください。