Importer et exporter des fichiers STL pour impression 3D

SketchUp vous permet d'importer et d'exporter des fichiers STL, utilisés dans l’impression 3D. Comme expliqué sur la page Imprimer un modèle en 3D, pour qu'un modèle SketchUp devienne une impression 3D réussie, le modèle doit répondre à certains critères, comme être un solide doté d'une base et d'un volume.

Importer un fichier STL dans SketchUp

Pour importer un fichier STL dans SketchUp, procédez comme suit :

  1. Sélectionnez Fichier > Importer.
  2. Dans la boîte de dialogue Importer qui s’ouvre, accédez au fichier STL que vous souhaitez importer et sélectionnez-le.
  3. (Facultatif) Sélectionnez Fichiers de STéréoLithographie (.stl) dans la liste déroulante Type de fichier, puis cliquez sur le bouton Options. La boîte de dialogue Options d'importation STL s'affiche.
  4. (Facultatif) Sélectionnez Fichiers de STéréoLithographie (.stl) dans la liste déroulante Format, puis cliquez sur le bouton Options. La boîte de dialogue Options d'importation STL s'affiche.
  5. (Facultatif) Sélectionnez les options de votre choix (détaillées dans la liste suivante) et cliquez sur OK. Vous revenez alors à la boîte de dialogue Importer.
  6. Cliquez sur Importer pour que SketchUp importe le fichier STL sélectionné.
Conseil : vous pouvez également faire glisser et déposer des fichiers importables dans la zone de dessin. Une fois que vous avez déposé le fichier, la boîte de dialogue d'importation correspondante s'ouvre pour vous permettre de sélectionner les options souhaitées.

La boîte de dialogue Options d'importation STL vous permet d'effectuer différentes sélections sur le traitement de la géométrie et de l'échelle lorsque SketchUp importe votre fichier :

  • Fusionner les faces coplanaires : dans la plupart des cas, il est préférable de cocher cette case qui fusionne toutes les faces d'un même plan en une seule face. Cette case est décochée par défaut, ce qui préserve plusieurs objets sur plusieurs calques.
  • Préserver l'origine du dessin : il est généralement préférable de décocher cette case et de laisser SketchUp choisir une origine ou réinitialiser l'origine après l'importation.
  • Inverser les coordonnées YZ : lorsque vous cochez cette case, la coordonnée Y devient la coordonnée verticale. En d'autres termes, l'axe Y est dirigé vers le haut au lieu de l'axe Z.
  • Unités STL : l’unité par défaut est le millimètre. Vous pouvez remplacer les unités par des centimètres, des pieds ou des pouces en sélectionnant une option dans la liste déroulante.

Exporter un modèle SketchUp sous forme de fichier STL

Pour exporter un modèle SketchUp vers un fichier STL, assurez-vous d’abord que votre modèle répond aux recommandations de base pour l’impression 3D. Puis procédez comme suit :

  1. Sélectionnez Fichier > Exporter > Modèle 3D. La boîte de dialogue Exporter le modèle s'affiche.
  2. Naviguez jusqu'à l'emplacement où vous souhaitez enregistrer votre fichier exporté.
  3. (Facultatif) Dans la zone de texte appropriée, saisissez un nom pour le fichier STL exporté.
  4. Dans la liste déroulante Type de fichier, sélectionnez Fichier de STéréoLithographie (.stl).
  5. Dans la liste déroulante Format, sélectionnez Fichier de STéréoLithographie (.stl).
  6. (Facultatif) Cliquez sur le bouton Options et, dans la boîte de dialogue Options d’exportation STL, sélectionnez les options souhaitées pour le fichier STL exporté. (Consultez la liste suivante pour en savoir plus sur chaque option.) Cliquez sur OK lorsque vous avez terminé.
  7. Dans la boîte de dialogue Exporter le modèle, cliquez sur Exporter. SketchUp exporte votre modèle au format STL et enregistre le fichier à l'emplacement que vous avez spécifié.

La boîte de dialogue Options d’exportation STL vous permet de choisir différentes options concernant le rendu par SketchUp de votre fichier exporté :

  • Exporter uniquement la sélection actuelle : lorsque vous cochez cette case, SketchUp exporte uniquement la géométrie sélectionnée vers le fichier STL. Cette option est utile si vous souhaitez modéliser plusieurs éléments rassemblés dans un seul fichier de modèle SketchUp, tout en exportant chaque élément vers un fichier STL distinct imprimable en 3D.
  • Format de fichier : le format binaire est sélectionné par défaut dans la liste déroulante. L'autre option disponible est le format ASCII. Le format binaire est généralement préféré car il permet de réduire la taille des fichiers STL.
  • Inverser les coordonnées YZ : cette case est décochée par défaut. Si vous la sélectionnez, l'axe Y devient l'axe vertical au lieu de l'axe Z.
  • Unités STL : par défaut, le fichier STL est exporté avec les mêmes unités spécifiées dans le modèle. (Pour vérifier les unités par défaut de votre modèle, sélectionnez Fenêtre > Infos du modèle, puis cliquez sur Unités dans le menu de gauche.) Vous pouvez remplacer les unités du fichier STL exporté par des mètres, centimètres, millimètres, pieds ou pouces.