Ajouter des composants pré-dessinés et des composants dynamiques

Les composants SketchUp vous permettent de réutiliser des objets. Par exemple, la plupart des bâtiments ont au moins une porte et une fenêtre. Au lieu de modéliser ces objets courants, vous pouvez insérer un composant que quelqu'un d'autre a déjà créé.

Comme toute géométrie dans SketchUp, un composant est composé d'arêtes et de faces. Les arêtes et les faces font simplement partie d'un groupe de composants spéciaux. Vous pouvez également créer des composants pour réutiliser votre propre géométrie, un sujet abordé dans la section Développement de composants et de composants dynamiques.

Se familiariser avec les composants

Avant de commencer à insérer des composants, il faut savoir que chaque composant a une définition et une instance :

  • La définition d'un composant fixe la façon dont tous les composants d'un type donné apparaissent et se comportent dans la zone de dessin.
  • Lorsque vous insérez un composant dans un modèle, vous créez une instance du composant, basée sur sa définition.

Supposons que vous souhaitiez utiliser un composant pré-dessiné appelé « Demi-porte encadrée à deux panneaux ». La définition du composant décrit à quoi ressemble cette porte, et vous pouvez insérer dans votre modèle autant d'instances de ce composant que vous le souhaitez. Dans le modèle suivant, on observe deux instances de Demi-porte encadrée à deux panneaux. Plus loin dans l'article, la section Insérer des composants explique comment insérer une ou plusieurs instances de composant.

Astuce : toute cette affaire de définition et d'instances est importante, car lorsque vous modifiez des entités dans une instance de composant, vous modifiez également sa définition. Si vous changez la vitre de la porte, la vitre de toutes les instances de ce composant change. Remplacez les deux panneaux par un seul panneau, et toutes les portes de votre modèle auront également un seul panneau. Vous pouvez cependant redimensionner, faire pivoter et retourner un composant entier sans modifier les autres instances. La section Modifier des composants explique comment modifier les entités d'un composant ou tout un composant.

Vous pouvez également remplacer toutes les instances d'un composant par un autre composant. Si vous ou votre client décidez que vous n'aimez pas la demi-porte encadrée à deux panneaux, vous pouvez facilement remplacer ce composant par un autre. Pour plus de détails, reportez-vous à la section Remplacer des composants, plus loin dans cet article.

Les composants dynamiques ont encore plus de fonctionnalités que les composants classiques. Un composant dynamique comporte au moins l'un des éléments suivants :

  • Valeurs contraintes : par exemple, un composant dynamique porte d'armoire peut avoir un cadre limité à 7,6 cm. Que le panneau situé à l'intérieur du cadre mesure 30 x 60 cm ou 60 x 120 cm ou d'autres dimensions, le cadre conserve une largeur de 7,6 cm autour de la porte, comme illustré dans la figure suivante.
  • Éléments répétitifs : un composant dynamique peut avoir des sous-composants qui se répètent lorsque vous redimensionnez ce composant. Par exemple, un composant dynamique répétitif peut ajouter des marches à un escalier, des coussins à un canapé, des piquets à une clôture, des poteaux à une charpente, etc.
  • Valeurs configurables : un composant dynamique peut comporter un ensemble de valeurs prédéfini que vous pouvez configurer, comme la longueur d'un canapé ou l'espacement des piquets dans un composant clôture.
  • Fonctionnalités d'animation : un composant dynamique animé se déplace lorsque vous cliquez dessus avec l'outil Interagir (). Les composants dynamiques animés permettent à votre modèle d'avoir des portes et fenêtres qui s'ouvrent. Plus loin dans cet article, la section Interagir avec les composants explique comment ouvrir et fermer des composants animés.

Vous trouverez un échantillon de composants dans le volet Composants de SketchUp, mais la véritable mine de composants est 3D Warehouse, un outil en ligne permettant de rechercher et de télécharger des modèles 3D créés dans SketchUp. Cet article explique comment naviguer dans le volet Composants et rechercher des composants dans 3D Warehouse à l'aide d'outils disponibles dans SketchUp.

Une fois à l'aise avec l'insertion et la modification de composants, vous pourriez développer une préférence pour les composants que vous trouverez dans 3D Warehouse ou que vous créerez vous-même. Pour organiser et garder vos composants préférés à portée de main, vous pouvez créer des collections dans le volet Composants.

La vidéo suivante présente brièvement les composants - ce qu'ils sont, leurs différences avec les groupes et comment les modifier. Bien que cette vidéo fasse référence à une ancienne version de SketchUp, le comportement et les fonctionnalités fondamentaux des composants sont les mêmes dans les versions actuelles. Les sections suivantes expliquent les bases de l'insertion et de l'utilisation de composants et de composants dynamiques à travers des étapes détaillées.

Insérer des composants

Il existe trois manières d'insérer une instance de composant dans votre modèle :

  • Sélectionnez ou téléchargez un composant dans le volet Composants.
  • Importez un fichier SketchUp (avec l'extension .skp .
  • Faites glisser un fichier SketchUp depuis l'Explorateur de fichiers (Microsoft Windows) ou le Finder (Mac OS X) vers votre modèle.

Les composants pré-dessinés s'insèrent le plus souvent dans un modèle à partir du volet Composants. Pour ce faire, procédez comme suit :

  1. Sélectionnez Fenêtre > Composants. Cliquez sur la flèche orientée à droite, à côté du volet Composants de la palette Par défaut. Comme illustré dans la figure, le volet Composants s'ouvre par défaut sur la collection Échantillons de composants.

  2. Vous pouvez sélectionner l'un des composants de l'échantillon et passer à l'étape suivante. La sélection de l'échantillon est cependant limitée par rapport à la vaste sélection disponible sur 3D Warehouse. Pour essayer 3D Warehouse, saisissez un terme dans la barre de recherche de 3D Warehouse. Plus loin dans l'article, la section Chercher des composants présente d'autres façons d'effectuer une recherche dans 3D Warehouse. Pour parcourir les collections, cliquez sur la flèche orientée vers le bas à côté de l'icône Dans le modèle () et sélectionnez une collection. (Voir Organiser des collections de composants pour en savoir plus sur les collections existantes et apprendre à créer les vôtres.) Une fois que vous avez sélectionné ou téléchargé un composant, SketchUp le charge sur le curseur Déplacer.
  3. Cliquez dans la zone de dessin pour placer le composant dans votre modèle.

Astuce : si vous avez du mal à voir les composants dans le volet Composants, essayez de modifier vos options d'affichage. Cliquez sur le bouton Voir les options () et choisissez parmi Petites vignettes, Grandes vignettes, Détails ou Liste.

Remarque : il est possible qu'un composant que vous avez téléchargé sur 3D Warehouse soit modifié par son créateur. Pour mettre rapidement à jour votre version locale du composant, effectuez un clic droit sur le composant dans votre modèle et sélectionnez Recharger dans le menu contextuel qui s'affiche. Sur la page de présentation des composants qui s'affiche dans 3D Warehouse, vous pouvez télécharger la nouvelle version et ainsi recharger votre composant Dans le modèle avec la dernière version de 3D Warehouse. Si vous souhaitez conserver l'ancien composant mais ajouter également la nouvelle version à votre modèle, faites un clic droit sur le composant et sélectionnez Voir les détails. La page de présentation du composant s'affiche, mais au lieu de recharger l'ancien composant, la nouvelle version est ajoutée à votre modèle en tant que nouvelle instance de composant.

Si vous avez enregistré un modèle SketchUp sur votre disque dur, vous pouvez importer ce modèle en tant que composant dans un autre modèle. Pour ce faire, procédez comme suit :

  1. Ouvrez le modèle dans lequel vous souhaitez importer un fichier SketchUp.
  2. Sélectionnez Fichier > Importer.
  3. Dans la boîte de dialogue Ouvrir qui s'affiche, accédez au fichier SketchUp. Si vous ne voyez pas votre fichier, sélectionnez Fichiers SketchUp (.skp) dans la liste déroulante Types de fichiers.
  4. Sélectionnez le fichier SketchUp, puis cliquez sur Ouvrir. SketchUp charge le composant sur le curseur Déplacer.
  5. Cliquez dans la zone de dessin pour placer le composant dans votre modèle.

Lorsqu'un fichier SketchUp est déplacé à partir de l'Explorateur de fichiers (Microsoft Windows) ou du Finder (Mac OS X) vers un modèle ouvert, il est également chargé sur le curseur Déplacer. Il vous suffit de cliquer pour placer le composant dans votre modèle.

Astuce : lorsque votre composant est chargé sur le curseur de l'outil Déplacer, ce dernier est ancré au point d'origine de l'axe du composant. Si cela ne vous convient pas, modifiez l'emplacement de l'origine de l'axe du composant avant d'insérer le composant. Cela changera le point d’insertion par défaut. Voir Ajuster le point d'insertion d'un composant pour plus de détails.

Remplacer des composants

Les gens aiment voir différentes options et changent constamment d'avis. En cas d'indécision ou si votre projet n'est pas encore clair pour vous, sachez que vous pouvez facilement remplacer un composant par un autre. Voici comment procéder :

  1. Ajoutez le nouveau composant à votre modèle. Si vous n'avez nulle part où le placer, placez-le simplement dans une zone vide de votre modèle en suivant les étapes de la section précédente. En plaçant le composant quelque part dans votre modèle, vous vous assurez qu'il apparaît dans votre collection Dans le modèle. Même si vous le supprimez ensuite, le composant reste dans votre collection Dans le modèle jusqu'à ce que vous purgiez les composants inutilisés.
  2. Dans le volet Composants, cliquez sur l’icône Dans le modèle () pour afficher votre collection Dans le modèle.
  3. Sélectionnez le ou les composants que vous souhaitez remplacer.

    Astuce : pour sélectionner toutes les instances d'un composant, effectuez un clic droit sur le composant dans le volet Composants et choisissez Sélectionner les instances, comme illustré dans la figure.

  4. Dans le volet Composants, effectuez un clic droit sur le composant que vous souhaitez utiliser plutôt que sur le composant existant et choisissez Remplacer la sélection dans le menu contextuel. Dans cet exemple, il s'agit du composant Porte à grand panneau. Comme le montre la figure suivante, l'ancienne porte est maintenant remplacée par la nouvelle.

Astuce : les utilisateurs de SketchUp Pro disposent d'un outil supplémentaire : la commande Changer de composant, qui fonctionne avec des composants dynamiques.

PRO Pour changer une série de composants dynamiques dans SketchUp Pro, procédez comme suit :

  1. Sélectionnez les composants dynamiques que vous souhaitez remplacer. Les composants sont mis en évidence dans la fenêtre de dessin.
  2. Effectuez un clic droit sur un composant et sélectionnez Composants dynamiques > Changer de composant La boîte de dialogue Sélectionner un fichier SKP s'affiche alors.
  3. Sélectionnez le fichier SketchUp contenant le composant dynamique qui remplacera les composants actuellement sélectionnés.
  4. Cliquez sur le bouton Ouvrir. Le nouveau composant dynamique remplace les composants dynamiques précédemment sélectionnés.

Interagir avec les composants dynamiques

Votre capacité à interagir avec un composant dynamique dépend de ses variables. La figure suivante illustre un bâtiment simple avec deux instances d'un composant dynamique porte.

Pour activer l'animation du composant, sélectionnez l'outil Interagir () dans la barre d'outils Composants dynamiques ou sélectionnez Outils > Interagir. Lorsque vous cliquez sur la porte avec le curseur de l'outil Interagir, la porte s'ouvre, comme le montre la figure.

Ce composant dynamique possède également des valeurs configurables. Pour voir ces valeurs, cliquez sur l'outil Options du composant ( ) dans la barre d'outils Composants dynamiques ou sélectionnez Fenêtre > Options du composant . Dans la fenêtre Options du composant illustrée ci-dessous, vous pouvez choisir parmi les options prédéfinies concernant la largeur du cadre, la hauteur du cadre, le type de porte, etc.

Rechercher des composants

Vous pouvez rechercher des composants dans le volet Composants ou sur 3D Warehouse.

Dans l'onglet Sélectionner du volet Composants, vous pouvez utiliser les fonctionnalités suivantes pour parcourir ou rechercher des composants :

  • Icône Dans le modèle : cliquez sur l'icône Dans le modèle () pour voir la collection Dans le modèle, qui affiche tous les composants actuellement enregistrés avec votre modèle. Notez qu’il n’est pas nécessaire qu’un composant apparaisse dans votre modèle pour être enregistré avec celui-ci.
  • Menu déroulant Dans le modèle : cliquez sur la flèche orientée vers le bas à côté de l'icône Dans le modèle. Dans la liste qui s'affiche, vous pouvez sélectionner des collections prédéfinies comme Architecture, Paysage, Personnes et Transport. Ce menu peut également afficher les collections que vous avez créées, celles que vous avez désignées comme favorites ou que vous avez consultées récemment. Plus loin dans l'article, la section Organiser les collections de composants explique comment créer et gérer des collections.

    Astuce : si votre modèle est géolocalisé, le volet Composants vous permet de rechercher des modèles à proximité. Recherchez des composants dans la barre de recherche. Puis dans le menu déroulant Dans le modèle, sélectionnez le filtre Modèles à proximité pour afficher les modèles à proximité dans vos résultats de recherche.
  • Barre de recherche de 3D Warehouse : saisissez un terme de recherche dans la barre et appuyez sur Entrée (Microsoft Windows) ou Retour (Mac OS X) pour afficher une liste de composants de 3D Warehouse. Votre ordinateur doit être connecté à Internet pour se connecter à 3D Warehouse. Si votre recherche affiche plusieurs résultats, vous pouvez cliquer sur les flèches situées en bas du volet Composants pour afficher plus de résultats. Il peut être plus facile d'effectuer vos recherches 3D Warehouse dans une grande fenêtre de navigateur plutôt que dans le volet Composants, trop petit pour afficher beaucoup de détails dans les vignettes de composants.

Pour accéder à 3D Warehouse directement à partir de SketchUp, cliquez sur l'outil Obtenir des modèles (), accessible depuis les sections suivantes de l'interface de SketchUp :

  • Barre d'outils Premiers pas
  • Barre d'outils Boutique

Vous pouvez également sélectionner Fichier > 3D Warehouse > Obtenir des modèles.

Quelle que soit la méthode utilisée, 3D Warehouse s'ouvre comme dans la figure suivante. Dans l'écran d'ouverture, vous pouvez parcourir les modèles, catalogues de fabricants et collections proposés, ainsi que les modèles récents. Mais il est généralement préférable d'utiliser la barre de recherche en haut de l'écran. Saisissez votre recherche et cliquez sur le bouton Rechercher.

Astuce : commencez par le terme de recherche le plus précis. Par exemple, si vous recherchez une fenêtre comme composant dynamique avec un plan de coupe perçant une ouverture dans votre modèle, saisissez un terme de recherche tel que « composant dynamique fenêtre ouverture face ». Élargissez ensuite ce terme de recherche si vous ne trouvez pas de composant qui vous convient.

Lorsqu'un résultat vous intéresse, cliquez dessus pour ouvrir sa page de présentation. Cliquez sur le bouton Télécharger situé en haut à droite pour télécharger le composant dans votre modèle. Revenez ensuite à SketchUp, où le composant est chargé sur le curseur Déplacer. Cliquez dans la zone de dessin pour placer le composant dans votre modèle.

Ajuster le point d'insertion d'un composant

Chaque composant a son propre point d’origine de l’axe qui détermine son point d’insertion, ou le point chargé sur le curseur Déplacer lorsque vous placez un composant dans votre modèle.

Si le composant a la forme d'une boîte (comme une commode, une armoire ou la Table des destins mésopotamienne), le point d'insertion est généralement le coin avant inférieur gauche, comme le montre la figure. Ce placement fonctionne parfaitement, sauf si vous devez placer le composant contre d'autres composants ou contourner la géométrie existante d'une autre manière.

Quelles que soient vos raisons de déplacer le point d'insertion, voici comment réinitialiser l'origine de l'axe d'un composant :

  1. Sélectionnez le composant dans votre modèle.
  2. Effectuez un clic droit sur le composant et sélectionnez Modifier les axes.
  3. Avec le curseur de l'outil Axes qui s'affiche, réinitialisez l'origine de l'axe. Pour savoir comment utiliser l'outil Axes, consultez la page Ajuster des axes de dessin. La seule différence est que vous définissez l'origine de l'axe pour un composant, et non pour l'ensemble du modèle.

Astuce : après avoir placé un composant dans votre modèle, vous pouvez le déplacer en utilisant le point de votre choix. Sélectionnez simplement l’outil Déplacer (), cliquez sur le point que vous souhaitez utiliser pour déplacer le composant, puis cliquez à nouveau pour placer le composant. Par exemple, après avoir placé un composant meuble dans votre modèle, vous devrez peut-être déplacer ce meuble par son milieu pour le faire glisser et le placer à côté des meubles existants. Consultez la page Déplacer des entités pour plus de détails sur le déplacement d'entités avec l’outil Déplacer.

Modifier des composants

Vous pouvez modifier tout un composant ou des entités individuelles au sein d'un composant.

L'édition ou la modification de toute une instance de composant se répercute uniquement sur cette instance de composant, et non sur la définition du composant ou d’autres instances. Voici quelques modifications que vous pouvez apporter à l'ensemble d'un composant :

  • Redimensionnement : le redimensionnement de tout un composant modifie la taille de cette instance du composant, et non de sa définition, ce qui vous permet d'avoir dans votre modèle des instances de différentes tailles pour un même composant. Un composant peut devenir incliné si vous le redimensionnez dans plusieurs directions. Pour réinitialiser la taille et l’inclinaison d’un composant, faites un clic droit sur celui-ci et sélectionnez Réinitialiser la taille ou Réinitialiser l’inclinaison. Pour redimensionner un composant, utilisez l'outil Mettre à l'échelle() comme expliqué dans l'article Modifier la taille d'une partie ou de l'intégralité d'un modèle.
  • Retournement : vous pouvez retourner (ou répliquer) un composant le long d'un axe. Faites un clic droit sur le composant, sélectionnez Retourner et sélectionnez un axe (Partie en rouge du composant, Partie en vert du composant ou Partie en bleu du composant).
  • Rotation : vous pouvez faire pivoter un composant à l'aide de l'outil Rotation () ou Déplacer (). L’outil Rotation offre plus de contrôle sur le plan et le centre de rotation.

La page Retournement et rotation explique comment retourner et faire pivoter une géométrie. Pour faire pivoter un composant avec l’outil Déplacer, balayez l’outil Déplacer au-dessus d'une face perpendiculaire à l’axe de rotation souhaité jusqu’à ce que quatre poignées de rotation et un rapporteur apparaissent sur la face, comme illustré dans la figure suivante. Cliquez ensuite sur une poignée de rotation et faites pivoter le composant.

La modification d'entités au sein d'un composant change la définition du composant, et donc toutes les autres instances de ce composant dans votre modèle. Pour en savoir plus sur les techniques plus avancées impliquées dans la modification d'une définition de composant, consultez Modifier un composant dans la section Développement de composants et de composants dynamiques.

Vous pouvez également enregistrer les modifications apportées à votre composant, rétablir le fichier d'origine d'un composant modifié ou éclater le composant :

  • Pour enregistrer un composant modifié en tant que fichier distinct avec un nouveau nom, sélectionnez le composant, cliquez dessus avec le bouton droit et sélectionnez Enregistrer sous dans le menu qui s'affiche. Accédez à l'emplacement où vous souhaitez enregistrer le fichier .skp, saisissez un nouveau nom, puis cliquez sur Enregistrer.
  • Pour recharger un composant à partir de son fichier d'origine et remplacer toutes les modifications, faites un clic droit sur le composant et sélectionnez Recharger.
  • Pour séparer les entités d'un composant, sélectionnez votre composant puis Modifier > Instance de composant > Éclater dans la barre de menu. Vous pouvez aussi faire un clic droit sur le composant et sélectionner Éclater dans le menu qui s'affiche. Votre composant n'est plus un composant avec un champ de force spécial. Il revient à son ancienne géométrie simple, un peu comme un capitaine retournant à la vie civile.

Remarque : vous pouvez modifier les propriétés d'un composant, en définissant par exemple s'il perce une ouverture dans une face, ou configurer les variables d'un composant dynamique. Ces tâches avancées étant étroitement liées à la création de composants, vous apprendrez comment travailler avec ces propriétés dans l'article Développer vos propres composants ou composants dynamiques.

Organiser des collections de composants

Dans le volet Composants de SketchUp, les collections vous permettent d'organiser les composants.

La collection Dans le modèle est une collection spéciale occupant une place importante dans le volet Composants. Elle contient tous les composants enregistrés avec votre modèle, qu'ils apparaissent ou non actuellement dans celui-ci. Faites un clic droit sur un composant de cette collection pour afficher les commandes non disponibles dans d'autres collections, telles que Sélectionner des instances, Recharger, etc. Pour afficher votre collection Dans le modèle, cliquez sur l'icône Dans le modèle (). Si vous avez inséré plusieurs composants que vous n'avez plus besoin d'enregistrer avec votre modèle, cliquez sur la flèche de menu déroulant () et sélectionnez Purger les éléments inutilisés.

SketchUp contient quelques collections prédéfinies, comme Architecture, Paysage, Construction, etc. Pour trouver ces collections, cliquez sur la flèche orientée vers le bas à côté de l'icône Dans le modèle, comme illustré dans la figure suivante.

Astuce : en créant vos propres collections, vous pouvez organiser les composants comme vous le souhaitez. Si vous utilisez certains composants tout le temps, créez une collection Mes composants favoris. Si vous utilisez des composants spécifiques pour un client ou projet donné, organisez-les dans une seule collection où ils seront facilement accessibles.

Les étapes suivantes expliquent comment créer une collection de composants pour le système d'exploitation que vous avez sélectionné (Microsoft Windows ou Mac OS X) :

  1. Sélectionnez Fenêtre > Composants pour ouvrir le volet Composants. Ouvrez le volet Composants dans la palette Par défaut.
  2. Cliquez sur la flèche de menu déroulant () et sélectionnez Ouvrir ou Créer une collection locale.
  3. Dans la boîte de dialogue Rechercher un dossierSélectionner un dossier qui s'affiche, accédez au dossier où vous souhaitez enregistrer votre collection. Pour créer un sous-dossier pour la collection, cliquez sur le bouton Créer un nouveau dossier et créez le dossier.
  4. Sélectionnez le dossier dans lequel vous souhaitez enregistrer la collection de composants, puis cliquez sur OKSélectionner le dossier. Vous verrez une collection vide dans l'onglet Sélectionner du volet Composants. Si le dossier vide n'apparaît pas, cliquez sur la flèche de la liste déroulante Dans le modèle et sélectionnez la collection correspondant à votre dossier dans le menu.
  5. Cliquez sur l'icône Afficher le volet de sélection secondaire ().
  6. Dans le volet de sélection secondaire, allez à un composant que vous souhaitez ajouter à votre collection et faites-le glisser dans la collection vide. Dans la figure suivante, le composant Vaisseau de classe Galaxie de la collection Dans le modèle (en bas) a été ajouté à la nouvelle collection Composants (en haut).
  7. Continuez à parcourir les composants du volet de sélection secondaire et à les ajouter à votre nouvelle collection jusqu'à ce que celle-ci soit terminée.

  1. Sélectionnez Fenêtre > ComposantsOuvrez la boîte de dialogue Composants dans la Palette Par défaut pour ouvrir le volet Composants.
  2. Cliquez sur la flèche de menu déroulant () et sélectionnez Créer une collection.
  3. Dans la boîte de dialogue Enregistrer qui s'affiche, accédez au dossier où vous souhaitez enregistrer votre collection. Pour créer un sous-dossier pour la collection, cliquez sur le bouton Nouveau dossier et créez le dossier.
  4. Sélectionnez le dossier dans lequel vous souhaitez enregistrer la collection de composants, puis cliquez sur Enregistrer. Vous verrez une collection vide dans l'onglet Sélectionner du volet Composants.
  5. Enregistrez chaque composant que vous souhaitez ajouter à votre collection au format .skp dans le dossier que vous avez sélectionné à l'étape précédente. Si le composant se trouve dans votre modèle, cliquez dessus avec le bouton droit et sélectionnez Enregistrer sous. La figure suivante montre le composant Vaisseau de classe Galaxie enregistré dans une collection appelée Composants favoris.

Astuce : lorsque vous avez quelques collections, vous pouvez les ajouter à une liste de collections favorites qui apparaît toujours dans le menu déroulant Dans le modèle. Tout d'abord, affichez la collection dans le volet Composants : si vous avez récemment utilisé la collection, vous pouvez sélectionner son nom dans le menu déroulant Dans le modèle. Si la collection n'y figure pas, cliquez sur la flèche de menu déroulant et sélectionnez Ouvrir ou créer une collection locale (Microsoft Windows) ou Ouvrir une collection locale (Mac OS X). Lorsque votre collection s'affiche dans le volet Composants, cliquez sur la flèche de menu déroulant et sélectionnez Ajouter aux favoris ou Supprimer des favoris.

Recueillir des informations sur les composants

Plusieurs outils de SketchUp permettent de trouver d'importantes informations sur les composants :

  • La fenêtre Infos sur l'entité est le plus simple d'entre eux. Pour l’ouvrir, faites un clic droit sur un composant et sélectionnez Infos sur l’entité. Ou sélectionnez un composant, puis Fenêtre > Infos sur l'entité et ouvrez la boîte de dialogue Infos sur l'entité dans la palette Par défaut. Si votre entité est bien un composant, vous verrez Composant s'afficher en haut à gauche et le nombre d'instances du composant sélectionné apparaître dans votre modèle.
  • Dans le volet Composants, le nom, la vignette et la description du composant se trouvent en haut. Cliquez sur l’onglet Statistiques pour afficher un rapport indiquant combien d’éléments tels que des faces, des arêtes et des lignes de construction apparaissent dans le composant. Sélectionnez Toutes les géométries dans la liste déroulante pour afficher les statistiques de toutes les géométries du composant ou du groupe. Vous pouvez également sélectionner Composants dans la liste déroulante pour afficher les statistiques de tous les composants au sein du composant. Enfin, cliquez sur Développer pour afficher les composants et groupes imbriqués dans le composant ou le groupe actuellement sélectionné.