Effacer et annuler

Tout le monde fait des erreurs. Dans SketchUp, vous pouvez corriger les erreurs avec la commande Undo (Annuler) ou l'outil Erase (Effacer).

Utilisation de la commande Annuler

La commande Annuler annule votre dernière action. Par exemple :

  • Si vous dessinez une ligne et que vous l'annulez, la ligne disparaîtra.
  • Si vous essayez de copier une géométrie complexe avec l'outil Move (Déplacer) et l'étirer accidentellement à la place, la commande Annuler peut remettre les choses comme elles étaient.

La commande Annuler est disponible dans le menu Edit (Modifier). Vous verrez le mot Undo avec une description de la dernière action que vous avez effectuée. Par exemple, si vous avez utilisé l'outil Push/Pull (Pousser/Tirer) pour la dernière fois, l'option Undo Push/Pull (Annuler Pousser/Tirer) apparaît dans le menu Edit.


Le raccourci clavier par défaut de la commande Undo est Alt+Touche retour. Toutefois, Ctrl+Z (Microsoft Windows) ou Commande+Z (macOS) fonctionnent également.

Tout ce que vous annulez, vous pouvez le refaire. Lorsque vous annulez une action, l'option Redo that action (Rétablir cette action) apparaît dans le menu Modifier.

Effacer la géométrie

Vous pouvez effacer la géométrie de votre modèle à l'aide de l'outil Effacer ou de la commande Erase context (Effacer le contexte).

L'outil Effacer peut vous aider à supprimer, adoucir, grossir ou masquer des parties de votre modèle, quel que soit le moment où vous l'avez créé. Pour l'instant, nous allons nous concentrer sur la suppression de la géométrie. Consultez cet article pour plus d'informations sur l'utilisation des autres fonctions de la gomme.

Vous pouvez trouver l'outil Effacer de SketchUp () à différents endroits :

  • Barre d'outils Getting Started (Premiers pas)
  • Barre d'outils Drawing (Dessin)
  • Barre d'outils Large Tool Set (Gros outils)
  • Barre d'outils principale
  • Palette d’outils (macOS uniquement)

Lorsque vous souhaitez supprimer des parties de votre modèle, voici comment l'outil Effacer peut vous aider :

  • Sélectionnez l'outil Effacer dans une barre d'outils et cliquez sur un bord avec le curseur de l'outil Effacer. Vous allez effacer ce bord et toutes les faces qu'il délimite. Astuce : L'outil Effacer ne vous permet pas d'effacer des faces. Techniquement, les faces sont effacées lorsque vous effacez les arêtes qui les délimitent, ouvrez et remodelez votre géométrie. Voir l'introduction aux bases du dessin pour plus d'informations sur le fonctionnement du logiciel.
  • Cliquez et faites glisser le curseur sur plusieurs lignes avec l'outil Effacer. Toute ligne surlignée en bleu sera effacée lorsque vous relâchez le bouton de la souris.

La commande Effacer le contexte vous aide à supprimer la géométrie sélectionnée, y compris les faces. Pour utiliser la commande Effacer le contexte :

  • Cliquez avec le bouton droit sur une face ou un bord et sélectionnez Effacer dans le menu contextuel.
  • Pour supprimer plusieurs arêtes et faces en même temps, utilisez l’outil Select (Sélection) pour sélectionner la géométrie, puis cliquez sur votre sélection en contexte et choisissez Effacer.

Adoucir, lisser et masquer des éléments géométriques

Le monde réel n'est pas uniquement composé de arêtes affûtées et d'angles saillants, et votre modèle ne devrait pas l'être non plus. SketchUp fournit les outils dont vous avez besoin pour adoucir et lisser les arêtes, ou même masquer la géométrie, sans compromettre l'intégrité structurelle de votre modèle.

Astuce : l’adoucissement et le lissage des arêtes modifient leur visibilité et peuvent rendre votre modèle plus réaliste tout en atténuant sa géométrie. Limiter les éléments géométriques de votre modèle peut également améliorer les performances de votre ordinateur.

Dans cette introduction à la géométrie douce, lisse et cachée, nous allons parler de la façon dont cela est fait et des types d'entités que vous pouvez créer. Après avoir passé en revue les principes de base, nous vous donnerons même quelques conseils pour améliorer l'apparence de votre modèle et l'efficacité du modelage.

Table des matières
  1. Comprendre les propriétés des arêtes
  2. Adoucir et lisser les arêtes en même temps
  3. Masquer les éléments géométriques
  4. Afficher les éléments géométriques

Comprendre les propriétés des arêtes

Dans SketchUp, vous pouvez ajouter les propriétés suivantes aux arêtes de votre modèle, dans diverses combinaisons, vous permettant de contrôler leur apparence :

  1. Lisse - Le lissage d’un bord ajoute de l’ombrage, ce qui rend les faces plus lisses. Lorsqu'il est utilisé seul, le bord reste visible.
  2. Doux - L'adoucissement d'un bord le masque et toutes les faces adjacentes deviennent une entité de surface. Les entités de surface joignent deux ou plusieurs faces de façon à ce qu'elles paraissent arrondies. Les entités de surface agissent comme des entités simples lorsqu'elles sont sélectionnées, mais conservent toutes les inférences de la géométrie dont elles sont issues.
  3. Masquer - Masquer un bord le rend invisible sans créer une entité de surface.

Adoucir et lisser les arêtes en même temps

Dans SketchUp, adoucir et lisser les arêtes va de pair. C'est pourquoi l'outil Effacer et la boîte de dialogue Soften Edges (Adoucir les arêtes) appliquent ces propriétés ensemble.

Conseil : utilisez l'outil Effacer pour lisser et adoucir rapidement vos arêtes. Ouvrez la boîte de dialogue Adoucir les arêtes lorsque vous avez besoin d'un contrôle plus précis.

Pour adoucir et lisser les arêtes avec l'outil Effacer :

  1. Sélectionnez l'outil Effacer () ou appuyez sur la touche E.
  2. Appuyez sur la touche Ctrl (Microsoft Windows) ou sur la touche Option (macOS) pour activer ou désactiver l'option Lisser les arêtes, puis effacez ces lignes comme vous le feriez pour les supprimer.
  3. Si vous faites une erreur ou changez d'avis, touchez l'Alt (Microsoft Windows) ou la Commande (macOS) et cliquez sur les arêtes pour annuler l'adoucissement et le lissage.

Pour adoucir et lisser avec la boîte de dialogue Adoucir les arêtes, procédez comme suit :

  1. Utilisez l'outil Sélectionner et mettez en surbrillance les arêtes que vous souhaitez adoucir et lisser. (Reportez-vous à la rubrique Sélection de la géométrie pour obtenir des conseils et des techniques de sélection.)
  2. Ouvrez la boîte de dialogue Adoucir les arêtes à l'aide de l'une des méthodes suivantes :
    • Sous macOS, ouvrez le menu Fenêtre et sélectionnez Adoucir les arêtes.
    • Dans Windows, ouvrez le menu Fenêtre, sélectionnez Barre d’état par défaut, puis Adoucir les arêtes.
    • Faites un clic droit sur votre sélection et choisissez Adoucir/Lisser les arêtes.
    • Cliquez et faites glisser le curseur sur l'option intitulé Angle Between Normals (Angle entre les normales). Ce curseur définit la taille maximale de tous les angles qui seront lissés ou adoucis. Plus le réglage est élevé, plus vous êtes susceptible de lisser ou d'adoucir les angles. Dans l'exemple, le curseur est défini sur 20 degrés, ce qui lisse et adoucit la plupart de la surface de la roche.

    • (Facultatif) La case Smooth normals (Lisser les normales) est cochée par défaut. Si vous ne souhaitez pas obtenir l'effet d'ombrage qui donne un aspect lisse à vos arêtes, décochez cette case.
    • (Facultatif) Cochez la case Soften coplanar (Adoucir coplanaire) pour adoucir les arêtes entre les surfaces coplanaires, ce qui revient presque à les effacer. Dans l'exemple de roche, la sélection de cette case n'a pas beaucoup d'impact sur la roche, car peu de ses faces (le cas échéant) sont sur le même plan.

Pour vérifier ou modifier les propriétés appliquées à une arête, cliquez avec le bouton droit et choisissez Entity Info (Informations sur l'entité). Vous verrez le type d'entité dans le coin supérieur gauche et pourrez cocher ou décocher les cases Doux et Lisse. Sélectionnez une face, et vous pouvez voir s'il s'agit d'une entité de surface ou d'un autre type de géométrie.

Conseil : Les arêtes adoucies et lissées donnent à la géométrie de base une apparence soignée. Dans un modèle complexe, le fait de s'appuyer sur des arêtes douces et lisses peut considérablement alléger la charge de la mémoire de votre ordinateur. Par exemple, vous pouvez créer la console affichée dans l'illustration en créant un dessin 2D dans la forme des arêtes sélectionnées. Extrudez ensuite la face dans la forme 3D illustrée ici. La forme est assez basique, mais les arêtes adoucies et lissées mettent en valeur les dimensions et la forme du modèle. En outre, si vous dessinez et extrudez des arcs, des cercles ou des curves, ces entités appliquent par défaut des arêtes douces et lisses.

Masquer les éléments géométriques

Lorsque vous dessinez un modèle, vous ne voulez pas nécessairement qu'une ligne marque chaque arête de votre modèle. Adoucir les arêtes masque les lignes, mais crée également une entité de surface, ce qui signifie que vous ne pouvez appliquer qu'un seul matériau à chaque face de l'entité de surface. Si vous souhaitez masquer une ligne disgracieuse sans créer une entité de surface, utilisez la fonction Hide (Masquer). Vous pouvez masquer des lignes, des faces et toute entité SketchUp.

Procédez comme suit pour masquer une ligne ou un élément géométrique :

  1. Sélectionnez l'élément géométrique à masquer.
  2. Cliquez avec le bouton droit sur la sélection et choisissez Masquer dans le menu contextuel qui s'affiche, comme indiqué dans l'illustration. Vous pouvez également ouvrir le menu Modifier et sélectionner Masquer. Même si elle est toujours là, la géométrie sélectionnée disparaît de la vue comme un fantôme dans la machine.

La géométrie masquée ne peut pas être sélectionnée. Pour rendre la géométrie masquée sélectionnable, vous devez afficher la géométrie masquée ou la démasquer. Reportez-vous à la rubrique Affichage des arêtes masquées pour plus d'informations.

Conseil : dans SketchUp, les styles changent l'apparence de l'ensemble de votre modèle. Il vous suffit de cliquer sur un style prédéfini. Si vous masquez des arêtes ou une géométrie pour voir à travers votre modèle ou pour modifier l'apparence de votre modèle dans son ensemble, déterminez si les styles offrent un moyen plus simple d'y parvenir.

Affichage des éléments géométriques et des objets masqués

Dans SketchUp, toute géométrie masquée est toujours là. Vous ne pouvez tout simplement pas la voir ou la sélectionner.

Pour afficher la ou les géométries masquées, mais les garder masquées, ouvrez le menu View (Affichage) et sélectionnez Hidden Geometry (Géométrie masquée) ou Hidden Objects (Objets masqués). Toutes les entités masquées apparaissent dans un motif en pointillé (comme illustré sur la figure), ce qui vous permet de les sélectionner. Sélectionnez à nouveau Géométrie masquée ou Objets masqués pour effacer l'option et faire disparaître le modèle ou l'objet en pointillé.

Pour faire passer la géométrie de masquée à visible, vous devez la démasquer. Sélectionnez la géométrie masquée, cliquez avec le bouton droit sur la sélection et choisissez Unhide (Démasquer). (L'élément de menu Masquer se transforme en Démasquer lorsque la géométrie sélectionnée est masquée.)