Színek és textúrák hozzáadása anyagokkal

A modellek részletességének és valósághűségének növelése érdekében a SketchUp lehetővé teszi anyagok festését a felületekre. Az anyagok lényegében festékek, amelyek egy színnel és opcionális textúrával rendelkeznek (egy képfájlban meghatározva). Például a következő ábrán a tetőfedő anyag kék színű, és olyan textúrával rendelkezik, amely a fém héjazatot utánozza. A burkolat és a fű szintén színnel és textúrával rendelkező anyagok.

Miután az ilyen anyagokat hozzáadta a modelljéhez, a SketchUp anyagainak speciális képességei a következők bármelyikének végrehajtásában segíthetnek:

  • Az egyik anyag cseréje egy másikra: tegyük fel, hogy fémtetőt szeretne megjeleníteni zsindely helyett. A zsindely tetőfedő anyagot gyorsan és egyszerűen lecserélheti.
  • Az anyag szerkesztése: mivel a szín és a textúra elkülönül egymástól, egymástól függetlenül is megváltoztathatja őket. Megváltoztathatja például a burkolat színét (milyen lenne a sárga?), ugyanakkor megtarthatja ugyanazt a textúrát. Szerkesztheti az anyag átlátszatlanságát is, amely azt határozza meg, hogy mennyire átlátszatlan vagy átlátszó az adott anyag.
  • Szükséges anyagmennyiség kiszámítása: a SketchUp meg tudja mondani az összes zsindely vagy a deszkaburkolat területét. Természetesen ahhoz, hogy ez a számítás jelentsen is valamit, pontos modellt kell készítenie, hogy a számok tükrözzék a modell tényleges méretét.
Tipp: a SketchUp számos anyagból álló gyűjteményt tartalmaz: szőnyeg, csempe, talajtakaró, üveg, fa stb. Ha azonban a szükséges anyag nem áll rendelkezésre, létrehozhatja saját anyagát. Ez a funkció akkor különösen hasznos, ha Ön lakberendező vagy építész, akinek pontosan meg kell mutatnia ügyfeleinek a felületeket.

A SketchUp felületen az anyagok modellezése a Paint Bucket (Festékes vödör) eszközzel () és a Materials (Anyagok) panellel (Microsoft Windows) vagy a Colors (Színek) panellel (macOS) végezhető. A Materials (Anyagok) vagy Colors (Színek) panel az anyagok megtekintését, kezelését és rendezését is lehetővé teszi. A Materials (Anyagok) vagy Colors (Színek) panel nyomon követi a modellben található anyagokat, és itt lehet létrehozni egyedi anyaggyűjteményeket a projektekhez vagy munkafolyamatokhoz.

Megjegyzés: ha a Microsoft Windows és a macOS operációs rendszert futtató számítógépek között vált, vegye figyelembe, hogy a Materials (Anyagok) panel és a Colors (Színek) panel interfész az operációs rendszertől függően eltér. A következő bekezdésekben a Microsoft Windows vagy a macOS rendszerre vonatkozó utasítások láthatók, attól függően, hogy melyik operációs rendszert választotta bármelyik oldal legördülő listájából a Súgóközpontban.

A következő videóban bemutatjuk, hogyan lehet alkalmazni az anyagokat és hogyan lehet néhány általános módosítást végrehajtani, például egyik anyagot kicserélni egy másikra. Az anyagok használatát bemutató részletes lépésekért tekintse meg a következő bekezdéseket.

Anyagok alkalmazása

Nagyon egyszerű a modellre alkalmazni az anyagokat: válasszon ki egy felületet vagy felületeket, majd válassza ki a kívánt anyagot. Ha csoportokat vagy összetevőket fest, nézze meg az ennek a bekezdésnek a végén található tippeket, amelyek még könnyebbé tehetik az anyagok felvitelét.

Az anyagokat a Paint Bucket (Festékes vödör) eszközzel viheti fel a modelljére (), amely a SketchUp felület következő pontján található:

    Windows
  • Első lépések eszköztár
  • Nagy eszközkészlet eszköztár
  • Fő eszköztár
  • Tools (Eszközök) > Paint Bucket (Festékes vödör) a menüsávban

Az anyagok alkalmazásának megkezdéséhez kövesse az alábbi lépéseket:

  1. Válassza a Paint Bucket (Festékes vödör) eszközt ().
  2. A megnyíló Materials (Anyagok) panelen kattintson a Select (Kiválasztás) fülre. Ha a Materials (Anyagok) panel nem nyílik meg a tálcán, akkor a párbeszédpanel egy rejtett tálcában lehet. Ebben az esetben vigye az egérmutatót a rejtett tálca fülére. Ez kinagyítja a tálcát. Ezután már megnyithatja az Anyagok panelt a tálcán.
  3. A legördülő listából válassza ki az anyaggyűjteményt.
  4. Kattintson a használni kívánt anyagra.
    Tipp: ha olyan anyagból szeretne mintát venni, amely már szerepel a modelljében, tartsa lenyomva az Alt billentyűt, hogy ideiglenesen átváltson egy Sample (Minta) eszközre. A Minta eszköz pipetta kurzorával kattintson arra a felületre, amelynek anyagából mintát szeretne venni. Engedje fel az Alt billentyűt a Paint Bucket (Festékes vödör) eszközhöz való visszatéréshez.
  5. Visszatérve a rajzolófelületre kattintson arra a felületre vagy felületekre, amelyeken alkalmazni kívánja az anyagot.

Anyagok alkalmazása a SketchUp for Windows-ban

Tipp: az alapértelmezett színek visszaállításához kövesse az előző lépéseket, de ahelyett, hogy egy anyagra kattintana, kattintson a Set Material to Paint with Default (Anyag beállítása alapértelmezett festésre) () lehetőségre a jobb felső sarokban, és az alapértelmezett színek alkalmazásához kattintson a modell egyik felületére.

    MacOS
  • Nagy eszközkészlet eszköztár
  • Tools (Eszközök) > Paint Bucket (Festékes vödör) a menüsávban
  • Eszközpaletta

Az anyagok alkalmazásának megkezdéséhez kövesse az alábbi lépéseket:

  1. Válassza a Paint Bucket (Festékes vödör) eszközt (). A megjelenő Colors (Színek) panelen kiválaszthat egy színt a négy színválasztó fül egyikén, vagy használhatja az anyaggyűjteményeket.
  2. Az anyaggyűjteményekben való böngészéshez kattintson a tégla ikonnal rendelkező Texture Palettes (Textúrapaletták) fülre. (A színválasztásra szolgáló többi fül használatával kapcsolatos további részletekért lásd a Színek keverése a színválasztóban c. részt.)
  3. A legördülő listából válassza ki az anyaggyűjteményt. A következő ábrán a Roofing (Tetőfedő) gyűjtemény van kiválasztva.
  4. Kattintson a modelljén alkalmazni kívánt anyagra.
    Tipp: ha olyan anyagból szeretne mintát venni, amely már szerepel a modelljében, kattintson a Pipetta eszközre a Texture Palettes (Textúra paletták) lap alján. A nagy kör kurzorral kattintson arra a felületre, amelynek anyagából mintát szeretne venni. Ez betölti az anyagot a mintadarabra, és újra megjelenik a Festékes vödör kurzor.
  5. Visszatérve a rajzolófelületre kattintson arra a felületre vagy felületekre, amelyeken alkalmazni kívánja az anyagot.

Alternatív megoldásként kattintson rá és húzza az anyagmintát a Texture Palettes (Textúra paletták) fül fő területéről egy felületre a modelljén. (Nem húzhatja el a mintadarabot a macOS Colors (Színek) panel alján lévő palettáról. A mentett színminták használatával kapcsolatos részletekért lásd a Színek keverése a Színválasztóban c. részt.)

Tipp: az alapértelmezett színekre való visszatéréshez válassza a Default Swatch (Alapértelmezett minta) lehetőséget a Colors In Model (Színek a modellben) gyűjteményben.

Tipp: ha a kiválasztott anyag nem jelenik meg a felületre kattintás után, akkor a modell valószínűleg olyan stílust használ, amely nem jeleníti meg a textúrákat. Ennek ellenőrzéséhez nyissa meg a Styles (Stílusok) panelt, válassza az Edit (Szerkesztés) fület, és kattintson a Face Settings (Felületbeállítások) ikonra. A Style (Stílus) területen gondoskodjon arról, hogy a Display Shaded Using Textures (Árnyékolt kijelző textúrák használatával) opció ki legyen jelölve.

Ha a stílusai textúrákat mutatnak, előfordulhat, hogy a számítógép nem rendelkezik elegendő memóriával a modell anyagainak megjelenítéséhez. Segítségért lásd: Probléma kijavítása a SketchUp-ban.

Több felületet és élt is festhet egyszerre. Ehhez használja a Select (Kiválasztás) eszközt () a festeni kívánt élek és felületek kiválasztásához. Ezután váltson a Paint Bucket (Festékes vödör) eszközre, és alkalmazzon egy anyagot. (A Geometria kiválasztása rész tippeket ad a kiválasztáshoz.)

Ha egyszerre több felületre visz fel anyagokat, ne feledje a következőket:

  • A felületeknek két oldala van: elülső és hátsó. Lefestheti az összes kijelölt felület elejét vagy hátulját, de ezeket nem kombinálhatja. A festett oldalt az az oldal határozza meg, amelyre a Festékes vödör kurzorral rákattint. A következő ábrán egy felület elejére kattintva a kiválasztásban lévő összes elülső oldalt lefesti a program, annak ellenére, hogy két elülső és két hátsó felület látható.
  • Szabályozza, hogyan nézzenek ki a hátsó élek egy stílussal. Ha kiválaszt egy felületet és az összes élt, és lefesti a felület elejét, akkor az összes kiválasztott élt is lefesti a program. Ha azonban a hátsó felületeket festi, egyik élt sem festi le a program. A hátsó élek anyagokkal való elegyítéséhez nyissa meg a Styles (Stílusok) panelt, kattintson az Edit (Szerkesztés) fülre, kattintson az Edge Settings (Élbeállítások) ikonra, és válassza a Color (Szín) legördülő listából a By Material (Anyag szerint) lehetőséget.

Anyagokat alkalmazhat egészében egy csoportra vagy összetevőre is, vagy a csoporton vagy összetevőn belüli meghatározott geometriára:

  • Egy egész csoport vagy összetevő festéséhez jelöljön ki és alkalmazzon egy anyagot. Ha kiválaszt egy csoportot vagy összetevőt, és alkalmaz egy anyagot, csak az alapértelmezett anyagú felületeket festi le a program.
  • Egy geometria lefestéséhez a csoporton vagy összetevőn belül kattintson duplán a környezeti menü megnyitásához. Ezután válassza ki az egy anyaggal lefesteni kívánt felületeket.

A következő videó számos tippet és trükköt mutat be az anyagok összetevőkre történő felviteléhez. Vagy tovább olvasva ismerje meg azokat a lépéseket, amelyek bemutatják az összetevők egészének vagy egy részének festését.

Tipp: az anyagok variációinak gyors és egyszerű modellezéséhez kombinálja az összes alkatrész és azok egy részének festésére szolgáló technikákat.

A tipp működésének kipróbálásához tételezzük fel, hogy egy fakeretes széket modellez két párnával, és meg szeretne jeleníteni négy párna színt. Az itt látható Outliner (Körvonalazó) azt mutatja, hogy mindegyik szék összetevő (a keret és a két párna) egy csoport, melynek mindegyik tagja be van ágyazva egy csoporton belül, amely aztán be van ágyazva egy összetevőbe. A Körvonalazóval kapcsolatos további részletekért lásd a Modell szervezése című részt.

A következő lépések az anyagok alkalmazásának legegyszerűbb módját magyarázzák el, és bemutatják a négy színválasztékot:

  1. Mivel a keret minden széknél azonos, válassza ki a keret csoportját, és alkalmazza a faanyagot az itt látható módon.
  2. Hozzon létre egy másolatot mindegyik párna színhez. (A már rajzoltak másolása részben elmagyarázzuk, hogyan.)
  3. Válasszon ki egy összetevőt, és alkalmazzon egy párnaszín anyagot. Mivel a keret már le van festve, de a párnák továbbra is alapértelmezett színűek, a program csak a párnákat festi le a színanyaggal. A keret faanyagú marad.
  4. Ismételje meg az előző lépést az egyes színlehetőségekhez. Az eredményt a következő ábrán láthatja.

Tipp: ha több csoport vagy összetevő van beágyazva más csoportokba és összetevőkbe, nem biztos, hogy a SketchUp engedi, hogy a legfelső csoportra vagy összetevőre kattintva festhessen. Ha találkozik ezzel a problémával, próbáljon anyagokat alkalmazni egy a hierarchiában alacsonyabb szinten beágyazott csoportra vagy összetevőre. Az Outliner (Körvonalazó) segíthet megnézni, hol található az Ön választása a hierarchiában.

Egyik anyag kicserélése egy másikra

Mivel a SketchUp lehetővé teszi az egyik anyag kicserélését egy másikra, gyorsan és egyszerűen kísérletezhet az anyagokkal. A konyhában megtekintheti a különböző munkalapok anyagait, például a fekete gránitot, a kék csempét és a fehér kompozitot. Ha a ház festékeinek színeit választja ki, hasonlítsa össze a sárga burkolatot és sötétzöld szegélyt a tengerészkék burkolattal és krémszínű szegéllyel. Ha ismeri a módosító billentyűket, ez a folyamat egy szempillantás alatt végrehajtható. A következő táblázatban megtekintheti a kombinációkat.

Egyik anyag kicserélése egy másikra... Módosító billentyű (Microsoft Windows) Módosító billentyű (macOS)
Szomszédos felületeken Ctrl Option
Az összes felületen az aktuális kontextusban (például ugyanaz a csoport vagy összetevő) Shift Shift
Az összes kapcsolódó felületen Ctrl+Shift Option+Shift

Íme egy példa, amely segít az egyes billentyűparancsok működésének áttekintésében. Tegyük fel, hogy egy absztrakt falfestményhez próbál színeket találni két külön falon. Az alábbi ábrán a Colors-Named gyűjtemény anyagaival modellezett falfestmény látható.

Ha látni szeretné, hogy nézne ki, ha a pirosat zöldre cserélné, válassza ki a Festékes vödör eszközt, majd válassza ki a zöldet a Materials (Anyagok) panelen (Micsrosoft Windows) vagy a Colors (Színek) panelen (macOS). Ha a Ctrl vagy az Option gombbal együtt rákattint a bal felső sarokban található piros háromszögre, akkor csak a szomszédos, piros anyagú felületek cserélődnek zöldre, amint az a következő ábrán látható.

Ha ehelyett a Shift gombra kattint, az összes piros felület zöld színűvé válik:

Ha azonban a Ctrl+Shift vagy Option+Shift billentyűkombinációt használja, akkor csak a bal oldali falon változnak zöld színűre a piros felületek:

Anyagok szerkesztése

A SketchUp lehetővé teszi az anyagok szerkesztését. A módosítások során a szerkesztett anyaggal festett felületek automatikusan frissülnek. Mivel mindegyik anyagnak van színe és opcionális textúrája, a színt és a textúrát egymástól függetlenül szerkesztheti.


Az anyagszerkesztés a SketchUp alkalmazásban különösen akkor hasznos, ha egy anyagot sok felületre alkalmaz. Az anyag szerkesztése révén ahelyett, hogy csak egyetlen felületen cserélné ki azt, a szerkesztett anyaggal festett felületek automatikusan frissülnek. Mivel mindegyik anyagnak van színe és opcionális textúrája, a színt és a textúrát egymástól függetlenül szerkesztheti.

Megjegyzés: az anyagszerkesztést a SketchUp for Web alkalmazás fizetős előfizetései tartalmazzák. A funkció a SketchUp for Schools felhasználók számára is elérhető.

Ahhoz, hogy szerkeszthesse, az anyagot először el kell mentenie a modelljével. A modelljével együtt mentett anyagok megtekintéséhez nyissa meg a Materials (Anyagok) panelt a képernyő jobb oldalán található segédtálcán.

Anyag szerkesztéséhez válassza ki az anyagot az In Model anyagokból (a ház ikon alatt), vagy vegyen mintát a modellezési ablakból a Pipetta eszközzel, amely automatikusan kiválasztja az anyagot a Materials (Anyagok) panelen. Miután kiválasztotta az anyagát, kattintson az Edit (Szerkesztés) ikonra az anyag miniatűrje mellett.

Az anyagok szerkesztése közben a következőket állíthatja be:

  • Anyag neve: adjon meg egy új anyagnevet a szerkesztett anyag nevének megváltoztatásához.
  • Szín: anyagának színét manuálisan testre szabhatja a SketchUp színválasztójával, illetve egy meghatározott RGB, HSL vagy HEX érték megadásával. A színmódosítások manipulálása közben láthatja, hogy a változások valós időben bekövetkeznek.
  • Kép: adjon hozzá vagy módosítson egy kép textúrát, hogy az anyagához társítsa. A kép textúrák hozzáadása vagy módosítása felülírhatja az anyag színválasztását. Az "X"-re kattintva eltávolíthatja a kép textúrát az anyagból.
  • Anyagméret: ha egy kép textúrát alkalmaz egy felületre, akkor a textúra képét úgy helyezi el a program, hogy kitöltse a felületet. A textúra csempe méretének módosításához írjon be egy értéket a Width (Szélesség) vagy a Height (Magasság) mezőbe. Alapértelmezés szerint a kép képaránya változatlan marad. Tehát ha a szélességi méret mezőbe beírja a 2-es értéket, a magasság mező automatikusan úgy frissül, hogy megmaradjon az eredeti képarány. Kattintson a lánc ikonra a lánc megtöréséhez, és ezután tetszés szerint módosíthatja a képarányt. Ha nem tetszenek az eredmények (és soha többé nem tetszenek majd), akkor kattintson a Cancel (Mégse) gombra a menü alján, vagy vonja vissza a módosításokat a CTRL/Command + Z gombokra kattintva.
  • Átlátszatlanság: módosíthatja, hogy mennyire átlátszó vagy átlátszatlan legyen az anyag. Az átlátszatlanság csúszkáját jobbra húzva növelheti az átlátszatlanságot; a 100 a teljesen átlátszatlant jelöli. Az átlátszóság növeléséhez húzza balra a csúszkát; a 0 a teljesen átlátszót jelöli. Másik megoldásként írjon be egy számot 0 és 100 között az Opacity (Átlátszatlanság) mezőbe.

Megjegyzés: minden anyag szerkesztése elvethető az anyag szerkesztése közben az Edit Materials (Anyagok szerkesztése) panel alján található „Cancel” (Mégse) gombra kattintva. Ha elfogadja az anyagszerkesztések módosításait, akkor az Undo (Visszavonás) és a Redo (Újra) parancsok segítségével előre és hátra ugorhat az eredeti és a szerkesztett anyagok között.

Windows

Ahhoz, hogy szerkeszthesse, az anyagot először el kell mentenie a modelljével. A modelljével együtt mentett anyagok megtekintéséhez nyissa meg a Materials (Anyagok) panelt, és kattintson az In Model (Modellben) ikonra () In Model gyűjteményének megjelenítéséhez, amint a következő ábrán látható.

Ha a szerkeszteni kívánt anyag nem jelenik meg az In Model gyűjteményében, elmenthet egy anyagot az In Model gyűjteményével együtt, függetlenül attól, hogy az anyag jelenleg alkalmazva van-e felületekre a modelljében. Anyag hozzáadásához az In Model gyűjteményéhez kövesse az alábbi lépéseket:

  1. Kattintson a Display Secondary Selection Pane (Másodlagos kijelölési panel megjelenítése) ikonra () a Materials (Anyagok) panel jobb felső sarkában.
  2. A másodlagos panel alján keresse meg a gyűjteményeket a szerkeszteni kívánt anyaghoz.
  3. Húzza át az anyagmintát az In Model gyűjteményébe.

Szerkesztéséhez válassza ki az anyagot az In Model gyűjteményben, és kattintson az Edit (Szerkesztés) fülre, amely a következő ábrán látható.

Az alábbiakban röviden bemutatjuk az anyag színének szerkesztéséhez szükséges összes eszközt:

  • Választó legördülő lista: A Picker (Választó) legördülő listával választhat a HLS (árnyalat, fény, telítettség), a HSB (árnyalat, telítettség, fényerő), RGB (piros, zöld, kék) és a színkerék színválasztók közül. A színválasztóval kapcsolatos további tudnivalókért lásd a Színek keverése a színválasztóban c. részt.)
  • Színváltoztatások minta visszavonása: Erre a mintára kattintva visszavonhatja a szerkesztési munkamenet során végzett összes színmódosítást.
  • Match Color of Object In Model (Objektum színének egyeztetése a modellben) gomb: Erre a gombra kattintva a kurzor pipettává változik. Kattintson a pipetta kurzorral egy elemre, hogy színmintát vehessen belőle, és alkalmazhassa ezt a színt az éppen szerkesztett anyagra.
    Tipp: ha texturált anyagból vesz mintát, a textúra variációi kissé elváltoztathatják az anyag színét. Ha egy textúrából egy adott színt szeretne mintavételezni, a jobb eredmény érdekében használja a Match Color on Screen (Szín egyeztetése a képernyőn) gombot.
  • Match Color on Screen (Szín egyeztetése a képernyőn) gomb: Kattintson erre a gombra, majd kattintson a képernyő bármely pontjára a pipetta kurzorral egy pixel színének mintavételezéséhez. A SketchUp aztán ezt a színt alkalmazza az aktuálisan kiválasztott anyagra.

A következő eszközök az anyag textúrájának finomítását teszik lehetővé:

  • Use Texture Image (Textúra kép használata) jelölőnégyzet: Ha ez a jelölőnégyzet be van jelölve, felvehet egy textúrát képviselő képfájlt. A jelölőnégyzet bejelölésének eltávolításával törli a textúra képfájlt. (Megjegyzés: a jelölőnégyzet újbóli bejelölése nem állítja vissza a képfájlt. Ehelyett a program egy új képfájl kiválasztására utasítja.)
  • Texture (Textúra) képfájl és Browse (Tallózás) gomb: A textúra fájl mező tartalmazza az aktuális anyaghoz társított képfájl nevét (amely egy textúrát képvisel). A textúra megváltoztatásához húzza a képfájlt ebbe a mezőbe, vagy kattintson a Browse (Tallózás) gombra a Choose Image (Kép kiválasztása) párbeszédpanel megjelenítéséhez, ahol képfájlokat kereshet a számítógép merevlemezén. A textúra alkalmazása után azt is beállíthatja, hogy miként helyezkedjen el a textúra a modelljén. A részletekért lásd a következő, Textúrák áthelyezése című részt.
  • Edit Texture Image in External Editor (Textúra képek szerkesztése külső szerkesztőben) gomb: Amikor erre a gombra kattint, a SketchUp megnyitja a textúra képfájlt az Ön alapértelmezett képszerkesztőjében.
    Megjegyzés: A képszerkesztő a SketchUp Preferences (Beállítások) párbeszédpanelén, az Applications (Alkalmazások) panelen van meghatározva. E preferenciák beállításával kapcsolatban lásd A munkaterület testreszabása című részt. Ha még nem adott meg képszerkesztőt, a SketchUp az operációs rendszer alapértelmezett szerkesztőjét vagy képmegjelenítő alkalmazását indítja el.
  • Színezés jelölőnégyzet: Ha bejelöli ezt a jelölőnégyzetet, a program ugyanazt az árnyalatot alkalmazza az egész textúrára. A szín az Edit (Szerkesztés) lap Color (Szín) területén határozható meg. Ez a lehetőség olyan fájlok esetében hasznos, amelyek nem jelenítenek meg megfelelő színeket.
  • Színminta visszaállítása: Erre a színmintára kattintva visszaállíthatja az anyagot a textúra képfájlban lévő színre.
  • Méret mezők: Ha lefest egy textúrát egy felületen, akkor a textúra képét úgy helyezi el a program, hogy kitöltse a felületet. A textúracsempe méretének módosításához írjon be egy értéket a Width (Szélesség) vagy a Height (Magasság) mezőbe. Alapértelmezés szerint a kép képaránya változatlan marad. Tehát ha a szélességi méret mezőbe beírja a 2-es értéket, a magasság mező automatikusan úgy frissül, hogy megmaradjon az eredeti képarány. Kattintson a lánc ikonra a lánc megtöréséhez (Break the chain? - bocs, Fleetwood Mac), és ezután tetszés szerint módosíthatja a képarányt. Ha nem tetszenek az eredmények (és soha többé tetszenek majd), akkor kattintson a vízszintes és függőleges nyíl gombokra az előző szélesség és magasság beállításokra való visszatéréshez.
  • Opacity (Átlátszatlanság) csúszka: Az Átlátszatlanság arra utal, hogy mennyire átlátszó illetve átlátszatlan a kép. Az átlátszatlanság csúszkáját jobbra húzva növelheti a textúra átlátszatlanságát; a 100 a teljesen átlátszatlant jelöli. A textúra átlátszóságának növeléséhez húzza balra a csúszkát; a 0 a teljesen átlátszót jelöli. Másik megoldásként írjon be egy számot 0 és 100 között az Opacity (Átlátszatlanság) mezőbe.

MacOS

Ahhoz, hogy szerkeszthesse, az anyagot először el kell mentenie a modelljével. A modelljével elmentett anyagok megtekintéséhez válassza a Window > Materials (Ablak > Anyagok) lehetőséget a Colors (Színek) panel megnyitásához. A Texture Palettes (Textúra paletták) lapon (tégla ikon) kattintson a Colors In Model (Színek a modellben) ikonra (), vagy válassza a Colors In Model (Színek a modellben) lehetőséget a legördülő listában a Colors In Model gyűjteményének megjelenítéséhez, amint a következő ábrán is látható.

Ha a szerkeszteni kívánt anyag nem jelenik meg a Colors In Model gyűjteményében, alkalmazza az anyagot egy felületre a modelljében. (Ne feledje, hogy ha később egy anyagot kicserél egy másikra, az eredeti anyag továbbra is a Colors In Model gyűjteményében marad, amíg el nem távolítja a nem használt anyagokat.)

Ha készen áll egy anyag szerkesztésére, kövesse az alábbi lépéseket:

  1. A Textures Palette (Textúrák paletta) lapon (tégla ikon) nyissa meg a Colors In Model gyűjteményt.
  2. Jelölje ki a szerkeszteni kívánt anyagot.
  3. A Color (Szín) legördülő listából válassza ki az Edit (Szerkesztés) lehetőséget, vagy a Control gomb megnyomása mellett kattintson az anyagra, és válassza a megjelenő menüben az Edit (Szerkesztés) lehetőséget.
  4. Az ábrán látható módon megjelenő Edit Material (Anyag szerkesztése) panelen válassza ki a kívánt szerkesztéseket.
  5. Amikor elkészült, kattintson a Close (Bezárás) gombra.

Az alábbiakban bemutatjuk az Edit Material (Anyag szerkesztése) panel lehetőségeit:

  • Név: Adjon meg egy új anyagnevet a szerkesztett anyag nevének megváltoztatásához.
  • Edit Texture Image in External Editor (Textúra képek szerkesztése külső szerkesztőben): Amikor erre a gombra kattint, megnyílik a textúra képfájl az Ön alapértelmezett képszerkesztőjében vagy képmegjelenítő programjában.
    Hajtsa végre és mentse el a szerkesztéseit a fájlba, és a módosítások megjelennek az anyagban.
  • Texture (Textúra) legördülő menü: A legördülő menü opciói lehetővé teszik a textúra szerkesztését a SketchUp-on belül. Válassza a Load (Betöltés) lehetőséget egy új képfájl kiválasztásához a textúrához. A textúra képfájl törléséhez válassza a Remove (Eltávolítás) lehetőséget. (A textúra törlésekor megjelenik az eltávolított kép egyszínű megközelítőleges megjelenítése.) Ha színezte a textúrát, válassza a Reset Color (Szín visszaállítása) lehetőséget a színezés eltávolításához Az Edit (Szerkesztés) kiválasztásával megnyílik a textúra képfájl az Ön alapértelmezett képszerkesztőjében vagy képmegjelenítő programjában. A textúra alkalmazása után azt is beállíthatja, hogy miként helyezkedjen el a textúra a modelljén. A részletekért lásd a következő, Textúrák áthelyezése című részt.
  • Szélesség és magasság: Ha lefest egy textúrát egy felületen, akkor a textúra képet úgy helyezi el a program, hogy kitöltse a felületet. A textúracsempe méretének módosításához írjon be egy értéket a Width (Szélesség) vagy a Height (Magasság) mezőbe. Alapértelmezés szerint a kép képaránya változatlan marad. Tehát ha a szélességi méret mezőbe beírja a 2-es értéket, a magasság mező automatikusan úgy frissül, hogy megmaradjon az eredeti képarány. Kattintson a lánc ikonra a lánc megtöréséhez (Break the chain? - bocs, Fleetwood Mac), és ezután tetszés szerint módosíthatja a képarányt. Ha nem tetszenek az eredmények (és soha többé nem tetszenek majd), akkor emlékeznie kell az eredeti méretekre, és manuálisan be kell írnia őket, hogy visszatérjen az eredeti képméretekhez.
  • Színezés: Ha az Edit material (Anyag szerkesztése) panel meg van nyitva, színezhet textúra fájlt. A szín lapok valamelyikével válasszon ki egy színt, és alkalmazza azt az anyagának előnézetére az Anyag szerkesztése panelen, vagy kattintson a Colors (Színek) panel alján található pipetta eszközre, és kattintson a modell bármely anyagára vagy a Textures Palettes (Textúra paletták) (tégla) fülre.
    Tipp: a színezés kiváló módja az anyagszín variációival történő kísérletezésnek.
  • Átlátszatlanság: Ha az Edit material (Anyag szerkesztése) panel meg van nyitva, az anyag átlátszatlanságát is szerkesztheti, ami azt jelöli, hogy mennyire átlátszó vagy átlátszatlan a kép. Az átlátszatlanság csúszkáját jobbra húzva növelheti a textúra átlátszatlanságát; a 100 a teljesen átlátszatlant jelöli. A textúra átlátszóságának növeléséhez húzza balra a csúszkát; a 0 a teljesen átlátszót jelöli. Másik megoldásként írjon be egy számot 0 és 100 között az Opacity (Átlátszatlanság) mezőbe.

Textúrák áthelyezése

Miután a 3D-s modell egy vagy több felületén alkalmazta a textúrát, azt is beállíthatja, hogy miként helyezkedjen el a textúra egy felületen. Ehhez használja a Textúra elhelyezése eszközt, amely két üzemmóddal rendelkezik:

  • Rögzített jelölő mód: Ebben az üzemmódban mozgathatja, forgathatja, méretezheti vagy torzíthatja a textúrát. Például ebben a módban beállíthat egy textúrát egy felületen úgy, hogy az igazodjon ugyanahhoz a textúrához egy másik felületen, mint például a burkolat egy épület két oldalán.
  • Szabad jelölő mód: Ha a textúrát nyújtania vagy zsugorítania kell, használja a szabad jelölő üzemmódot.

Szabad jelölő módban a következőképpen állíthat be egy textúrát.

  1. Kattintson a jobb egérgombbal az anyagra, és válassza a megjelenő menüben a Texture > Position (Textúra > Pozíció) lehetőséget. Látni fog egy pontozott vonalakból álló mátrixot, amely a textúra egyes lapjait ábrázolja. A kurzor is kézzé változik, és megjelenik négy jelölő.
  2. Ha az alábbi ábrának megfelelően látja a négy színes jelölőt, folytassa a következő lépéssel. Ha nem, kattintson a jobb egérgombbal az anyagra, és válassza a Fixed Pins (Szabad jelölők) lehetőséget.
  3. Textúrája beállításához használja a kéz kurzort és/vagy a jelölőket. Ebben a példában az a cél, hogy a zöld jelölőt úgy mozgassuk, hogy a szekrény tetején lévő fa iránya megegyezzen az oldalával. Íme az összes lehetőség gyors áttekintése:
    • Kattintson rá és húzza az anyagot a kéz kurzorral a textúra egészének áthelyezéséhez.
    • Rákattintva vegyen fel egy jelölőt, majd újra rákattintva tegye le a jelölőt máshol a textúrán.
    • A textúra módosításához húzzon el egy jelölőt. A kék jelölő elhúzásával méretezheti vagy vághatja a textúrát. A sárga jelölő elhúzásával torzíthatja a textúrát. A zöld jelölő elhúzásával méretezheti a textúrát, vagy elforgathatja a jelölő mozgási tengelye körül. A piros jelölővel, amely a mozgató jelölő, elmozdíthatja a textúrát.
    Tipp: Fixed Pin (Rögzített jelölő) módban a textúrára jobb egérgombbal kattintva további lehetőségeket is megtekinthet: a textúrát balra vagy jobbra, illetve felfelé vagy lefelé fordíthatja, a textúrát 90 fokos lépésekben forgathatja. A Reset (Visszaállítás) opcióval visszaállíthatja a textúrát az eredeti állapotába, míg az Undo (Visszavonás) lehetőséggel egyszerűen visszavonhatja az utolsó parancsot. Ha visszavon egy műveletet, a Redo (Újra) lehetőség is elérhetővé válik.
  4. Ha befejezte a textúra módosítását, kattintson a jobb egérgombbal a textúrára, és válassza a Done (Kész) gombot, vagy egyszerűen kattintson a textúrán kívülre a Rögzített jelölő módból való kilépéshez.

A Szabad jelölő módban beállíthatja a textúracsempe méretét a modelljéhez viszonyítva. A folyamat a következőképpen működik:

  1. Kattintson a jobb egérgombbal az anyagra, és válassza a megjelenő menüben a Texture > Position (Textúra > Pozíció) lehetőséget. Alapértelmezés szerint a Fixed Pin (Rögzített jelölő) üzemmódban van.
  2. Jobb egérgombbal a textúrára kattintva, majd a Fixed Pins (Rögzített jelölő) lehetőség bejelölésének eltávolításával váltson át Free Pin (Szabad jelölő) módba. Free Pin (Szabad jelölő) módban négy fehér jelölő látható, az alábbi ábrán látható módon.
  3. Rákattintva felvehet egy jelölőt, és ismételt kattintással áthelyezheti az új helyére. Végezze el ezt mind a négy jelölővel, hogy kijelölje a textúracsempe sarjait. Ha a jelölőket nem téglalap alakban helyezi el, akkor eltorzítja a textúrát.
  4. Ha befejezte, kattintson a jobb egérgombbal a textúrára, és válassza a Done (Kész) gombot, vagy egyszerűen kattintson a textúrán kívülre a Free Pin (Szabad jelölő) módból való kilépéshez.
Tipp: szabad jelölő módban a textúracsempe méretét csak a kiválasztott felületen láthatja. Ha az egész modelljén meg szeretné változtatni a textúrájának méretét, használja a Materials (Anyagok) panelt (Microsoft Windows) vagy a Colors (Színek) panelt (macOS). A részletekért lásd az előző, Anyagok szerkesztése című részt.

Anyagterület automatikus kiszámítása

Ha azt szeretné, hogy a SketchUp kiszámolja az anyaggal festett felület területét, akkor kattintson a jobb egérgombbal az anyagra, és válassza az Area > Material (Terület > Anyag) lehetőséget. A Windows rendszerben rákattinthat jobb egérgombbal az adott anyagra a Materials (Anyagok) panelen is, és kiválaszthatja a menüből az Area (Terület) lehetőséget. (Ha az Area (Terület) menüpont szürke, akkor az anyagot nem alkalmazták egyik felületre sem.)

Mindenképpen megjelenik egy Area (Terület) párbeszédpanel, amely azoknak a felületeknek a teljes területét mutatja, amelyekre a kiválasztott anyagot alkalmazták. A mértékegységek (például négyzetláb vagy négyzetméter) a sablonban megadott mértékegységektől függenek. Az alapértelmezett mértékegységek módosításával kapcsolatos részletekért lásd a Sablonok beállítása c. részt.

Ha IFC osztályozásokat használ, jelentést készíthet az egész modelljében szereplő anyagokról. A részletekért lásd az Objektumok osztályozása c. részt (különösen a jelentéskészítésről szóló szakasz).

Anyagok kezelése és rendezése

A Materials (Anyagok) panel (Microsoft Windows) vagy a Colors (Színek) panel (macOS) segít megtalálni és rendszerezni az anyagokat. Az alábbi lista elmagyarázza, hogyan kezelheti az anyagokat a Súgóközpontban kiválasztott operációs rendszerrel.

Windows

  • A belefoglalt gyűjtemények tallózása: A Select (Kiválasztás) fülön kiválaszthat egy gyűjteményt a legördülő listából, és megtekintheti az anyagokat.
  • A modelljében szereplő anyagok nyomon követése: Kattintson az In Model (Modellben) ikonra (), hogy megtekinthesse a modelljére alkalmazott összes anyagot.
  • Felesleges anyagok törlése: Még ha egy anyagot ki is cserél egy másikra, hogy az eredeti anyag ne jelenjen meg többé a modelljében, az eredeti anyag továbbra is az In Model gyűjteményében marad, amíg a jobb egérgombbal kattintva meg nem nyitja a környezeti menüt, és a Delete (Törlés) elemre kattintva nem törli az anyagot. A modell összes nem használt anyagának eltávolításához válassza ki az In Model gyűjteményt, majd kattintson a Details (Részletek) nyílra () és válassza a Purge Unused (Nem használtak törlése) lehetőséget. Alternatív megoldásként a Delete All (Összes törlése) lehetőséget kiválasztva is eltávolíthatja az összes anyagot a modelljéből és az In Model gyűjteményéből.
  • Saját gyűjtemények létrehozása: Létrehozhat egy gyűjteményt egy adott projekthez, vagy létrehozhat egy gyűjteményt az Ön által létrehozott anyagokhoz, például egy adott színvilághoz, szövetmintákhoz, tereprendezési lehetőségekhez vagy bármi máshoz, amit ismétlődően használ. A Select (Kiválasztás) lapon kattintson a Details nyílra (), és válassza az Open or Create a Collection (Gyűjtemény megnyitása vagy létrehozása) lehetőséget. A Select a collection folder or create a new one (Gyűjtemény mappa kiválasztása vagy új létrehozása) párbeszédpanelen lépjen arra a mappára, amelybe el szeretné menteni a gyűjteményét. Kattintson a New Folder (Új mappa) gombra, nevezze el a mappát (ez lesz a gyűjtemény neve), majd kattintson a Select Folder (Mappa kiválasztása) lehetőségre. A gyűjtemény létrehozása után a mappára lépve megnyithatja a gyűjteményt. Ha anyagokat kíván hozzáadni egy gyűjteményhez, húzza át azokat a másodlagos választópanelről a gyűjteményébe, vagy mentse el a létrehozott anyagait a gyűjteményébe.
  • Gyakran használt gyűjtemények hozzáadása a kedvencekhez: A Select (Kiválasztás) lapon kattintson a Details nyílra, és válassza az Add Collection to Favorites (Gyűjtemény hozzáadása a kedvencekhez) lehetőséget. Ezután megjelenik az éppen kiválasztott gyűjtemény a kedvencek listában a legördülő lista alján. Kijelölheti a gyűjteményt, és a Details (Részletek) nyílra kattintva kiválaszthatja a Remove Collection from Favorites (Gyűjtemény eltávolítása a kedvencekből) lehetőséget, ha már nincs szüksége a gyűjteményre a kedvencek listában.
    Megjegyzés: Kattintson a Details nyílra, és kiválaszthatja, hogy kicsi, közepes, nagy vagy extra nagy csempékként szeretné megtekinteni az anyagokat. A Lista lehetőség kiválasztásával az előnézeti minták helyett az anyagok neveit láthatja.

MacOS

  • A mellékelt gyűjtemények tallózása: A SketchUp-hoz mellékelt anyagok megtekintéséhez kattintson a Texture Palettes ikonra (tégla), és válasszon a legördülő menü gyűjteményeiből, például Brick and Cladding (Tégla és burkolat), Fencing (Kerítés), Roofing (Tetőfedés), Translucent (Áttetsző) vagy Wood (Fa). A gyűjtemény minden anyaga mintaként jelenik meg, amelyet a Festékes vödör kurzorral kattintva alkalmazhat a modelljére.
  • Anyagok nyomon követése egy modellben: A Colors (Színek) panel tartalmaz egy speciális, Colors In Model (Színek a modellben) elnevezésű anyaggyűjteményt, amely a modellben aktuálisan használt összes anyagot magában foglalja. Ennek a gyűjteménynek a tartalma automatikusan létrejön, amikor anyagokat ad hozzá SketchUp modelljéhez. E gyűjtemény megtekintéséhez válassza az anyaggyűjtemények legördülő menüben a Colors In Model (Színek a modellben) lehetőséget, vagy egyszerűen kattintson a Színek a modellben ikonra ().
  • Felesleges anyagok törlése: Még ha egy anyagot ki is cserél egy másikra, hogy az eredeti anyag ne jelenjen meg többé a modelljében, az eredeti anyag továbbra is a Colors In Model gyűjteményében marad, amíg a jobb egérgombbal kattintva meg nem nyitja a környezeti menüt, és a Remove (Eltávolítás) elemre kattintva nem törli az anyagot. A modell összes nem használt anyagának eltávolításához válassza ki a Colors In Model gyűjteményt, és válassza a List > Purge Unused (Lista > Nem használtak törlése) lehetőséget. Alternatív megoldásként a Delete All (Összes törlése) lehetőséget kiválasztva is eltávolíthatja az összes anyagot a modelljéből és a Colors In Model gyűjteményéből.
  • Saját gyűjtemények létrehozása: Létrehozhat egy gyűjteményt egy adott projekthez, vagy létrehozhat egy gyűjteményt az Ön által létrehozott anyagokhoz, például egy adott színvilághoz, szövetmintákhoz, tereprendezési lehetőségekhez vagy bármi máshoz, amit ismétlődően használ. Válassza a List > New (Lista > Új) elemet. A megjelenő List Name (Listanév) mezőbe írjon be egy nevet, és kattintson az OK gombra. Ettől kezdve láthatja a beírt nevet a gyűjtemények legördülő listájában.
    Anyagok új gyűjteményhez való hozzáadásához húzza át a Colors (Színek) paletta alján látható pipetta mellett lévő mintát az új gyűjtemény minta paneljébe, vagy hozzon létre új textúrákat, és mentse el őket a gyűjteménybe. A gyűjtemény eltávolításához válassza a List > Remove (Lista > Eltávolítás) elemet.
Megjegyzés: Ha megszokta a Materials (Anyagok) panel használatát a Windows rendszerben, vegye figyelembe, hogy a macOS rendszer Colors (Színek) panelje nem teszi lehetővé a gyakran használt gyűjtemények hozzáadását a kedvencek listájához.

Saját anyagok létrehozása

A SketchUp programba belefoglalt anyagok segítenek Önnek abban, hogy elkezdhesse használni az anyagokat, és felfedezze, hogyan működnek. A saját tervére vagy épületére jellemző anyagok alkalmazásához valószínűleg saját anyagokat kell létrehoznia. A folyamat elég egyszerű: először egy képpel hozzon létre egy textúracsempét, majd szükség esetén adjon meg egy színt.

Windows

Ha a saját fájljaiból vagy színkódokból szeretne új anyagot létrehozni, kövesse az alábbi lépéseket:

  1. A Materials (Anyagok) panelen kattintson az Anyag létrehozása ikonra () a jobb felső sarokban.
  2. A megnyíló Create Material (Anyag létrehozása) párbeszédpanelen írja be az új anyag nevét a felső szövegmezőbe.
  3. Válassza ki az új anyag színét, textúráját és átlátszatlanságát. Az opciók ugyanúgy működnek, mint az Edit (Szerkesztés) panelen. A részletekért lásd a korábbi Anyagok szerkesztése című részt, vagy a szín opciókkal kapcsolatos segítségért lásd a Színek keverése a színválasztóban c. részt.
  4. Kattintson az OK gombra. Új anyaga kijelölve megjelenik az In Model gyűjteményben.

MacOS

Olyan új anyag létrehozásához, amely textúra, kövesse az alábbi lépéseket:

  1. A Colors (Színek) panelen kattintson a Textures Palette (Textúra paletta) fülre (amelyikhez a tégla ikon tartozik).
  2. Válassza ki azt a gyűjteményt, ahol az új anyagot meg szeretné jeleníteni.
  3. Válassza a Color > New Texture (Szín > Új textúra) lehetőséget.
  4. A megjelenő párbeszédpanelen válasszon ki egy képfájlt a textúrához.
  5. A megjelenő panelen írja be a textúra nevét, állítsa be a csempe méretének szélességét és magasságát, majd kattintson az OK gombra. Ha színezni szeretné a textúrát, kövesse az előző, Anyagok szerkesztése című részben leírt lépéseket.

A következőképpen menthet el egy bizonyos színt anyagként:

  1. A szín lapok valamelyikével hozza létre a kívánt színt, amely a Colors (Színek) paletta alján, a színmintában jelenik meg. A részletekért lásd a Színek keverése a színválasztóban c. részt.
  2. Válassza a Textures Palette (Textúra paletta) lapot (más néven tégla ikont).
  3. Keresse meg azt a gyűjteményt, ahová el szeretné menteni a színt.
  4. Húzza a színmintát a Colors (Színek) panel aljáról a gyűjtemény mintaterületére.
Tipp: az anyaggyűjteményeit anyagok letöltésével is bővítheti. A részletekért tekintse meg ezt a bejegyzést a SketchUpdate blogból.