A rajzolás alapjainak és fogalmainak bemutatása

A 3D-s modellrajzolás eltér a 2D-s képrajzolástól. A rajzolás alapjainak és fogalmainak jelen bemutatása néhány módszert ismertet az élek és felületek (minden SketchUp modell alapvető entitásainak) létrehozására. Azt is megtudhatja, hogyan segít a SketchUp következtetési eszköze ezeknek a vonalaknak és felületeknek az elhelyezésében a kívánt tengelyen.

Tipp: az alapvető alakzat eszközök vékony folytonos vonalat használnak. Szaggatott vonalak létrehozásához lásd a Szaggatott vonalak alkalmazása rétegekre című részt.

Vonal rajzolása

A Vonal eszközzel rajzoljon éleket (más néven vonal entitásokat). Az élek alkotják minden modell szerkezeti alapját. Vonalat a következőképpen rajzolhat:

  1. Válassza ki a Vonal eszközt () az eszköztárból (vagy nyomja meg az L billentyűt). A kurzor ceruzává változik.
  2. Kattintson a vonal kezdőpontjára. Ha rossz helyre kattintott, nyomja meg az újrakezdéshez az Esc billentyűt. Miközben a kurzort a rajzterületen mozgatja, a következőket figyelheti meg:
    • Egy vonal követi a kurzort.
    • A vonal hosszúsága dinamikusan megjelenik a Measurements (Méretek) mezőben. (A Measurements (Méretek) mező az Ön sablonjában meghatározott mértékegységeket használja.)
    • A kurzort követő vonal pirosra, zöldre vagy kékre változik, amikor a vonal párhuzamos a piros, a zöld vagy a kék tengellyel. Ha egy pillanatra fölé húzza az egérmutatót, megjelenik egy képernyőtipp, például a képen látható "Kék tengelyen" tipp. Nincs szellem a gépben, csak a SketchUp következtető eszköze, amelyet később mutatunk be a cikkben.
  3. Kattintson a vonal végpontjának beállításához. Ez a végpont egy másik vonal kezdőpontja is lehet. Amikor befejezte a vonalak rajzolását, nyomja meg az Esc billentyűt, vagy válasszon ki egy másik eszközt. Miután beállította a végpontot, a Ctrl+Z (Microsoft Windows) vagy a Command+Z (macOS) billentyűkombinációval visszavonhatja és újrakezdheti a vonalát.

  4. (Opcionális) Pontos hosszúságú vonal létrehozásához írjon be egy értéket, és nyomja meg az Enter (Microsoft Windows) vagy a Return (macOS) billentyűt. Ezt az eljárást tetszés szerint akárhányszor megismételheti addig, amíg újabb vonalat nem rajzol, vagy ki nem választ egy másik eszközt. Ha nem határoz meg mértékegységet, a SketchUp az Ön sablonjában szereplő mértékegységeket használja. Azonban angolszász vagy metrikus mértékegységet is megadhat a vonalához. Tehát beírhatja például a 3mm vagy 5’2” értéket is. Értéke beírás közben megjelenik a Measurements (Méretek) mezőben.

Megjegyzés: a Measurements (Méretek) mező 3D-s koordinátákat is elfogad a vonalakhoz:
  • Egy abszolút koordináta, például [3', 5', 7'] a vonal végét az aktuális tengelyekhez viszonyítva helyezi el. A szögletes zárójelek abszolút koordinátát jelölnek.
  • Egy relatív koordináta, például <1,5 m, 4 m, 2,75 m>, a vonal végét az Ön vonalának kezdőpontjához viszonyítva helyezi el. A csúcsos zárójelek relatív koordinátát jelölnek.

A vonal hosszát addig szerkesztheti, amíg a vonal nem határol felületet. Vonalat így szerkeszthet:

  1. Válassza ki a Mozgatás eszközt ().
  2. Húzza a Mozgatás eszköz kurzorát a vonal egyik végpontja fölé.
  3. Kattintson rá és húzza el a végpontot a vonal hosszának módosításához.

Tipp: az Entity Info (Entitásadatok) párbeszédpanelen is módosíthatja a hosszúságot. Kattintson a jobb egérgombbal a vonalra, és válassza a megjelenő menüben az Entity Info (Entitásadatok) lehetőséget. Írja be a Length (Hosszúság) mezőbe az új vonalhosszt.

Felület létrehozása

Ha több vonalat csatlakoztat egy alakzattá, akkor felületet alkotnak.

Itt ne valamilyen különleges felületre gondoljon. A felületek alapértelmezés szerint egyszerűek, de kulcsfontosságúak: ez az él-felület duó másik tagja, amely lehetővé teszi a SketchUp modellek létezését.

Tipp: alapértelmezés szerint a SketchUp árnyékolást is hozzáad egyes felületekhez, amint itt is látható, és a felületek átlátszatlanok, így tudhatja, hogy a modelljének tényleges fala, padlója vagy bármije van, amit a felületnek a 3D modellben ábrázolnia kell. (A SketchUp-ban azonban van egy olyan nézet is, amellyel átláthat a falakon, mint Superman. A részletekért lásd a Modellek megtekintése c. részt.

Az alakzat eszközökkel — téglalap, kör és sokszög — is létre lehet hozni felületeket. (Az eszközökkel kapcsolatos további részletekért lásd az Alapvető alakzatok rajzolása című részt.)

Felületek felosztása

Amikor egy vonalat (vagy görbét) rajzol egy meglévő felületre, akkor felosztja a felületet.

Tipp: ez a fogalom azért fontos, mert a felület felosztása után a Tolás/Húzás eszközzel eltolhatja/elhúzhatja a felület egy részét, míg a másik része a helyén marad, amint itt is látható. A Tolás/Húzás eszközzel kapcsolatos részletekért lásd az Alakzatok tolása és húzása 3D-be című részt.

3D-s alakzatok megnyitása az élek és a felületek törlésével

Egy él vagy felület kiradírozásával létrehozhat egy nyílást az alakzatban. Ha meg szeretné tudni, hogyan befolyásolja egy él törlése a modellt, először válassza ki a Radír eszközt (), vagy nyomja meg az E billentyűt, majd kattintson egy élre:

  • Ha egy élre kattint, törli az élt és minden olyan felületet, amely érintette azt adott élt. Általános igazságként kijelenthetjük, hogy vonalak lehetnek felület nélkül, a felületet azonban teljesen körül kell határolniuk vonalaknak.
  • Ha jobb egérgombbal rákattint a felületre és kiválasztja az Erase (Radírozás) lehetőséget, azzal csak a felületet törli.

Az ábrán láthatja az eredeti kockát, és azt, hogyan módosítja a kockát egy él vagy felület törlése.

Tipp: ha törlés helyett el szeretne rejteni egy vonalat, tartsa lenyomva a Shift billentyűt, és közben kattintson a Radír eszközzel a vonalra, vagy kattintson a jobb egérgombbal a vonalra, és válassza a Hide (Elrejtés) lehetőséget.

Törölt felületek helyreállítása

Ha véletlenül töröl egy felületet, a következőképpen állíthatja vissza:

  • Ha nem hajtott végre más módosításokat, amelyeket meg szeretne tartani, egyszerűen válassza az Edit > Undo (Szerkesztés > Visszavonás) elemet a menüsávban, vagy nyomja meg a Visszavonás Ctrl+Z (Microsoft Windows) vagy Command+Z (macOS) billentyűparancsát.
  • Rajzolja meg újra a vonalat, amely a felületek eltűnését okozta, és a SketchUp újra létrehozza a felületeket.

Következtetés keresése és zárolása

A SketchUp rendelkezik egy következtetési eszközzel, amely segít Önnek a 3 dimenziós térben végzett munkában. Például amikor a Vonal eszköz kurzorát egy másik vonal felezőpontja fölé viszi, a következtetési eszköz egy világoskék pont és a „Középpont” feliratú képernyőtipp megjelenítésével tájékoztatja Önt az itt látható módon. Mindegyik következtetésnek megvan a maga színe és képernyőtippje. (A teljes lista megtekintéséhez olvassa el A következtetési típusok ismerete című részt.)

A következtetési motor a vonalak közötti geometriai összefüggéseket is segíthet megtalálni. Például jelzi, amikor egy rajzolt vonal merőleges egy másik vonalra. A következő ábrán láthatja, hogy a vonal kezdőpontján egy színes pont is megjelenik, amely egyszerre ad néhány információt.

Figyelmeztetés: fokozottan figyeljen oda a következtetési eszközre, és időnként keringjen a modellben, hogy különböző nézőpontokból ellenőrizze a rajzát. A következő ábrán például úgy tűnhet, mintha a vonalak a piros és a zöld síkon lennének egészen addig, amíg egy másik nézetbe nem kering. Ennek a gyakori buktatónak az elkerülése érdekében a SketchUp úgy segít, hogy a rajzolás irányát vagy síkját piros, zöld vagy kék színűre változtatja, amikor ezekkel a tengelyekkel párhuzamos éleket vagy síkokat hoz létre (vagy ibolyaszínűre, ha párhuzamos vagy merőleges egy élre ill. felületre a modelljében).

Tipp: előfordulhat, hogy a szükséges következtetések nem azonnal jelennek meg, vagy a SketchUp rossz geometriával választ igazításokat. Ezekben az esetekben azzal ösztönözheti a következtetést, vagy növelheti az adott igazítás esélyét, hogy az egérmutatót megállítja azon hely fölött, amelyből szeretné, hogy a SketchUp következtessen. Amikor megjelenik a vizuális segédjel, a SketchUp a rajzolás folytatásakor röviden kiemeli az igazítást.

Lineáris következtetés kapcsoló

Új funkció! - SketchUp 2020.2

A következtetés a SketchUp alapvető funkciója, amelytől a legtöbb eszköz valamilyen módon függ. A következtetés azonban néha útban lehet, különösen akkor, amikor a modell egy zsúfolt területén dolgozik. A Vonal eszközzel egy egyszerű módosító művelettel ki- és bekapcsolhatja a lineáris következtetéseket.

A Vonal eszközben a lineáris következtetés ki-/bekapcsolásához egyszer kattintva el kell kezdenie a vonal rajzolását. Miután elkezdte a vonalat, de még mielőtt rákattintana a befejezéséhez, nyomja meg a COMMAND billentyűt (Mac rendszerben) vagy az ALT billentyűt (Windows rendszerben), amellyel a következő állapotok között válthat:

  • Minden következtetés be
  • Minden következtetés ki
  • Csak párhuzamos és merőleges

Minden következtetés be

Ez az alapértelmezett viselkedés, az, amit az 1. verzió óta tapasztalhatott a SketchUp alkalmazásban. A Vonal eszköz a piros, a zöld és a kék tengelyhez, valamint az ibolyaszínű tengelyhez igazodik (párhuzamosan/merőlegesen egy meghatározott élre).

Minden következtetés ki

Ebben az állapotban a Vonal eszköz figyelmen kívül hagy minden lineáris következtetést. Vegye figyelembe, hogy a kurzor szabadabban mozog a képernyőn, amikor az élszegmenseket kitölti. Ne feledje, hogy továbbra is megtalálhatók más következtetéstípusok, például a Felületen, Vezetőpontok, Középpontok stb. Ezekkel az egyéb következtetési típusokkal megbizonyosodhat arról, hogy vonalai a kívánt síkokra lettek-e rajzolva.

Csak párhuzamos és merőleges

Ez az állapot csak a párhuzamos és merőleges lineáris következtetéseket mutatja a Vonal eszköz használatakor. Ennek az opciónak a kiválasztása lehetővé teszi, hogy megrajzolja a vonalat és meggyőződjön arról, hogy párhuzamos vagy merőleges a többi geometriára, miközben nem vonják el a figyelmét más lineáris következtetések, amelyek arra vetemedhetnek, hogy ellopják az Ön vonalát.

Következtetések zárolása billentyűzettel

A következtetések zárolásával magabiztosan rajzolhat a kívánt irány mentén. A következtetés lezárásának másik oka az lehet, hogy megtartsa az egyik rajzolási irányt, miközben a modell egy másik részéről hivatkozik geometriát. Ez egy speciálisabb lépés, de nagyon hasznos. A következtetés a nyíl billentyűkkel zárolható legegyszerűbben az alapértelmezett tengelyek irányaihoz:

>

A rajzolási irány zárolása nyílbillentyűkkel
Billentyű Hogy néz ki?
A kék tengelyhez rögzíti a rajzolás irányát vagy síkját.
A zöld tengelyhez rögzíti a rajzolás irányát vagy síkját.
A piros tengelyhez rögzíti a rajzolás irányát vagy síkját. A bal-jobb megkülönböztetéséhez az a legjobb, ha kimondja: "a jobb zárolja a pirosat."
Kapcsolja át, hogy zárolja a párhuzamos/merőleges rajzolási irányt vagy rajzolási síkot egy következtetett élhez vagy síkhoz. Alapvetően mindent, ami ibolya színűvé válik. A rajzolás iránya és az éppen következtetett felület éle is ibolya színűvé válik.
Shift Az aktív rajzolási irányhoz/síkhoz rögzíti a rajzolás irányát vagy síkját. Tehát ha a kék tengely mentén rajzol, és lenyomva tartja a Shift billentyűt, a kék következtetés kerül zárolásra.
Shift+Alt (Windows) vagy Shift+Command (MacOS) Ha a Shift nyomva tartásával zárolja a rajzolási síkot, azzal az eszközt is rögzíti ugyanahhoz a felületsíkhoz, amelyet a program következtet. Az Elforgatás és a Szögmérő eszközök esetében azonban nyomja meg az Alt billentyűt (Microsoft Windows) vagy a Command billentyűt (macOS) az eszközök felszabadításához, hogy a középpontot a modell másik helyére vihesse, miközben megtartja ugyanazt a rajzolási síkot.

Néhány eszköz, például a kör és az elforgatás, egy síkhoz rögzülhet (nem pedig rajzolási irányhoz), amint az alábbi ábrán is látható. Ezeknek az eszközöknek az esetében úgy rögzítheti a rajzolási síkot, hogy a színes irányt választja ki az eszköz tengelyének vagy „normálisnak”.

A rajzolási sík zárolása nyílbillentyűkkel

Élek igazítása tengelyekhez

Annak érdekében, hogy az élek biztosan igazodjanak a tengelyekhez, hasznos lehet a kurzort a tengelyek színeire változtatni. Vagy ha ellenőriznie kell a meglévő geometria igazítását, változtassa az éleit a tengelyek színeire.

Ha a tengelyszínekre szeretné változtatni a kurzort, kövesse az alábbi lépéseket:

  • Válassza a Window > Preferences (Ablak > Beállítások) (Microsoft Windows) vagy a SketchUp > Preferences (SketchUp > Beállítások) (Mac OS) elemet. Megnyílik a "SketchUp Preferences" (SketchUp beállítások) párbeszédpanel.
  • Válassza a bal oldali Drawing (Rajz) elemet.
  • A Drawing (Rajz) panel Miscellaneous (Egyéb) területén jelölje be a Display cross hairs (Célkereszt megjelenítése) jelölőnégyzetet.
  • Kattintson az OK gombra a SketchUp beállítások párbeszédpanel bezárásához. A kurzor a tengelyek színével megegyező célkeresztet jelenít meg, amint az ábrán látható.

Ahhoz, hogy a modellben lévő élek visszatükrözzék annak a tengelynek a színét, amelyhez igazodnak, kövesse az alábbi lépéseket:

  1. Válassza a Window > Styles (Ablak > Stílusok) elemet.
  2. A Styles (Stílusok) párbeszédpanelen válassza az In Model (Modellben) lehetőséget a stíluskönyvtárak legördülő listájából.
  3. Kattintson az Edit (Szerkesztés) fülre.
  4. Kattintson az ábrán is látható Élbeállítások ikonra.
  5. A Color (Szín) legördülő listából válassza ki a By axis (Tengely szerint) lehetőséget. A modellben az élek színei megváltoznak, hogy visszatükrözzék a tengelyekhez való igazodásukat (kivéve, ha egy él nem igazodik tengelyhez, mert akkor az él színe nem változik). A következő ábra azt mutatja, hogy mely élek igazodnak (vagy nem igazodnak) a három tengelyhez.