Skip to Content
Help

CAD fájlok importálása és exportálása

Last updated: okt. 21, 2026•6 p read.

A leggyakoribb CAD-formátumok a .dwg és a .dxf. Ezek a formátumok saját fejlesztésűek, és leggyakrabban az Autodesk és az AutoCAD alkalmazásokhoz kapcsolódnak, de más programok is használják őket. A SketchUp-előfizetők importálhatnak CAD-fájlokat a modelljeikbe, és exportálhatják a modelljeiket CAD-fájlként más szoftverekben való használathoz.

CAD-fájlok importálása

CAD-fájl importálásakor a SketchUp megpróbálja a fájlban lévő entitásokat SketchUp entitásokká alakítani. A SketchUp a következő importált CAD-entitásokat támogatja:

  • Ívek

  • Körök

  • Felületek

  • 3D-s felületek

  • Rétegek/címkék

  • Vonalak és vonalstílusok

  • Materials (Anyagok)

  • Vonallánc alapú tömör testek

  • Beágyazott blokkok

  • AutoCAD régiók

  • Pont

  • Ellipszis

  • Ék

  • Raszterképek

  • Kitöltött sraffozások

A SketchUp a következő CAD-entitásokat nem támogatja:

  • Saját ADT vagy ARX objektumok

  • Méretek

  • Szöveg

  • XREF-ek

Mielőtt importálná a CAD-fájlt, néhány lépéssel biztosíthatja, hogy minden szükséges adat bekerüljön a SketchUpba, és az importálási folyamat a lehető leghatékonyabb legyen.

Fájl előkészítése:

  • Nem támogatott elemek módosítása – Ha olyan CAD-elemeket kell importálnia a SketchUpba, amelyeket a program nem támogat, próbálja meg ezeket a CAD-ben szétbontani, és alakítsa át őket a SketchUp által támogatott elemekké.

  • Felesleges rétegek törlése – A SketchUp elvet minden olyan elemet, amelynek nincs 3D-s jelentősége. Azon rétegek, amelyeken ezek az elemek voltak, megmaradnak, és üres címkéket hoznak létre a SketchUpban. Ennek elkerülése érdekében az importálás előtt törölje ezeket a nem használt rétegeket.

  • Geometria mozgatása az origó közelébe – A tengely origótjáól túl messze lévő geometria teljesítményproblémákat okozhat. Ellenőrizze a geometria elhelyezését a CAD-fájlban, mielőtt importálja a CAD-fájlt a SketchUp programba.

  • Csökkentse a fájl méretét szükség szerint – Minél kisebb a CAD-fájl mérete, annál gyorsabb és egyszerűbb az importálás. A 15 MB-nál nagyobb fájlok teljesítményproblémákat okozhatnak. A fájlméret csökkentése érdekében csak a szükséges geometriát importálja, vagy fontolja meg a CAD-fájl több részre bontását.

  • Mentse a CAD-fájlt SketchUp-kompatibilis formátumba – Amikor a SketchUp CAD-fájlt importál, a SketchUp az információkat alapvető geometriai összetevőkre bontja. A régebbi CAD-formátumok esetleg nem működnek jól a SketchUppal. A problémamentes importálás érdekében mentse a régebbi verziókban létrehozott CAD-fájlokat újabb verzióba.

A fájl előkészítése után kövesse az alábbi lépéseket a CAD-fájl importálásához:

  1. Válassza a File > Import (Fájl > Importálás) elemet.

  2. Keresse meg az importálni kívánt CAD-fájlt.

  3. Fájltípusként válassza az AutoCAD Files (AutoCAD-fájlok) lehetőséget.

  4. Kattintson az Options (Beállítások) lehetőségre. Szükség szerint állítsa be a következőket:

    • A Pozíció alatt válassza a Preserve Drawing Origin (Rajzolás origójának megőrzése) lehetőséget, hogy az importált geometria a .dwg vagy .dxf fájlban meghatározott origóhoz kerüljön. Hagyja üresen, ha az importált geometriát a SketchUp origója közelébe szeretné helyezni.

    • Az Import Layers as Groups (Rétegek importálása csoportként) beállítás kiválasztásakor a program csoportokat hoz létre az importált CAD-fájl rétegstruktúrájának megfelelően. Ezek az importált rétegek továbbra is rendelkeznek saját címkével, és megfelelő, csoportosított geometriával.

    • Az Import Linework Flattened (Vonalkázás importálása síkban) lehetőség kiválasztásával az importált geometria Z értéke 0-ra változik, kiküszöbölve a Z tengely eltéréseit.

    • A Merge Coplanar Faces (Közös síkú felületek egyesítése) kiválasztása arra utasítja a SketchUp alkalmazást, hogy távolítsa el a síkokról a háromszög alakú vonalakat.

    • Az Orient Faces Consistently (Felületek egységes tájolása) kiválasztása arra utasítja a SketchUp alkalmazást, hogy elemezze az importált felületek irányát, és egységesen tájolja a felületeket.

    • Az Import Materials (Anyagok importálása) kiválasztásával az eredeti fájlból történik az importálás. Törölje a kijelölést, hogy ezek az anyagok ne legyenek importálva.

    • Válasszon egy méretarány opciót, amelyet az importált fájl fog használni. A lehetőségek a következők: modellegység, hüvelyk, láb, yard, mérföld, milliméter, centiméter, méter és kilométer.

  5. Kattintson az OK gombra.

  6. Kattintson az Import (Importálás) lehetőségre.

A CAD-fájl importálása után előfordulhat néhány ismert hiba:

  • A méret vagy a méretarány nem a vártnak megfelelően kerül importálásra . Ez különösen igaz, ha nem volt biztos abban, hogy milyen mértékegység használatával készült a CAD-fájl.

  • Előfordulhat, hogy a vonalak nem kapcsolódnak össze felületekké . Az ilyen apró rések felkutatása nehéz lehet.

Az importált fájl használatának megkezdése előtt az alábbi lépéseket követve bizonyosodjon meg arról, hogy az importált fájl készen áll a modellezésre:

  1. Ellenőrizze az importált CAD-geometria méretét, és szükség esetén méretezze át a helytelen méréseket.

  2. Győződjön meg arról, hogy a CAD-geometria egyetlen csoportot alkot. Ha a modellben már vannak csoportosított geometriák, a SketchUp automatikusan csoportosítja az importált CAD-geometriát is.

  3. Igazítsa az alaprajzot a SketchUp rajztengelyeihez.

  4. Törölje az összes felesleges címkét, és adjon a CAD-csoportnak saját címkét.

  5. Szükség szerint állítsa be az élstílusokat.

Exportálás 2D CAD-formátumba

Amikor egy SketchUp-modellt CAD-formátumba exportál, a SketchUp az alábbi módokon alakítja át az adatokat:

  • A SketchUp-geometria jobb szimulálása érdekében a SketchUp-felületeket belső rejtett vonalakat tartalmazó háromszög alakú sokfelületű hálóként kerünek exportálásra.

  • A SketchUp az aktuális mértékegységet használja referenciaként a .dwg vagy .dxf fájlba történő átalakításhoz.

  • Kettőzött vonal entitásokat nem hoz létre a rendszer p-vonal entitás tetején.

Modell exportálása 2D CAD-fájlként:

  1. Mielőtt elkezdené az exportálási folyamatot, a Camera > Standard Views (Kamera > Standard nézetek) menüpontban győződjön meg róla, hogy a modellje szabványos nézetben van.

  2. Válassza a File > Export > 2D Graphic (Fájl > Exportálás > 2D-s grafika) lehetőséget.

  3. Válassza ki az exportálás helyét.

  4. Válassza ki a .dwg vagy a .dxf fájltípust.

  5. Kattintson az Options (Beállítások) lehetőségre. Szükség szerint állítsa be a következőket:

    1. AutoCAD verzió – Válassza ki, hogy az AutoCAD melyik verziójába kíván exportálni.

    2. Rajzolási méretarány és méret – Alapértelmezés szerint a Full Scale (Eredeti nagyság) van kiválasztva. A négyzet kijelölésének megszüntetésével lehetősége van egyéni méretarány beállítására.

    3. Profilvonalak – Testre szabhatja, hogyan jelenjenek meg a profilvonalak az exportált fájlban.

      • Az exportált profilvonalak normál szélességének beállításához válassza a None (Nincs) lehetőséget.

      • Ha AutoCAD vonalláncként szeretné exportálni a profilvonalakat, válassza a Polylines with Width (Vonalláncok szélességgel) lehetőséget.

      • Ha AutoCAD széles vonalú entitásként szeretné exportálni a profilvonalakat, válassza a Wide Line Entities (Széles vonalú entitás) lehetőséget.

      • Alapértelmezés szerint a Separate on a Layer (Különválasztás egy rétegen) ki van választva, és létrehoz egy réteget a profilélek számára.

    4. Metszetvonalak – Ezek a beállítások metszetvonalak vagy metszetszeletek exportálásakor érhetők el. A beállítások működésével kapcsolatos olvassa el a Modell szeletelése bepillantásért című részt.

    5. Éltoldatok – Egyes CAD alkalmazásoknak problémái lehetnek a vonalvégpontok és kereszteződések felismerésével, amikor a modell SketchUp vonaltoldatokat használ. Törölje a Show Extensions (Toldatok megjelenítése) bejelölését, hogy kikapcsolja a toldatokat az exportált fájlban. Ha bejelölve hagyja a Show Extensions (Toldatok megjelenítése) négyzetet, és törli az Automatic (Automatikus) bejelölését, a Length (Hosszúság) mezőbe beírhatja a vonaltoldatok pontos hosszát.

  6. Kattintson az OK lehetőségre az exportálási párbeszédpanelhez való visszatéréshez.

  7. Kattintson az Export (Exportálás) lehetőségre.

SketchUp modell exportálása 3D-s CAD fájlként

Amikor 3D CAD-fájlként exportál SketchUp-modellt, az alábbi lépéseket követve exportálhatja a teljes modellt, vagy csak bizonyos entitástípusokat: