Összetett 3D-s alakzatok modellezése a Téridom eszközökkel
A SketchUp téridom eszközeivel új alakzatokat hozhat létre, kombinálva vagy elvágva egy alakzatot a másikkal, megkönnyítve ezzel a külső héj vagy asztalosmunka modellezését.
A következő táblázatban megtekintheti a téridom eszközök gyors bemutatását, beleértve az eszköz funkcióját, illetve azt is, hogy elérhető-e a SketchUp Free verzióban.
Eszköz | Név | Funkció | Elérhető a SketchUp Free-ben? |
|---|---|---|---|
Külső héj | Az átfedő téridomoknak csak a külső felületeit hagyja meg. | Igen | |
Egyesítés | Két vagy több téridomot egyetlen alakzatban egyesít. | Csak előfizetés esetén | |
Kivonás | Az egyik téridom eltávolítja egy másik egy részét, és törlődik. | Csak előfizetés esetén A SketchUp Free verzióban használja az Intersect with Model (Metszés a modellel) lehetőséget. | |
Vágás | Az egyik téridom megvágja a másikat, de a modellben marad. | Csak előfizetés esetén | |
Metszés | Csak a metsző geometriát hagyja meg. | Csak előfizetés esetén | |
Felosztás | A téridomokat a metsző geometria mentén osztja fel. | Csak előfizetés esetén |
A Solid Tools (Téridom eszközök) a SketchUp felület következő részein találhatók:
SketchUp Pro
Solids (Téridomok) eszköztár
Tools (Eszközök) menü (válassza a Tools > Outer Shell (Eszközök > Külső héj) vagy a Tools > Solid Tools (Eszközök > Téridom eszközök) lehetőséget, majd válassza ki a másik eszközt egy almenüből)
Eszközpaletta (macOS)
Webes SketchUp
Solids (Téridomok) eszköztár a bal oldali tálcán
Solid Inspector segédprogram a jobb oldali panelen
A következő videóban a Solid (Téridom) eszközök működésére láthat példákat. A cikk következő részeiben elolvashatja az egyes eszközök használatának lépéseit és részleteit. (Ne feledje azonban, hogy többé nem helyezheti el a SketchUp modelleket a Google Earth programban.)
Tartalomjegyzék
Külső héj létrehozása
Téridomok egyesítése egyetlen alakzatban
Az egyik téridom kivonása egy másikból (vagy használja az Intersect with Model (Metszés a modellel) lehetőséget)
Egyik téridom vágása egy másikkal
Csak a metsző geometria meghagyása
Téridomok felosztása
SketchUp Web: Modellek javítása a Solid Inspector segédprogrammal
Külső héj létrehozása
Tegyük fel például, hogy két modellje van: az egyik egy részletes belső és külső épületmodell. A másik modell az épületet egy utcaképen ábrázolja, amelyen a környező épületek, utcák és tereprendezés látható. Importálhatja a részletes épületmodellt az utcaképbe, de ez a sok geometria lassíthatja az utcakép modelljét, és felesleges. Az utcaképen az épület külső héjának létrehozása kiküszöböli a belső geometriákat, amelyekre nincs szükség, így az utcakép modellje könnyebb és gyorsabb lesz munka közben.
Ha egymást átfedő csoportokból vagy összetevőkből szeretne külső héjat létrehozni, kövesse az alábbi lépéseket:
SketchUp Pro
- A Select (Kiválasztás) eszközzel (
) jelölje ki az összes olyan metsző csoportot vagy összetevőt, amelyet bele szeretne foglalni a külső héjba. - A jobb egérgombbal kattintson a kijelölésére, majd a megjelenő menüből válassza az Outer Shell (Külső héj) lehetőséget, az ábra szerint. A külső felületek megmaradnak.
Vagy a következőképpen hozhat létre külső héjat:
- Válassza ki a Külső héj eszközt (
). Kattintson az első csoport vagy összetevő kiválasztásához a külső héjban.
Kattintson a második csoportra vagy összetevőre. A SketchUp a kijelöléseit úgy egyesíti egy külső héjban, hogy csak a külső felületek maradnak meg.
(Opcionális) Folytassa a további csoportokra vagy összetevőkre kattintást, hogy felvegye őket a külső héjába, az ábra szerint.

Webes SketchUp
- Válassza ki a Külső héj eszközt (
) a bal oldali eszköztálcáról. Kattintson az első csoport vagy összetevő kiválasztásához a külső héjban.
Kattintson a második csoportra vagy összetevőre. A SketchUp a kijelöléseit úgy egyesíti egy külső héjban, hogy csak a külső felületek maradnak meg.
(Opcionális) Folytassa a további csoportokra vagy összetevőkre kattintást, hogy felvegye őket a külső héjába, az ábra szerint.

Téridomok egyesítése egyetlen alakzatban
Az egyesítés két vagy több téridomot egyesít egyetlen téridommá.
Az egyesítés eredménye hasonló a külső héj eredményéhez. Az egyesítés eredménye azonban tartalmazhat belső geometriát, míg a külső héj csak külső felületeket tartalmaz. (Példát az előző ábrán láthat.)
A Union (Egyesítés) eszköz téridomok kombinálásához a következőképpen használható:
- Válassza az Egyesítés eszközt (
). Kattintson az első csoport vagy összetevő kiválasztásához az egyesítéshez.
Kattintson a második csoportra vagy összetevőre. A geometria ebből származó egyesítése megmarad.
(Opcionális) Folytassa a további csoportokra vagy összetevőkre kattintást, hogy felvegye őket az egyesítésbe, amint az ábrán látható, amely röntgen nézetet alkalmaz, hogy láthassa az egyes téridomok belsejében lévő geometriákat.

Az egyik téridom kivonása egy másikból (vagy használja az Intersect with Model (Metszés a modellel) lehetőséget)
A Kivonás eszközzel egy téridom entitás felhasználásával kivághat egy másik téridom entitást. Ezután az eredeti téridom entitást kivonja a program a modellből. Ahhoz, hogy a kivonás működjön, a két téridomnak át kell fednie egymást.
Vágás végrehajtásához kövesse az alábbi lépéseket:
- Válassza ki a Vágás eszközt (
). Kattintson a vágó csoport vagy összetevő kiválasztásához. Az itt látható példában először válassza ki a csapot, hogy lyukat készítsen a deszkában. Miután választott, a kurzor melletti 1-es 2-esre változik.
Kattintson a kivágni kívánt csoportra vagy összetevőre. A vágó csoport megmarad, de egy lyukat hoz létre a második kijelölésben. Az eredmény először nehezen látható (lásd az 1. képet). Ha azonban kiveszi a csapot a lyukból, amint a 2. kép mutatja, láthatóvá válik a lyuk a deszkában.

Csak a metsző geometria meghagyása
Metszés végrehajtásához kövesse az alábbi lépéseket:
- Válassza ki a Metszés eszközt (
). Válasszon egy téridom entitást, amelyet használni szeretne a metszetben.
Válasszon ki további egy vagy több téridomot, amelyek átfedik a kezdeti kijelölését. Az így kapott metsző geometria megmarad. Ebben a példában a doboz és a gömb metszéspontja (1. kép) egy kerek alapú pontot hoz létre (2. kép).

Téridomok felosztása
- Válassza a Felosztás eszközt (
). Kattintson egy téridom entitásra.
Kattintson egy másik téridom entitásra, amely metszi az első kijelölését. A SketchUp felosztja az összes geometriát azon élek mentén, ahol a kijelölt téridomok metszik egymást. Például az ábrán a bal oldalon látható két csoport 3 csoportra oszlik, a jobb oldalon látható módon.

Modellek javítása a Solid Inspector segédprogrammal a SketchUp Web alkalmazásban
Ahogyan a geometria egyre összetettebbé válik, apró hibák megakadályozhatják a modellek sokszorosítását. A Solid Inspector a SketchUp for Web egy olyan segédprogramja, amely segít előkészíteni a modelleket a 3D-s nyomtatásra azáltal, hogy megkeresi és kijavítja az olyan problémákat, melyek megakadályozzák, hogy a SketchUp téridomként osztályozhassa a modellt. Ez az ellenőrzés ahhoz is hasznos, hogy kijavítsa a 3D-s modelleket a Téridom eszközökkel végzett műveletekhez.