Přidávání barev a textur pomocí materiálů

Chcete-li do modelů přidat detaily a zdání reality, umožňuje aplikace SketchUp malovat materiály na plochách. Materiály jsou v podstatě povrchové úpravy, které mají barvu a volitelnou texturu (definovanou v souboru obrázku). Například na následujícím obrázku má střešní materiál modrou barvu a texturu, která simuluje kovovou střešní krytinu. Obklady fasád a tráva jsou také materiály, které mají barvu a strukturu.

Po aplikaci takovýchto materiálů na váš model vám speciální možnosti materiálů v aplikaci SketchUp mohou pomoci provést některý z následujících úkonů:

  • Nahradit jeden materiál za jiný: Řekněme, že místo šindelů chcete zobrazit kovovou střechu. Střešní materiál můžete vyměnit za šindele snadno a rychle.
  • Upravte materiál: Vzhledem k tomu, že barva a textura jsou oddělené, můžete je měnit navzájem nezávisle. Můžete například změnit barvu obkladů fasád (jak vypadá žlutá?) ale zachovat stejnou texturu. Můžete také upravit průhlednost materiálu, která určuje, jak je materiál neprůhledný nebo transparentní.
  • Vypočítejte, kolik materiálu potřebujete: SketchUp vám může sdělit plochu všech šindelů nebo obkladů fasád. Ať už tento výpočet znamená cokoli, musíte vytvořit přesný model tak, aby čísla odrážela skutečnou velikost vašeho modelu.
Tip: Aplikace SketchUp obsahuje několik sbírek materiálů: koberec, dlaždice, rostlinné porosty, sklo, dřevo a další. Pokud však není k dispozici konkrétní materiál, který potřebujete, můžete vytvořit vlastní materiál. Tato funkce je obzvláště užitečná, pokud jste dekoratér nebo stavitel, který potřebuje ukázat svým klientům přesné povrchové úpravy.

V rozhraní aplikace SketchUp modelujete materiály nástrojem Vyplnit barvou () a panelu Materiály (Microsoft Windows) nebo panelu Barvy (macOS). Panel Materiály nebo Barvy také umožňuje prohlížet, spravovat a organizovat materiály. Panely Materiály nebo Barvy udržují přehled o materiálech v modelu a v něm můžete vytvářet vlastní kolekce materiálů specifické pro vaše projekty nebo pracovní postupy.

Poznámka: Pokud přepínáte mezi počítači se systémem Microsoft Windows a macOS, všimněte si, že rozhraní panelu Materiály a rozhraní panelu Barvy jsou pro příslušné operační systémy jedinečné. V následujících částech naleznete pokyny pro systém Microsoft Windows nebo macOS podle toho, který operační systém jste si vybrali z rozevíracího seznamu na libovolné stránce Centra nápovědy.

V následujícím videu uvidíte, jak aplikovat materiály a provést několik běžných změn – například výměna jednoho materiálu za jiný. Kroky, které vás provedou podrobným používáním materiálů, naleznete v následujících částech.

Použití materiálů

Použití materiálů na model je opravdu jednoduché: Vyberte plochu nebo plochy a poté vyberte požadovaný materiál. Pokud malujete skupiny nebo komponenty, podívejte se na tipy na konci této části, což může ještě více usnadnit nanášení materiálů.

Materiály nanášíte na model pomocí nástroje Vyplnit barvou (), který najdete v následujících částech rozhraní aplikace SketchUp:

    Windows
  • Panel nástrojů Začínáme
  • Velký panel Sada nástrojů
  • Hlavní panel nástrojů
  • Nástroje > Vyplnit barvou na panelu nabídek

Chcete-li na svůj model začít používat materiály, postupujte takto:

  1. Vyberte nástroj Vyplnit barvou ().
  2. Na panelu Materiály, který se otevře, klikněte na kartu Vybrat. Pokud se panel Materiály v panelu neotevře, dialogové okno může být ve skrytém panelu. V takovém případě umístěte kurzor nad kartu skrytého panelu. Tím se panel rozbalí. Poté můžete v panelu otevřít panel Materiály.
  3. Z rozevíracího seznamu vyberte kolekci materiálů.
  4. Klikněte na materiál, který chcete použít.
    Tip: Chcete-li vzorek materiálu, který je již ve vašem modelu, podržte stisknutouklávesu Alt a dočasně přepněte na nástroj Vzorek. Pomocí kurzoru v podobě kapátka klikněte na plochu, z níž chcete odebrat vzorek. Uvolněním klávesy Alt se vraťte do nástroje Vyplnit barvou.
  5. Zpátky na kreslicí ploše klikněte na plochu nebo plochy a aplikujte materiál.

Použití materiálů v aplikaci SketchUp pro Windows

Tip: Chcete-li obnovit výchozí barvy, postupujte podle předchozích kroků, ale místo kliknutí na materiál klikněte v pravém horním rohu na položku Nastavit materiál na Malování s výchozím () a kliknutím na plochu v modelu použijte výchozí barvy.

    macOS
  • Velký panel Sada nástrojů
  • Nástroje > Vyplnit barvou na panelu nabídek
  • Paleta nástrojů

Chcete-li na svůj model začít používat materiály, postupujte takto:

  1. Vyberte nástroj Vyplnit barvou (). Na panelu Barvy, který se zobrazí, můžete vybrat barvu v jedné ze čtyř karet k výběru barvy nebo použít kolekce materiálů.
  2. Chcete-li procházet kolekcemi materiálů, klikněte na kartu Palety textur, která obsahuje ikonu cihly. (Podrobnosti o používání ostatních karet, které slouží k výběru barev, najdete v části Míchání barev v dialogu Výběr barvy.)
  3. Z rozevíracího seznamu vyberte kolekci materiálů. Na následujícím obrázku je vybrána kolekce Střešní krytina.
  4. Klikněte na materiál, který chcete použít na svůj model.
    Tip: Chcete-li vzorek materiálu, který je již v modelu, klikněte na nástrojKapátko v dolní části karty Palety textur. Pomocí kurzoru v podobě velkého kruhu klikněte na plochu, z jejíhož materiálu chcete odebrat vzorek. Tím se načte materiál do vzorníku vzorku a znovu se zobrazí kurzor Vyplnit barvou.
  5. Zpátky na kreslicí ploše klikněte na plochu nebo plochy a aplikujte materiál.

Alternativně klikněte a přetáhněte vzorek materiálu z hlavní oblasti karty Palety textur na plochu v modelu. (Vzorník nelze přetáhnout z palety ve spodní části panelu Barvy systému macOS. Podrobnosti o používání těchto uložených vzorníků naleznete v části Míchání barev v dialogu Výběr barvy.)

Tip: Chcete-li se vrátit k výchozím barvám, vyberte políčko Výchozí v kolekci Barvy v modelu.

Tip: Pokud se vybraný materiál po kliknutí na plochu nezobrazí, model zřejmě používá styl, který nezobrazuje textury. Chcete-li si to ověřit, otevřete panel Styly, vyberte kartu Upravit a klikněte na ikonu Nastavení plochy. V oblasti Styl zkontrolujte, zda je vybrána možnost Zobrazit stínované pomocí textur.

Pokud vaše styly zobrazují textury, může mít počítač nedostatek volné paměti k zobrazení materiálů v modelu. Nápověda viz Oprava problému v aplikaci SketchUp.

Můžete malovat více ploch a hran najednou. Chcete-li to provést, použijte nástroj Výběr () k výběru hran a ploch, které chcete malovat. Poté přepněte na nástroj Vyplnit barvou a aplikujte materiál. (Výběr geometrie nabízí tipy k provádění výběru.)

Když aplikujete materiály na několik ploch najednou, nezapomeňte na následující:

  • Plochy mají dvě strany: přední a zadní. Můžete namalovat přední nebo zadní stranu všech vybraných ploch, ale ne jejich kombinaci. Strana, kterou malujete, je určena stranou, na kterou kliknete kurzorem Vyplnit barvou. Na následujícím obrázku vybarvíte klepnutím na přední část plochy všechny přední plochy ve výběru, přestože vidíte dvě přední plochy a dvě zadní plochy.
  • Pomocí stylu ovládejte vzhled zadních okrajů. Když vyberete plochu a všechny hrany a malujete přední část plochy, namalují se všechny vybrané hrany. Pokud však malujete zadní plochy a žádná z hran se nenamaluje. Chcete-li prolnout zadní hrany s materiály, otevřete panel Styly, klikněte na kartu Upravit, klikněte na ikonu Nastavení hran a z rozevíracího seznamu Barva vyberte možnost Podle materiálu.

Materiály lze použít na skupinu nebo komponentu jako celek nebo na určitou geometrii v rámci skupiny nebo komponenty:

  • Chcete-li namalovat celou skupinu nebo komponentu, vyberte ji a použijte na ni materiál. Pokud vyberete skupinu nebo komponentu a použijete materiál, budou namalovány pouze plochy ve výchozím materiálu.
  • Chcete-li namalovat geometrii ve skupině nebo komponentě, její kontext otevřete dvojitým kliknutím na ni. Poté vyberte plochy, které chcete malovat materiálem.

Následující video ukazuje několik tipů a triků při aplikaci materiálů na součásti. Nebo si přečtěte kroky, které vás provedou postupem, jak malovat všechny komponenty nebo jejich části.

Tip: Chcete-li snadno a rychle modelovat variace materiálů, kombinujte techniky malování všech součástí a jejich částí.

Chcete-li vidět, jak tento tip funguje, řekněme, že modelujete židli s dřevěným rámem a dvěma polštáři, a chcete ukázat čtyři barvy polštářů. Zde zobrazený náčrt ukazuje, že každý prvek židle (rám a dva polštáře) jsou skupina, z nichž všechny jsou vnořeny ve skupině, která je pak vnořena do komponenty. (Podrobnosti o vytvoření náčrtu naleznete v části Uspořádání modelu.)

Následující kroky vysvětlují nejjednodušší způsob použití materiálů a zobrazení čtyř barevných možností:

  1. Vzhledem k tomu, že rám je stejný na všech židlích, vyberte skupinu rámu a aplikujte dřevěný materiál, jak je znázorněno zde.
  2. Vytvořte kopii pro každou barvu polštáře. (Kopírování toho, co jste již nakreslili, vysvětluje způsob.)
  3. Vyberte komponentu a použijte barevný materiál polštáře. Protože rám je již natřený, ale polštáře jsou stále výchozí barvy, barevným materiálem se natřou pouze polštáře. Rám zachovává dřevěný materiál.
  4. Předchozí krok zopakujte pro každou volbu barvy. Výsledek vidíte na následujícím obrázku.

Tip: Pokud je v jiných skupinách a komponentách vnořeno několik skupin nebo komponent, aplikace SketchUp vám nemusí umožnit malovat kliknutím na skupinu nebo komponentu, která je nejvíce nahoře. Pokud narazíte na tento problém, zkuste použít materiály na skupinu nebo komponentu vnořenou v hierarchii níže. Náčrt vám pomůže zjistit, kde je váš výběr v hierarchii.

Náhrada jednoho materiálu jiným

Protože aplikace SketchUp umožňuje nahradit jeden materiál jiným, můžete s materiály experimentovat snadno a rychle. V kuchyni si prohlédněte různé materiály pultu, jako je černá žula, modrá dlaždice a bílý kompozitní materiál. Pokud vybíráte domácí barvy, porovnejte žluté obložení a tmavě zelenou úpravu s námořnickým obložením a krémovou úpravou. Když znáte modifikátory klávesnice, je celý proces hračka. Podívejte se na ně v následující tabulce.

Náhrada jednoho materiálu jiným... Klávesa modifikátoru (Microsoft Windows) Klávesa modifikátoru (macOS)
Na sousedících plochách Ctrl Volba
Na všech plochách v aktuálním kontextu (například ve stejné skupině nebo komponentě) Shift Shift
Na všech připojených plochách Ctrl+Shift Alt+Shift

Zde je příklad, který vám pomůže představit si, jak fungují jednotlivé zkratky. Řekněme, že se snažíte zjistit barvy abstraktní nástěnné malby na dvou oddělených stěnách. Následující obrázek znázorňuje nástěnnou malbu napodobující materiály z kolekce Pojmenované barvy.

Chcete-li zjistit, jak může vypadat náhrada červené barvy zelenou barvou, vyberte nástroj Vyplnit barvou a potom z panelu Materiály (Microsoft Windows) nebo v panelu Barvy (macOS) vyberte zelenou barvu. Pokud kliknete s klávesou Ctrl nebo Alt na červený trojúhelník vlevo nahoře, budou pouze přilehlé plochy s červeným materiálem nahrazeny zelenou barvou, jak je znázorněno na následujícím obrázku.

Pokud místo toho kliknete se stisknutou klávesou Shift, všechny červené plochy se změní na zelenou:

Pokud ale kliknete se stisknutou klávesou Ctrl+Shift nebo Alt+Shift, červené plochy se změní na zelenou pouze na levé stěně:

Úpravy materiálů

Aplikace SketchUp umožňuje upravovat materiály. Při provádění změn se všechny plochy namalované materiálem, který upravujete, automaticky aktualizují. Protože každý materiál má barvu a volitelnou texturu, můžete barvu a texturu upravovat navzájem nezávisle.


Úpravy materiálu v aplikaci SketchUp jsou užitečné zejména tehdy, když máte jeden materiál aplikovaný na mnoho ploch. Úpravou materiálu – namísto pouhé výměny na jedné ploše – se všechny plochy namalované daným materiálem, který upravujete, automaticky aktualizují. Protože každý materiál má barvu a volitelnou texturu, můžete barvu a texturu upravovat navzájem nezávisle.

Poznámka: Úpravy materiálů jsou v aplikaci SketchUp pro webovou aplikaci součástí placených předplatných. K dispozici jsou také pro uživatele aplikace SketchUp for Schools.

Před úpravou je třeba materiál uložit s modelem. Chcete-li zobrazit materiály uložené s modelem, otevřete panel Materiály v panelu nástrojů na pravé straně obrazovky.

Chcete-li upravit materiál, vyberte ho z Materiálů v modelu (pod ikonou Výchozí) nebo ho můžete vybrat z okna modelování pomocí nástroje Kapátko , který automaticky vybere materiál v panelu Materiály. Jakmile vyberete materiál, klikněte na ikonu Upravit vedle miniatury materiálu.

Při úpravách materiálů můžete konfigurovat:

  • Název materiálu: Zadejte nový název materiálu, který chcete změnit jako název upravovaného materiálu.
  • Barva: Barvu materiálu můžete přizpůsobit pomocí výběru barvy aplikace SketchUp ručně nebo zadáním určitých hodnot RGB, HSL nebo HEX. Při manipulaci s barevnými změnami uvidíte své úpravy v reálném čase.
  • Obrázek: Přidejte nebo změňte texturu obrázku tak, aby se spojila s materiálem. Přidání nebo změna textur obrázku může přepsat váš výběr barvy materiálu. Texturu obrazu můžete také zcela odstranit z materiálu kliknutím na tlačítko „X“.
  • Velikost materiálu: Když použijete texturu obrazu na plochu, obraz textury se rozloží na dlaždice, aby vyplnil plochu. Chcete-li změnit velikost dlaždice textury, zadejte hodnotu do pole Šířka nebo Výška. Ve výchozím nastavení je zachován poměr stran obrazu. Pokud tedy do pole Rozměr šířky zadáte hodnotu 2, výškový rámeček se automaticky aktualizuje, aby se zachoval poměr stran. Kliknutím na ikonu řetězu přerušíte řetězec (omlouvám se, Fleetwood Mac) a můžete zkreslit poměr stran k obsahu svého srdce. Pokud se vám výsledky nelíbí (a už nikdy se vám nebudou líbit), můžete kliknout na tlačítko Storno v dolní části nabídky nebo vrátit změny kliknutím na Ctrl/Command+Z.
  • Neprůhlednost: Můžete také upravit, nakolik je váš materiál průhledný nebo neprůhledný. Posunutím posuvníku neprůhlednosti doprava se zvyšuje neprůhlednost, kde 100 znamená naprostou neprůhlednost. Posunutím posuvníku doleva zvýšíte průhlednost, kde 0 je zcela transparentní. Alternativně zadejte do pole Neprůhlednost číslo od 0 do 100.

Poznámka: Všechny provedené úpravy materiálu lze zrušit klepnutím na tlačítko 'Storno' v dolní části panelu Upravit materiály. Pokud přijmete změny úprav materiálu, můžete také pomocí příkazů Zpět a Znovu přecházet mezi původním a upraveným materiálem také pomocí příkazů Zpět a Znovu.

Windows

Před úpravou je třeba materiál uložit s modelem. Chcete-li zobrazit materiály uložené s modelem, otevřete panel Materiály a klepnutím na ikonu V modelu () zobrazte kolekci V modelu, jak je znázorněno na následujícím obrázku.

Pokud se materiál, který chcete upravit, nezobrazí ve sbírce V modelu, můžete materiál uložit do sbírky V modelu bez ohledu na to, zda je materiál aktuálně aplikován na plochy v modelu. Chcete-li přidat materiál do sbírky V modelu, postupujte takto:

  1. Klikněte na ikonu Zobrazit podokno sekundárního výběru () v pravém horním rohu panelu Materiály.
  2. V sekundárním podokně dole procházejte kolekce materiálu, který chcete upravit.
  3. Přetáhněte vzorek materiálu do své sbírky V modelu.

Chcete-li materiál upravit, vyberte jej ve sbírce V modelu a klikněte na kartu Upravit, uvedenou na následujícím obrázku.

Zde je stručný úvod ke všem nástrojům pro úpravu barvy materiálu:

  • Rozevírací výběrový seznam: V rozevíracím výběrovém seznamu volte mezi HLS (odstín, světlo, sytost), HSB (odstín, sytost a jas), RGB (červená, zelená, modrá) a kolečkem pro výběr barev. Podrobnosti o výběru barvy viz Míchání barev v dialogu pro výběr barvy.
  • Vrácení změny barev: Kliknutím na toto políčko můžete vrátit zpět všechny změny barev, které provedete během relace úprav.
  • Tlačítko Spárovat barvu objektu V modelu: Kliknutím na toto tlačítko změníte kurzor na kapátko. Pomocí kurzoru kapátko klikněte na entitu, abyste vyzkoušeli její barvu a aplikujte tuto barvu na materiál, který upravujete.
    Tip: Pokud zkoušíte texturovaný materiál, variace textur mohou trochu zamaskovat barvu materiálu. Chcete-li vyzkoušet určitou barvu z textury, lepších výsledků dosáhnete s tlačítkem Přizpůsobit barvu na obrazovce.
  • Tlačítko Spárovat barvu na obrazovce: Klikněte na toto tlačítko a poté kliknutím na libovolné místo na obrazovce s kurzorem kapátko vyzkoušejte barvu obrazových bodů. Aplikace SketchUp pak použije tuto barvu na aktuálně vybraný materiál.

Následující nástroje vám umožňují pohrát si s texturou materiálu:

  • Zaškrtávací políčko Použít obrázek textury: Pokud je toto políčko zaškrtnuto, můžete vložit obrazový soubor, který představuje texturu. Zrušení zaškrtnutí políčka odstraní obrazový soubor textury. (Všimněte si, že opětovným zaškrtnutím políčka se obrazový soubor neobnoví. Místo toho budete vyzváni k výběru nového obrazového souboru.)
  • Obrazový soubor textury a tlačítko Procházet: Pole souboru textury obsahuje název obrazového souboru (představujícího texturu), pokud existuje, spojeného s aktuálním materiálem. Chcete-li změnit texturu, přetáhněte soubor obrázku do tohoto pole nebo kliknutím na tlačítko Procházet zobrazte dialogové okno Vybrat obrázek, kde můžete vyhledat obrazový soubor na pevném disku. Jakmile použijete texturu, můžete také upravit způsob rozložení textury na dlaždice v modelu. Podrobnosti viz další část Přemístění textur.
  • Tlačítko Upravit obrázek textury v externím editoru: Když kliknete na toto tlačítko, aplikace SketchUp otevře obrazový soubor textury ve výchozím editoru obrázků.
    Poznámka: Editor obrázků je určen v dialogu Předvolby aplikace SketchUp na panelu Aplikace. Podrobnosti o nastavení této předvolby viz Přizpůsobení pracovního prostoru. Pokud jste neurčili editor obrázků, aplikace SketchUp spustí výchozí editor nebo aplikaci pro zobrazení obrázků vašeho operačního systému.
  • Zaškrtávací políčko Kolorovat: Zaškrtněte toto políčko, chcete-li použít stejný odstín na celou texturu. Barva je definována v oblasti Barva na kartě Upravit. Tato volba je užitečná pro soubory, které nezobrazují správné barvy.
  • Obnovit vzorek barvy: Kliknutím na toto políčko barvy obnovíte barvu materiálu na barvu v obrazovém souboru textury.
  • Rozměry pole: Když nakreslíte texturu na plochu, obraz textury se rozloží na dlaždice, aby vyplnil plochu. Chcete-li změnit velikost dlaždice textury, zadejte hodnotu do pole pro šířku nebo výšku. Ve výchozím nastavení je zachován poměr stran obrazu. Pokud tedy do pole Rozměr šířky zadáte hodnotu 2, výškový rámeček se automaticky aktualizuje, aby se zachoval poměr stran. Kliknutím na ikonu řetězu přerušíte řetězec (pardon, Fleetwood Mac) a můžete zkreslit poměr stran. Pokud se vám výsledky nelíbí (a už nikdy se vám nebudou líbit), kliknutím na vodorovná a svislá tlačítka se šipkami se vrátíte k předchozímu nastavení šířky a výšky.
  • Posuvník neprůhlednosti: Neprůhlednost znamená, nakolik je váš obrázek průhledný nebo neprůhledný. Posunutím posuvníku neprůhlednosti doprava se zvyšuje neprůhlednost textury, kde 100 znamená naprostou neprůhlednost. Posunutím posuvníku doleva zvýšíte průhlednost textury, kde 0 je zcela průhledná. Alternativně zadejte do pole Neprůhlednost číslo od 0 do 100.

macOS

Před úpravou je třeba materiál uložit s modelem. Chcete-li zobrazit materiály uložené s modelem, vyberte Okno > Materiály a otevřete panel Barvy. Na kartě Palety textur (ikona cihly) klepněte na ikonu Barvy v modelu () nebo výběrem položky Barvy v modelu z rozevíracího seznamu zobrazte sbírku Barvy v modelu, jak je znázorněno na následujícím obrázku.

Pokud se materiál, který chcete upravit, nezobrazí v Barvách v modelu, aplikujte materiál na plochu v modelu. (Všimněte si, že pokud později nahradíte jeden materiál jiným, původní materiál zůstane ve sbírce Barvy v modelu, dokud nevyčistíte nepoužité materiály.)

Až budete připraveni upravit materiál, postupujte takto:

  1. Na kartě Paleta textur (ikona cihly) otevřete svou sbírku Barvy v modelu.
  2. Vyberte materiál, který chcete použít.
  3. V rozevíracím seznamu Barva vyberte Upravit . Nebo podržte klávesu Ctrl, klikněte na materiál a vyberte Upravit ze zobrazené nabídky.
  4. Na panelu Upravit materiál, který se zobrazí, jak je znázorněno na obrázku, vyberte požadované úpravy.
  5. Až skončíte, klikněte na tlačítko Zavřít.

Zde je úvod k možnostem na panelu Upravit materiál:

  • Název: Zadejte nový název materiálu, který chcete změnit, jako název upravovaného materiálu.
  • Upravit obrázek textury v externím editoru: Klikněte na toto tlačítko a ve výchozím editoru obrázků nebo programu náhledu se otevře obrazový soubor textury. Proveďte a uložte úpravy souboru a změny se projeví na materiálu.
  • Rozevírací nabídka Textura: Možnosti v této rozevírací nabídce umožňují upravit texturu v aplikaci SketchUp. Volbou Načíst vyberte nový obrazový soubor textury. Volbou Odstranit odstraníte obrazový soubor textury. (Při odstranění obrázku textury se zobrazí plochá barevná aproximace odstraněného obrázku.) Pokud jste kolorovali texturu, zvolte Obnovit barvu a odstraníte kolorizaci. Výběr Upravit otevře obrazový soubor textury ve výchozím editoru obrázků nebo programu náhledu. Jakmile použijete texturu, můžete také upravit způsob rozložení textury na dlaždice v modelu. Podrobnosti viz další část Přemístění textur.
  • Šířka a výška: Když nakreslíte texturu na plochu, obraz textury se rozloží na dlaždice, aby vyplnil plochu. Chcete-li změnit velikost dlaždice textury, zadejte hodnotu do pole Šířka nebo Výška. Ve výchozím nastavení je zachován poměr stran obrazu. Pokud tedy do pole Rozměr šířky zadáte hodnotu 2, výškový rámeček se automaticky aktualizuje, aby se zachoval poměr stran. Kliknutím na ikonu řetězu přerušíte řetězec (pardon, Fleetwood Mac) a můžete zkreslit poměr stran podle svého srdce. Pokud se vám výsledky nelíbí (a už nikdy se vám nebudou líbit), musíte si zapamatovat původní rozměry a zadat je ručně, abyste se vrátili k původním rozměrům obrázku.
  • Kolorovat: Když je otevřený panel Upravit materiál, můžete kolorovat soubor textury. Pomocí libovolné karty barev vyberte barvu a aplikujte ji na náhled materiálu na panelu Upravit materiál. Nebo klikněte na nástroj kapátko v dolní části panelu Barvy a klikněte na libovolný materiál v modelu nebo na kartě Palety textur (cihla).
    Tip: Kolorizace je skvělý způsob, jak experimentovat se změnami barev materiálu.
  • Neprůhlednost: Je-li otevřen panel Upravit materiál, můžete rovněž upravit neprůhlednost materiálu, což znamená, nakolik je váš obrázek průhledný. Posunutím posuvníku neprůhlednosti doprava se zvyšuje neprůhlednost textury, kde 100 znamená naprostou neprůhlednost. Posunutím posuvníku doleva zvýšíte průhlednost textury, kde 0 je zcela průhledná. Alternativně zadejte do pole Neprůhlednost číslo od 0 do 100.

Přemístění textur

Jakmile použijete texturu na jednu či více ploch v 3D modelu, můžete také upravit rozložení textury na plochu. Chcete-li to provést, použijete nástroj Pozice textury, který má dva režimy:

  • Režim pevného bodu: V tomto režimu můžete texturu přesouvat, otáčet, měnit měřítko nebo deformovat. Například v tomto režimu můžete upravit texturu na jedné ploše tak, aby byla v linii se stejnou texturou na jiné ploše, například na dvou plochách budovy.
  • Režim volného bodu: Pokud potřebujete texturu protáhnout nebo zmenšit, použijte režim volného bodu.

Takto upravíte texturu v režimu pevného bodu:

  1. V kontextové nabídce klikněte na materiál a vyberte Textura > Pozice ze zobrazené nabídky. Zobrazí se matice tečkovaných čar, která představuje jednotlivé dlaždice textury. Kurzor se také změní na ruku a zobrazí se čtyři body.
  2. Pokud vidíte čtyři barevné body, jak je znázorněno na následujícím obrázku, přejděte k dalšímu kroku. Pokud ne, v kontextové nabídce klikněte na materiál a vyberte Pevné body.
  3. Pomocí kurzoru ruky a/nebo bodů upravte texturu. V tomto příkladu je cílem posunout zelený bod tak, aby směr dřeva v horní části skříně odpovídal straně. Zde je rychlý přehled všech vašich možností:
    • Kliknutím a přetažením materiálu s kurzorem ruky přemístěte texturu jako celek.
    • Kliknutím na bod jej zvedněte a dalším kliknutím upusťte bod jinam na texturu.
    • Přetažením bodu změňte texturu. Přetažením modrého bodu změníte měřítko textury nebo ji rozstřihnete. Přetažením žlutého bodu zkreslíte texturu. Přetažením zeleného bodu změníte měřítko textury nebo ji otočíte kolem osy bodu přesunu. Přetažením červeného bodu, což je bod přesunu, přesunete texturu.
    Tip: V režimu Pevný bod můžete také v kontextové nabídce kliknout na texturu a zobrazí se další možnosti: převrátit texturu doleva nebo doprava nebo nahoru nebo dolů, otáčet texturu v krocích po 90 stupních. Možnost resetování vrátí texturu do původního stavu, zatímco volba Zpět jednoduše vrátí poslední příkaz. Pokud akci vrátíte zpět, můžete využít možnost Znovu.
  4. Až skončíte se změnou textury, v kontextové nabídce klikněte na texturu a vyberte možnost Hotovo . Nebo stačí kliknout mimo texturu a ukončit režim Pevný bod.

V režimu Volný bod můžete nastavit velikost dlaždice textury v poměru k modelu. Postup funguje takto:

  1. V kontextové nabídce klikněte na materiál a vyberte Textura > Pozice ze zobrazené nabídky. Ve výchozím nastavení jste v režimu pevného bodu.
  2. Přepněte do režimu volného bodu tak, že v kontextové nabídce kliknete na texturu a zrušíte možnost Pevný bod. V režimu Volný bodu vidíte čtyři bílé body, jak je znázorněno na následujícím obrázku.
  3. Kliknutím na bod jej zvedněte a dalším kliknutím umístěte bod na nové místo. Udělejte to se všemi čtyřmi body, abyste nastavili, kde se objeví rohy dlaždice textury. Pokud umístíte body do konfigurace, která není obdélníková, zkreslíte texturu.
  4. Až skončíte, v kontextové nabídce klikněte na texturu a vyberte možnost Hotovo. Nebo jednoduše kliknutím mimo texturu ukončíte režim volného bodu.
Tip: V režimu Volný bod vidíte velikost dlaždice textury pouze na vybrané ploše. Chcete-li změnit velikost dlaždice textury v celém modelu, použijte panel Materiály (Microsoft Windows) nebo panel Barvy (macOS). Podrobnosti viz předchozí část Úprava materiálů.

Automatický výpočet plochy materiálu

Pokud chcete, aby aplikace SketchUp vypočítala plochu povrchu vybarvenou materiálem, můžete v kontextové nabídce kliknout na materiál a vybrat Oblast > Materiál . V systému Windows můžete také v kontextové nabídce kliknout na materiál v panelu Materiály a vybrat Oblast z nabídky. (Pokud je položka nabídky Oblast šedá, materiál se nepoužije na žádné plochy.)

V každém případě dialogové okno Plocha zobrazuje celkovou plochu, na kterou je vybraný materiál použit. Zobrazení jednotek (například čtvereční stopy nebo čtvereční metry) závisí na jednotkách zadaných ve vaší šabloně. Podrobnosti o změně výchozích jednotek viz Nastavení šablon.

Pokud používáte klasifikace IFC, můžete vygenerovat sestavu o materiálech v celém modelu. Podrobnosti viz Klasifikace objektů (a konkrétně část o generování sestavy).

Správa a organizace materiálů

Panel Materiály (Microsoft Windows) nebo panel Barvy (macOS) vám pomůže najít a uspořádat materiály. V následujícím seznamu je vysvětleno, jak můžete spravovat materiály pomocí operačního systému, který jste vybrali v Centru nápovědy.

Windows

  • Prohlédněte si vložené kolekce: Na kartě Vybrat vyberte kolekci z rozevíracího seznamu a zobrazí se materiály.
  • Sledujte materiály ve vašem modelu: Klikněte na ikonu V modelu () a uvidíte všechny materiály, které jste použili na model.
  • Vymazání nepotřebných materiálů: I když materiál nahradíte jiným materiálem, takže původní materiál se již v modelu nezobrazuje, původní materiál zůstane ve sbírce V modelu, dokud jej neodstraníte tak, že v kontextové nabídce kliknete a vyberete možnost Smazat . Chcete-li odstranit všechny nepoužité materiály v modelu, musíte vybrat sbírku V modelu. Poté klikněte na Šipka podrobností () a vyberte možnost Vyčistit nepoužité. Nebo můžete vybrat Smazat vše a odebrat všechny materiály z modelu a sbírky V modelu.
  • Vytvořte si vlastní kolekce: Můžete vytvořit kolekci pro konkrétní projekt nebo vytvořit kolekci pro materiály, které vytváříte, například konkrétní barevné schéma, vzorníky textilií, možnosti terénní úpravy nebo cokoliv jiného, co opakovaně používáte. Na kartě Vybrat klikněte na Šipka podrobností () a vyberte možnost Otevření nebo vytvoření kolekce. V dialogovém okně Vybrat složku kolekce nebo vytvořit novou přejděte do složky, do které chcete uložit kolekci. Klikněte na tlačítko Nová složka, pojmenujte svou složku (název vaší kolekce) a klikněte na tlačítko Vybrat složku. Po vytvoření kolekce můžete přejít do složky a otevřít kolekci. Chcete-li do kolekce přidat materiály, přetáhněte je do kolekce z podokna sekundárního výběru nebo do své kolekce uložte vytvořené materiály.
  • Přidejte často používané kolekce k oblíbeným položkám: Na kartě Vybrat klikněte na šipku Podrobnosti a zvolte Přidat kolekci k oblíbeným. Aktuálně vybraná kolekce se pak zobrazí v seznamu oblíbených položek v dolní části rozevíracího seznamu. Můžete vybrat kolekci, klikněte na tlačítko šipka Podrobnosti a vyberte možnost Odebrat kolekci z oblíbených, pokud již nepotřebujete kolekci ve svém seznamu oblíbených položek.
    Poznámka: Klikněte na šipku Podrobnosti a můžete zvolit zobrazení materiálů jako malé, střední, velké nebo extra velké dlaždice. Zvolte možnost Seznam, chcete-li zobrazit názvy materiálů namísto vzorníku náhledu.

macOS

  • Procházet vložené kolekce: Chcete-li zobrazit materiály obsažené v aplikaci SketchUp, klikněte na ikonu Palety textur (cihla) a vyberte z kolekce v rozevírací nabídce, jako je Cihly a Obklady, Oplocení, Střešní krytina, Průsvitné nebo Dřevo. Každý materiál v kolekci se zobrazí jako vzorek, na který můžete kliknout kurzorem Kbelík barvy a aplikovat na model.
  • Sledujte materiály v modelu: Panel Barvy obsahuje speciální kolekci materiálů nazvanou Barvy v modelu, která obsahuje všechny materiály, které jsou aktuálně používány ve vašem modelu. Obsah této kolekce se generuje automaticky při přidávání materiálů do modelu SketchUp. Chcete-li zobrazit tuto kolekci, vyberte z rozevírací nabídky kolekce materiálů možnost Barvy v modelu nebo jednoduše klikněte na ikonu Barvy v modelu ().
  • Vymazání nepotřebných materiálů: I když materiál nahradíte jiným materiálem, takže původní materiál se již v modelu nezobrazuje, původní materiál zůstane ve sbírce Barvy v modelu, dokud jej neodstraníte tak, že v kontextové nabídce kliknete a vyberete možnostOdstranit. Chcete-li odstranit všechny nepoužité materiály v modelu, musíte vybrat sbírku Barvy v modelu. Pak vyberte Seznam > Vyčistit nepoužité. Nebo můžete vybrat Smazat vše a odebrat všechny materiály z modelu a sbírky Barvy v modelu.
  • Vytvoření vlastní kolekce: Můžete vytvořit kolekci pro konkrétní projekt nebo vytvořit kolekci pro materiály, které vytváříte, například konkrétní barevné schéma, vzorníky textilií, možnosti terénní úpravy nebo cokoliv jiného, co opakovaně používáte. Vyberte Seznam > Nový. Do pole Název seznamu, které se zobrazí, zadejte název a klikněte na OK. Nyní se zobrazí název, který jste zadali v rozevíracím seznamu kolekcí.
    Chcete-li přidat materiály do nové kolekce, můžete přetáhnout políčko vedle kapátka v dolní části panelu Barvy do podokna vzorníku nové kolekce. Nebo vytvořte nové textury a uložte je do kolekce. Chcete-li kolekci odebrat, vyberte Seznam > Odstranit.
Poznámka: Pokud jste zvyklí používat panel Materiály ve Windows, všimněte si, že panel Barvy v macOS neumožňuje přidávat často používané kolekce do seznamu oblíbených položek.

Vytváření vlastních materiálů

Materiály obsažené v aplikaci SketchUp vám pomohou začít používat materiály a zkoumat, jak fungují. Chcete-li aplikovat materiály specifické pro vlastní design nebo budovu, pravděpodobně budete muset vytvořit vlastní materiály. Proces je velmi snadný: Začněte s obrázkem, abyste vytvořili dlaždici textury a v případě potřeby zadejte barvu.

Windows

Chcete-li vytvořit nový materiál z vlastních souborů nebo kódů barev, postupujte takto:

  1. V panelu Materiály klikněte na ikonu Vytvořit materiál () vpravo nahoře.
  2. V dialogovém okně Vytvořit materiál, které se otevře, zadejte název nového materiálu do textového pole nahoře.
  3. Vyberte možnosti pro barvu, texturu a neprůhlednost nového materiálu. Možnosti fungují stejně jako ty v panelu Upravit. Podrobnosti viz předchozí část Úprava materiálů. Nebo pokud chcete porozumět možnostem barvy, podívejte se na část Míchání barev v dialogu Výběr barvy.
  4. Klikněte na OK. Nový materiál se zobrazí vybraný ve sbírce V modelu.

macOS

Chcete-li vytvořit nový materiál, který je texturou, postupujte takto:

  1. V panelu Barvy klikněte na kartu Paleta textur (s ikonou cihly).
  2. Vyberte kolekci, ve které se má nový materiál zobrazit.
  3. Vyberte Barva > Nová textura.
  4. V zobrazeném dialogovém okně vyberte obrazový soubor pro texturu.
  5. V zobrazeném panelu zadejte název textury, nastavte šířku a výšku velikosti dlaždic a klikněte na OK . Chcete-li kolorovat texturu, postupujte podle kroků v předchozí části, Úpravy materiálů.

A tady je návod, jak uložit určitou barvu jako materiál:

  1. Pomocí libovolné karty barev vytvořte požadovanou barvu, která se zobrazí ve vzorníku barev v dolní části panelu Barvy. Podrobnosti o výběru barvy viz Míchání barev v dialogu pro výběr barvy.
  2. Vyberte kartu Paleta textur (označovanou také jako ikona cihly).
  3. Přejděte do kolekce, do které chcete barvu uložit.
  4. Přetáhněte vzorek barvy ze spodní části panelu Barvy do oblasti vzorníku kolekce.
Tip: Své kolekce materiálů můžete také rozšířit stažením materiálů. Podrobnosti viz tento příspěvek z blogu SketchUpdate.