Skip to Content
Help

更新后迁移

最后更新时间: 10月 28, 2026•1 分钟 阅读。

在将 SketchUp 更新至新版本时,可以从旧版本迁移多项设置和自定义项。

迁移文件

使用受支持的 SketchUp 版本创建的 SketchUp 文件 (.skp) 无版本区分。当您将使用旧版受支持 SketchUp 创建的模型保存到 Trimble Connect 时,SketchUp 会保留并载入该模型中的所有分类、组件、材质和样式。

如果您希望手动迁移各项元素,请按照以下步骤操作:

安装新版本之前:

  1. 在 SketchUp 中,单击 Window > Preferences(窗口 > 首选项)(Windows) 或 SketchUp Preferences(SketchUp 首选项)(macOS)。

  2. 转到 Files(文件)部分。

  3. 选择需要迁移到新版本的每种文件类型。

  4. 在资源管理器或访达窗口中,将文件复制并保存到易于找到的位置。

安装新版本之后:

  1. 找到复制的文件。

  2. 打开新版本的 SketchUp,进入 Preferences(首选项)。

  3. 转到 Files(文件)部分。

  4. 将之前复制的文件粘贴到新版本的 Files(文件)对应的目录中。

Extension Migrator

Extension Migrator 可在 Extension Warehouse 中获取,并默认随 SketchUp 一并提供。Extension Migrator 可帮助您将扩展程序从受支持旧版本迁移到较新版本的 SketchUp。

更新 SketchUp 后,首次运行应用程序时,该工具会提示您进行迁移。Extension Migrator 还会运行 Migrate Preferences(迁移首选项)实用工具,将您的首选项设置从较早的受支持版本迁移过来。如果您需要手动运行该程序,请按照以下步骤操作:

  1. 单击 Extensions > Migrate Extensions(扩展程序 > 迁移扩展程序)。

  2. 在弹出窗口中,使用选项在您的设备中搜索扩展程序文件夹。

    migrate extensions popup window.png
  3. 单击 Next(下一步)。Extension Migrator 然后会将所有扩展程序导入新版 SketchUp 中。

  4. 重新启动 SketchUp。

迁移首选项

Migrate Preferences(迁移首选项)实用工具可以快速高效地迁移 Preferences(首选项)中的全部自定义设置。您可以在运行 Extension Migrator 时选择迁移首选项设置。如果您已经迁移了扩展程序,但尚未迁移首选项设置,可以从 File(文件)菜单中运行 Migrate Preferences(迁移首选项)。

desktop migrate preferences.jpeg

运行该工具时,会弹出一个窗口,提示您选择要从中迁移首选项的 SketchUp 版本。选择版本后,单击 Migrate(迁移)。运行 Migrate Preferences(迁移首选项)工具后,重新启动 SketchUp。

查找旧版材质库

SketchUp 2025 引入了一组全新的默认材质库,同时 3D Warehouse 中的 SketchUp 材质库也得到了扩充。要访问您在旧版 SketchUp 中使用的经典材质库,并将其保存为材质集,请按照以下步骤操作:

Windows

  1. 打开 File Explorer(文件管理器)。

  2. 导航至 C:\ProgramData\SketchUp\SketchUp[Version Number]\SketchUp\Materials。

  3. 将要保留的文件夹保存在易于记住的位置。

  4. 在新版 SketchUp 中打开 Materials(材质)面板。

  5. 单击 Details(详细信息)(icon details.png)。
  6. 选择 Add collection to favorites(将材质集添加到收藏夹)。

  7. 找到您保存经典材质的文件夹,然后单击 Select Folder(选择文件夹)。新的材质集将会始终显示在材质集列表中。

MacOS

  1. 打开 Finder(访达)。导航到先前安装的 SketchUp 版本。

  2. 在 Finder(访达)中右键单击 SketchUp 应用程序,然后选择 Show Package Contents(显示程序包内容)。

  3. 导航至 ~/SketchUp/Contents>Resources>Content>Materials。

  4. 复制您想要在 SketchUp 中继续使用的单个材质集文件夹。

  5. 在新版 SketchUp 中,单击 SketchUp > Settings(SketchUp > 设置),打开 SketchUp Preferences(SketchUp 首选项)。

  6. 在 Files(文件)部分,单击 Materials(材质)旁边的 Open This Folder in Finder(在访达中打开此文件夹)。

  7. 在弹出的 Finder(访达)窗口中,粘贴您复制的文件夹。

  8. SketchUp 现在会将材质集添加至 Colors(颜色)面板中。