Skip to Content
Help

使用实体工具为复杂的 3D 形状建模

最后更新时间: 10月 30, 2026•2 分钟 阅读。

使用 SketchUp 的实体工具,您可以通过组合或切割一个形状与另一个形状来创建新的形状,从而对轮廓或细木工制品轻松建模。

查看下表关于“实体工具”的简要介绍,包括此工具的功能,以及在 SketchUp Free 中是否提供。

工具

名称

功能

SketchUp Free 中是否包含?

Outer 20Shell.png

Outer Shell(轮廓)

仅保留重叠实体的外表面。

是

Union.png

Union(并集)

将两个或多个实体合并为单个形状。

仅限付费订阅

Subtract.png

Subtract(移除)

一个实体移除另一个实体的一部分,而后再被删除。

仅限付费订阅。在 SketchUp Free 中,使用 Intersect with Model(与模型相交)。

Trim.png

Trim(修剪)

一个实体修剪另一个实体,但仍保留在模型中。

仅限付费订阅

Intersect.png

Intersect(相交)

仅保留相交的几何体。

仅限付费订阅

Split.png

Split(拆分)

沿相交的几何体拆分实体。

仅限付费订阅

若要查找实体工具,请查看 SketchUp 界面的以下部分:

SketchUp Pro

  • Solids(实体)工具栏

  • Tools(工具)菜单(选择 Tools > Outer Shell (工具 > 轮廓),或选择 Tools > Solid Tools (工具 > 实体工具),然后从子菜单中选择其他工具)

  • 工具面板 (macOS)

SketchUp Web 版

  • 左侧托盘中的 Solids(实体)工具栏

  • 右侧面板中的 Solid Inspector 实用程序

在下面的视频中,您将看到实体工具的应用实例。本文以下章节将介绍使用每种工具的步骤和详细信息。(但是请注意,您无法再将 SketchUp 模型放置在 Google Earth 中。)

目录
  1. 创建轮廓

  2. 将实体合并为单个形状

  3. 从一个实体中移除另一个实体(或使用 Intersect Faces with Model(与模型相交面))

  4. 用一个实体修剪另一个实体

  5. 仅保留相交的几何体

  6. 拆分实体

  7. SketchUp Web:使用 Solid Inspector 修复模型

创建轮廓

轮廓工具 ( Outer 20Shell.png ) 删除重叠的组或组件内部的几何体,仅保留外表面。

例如,假设您有两个模型:一个是详细的建筑内部和外部模型。另一个模型则从街景视图展示该建筑,视图显示了周围的建筑、街道和景观。您可以将详细的建筑模型导入街景视图。然而,所有这些几何体都可能拖慢街景模型的速度,而且并非必要。在街景视图中,创建建筑物的轮廓可以消除不需要的内部几何体,从而使街景模型更轻巧,并且在处理时可以更快渲染。

要从重叠的组或组件创建一个轮廓,请按照以下步骤操作:

SketchUp Pro

  1. 使用 选择 工具 ( Select.png ),选中要包含在轮廓中的所有相交的组或组件。
  2. 右键单击选中的组或组件,然后从出现的菜单中选择 Outer Shell (轮廓),如图所示。外表面将保留下来。

您也可以通过以下步骤创建一个轮廓:

  1. 选择 轮廓 工具 ( Outer 20Shell.png )。
  2. 单击选择轮廓中的第一个组或组件。

  3. 单击第二个组或组件。SketchUp 将您的选择组合成一个轮廓,这样只有外表面保留。

  4. (可选)继续单击其他组或组件,将它们添加到轮廓中,如图所示。

fg022 3.png

SketchUp Web 版

  1. 从左侧的工具托盘中选择轮廓工具 ( Outer 20Shell.png )。
  2. 单击选择轮廓中的第一个组或组件。

  3. 单击第二个组或组件。SketchUp 将您的选择组合成一个轮廓,这样只有外表面保留。

  4. (可选)继续单击其他组或组件,将它们添加到轮廓中,如图所示。

sketchup 1004124 UnionOuterShell.png

将实体合并为单个形状

并集 将两个或多个实体合并为一个实体。

并集的结果与轮廓的结果相似。但是,并集的结果可以包含内部几何体,而轮廓仅包含外表面。(见上图示例。)

下面是使用并集工具合并实体的方法:

  1. 选择 并集 工具( Union.png )。
  2. 单击选择并集的第一个组或组件。

  3. 单击第二个组或组件。所得的几何并集将保留。

  4. (可选)继续单击其他组或组件,将它们添加到并集中,如下图所示,该图使用 X 射线视图,以便您查看每个实体中的几何体。

fg022 4.png

从一个实体中移除另一个实体(或使用 Intersect Faces with Model(与模型相交面))

借助移除工具,您可以使用一个实体来切割另一个实体。然后,您的原始实体将从模型中移除。要使移除有效,两个实体必须重叠。

要进行修剪,请按照以下步骤操作:

  1. 选择 修剪 工具 ( Trim.png )。
  2. 单击以选择切割组或组件。在此处显示的例子中,首先选择短桩,以便在板上打孔。完成选择后,光标旁的 1 变成了 2。

  3. 单击要切割的组或组件。切割组保留,但在第二个选择对象中开了一个孔。起初很难看清结果(请参阅插图 1)。但是,如插图 2 所示,将短桩移出孔外,您就能看到板上的孔了。

image trim steps

仅保留相交的几何体

使用 SketchUp Pro 的相交工具 ( Intersect.png ),您可以选择两个或多个重叠的实体,而最后只留下相交的几何体。

要执行相交,请按照以下步骤操作:

  1. 选择 相交 工具 ( Intersect.png )。
  2. 选择一个要在相交中使用的实体。

  3. 选择一个或多个与初始选择重叠的其他实体。所得的几何相交图形将保留。在这个例子中,方盒和球体的相交面(插图 1)创建了一个圆形底面(插图 2)。

image intersect steps

拆分实体

您可以使用拆分工具 ( Split.png ) 沿着相交的边缘分割重叠的实体。要进行拆分,请按照以下步骤操作:
  1. 选择 拆分 工具 ( Split.png )。
  2. 单击一个实体。

  3. 单击与选择的第一个实体相交的另一个实体。SketchUp 沿所选实体相交的边缘拆分所有几何体。例如,如下图所示,左图中的两个组被拆分成了右图中的 3 个组。

image solid tools split

在 SketchUp Web 中使用 Solid Inspector 修复模型

随着几何体变得越来越复杂,小误差可能会阻碍模型的多样化。 SketchUp Web 版中的 Solid Inspector 是一种实用程序 ,可以查找和修复阻止 SketchUp 将模型按实体分类的问题,从而帮助您准备 3D 打印模型。这一检查也有助于修复 3D 模型,用于实体工具操作。