It's time for 3D Basecamp! September 21st - October 1st - We'll do our best but we may be not be able get back to you as quickly as you're used to. Please expect some delay in responses.

Clipping and missing faces

Clipped or Missing Faces

Situation: you are orbiting around your model and you see an effect that looks like a section plane attached to your view at a fixed distance. Objects may also disappear or appear to shake when you try to zoom in.

This is a known issue called Camera Clipping Plane. First, don't worry; although it can be distracting, this doesn't cause any actual damage to your model.

There are several situations in which you might encounter this:

  • One is when the field of view (FOV) is set very wide. You can adjust the FOV between 1 and 120 degrees (the default is 35 degrees in SketchUp and 30 degrees in SketchUp Pro). It's easy to unintentionally change the FOV by pressing the Shift key while you are zooming in or out using the Zoom tool. You can change it back, though, by going to Camera > Field of view and typing your desired field of view in the measurement toolbar.
  • Another situation that can cause clipping is when the Perspective camera mode is turned off. In that case, click the Zoom Extents button (it looks like a magnifying glass with four red arrows pointing outward). The camera zooms out to display the entire model, and the clipping is eliminated.
  • Another situation is when the scale of your model is very small or very large. In this case, you can change the scale of your model while you work on it. For more information about how to control the scale in a model, click here.
  • This can also happen if your model is very far away from the origin point (the point where the red, green, and blue axes intersect). In that case, you can move your model closer to the origin point following these steps:
    • Select all of the geometry in your model by typing Control+A or Command+A, or by clicking and dragging the Select tool across your geometry.
    • Change to the Move tool by going to Tools > Move.
    • Grab a corner point of the selected geometry that is on the ground plane and start to move the selected geometry.
    • Type [0,0,0] (including the square brackets) in the Measurement toolbar (which is in the lower-right corner of the SketchUp window). This causes the selected point to be moved to the origin point.
  • Most frequently, clipping occurs after a DWG import and is caused by a combination of the above points. If you're moving your geometry to the origin or checking for scale, you'll want to ensure that you can see all the geometry in the model. These three steps will help you do that:
    • Turn on all your layers in the Window > Layers menu.
    • Unhide geometry using the Edit > Unhide all command.
    • View all hidden geometry by clicking on View > Hidden Geometry.
    After making all your geometry visible, go to Camera > Zoom extents to see the full extents of your model. If you find that you have geometry located long distances from the origin, removing that geometry will help resolve this problem.

Flickering Faces in your model

You may sometimes encounter a flickering behavior on some surfaces, this is typically called "z-fighting" as two faces are fighting to be seen along the z-axis. This happens when two faces are either co-planar or nearly co-planar and SketchUp is trying to show both.

If you have overlapping geometry but they're not grouped then it will just "cut" the surface and no flickering will occur. You'll see this flickering when a face is drawn on grouped geometry, or when 2 different groups have a face that is on the same plane. The group (or component) is preventing the 2 faces from merging into one face, so the 2 faces compete. If you would like to eliminate the z-fighting, here are three approaches:

  • Change how the geometry is grouped so that the faces merge. eg. Explode your group or component or re-nest the geometry.
  • Move the 2 face away from each other to prevent the z-fighting.
    Note that moving it so that its still nearly co-planar will still result in some flickering at different zoom levels.
  • Give the top face some thickness. eg. Use Push/Pull to pull that 0 thickness face into a piece of geometry with some thickness to it.

If you need to adjust the nested level of the geometry, rather than just exploding, then you can use the Outliner to move geometry between levels. To adjust the nest level:

  1. Select one set of geometry by double-clicking that group until you're able to select ungrouped geometry.
  2. Go to Edit > Cut.
  3. Change nested levels either by double-clicking until you can select the remaining surface or use the Outliner to find the desired nest level.
  4. Use Edit > Paste In Place to paste the cut geometry into the nested group definition.

TAGS