Modeling Complex 3D Shapes with the Solid Tools
With SketchUp’s Solid tools, you can create new shapes by combining or cutting one shape with another, making it easy to model an outer shell or joinery.
Check out the following table for a quick introduction to the Solid Tools, including what the tool does and whether it’s available in SketchUp Free.
Tool | Name | What It Does | Included in SketchUp Free? |
|---|---|---|---|
Outer Shell | Leaves only the outer faces of overlapping solids. | Yes | |
Union | Combines two or more solids into a single form. | Paid subscriptions only | |
Subtract | One solid removes part of another and is deleted. | Paid subscriptions only. In SketchUp Free, use Intersect with Model. | |
Trim | One solid trims another but remains in the model. | Paid subscriptions only | |
Intersect | Leaves only the intersecting geometry. | Paid subscriptions only | |
Split | Splits solids along intersecting geometry. | Paid subscriptions only |
To find the Solid Tools, look in the following parts of the SketchUp interface:
SketchUp Pro
Solids toolbar
Tools menu (Select Tools > Outer Shell or Select Tools > Solid Tools and select the other tools from a submenu)
Tool palette (macOS)
SketchUp for Web
Solids toolbar in the left-hand tray
Solid Inspector utility in the right-hand panel
In the following video, you see examples of the Solid tools in action. In the following sections of this article, you will find steps and details about using each tool. (Note, however, that you can't place SketchUp models in Google Earth anymore.)
Creating an outer shell
For example, say you have two models: One is a detailed interior and exterior building model. The other model illustrates the building in a street view that shows surrounding buildings, streets, and landscaping. You can import the detailed building model into your street view. However, all that geometry might slow down your street view model and isn’t necessary. In your street view, creating an outer shell of the building eliminates the interior geometry you don’t need so that your street view model is lighter and renders faster as you work on it.
To create an outer shell from overlapping groups or components, follow these steps:
SketchUp Pro
- With the Select tool (
), select all the intersecting groups or components you want to include in your outer shell. - Context-click your selection and choose Outer Shell from the menu that appears, as shown in the figure. The outer faces remain.
Or, you can create an outer shell as follows:
- Select the Outer Shell tool (
). Click to select the first group or component in your outer shell.
Click the second group or component. SketchUp combines your selections into an outer shell so that only the outer faces remain.
(Optional) Continue clicking additional groups or components to add them to your outer shell, as shown in the figure.

SketchUp for Web
- Select the Outer Shell tool (
) from the left hand tool tray. Click to select the first group or component in your outer shell.
Click the second group or component. SketchUp combines your selections into an outer shell so that only the outer faces remain.
(Optional) Continue clicking additional groups or components to add them to your outer shell, as shown in the figure.

Uniting solids into a single form
A union merges two or more solid entities into a single solid.
The result of a union is similar to the result of an outer shell. However, the result of a union can contain internal geometry whereas an outer shell contains only external faces. (See the preceding figure for an example.)
Here’s how to use the Union tool to combine solid entities:
- Select the Union tool (
). Click to select the first group or component for the union.
Click the second group or component. The resulting union of the geometry remains.
(Optional) Continue clicking additional groups or components to add them to the union, as shown in the figure, which uses X-Ray view so that you can see the geometry within each solid.

Subtracting one solid from another (or use Intersect Faces with Model)
With the Subtract tool, you can use one solid entity to cut another solid entity. Your original solid entity is then subtracted from the model. For the subtraction to work, the two solids need to overlap.
To perform a trim, follow these steps:
- Select the Trim tool (
). Click to select the cutting group or component. In the example shown here, select the peg first to make a hole in the board. After you make a selection, the 1 next to the cursor becomes a 2.
Click the group or component that you want to cut. The cutting group remains, but makes a hole in the second selection. The result is hard to see at first (refer to Callout 1). However, move the peg out of the hole, as shown in Callout 2, and you see the hole in the board.

Leaving only the intersecting geometry
To perform an intersection, follow these steps:
- Select the Intersect tool (
). Select a solid entity that you want to use in the intersection.
Select one or more additional solids that overlap your initial selection. The resulting intersecting geometry remains. In this example, the intersection of the box and the sphere (Callout 1) creates a point with a rounded base (Callout 2).

Splitting solids
- Select the Split tool (
). Click a solid entity.
Click another solid entity that intersects your first selection. SketchUp splits all the geometry along the edges where the selected solids intersect. For example, in the figure, the two groups shown on the left split into 3 groups, as shown on the right.

Fixing models with Solid Inspector in SketchUp Web
As geometry gets more and more complex, small errors may prevent models from being manifold. Solid Inspector in SketchUp for Web is a utility that helps you prepare models for 3D printing by finding and fixing problems that prevent SketchUp from classifying your model as a solid. This inspection is also useful for fixing 3D models for Solid Tool operations.