Миграция после обновления
При обновлении SketchUp до новой версии вы можете перенести некоторые настройки и пользовательские предпочтения из ранее установленной версии.
Перенос файлов
Файлы SketchUp (.skp), созданные с помощью поддерживаемых версий SketchUp, не имеют версии. При сохранении в Trimble Connect модели, созданной в более старой поддерживаемой версии SketchUp, программа сохраняет и включает все классификации, компоненты, материалы и стили, содержащиеся в этой модели.
Если вы хотите перенести каждый элемент вручную, выполните следующие действия:
Перед установкой новой версии выполните следующие шаги:
В SketchUp выберите Window > Preferences (Окно > Параметры) в Windows или SketchUp Preferences (Параметры SketchUp) в MacOS.
Перейдите в раздел Files (Файлы).
Откройте каждый тип файла, который вы хотите перенести в новую версию.
В окне Проводника или Finder скопируйте и сохраните файлы в месте, где вы легко сможете их найти.
После установки новой версии выполните следующие шаги:
Откройте месторасположение скопированных файлов.
Откройте новую версию SketchUp и выберите Preferences (Параметры).
Перейдите в раздел Files (Файлы).
Скопируйте и вставьте ранее скопированные файлы в диалоговое окно Files (Файлы) в новой версии.
Примечание. Для некоторых типов файлов может понадобиться создать папки.
Extrension Migrator (Средство переноса расширений).
Средство переноса расширений Extrension Migrator доступно в хранилище расширений Extension Warehouse и по умолчанию поставляется в комплекте со SketchUp. Extension Migrator поможет вам перенести расширения из более старых поддерживаемых версий в новую версию SketchUp.
При обновлении SketchUp инструмент предложит вам выполнить перенос при первом запуске приложения. Средство переноса расширений Extension Migrator также запускает утилиту Migrate Preferences (Перенос параметров) для переноса ваших настроек из более ранней поддерживаемой версии. Если вам необходимо запустить расширение вручную, выполните следующие действия:
Нажмите Extensions > Migrate Extensions (Расширения > Перенести расширения).
В появившемся окне воспользуйтесь опциями поиска папки расширений на вашем устройстве.

Нажмите Next (Далее). Затем Extension Migrator (Средство переноса расширений) импортирует все эти расширения в новую версию SketchUp.
Перезапустите SketchUp.
Примечание. Если вы приобрели расширения вне хранилища расширений Extension Warehouse, вам может потребоваться повторно авторизовать расширение после переноса. По всем вопросам, касающимся авторизации расширения, обращайтесь к разработчику.
Перенос параметров
С помощью утилиты Migrate Preferences (Перенос параметров) можно быстро и эффективно перенести все пользовательские настройки из меню Preferences (Параметры). Вы можете перенести свои параметры при запуске средства переноса расширений Extension Migrator. Если вы уже перенесли расширения, но еще не перенесли параметры, вы можете запустить утилиту Migrate Preferences (Перенос параметров) из меню File (Файл).

При запуске инструмента появится окно с предложением выбрать версию SketchUp, из которой вы хотите перенести параметры. После выбора версии нажмите Migrate (Перенести). После выполнения команды Migrate Preferences (Перенос параметров) перезапустите SketchUp.
Примечание. Если вы обновляете программу на основе более старой версии, например переходите со SketchUp 2026 на SketchUp 2027, при первом запуске приложения SketchUp предложит вам запустить утилиту Migrate Preferences (Перенос параметров).
Поиск старых библиотек материалов
В SketchUp 2025 представлены новый набор библиотек материалов по умолчанию и расширенная библиотека материалов SketchUp в 3D Warehouse. Чтобы получить доступ к классическим библиотекам материалов, которые вы использовали в старых версиях SketchUp, и сохранить их как коллекцию, выполните следующие действия:
Windows
Откройте File Explorer (Проводник файлов).
Перейдите в папку
C:\ProgramData\SketchUp\SketchUp[Version Number]\SketchUp\MaterialsСохраните нужные папки в легко запоминающемся месте.
В новой версии SketchUp откройте панель Materials (Материалы).
- Нажмите Details (Сведения) (
). Выберите Add collection to favorites (Добавить коллекцию в избранное).
Найдите папку, в которой вы сохранили классические материалы, и нажмите Select Folder (Выбрать папку). Новая коллекция будет отображаться в списке коллекций постоянно.
MacOS
Откройте Finder. Перейдите к ранее установленной версии SketchUp.
Щелкните правой кнопкой мыши приложение SketchUp в Finder и выберите Show Package Contents (Показать содержимое пакета).
Перейдите в
~/SketchUp/Contents>Resources>Content>MaterialsСкопируйте любую отдельную папку с коллекцией материалов, которую вы хотите продолжить использовать в SketchUp.
В новой версии SketchUp нажмите SketchUp > Settings (Настройки), чтобы открыть настройки SketchUp.
В разделе Files (Файлы) нажмите Open This Folder in Finder (Открыть эту папку в Finder) рядом с пунктом Materials (Материалы).
В открывшемся окне Finder вставьте скопированные папки.
После этого SketchUp включит указанные коллекции в панель Colors (Цвета).