Nozioni e concetti base del disegno

Disegnare un modello in 3D è molto diverso dal 2D. Questa introduzione a nozioni e concetti di progettazione di base spiega come creare bordi e facce (cioè le entità base di qualunque modello SketchUp). Inoltre, consente di scoprire come il motore di inferenza di SketchUp aiuta a posizionare tali linee e lati sull'asse desiderato.

Suggerimento: gli strumenti per le forme di base utilizzano una linea continua sottile. Per creare una linea tratteggiata, consulta Applicazione di linee tratteggiate ai livelli.

Disegno di una linea

Usa lo strumento Linea per disegnare i bordi (chiamati anche entità linea). I bordi costituiscono la base strutturale di qualsiasi modello. Ecco come tracciare una linea:

  1. Seleziona lo strumento Linea () dalla barra degli strumenti o premi L. Il cursore si trasformerà in una matita.
  2. Fai clic per fissare il punto di inizio della linea. Se fai clic nel punto sbagliato, premi Esc per ricominciare. Muovendo il cursore nell'area di disegno, noterai quanto segue:
    • C'è una linea che segue il cursore.
    • La lunghezza della linea viene visualizzata in maniera dinamica nella casella Misure (che usa le unità di misura specificate nel modello).
    • La linea che segue il cursore diventa rossa, verde o blu ogni volta che la linea è parallela rispettivamente all'asse rosso, verde o blu. Se ci si passa il mouse sopra per un momento, viene visualizzata una descrizione, come il "Su asse blu" mostrato in figura. Non è una magia: è il motore di inferenza di SketchUp, di cui parleremo più avanti in questo articolo.
  3. Fai clic per impostare il punto finale della linea, che può anche diventare l'inizio di un'altra linea. Quando hai finito di tracciare tutte le linee, premi Esc o seleziona un altro strumento. Dopo aver impostato il punto finale, premi Ctrl+Z (Microsoft Windows) o Comando+Z (macOS) per cancellare la linea e ricominciare da capo.

  4. (Facoltativo) Per rendere la linea di una lunghezza precisa, digita un valore e premi Invio (Microsoft Windows) o Return (macOS). È possibile ripetere questo processo ogni volta che si vuole, finché non si disegna una nuova linea o si seleziona un altro strumento. Se non specifichi un'unità, SketchUp userà l'unità specificata nel modello. Tuttavia, è possibile digitare qualsiasi unità, metrica o imperiale. Quindi puoi digitare 3 mm o 5'2". Il valore viene visualizzato nella casella Misure durante la digitazione.

Nota: la casella Misure accetta anche coordinate 3D:
  • Una coordinata assoluta, come [3', 5', 7'], imposta la posizione della fine della linea rispetto agli assi correnti. Le parentesi quadre indicano una coordinata assoluta.
  • Una coordinata relativa, ad esempio<1,5 m, 4 m, 2,75 m> , imposta la posizione la fine della linea rispetto al punto di partenza. Le parentesi angolari indicano una coordinata relativa.

Puoi modificare la lunghezza di una linea purché non vincoli una faccia. Ecco come modificare una linea:

  1. Seleziona lo strumento Sposta ().
  2. Posiziona il cursore dello strumento Sposta su una delle estremità della linea.
  3. Fai clic e trascina l'estremità della linea per modificarne la lunghezza.

Suggerimento: puoi anche modificare la lunghezza della linea dalla finestra di dialogo Informazioni entità. Fai clic con il tasto destro sulla linea e scegli Informazioni entità dal menu contestuale. Nella casella Lunghezza, digita la lunghezza desiderata.

Creare una faccia

Unendo più linee in una forma, otterrai una faccia.

Non una faccia buffa, né una faccia da pagliaccio spaventoso e nemmeno un bel muso da cucciolo. Per impostazione predefinita, le facce sono lisce, ma molto importanti: sono l'altra metà dell'accoppiata di bordi e facce che consente a ogni modello SketchUp di esistere.

Suggerimento: per impostazione predefinita, SketchUp aggiunge ombreggiature ad alcune facce, come mostrato qui, rendendole opache, in modo da sapere che quel modello ha una parete, un pavimento o qualunque altra cosa debba rappresentare quella specifica faccia (in ogni caso, SketchUp è dotato anche di una modalità per vedere attraverso i muri, come Superman. Per maggiori dettagli, vedi Visualizzare un modello).

Anche gli strumenti Forma, cioè Rettangolo, Cerchio e Poligono, consentono di creare delle facce (per maggiori informazioni, vedi Disegnare forme base).

Dividere le facce

Tracciando una linea (o una curva) su una faccia esistente, la si divide in parti.

Suggerimento: si tratta di un concetto importante perché, dopo aver diviso una faccia, si può usare lo strumento Spingi/Tira per spingere o tirare parte della faccia mentre l'altra rimane ferma, come mostrato in figura. Per maggiori dettagli, vedi Spingere e tirare le forme in 3D.

Aprire forme 3D eliminando i bordi

È possibile cancellare un bordo o una faccia per creare un'apertura in una forma. Per vedere in che modo eliminare un bordo influisce sul modello, seleziona innanzitutto lo strumento Gomma () nella barra degli strumenti o premi il tasto E, poi fai clic su un bordo:

  • Fare clic su un bordo cancella sia quello sia eventuali facce adiacenti. È possibile tracciare delle linee senza creare una faccia, ma una faccia, per essere tale, deve essere completamente delimitata da bordi.
  • Fare clic con il tasto destro su una faccia e scegliere Cancella elimina solo la faccia.

La figura che segue mostra il parallelepipedo originale e l'effetto che si ottiene cancellando un bordo oppure una singola faccia.

Suggerimento: per nascondere una linea, invece di cancellarla, tieni premuto il tasto Maiusc mentre fai clic sulla linea con la Gomma. In alternativa, fai clic con il tasto destro sulla linea e scegli Nascondi.

Ripristinare le facce cancellate

Se elimini una faccia per errore, puoi sempre ripristinarla:

  • Se non hai apportato altre modifiche che vuoi conservare, seleziona Modifica > Annulla dalla barra del menu. In alternativa, usa la scelta rapida da tastiera Ctrl+Z (Microsoft Windows) o Command+Z (macOS).
  • Traccia di nuovo il bordo che ha portato alla cancellazione della faccia e SketchUp la ricreerà.

Trovare e bloccare un'inferenza

SketchUp ha un motore di inferenza che aiuta a lavorare nello spazio 3D. Per esempio, quando il cursore dello strumento Linea passa sopra il punto mediano di un'altra linea, il motore di inferenza te lo indica aggiungendo un puntino blu chiaro e un suggerimento che dice: “Punto mediano”, come mostrato qui. Ogni inferenza ha il suo colore e la sua descrizione comandi (per un elenco completo, vedi Conoscere i vari tipi di inferenza).

Il motore di inferenza può anche aiutare a individuare rapporti geometrici tra le linee. Ad esempio, indica quando una linea che stai tracciando è perpendicolare a un'altra linea. Nella figura che segue, si nota un punto colorato nel punto iniziale della linea, con le relative informazioni nell'etichetta.

Attenzione: tieni d'occhio il motore di inferenza e di tanto in tanto usa lo strumento Orbita per controllare il disegno da diversi punti di vista. Nella figura che segue, le linee possono sembrare allineate ai piani rosso e verde finché non si orbita su una visuale diversa. Per evitare questo errore, SketchUp evidenzia la direzione o il piano del disegno in rosso, verde o blu quando si creano bordi o facce paralleli a tali assi (il magenta invece indica se si è paralleli o perpendicolari a un bordo o a una faccia del modello).

Suggerimento: può capitare che l'inferenza di cui hai bisogno non venga visualizzata immediatamente o che SketchUp scelga di allinearsi con la geometria sbagliata. In questo caso, è possibile stimolare una data inferenza o aumentare le probabilità di un determinato allineamento tenendo il cursore del mouse sulla posizione da cui si vuole far partire l'inferenza. Una volta visualizzato il relativo segnale visivo, per un po' SketchUp tenderà a dare la priorità a quell'allineamento con il disegno.

Attivare e disattivare l'inferenza lineare

Nuova funzionalità! - SketchUp 2020.2

Le inferenze sono una caratteristica fondamentale di SketchUp, e molti degli strumenti disponibili dipendono proprio da questo. Tuttavia, a volte possono diventare un fastidio, soprattutto quando si lavora in un'area del modello molto densa di figure. Per questo lo strumento Linea consente di attivare o disattivare l'inferenza tramite un semplice modificatore.

Per attivare o disattivare le inferenze lineari dello strumento Linea, fai clic una volta per iniziare a tracciare la riga. Dopodiché, prima di fare clic per terminare la linea, premi il tasto COMMAND su Mac o ALT su Windows per scegliere tra le seguenti opzioni:

  • Tutte le inferenze attive
  • Tutte le inferenze inattive
  • Solo parallele e perpendicolari

Tutte le inferenze attive

È l'impostazione predefinita presente fin dalla prima versione di SketchUp. Lo strumento Linea si aggancia agli assi rosso, verde e blu, oltre che all'asse magenta (parallelo o perpendicolare a un dato bordo).

Tutte le inferenze inattive

Se così impostato, lo strumento Linea ignorerà tutte le inferenze lineari. Tieni presente che il cursore si muoverà più liberamente sullo schermo mentre completi i bordi. Potrai comunque individuare altri tipi di inferenza, quali Sulle facce, Punti guida, Punti mediani, ecc. Usa queste altre inferenze per assicurarti che le linee siano tracciate lungo i piani desiderati.

Solo parallele e perpendicolari

Questa opzione mostra solo le inferenze lineari parallele o perpendicolari per lo strumento Linea. In questo modo, puoi tracciare la tua linea verificando che sia parallela o perpendicolare ad altre geometrie, senza lasciarti distrarre da altre inferenze lineari che potrebbero deviarti.

Bloccare le inferenze da tastiera

Bloccando le inferenze, puoi disegnare esattamente nella direzione desiderata. Un altro motivo per bloccare un'inferenza è mantenere la direzione del disegno, andando a prendere come riferimento una forma in un'altra area del modello. Si tratta di un'azione piuttosto avanzata, ma che può risultare molto utile. Il modo più semplice per bloccare un'inferenza nella direzione di uno degli assi predefiniti consiste nell'usare le frecce:

>

Blocco della direzione di disegno con i tasti freccia
Chiave Cosa fa
Blocca la direzione o il piano di disegno sull'asse blu
Blocca la direzione o il piano di disegno sull'asse verde
Blocca la direzione o il piano di disegno sull'asse rosso. Quindi, sinistra verde, destra rosso
Usala per bloccare o sbloccare la direzione o il piano di disegno parallelamente/perpendicolarmente a un bordo o piano inferito. In sostanza, qualunque cosa diventi color magenta, quindi la direzione del disegno e il bordo della faccia inferita
Maiusc Blocca la direzione o il piano di disegno nella direzione/piano di disegno attivi. Quindi, se stai disegnando sull'asse blu e premi Maiusc, bloccherai l'inferenza blu
Maiusc+Alt (Windows) o Maiusc+Command (MacOS) Premendo Maiusc per bloccare il piano di disegno si blocca anche lo strumento sul piano della faccia inferita. Nel caso degli strumenti Ruota e Goniometro, premi Alt (Microsoft Windows) o Command (MacOS) per liberarli in modo da poter spostare il centro in un altro punto del modello senza uscire dal piano di disegno

Alcuni strumenti, come Cerchio e Ruota, possono essere bloccati su un piano (invece che in una direzione di disegno), come mostrato di seguito: In questo caso è possibile agganciare il piano di disegno scegliendo la direzione del colore dell'asse dello strumento, detta anche “normale”.

Blocco del piano di disegno con i tasti freccia

Assicurarsi che i bordi siano allineati agli assi

Per assicurarsi che i bordi siano allineati agli assi, può essere utile fare in modo che il cursore prenda il colore degli assi interessati. Anche per verificare l'allineamento delle forme esistenti può essere utile modificare i bordi con i colori degli assi.

Per farlo, segui questi passaggi:

  • Seleziona Finestra > Preferenze (Microsoft Windows) o SketchUp > Preferenze (MacOS). Apparirà la finestra di dialogo “Preferenze” di SketchUp.
  • Seleziona l'elemento Disegno sulla sinistra.
  • Nell'area Varie del pannello Disegno, seleziona la casella di controllo Mostra reticolo di puntamento.
  • Fai clic su OK per chiudere la finestra di dialogo Preferenze di SketchUp. Il cursore mostrerà un reticolo di puntamento dello stesso colore degli assi, come mostrato qui.

Per fare in modo che i bordi del modello riprendano il colore degli assi a cui sono allineati, segui questi passaggi:

  1. Seleziona Finestra > Stili.
  2. Nella finestra di dialogo Stili, seleziona Nel modello dall'elenco a discesa delle librerie di stili.
  3. Fai clic sulla scheda Modifica.
  4. Fai clic sull'icona Impostazioni bordi, come mostrato in figura.
  5. Seleziona Per asse dall'elenco a discesa del Colore. Il colore dei bordi del tuo modello cambierà in modo da rispecchiare l'allineamento con gli assi del disegno (a meno che non siano allineati con nessun asse, nel qual caso manterranno il colore originario). La figura che segue mostra quali bordi sono o meno allineati con i tre assi.