It's time for 3D Basecamp! September 21st - October 1st - We'll do our best but we may be not be able get back to you as quickly as you're used to. Please expect some delay in responses.

Working with Scrapbooks of Reusable Entities

Whether your documents often include company branding elements or you just prefer certain shapes or styles, LayOut’s scrapbooks are a handy way to store and access entities you use and reuse in your documents.

In LayOut’s Scrapbooks panel, shown in the following figure, you find premade scrapbooks of arrows, cars, colors, people, signs, title blocks, and trees. You can also create your own scrapbooks for custom items, such as logos or shapes that you design. A scrapbook can hold any content you create, including title blocks, drawings, and styles (such as colors and line thickness). To open the Scrapbooks panel, click its name in the panel tray or, if it’s not on-screen, select Window > Scrapbooks.

LayOuts Scrapbooks panel contains premade shapes and styles and any custom scrapbooks you create.
LayOuts Scrapbooks panel contains premade shapes and styles and any custom scrapbooks you create.

The following sections explain how to apply scrapbook items to your documents, navigate the premade scrapbooks, or create your own scrapbooks.

Inserting scrapbook items in a document

To help you start using scrapbooks right away, LayOut includes lots of premade scrapbooks. But whether you’re using a premade or custom scrapbook, adding scrapbook items to your document works the same way.

To add scrapbook items to your document, follow these steps:

  1. Choose the Select tool () from the default toolbar or by choosing Tools > Select.
  2. In the Scrapbooks panel, select the scrapbook you want to use from the drop-down menu in the upper left. If the scrapbook contains multiple pages, an arrow appears next to the scrapbook name, and you can select a specific page from the list. Alternately, click the Next Page or Previous Page buttons (right next to the drop-down list) to navigate to the page you need. A preview of the scrapbook items appears in the main area of the Scrapbooks panel.
  3. Do either of the following:
    • To place one instance of a scrapbook entity, click and drag a scrapbook element into the document area. If you’re unable to drag a scrapbook entity into your document, check that the Select tool is active.
    • To stamp multiple instances of an entity, click the scrapbook entity that you want to stamp in the Scrapbooks panel and then click in the document area wherever you want to stamp an instance of the entity. Press Esc to exit the stamping mode.

Creating a custom scrapbook

To create a custom scrapbook, you simply need to create a LayOut document (just a regular one with the .layout file extension) with all the entities you want to include in the scrapbook, such as a library of title blocks, logos, models, text, images, or symbols. After your LayOut document has all the entities you need, follow these steps to transform your .layout file into a scrapbook (the steps reflect your current operating system):

  1. Select File > Save As Scrapbook. The Save As Scrapbook dialog box appears.
  2. Type a scrapbook name in the Scrapbook Name field. When you want to use elements from your scrapbook, this name is what appears in the Scrapbooks panel’s drop-down list of options.
  3. In the Scrapbook Folder list, select the folder where you want to save your scrapbook file.
  4. Click OK. Your scrapbook is saved to the highlighted folder and becomes available in the Scrapbooks panel.
  1. Select File > Save As Scrapbook. A dialog box for saving your scrapbook appears.
  2. Type a scrapbook name in the Scrapbook Name field. When you want to use elements from your scrapbook, this name is what appears in the Scrapbooks panel’s drop-down list of options.
  3. In the Scrapbook Folder list, select the folder where you want to save your scrapbook file.
  4. Click Save. Your scrapbook is saved to the highlighted folder and becomes available in the Scrapbooks panel.

If you want to use a folder other than the ones that appear in the Scrapbook Folder list, you can designate your own scrapbook folder. Simply follow these steps, which reflect your current operating system:

  1. Select Edit > Preferences to open the Preferences dialog box.
  2. Select Folders in the sidebar on the left.
  3. In the Scrapbooks area, click the + button to add a new scrapbook folder.
  4. In the Browse for Folder dialog box that appears, navigate to the folder that you want to use for scrapbook files and select it. Alternately, navigate to the location where you want to create a new folder, click Make New Folder, and type a name for the folder.
  5. Click OK in the Browse for Folder dialog box. Back in the LayOut Preferences dialog box, your folder appears in the list of designated scrapbook folders.
  6. Click Close.
  1. Select LayOut > Preferences to open the LayOut Preferences dialog box.
  2. Select Folders in the sidebar on the left.
  3. In the Scrapbooks area, click the + button to add a new scrapbook folder.
  4. In the dialog box that appears, navigate to the folder that you want to use for scrapbook files and select it. Alternately, navigate to the location where you want to create a new folder, click New Folder, type a name for the folder, and click Create.
  5. Click Open in the dialog box where you selected your new scrapbook folder. Back in the LayOut Preferences dialog box, your folder appears in the list of designated scrapbook folders.
  6. Click Close.

After you set up the folder in the LayOut Preferences dialog box, the folder becomes an option when you follow the preceding steps for saving a file as a scrapbook. If you ever want to eliminate the folder from your list of scrapbook locations, return the Folders preferences and click the Restore Defaults button the in Scrapbooks area.

Tip: You can share a scrapbook file with another user or use a .layout file that you’ve received as a scrapbook. All the other user (or you) needs to do is open the file and follow the steps to save the file as a scrapbook on their computer. If you designate a folder on a network as a scrapbook folder, you can simply share the network folder.

Editing a scrapbook

Edit a scrapbook file just as you edit any other LayOut file. To edit a scrapbook file, follow these steps:

  1. Select the scrapbook you want to edit from the drop-down list in the Scrapbooks panel.
  2. Click the Edit button in the upper right. The Scrapbook file appears in the document area. If the scrapbook has more than one page, the first page of the scrapbook file appears, and you can use the Next Page () and Previous Page () buttons on the default toolbar to navigate to the page you want to edit.
  3. Make edits to the scrapbook.
  4. Select File > Save to save the changes to your scrapbook file. These edits are reflected in the scrapbook in the Scrapbooks panel.
Note: For Mac OS X users, LayOut won’t edit the default scrapbook because it’s part of the app bundle. Instead, LayOut will create a copy of the default scrapbook, and when you save your changes a new LayOut file will be saved in your User folder. Both the original default scrapbook and your copy will show in the drop-down menu of the Scrapbook dialog box. For this reason, we recommend renaming your “edited” version of the original scrapbook to be different from the original scrapbook.
TAGS