It's time for 3D Basecamp! September 21st - October 1st - We'll do our best but we may be not be able get back to you as quickly as you're used to. Please expect some delay in responses.

Importing and Exporting STL Files for 3D Printing

This article covers a feature introduced in SketchUp 2018. For help working with STL files in earlier versions of SketchUp, see 3D Printing a Model.

In SketchUp, you can import and export STL files, which are used in 3D printing. As explained in 3D Printing a Model, for a SketchUp model to become a successful 3D printout, the model needs to meet certain criteria, such as having a base and a volume and being a solid.

Importing an STL file into SketchUp

To import an STL file into SketchUp, follow these steps:

  1. Select File > Import.
  2. In the Import dialog box that opens, navigate to the STL file that you want to import and select it.
  3. (Optional) Select STereoLithography Files (.stl) from the Formatfile type drop-down list and then click the Options button. The STL Import Options dialog box appears.
  4. (Optional) Select your desired options (explained in the following list) and click OK. You return to the Import dialog box.
  5. Click Import, and SketchUp imports the selected STL file.

The STL Import Options dialog box enables you to make a few selections about how geometry and scale are handled when SketchUp imports your file:

  • Merge Coplanar Faces: In most cases, you want to select this checkbox, which merges all faces on the same plane into one face. By default, this checkbox is cleared, which preserves multiple objects on multiple layers.
  • Preserve Drawing Origin: You likely want to clear this checkbox and let SketchUp choose an origin or reset the origin after import.
  • Swap YZ Coordinates: When you select this checkbox, the Y coordinate becomes the vertical coordinate. In other words, the Y axis is up instead of the Z axis.
  • STL Units: The default unit is millimeters. You can change the units to centimeters, feet, or inches by selecting an option from the drop-down list.

Exporting a SketchUp model as an STL File

To export a SketchUp model to an STL file, first make sure that your model meets the basic recommendations for 3D printing. Then follow these steps:

  1. Select File > Export > 3D Model. The Export Model dialog box appears.
  2. Navigate to the location where you want to save your exported file.
  3. (Optional) In the appropriate text box, type a name for the exported STL file.
  4. From the FormatSave As Type drop-down list, select STereolithography File (.stl).
  5. (Optional) Click the Options button, and in the STL Export Options dialog box, select your desired options for the exported STL file. (See the following list for details about each option.) Click OK when you’re done.
  6. Back in the Export Model dialog box, click Export. SketchUp exports your model to the STL format and saves the file in the location you specified.

The STL Export Options dialog box enables you to choose a few options for how SketchUp renders your exported file:

  • Export Only Current Selection: When you select this checkbox, SketchUp exports only the selected geometry to the STL file. This option is helpful if you want to model several parts that fit together in one SketchUp model file, but export each part to a separate 3D-printable STL file.
  • File Format: By default, Binary is selected from the drop-down list. The other format option is ASCII. The binary format is generally preferred because this format helps reduce the size of an STL file.
  • Swap YZ Coordinates: By default, this checkbox is cleared. If you select it, the Y axis becomes the vertical axis instead of the Z axis.
  • STL Units: By default, the STL file is exported using the same units specified in the model. (To check your model’s default units, select Window > Model Info and, in the Model Info window, click Units in the sidebar on the left.) You can change the units in the exported STL file to meters, centimeters, millimeters, feet, or inches.
TAGS