Migrazione dopo l'aggiornamento
Quando aggiorni SketchUp a una nuova versione, puoi migrare diverse impostazioni e personalizzazioni dall'installazione precedente.
Migrazione dei file
I file SketchUp (.skp) creati con le versioni supportate di SketchUp non hanno versione. Quando salvi in Trimble Connect un modello creato con una vecchia versione supportata di SketchUp, SketchUp preserva e incorpora tutti i componenti, le classificazioni, i materiali e gli stili rilevati nel modello.
Se vuoi migrare i singoli elementi manualmente, procedi come segue:
Prima di installare la nuova versione:
In SketchUp, fai clic su Window > Preferences (Finestra > Preferenze), in Windows, o SketchUp Preferences (Preferenze di SketchUp) in MacOS.
Accedi alla sezione Files (File).
Apri ciascun tipo di file da migrare alla nuova versione.
Nella finestra File Explorer (Esplora file) o nel Finder, copia i file e salvali in una posizione facile da trovare.
Dopo aver installato la nuova versione:
Accedi al percorso dei file copiati.
Apri la nuova versione di SketchUp e accedi a Preferences (Preferenze).
Vai alla sezione File.
Copia i file che hai copiato e incollali nella finestra di dialogo Files (File) della nuova versione.
Nota: potrebbe essere necessario creare delle cartelle per alcuni tipi di file.
Extension Migrator
Extension Migrator, disponibile in Extension Warehouse e fornito in bundle con SketchUp per impostazione predefinita, semplifica la migrazione delle estensioni dalle versioni supportate precedenti a un versione più recente di SketchUp.
Se aggiorni SketchUp, al primo avvio dell'applicazione lo strumento ti propone di eseguire la migrazione. Extension Migrator esegue anche l'utilità Migrate Preferences (Migra preferenze), per trasferire le preferenze da una versione supportata precedente. Se hai l'esigenza di eseguire l'estensione manualmente, procedi come segue:
Fai clic su Extensions > Migrate Extensions (Estensioni > Migra estensioni).
Nella finestra che appare, usa le opzioni per cercare nel tuo dispositivo la cartella delle estensioni.

Fai clic su Next (Avanti). Extension Migrator importerà tutte le estensioni nella nuova versione di SketchUp.
Riavvia SketchUp.
Nota: se hai acquistato estensioni all'esterno di Extension Warehouse, dopo la migrazione potrebbe essere necessario riautorizzarle. Per qualsiasi domanda sull'autorizzazione di un'estensione, contatta lo sviluppatore.
Migrazione delle preferenze
L'utilità Migrate Preferences (Migra preferenze) consente di trasferire in modo rapido ed efficiente tutte le impostazioni che avevi personalizzato nella finestra Preferences (Preferenze). Quando esegui Extension Migrator, puoi scegliere di migrare le preferenze. Se hai già migrato le estensioni, ma non le preferenze, puoi eseguire Migrate Preferences (Migra preferenze) dal menu File.

Quando esegui lo strumento, viene visualizzata una finestra che ti chiede di selezionare la versione di SketchUp da cui eseguire la migrazione. Seleziona la versione, quindi fai clic su Migrate (Migra). Terminata l'esecuzione di Migrate Preferences (Migra preferenze), riavvia SketchUp.
Nota: se esegui l'aggiornamento da una versione precedente, ad esempio da SketchUp 2026 a SketchUp 2027, al primo avvio dell'applicazione ti viene proposto di eseguire l'utilità Migrate Preferences (Migra preferenze).
Ricerca di librerie di materiali meno recenti
In SketchUp 2025 è stata introdotta una nuova serie di librerie di materiali predefiniti e la libreria di materiali SketchUp in 3D Warehouse è stata ulteriormente estesa. Per accedere alle librerie di materiali classiche disponibili nelle versioni precedenti di SketchUp e salvarle come raccolta, procedi come segue:
Windows
Apri File Explorer (Esplora file).
Vai a
C:\ProgramData\SketchUp\SketchUp[numero versione]\SketchUp\MaterialsSalva le cartelle che vuoi conservare in una posizione facile da ricordare.
Nella nuova versione di SketchUp, apri il pannello Materials (Materiali).
- Fai clic su Details (Dettagli)
. Seleziona Add collection to favorites (Aggiungi raccolta ai preferiti).
Individua la cartella in cui hai salvato quei materiali classici e fai clic su Select Folder (Seleziona cartella). La nuova raccolta apparirà nell'elenco di raccolte su base continuativa.
MacOS
Apri il Finder. Vai alla versione installata in precedenza di SketchUp.
Fai clic con il pulsante destro del mouse sull'applicazione SketchUp nel Finder e seleziona Show Package Contents (Mostra contenuti pacchetto).
Vai a
~/SketchUp/Contents>Resources>Content>MaterialsCopia la singola cartella della raccolta di materiali che vuoi continuare a usare in SketchUp.
Nella nuova versione di SketchUp, fai clic su SketchUp > Settings (SketchUp > Impostazioni) per aprire le Preferenze SketchUp.
Nella sezione File, fai clic su Open This Folder in Finder (Apri questa cartella nel Finder) accanto a Materiali.
Nella finestra del Finder che appare, incolla le cartelle che hai copiato.
SketchUp ora includerà tali raccolte nel pannello Colors (Colori).