Aggiungere colori e texture con Materiali

Per rendere i tuoi modelli ancora più dettagliati e realistici, SketchUp consente di scegliere tra diversi materiali con cui verniciare i tuoi oggetti. I Materiali sono sostanzialmente "vernici" con un colore e una texture facoltativa (definiti entro un file di immagine). Nella figura che segue, per esempio, il materiale del tetto è di colore blu, con una texture che simula le coperture metalliche. Muri e prati sono caratterizzati da altri materiali, di colore e texture diversi.

Dopo aver applicato materiali come questi al modello, le speciali funzionalità di SketchUp consentono di:

  • Sostituire un materiale con un altro: poniamo che tu voglia vedere che effetto fa un tetto di metallo invece delle tegole. Puoi cambiare il materiale del tetto in pochi clic.
  • Modificare il materiale: dato che colore e texture sono due elementi distinti, possono essere modificati indipendentemente l'uno dall'altro. Per esempio, puoi cambiare il colore di una parete (come starà in giallo?), mantenendo la stessa texture. Inoltre, puoi intervenire sull'opacità di un materiale, rendendolo più opaco o più trasparente.
  • Calcolare la quantità di materiale necessaria: SketchUp può indicarti esattamente l'area coperta dalle tegole o della parete. Ovviamente, perché questo dato sia significativo, devi aver creato un modello preciso che rispecchi le dimensioni reali del tuo progetto.
Suggerimento: SketchUp include diverse categorie di materiali, come piastrelle, moquette, pavimentazioni, vetro, legno e molto altro ancora. Se però il materiale che cerchi non è disponibile, puoi sempre crearlo. Questa funzionalità è particolarmente utile per gli arredatori di interni e le imprese edili che vogliono mostrare ai clienti anche i dettagli delle finiture.

Nell'interfaccia di SketchUp, puoi modificare i tuoi materiali servendoti dello strumento Riempi () e del pannello Materiali (Microsoft Windows) o Colori (macOS). Il pannello Materiali o Colori consente anche di visualizzare, gestire e organizzare i materiali usati. In più, tiene traccia dei materiali impiegati in un dato modello e consente di creare raccolte di materiali specifiche per i tuoi progetti o flussi di lavoro.

Nota: se passi da un computer che usa Windows a uno con macOS, noterai che le interfacce dei pannelli Materiali e Colori cambiano da un sistema operativo all'altro. Nelle sezioni che seguono, troverai istruzioni per Microsoft Windows o macOS, a seconda del sistema operativo selezionato dal menu a discesa in qualunque pagina del Centro assistenza.

Il seguente video mostra come applicare i materiali e apportare alcune delle modifiche più comuni, per esempio come sostituire un materiale con un altro. Per istruzioni su come usare i materiali nel dettaglio, continua a leggere.

Applicare i materiali

Applicare materiali a un modello è molto semplice: seleziona la faccia o le facce dell'elemento da verniciare e scegli il materiale desiderato. Per applicarlo a gruppi di oggetti o componenti, dai un'occhiata ai suggerimenti alla fine di questa sezione, in modo da rendere l'applicazione dei materiali ancora più semplice.

Per applicare materiali a un modello serve lo strumento Riempi (), che si trova nelle seguenti aree dell'interfaccia di SketchUp:

    Windows
  • Barra Operazioni preliminari
  • Barra Set grandi strumenti
  • Barra degli strumenti principale
  • Strumenti > Riempi nella barra del menu

Per iniziare ad applicare materiali al tuo modello, segui questa procedura:

  1. Seleziona lo strumento Riempi ().
  2. Si aprirà un pannello Materiali da cui fare clic sulla scheda Seleziona. Se il pannello Materiali non dovesse aprirsi, è possibile che la finestra di dialogo sia ridotta a icona. In questo caso, passa il cursore sopra l'icona ed espandi l'area di notifica. A quel punto, potrai aprire il pannello Materiali da lì.
  3. Seleziona una categoria di materiali dal menu a discesa.
  4. Fai clic sul materiale che ti interessa.
    Suggerimento: per campionare un materiale già inserito nel modello, tieni premuto il tasto Alt per passare temporaneamente allo strumento Campiona. Con il cursore a contagocce dello strumento Campiona, fai clic sull'area da cui campionare il materiale. Rilascia il tasto Alt per tornare allo strumento Riempi.
  5. Di nuovo nell'area di disegno, fai clic su una o più facce degli oggetti nel modello per applicare il materiale.

Applica i materiali in SketchUp per Windows

Suggerimento: per ripristinare i colori predefiniti, segui i passaggi precedenti ma, invece di fare clic su un materiale, fai clic su Imposta materiale predefinito () nell'angolo in alto a destra e poi sulla faccia di un oggetto nel modello per applicare i colori predefiniti.

    MacOS
  • Barra Set grandi strumenti
  • Strumenti > Riempi nella barra del menu
  • Tavolozza strumenti

Per iniziare ad applicare materiali al tuo modello, segui questa procedura:

  1. Seleziona lo strumento Riempi (). Dal pannello Colori che apparirà, puoi impostare il colore da una delle quattro opzioni di selezione del colore disponibili o visualizzare le categorie di materiali.
  2. Per sfogliare le categorie di materiali, fai clic sulla scheda Tavolozza delle texture, contrassegnata dall'icona di un mattone. Per maggiori dettagli sull'uso delle altre schede, utili per selezionare i colori, vedi Miscelare i colori con la Selezione colore.
  3. Seleziona una categoria di materiali dal menu a discesa. Nell'immagine visualizzata sotto, abbiamo selezionato la categoria Tetti.
  4. Fai clic sul materiale da applicare al tuo modello.
    Suggerimento: per campionare un materiale già inserito nel modello, fai clic sullo strumento Contagocce nella parte inferiore della scheda Tavolozza delle texture. Con il cursore trasformato in un grosso cerchio, fai clic sul materiale da campionare. In questo modo il materiale viene caricato tra i campioni di colore e il cursore torna a essere visualizzato con lo strumento Riempi.
  5. Di nuovo nell'area di disegno, fai clic su una o più facce degli oggetti nel modello per applicare il materiale.

In alternativa, tieni premuto e trascina un campione di colore dall'area principale della Tavolozza delle texture a un'area del tuo modello (non è possibile trascinare i campioni di colore dalla tavolozza nella parte inferiore del pannello Colori di macOS. Per maggiori dettagli su come utilizzare i campioni salvati, consulta Miscelare i colori con la Selezione colore).

Suggerimento: per tornare ai colori predefiniti, seleziona i campioni di colore predefiniti nella raccolta Colori nel modello.

Suggerimento: se, facendo clic su un oggetto, il materiale selezionato non viene visualizzato, è possibile che il modello sia impostato su uno stile che non mostra le texture. Per verificarlo, apri il pannello Stili, fai clic sulla scheda Modifica e poi sull'icona Impostazioni facce. Nell'area Stile, controlla che sia selezionata l'opzione Visualizza ombreggiato con texture.

Se l'opzione fosse già selezionata, è possibile che il computer non disponga di memoria sufficiente per mostrare i materiali nel modello. Per assistenza, vedi Risoluzione problemi di SketchUp.

È possibile verniciare più facce e bordi per volta. A tale scopo, usa lo strumento Seleziona () per selezionare le aree da colorare, poi passa allo strumento Riempi e applica il materiale desiderato (Selezionare geometrie offre suggerimenti utili su come selezionare determinate aree).

Se applichi un materiale a più aree in una volta, ricorda che:

  • Le facce hanno due lati: un fronte e un retro. Puoi verniciare il fronte o il retro della faccia selezionata, ma non le due cose insieme. Il lato che verrà dipinto è quello su cui fai clic con il cursore Riempi. Nell'immagine mostrata di seguito, fare clic sulla parte anteriore di una faccia colora tutti i lati frontali selezionati, anche se si vedono solo due dei fronti e due dei retri.
  • Puoi modificare l'estetica dei bordi posteriori con gli stili. Quando selezioni una faccia e tutti i bordi, verniciando la parte anteriore si colorano anche tutti i bordi selezionati. Se selezioni una faccia posteriore, però, nessuno dei bordi verrà verniciato. Per uniformare i bordi posteriori al resto del materiale, apri il pannello Stili, fai clic sulla scheda Modifica e sull'icona Impostazioni dei bordi e seleziona Per materiale dal menu a discesa Colore.

Puoi applicare i materiali a un gruppo o componente in generale, oppure a una specifica area all'interno del gruppo o componente:

  • Per verniciare un intero gruppo o componente, selezionalo e applica il materiale. Quando selezioni un gruppo o componente a cui applicare il materiale, vengono verniciate solo le facce visibili nel materiale predefinito.
  • Per verniciare un'area all'interno di un gruppo o componente, facci doppio clic sopra per aprire il relativo contesto e seleziona le facce da verniciare con un dato materiale.

Il seguente video mostra diversi trucchi e suggerimenti per applicare materiali ai componenti. In alternativa, continua a leggere per ricevere istruzioni su come verniciare i tuoi componenti, in parte o in toto.

Suggerimento: per inserire variazioni dei materiali nel modello in modo facile e veloce, puoi combinare le tecniche per il riempimento di tutti o parte dei tuoi componenti.

Per capire come funziona, poniamo che tu voglia creare il modello di una sedia con il telaio in legno e due cuscini in quattro opzioni di colore. La Struttura, qui visibile come "Outliner", mostra che ogni elemento sedia (costituito dal telaio e da due cuscini) costituisce un gruppo, nidificato all'interno di un gruppo a sua volta nidificato in un componente (per maggiori informazioni su questa sezione vedere Organizzazione dei modelli).

I seguenti passaggi illustrano il modo più semplice per applicare i materiali e mostrare le quattro opzioni di colore:

  1. Dato che il telaio è lo stesso per tutte le sedie, basta selezionare il gruppo telaio e applicare il materiale legno, come mostrato qui.
  2. Crea una copia per ciascun colore di cuscino (per scoprire come, vedi Copiare un oggetto già disegnato).
  3. Seleziona un componente e applica un colore per il cuscino. Dato che il telaio è già verniciato ma i cuscini sono ancora nel colore predefinito, questa modifica si applicherà solo ai cuscini, mentre il telaio rimarrà in legno.
  4. Ripeti l'ultimo passaggio per ogni opzione di colore. Il risultato dovrebbe essere come segue:

Suggerimento: quando ci sono diversi gruppi o componenti nidificati all'interno di altri gruppi o componenti, è possibile che SketchUp non ti lasci verniciare facendo clic sul gruppo o componente principale. Se dovessi incorrere in questo problema, prova ad applicare i materiali a un gruppo o componente a un livello più basso della gerarchia. La Struttura può aiutarti a capire in che punto della gerarchia si trova l'elemento selezionato.

Sostituire un materiale con un altro

Poiché SketchUp ti consente di sostituire un materiale con un altro, puoi sperimentarne diversi in modo semplice e veloce. Prova a vedere l'effetto di vari materiali per il piano di lavoro della tua cucina, tra granito nero, piastrelle blu e composito bianco. Se stai scegliendo i colori per le pareti di casa, passa da muri gialli e finiture verde scuro a muri blu marino con finiture color panna. Non appena avrai imparato a usare i modificatori da tastiera, diventerà un gioco da ragazzi. Dai un'occhiata alle combinazioni di tasti qui sotto.

Per sostituire un materiale con un altro... Tasto rapido (Windows) Tasto rapido (macOS)
Su facce adiacenti Ctrl Opzione
Su tutte le facce in quel dato contesto (es. uno stesso gruppo o componente) Maiusc Maiusc
Su tutte le facce collegate Ctrl+Maiusc Opzione+Maiusc

L'esempio di seguito illustra il funzionamento delle diverse combinazioni di tasti rapidi. Poniamo che tu stia cercando di decidere i colori da usare per un murale astratto su due pareti separate. L'immagine che segue mostra il murale simulato con i materiali della raccolta Colori con nomi.

Per capire che effetto potrebbe fare sostituire il rosso con il verde, seleziona lo strumento Riempi e poi scegli il verde nel pannello Materiali (Microsoft Windows) o Colori (macOS). Premendo Ctrl/Opzione e facendo clic sul triangolo rosso in alto a sinistra, le facce adiacenti in rosso vengono sostituite dal materiale verde, come mostrato di seguito.

Usando Maiusc+clic, invece tutte le facce rosse diventano verdi:

Se invece usi Ctrl+Maiusc+clic o Opzione+Maiusc+clic, a diventare verdi saranno solo le superfici rosse sulla parete sinistra:

Modificare i materiali

Sketchup ti consente di modificare i materiali. Man mano che apporti le tue modifiche, le aree verniciate con il materiale su cui stai intervenendo cambiano automaticamente. Dal momento che ogni materiale ha un suo colore e una sua texture opzionale, questi due elementi possono essere modificati in maniera indipendente l'uno dall'altro.


La modifica dei materiali su SketchUp è particolarmente utile quando un materiale è applicato a molte aree diverse. Intervenendo direttamente sul materiale, invece che su una singola faccia, tutte le aree verniciate con quel materiale si aggiornano automaticamente. Dal momento che ogni materiale ha un suo colore e una sua texture opzionale, questi due elementi possono essere modificati in maniera indipendente l'uno dall'altro.

Nota: la modifica dei materiali è inclusa negli abbonamenti a pagamento per l'app SketchUp for Web, oltre che per gli utenti di SketchUp for Schools.

Prima di poter modificare un materiale, devi salvarlo all'interno del modello. Per vedere i materiali salvati nel tuo modello, apri il pannello Materiali nella barra delle utility sulla destra dello schermo.

Per modificare un materiale, selezionalo dai materiali Nel modello (sotto l'icona Home) o esegui una campionatura dalla finestra di modellazione con lo strumento Contagocce per inserire automaticamente il materiale nel pannello Materiali. Una volta selezionato il materiale, fai clic sull'icona Modifica accanto alla miniatura corrispondente.

Nel modificare un materiale puoi intervenire su:

  • Nome del materiale: inserisci un nuovo nome per il materiale per modificare quello esistente.
  • Colore: personalizza il colore del tuo materiale manualmente, tramite la selezione colori di SketchUp, oppure inserisci valori RGB, HSL, o HEX. In entrambi i casi, vedrai il colore variare in tempo reale.
  • Immagine: aggiungi o modifica la texture dell'immagine per associarla a un materiale. L'aggiunta o la modifica di una texture può influire sull'effetto cromatico. Puoi anche decidere di rimuovere del tutto la texture facendo clic su “X”.
  • Dimensione dei materiali: quando si applica una texture immagine a una certa area, l'immagine viene inserita in modo da riempirla completamente. Per cambiare le dimensioni del riquadro della texture, inserisci i valori desiderati nei campi Larghezza e Altezza. Per impostazione predefinita, le proporzioni dell'immagine rimangono le stesse. Pertanto, se digiti 2 nella casella della larghezza, quella dell'altezza si aggiorna automaticamente per mantenere la proporzione. Fai clic sull'icona della catena per romperla e modificare le proporzioni come meglio credi. Se il risultato non ti soddisfa, fai clic su Annulla nella parte inferiore del menu, oppure usa i tasti rapidi Ctrl/Comando +Z.
  • Opacità: volendo puoi intervenire anche sul livello di opacità o trasparenza del tuo materiale. Portare il cursore verso destra aumenta l'opacità, per cui 100 è completamente opaco, mentre a sinistra si aumenta la trasparenza, per cui 0 è completamente trasparente. In alternativa, digita un numero da 0 a 100 nel campo Opacità.

Nota: tutte le modifiche effettuate sui materiali possono essere annullate (se ancora in corso) facendo clic su "Annulla" nella parte bassa del pannello dei materiali. Se hai già confermato le modifiche ai materiali, puoi sempre usare i comandi Cancella e Ripristina per passare dall'originale alla versione modificata e viceversa.

Windows

Prima di poter modificare un materiale, devi salvarlo all'interno del modello. Per vedere i materiali salvati nel tuo modello, apri il pannello Materiali e fai clic sull'icona Nel modello () per visualizzare la raccolta Nel modello come mostrata nell'immagine che segue.

Se il materiale da modificare non compare nella raccolta Nel modello, puoi scegliere di salvare un materiale nella raccolta anche se non è applicato a nessuna area del modello. Per aggiungere un materiale alla raccolta Nel modello, segui queste istruzioni:

  1. Fai clic sull'icona Mostra riquadro di selezione secondario () nell'angolo in alto a destra del pannello materiali.
  2. Nel riquadro secondario in basso, sfoglia le raccolte fino a trovare il materiale da modificare.
  3. Trascina il campione di materiale nella raccolta Nel modello.

Per modificare il materiale, selezionalo nella raccolta Nel modello e fai clic sulla scheda Modifica, illustrata di seguito.

Di seguito una breve introduzione a tutti gli strumenti di modifica del colore del materiale:

  • Menu a discesa per la selezione dei colori: utilizzalo per scegliere una delle opzioni di selezione del colore tra HLS (tonalità, luminosità e saturazione), HSB (tonalità, saturazione, luminosità), RGB (rosso, verde e blu) e ruota dei colori. Per maggiori dettagli sulla selezione dei colori, consulta Miscelare i colori con la Selezione colore.
  • Campione di annullamento delle modifiche del colore: fai clic su questo campione per annullare tutte le modifiche apportate nella sessione di modifica.
  • Pulsante Campiona colore dell'oggetto nel modello: fai clic su questo pulsante per trasformare il cursore in un contagocce. A questo punto, fai clic sull'elemento desiderato per campionarne il colore e applicarlo al materiale che stai modificando.
    Suggerimento: se campioni un materiale con una texture, le variazioni di quest'ultima possono camuffare leggermente il colore del materiale. Per campionare al meglio un colore specifico di una texture, utilizza il pulsante Campiona colore a schermo.
  • Pulsante Campiona colore a schermo: premi il pulsante e fai clic in un punto qualsiasi dello schermo con il cursore a contagocce per campionare il colore di un pixel, che SketchUp applicherà al materiale selezionato.

I seguenti strumenti consentono di giocare con la texture di un materiale:

  • Casella di selezione Usa immagine per texture: quando la casella è selezionata, puoi scegliere un file immagine da utilizzare come texture. Deselezionando la casella, l'immagine per la texture verrà rimossa. Nota: selezionando nuovamente la casella, il file non verrà ripristinato e dovrai selezionare una nuova immagine.
  • Nome del file dell'immagine per la texture e pulsante Sfoglia: il campo del file della texture contiene il nome dell'immagine (da utilizzare come texture) eventualmente selezionata per il materiale corrente. Per cambiare texture, trascina un file immagine nel campo o fai clic sul pulsante Sfoglia per visualizzare la finestra di dialogo Scegli immagine, da dove puoi cercare un'immagine sul disco rigido. Una volta applicata la texture, puoi regolare il pattern da associare al modello. Per maggiori dettagli, consulta la prossima sezione Riposizionamento delle texture.
  • Pulsante Modifica immagine per la texture in Editor esterno: facendo clic su questo pulsante, SketchUp apre il file di immagine per la texture nell'editor grafico predefinito.
    Nota: è possibile impostare l'editor grafico predefinito dalla finestra di dialogo delle Preferenze di SketchUp, nel pannello Applicazioni. Per maggiori dettagli su come impostare questa preferenza, consulta Personalizza la tua area di lavoro. Se non hai indicato nessun editor grafico, SketchUp aprirà l'editor o l'applicazione di visualizzazione immagini del tuo sistema operativo.
  • Casella di selezione Colora: seleziona questa casella per applicare la stessa tonalità all'intera texture. Il colore viene definito nella sezione Colore della scheda Modifica. Questa opzione è utile per i file che non mostrano i colori appropriati.
  • Campione del colore di ripristino: fai clic su questo campione di colore per reimpostare il colore del file di immagine per la texture come colore del materiale.
  • Campi dimensione: quando applichi una texture a una superficie, l'immagine della texture viene posizionata fino a coprire l'intera superficie. Per cambiare le dimensioni del riquadro della texture, inserisci i valori desiderati nei campi larghezza e altezza. Per impostazione predefinita, le proporzioni dell'immagine rimangono le stesse. Pertanto, se digiti 2 nella casella della larghezza, quella dell'altezza si aggiorna automaticamente per mantenere le proporzioni. Fai clic sull'icona della catena per romperla e modificare le proporzioni. Se non sei soddisfatto del risultato, fai clic sui pulsanti freccia orizzontale e verticale per ripristinare le impostazioni di larghezza e altezza precedenti.
  • Cursore opacità: la voce Opacità indica il livello di opacità o trasparenza dell'immagine. Portare il cursore verso destra aumenta l'opacità della texture, per cui 100 è completamente opaco, mentre a sinistra se ne aumenta la trasparenza, per cui 0 è completamente trasparente. In alternativa, digita un numero da 0 a 100 nel campo Opacità.

MacOS

Prima di poter modificare un materiale, devi salvarlo all'interno del modello. Per vedere i materiali salvati nel modello, seleziona Finestra > Materiali per aprire il pannello Colori. Nella scheda Tavolozza delle texture (l'icona del mattone), fai clic sull'icona Colori nel modello () o seleziona Colori nel modello dal menu a discesa per visualizzare la raccolta Colori nel modello, come mostrato nella figura seguente.

Se il materiale che desideri modificare non è presente nella raccolta Colori nel modello, applica il materiale a una superficie del tuo modello. Nota: se in seguito sostituisci un materiale con un altro, l'originale rimarrà nella raccolta Colori nel modello fino a quando non cancellerai i materiali inutilizzati.

Quando è tutto pronto per modificare un materiale, segui questa procedura:

  1. Nella scheda Tavolozza delle texture (icona del mattone), apri la raccolta Colori nel modello.
  2. Seleziona il materiale da modificare.
  3. Seleziona Modifica dall'elenco a discesa del Colore oppure fai clic sul materiale tenendo premuto Ctrl e seleziona Modifica dal menu contestuale.
  4. Nel pannello Modifica materiale, mostrato in figura, apporta le modifiche desiderate.
  5. Una volta terminato, fai clic su Chiudi.

Di seguito ti presentiamo le diverse opzioni del pannello Modifica materiale:

  • Nome: inserisci un nuovo nome del materiale per modificare quello esistente.
  • Modifica texture in Editor esterno: fai clic su questo pulsante per aprire l'immagine per la texture nell'editor grafico o programma di anteprima predefinito. Applica le modifiche e salva il file affinché vengano trasferite al materiale.
  • Menu a discesa della texture: le opzioni di questo menu a discesa ti consentono di modificare la texture dall'interno di SketchUp. Scegli Carica per selezionare un nuovo file di immagine per la texture. Scegli Rimuovi per eliminare il file di immagine della texture (quando l'immagine della texture viene rimossa, compare un'approssimazione uniforme del colore dell'immagine rimossa). Se hai colorato la texture, scegli Ripristina colore per rimuovere la colorazione. Scegliendo Modifica, il file di immagine della texture verrà aperto nell'editor grafico o programma di anteprima predefinito. Una volta applicata la texture, puoi regolare il pattern da associare al modello. Per maggiori dettagli, consulta la prossima sezione Riposizionamento delle texture.
  • Larghezza e Altezza: quando applichi una texture a una superficie, l'immagine della texture viene posizionata fino a coprire l'intera superficie. Per cambiare le dimensioni del riquadro della texture, inserisci i valori desiderati nei campi Larghezza e Altezza. Per impostazione predefinita, le proporzioni dell'immagine rimangono le stesse. Pertanto, se digiti 2 nella casella della larghezza, quella dell'altezza si aggiorna automaticamente per mantenere le proporzioni. Fai clic sull'icona della catena per romperla e modificare le proporzioni come meglio credi. Se non sei soddisfatto del risultato, per ripristinare l'immagine devi ricordare le dimensioni originali e inserirle manualmente.
  • Colora: quando il pannello Modifica materiale è aperto, puoi colorare una texture. Utilizza una delle schede colore e applica il colore desiderato all'anteprima del materiale nel pannello. In alternativa, fai clic sullo strumento contagocce nella parte inferiore del pannello Colori e fai clic su uno dei materiali del modello o sulla scheda Tavolozze delle texture (icona del mattone).
    Suggerimento: la colorazione è un ottimo modo per sperimentare con le variazioni cromatiche del materiale.
  • Opacità: quando il pannello Modifica materiale è aperto, puoi anche modificare l'opacità di un materiale, ossia il livello di opacità o trasparenza dell'immagine. Portare il cursore verso destra aumenta l'opacità della texture, per cui 100 è completamente opaco, mentre a sinistra se ne aumenta la trasparenza, per cui 0 è completamente trasparente. In alternativa, digita un numero da 0 a 100 nel campo Opacità.

Riposizionare una texture

In seguito all'applicazione di una texture a una o più superfici di un modello 3D, puoi regolarne il posizionamento sulla superficie. A tale scopo, puoi utilizzare lo strumento Posiziona texture, che prevede due modalità:

  • Modalità Puntina fissa: ti permette di muovere, ruotare, ridimensionare o distorcere una texture. Per esempio, puoi regolare la texture di una superficie per allinearla alla stessa texture su un'altra superficie, come ad esempio su due facciate di un edificio.
  • Modalità Puntina libera: se vuoi allungare o restringere una texture, usa la modalità Puntina libera.

Ecco come regolare una texture in modalità Puntina fissa:

  1. Fai clic col tasto destro nel punto desiderato e seleziona Texture > Posiziona dal menu contestuale. Comparirà una matrice di linee tratteggiate che rappresenta i singoli riquadri della texture. Inoltre, il cursore si trasformerà in una mano e compariranno quattro puntine.
  2. Se riesci a vedere le quattro puntine colorate mostrate in figura, procedi al passaggio successivo. Se non le vedi, fai clic con il tasto destro sul materiale e seleziona Puntine fisse.
  3. Sistema la texture con il cursore a forma di mano e/o con le puntine. In questo esempio, vogliamo spostare la puntina verde in modo tale che il legno della parte superiore della credenza sia orientato nella stessa direzione del legno della parte laterale. Ecco un breve riepilogo di tutte le opzioni disponibili:
    • Fai clic sul materiale con il cursore a forma di mano e trascinalo per riposizionare l'intera texture.
    • Fai clic su una puntina per sollevarla e fai clic nuovamente in un altro punto della texture per riposizionarla.
    • Trascina una puntina per modificare la texture. Trascina la puntina blu per ridimensionare o tagliare la texture. Trascina la puntina gialla per distorcere la texture. Trascina la puntina verde per ridimensionare la texture o ruotarla attorno all'asse della puntina Sposta. Trascina la puntina rossa (puntina Sposta) per spostare la texture.
    Suggerimento: in modalità Puntina fissa puoi anche fare clic con il tasto destro sulla texture per visualizzare opzioni aggiuntive, ossia capovolgere la texture a sinistra o a destra o verso l'alto o verso il basso o ruotare la texture in incrementi di 90 gradi. L'opzione Ripristina riporta la texture allo stato originale, mentre l'opzione Annulla non fa che annullare l'ultimo comando. Se annulli un'azione, si attiva anche l'opzione Ripeti.
  4. Una volta applicate le modifiche alla texture, fai clic con il tasto destro sulla texture e seleziona Fatto. In alternativa, fai clic al di fuori della texture per uscire dalla modalità Puntina fissa.

In modalità Puntina libera, puoi impostare la dimensione del riquadro della texture in relazione al modello. Ecco come funziona:

  1. Fai clic col tasto destro nel punto desiderato e seleziona Texture > Posiziona dal menu contestuale. La modalità Puntina fissa viene attivata per impostazione predefinita.
  2. Passa alla modalità Puntina libera facendo clic con il tasto destro sulla texture e disattivando l'opzione Puntine fisse. In modalità Puntina libera vedrai quattro puntine bianche, come nella figura seguente.
  3. Fai clic su una puntina per sollevarla e fai clic nuovamente per riposizionarla. Ripeti l'operazione per tutte e quattro le puntine per impostare gli angoli del riquadro della texture. Se le puntine non formano una configurazione rettangolare, la texture risulterà distorta.
  4. Una volta terminato, fai clic con il tasto destro sulla texture e seleziona Fatto. In alternativa, fai clic al di fuori della texture per uscire dalla modalità Puntina libera.
Suggerimento: in modalità Puntina libera, vedrai le dimensioni del riquadro della texture solo sulla superficie selezionata. Per modificare le dimensioni del riquadro della texture per tutto il modello, usa il pannello Materiali (Microsoft Windows) o il pannello Colori (macOS). Per maggiori dettagli, consulta la precedente sezione Modificare i materiali.

Calcolare l'area dei materiali in automatico

Se vuoi che SketchUp calcoli l'area di una superficie a cui è stato applicato un materiale, fai clic con il tasto destro sul materiale e seleziona Area > Materiale. Su Windows puoi anche fare clic con il tasto destro sul materiale nel pannello Materiali e selezionare Area dal menu (se la voce Area nel menu è grigia, significa che il materiale non è stato applicato ad alcuna superficie).

In entrambi i casi, comparirà una finestra di dialogo dove è indicata l'area totale delle superfici alle quali è stato applicato il materiale selezionato. Le unità di misura (come piedi quadrati e metri quadrati) dipendono dalle unità di misura indicate nel template. Per maggiori dettagli sulla modifica delle unità di misura predefinite, consulta Configurare i template.

Se utilizzi la classificazione IFC, puoi generare un report sui materiali utilizzati per tutto il modello. Per maggiori dettagli, consulta Classificare gli oggetti (in particolare la sezione sulla generazione dei report).

Gestire e organizzare i materiali

Il pannello Materiali (Microsoft Windows) o il pannello Colori (macOS) consentono di trovare e organizzare i materiali. L'elenco seguente spiega come gestire i materiali con il sistema operativo selezionato nel Centro assistenza.

Windows

  • Sfogliare le raccolte incluse: per vedere i materiali, scegli una raccolta dal menu a discesa nella scheda Seleziona.
  • Tenere traccia dei materiali del modello: fai clic sull'icona Nel modello () per vedere tutti i materiali applicati al modello.
  • Eliminare i materiali non necessari: se sostituisci un materiale con un altro in modo tale che l'originale non sia più presente all'interno del modello, questo rimarrà comunque nella raccolta Nel modello fino a quando non lo eliminerai facendovi clic con il tasto destro e selezionando Elimina. Per rimuovere tutti i materiali inutilizzati di un modello, seleziona la raccolta Nel modello. Quindi, fai clic sulla freccia Dettagli () e seleziona Cancella non usati. In alternativa, seleziona Elimina tutto per rimuovere tutti i materiali del modello e della raccolta Nel modello.
  • Creare raccolte personali: puoi creare una raccolta per un progetto specifico o una raccolta di materiali creati da te, come nel caso di schemi colore specifici, campioni di tessuto, opzioni di paesaggistica o qualsiasi altro elemento che utilizzi di frequente. Nella scheda Seleziona, fai clic sulla freccia Dettagli () e seleziona Apri o Crea una raccolta. Nella finestra di dialogo Seleziona la cartella di una raccolta o creane una nuova, vai alla cartella dove vuoi salvare la tua raccolta. Fai clic sul pulsante Nuova cartella, assegna un nome alla cartella (sarà il nome della raccolta) e fai clic su Seleziona cartella. Una volta creata la raccolta, puoi andare nella cartella e aprirla. Per aggiungere materiali alla raccolta, trascinali al suo interno dal panello di selezione secondario oppure salvaci i materiali da te creati.
  • Aggiungere raccolte utilizzate di frequente ai preferiti: nella scheda Seleziona, fai clic sulla freccia Dettagli e scegli Aggiungi raccolta ai Preferiti. La raccolta selezionata viene visualizzata in un elenco dei preferiti in fondo all'elenco a discesa. Se non vuoi più che la raccolta sia tra i preferiti, selezionala, fai clic sulla freccia Dettagli e su Rimuovi raccolta dai Preferiti.
    Nota: fai clic sulla freccia Dettagli per scegliere di visualizzare i materiali in riquadri piccoli, medi, grandi o molto grandi. Scegli l'opzione Elenco per vedere i nomi dei materiali invece che l'anteprima dei campioni.

MacOS

  • Sfogliare le raccolte incluse: per accedere ai materiali inclusi in SketchUp, fai clic sull'icona Tavolozza delle texture (l'icona del mattone) e scegli tra le raccolte presenti nel menu a discesa, come Mattoni e rivestimento, Recinto, Rivestimento tetti, Semitrasparente o Legno. Ogni materiale di una raccolta viene presentato sotto forma di campione sul quale puoi fare clic con il cursore Riempi per applicarlo al modello.
  • Tenere traccia dei materiali di un modello: nel pannello Colori c'è una speciale raccolta di materiali denominata Colori nel modello, che contiene tutti i materiali attualmente in uso nel modello. I contenuti di questa raccolta vengono generati automaticamente ogni volta che aggiungi un materiale al modello SketchUp. Per accedere a questa raccolta, seleziona Colori nel modello dal menu a discesa della raccolta di materiali, oppure fai clic sull'icona Colori nel modello ().
  • Eliminare i materiali non necessari: se sostituisci un materiale con un altro in modo tale che l'originale non sia più presente all'interno del modello, questo rimarrà comunque nella raccolta Colori nel modello fino a quando non lo eliminerai facendovi clic con il tasto destro e selezionando Rimuovi. Per rimuovere tutti i materiali inutilizzati di un modello, seleziona la raccolta Colori nel modello. Quindi seleziona Elenco > Cancella non usati. In alternativa, seleziona Elimina tutto per rimuovere tutti i materiali del modello e della raccolta Colori nel modello.
  • Creare raccolte personali: puoi creare una raccolta per un progetto specifico o una raccolta di materiali creati da te, come nel caso di schemi colore specifici, campioni di tessuto, opzioni di paesaggistica o qualsiasi altro elemento che utilizzi di frequente. Seleziona Elenco > Nuova. Nella casella Nome elenco visualizzata, digita un nome e fai clic su OK. A questo punto vedrai il nome della raccolta creata nell'elenco a discesa.
    Per aggiungere materiali a una nuova raccolta, puoi trascinare nel pannello dei campioni della nuova raccolta il campione accanto al Contagocce nella parte inferiore del pannello Colori. In alternativa, puoi creare nuove texture e salvarle nella raccolta. Per rimuovere la raccolta, seleziona Elenco > Rimuovi.
Nota: se sei solito utilizzare il pannello Materiali su Windows, ricorda che il pannello Colori su macOS non permette di aggiungere le raccolte utilizzate di frequente all'elenco dei preferiti.

Creare materiali personalizzati

I materiali inclusi in SketchUp consentono di iniziare a utilizzare i materiali e capirne il funzionamento. Probabilmente, per applicare materiali specifici al tuo progetto o edificio, dovrai creare dei materiali personali. La procedura è piuttosto semplice: parti da un'immagine per creare un riquadro della texture e, se necessario, indica un colore.

Windows

Per creare un nuovo materiale dai tuoi file o codici colore, segui questi passaggi:

  1. Nel pannello Materiali, fai clic sull'icona Crea materiale () in alto a destra.
  2. Nella finestra di dialogo Crea materiale visualizzata, digita il nome del nuovo materiale nel campo di testo in alto.
  3. Scegli le opzioni di colore, texture e opacità del materiale. Queste opzioni funzionano esattamente come quelle del pannello Modifica. Per maggiori dettagli, consulta la precedente sezione Modificare i materiali. In alternativa, per una migliore comprensione delle opzioni di colore, consulta Miscelare i colori con la Selezione colore.
  4. Fai clic su OK. Il nuovo materiale risulta selezionato nella raccolta Nel modello.

MacOS

Per creare un nuovo materiale da usare come texture, segui questi passaggi:

  1. Nel pannello Colori, fai clic sulla scheda Tavolozza delle texture (indicata con l'icona del mattone).
  2. Seleziona la raccolta in cui vuoi inserire il nuovo materiale.
  3. Seleziona Colore > Nuova texture.
  4. Nella finestra di dialogo visualizzata, seleziona un file immagine per la texture.
  5. Nel pannello visualizzato, digita il nome della texture, imposta la larghezza e l'altezza del riquadro e fai clic su OK. Se desideri colorare la texture, segui i passaggi indicati nella precedente sezione, Modificare i materiali.

Ecco invece come salvare un colore specifico come materiale:

  1. Usa una qualsiasi delle schede colore per creare il colore desiderato, che viene visualizzato nel campione nella parte inferiore del pannello Colori. Per maggiori dettagli, consulta Miscelare i colori con la Selezione colore.
  2. Seleziona la scheda Tavolozza delle texture (indicata con l'icona del mattone).
  3. Vai nella raccolta in cui vuoi salvare il colore.
  4. Trascina il campione del colore dalla parte bassa del pannello Colori fino all'area dei campioni della raccolta.
Suggerimento: puoi ampliare le raccolte di materiali scaricando altri materiali. Dai un'occhiata a questo post del blog di SketchUpdate per maggiori dettagli.