Välj geometri

Väljverktyget (Väljverktyg) anger vilka objekt du vill ändra med hjälp av SketchUps andra verktyg eller kommandon. Om du vill ändra längden på en linje, börja med att välja linjen. Om du vill skala upp eller ner en box, börja med att välja boxen. Om du vill flytta en linje och en box, börja med att välja båda delarna. Detta kallas för ett set.

Här hittar du väljverktyget i SketchUp:

  • Verktygsfältet för att komma igång (visas här), verktygsfältet med stora verktyg och det huvudsakliga verktygsfältet (Microsoft Windows)
  • Verktygspaletten (macOS)
  • Verktygsmenyn

Kom igång-verktygsfält

Tips: Väljverktyget är så viktigt för 3D-modellering i SketchUp att det har ett enkelt kortkommando: tryck helt enkelt på mellanslag så aktiveras verktyget.

Välj ett objekt

För att välja ett objekt:

  1. Aktivera väljverktyget (Väljverktyg). Markören ändras till en pil.
  2. Klicka på ett objekt. Vad du än väljer (kant, yta eller komponent till exempel) markeras, såsom soffkudden som visas här.
Kudden är vald

Om du inte väljer rätt objekt första gången, försök helt enkelt igen. Om du inte vill välja något, klicka på en tom plats i ritfönstret.

Välj flera objekt

När du behöver välja flera objekt har SketchUp ett par olika alternativ. Titta på videon för att se hur alternativen fungerar och lär dig tips och tricks för att snabbt och enkelt göra komplexa val. Eller läs vidare för information om hur du väljer flera objekt.

Tips: Oberoende av vilket verktyg som är aktivt kan du välja Redigera (Edit) > Välj alla (Select All) i menyn eller trycka på Ctrl + A (Microsoft Windows) eller Command + A (macOS) för att välja allt i modellen.
För att se till att inget är valt, använd Redigera (Edit) > Avmarkera alla (Deselect All), tryck Ctrl + T (Microsoft Windows) eller Shift + Command (macOS). Du kan även klicka på ett tomt utrymme i ritytan.

När väljverktyget är aktivt kan du välja flera objekt på ett av följande sätt:

  • Klicka och dra för att skapa en ruta för val. När väljverktyget är aktivt kan du klicka och dra för att skapa en tillfällig ruta runt objekten som du vill välja. När du släpper musens knapp väljs dina objekt. Om du klickar och drar till vänster (korsande val) väljs allt som är helt eller delvis inom rutan. Om du klickar och drar till höger (fönsterval som visas på bilden) väljs endast de objekt som är helt inom rutan. Till exempel kan du se att endast en röd kudde är vald trots att del av den andra kudden är inuti rutan.

    Fönsterval
  • Dubbel- eller trippelklick. Beroende på vad du klickar på kan du välja kombinationer av kanter och ytor. Följande tabell visar valmöjligheterna.
    Gör så här . . . . . . För att välja det här
    Dubbelklicka på en ytaYtan och alla dess avgränsande kanter (1)
    Dubbelklicka på en kantKanten och dess anslutna yta (2)
    Trippelklicka på ett objektAlla anslutna objekt. Om du till exempel trippelklickar på en yta av en kub väljs hela kuben. (3)

    Dubbelklicka på en yta eller kant. Trippelklicka för att välja ett objekt.
  • Kontext-klicka på en kant. Ett kontext-klick på en kant öppnar en meny med följande alternativ:
    • Välj (Select) > Anslutna ytor (Connected Faces) väljer alla ytor som är länkade till det valda objektet.
    • Välj (Select) > Alla anslutna (All Connected) väljer alla objekt som är länkade till det valda objektet. (Detta ger samma resultat som att trippelklicka på objektet.)
    • Välj (Select) > Alla i samma lager (All on same Layer) väljer alla objekt i samma lager som det valda objektet. Om din modell inte har lager är resultatet detsamma som att trippelklicka.
  • Kontext-klicka på en yta. När du kontext-klickar på en yta visar menyn alla alternativ som kan ses när du kontext-klickar på en kant, samt två ytterligare alternativ:
    • Välj (Select) > Yttre kanter (Bounding Edges) väljer yttre kanter på den valda ytan.
    • Välj (Select) > Alla med samma material (All with same Material) väljer alla objekt med samma material som den valda ytan. Om du till exempel vill välja alla ytor med tegel eller röd färg och ändra materialet till något annat kan du enkelt göra det med den här metoden.

Lägg till och ta bort från ett val-set

När du väljer flera objekt är det lätt hänt att du tar tag i ett objekt du inte vill inkludera eller missar ett objekt du vill ha. För att lägga till eller ta bort objekt från ett val-set, se till att väljverktyget (Select) är aktiverat. Sedan kan du justera valet med hjälp av de tangentbordskommandon som visas i följande tabell. För att till exempel välja båda röda kuddar som visas här väljer du en kudde och håller sedan ner Ctrl medan du väljer den andra kudden.

Två objekt har valts.

Tips: När du aktiverar en ändring genom tangentbordet visar verktygets markör plus- eller minustecken (Väljverktygets markör vid kommando från tangentbordet.) bredvid pilen.
För att göra så här . . . Tryck och håll ner tangent(er) Och samtidigt . . .
Lägga till i ett val-set, ett objekt åt gången Ctrl (Microsoft Windows) eller Option (macOS) Klicka på ej valda objekt
Ändra ett objekts status (valt eller inte valt). (Välj ett icke valt objekt eller ta bort val)Shift Klicka på ett objekt
Ta bort objekt från val-set Shift+Ctrl (Microsoft Windows) eller Shift+Option (macOS) Klicka på valda objekt

Tips: Om du behöver ett tillfälligt sätt att snabbt välja om samma grupp av objekt kan du göra ditt val till en grupp. Se Organisera en modell för information om hur du skapar en grupp.

Omvänd ett val

Att göra ett omvänt val kan förenkla komplex redigering, som att ta bort löv från ett träd. I det exemplet väljer du stammen och grenarna. Sedan omvänder du valet för att välja alla blad.

För att göra ett omvänt val, gör ett val och tryck sedan Ctrl + Shift + I.

För att göra ett omvänt val, gör ett val och tryck sedan Command + Shift + I.

Du kan även använda valet Redigera (Edit) > Omvänd val (Invert Selection) i menyn.