Skip to Content
Help

Modellering av komplexa 3D-former med Solid-verktygen

Senast uppdateras: okt. 21, 2026•6 min upplästa.

Med SketchUps Solid-verktyg kan du skapa nya former genom att kombinera eller beskära en form med en annan, vilket gör det enkelt att modellera ett ytterskal eller snickeri.

Kolla in följande tabell för en snabb introduktion till Solid-verktygen, inklusive vad verktyget gör och om det är tillgängligt i SketchUp Free.

Verktyg

Namn

Vad gör det

Ingår i SketchUp Free?

Outer 20Shell.png

Ytterskal

Lämnar endast de yttre ytorna på överlappande solider.

Ja

Union.png

Förening

Kombinerar två eller fler solider i en enda form.

Endast betalda prenumerationer

Subtract.png

Subtrahera

En solid tar bort en del av en annan och raderas.

Endast betalda prenumerationer. I SketchUp Free använder du Korsa med modell.

Trim.png

Trimma

En solid trimmar en annan men stannar kvar i modellen.

Endast betalda prenumerationer

Intersect.png

Korsa

Lämnar bara den korsande geometrin.

Endast betalda prenumerationer

Split.png

Dela

Delar solider längs korsande geometri.

Endast betalda prenumerationer

För att hitta Solid-verktygen, leta i följande delar av SketchUp-gränssnittet:

SketchUp Pro

  • Verktygsfält för solider

  • Verktyg-meny (Välj Tools > Outer Shell (Verktyg > Ytterskal) eller Välj Tools > Solid Tools (Verktyg > Solid-verktyg) och välj de andra verktygen från en undermeny)

  • Verktygspaletten (macOS)

SketchUp för webben

  • Verktygsfält för solider i vänster panel

  • Verktyget Solidinspektören i den högra panelen

I följande video ser du exempel på hur Solid-verktygen kan användas. I följande avsnitt i den här artikeln hittar du steg och detaljer om hur du använder varje verktyg. (Observera dock att du inte längre kan placera SketchUp-modeller i Google Earth.)

Innehållsförteckning
  1. Skapa ett ytterskal

  2. Förena solider i en enda form

  3. Subtrahera en solid från en annan (eller använd Korsa ytor med modell)

  4. Trimma en solid med en annan

  5. Lämnar bara den korsande geometrin

  6. Klyva solider

  7. SketchUp Web: Fixa modeller med Solidinspektören

Skapa ett ytterskal

Ytterskal-verktyget ( Outer 20Shell.png ) tar bort geometri inuti överlappande grupper eller komponenter och lämnar endast de yttre ytorna.

Anta till exempel att du har två modeller: den ena är en detaljerad byggnadsmodell för interiör och exteriör. Den andra modellen illustrerar byggnaden i en gatuvy som visar omgivande byggnader, gator och landskapsarkitektur. Du kan importera den detaljerade byggnadsmodellen till din gatuvy. Men all den geometrin kan sakta ner din gatuvymodell och är inte nödvändig. I din gatuvy eliminerar du den inre geometrin som du inte behöver genom att skapa ett yttre skal av byggnaden så att din gatuvymodell blir lättare och renderas snabbare när du arbetar på den.

Följ dessa steg för att skapa ett yttre skal från överlappande grupper eller komponenter:

SketchUp Pro

  1. Med verktyget Select (Välj) ( Select.png ), välj alla korsande grupper eller komponenter som du vill inkludera i ditt ytterskal.
  2. Kontext-klicka på ditt val och välj Outer Shell (Ytterskal) från menyn som visas, så som visas på bilden. De yttre ytorna blir kvar.

Eller så kan du skapa ett ytterskal enligt följande:

  1. Välj verktyget Outer Shell (Ytterskal) ( Outer 20Shell.png ).
  2. Klicka för att välja den första gruppen eller komponenten i ditt ytterskal.

  3. Klicka på den andra gruppen eller komponenten. SketchUp kombinerar dina val i ett ytterskal så att endast de yttre ytorna finns kvar.

  4. (Valfritt) Fortsätt att klicka på ytterligare grupper eller komponenter för att lägga till dem i ditt ytterskal, så som visas på bilden.

fg022 3.png

SketchUp för webben

  1. Välj verktyget Outer Shell (Ytterskal) ( Outer 20Shell.png ) från den vänstra verktygspanelen.
  2. Klicka för att välja den första gruppen eller komponenten i ditt ytterskal.

  3. Klicka på den andra gruppen eller komponenten. SketchUp kombinerar dina val i ett ytterskal så att endast de yttre ytorna finns kvar.

  4. (Valfritt) Fortsätt att klicka på ytterligare grupper eller komponenter för att lägga till dem i ditt ytterskal, så som visas på bilden.

sketchup 1004124 UnionOuterShell.png

Förena solider i en enda form

En förening sammanfogar två eller flera solida enheter till en enda solid.

Resultatet av en förening liknar resultatet av ett ytterskal. Resultatet av en förening kan dock innehålla inre geometri medan ett ytterskal endast innehåller externa ytor. (Se föregående bild för ett exempel.)

Så här använder du Föreningsverktyget för att kombinera solida enheter:

  1. Välj verktyget Union (Förening) ( Union.png ).
  2. Klicka för att välja den första gruppen eller komponenten för föreningen.

  3. Klicka på den andra gruppen eller komponenten. Den resulterande föreningen av geometrin kvarstår.

  4. (Valfritt) Fortsätt att klicka på ytterligare grupper eller komponenter för att lägga till dem i föreningen, så som visas i figuren, som använder röntgenvy så att du kan se geometrin inom varje solid.

fg022 4.png

Subtrahera en solid från en annan (eller använd Korsa ytor med modell)

Med Subtraheringsverktyget kan du använda en solid enhet för att klippa en annan solid enhet. Din ursprungliga solida enhet subtraheras sedan från modellen. För att subtraktionen ska fungera måste de två soliderna överlappa varandra.

Följ dessa steg för att utföra en trimning:

  1. Välj verktyget Trim ( Trim.png ).
  2. Klicka för att välja skärgrupp eller komponent. I exemplet som visas här väljer du pinnen först för att göra ett hål i brädet. När du har gjort ett val blir 1 bredvid markören till 2.

  3. Klicka på den grupp eller komponent som du vill klippa. Klippgruppen stannar kvar, men gör ett hål i det andra urvalet. Resultatet är först svårt att se (se Bildtext 1). Men om du flyttar pinnen ur hålet, så som visas i Bildtext 2, så ser du hålet i brädet.

image trim steps

Lämnar bara den korsande geometrin

Med verktyget SketchUp Pros Intersect (Korsa) ( Intersect.png ), välj två eller flera överlappande solida enheter så stannar endast den korsande geometrin kvar.

Följ dessa steg för att utföra en korsning:

  1. Välj verktyget Intersect (Korsa) ( Intersect.png ).
  2. Välj en solid enhet som du vill använda i korsningen.

  3. Välj en eller flera ytterligare solider som överlappar ditt ursprungliga val. Den resulterande korsande geometrin stannar kvar. I det här exemplet skapar korsningspunkten mellan rutan och sfären (Bildtext 1) en punkt med en rundad bas (Bildtext 2).

image intersect steps

Klyva solider

Med verktyget Split (Dela) ( Split.png ) kan du dela överlappande solida enheter längs deras korsande kanter. Följ dessa steg för att utföra en delning:
  1. Välj verktyget Split (Dela) ( Split.png ).
  2. Klicka på en solid enhet.

  3. Klicka på en annan solid enhet som korsar ditt första urval. SketchUp delar upp all geometri längs kanterna där de valda soliderna korsar varandra. Till exempel: de två grupperna till vänster på bilden delas upp i tre grupper, så som visas till höger.

image solid tools split

Fixa modeller med Solidinspektören i SketchUp Web

När geometrin blir mer och mer komplex kan små fel förhindra att modellerna kan bli mångfaldiga. Solidinspektören i SketchUp for Web är ett verktyg som hjälper dig att förbereda modeller för 3D-utskrift genom att hitta och åtgärda problem som hindrar SketchUp från att klassificera din modell som en solid. Denna inspektion är också användbar för att fixa 3D-modeller för användning med Solid-verktyg.