Dodawanie kolorów i tekstur za pomocą materiałów

Aby dodać szczegóły i nadawać modelom realny wygląd, program SketchUp umożliwia malowanie powierzchni materiałów. Materiały to po prostu farby, które mają kolor i opcjonalną teksturę (zdefiniowaną w pliku obrazu). Na przykład na poniższej ilustracji materiał pokrycia dachowego ma kolor niebieski i teksturę imitującą metalowe pokrycie dachowe. Oblicówka i trawa również są materiałami mającymi kolor i teksturę.

Po zastosowaniu podobnych materiałów do modelu specjalne możliwości materiałów programu SketchUp mogą pomóc w wykonaniu dowolnej z następujących czynności:

  • Wymiana jednego materiału na inny: powiedzmy, że chcesz pokazać metalowy dach zamiast gontów. Można szybko i łatwo zamienić pokrycie dachowe na gonty.
  • Edytowanie materiału: ponieważ kolor i tekstura są oddzielne, można je zmieniać niezależnie od siebie. Na przykład można zmienić kolor oblicówki (może na żółty?), ale zachować tę samą teksturę. Można również edytować stopień przezroczystości, aby zdefiniować, jak bardzo nieprzezroczysty lub przezroczysty będzie materiał.
  • Obliczanie potrzebnej ilości materiału: program SketchUp może wskazać powierzchnię wszystkich gontów lub oblicówki. Oczywiście, aby to obliczenie miało jakikolwiek sens, trzeba utworzyć dokładny model, aby liczby odzwierciedlały rzeczywisty rozmiar modelu.
Wskazówka: program SketchUp zawiera kilka kolekcji materiałów: dywan, płytki, pokrycie podłoża, szkło, drewno i inne. Jeśli jednak potrzebny Ci materiał nie jest dostępny, możesz stworzyć własny. Ta funkcja jest szczególnie przydatna, jeśli jesteś dekoratorem lub konstruktorem, który musi pokazać swoim klientom precyzyjne wykończenie.

W interfejsie programu SketchUp można modelować materiały za pomocą narzędzia Paint Bucket (Wiadro z farbą) () i panelu Materials (Materiały) w systemie Microsoft Windows lub panelu Colors (Kolory) w systemie macOS. Panele Materials (Materiały) i Colors (Kolory) umożliwiają również przeglądanie i organizowanie materiałów oraz zarządzanie nimi. Panel Materials (Materiały) lub Colors (Kolory) śledzi materiały w modelu i umożliwia tworzenie niestandardowych kolekcji materiałów, specyficznych dla konkretnych projektów lub przepływów pracy.

Uwaga: jeśli przełączasz się między komputerami z systemem Microsoft Windows i macOS, pamiętaj, że interfejsy panelu Materials (Materiały) i Colors (Kolory) są unikatowe dla odpowiednich systemów operacyjnych. W kolejnych częściach będą wyświetlane instrukcje dotyczące systemu Microsoft Windows lub macOS, w zależności od systemu operacyjnego wybranego z listy rozwijanej na dowolnej stronie Centrum pomocy.

Na poniższym filmie pokazujemy, jak stosować materiały i wprowadzać typowe zmiany, takie jak wymiana jednego materiału na inny. Aby uzyskać szczegółowe instrukcje dotyczące korzystania z materiałów, zapoznaj się z następnymi punktami.

Stosowanie materiałów

Stosowanie materiałów do modelu jest dość proste: wybierz powierzchnię lub powierzchnie, a następnie żądany materiał. Jeśli malujesz grupy lub komponenty, zapoznaj się ze wskazówkami na końcu tego punktu, które mogą jeszcze bardziej ułatwić stosowanie materiałów.

Stosowanie materiałów do modelu za pomocą narzędzia Paint Bucket (Wiadro z farbą) (), które można znaleźć w następujących częściach interfejsu programu SketchUp:

    Windows
  • Pasek narzędzi Getting Started (Pierwsze kroki)
  • Pasek narzędzi Large Tool Set (Duży zestaw narzędzi)
  • Pasek narzędzi Principal (Główny)
  • Tools (Narzędzia) > Paint Bucket (Wiadro z farbą) na pasku menu

Aby rozpocząć stosowanie materiałów do modelu, wykonaj następujące kroki:

  1. Wybierz narzędzie Paint Bucket (Wiadro z farbą) ().
  2. W panelu Materials (Materiały), który się otworzy, kliknij kartę Select (Wybierz). Jeśli panel Materials (Materiały) nie otwiera się w zasobniku, okno dialogowe może znajdować się na ukrytym zasobniku. W takim przypadku najedź kursorem na kartę ukrytego zasobnika. Spowoduje to rozwinięcie zasobnika. Następnie można otworzyć panel Materials (Materiały) w zasobniku.
  3. Z listy rozwijanej wybierz kolekcję materiałów.
  4. Kliknij materiał, którego chcesz użyć.
    Wskazówka: aby pobrać próbkę materiału, który jest już w modelu, przytrzymaj klawisz Alt, co spowoduje tymczasowe przełączenie się na narzędzie Sample (Próbka). Kursorem pipety narzędzia Sample (Próbka) kliknij powierzchnię, z której chcesz pobrać materiał. Zwolnij klawisz Alt, aby powrócić do narzędzia Paint Bucket (Wiadro z farbą).
  5. Wróć do obszaru rysunku i kliknij powierzchnię lub powierzchnie, aby zastosować materiał.

Stosowanie materiałów w programie SketchUp dla systemu Windows

Wskazówka: aby przywrócić domyślne kolory, wykonaj powyższe kroki, ale zamiast klikać materiał, kliknij opcję Set Material to Paint with Default (Ustaw materiał do malowania na wartości domyślne) () w prawym górnym rogu i kliknij powierzchnię w modelu, aby zastosować domyślne kolory.

    MacOS
  • Pasek narzędzi Large Tool Set (Duży zestaw narzędzi)
  • Tools (Narzędzia) > Paint Bucket (Wiadro z farbą) na pasku menu
  • Paleta narzędzi

Aby rozpocząć stosowanie materiałów do modelu, wykonaj następujące kroki:

  1. Wybierz narzędzie Paint Bucket (Wiadro z farbą) (). W panelu Colors (Kolory), który zostanie wyświetlony, można wybrać kolor na jednej z czterech kart selektora kolorów lub skorzystać z kolekcji materiałów.
  2. Aby przeglądać kolekcje materiałów, kliknij kartę Texture Palettes (Palety tekstur), na której znajduje się ikona cegły. (Zobacz temat Mieszanie kolorów w selektorze kolorów, aby uzyskać szczegółowe informacje na temat korzystania z innych kart służących do wybierania kolorów).
  3. Z listy rozwijanej wybierz kolekcję materiałów. Na poniższej ilustracji wybrano kolekcję Roofing (Pokrycia dachowe).
  4. Kliknij materiał, który chcesz zastosować do modelu.
    Wskazówka: aby pobrać próbkę materiału, który jest już w modelu, kliknij narzędzie Eyedropper (Pipeta) u dołu karty Texture Palettes (Palety tekstur). Za pomocą dużego okrągłego kursora kliknij powierzchnię, z której chcesz pobrać próbkę materiału. Spowoduje to załadowanie próbki materiału i ponownie zostanie wyświetlony kursor wiadra z farbą.
  5. Wróć do obszaru rysunku i kliknij powierzchnię lub powierzchnie, aby zastosować materiał.

Alternatywnie możesz kliknąć i przeciągnąć próbkę materiału z głównego obszaru karty Texture Palettes (Palety tekstur) na powierzchnię w modelu. (Nie można przeciągnąć próbki z palety u dołu panelu Colors (Kolory) w systemie macOS. Aby uzyskać szczegółowe informacje na temat korzystania z tych zapisanych próbek, zobacz temat Mieszanie kolorów w selektorze kolorów).

Wskazówka: aby przywrócić domyślne kolory, wybierz próbkę Default (Domyślna) z kolekcji Colors In Model (Kolory w modelu).

Wskazówka: jeśli wybrany materiał nie pojawia się po kliknięciu powierzchni, model prawdopodobnie używa stylu, który nie wyświetla tekstur. Aby to sprawdzić, otwórz panel Styles (Style), wybierz kartę Edit (Edycja), a następnie kliknij ikonę Face Settings (Ustawienia powierzchni). Upewnij się, że w obszarze Styl jest zaznaczona opcja Display Shaded Using Textures (Wyświetlaj cieniowanie przy użyciu tekstur).

Jeśli style wyświetlają tekstury, komputer może mieć za mało pamięci, aby wyświetlić materiały w modelu. Aby uzyskać pomoc, zobacz temat Rozwiązywanie problemu w programie SketchUp.

Można pomalować wiele płaszczyzn i krawędzi jednocześnie. Aby to zrobić, użyj narzędzia Select (Zaznacz) () do zaznaczenia płaszczyzn i krawędzi, które chcesz pomalować. Następnie przełącz się na narzędzie Paint Bucket (Wiadro z farbą) i zastosuj materiał. (Wskazówki dotyczące procesu zaznaczania są przedstawione w punkcie Wybieranie geometrii).

Stosując materiały do kilku powierzchni jednocześnie, należy pamiętać o następujących kwestiach:

  • Powierzchnie mają dwie strony: przód i tył. Można pomalować przód lub tył wszystkich zaznaczonych powierzchni, ale nie ich kombinację. Malowana strona jest określana przez stronę, którą klikniesz kursorem wiadra z farbą. Na poniższej ilustracji kliknięcie przodu powierzchni powoduje pomalowanie wszystkich przednich stron zaznaczonych powierzchni, nawet jeśli są widoczne dwie przednie i dwie tylne ściany.
  • Kontroluj wygląd tylnych krawędzi za pomocą stylu. Gdy zaznaczysz powierzchnię i wszystkie krawędzie oraz pomalujesz przód powierzchni, wszystkie zaznaczone krawędzie zostaną pomalowane. Jednak przy malowaniu tylnych powierzchni żadna z krawędzi nie zostanie pomalowana. Aby połączyć tylne krawędzie z materiałami, otwórz panel Styles (Style), kliknij kartę Edit (Edycja), kliknij ikonę Edge Settings (Ustawienia krawędzi) i wybierz opcję By Material (Według materiału) z listy rozwijanej Color (Kolor).

Można stosować materiały do grupy lub komponentu jako całości albo do określonej geometrii w grupie lub w komponencie:

  • Aby pomalować całą grupę lub komponent, zaznacz go i zastosuj materiał. Po wybraniu grupy lub komponentu i zastosowaniu materiału malowane są tylko powierzchnie za pomocą domyślnego materiału.
  • Aby malować geometrię w grupie lub komponencie, kliknij ją dwukrotnie, aby otworzyć jej kontekst. Następnie zaznacz powierzchnie, które chcesz pomalować materiałem.

Poniższy film przedstawia kilka praktycznych wskazówek dotyczących nakładania materiałów na komponenty. Możesz też czytać dalej, aby poznać kroki, które przeprowadzą Cię przez proces malowania wszystkich lub wybranych komponentów.

Wskazówka: aby szybko i łatwo modelować różnice w materiałach, połącz techniki malowania wszystkich i wybranych komponentów.

Aby zobaczyć praktyczne zastosowanie tej wskazówki, załóżmy, że modelujesz krzesło z drewnianą ramą i dwiema poduszkami i chcesz pokazać cztery kolory poduszek. Przedstawiony tutaj Outliner (Szkicownik) pokazuje, że każdy element krzesła (rama i dwie poduszki) jest grupą, z których wszystkie są zagnieżdżone w grupie, która jest następnie zagnieżdżona w komponencie. (Aby uzyskać więcej informacji na temat działania Szkicownika, zobacz punkt Organizowanie modelu).

Poniższe kroki przedstawiają najłatwiejszy sposób nakładania materiałów i pokazują cztery opcje kolorów:

  1. Ponieważ rama jest taka sama w każdym krześle, wybierz grupę ram i zastosuj materiał drewniany, jak pokazano tutaj.
  2. Utwórz kopię dla każdego koloru poduszki. (W punkcie Kopiowanie narysowanych wcześniej elementów znajdziesz wyjaśnienie, jak to zrobić).
  3. Wybierz komponent i zastosuj materiał w kolorze poduszki. Ponieważ rama jest już pomalowana, ale poduszki są nadal w domyślnym kolorze, tylko poduszki są pomalowane kolorowym materiałem. Rama zachowuje materiał o strukturze drewna.
  4. Powtórz poprzedni krok dla każdej opcji koloru. Wynik widać na poniższej ilustracji.

Wskazówka: gdy kilka grup lub komponentów jest zagnieżdżonych w innych grupach i komponentach, program SketchUp może nie pozwolić na malowanie przez kliknięcie najwyżej położonej grupy lub komponentu. Jeśli napotkasz ten problem, spróbuj zastosować materiały do grupy lub komponentu zagnieżdżonego niżej w hierarchii. Szkicownik może pomóc w ustaleniu, na jakim etapie hierarchii znajduje się wybrany element.

Wymiana jednego materiału na inny

Ponieważ program SketchUp umożliwia zastąpienie jednego materiału innym, można szybko i łatwo eksperymentować z materiałami. W kuchni można zobaczyć różne materiały blatu, takie jak czarny granit, niebieskie płytki lub biały kompozyt. Jeśli wybierasz kolory farb do domu, porównaj żółtą oblicówkę i ciemnozielone wykończenie z granatową oblicówką z kremowym wykończeniem. Jeśli zna się skróty klawiaturowe, proces ten jest bardzo prosty. Zobacz skróty w poniższej tabeli.

Wymiana jednego materiału na inny… Klawisz modyfikujący (Microsoft Windows) Klawisz modyfikujący (macOS)
Na sąsiednich powierzchniach Ctrl Option
Na wszystkich powierzchniach w bieżącym kontekście (na przykład ta sama grupa lub komponent) Shift Shift
Na wszystkich połączonych powierzchniach Ctrl+Shift Option+Shift

Oto przykład prezentujący działanie każdego skrótu. Powiedzmy, że próbujesz wymyślić kolory abstrakcyjnego muralu na dwóch oddzielnych ścianach. Poniższa ilustracja przedstawia mural wykonany przy użyciu materiałów z kolekcji Colors-Named.

Aby zobaczyć, jak może wyglądać zamiana koloru czerwonego na zielony, wybierz narzędzie Paint Bucket (Wiadro z farbą), a następnie wybierz kolor zielony z panelu Materials (Materiały) w systemie Microsoft Windows lub z panelu Colors (Kolory) w systemie macOS. Jeśli klikniesz z wciśniętym klawiszem Ctrl lub Option czerwony trójkąt w lewym górnym rogu, tylko sąsiednie powierzchnie z czerwonym materiałem zostaną zastąpione zielonym, jak pokazano na poniższej ilustracji.

Jeśli zamiast tego klikniesz z wciśniętym klawiszem Shift, wszystkie czerwone powierzchnie staną się zielone:

Ale jeśli klikniesz z wciśniętymi klawiszami Ctrl + Shift lub Option + Shift, czerwone powierzchnie zmienią kolor na zielony tylko na lewej ścianie:

Edytowanie materiałów

Program SketchUp umożliwia edycję materiałów. Gdy wprowadzisz zmiany, wszystkie powierzchnie pomalowane materiałem, który edytujesz, są automatycznie aktualizowane. Ponieważ każdy materiał ma kolor i opcjonalną teksturę, można niezależnie edytować kolor i teksturę.


Edycja materiału w programie SketchUp jest szczególnie przydatna, gdy jeden materiał jest stosowany do wielu powierzchni. Edycja materiału powoduje, że wszystkie powierzchnie pomalowane materiałem, który edytujesz, są aktualizowane automatycznie, co eliminuje konieczność zmiany każdej powierzchni. Ponieważ każdy materiał ma kolor i opcjonalną teksturę, można niezależnie edytować kolor i teksturę.

Uwaga: edycja materiałów jest dostępna w płatnych subskrypcjach aplikacji SketchUp for Web. Jest również dostępna dla użytkowników SketchUp for Schools.

Materiał należy zapisać wraz z modelem, zanim będzie można go edytować. Aby zobaczyć materiały zapisane z modelem, otwórz panel Materials (Materiały) na pasku narzędzi po prawej stronie ekranu.

Aby edytować materiał, wybierz go z materiałów w modelu (pod ikoną Strona główna) lub pobierz go z okna modelowania za pomocą narzędzia Eyedropper (Pipeta), które automatycznie wybierze materiał w panelu Materials (Materiały). Po wybraniu materiału kliknij ikonę Edit (Edytuj) obok miniatury materiału.

Podczas edycji materiałów można skonfigurować następujące elementy:

  • Nazwa materiału: wprowadź nową nazwę materiału, aby zmienić nazwę edytowanego materiału.
  • Kolor: można dostosować kolor materiału, wybierając go ręcznie z selektora kolorów programu SketchUp lub wprowadzając określone wartości RGB, HSL lub HEX. Podczas manipulowania zmianami kolorów zobaczysz, że zmiany są wprowadzane w czasie rzeczywistym.
  • Obraz: można dodać lub zmienić teksturę obrazu, aby skojarzyć ją z materiałem. Dodanie lub zmiana tekstur obrazu może nadpisać wybrany kolor materiału. Można także całkowicie usunąć teksturę obrazu z materiału, klikając „X”.
  • Rozmiar materiału: po zastosowaniu tekstury obrazu do powierzchni obraz tekstury jest układany kafelkami, aby wypełnić powierzchnię. Wpisz wartość w polu Width (Szerokość) lub Height (Wysokość), aby zmienić rozmiar kafelka tekstury. Domyślnie zachowane są proporcje obrazu. Tak więc jeśli wpiszesz 2 w polu wymiaru szerokości, pole wysokości zostanie automatycznie zaktualizowane, aby zachować proporcje. Kliknij ikonę łańcucha, aby przerwać łańcuch (przepraszamy, Fleetwood Mac). Możesz też zniekształcić współczynnik proporcji zgodnie z preferencjami. Jeśli nie spodobają Ci się wyniki (i już nigdy chcesz do nich wrócić), kliknij pozycję Cancel (Anuluj) u dołu menu lub cofnij zmiany, klikając CTRL/Command + Z.
  • Stopień krycia: można także edytować przezroczystość lub nieprzezroczystość materiału. Przesunięcie suwaka krycia w prawo zwiększa nieprzezroczystość, a w pozycji 100 materiał jest całkowicie nieprzezroczysty. Przesuń suwak w lewo, aby zwiększyć przezroczystość, a w pozycji 0 materiał jest całkowicie przezroczysty. Alternatywnie można wpisać liczbę od 0 do 100 w polu Opacity (Stopień krycia).

Uwaga: wszystkie zmiany w materiałach można odrzucić podczas edycji materiału, klikając przycisk „Cancel” (Anuluj) u dołu panelu Edit Materials (Edytuj materiały). Jeśli zaakceptujesz zmiany w edycjach materiału, możesz również użyć poleceń Undo (Cofnij) i Redo (Ponów), aby przeskakiwać między materiałami oryginalnymi i edytowanymi.

Windows

Materiał należy zapisać wraz z modelem, zanim będzie można go edytować. Aby zobaczyć materiały zapisane z modelem, otwórz panel Materials (Materiały) i kliknij ikonę In Model (W modelu) (), aby wyświetlić kolekcję In Model (W modelu), jak pokazano na poniższej ilustracji.

Jeśli materiał, który chcesz edytować, nie pojawia się w kolekcji In Model (W modelu), możesz zapisać materiał w swojej kolekcji In Model niezależnie od tego, czy materiał jest aktualnie zastosowany do powierzchni w modelu. Aby dodać materiał do swojej kolekcji In Model (W Modelu), wykonaj następujące kroki:

  1. Kliknij ikonę Display Secondary Selection Pane (Wyświetl dodatkowe okienko wyboru) () w prawym górnym rogu panelu Materials (Materiały).
  2. W dodatkowym okienku u dołu przejrzyj kolekcje w poszukiwaniu materiału, który chcesz edytować.
  3. Przeciągnij próbkę materiału do swojej kolekcji In Model (W modelu).

Aby edytować materiał, wybierz go z kolekcji In Model (W modelu) i kliknij kartę Edit (Edycja), jak pokazano na poniższej ilustracji.

Oto krótkie wprowadzenie do wszystkich narzędzi do edycji koloru materiału:

  • Lista rozwijana Color Picker (Selektor kolorów): użyj listy rozwijanej selektora kolorów, aby wybrać między selektorami HLS (Hue, Light, Saturation – Barwa, Światło, Nasycenie), HSB (Hue, Saturation i Brightness – Barwa, Nasycenie i Jasność), RGB (Red, Green, Blue – Czerwony, Zielony, Niebieski) i Color Wheel (Koło barw). Zobacz temat Mieszanie kolorów w selektorze kolorów, aby uzyskać szczegółowe informacje na temat działania selektora kolorów.
  • Próbnik Undo Color Changes (Cofnij zmiany koloru): kliknij ten próbnik, aby cofnąć wszystkie zmiany koloru wprowadzone podczas sesji edycji.
  • Przycisk Match Color of Object In Model (Dopasuj kolor obiektu w modelu): kliknij ten przycisk, aby zmienić kursor w pipetę. Kursorem pipety kliknij obiekt, aby pobrać próbkę koloru i zastosować ten kolor do edytowanego materiału.
    Wskazówka: jeśli jako próbkę pobierzesz materiał teksturowany, różnice w fakturze mogą nieco zamaskować kolor materiału. Aby uzyskać lepsze wyniki przy pobieraniu konkretnego koloru z tekstury, użyj przycisku Match Color on Screen (Dopasuj kolor na ekranie).
  • Przycisk Match Color on Screen (Dopasuj kolor na ekranie): kliknij ten przycisk, a następnie kliknij w dowolnym miejscu ekranu za pomocą kursora pipety, aby pobrać próbkę koloru piksela. Następnie program SketchUp zastosuje ten kolor do aktualnie wybranego materiału.

Następujące narzędzia umożliwiają modyfikacje tekstury materiału:

  • Pole wyboru Use Texture Image (Użyj obrazu tekstury): gdy to pole wyboru jest zaznaczone, można dołączyć plik obrazu, który reprezentuje teksturę. Cofnięcie zaznaczenia tego pola wyboru powoduje usunięcie pliku obrazu tekstury. (Należy pamiętać, że ponowne zaznaczenie tego pola wyboru nie przywraca pliku obrazu. Zamiast tego zostanie wyświetlona prośba o wybranie nowego pliku obrazu).
  • Plik obrazu tekstury i przycisk Browse (Przeglądaj): pole pliku tekstury zawiera nazwę pliku obrazu (reprezentującego teksturę), jeśli istnieje, skojarzonego z bieżącym materiałem. Aby zmienić teksturę, przeciągnij plik obrazu do tego pola lub kliknij przycisk Browse (Przeglądaj), aby wyświetlić okno dialogowe Choose Image (Wybierz obraz), w którym można wyszukać plik obrazu na dysku twardym. Po zastosowaniu tekstury można również dostosować sposób ułożenia tekstur na modelu. Szczegółowe informacje można znaleźć w kolejnym punkcie: Zmiana położenia tekstur.
  • Przycisk Edit Texture Image in External Editor (Edytuj obraz tekstury w edytorze zewnętrznym): po kliknięciu tego przycisku program SketchUp otworzy plik obrazu tekstury w domyślnym edytorze obrazów.
    Uwaga: Twój edytor obrazów jest zdefiniowany w oknie dialogowym Preferences (Preferencje) programu SketchUp na panelu Applications (Aplikacje). Aby uzyskać szczegółowe informacje na temat ustawiania tej preferencji, zobacz punkt Dostosowywanie obszaru roboczego. Jeśli edytor obrazów nie został zdefiniowany przez użytkownika, program SketchUp uruchomi domyślny edytor lub aplikację do wyświetlania obrazów w systemie operacyjnym.
  • Pole wyboru Colorize (Koloruj): zaznacz to pole wyboru, aby zastosować ten sam odcień do całej tekstury. Kolor jest definiowany w obszarze Color (Kolor) na karcie Edit (Edycja). Ta opcja jest przydatna w przypadku plików, w których nie są wyświetlane odpowiednie kolory.
  • Reset Color swatch (Resetuj próbkę koloru): kliknij tę próbkę koloru, aby zresetować materiał do koloru z pliku obrazu tekstury.
  • Pola wymiarów: podczas malowania tekstury na powierzchni obraz tekstury jest układany kafelkami, aby wypełnić powierzchnię. Wpisz wartość w polu szerokości lub wysokości, aby zmienić rozmiar kafelka tekstury. Domyślnie zachowane są proporcje obrazu. Tak więc jeśli wpiszesz 2 w polu wymiaru szerokości, pole wysokości zostanie automatycznie zaktualizowane, aby zachować proporcje. Kliknij ikonę łańcucha, aby przerwać łańcuch (przepraszamy, Fleetwood Mac). Możesz też zniekształcić współczynnik proporcji. Jeśli nie spodobają Ci się wyniki (i już nigdy chcesz do nich wrócić), kliknij przyciski strzałek w poziomie i w pionie, aby powrócić do poprzednich ustawień szerokości i wysokości.
  • Suwak stopnia krycia: krycie odnosi się do stopnia przezroczystości lub nieprzezroczystości obrazu. Przesunięcie suwaka krycia w prawo zwiększa nieprzezroczystość tekstury, a w pozycji 100 tekstura jest całkowicie nieprzezroczysta. Przesuń suwak w lewo, aby zwiększyć przezroczystość tekstury, a w pozycji 0 tekstura jest całkowicie przezroczysta. Alternatywnie można wpisać liczbę od 0 do 100 w polu Opacity (Stopień krycia).

MacOS

Materiał należy zapisać wraz z modelem, zanim będzie można go edytować. Aby zobaczyć materiały zapisane z modelem, wybierz Window (Okno) > Materials (Materiały), co spowoduje otwarcie panelu Colors (Kolory). Na karcie Texture Palettes (Palety tekstur) (ikona cegły) kliknij ikonę Colors In Model (Kolory w modelu) () lub wybierz opcję Colors In Model (Kolory w modelu) z listy rozwijanej, aby wyświetlić kolekcję kolorów w modelu, jak pokazano na poniższej ilustracji.

Jeśli materiał, który chcesz edytować, nie pojawia się w kolekcji Colors In Model (Kolory w modelu), zastosuj materiał do powierzchni w modelu. (Pamiętaj, że jeśli później wymienisz jeden materiał na inny, oryginalny materiał pozostanie w kolekcji Colors In Model (Kolory w modelu), dopóki nie usuniesz nieużywanych materiałów).

Aby przystąpić do edycji materiału, wykonaj następujące kroki:

  1. Na karcie Textures Palette (Paleta tekstur) (ikona cegły) otwórz swoją kolekcję Colors In Model (Kolory w modelu).
  2. Wybierz materiał, który chcesz edytować.
  3. Z listy rozwijanej Color (Kolor) wybierz polecenie Edit (Edytuj). Alternatywnie można kliknąć materiał z wciśniętym klawiszem Control i wybrać polecenie Edit (Edytuj) z menu, które się pojawi.
  4. Wybierz żądane zmiany na wyświetlonym panelu Edit Material (Edytuj materiał), jak pokazano na ilustracji.
  5. Po zakończeniu kliknij przycisk Close (Zamknij).

Oto wprowadzenie do opcji dostępnych w panelu Edit Material (Edytuj materiał):

  • Name (Nazwa): wprowadź nową nazwę materiału, aby zmienić nazwę edytowanego materiału.
  • Przycisk Edit Texture Image in External Editor (Edytuj obraz tekstury w edytorze zewnętrznym): po kliknięciu tego przycisku plik obrazu tekstury zostanie otwarty w domyślnym edytorze obrazów lub w programie do podglądu. Wprowadź zmiany w pliku i zapisz je, a zmiany zostaną odzwierciedlone w materiale.
  • Menu rozwijane Texture (Tekstura): opcje w tym menu rozwijanym umożliwiają edycję tekstury w programie SketchUp. Wybierz opcję Load (Załaduj) i zaznacz nowy plik obrazu dla tekstury. Wybierz opcję Remove (Usuń), aby usunąć plik obrazu tekstury. (Po usunięciu obrazu tekstury pojawia się jednolite przybliżenie koloru usuniętego obrazu). Jeśli tekstura została pokolorowana, wybierz opcję Reset Color (Resetuj kolor), aby usunąć koloryzację. Wybranie opcji Edit (Edytuj) otwiera plik obrazu tekstury w domyślnym edytorze obrazów lub w programie do podglądu. Po zastosowaniu tekstury można również dostosować sposób ułożenia tekstur na modelu. Szczegółowe informacje można znaleźć w kolejnym punkcie: Zmiana położenia tekstur.
  • Width (Szerokość) i Height (Wysokość): podczas malowania tekstury na powierzchni obraz tekstury jest układany kafelkami, aby wypełnić powierzchnię. Wpisz wartość w polu Width (Szerokość) lub Height (Wysokość), aby zmienić rozmiar kafelka tekstury. Domyślnie zachowane są proporcje obrazu. Tak więc jeśli wpiszesz 2 w polu wymiaru szerokości, pole wysokości zostanie automatycznie zaktualizowane, aby zachować proporcje. Kliknij ikonę łańcucha, aby przerwać łańcuch (przepraszamy, Fleetwood Mac). Możesz też zniekształcić współczynnik proporcji zgodnie z preferencjami. Jeśli nie spodobają Ci się wyniki (i już nigdy chcesz do nich wrócić), musisz zapamiętać oryginalne wymiary i wprowadzić je ręcznie, aby powrócić do oryginalnych wymiarów obrazu.
  • Colorize (Koloruj): gdy panel Edytuj materiał jest otwarty, możesz pokolorować plik tekstury. Użyj dowolnej karty kolorów, aby wybrać kolor i zastosować go do podglądu materiału w panelu Edytuj materiał. Można też kliknąć narzędzie Eyedropper (Pipeta) u dołu panelu Colors (Kolory) i kliknąć dowolny materiał w modelu lub na karcie Textures Palettes (Palety tekstur) z ikoną cegły.
    Wskazówka: kolorowanie to świetny sposób na eksperymentowanie z różnicami w kolorze materiału.
  • Opacity (Stopień krycia): gdy panel Edit Material (Edytuj materiał) jest otwarty, można również edytować krycie materiału, które odnosi się do przezroczystości lub nieprzezroczystości obrazu. Przesunięcie suwaka krycia w prawo zwiększa nieprzezroczystość tekstury, a w pozycji 100 tekstura jest całkowicie nieprzezroczysta. Przesuń suwak w lewo, aby zwiększyć przezroczystość tekstury, a w pozycji 0 tekstura jest całkowicie przezroczysta. Alternatywnie można wpisać liczbę od 0 do 100 w polu Opacity (Stopień krycia).

Zmiana położenia tekstur

Po zastosowaniu tekstury do jednej lub wielu powierzchni w modelu 3D można dostosować sposób rozmieszczania tekstur na powierzchni. Aby to zrobić, użyj narzędzia Position Texture (Ustaw teksturę), które ma dwa tryby:

  • Tryb Fixed Pin (Stała pinezka): w tym trybie można przesuwać, obracać, skalować lub zniekształcać teksturę. Na przykład w tym trybie można dostosować teksturę na jednej powierzchni w taki sposób, aby wyrównała się z tą samą teksturą na innej powierzchni, na przykład oblicówka na dwóch ścianach budynku.
  • Tryb Free Pin (Swobodna pinezka): użyj go, jeśli chcesz rozciągnąć lub zmniejszyć teksturę.

Oto jak dostosować teksturę w trybie Stałej pinezki:

  1. Kliknij materiał prawym przyciskiem myszy i wybierz opcję Texture (Tekstura) > Position (Położenie) z wyświetlonego menu. Zobaczysz matrycę z przerywanych linii, które reprezentują poszczególne kafelki tekstury. Kursor również zmieni się w dłoń i zostaną wyświetlone cztery pinezki.
  2. Jeśli zobaczysz cztery kolorowe pinezki, jak pokazano na poniższej ilustracji, przejdź do następnego kroku. Jeśli nie, kliknij materiał prawym przyciskiem myszy i wybierz opcję Fixed Pins (Stałe pinezki).
  3. Użyj kursora dłoni i/lub pinezek, aby dostosować teksturę. W tym przykładzie celem jest przesunięcie zielonej pinezki w taki sposób, aby kierunek drewna na górze szafki był zgodny z bokiem. Oto krótki przegląd wszystkich dostępnych opcji:
    • Kliknij i przeciągnij materiał za pomocą kursora dłoni, aby zmienić położenie tekstury jako całości.
    • Kliknij pinezkę, aby ją podnieść, i kliknij ponownie, aby upuścić pinezkę w innym miejscu tekstury.
    • Przeciągnij pinezkę, aby zmienić teksturę. Przeciągnięcie niebieskiej pinezki powoduje skalowanie lub ścinanie tekstury. Przeciągnięcie żółtej pinezki zniekształca teksturę. Przeciągnięcie zielonej pinezki skaluje teksturę lub obraca ją wokół osi pinezki do przesuwania. Przeciągnięcie czerwonej pinezki przesuwa teksturę.
    Wskazówka: w trybie Fixed Pin (Stała pinezka) można również kliknąć prawym klawiszem teksturę, aby wyświetlić dodatkowe opcje: odwróć teksturę w lewo lub w prawo lub w górę lub w dół, obracaj teksturę o 90 stopni. Opcja resetowania przywraca teksturę do pierwotnego stanu, podczas gdy opcja Undo (Cofnij) po prostu cofa ostatnie polecenie. Jeśli cofniesz czynność, pojawi się opcja Redo (Ponów).
  4. Po zakończeniu edycji tekstury kliknij teksturę prawym przyciskiem myszy i wybierz opcję Done (Gotowe). Można też kliknąć obszar poza teksturą, aby wyjść z trybu Fixed Pin (Stała pinezka).

W trybie Free Pin (Swobodna pinezka) można ustawić rozmiar kafelka tekstury w stosunku do modelu. Ten proces działa w następujący sposób:

  1. Kliknij materiał prawym przyciskiem myszy i wybierz opcję Texture (Tekstura) > Position (Położenie) z wyświetlonego menu. Domyślne ustawienie to tryb Stała pinezka.
  2. Przełącz się do trybu Free Pin (Swobodna pinezka), klikając teksturę prawym przyciskiem myszy i usuwając zaznaczenie opcji Fixed Pins (Stałe pinezki). W trybie Free Pin (Swobodna pinezka) widoczne są cztery białe pinezki, jak pokazano na poniższej ilustracji.
  3. Kliknij pinezkę, aby ją podnieść, i kliknij ponownie, aby umieścić ją w innym miejscu. Zrób to ze wszystkimi czterema pinezkami, aby ustawić położenie narożników płytki tekstury. Jeśli umieścisz pinezki w konfiguracji, która nie jest prostokątna, zniekształcisz teksturę.
  4. Po zakończeniu edycji kliknij teksturę prawym przyciskiem myszy i wybierz opcję Done (Gotowe). Można też kliknąć obszar poza teksturą, aby wyjść z trybu free Pin (Swobodna pinezka).
Wskazówka: w trybie Free Pin (Swobodna pinezka) rozmiar kafelka tekstury jest widoczny tylko na wybranej powierzchni. Aby zmienić rozmiar kafelka tekstury w całym modelu, użyj panelu Materials (Materiały) [Microsoft Windows] lub panelu Colors (Kolory) [macOS]. Aby uzyskać szczegółowe informacje, zobacz poprzedni punkt: Edycja materiałów.

Automatyczne obliczanie powierzchni materiału

Jeśli chcesz, aby program SketchUp obliczył powierzchnię pomalowaną materiałem, można kliknąć materiał prawym przyciskiem myszy i wybrać Area (Obszar) > Material (Materiał). W systemie Windows można również kliknąć materiał prawym przyciskiem myszy w panelu Materials (Materiały) i wybrać z menu opcję Area (Obszar). (Jeśli element menu Area (Obszar) jest szary, materiał nie jest stosowany do żadnych powierzchni).

Niezależnie od wyboru okno dialogowe Area (Obszar) pokazuje całkowitą powierzchnię ścian, do których zastosowano wybrany materiał. Jednostki (takie jak stopy kwadratowe czy metry kwadratowe) zależą od jednostek określonych w szablonie. Aby uzyskać szczegółowe informacje na temat zmiany domyślnych jednostek, zobacz punkt Konfigurowanie szablonów.

Jeśli używasz klasyfikacji IFC, można wygenerować raport dotyczący materiałów w całym modelu. Szczegółowe informacje na ten temat można znaleźć w punkcie Klasyfikowanie obiektów (a konkretnie w części dotyczącej generowania raportu).

Organizowanie materiałów i zarządzanie nimi

Panel Materials (Materiały) w systemie Microsoft Windows lub Colors (Kolory) w systemie macOS pomaga znaleźć i uporządkować materiały. Poniższa lista wyjaśnia, jak zarządzać materiałami w systemie operacyjnym wybranym w Centrum pomocy.

Windows

  • Przeglądanie dołączonych kolekcji: na karcie Select (Zaznacz) wybierz kolekcję z listy rozwijanej, aby wyświetlić materiały.
  • Śledzenie materiałów w modelu: kliknij ikonę In Model (W modelu) (), aby zobaczyć wszystkie materiały zastosowane w modelu.
  • Usuwanie niepotrzebnych materiałów: nawet jeśli zastąpisz materiał innym w taki sposób, że oryginalny materiał nie będzie już pojawiać się w modelu, oryginalny materiał pozostanie dalej w kolekcji In Model (W modelu), dopóki go nie usuniesz, klikając prawym przyciskiem myszy i wybierając opcję Delete (Usuń). Aby usunąć wszystkie nieużywane materiały w swoim modelu, upewnij się, że wybrano kolekcję In Model (W modelu). Następnie kliknij strzałkę Details (Szczegóły) () i wybierz opcję Purge Unused (Wyczyść nieużywane). Alternatywnie można wybrać opcję Delete All (Usuń wszystko), aby usunąć wszystkie materiały z modelu i z kolekcji In Model (W modelu).
  • Tworzenie własnych kolekcji: można utworzyć kolekcję dla konkretnego projektu lub kolekcję tworzonych przez siebie materiałów, na przykład określonego schematu kolorów, próbek tkanin, opcji kształtowania krajobrazu lub dowolnych innych często używanych elementów. Na karcie Select (Zaznacz) kliknij strzałkę Details (Szczegóły) () i wybierz opcję Open or Create a Collection (Otwórz lub utwórz kolekcję). W oknie dialogowym Select a collection folder or create a new one (Wybierz folder kolekcji lub utwórz nowy) przejdź do folderu, w którym chcesz zapisać swoją kolekcję. Kliknij przycisk New Folder (Nowy folder), nadaj folderowi nazwę (która stanie się nazwą Twojej kolekcji) i kliknij Select Folder (Wybierz folder). Po utworzeniu kolekcji możesz przejść do folderu, aby otworzyć kolekcję. Aby dodać materiały do kolekcji, przeciągnij je z dodatkowego okienka wyboru do swojej kolekcji lub zapisz utworzone materiały w swojej kolekcji.
  • Dodawanie często używanych kolekcji do ulubionych: na karcie Select (Zaznacz) kliknij strzałkę Details (Szczegóły) i wybierz opcję Add Collection to Favorites (Dodaj kolekcję do ulubionych). Aktualnie wybrana kolekcja pojawi się na liście ulubionych u dołu listy rozwijanej. Jeśli chcesz usunąć jakąś kolekcję z listy ulubionych, kliknij strzałkę Details (Szczegóły) i wybierz opcję Remove Collection from Favorites (Usuń kolekcję z ulubionych).
    Uwaga: kliknij strzałkę Details (Szczegóły), aby wyświetlać materiały jako małe, średnie, duże lub bardzo duże kafelki. Wybierz opcję List (Lista), aby zobaczyć nazwy materiałów zamiast podglądu próbek.

MacOS

  • Przeglądanie dołączonych kolekcji: aby zobaczyć materiały dołączone do programu SketchUp, kliknij ikonę cegły Texture Palettes (Palety tekstur) i wybierz jedną z kolekcji w menu rozwijanym, na przykład Brick and Cladding (Cegła i okładziny), Fencing (Ogrodzenia), Roofing (Pokrycia dachowe), Translucent (Prześwitujący) lub Wood (Drewno). Każdy materiał w kolekcji jest wyświetlany jako próbka, którą można kliknąć kursorem Paint Bucket (Wiadro z farbą) i zastosować do modelu.
  • Śledzenie materiałów w modelu: panel Colors (Kolory) zawiera specjalną kolekcję materiałów o nazwie Colors In Model (Kolory w modelu), która zawiera wszystkie materiały aktualnie używane w modelu. Zawartość tej kolekcji jest generowana automatycznie podczas dodawania materiałów do modelu w programie SketchUp. Aby zobaczyć tę kolekcję, wybierz Colors In Model (Kolory w modelu) z menu rozwijanego kolekcji materiałów lub po prostu kliknij ikonę Colors In Model (Kolory w modelu) ().
  • Usuwanie niepotrzebnych materiałów: nawet jeśli zastąpisz materiał innym w taki sposób, że oryginalny materiał nie będzie już pojawiać się w modelu, oryginalny materiał pozostanie dalej w kolekcji Colors In Model (Kolory w modelu), dopóki go nie usuniesz, klikając prawym przyciskiem myszy i wybierając opcję Remove (Usuń). Aby usunąć wszystkie nieużywane materiały w swoim modelu, upewnij się, że wybrano kolekcję Colors In Model (Kolory w modelu). Następnie wybierz opcję List (Lista) > Purge Unused (Wyczyść nieużywane). Alternatywnie można wybrać opcję Delete All (Usuń wszystko), aby usunąć wszystkie materiały z modelu i z kolekcji Colors In Model (Kolory w modelu).
  • Tworzenie własnych kolekcji: można utworzyć kolekcję dla konkretnego projektu lub kolekcję tworzonych przez siebie materiałów, na przykład określonego schematu kolorów, próbek tkanin, opcji kształtowania krajobrazu lub dowolnych innych często używanych elementów. Wybierz opcję List (Lista) > New (Nowa). W wyświetlonym polu List Name (Nazwa listy) wpisz nazwę i kliknij przycisk OK. Wpisana nazwa pojawi się teraz na liście rozwijanej kolekcji.
    Aby dodać materiały do nowej kolekcji, można przeciągnąć próbkę obok pipety u dołu panelu Colors (Kolory) do panelu próbek nowej kolekcji. Można też tworzyć nowe tekstury i zapisywać je w kolekcji. Aby usunąć kolekcję, wybierz opcję List (Lista) > Remove (Usuń).
Uwaga: jeśli często korzystasz z panelu Materials (Materiały) w systemie Windows, pamiętaj, że panel Colors (Kolory) w systemie macOS nie umożliwia dodawania często używanych kolekcji do listy ulubionych.

Tworzenie własnych materiałów

Materiały zawarte w programie SketchUp pomagają w rozpoczęciu korzystania z materiałów i poznaniu ich działania. Aby zastosować materiały specyficzne dla własnego projektu lub budynku, prawdopodobnie musisz stworzyć własne materiały. Jest to dość proste zadanie: zacznij od obrazu, aby utworzyć kafelek tekstury, a następnie określ kolor, jeśli to konieczne.

Windows

Aby utworzyć nowy materiał z własnych plików lub kodów kolorów, wykonaj następujące kroki:

  1. W panelu Materials (Materiały) kliknij ikonę Create Material (Utwórz materiał) () w prawym górnym rogu.
  2. W oknie dialogowym Create Material (Utwórz materiał) wpisz nazwę nowego materiału w polu tekstowym u góry.
  3. Wybierz kolor, teksturę i stopień krycia dla nowego materiału. Opcje działają tak samo jak te w panelu Edit (Edycja). Aby uzyskać szczegółowe informacje, zobacz poprzedni punkt: Edycja materiałów. Aby lepiej zrozumieć opcje dotyczące kolorów, zobacz też Mieszanie kolorów w selektorze kolorów.
  4. Kliknij przycisk OK. Nowy materiał pojawi się po wybraniu kolekcji In Model (W modelu).

MacOS

Aby utworzyć nowy materiał, który jest teksturą, wykonaj następujące kroki:

  1. W panelu Colors (Kolory) kliknij kartę z ikoną cegły Textures Palette (Paleta tekstur).
  2. Wybierz kolekcję, w której chcesz umieścić nowy materiał.
  3. Wybierz opcję Color (Kolor) > New Texture (Nowa tekstura).
  4. W oknie dialogowym, które zostanie wyświetlone, wybierz plik obrazu dla tekstury.
  5. W panelu, który zostanie wyświetlony, wpisz nazwę tekstury, ustaw szerokość i wysokość rozmiaru kafelka, a następnie kliknij przycisk OK. Jeśli chcesz pokolorować teksturę, wykonaj czynności opisane we wcześniejszym punkcie Edycja materiałów.

Oto jak zapisać określony kolor jako materiał:

  1. Użyj dowolnej karty kolorów, aby utworzyć żądany kolor, który pojawi się na próbce koloru u dołu panelu Colors (Kolory). Zobacz temat Mieszanie kolorów w selektorze kolorów, aby uzyskać szczegółowe informacje.
  2. Wybierz kartę Textures Palette (Paleta tekstur), znaną również jako ikona cegły.
  3. Przejdź do kolekcji, w której chcesz zapisać kolor.
  4. Przeciągnij próbkę koloru z dołu panelu Colors (Kolory) do obszaru próbek kolekcji.
Wskazówka: można również rozszerzyć swoje kolekcje materiałów, pobierając materiały. Aby uzyskać szczegółowe informacje, przeczytaj ten wpis na blogu SketchUpdate.