Dodawanie rozszerzeń do programu SketchUp

Witryna internetowa Extension Warehouse i program SketchUp zostały stworzone do współpracy z sobą. W większości przypadków w celu dodania rozszerzenia do lokalnej kopii programu SketchUp wystarczy kliknąć przycisk Install (Instaluj) na stronie szczegółów rozszerzenia i poczekać chwilę, aż oprogramowanie wykona resztę pracy.

Jednak ten magiczny proces instalacji wiąże się z kilkoma zastrzeżeniami:

  • Dostęp do witryny internetowej Extension Warehouse musi nastąpić z programu SketchUp (a nie z przeglądarki). Po zalogowaniu do witryny Extension Warehouse z przeglądarki internetowej pojawi się przycisk pobierania zamiast przycisku instalacji. Po pobraniu rozszerzenia trzeba ręcznie zainstalować plik .rbz w programie SketchUp za pośrednictwem opcji Preferences (Preferencje).

    Wskazówka: instalowanie rozszerzeń i zarządzanie nimi jest najłatwiejsze, jeśli uzyskasz dostęp witryny Extension Warehouse z programu SketchUp, wybierając polecenie Window (Okno) > Extension Warehouse.

  • Rozszerzenie jest darmowe. Wiele rozszerzeń w witrynie Extension Warehouse można pobrać i wykorzystywać bezpłatnie. Programiści mają również możliwość sprzedaży rozszerzeń za jednorazową opłatą lub po wykupieniu subskrypcji. Jeśli rozszerzenie jest dostępne do kupienia, zamiast przycisku Install (Instaluj) zostanie wyświetlony przycisk Purchase (Kup), a czasami przycisk Install Trial (Zainstaluj wersję próbną), jak pokazano na poniższej ilustracji. Z wersji próbnej można korzystać bezpłatnie przez ograniczony czas. W niektórych przypadkach rozszerzenie jest dostępne do kupienia, ale trzeba je zakupić w witrynie internetowej programisty i zainstalować je ręcznie.
Jeśli rozszerzenie SketchUp jest dostępne do kupienia, w witrynie Extension Warehouse zostanie wyświetlony przycisk Purchase (Kup), a czasami przycisk Install Trial (Zainstaluj wersję próbną).

Uwaga: jeśli nie znasz funkcji na stronie szczegółów rozszerzenia, zapoznaj się z wprowadzeniem w interfejsie witryny internetowej Extension Warehouse w sekcji Pierwsze kroki. Jeśli nie wiesz, jak odinstalować lub zaktualizować rozszerzenia bądź zarządzać nimi w inny sposób, zobacz sekcję Zarządzanie rozszerzeniami.

W poniższych sekcjach wyjaśniono, co należy wiedzieć o ręcznym instalowaniu rozszerzeń, kupowaniu ich oraz korzystaniu z nich po instalacji.

Ręczne instalowanie rozszerzeń w preferencjach programu SketchUp

Jeśli rozszerzenie zostało pobrane z witryny Extension Warehouse za pośrednictwem przeglądarki internetowej lub ze strony internetowej dewelopera, ma formę archiwum .rbz, które można zainstalować ręcznie. Oto kroki, które należy wykonać:

  1. W programie SketchUp wybierz polecenie Window (Okno) > Preferences (Preferencje) w systemie Microsoft Windows lub SketchUp > Preferences (Preferencje) w systemie Mac OS X.
  2. W wyświetlonym oknie dialogowym wybierz pozycję Extensions (Rozszerzenia) na pasku bocznym po lewej stronie.
  3. W okienku Rozszerzenia kliknij przycisk Install Extension (Zainstaluj rozszerzenie).
  4. W wyświetlonym oknie dialogowym Open (Otwórz) przejdź do pliku .rbz, który został zapisany na komputerze, wybierz ten plik i kliknij przycisk OK w systemie Microsoft Windows lub Open (Otwórz) w systemie Mac OS X.
  5. Gdy program SketchUp ostrzega przed instalowaniem rozszerzeń tylko z zaufanych źródeł, kliknij przycisk Yes (Tak), aby kontynuować i zainstalować rozszerzenie. (Zakłada się, że masz zaufanie do tego źródła rozszerzenia).
  1. W programie SketchUp wybierz opcję Window (Okno) > Extension Manager (Menedżer rozszerzeń). Zostanie wyświetlone okno Extension Manager.
  2. Kliknij przycisk Install Extension (Zainstaluj rozszerzenie).
  3. W wyświetlonym oknie dialogowym Open (Otwórz) przejdź do pliku .rbz, który został zapisany na komputerze, wybierz ten plik i kliknij przycisk OK w systemie Microsoft Windows lub Open (Otwórz) w systemie Mac OS X.
  4. Gdy program SketchUp ostrzega przed instalowaniem rozszerzeń tylko z zaufanych źródeł, kliknij przycisk Yes (Tak), aby kontynuować i zainstalować rozszerzenie. (Zakłada się, że masz zaufanie do tego źródła rozszerzenia).

Korzystanie z wersji próbnych lub zakup rozszerzeń w witrynie Extension Warehouse

Niezależnie od tego, czy zalogowanie do witryny Extension Warehouse nastąpiło w przeglądarce czy programie SketchUp, można kupić rozszerzenie. Aby jednak zainstalować wersję próbną lub zakupione rozszerzenie, trzeba zalogować się do witryny Extension Warehouse w programie SketchUp.

Aby dokonać zakupu, wykonaj następujące kroki:

  1. Na stronie szczegółów rozszerzenia kliknij przycisk Purchase (Kup). (Jeśli możliwe jest pobranie wersji próbnej przed zakupem, zostanie wyświetlone łącze Install Trial (Zainstaluj wersję próbną) z programu SketchUp. Aby zainstalować wersję próbną, zapoznaj się z kolejnymi krokami instalacji wersji próbnej lub zakupionej).
  2. Po wyświetleniu monitu wprowadź informacje dotyczące rozliczeń i płatności. Informacje rozliczeniowe są wymagane do zweryfikowania karty kredytowej. Potwierdzenie zostanie wysłane na adres e-mail, którego używasz do logowania się w Extension Warehouse. Jeśli nie otrzymasz wiadomości e-mail z potwierdzeniem wkrótce po dokonaniu zakupu, sprawdź folder ze spamem.

Wskazówka: po zakupie rozszerzenia Extension Warehouse nie oferuje zwrotów kosztów. Jeśli chcesz wypróbować rozszerzenie przed zakupem, poszukaj przycisku Install Trial (Zainstaluj wersję próbną), który umożliwia wypróbowanie działania rozszerzenia przed jego zakupem. Jeśli masz problem z zakupem rozszerzenia lub chcesz skontaktować się z nami w sprawie zakupu w witrynie Extension Warehouse, wypełnij nasz formularz kontaktowy obsługi klienta i z listy rozwijanej You Would Like To (Co chcesz zrobić?) wybierz opcję Resolve a Purchasing Issue (Rozwiąż problem z zakupem).

Aby zainstalować wersję próbną lub zakupione rozszerzenie, wykonaj następujące kroki:

  1. W programie SketchUp wybierz opcję Window (Okno) > Extension Warehouse i zaloguj się do witryny Extension Warehouse.
  2. Aby zainstalować wersję próbną, wyszukaj rozszerzenie, które chcesz wypróbować, i na stronie szczegółów rozszerzenia kliknij opcję Install Trial (Zainstaluj wersję próbną). Jeśli rozszerzenie zostało już zakupione, przejdź do kroku 3.
  3. Z menu użytkownika wybierz opcję My Extensions (Moje rozszerzenia).
  4. Na karcie My Extensions (Moje rozszerzenia) przewiń w dół do wersji próbnej rozszerzenia lub do zakupionej wersji rozszerzenia, które chcesz zainstalować, i kliknij łącze Install Trial (Zainstaluj wersję próbną) lub Install (Zainstaluj). Na poniższej ilustracji widać łącze Install Trial (Zainstaluj wersję próbną).
  5. Gdy program SketchUp zapyta, czy ufasz autorowi i chcesz kontynuować instalację rozszerzenia, musisz kliknąć przycisk Yes (Tak), aby kontynuować. Po chwili pojawi się okno dialogowe z potwierdzeniem, że rozszerzenie zostało zainstalowane.
Po zakupie rozszerzenia lub pobraniu wersji próbnej można zainstalować je na karcie My Extensions (Moje rozszerzenia) w Extension Warehouse.

Znajdowanie i używanie rozszerzenia po instalacji

Jak używać rozszerzenia w programie SketchUp po instalacji?

Czasami rozszerzenie pojawia się w menu Extensions (Rozszerzenia), jak pokazano na poniższej ilustracji. Wystarczy wybrać rozszerzenie z menu, aby zacząć go używać. Rozszerzenie może również dodać pasek narzędzi do korzystania z funkcji rozszerzenia, takich jak pasek narzędzi Curve Maker (Narzędzie do krzywych) pokazany na ilustracji. Czasami rozszerzenie może się znaleźć się w menu Draw (Rysuj), menu Tools (Narzędzia) lub menu kontekstowym.

Wskazówka: szczegółowe informacje na temat korzystania z rozszerzenia znajdują się w dokumentacji, którą można znaleźć na stronie ze szczegółowymi informacjami o rozszerzeniu lub za pośrednictwem tej strony. Na przykład strona szczegółów rozszerzenia może zawierać film, instrukcje lub łącza do dodatkowej dokumentacji na temat działania rozszerzenia. Jeśli masz pytanie, zapoznaj się z opiniami innych użytkowników (również na stronie ze szczegółami rozszerzenia) lub sprawdź, czy autor udostępnia informacje kontaktowe za pośrednictwem strony szczegółów, swojego profilu lub witryny internetowej.

Aby rozpocząć korzystanie z rozszerzenia programu SketchUp, wybierz je z menu Extensions (Rozszerzenia).