Pomiar kątów i odległości w celu precyzyjnego modelowania

Co odróżnia konstrukcję i projekt bryły od złudzenia optycznego M.C. Eschera? Dokładne wymiary.

W programie SketchUp narzędzia Tape Measure (Miarka) i Protractor (Kątomierz) oraz pole Measurements (Wymiary) umożliwiają precyzyjne modelowanie:

  • Za pomocą narzędzia Tape Measure (Miarka) () można zmierzyć odległość i ustawić precyzyjne linie pomocnicze lub punkty prowadzące.

    Uwaga: linie pomocnicze i punkty prowadzące to tymczasowe linie przerywane używane jako prowadnice do precyzyjnego rysowania. Nie kolidują one z regularną geometrią.
  • Narzędzie Protractor (Kątomierz) () umożliwia mierzenie kątów i ustawianie precyzyjnej linii pomocniczej pod kątem.
  • Podczas korzystania z prawie każdego narzędzia w programie SketchUp w polu Measurements (Wymiary) można wpisać dokładny wymiar.

Oprócz tych narzędzi można również wykorzystać wskazówki zawarte w tym artykule z odrobiną matematyki, aby dokładnie oszacować wysokość budynku.

Pomiar odległości

Za pomocą narzędzia Tape Measure (Miarka) można mierzyć odległość, tworzyć prowadnice lub wyświetlać współrzędne wzdłuż osi. Oto miejsca, w których można skorzystać z narzędzia Tape Measure (Miarka) w programie SketchUp:

  • Pasek narzędzi Getting Started (Pierwsze kroki)
  • Pasek narzędzi Construction (Konstrukcja)
  • Pasek narzędzi Large Tool Set (Duży zestaw narzędzi)
  • Menu Tools (Narzędzia) na pasku menu
  • Paleta narzędzi (macOS)

Wskazówka: po wybraniu narzędzia Tape Measure (Miarka) można błyskawicznie sprawdzić długość linii lub wielkość powierzchni. Umieść kursor narzędzia Tape Measure (Miarka) na linii lub powierzchni, a zobaczysz długość linii lub wielkość powierzchni w polu Measurements (Wymiary).

Aby zmierzyć geometrię lub ustawić linię pomocniczą, wykonaj następujące kroki:

Uwaga: dobra zasada do zapamiętania – za pomocą punktów końcowych można tworzyć punkty prowadzące, a linie pomocnicze – za pomocą punktów środkowych linii lub powierzchni.
  1. Wybierz narzędzie Tape Measure (Miarka) () lub naciśnij klawisz T.
    Uwaga: domyślnym ustawieniem narzędzia Tape Measure (Miarka) jest tworzenie linii pomocniczych i punktów prowadzących podczas pomiaru. Znak plus pojawia się obok kursora narzędzia Tape Measure (Miarka) w trybie tworzenia prowadnic (). Jeśli chcesz po prostu zmierzyć odległość między dwoma punktami bez tworzenia linii pomocniczej, możesz nacisnąć Ctrl (Microsoft Windows) lub Option (macOS). W tym trybie znika znak plus obok narzędzia Miarka. Ten tryb zostanie utrzymany do momentu zmiany narzędzi.
  2. Kliknij punkt początkowy pomiaru. Jeśli chcesz wybrać punkt końcowy lub punkt środkowy, mechanizm wnioskowania programu SketchUp pomoże Ci je znaleźć. Aby utworzyć linię pomocniczą, kliknij linię, która musi być równoległa do linii pomocniczej.
  3. Przesuń kursor w kierunku, w którym chcesz wykonać pomiar. Gdy poruszasz myszą, od punktu początkowego rozciąga się tymczasowa linia miarki ze strzałkami na każdym końcu, jak pokazano na ilustracji.

    Wskazówka: oto kilka ważnych informacji, które pomogą przesuwać kursor narzędzia Tape Measure (Miarka) w przestrzeni 3D:
    • Linia miarki zmienia kolor, aby dopasować się do koloru osi, gdy jest do niej równoległa. Na ilustracji miarka jest wyrównana do osi czerwonej.
    • Naciśnij i przytrzymaj klawisz kierunkowy podczas pomiaru, aby zablokować oś. Klawisz strzałki w górę blokuje oś niebieską, strzałki w lewo – oś zieloną, a strzałki w prawo – oś czerwoną.
    • W polu Measurements (Wymiary) długość miarki jest wyświetlana dynamicznie.
  4. Naciśnij klawisz Esc, aby zacząć od nowa.
  5. (Opcjonalnie) Aby utworzyć linię pomocniczą, naciśnij klawisz Ctrl (Microsoft Windows) lub Option (macOS). Znak plus pojawia się obok kursora narzędzia Tape Measure (Miarka) ().
  6. Kliknij punkt końcowy pomiaru. Odległość od punktu początkowego pojawi się w polu. Jeśli w poprzednim kroku naciśnięto klawisz Ctrl, linia pomocnicza pojawi się jako linia przerywana sięgająca do nieskończonej przestrzeni 3D (przynajmniej w obrębie modelu). Na poniższej ilustracji linie pomocnicze oznaczają odległość 3 stóp od ścian wewnętrznych. (Aby uzyskać informacje na temat etykietowania odległości w modelu, zobacz temat Dodawanie tekstu do modelu).
  7. (Opcjonalnie) Aby przesunąć linię pomocniczą na dokładną odległość od punktu początkowego, wpisz liczbę i jednostkę, a następnie naciśnij klawisz Enter.

Uwaga: jeśli zmierzysz odległość bez tworzenia linii pomocniczej, a następnie wprowadzisz wartość, program SketchUp zapyta, czy chcesz zmienić rozmiar modelu. Aby uzyskać szczegółowe informacje, zobacz temat Skalowanie modelu lub jego części.

Wskazówka: jeśli pomiar jest wykonywany od punktu końcowego i tworzona jest linia pomocnicza, program SketchUp tworzy punkt prowadzący, jak pokazano na ilustracji. Punktem prowadzącym jest skończona przerywana linia, zaś linia pomocnicza jest nieskończona.

Pomiar kąta

Zmierz kąt, jeśli chcesz powielić ten kąt w innym miejscu w modelu lub utworzyć plany, na przykład na użytek projektu obróbki drewna. Aby zmierzyć kąt lub utworzyć ukośne linie pomocnicze, użyj narzędzia Protractor (Kątomierz).

Narzędzie Protractor (Kątomierz) () jest dostępne w kilku różnych częściach interfejsu programu SketchUp:

  • Pasek narzędzi Construction (Konstrukcja)
  • Pasek narzędzi Large Tool Set (Duży zestaw narzędzi)
  • Menu Tools (Narzędzia)
  • Paleta narzędzi (macOS)

Na filmie przedstawiamy, jak mierzyć kąty i ustawiać linie pomocnicze za pomocą narzędzia Protractor (Kątomierz). Aby uzyskać szczegółowe instrukcje dotyczące tego procesu, zapoznaj się z następnymi punktami.

Aby zmierzyć kąt lub ustawić linię pomocniczą, wykonaj następujące kroki:

  1. Wybierz narzędzie Protractor (Kątomierz) (). Kursor zmieni się w kątomierz. Punkt środkowy jest przymocowany do kursora.
  2. Kliknij, aby ustawić wierzchołek kąta, który chcesz zmierzyć. (Zobacz objaśnienie 1 na ilustracji). Jeśli chcesz zablokować orientację, naciśnij i przytrzymaj klawisz Shift przed kliknięciem.
    Wskazówka: po naciśnięciu i przytrzymaniu klawisza Shift w celu zablokowania/ograniczenia płaszczyzny obrotu można nacisnąć klawisz Alt (Microsoft Windows) lub Command (macOS), aby zwolnić kątomierz z płaszczyzny wywnioskowanej. Kąt kątomierza pozostanie kątem oryginalnej płaszczyzny, ale teraz można przesunąć kątomierz, aby wywnioskować inną geometrię.
  3. Kliknij miejsce, gdzie zaczyna się kąt, który chcesz zmierzyć. (Zobacz objaśnienie 2 na ilustracji).

    Wskazówka: można kliknąć i przeciągnąć od wierzchołka do pierwszego punktu, aby zdefiniować oś obrotu. Jest to szczególnie przydatne, jeśli chcesz wykonać obrót wokół osi, która nie znajduje się na płaszczyźnie czerwonej, zielonej lub niebieskiej. Naciśnij klawisz Esc w dowolnym momencie, aby zacząć od nowa.
  4. Przesuń kursor, aby zmierzyć kąt. (Zobacz objaśnienie 3 na ilustracji).

    Wskazówka: oto kilka ważnych informacji, które pomogą znaleźć właściwy pomiar kąta:
    • Podczas przesuwania kursora wartość kąta jest dynamicznie wyświetlana w polu Measurements (Wymiary).
    • Gdy kursor znajduje się blisko kątomierza, kąt jest przyciągany do znaczników kątomierza, które wskazują przyrosty o 15 stopni. Gdy kursor znajduje się dalej od środka kątomierza, można zmierzyć kąt bardziej precyzyjnie.
  5. Kliknij, aby ustawić ukośną linię pomocniczą.
  6. (Opcjonalnie) Wpisz wartość i naciśnij klawisz Enter, aby zmienić kąt linii pomocniczej (względem linii początkowej). Można wpisać wartość dziesiętną, na przykład 34.1, lub nachylenie, na przykład 1:6. Zmieniaj tę wartość tyle razy, ile chcesz, aż dokonasz kolejnego wyboru lub wybierzesz inne polecenie.

Uwaga: program SketchUp pracuje z dokładnością kątową do 0,1 stopnia.

Edycja linii pomocniczych

Aby zmienić orientację linii pomocniczej lub punktu prowadzącego, możesz je przesunąć lub obrócić. Aby uzyskać szczegółowe informacje, zobacz tematy Przesuwanie elementów oraz Odwracanie i obracanie.

Uwaga: nie można zmienić długości linii pomocniczej, ponieważ mają one długość nieskończoną.

Ukrywanie i usuwanie linii pomocniczych

Linie pomocnicze są zwykle tworzone jako tymczasowa pomoc przy tworzeniu części modelu. Utrzymywanie zbyt wielu linii pomocniczych w modelu może zmniejszyć dokładność wnioskowania programu SketchUp i wydajność wyświetlania, więc podczas pracy można ukryć linie pomocnicze lub usunąć wszystkie linie pomocnicze po ukończeniu modelu 3D.

Aby ukryć linie pomocnicze, można użyć jednej z następujących metod:

  • Za pomocą narzędzia Select (Zaznacz) () wybierz jedną lub więcej linii pomocniczych, a następnie użyj opcji Edit (Edycja) > Hide (Ukryj).
  • Kliknij prawym przyciskiem myszy wybraną linię pomocniczą lub linie pomocnicze i wybierz z wyświetlonego menu opcję Hide (Ukryj), jak pokazano na ilustracji.

Aby ponownie wyświetlić ukryte linie pomocnicze, wybierz opcję Edit (Edycja) > Unhide (Odkryj) i wybierz opcję z podmenu Unhide (Odkryj).

Usunięcie linii pomocniczych usuwa je całkowicie i bezpowrotnie. Oto kilka sposobów na usunięcie linii pomocniczych:

  • Za pomocą narzędzia Select (Zaznacz) () wybierz jedną lub więcej linii pomocniczych, a następnie użyj opcji Edit (Edycja) > Delete (Usuń).
  • Kliknij linię pomocniczą prawym przyciskiem myszy i wybierz polecenie Erase (Wymaż) z wyświetlonego menu.
  • Kliknij linię pomocniczą narzędziem Eraser (Gumka) ().
  • Wybierz polecenie Edit (Edycja) > Delete Guides (Usuń linie pomocnicze), aby usunąć wszystkie linie pomocnicze w bieżącym kontekście.

Dokładne szacowanie wysokości budynku

Jeśli nie znasz wysokości istniejącego budynku, który chcesz modelować, oto kilka przydatnych działań ułatwiających trafną odpowiedź:

  • Policz powtarzające się jednostki.
  • Zrób zdjęcie obiektu o znanej wysokości.
  • Użyj trygonometrii.

Kiedy zakończysz przygotowania do wyciągnięcia obrysu budynku na odpowiednią wysokość, upewnij się, że jesteś w widoku ISO, wybierając opcję Camera (Aparat) > Standard Views (Widoki standardowe) > Iso. Następnie użyj narzędzia Push/Pull (Wypchnij/Wyciągnij) (), aby wyciągnąć budynek w 3D i wprowadzić dokładną wysokość budynku.

Metoda 1: Policz powtarzające się jednostki

Budynki są często budowane z cegieł, bloków lub innych modułowych materiałów konstrukcyjnych. Zmierz wysokość pojedynczej jednostki, policz całkowitą liczbę jednostek na elewacji i pomnóż, aby uzyskać przybliżoną wysokość całkowitą budynku.

Ta metoda działa również w przypadku pięter budynku. Jeśli można zmierzyć wysokość jednego piętra na elewacji budynku, wystarczy ją pomnożyć przez całkowitą liczbę pięter, aby uzyskać przybliżoną wysokość całkowitą budynku.

Metoda 2: Zrób zdjęcie obiektu o znanej wysokości

Jeśli chcesz zrobić zdjęcie budynku, który zamierzasz modelować, umieść na zdjęciu coś (lub kogoś) o znanej wysokości.

Wskazówka: oto kilka ważnych informacji, które pomogą prawidłowo ustalić wysokość budynku tą metodą:
  • Skorzystaj ze składanej marki lub pomocy drugiej osoby.
  • Aby zapewnić odpowiednią dokładność, umieść obiekt o znanej wysokości jak najbliżej budynku.
  • Zrób zdjęcie z jak największej odległości, aby zminimalizować zniekształcenia w pionie.

Aby oszacować wysokość budynku na podstawie przedmiotu lub osoby umieszczonych na zdjęciu, użyj programu do edycji zdjęć.

Metoda 3: Użyj prostej trygonometrii

Dzięki kilku prostym pomiarom możliwe jest oszacowanie wysokości budynku z dość dużą dokładnością. Spójrz na poniższą ilustrację. W tym przypadku wystarczy znać:

  1. Odległość budynku od miejsca, w którym stoisz
  2. Wysokość, na której są Twoje oczy
  3. Kąt między poziomem gruntu a górą budynku

Użyj tego wzoru, aby obliczyć wysokość budynku:

Wysokość = (tan(kąt) × odległość) + wysokość oczu

Załóżmy na przykład, że odległość do budynku wynosi 25 metrów, kąt to 37 stopni, a wysokość oczu 1,75 metra. Wówczas wzór byłby następujący:

Wysokość = tan(37) × 25 m + 1,75 m
= 0,75355 × 25 m + 1,75 m
= 20,6 m

Uwaga: tangens kąta można również obliczyć za pomocą odpowiedniego przycisku na kalkulatorze („tg” lub „tan”).

Szybkie wskazania w polu Measurements (Wymiary)

W tej sekcji znajdziesz tabele przedstawiające wszystkie wartości, które akceptuje pole Measurements (Wymiary), w zależności od używanego narzędzia. Pamiętaj, że po użyciu narzędzia można po prostu wpisać wartość i nacisnąć klawisz Enter. Nie musisz klikać pola Measurements (Wymiary). Ponadto, dopóki nie wprowadzisz kolejnej zmiany w modelu ani nie wybierzesz innego narzędzia, możesz kontynuować wprowadzanie wartości, które modyfikują daną czynność.

Określanie jednostek miary

W poniższej tabeli opisano, jak określać jednostki miary. Jeśli nie wskażesz jednostki, program SketchUp użyje jednostek podanych w Twoim szablonie. Aby wyświetlić lub zmienić domyślne jednostki miary, wybierz opcję Window (Okno) > Model Info (Informacje o modelu) i wybierz pozycję Units (Jednostki) na pasku bocznym po lewej stronie.

Jednostka Jak ją określić Przykład
Cale liczba + ” 10”
Stopy liczba + ’ 10’
Milimetry liczba + mm 10mm
Centymetry liczba + cm 10cm
Metry liczba + m 10m

Tworzenie szyków

Szyk rozmieszcza geometrię w linii (szyk liniowy) lub wokół punktu (szyk promieniowy). Szyk tworzy się podczas kopiowania geometrii za pomocą narzędzia Move (Przesuń) lub Rotate (Obróć). Poniższa tabela przedstawia wszystkie modyfikatory, których można użyć podczas tworzenia szyków.

Rodzaj szyku Jak ją określić Przykład Rozstaw
Zewnętrzny liczba + x 3x Taka sama odległość jak oryginał i kopia początkowa
Zewnętrzny numer + * 3* Taka sama odległość jak oryginał i kopia początkowa
Wewnętrzny liczba + / 3/ Równa odległość między oryginałem a początkową kopią

Wprowadzanie wartości pomiarowych specyficznych dla danego narzędzia

Zaraz po użyciu danego narzędzia można wprowadzić dokładne wartości, które pojawią się w polu Measurements (Wymiary). Wartości, które można wprowadzić, zależą od narzędzia.

Uwaga: dokładny format separatora listy może się różnić w zależności od ustawień regionalnych komputera. W przypadku użytkowników europejskich symbolem separatora listy może być średnik zamiast przecinka.

Poniższe łącza prowadzą do artykułu, w którym opisano akceptowane wartości i modyfikatory dla każdego narzędzia: