Modelowanie złożonych kształtów 3D za pomocą narzędzi Solid Tools (Narzędzia brył)

Za pomocą Solid Tools (Narzędzia brył) programu SketchUp można tworzyć nowe kształty, łącząc jeden kształt z innym lub wycinając go, co ułatwia modelowanie zewnętrznej powłoki lub stolarki.

Uwaga: narzędzia Solid Tools (Narzędzia brył) są również zawarte w subskrypcji Shop programu SketchUp for Web. Aby dowiedzieć się więcej o funkcjach subskrypcji Shop, zobacz temat SketchUp for Web: porównanie subskrypcji Free i Shop.

W programie SketchUp bryłą jest dowolny model 3D (komponent lub grupa) o skończonej i zamkniętej objętości. Bryła w programie SketchUp nie może mieć żadnych nieszczelności (brakujących ścian lub ścian, które nie stykają się krawędziami). Poniższy obraz przedstawia kilka brył.

Wskazówka: aby sprawdzić, czy grupa lub komponent jest bryłą, kliknij ją prawym przyciskiem myszy i wybierz opcję Entity Info (Informacje o elemencie). W wyświetlonym oknie dialogowym Entity Info (Informacje o elemencie) lewy górny róg wskazuje, czy zaznaczenie jest bryłą, jak pokazano na ilustracji. Jeśli masz problem ze zidentyfikowaniem nieszczelności, które uniemożliwiają modelowi działanie jako bryła, spróbuj przeszukać witrynę Extensions Warehouse w poszukiwaniu wtyczki innej firmy, przeznaczonej do rozwiązania tego problemu.
Wskazówka: aby sprawdzić, czy grupa lub komponent jest bryłą, kliknij ją prawym przyciskiem myszy i wybierz opcję Entity Info (Informacje o elemencie). W wyświetlonym oknie dialogowym Entity Info (Informacje o elemencie) lewy górny róg wskazuje, czy zaznaczenie jest bryłą, jak pokazano na ilustracji. Jeśli masz problem ze zidentyfikowaniem nieszczelności, które uniemożliwiają modelowi działanie jako bryła, możesz użyć narzędzia Solid Inspector (Inspektor brył), które jest dostępne w płatnych subskrypcjach, aby sprawdzić i naprawić problemy z modelowaniem brył.

Zapoznaj się z poniższą tabelą, aby uzyskać szybkie wprowadzenie do Solid Tools (Narzędzia brył), przedstawiające działanie narzędzia oraz informację, czy jest dostępne w programie SketchUp Free.

Narzędzie Nazwa Działanie narzędzia Czy jest zawarte w programie SketchUp Free?
Outer Shell (Powłoka zewnętrzna) Pozostawia tylko zewnętrzne powierzchnie nakładających się brył. Tak
Union (Połącz) Łączy dwie lub więcej brył w jedną formę. Tylko płatne subskrypcje
Subtract (Odejmij) Jedna bryła usuwa część drugiej i jest usuwana. Tylko płatne subskrypcje. W programie SketchUp Free użyj opcji Intersect with Model (Przetnij z modelem).
Trim (Przytnij) Jedna bryła przycina drugą, ale pozostaje w modelu. Tylko płatne subskrypcje
Intersect (Przetnij) Pozostawia tylko przecinającą się geometrię. Tylko płatne subskrypcje
Split (Rozdziel) Rozdziela bryły wzdłuż przecinającej się geometrii. Tylko płatne subskrypcje

Aby znaleźć Solid Tools (Narzędzia brył), zajrzyj w następujące części interfejsu programu SketchUp:

  • Pasek narzędzi Solids (Bryły)
  • Menu Tools (Narzędzia) – wybierz Tools (Narzędzia) > Outer Shell (Powłoka zewnętrzna) lub Tools (Narzędzia) > Solid Tools (Narzędzia brył) i wybierz inne narzędzia z podmenu
  • Paleta narzędzi (macOS)
  • Pasek narzędzi Solids (Bryły) w lewym panelu
  • Narzędzie Solid Inspector (Inspektor brył) w panelu po prawej stronie

Na filmie przedstawiamy działanie Solid Tools (Narzędzia brył). W kolejnych sekcjach tego artykułu znajdziesz kroki i szczegółowe informacje dotyczące korzystania z każdego narzędzia. (Należy jednak pamiętać, że nie można już umieszczać modeli programu SketchUp w programie Google Earth).

Tworzenie powłoki zewnętrznej

Narzędzie Outer Shell (Powłoka zewnętrzna) () usuwa geometrię wewnątrz nakładających się grup lub komponentów, pozostawiając tylko zewnętrzne powierzchnie.

Wskazówka: ponieważ powłoka zewnętrzna zmniejsza geometrię modelu, je utworzenie jest pomocne, gdy trzeba zwiększyć wydajność programu SketchUp.

Załóżmy na przykład, że masz dwa modele: jeden to szczegółowy model wnętrza i zewnętrza budynku. Drugi model ilustruje budynek w widoku ulicy, który pokazuje okoliczne budynki, ulice i elementy krajobrazu. Można zaimportować do widoku ulicy szczegółowy model budynku. Jednak cała ta geometria nie jest konieczna i może spowolnić działanie modelu w widoku ulicy. W widoku ulicy utworzenie powłoki zewnętrznej budynku eliminuje niepotrzebną geometrię wnętrza. Dzięki temu model w widoku ulicy jest lżejszy i szybciej się renderuje w trakcie pracy nad nim.

Aby utworzyć powłokę zewnętrzną z nakładających się grup lub komponentów, wykonaj następujące kroki:

  1. Za pomocą narzędzia Select (Zaznacz) () wybierz wszystkie przecinające się grupy lub komponenty, które chcesz uwzględnić w powłoce zewnętrznej.
  2. Kliknij prawym przyciskiem myszy wybrane elementy i z wyświetlonego menu wybierz opcję Outer Shell (Powłoka zewnętrzna), jak pokazano na ilustracji. Pozostaną zewnętrzne powierzchnie.

Można także utworzyć powłokę zewnętrzną w następujący sposób:

  1. Wybierz narzędzie Outer Shell (Powłoka zewnętrzna) ().

    Wskazówka: dopóki nie umieścisz kursora na grupie lub komponencie bryły, będziesz widzieć kursor strzałki z okręgiem i ukośnikiem. Gdy kursor najedzie na grupę lub komponent bryły, czerwony okrąg i ukośnik zmienią się na czarną cyfrę 1 wewnątrz okręgu i zostanie wyświetlona ekranowa wskazówka Solid Group (Grupa brył) lub Solid Component (Komponent bryły).
  2. Kliknij, aby zaznaczyć pierwszą grupę lub komponent w powłoce zewnętrznej.
  3. Kliknij drugą grupę lub komponent. SketchUp łączy wybrane elementy w powłokę zewnętrzną, co powoduje, że pozostaną zewnętrzne powierzchnie.
  4. (Opcjonalnie) Kontynuuj klikanie dodatkowych grup lub komponentów, aby dodać je do powłoki zewnętrznej, jak pokazano na ilustracji.
  1. Wybierz narzędzie Outer Shell (Powłoka zewnętrzna) () z lewego zasobnika na narzędzia.
    Wskazówka: dopóki nie umieścisz kursora na grupie lub komponencie bryły, będziesz widzieć kursor strzałki z okręgiem i ukośnikiem. Gdy kursor najedzie na grupę lub komponent bryły, czerwony okrąg i ukośnik zmienią się na czarną cyfrę 1 wewnątrz okręgu i zostanie wyświetlona ekranowa wskazówka Solid Group (Grupa brył) lub Solid Component (Komponent bryły).
  2. Kliknij, aby zaznaczyć pierwszą grupę lub komponent w powłoce zewnętrznej.
  3. Kliknij drugą grupę lub komponent. SketchUp łączy wybrane elementy w powłokę zewnętrzną, co powoduje, że pozostaną zewnętrzne powierzchnie.
  4. (Opcjonalnie) Kontynuuj klikanie dodatkowych grup lub komponentów, aby dodać je do powłoki zewnętrznej, jak pokazano na ilustracji.

Uwaga: wynik uzyskany za pomocą powłoki zewnętrznej jest podobny do wyniku połączenia. Należy jednak pamiętać, że wynik uzyskany za pomocą powłoki zewnętrznej zawiera tylko powierzchnie zewnętrzne, podczas gdy ten uzyskany przez połączenie może również zawierać geometrię wewnętrzną. Poniższa ilustracja przedstawia dwie kwadratowe rury po lewej stronie, połączenie rur w środku i zewnętrzną powłokę rur po prawej stronie.

Łączenie brył w jeden element

Połączenie scala dwie lub więcej brył w jedną formę.

Wynik uzyskany za pomocą połączenia jest podobny do wyniku uzyskanego za pomocą powłoki zewnętrznej. Należy jednak pamiętać, że wynik uzyskany przez połączenie może również zawierać geometrię wewnętrzną, podczas gdy powłoka zewnętrzna zawiera tylko powierzchnie zewnętrzne. (Zobacz przykład na poprzedniej ilustracji).

Oto jak używać narzędzia Union (Połącz) do łączenia brył:

  1. Wybierz narzędzie Union (Połącz) ().

    Wskazówka: dopóki nie umieścisz kursora na grupie lub komponencie bryły, będziesz widzieć kursor strzałki z okręgiem i ukośnikiem. Gdy kursor najedzie na grupę lub komponent bryły, czerwony okrąg i ukośnik zmienią się na czarną cyfrę 1 wewnątrz okręgu i zostanie wyświetlona ekranowa wskazówka Solid Group (Grupa brył) lub Solid Component (Komponent bryły).
  2. Kliknij, aby zaznaczyć pierwszą grupę lub komponent do połączenia.
  3. Kliknij drugą grupę lub komponent. Utworzone połączenie geometrii zostaje zachowane.
  4. (Opcjonalnie) Kontynuuj klikanie dodatkowych grup lub komponentów, aby dodać je do połączenia, jak pokazano na ilustracji, które wykorzystuje widok rentgenowski. Dzięki temu można zobaczyć geometrię w każdej bryle.

Wskazówka: zamiast wykonywać poprzednie kroki, można wstępnie wybrać grupy lub komponenty za pomocą narzędzia Select (Zaznacz), kliknąć prawym przyciskiem myszy zaznaczenie i wybrać z wyświetlonego menu Solid Tools (Narzędzia brył) > Union (Połącz).

Oddzielanie jednej bryły od drugiej lub użycie opcji Intersect Faces with Model (Przetnij powierzchnie z modelem)

Za pomocą narzędzia Subtract (Odejmij) można użyć jednej bryły do wycięcia innej bryły. Pierwotna bryła jest następnie odejmowana od modelu. Aby odejmowanie zadziałało, dwie bryły muszą na siebie nachodzić.

Wskazówka: podczas korzystania z narzędzia Subtract (Odejmij) istotna jest kolejność zaznaczania każdej bryły. Aby zapamiętać, którą bryłę wybrać jako pierwszą, pomyśl: „Użyj tej, aby wyciąć tamtą”. Innymi słowy, pierwsza wybrana bryła jest narzędziem tnącym. Druga wybrana bryła jest elementem, który zostanie wycięty.

Aby wykonać odejmowanie, wykonaj następujące kroki:

  1. Wybierz narzędzie Subtract (Odejmij) ().

    Wskazówka: dopóki nie umieścisz kursora na grupie lub komponencie bryły, będziesz widzieć kursor strzałki z okręgiem i ukośnikiem. Gdy kursor najedzie na grupę lub komponent bryły, czerwony okrąg i ukośnik zmienią się na czarną cyfrę 1 wewnątrz okręgu i zostanie wyświetlona ekranowa wskazówka Solid Group (Grupa brył) lub Solid Component (Komponent bryły).
  2. Kliknij, aby wybrać grupę lub komponent, które posłużą jako narzędzie tnące. W przedstawionym przykładzie najpierw wybierz kołek, aby zrobić dziurę w płycie. Po dokonaniu wyboru ikona 1 obok kursora zmienia się w 2.
  3. Kliknij grupę lub komponent, które chcesz wyciąć. Grupa tnąca znika, ale robi dziurę w drugim wybranym elemencie. W tym przykładzie w płycie widać otwór wielkości kołka.

Wskazówka: zamiast wykonywać poprzednie kroki, można wstępnie wybrać bryły, kliknąć prawym przyciskiem myszy zaznaczenie i wybrać z menu Solid Tools (Narzędzia brył) > Subtract (Odejmij). SketchUp używa kolejności, w jakiej każda bryła została zaznaczona, aby określić, która bryła posłuży jako narzędzie tnące, a która będzie wycinana.

W programie SketchUp Free można stworzyć efekt odejmowania, używając polecenia Intersect with Model (Przetnij z modelem). Gdy korzystasz z polecenia Intersect with Model (Przetnij z modelem), dwa kształty nie muszą być bryłami. (W rzeczywistości Intersect with Model [Przetnij z modelem] działa inaczej w przypadku brył, co wyjaśniono nieco dalej w tej sekcji). Jednak podczas tworzenia odejmowania za pomocą polecenia Intersect with Model (Przetnij z modelem) proces ten wymaga wykonania kilku dodatkowych kroków w porównaniu z procesem wykonywanym za pomocą narzędzia Subtract (Odejmij) programu SketchUp Pro.

Oto jak utworzyć odejmowanie za pomocą polecenia Intersect with Model (Przetnij z modelem):

  1. Utwórz dwie odrębne bryły, takie jak kostka i walec. (Aby uzyskać pomoc, zobacz temat Rysowanie podstawowych kształtów oraz Wypychanie i wciąganie kształtów do formatu 3D).
  2. Za pomocą narzędzia Select (Zaznacz) () kliknij trzykrotnie pierwszą bryłę, która będzie narzędziem tnącym. W tym przykładzie narzędziem tnącym jest walec, jak pokazano na ilustracji.
  3. Przesuń i obróć narzędzie tnące, aby przecinało się z kształtem, który chcesz wyciąć. (Aby uzyskać szczegółowe informacje, zobacz tematy Przesuwanie elementów oraz Odwracanie i obracanie). Pozostaw zaznaczone narzędzie tnące, jak pokazano na ilustracji.
  4. Kliknij prawym przyciskiem myszy narzędzie tnące i wybierz z wyświetlonego menu opcję Intersect Faces (Przetnij powierzchnie) > With Model (Z modelem). Polecenie to nakazuje programowi SketchUp utworzenie krawędzi w miejscu przecięcia się dwóch kształtów.
  5. Za pomocą narzędzia Eraser (Gumka) () usuń lub przenieś geometrię, której nie chcesz zachować. Na poniższej ilustracji widać, jak zmienia się kształt kostki po wymazaniu walca.

    Wskazówka: pamiętaj, że można przytrzymać kółko przewijania myszy, aby tymczasowo przełączyć się na narzędzie Orbit (Orbituj), aby obejrzeć model ze wszystkich stron i znaleźć całą geometrię, którą chcesz usunąć. (Aby uzyskać szczegółowe informacje na temat narzędzia Eraser [Gumka], zobacz punkt Wymazywanie i cofanie polecenia).

Polecenie Intersect with Model (Przetnij z modelem) tworzy krawędzie w bieżącym kontekście. Jeśli kształty są grupami lub komponentami, można utworzyć przecinające się linie w obrębie grupy lub poza nią. Jeśli przecięcia linii zostaną utworzone poza kontekstem grupy, można łatwo oddzielić oryginalne kształty od krawędzi utworzonych przez program SketchUp, jak pokazano na poniższej ilustracji. Aby zapoznać się z wprowadzeniem do grup i komponentów, zobacz punkty Porządkowanie modelu i Dodawanie gotowych komponentów i komponentów dynamicznych.

Przycinanie jednej bryły drugą

Za pomocą narzędzia Trim (Przytnij) można przecinać jedną bryłę za pomocą drugiej, podobnie jak przy odejmowaniu. Jednak podczas korzystania z narzędzia Trim (Przytnij) bryła tnąca pozostaje w modelu. Tak więc jeśli używasz kołka do wycięcia płyty, kołek pozostaje po wycięciu otworu. Podobnie jak wszystkie Solid Tools (Narzędzia brył), narzędzie Trim (Przytnij) działa tylko wtedy, gdy dwie bryły nakładają się na siebie.

Wskazówka: podczas korzystania z narzędzia Trim (Przytnij) istotna jest kolejność zaznaczania każdej bryły. Aby zapamiętać, którą bryłę wybrać jako pierwszą, pomyśl: „Użyj tej, aby wyciąć tamtą”. Innymi słowy, pierwsza wybrana bryła jest narzędziem tnącym. Druga wybrana bryła jest elementem, który zostanie wycięty.

Aby wykonać przycięcie, wykonaj następujące kroki:

  1. Wybierz narzędzie Trim (Przytnij) ().

    Wskazówka: dopóki nie umieścisz kursora na grupie lub komponencie bryły, będziesz widzieć kursor strzałki z okręgiem i ukośnikiem. Gdy kursor najedzie na grupę lub komponent bryły, czerwony okrąg i ukośnik zmienią się na czarną cyfrę 1 wewnątrz okręgu i zostanie wyświetlona ekranowa wskazówka Solid Group (Grupa brył) lub Solid Component (Komponent bryły).
  2. Kliknij, aby wybrać grupę lub komponent, które posłużą jako narzędzie tnące. W przedstawionym przykładzie najpierw wybierz kołek, aby zrobić dziurę w płycie. Po dokonaniu wyboru ikona 1 obok kursora zmienia się w 2.
  3. Kliknij grupę lub komponent, które chcesz wyciąć. Grupa tnąca pozostaje, ale robi dziurę w drugim wybranym elemencie. Wynik jest w pierwszej chwili trudny do zobaczenia (patrz objaśnienie 1). Jeśli jednak kołek zostanie wysunięty z otworu, jak pokazano w objaśnieniu 2, zobaczysz dziurę w płycie.

Pozostawienie tylko przecinającej się geometrii

Za pomocą narzędzia Intersect (Przetnij) programu SketchUp Pro () można wybrać dwie lub więcej nakładających się brył, a pozostanie tylko przecinająca się geometria.

Aby wykonać przecięcie, wykonaj następujące kroki:

  1. Wybierz narzędzie Intersect (Przetnij) ().

    Wskazówka: dopóki nie umieścisz kursora na grupie lub komponencie bryły, będziesz widzieć kursor strzałki z okręgiem i ukośnikiem (). Gdy kursor najedzie na grupę lub komponent bryły, czerwony okrąg i ukośnik zmienią się na czarną cyfrę 1 wewnątrz okręgu i zostanie wyświetlona ekranowa wskazówka Solid Group (Grupa brył) lub Solid Component (Komponent bryły).
  2. Wybierz bryłę, której chcesz użyć w przecięciu.
  3. Wybierz jedną lub więcej dodatkowych brył, które nakładają się na Twój początkowy wybór. Utworzona przecinająca się geometria zostaje zachowana. W tym przykładzie przecięcie kostki i kuli (objaśnienie 1) tworzy element o zaokrąglonej podstawie (objaśnienie 2).

Wskazówka: alternatywnie możesz wstępnie wybrać bryły, które chcesz przeciąć. Kliknij wybrane elementy prawym przyciskiem myszy i z wyświetlonego menu wybierz opcję Solid Tools (Narzędzia brył) > Intersect (Przetnij).

Dzielenie brył

Za pomocą narzędzia Split (Rozdziel) () można rozdzielić nakładające się bryły wzdłuż ich przecinających się krawędzi. Aby wykonać rozdzielenie, wykonaj następujące kroki:

  1. Wybierz narzędzie Split (Rozdziel) ().

    Wskazówka: dopóki nie umieścisz kursora na grupie lub komponencie bryły, będziesz widzieć kursor strzałki z okręgiem i ukośnikiem. Gdy kursor najedzie na grupę lub komponent bryły, czerwony okrąg i ukośnik zmienią się na czarną cyfrę 1 wewnątrz okręgu i zostanie wyświetlona ekranowa wskazówka Solid Group (Grupa brył) lub Solid Component (Komponent bryły).
  2. Kliknij bryłę.
  3. Kliknij inną bryłę, która przecina Twój pierwszy wybór. Program SketchUp dzieli całą geometrię wzdłuż krawędzi, na których przecinają się wybrane bryły. Na przykład na ilustracji po lewej stronie pokazane są dwie grupy, które zostają rozdzielone na trzy grupy, jak pokazano na ilustracji po prawej stronie.

Naprawianie modeli za pomocą narzędzia Solid Inspector (Inspektor brył)

W miarę jak geometria staje się coraz bardziej złożona, małe błędy mogą uniemożliwić tworzenie różnorodnych modeli. Solid Inspector (Inspektor brył) w programie SketchUp for Web to narzędzie, które pomaga przygotować modele do drukowania 3D poprzez znajdowanie i naprawianie problemów, które uniemożliwiają programowi SketchUp sklasyfikowanie modelu jako bryły. Ta kontrola jest również przydatna do naprawiania modeli 3D w celu stosowania narzędzi Solid Tool (Narzędzia brył).

Uwaga: narzędzie Solid Inspector (Inspektor brył) jest dostępne w przypadku płatnych subskrypcji. W programie SketchUp Pro rozszerzenie Solid Inspector (Inspektor brył) pełni podobną funkcję.

Aktywowanie funkcji Solid Inspector (Inspektor brył)

Znajdź narzędzie Solid Inspector (Inspektor brył) u dołu menu w panelu po prawej stronie w programie SketchUp for Web. Po aktywowaniu narzędzia zostanie wyświetlona prośba o wybranie grupy lub komponentu. Po zaznaczeniu obiektu kliknij opcję Run Inspector (Uruchom inspektora), aby kontynuować. Po zidentyfikowaniu błędu kliknij jego nazwę, aby dowiedzieć się więcej. Użyj ikon strzałek, aby skierować kamerę programu SketchUp na poszczególne problemy w modelu.

Uwaga: nie można sprawdzić geometrii niezgrupowanej.

Błędy, które można naprawić automatycznie

Niektóre błędy wykryte za pomocą narzędzia Solid Inspector (Inspektor brył) można naprawić automatycznie. Błędy wykryte przez to narzędzie są identyfikowane przez podświetloną na czerwono geometrię. Umożliwia to ich analizę przed zatwierdzeniem automatycznego naprawienia błędów. Błędy, które można naprawić automatycznie, obejmują:

  • Odwrócone powierzchnie: narzędzie Solid Inspector (Inspektor brył) nadaje się doskonale do sprawdzania, czy normalne powierzchnie są skierowane na zewnątrz.
  • Zagubione krawędzie: nadwyżkowa geometria krawędzi, która nie definiuje żadnej powierzchni.
  • Powierzchnie wewnętrzne i zewnętrzne: zagubiona geometria wewnątrz lub na zewnątrz modelu.
  • Otwory w powierzchni: otwór w powierzchniach zewnętrznych. Są to błędy łatwo naprawiane przez narzędzie Solid Inspector (Inspektor brył).

Błędy naprawiane ręcznie

Niektóre błędy nie mogą być automatycznie naprawione przez narzędzie Solid Inspector (Inspektor brył) i muszą zostać skorygowane ręcznie za pomocą narzędzi rysunkowych programu SketchUp lub narzędzia Eraser (Gumka). Po naprawieniu ręcznie kilku błędów dobrze jest ponownie uruchomić narzędzie Solid Inspector (Inspektor brył), aby sprawdzić, czy wprowadzone zmiany oczyściły model na tyle, że może być użyte automatyczne naprawianie błędów. Błędy, które trzeba naprawić ręcznie, obejmują:

  • Otwory graniczne: to takie, które mają co najmniej jedną krawędź wspólną z powierzchnią bryły. Błędy te można naprawić ręcznie, ponownie rysując lub usuwając podświetloną geometrię. W trakcie wykonywania korekt warto ponownie uruchomić inspektora, aby sprawdzić, czy model jest na tyle poprawny, że reszta błędów może zostać naprawiona automatycznie za pomocą narzędzia Solid Inspector (Inspektor brył).
  • Zagnieżdżone grupy/komponenty: zagnieżdżone obiekty w grupach lub komponentach mogą prowadzić do mylących eksportów STL dla drukarek 3D. Narzędzie Solid Inspector (Inspektor brył) nie naprawi tego ręcznie, ale można użyć go, aby spojrzeć na każde zagnieżdżone wystąpienie i zdecydować, czy je usunąć czy wbudować tę geometrię do modelu.
  • Obrazy: obrazy zaimportowane do programu SketchUp nie mogą być eksportowane do pliku STL, a także blokują działanie opcji Solid Tools (Narzędzia brył). Narzędzie Solid Inspector (Inspektor brył) wyświetli monit o tych błędach, ale trzeba będzie usunąć je ręcznie. Rozważ przekształcenie obrazów w komponenty. Dzięki temu można je łatwo tymczasowo usunąć z modelu. Ponadto malowanie powierzchni teksturą obrazu nie wpływa na właściwości brył.
  • Krótkie krawędzie: bardzo mała geometria może powodować problemy w wydrukach 3D lub w operacjach brył. Ponieważ te problemy są nieprzewidywalne, a krótkie krawędzie nie dyskwalifikują obiektów jako brył w programie SketchUp, narzędzie Solid Inspector (Inspektor brył) nie naprawi tych błędów automatycznie. Narzędzie to nadaje się jednak znakomicie do wyszukiwania i oceny tych obszarów problemowych.

Pokaż błędy

W przypadku wystąpienia wielu błędów, których nie można naprawić automatycznie, warto użyć polecenia „Pokaż błędy”, aby wyświetlić poszczególne problemy wymagające ręcznego skorygowania. Użyj lewej i prawej strzałki, aby przejść przez wszystkie błędy określonego typu zidentyfikowane przez narzędzie Solid Inspector (Inspektor brył). Kamera programu SketchUp przybliży obszar, w którym występuje problem.

Wskazówka: podczas pracy może być pomocna zmiana opcji stylu lub wyświetlania. Przełącz się na styl rentgenowski lub włącz ukrytą geometrię, aby ułatwić sobie naprawę modelu.