Wybieranie geometrii

Narzędzie Select (Zaznacz) (Wybierz narzędzie) umożliwia wybór elementów, które będą modyfikowane za pomocą innych narzędzi lub poleceń programu SketchUp. Jeśli chcesz zmienić długość linii, najpierw wybierz linię. Jeśli chcesz przeskalować ramkę, najpierw wybierz tę ramkę. Jeśli chcesz przenieść linię i ramkę, zacznij od zaznaczenia obu, tworząc tak zwany zbiór wskazań.

Oto miejsca, w których można skorzystać z narzędzia Select (Zaznacz) w programie SketchUp:

  • Pokazany tutaj pasek narzędzi Getting Started (Pierwsze kroki), pasek narzędzi Large Tool Set (Duży zestaw narzędzi) i główny pasek narzędzi (Microsoft Windows)
  • Tool Palette (Paleta narzędzi) w systemie macOS
  • Menu Tools (Narzędzia)

Pasek narzędzi Getting Started (Pierwsze kroki)

Wskazówka: narzędzie Select (Zaznacz) jest tak ważne w modelowaniu 3D w programie SketchUp, że jest udostępniane również za pomocą łatwego skrótu klawiaturowego: wystarczy nacisnąć klawisz spacji, aby aktywować narzędzie Select (Zaznacz).

Wybieranie pojedynczego elementu

Aby wybrać pojedynczy element:

  1. Aktywuj narzędzie Select (Zaznacz) (Wybierz narzędzie). Kursor zmieni się w strzałkę.
  2. Kliknij element. Każdy wybrany obiekt (na przykład krawędź, powierzchnia lub komponent) zostanie podświetlony, tak jak pokazana tutaj poduszka na kanapie.
Poduszka została zaznaczona

Jeśli właściwy element nie zostanie wybrany za pierwszym razem, spróbuj ponownie. Jeśli nie chcesz, aby cokolwiek było zaznaczane, kliknij dowolne puste miejsce w oknie rysunku.

Wybieranie wielu elementów

Gdy musisz wybrać więcej niż jeden element, program SketchUp oferuje kilka różnych opcji wyboru. Obejrzyj film, aby zobaczyć, jak działają te opcje, i poznaj sztuczki umożliwiające szybkie i łatwe dokonywanie skomplikowanych wyborów. Sposoby wybierania wielu elementów opisujemy też w tekście poniżej.

Wskazówka: bez względu na to, które narzędzie jest aktywne, można zaznaczyć wszystkie elementy w modelu, wybierając na pasku menu polecenie Edit (Edycja) > Select All (Zaznacz wszystko). Można też nacisnąć klawisze Ctrl + A (Microsoft Windows) lub Command + A (macOS).
Aby upewnić się, że żaden element nie jest zaznaczony, wybierz polecenie Edit (Edycja) > Deselect All (Usuń wszystkie zaznaczenia). Możesz też nacisnąć klawisze Ctrl + T (Microsoft Windows) lub Shift + Command + A (macOS) bądź kliknąć dowolne puste miejsce w obszarze rysunku.

Gdy narzędzie Select (Zaznacz) jest aktywne, można wybrać wiele elementów w jeden z następujących sposobów:

  • Kliknij i przeciągnij, aby utworzyć ramkę. Gdy narzędzie Select (Zaznacz) jest aktywne, kliknij i przeciągnij, aby utworzyć tymczasową ramkę wokół elementów, które chcesz zaznaczyć. Po zwolnieniu przycisku myszy te elementy zostaną zaznaczone. Jeśli klikniesz i przeciągniesz w lewo (zaznaczenie przecinające), wszystko w całości lub częściowo wewnątrz ramki zostanie zaznaczone. Jeśli klikniesz i przeciągniesz w prawo (pokazane na rysunku zaznaczenie w oknie), zostanie zaznaczone tylko to, co znajduje się w całości wewnątrz ramki. Zwróć uwagę na naszym przykładzie, że zaznaczona jest tylko jedna czerwona poduszka, mimo że druga znajduje się częściowo wewnątrz ramki.

    Zaznaczenie w oknie
  • Podwójne lub potrójne kliknięcie. W zależności od tego, jaki element zostanie kliknięty, można wybrać kombinacje krawędzi i powierzchni. Możliwe opcje przedstawiono w poniższej tabeli.
    Zrób to… …aby zaznaczyć to
    Kliknij dwukrotnie powierzchnięPowierzchnia i wszystkie przylegające krawędzie (1)
    Kliknij dwukrotnie krawędźKrawędź i połączona z nią powierzchnia (2)
    Kliknij trzykrotnie elementWszystkie połączone elementy. Na przykład jeśli trzykrotnie klikniesz ścianę w sześcianie, cały sześcian zostanie zaznaczony. (3)

    Kliknij dwukrotnie powierzchnię lub krawędź. Kliknij trzykrotnie, aby zaznaczyć element.
  • Kliknij krawędź prawym przyciskiem myszy. Po kliknięciu krawędzi prawym przyciskiem myszy pojawia się menu kontekstowe z następującymi opcjami:
    • Select (Zaznacz) > Connected Faces (Połączone powierzchnie) powoduje zaznaczenie wszystkich powierzchni połączonych z wybranym elementem.
    • Select (Zaznacz) >All Connected (Wszystkie połączone elementy) powoduje zaznaczenie wszystkich elementów połączonych z wybranym elementem. (Rezultat jest taki sam jak po trzykrotnym kliknięciu elementu).
    • Select (Zaznacz)> All on same Layer (Wszystko na tej samej warstwie) powoduje zaznaczenie wszystkich elementów na tej samej warstwie co wybrany element. Jeśli model nie zawiera żadnych warstw, rezultat jest taki sam jak w przypadku potrójnego kliknięcia.
  • Kliknij powierzchnię prawym przyciskiem myszy. Po kliknięciu powierzchni prawym przyciskiem myszy pojawia się menu kontekstowe z tymi samymi opcjami jak po kliknięciu krawędzi prawym przyciskiem myszy, jednak dostępne są kolejne dwie opcje:
    • Select (Zaznacz) > Bounding Edges (Przylegające krawędzie) powoduje zaznaczenie wszystkich przylegających krawędzi wybranej powierzchni.
    • Select (Zaznacz)> All with same Material (Wszystko z tego samego materiału) powoduje zaznaczenie wszystkich elementów z tego samego materiału co wybrana powierzchnia. Jeśli chcesz na przykład zaznaczyć wszystkie ściany z cegły lub pomalowane na czerwono i zmienić ten materiał na inny, dzięki tej metodzie jest to szybkie i łatwe.

Dodawanie elementów do zbioru zaznaczonych i ich usuwanie

Kiedy zaznaczasz wiele elementów, łatwo jest złapać element, którego nie chcesz, lub pominąć inny, którego potrzebujesz. Aby dodać lub usunąć elementy ze zbioru zaznaczonych, upewnij się, że narzędzie Select (Zaznacz) jest aktywne, a następnie dostosuj swój wybór za pomocą modyfikatorów klawiaturowych w poniższej tabeli. Aby zaznaczyć obie czerwone poduszki, jak pokazano w tym przykładzie, zaznacz jedną, a następnie przytrzymaj klawisz Ctrl podczas wybierania drugiej poduszki.

Zostały zaznaczone dwa elementy.

Wskazówka: gdy aktywujesz klawisz modyfikujący, kursor narzędzia Select (Zaznacz) wyświetla znak plus lub minus (Kursor narzędzia Select (Zaznacz), gdy wybrany jest klawisz modyfikujący) obok strzałki.

Aby… Naciśnij i przytrzymaj te klawisze I jednocześnie…
Dodać jeden element naraz do zbioru zaznaczonych Ctrl (Microsoft Windows) lub Option (macOS) Kliknij niezaznaczone elementy
Zmienić status zaznaczenia elementu (wybrać niezaznaczony element lub usunąć zaznaczenie elementu).Shift Kliknij dany element
Usunąć element ze zbioru zaznaczonych Shift + Ctrl (Microsoft Windows) lub Shift + Option (macOS) Kliknij wybrane elementy

Wskazówka: jeśli chcesz szybko ponownie zaznaczyć ten sam zbiór elementów, zmień ten zbiór w grupę. Aby uzyskać szczegółowe informacje na temat tworzenia grupy, zobacz punkt Porządkowanie modelu.

Odwracanie zaznaczenia

Odwrócenie zaznaczenia może uprościć skomplikowane zmiany, takie jak usuwanie liści z drzewa. W tym przykładzie wybieramy pień i gałęzie, a następnie odwracamy zaznaczenie, aby zaznaczyć wszystkie liście.

Aby odwrócić zaznaczenie, zaznacz pierwszy element, a następnie naciśnij klawisze Ctrl + Shift + I.

Aby odwrócić zaznaczenie, zaznacz pierwszy element, a następnie naciśnij klawisze Command + Shift + I.

Alternatywnie można wybrać na pasku menu opcję Edit (Edycja)> Invert Selection (Odwróć zaznaczenie).

TAGS
Was this article helpful?