Wprowadzenie do podstaw i koncepcji rysowania

Rysowanie modelu w 3D różni się od rysowania obrazu w 2D. To wprowadzenie do podstaw i koncepcji rysowania wyjaśnia kilka sposobów tworzenia krawędzi i płaszczyzn (podstawowych elementów każdego modelu programu SketchUp). Dowiesz się również, jak mechanizm wnioskowania programu SketchUp pomaga w umieszczaniu tych linii i powierzchni na wybranej osi.

Wskazówka: podstawowe narzędzia kształtu używają cienkiej linii ciągłej. Aby utworzyć linie przerywane, patrz Stosowanie linii przerywanych do warstw.

Rysowanie linii

Użyj narzędzia Line (Linia), aby narysować krawędzie (zwane także liniami). Krawędzie stanowią podstawę konstrukcyjną wszystkich modeli. Oto jak narysować linię:

  1. Wybierz narzędzie Line (Linia) () z paska narzędzi lub naciśnij klawisz L. Kursor zmieni się w ołówek.
  2. Kliknij, aby ustawić punkt początkowy linii. Jeśli klikniesz niewłaściwe miejsce, naciśnij klawisz Esc, aby zacząć od nowa. Podczas przesuwania kursora po obszarze rysunku zwróć uwagę na następujące kwestie:
    • Linia podąża za kursorem.
    • Długość linii jest dynamicznie wyświetlana w polu Measurements (Wymiary). (Pole Measurements [Wymiary] używa jednostek miary określonych w szablonie).
    • Linia podążająca za kursorem zmienia kolor na czerwony, zielony lub niebieski, ilekroć linia jest równoległa odpowiednio do czerwonej, zielonej lub niebieskiej osi. Jeśli na chwilę zatrzymasz kursor, pojawi się wskazówka ekranowa, na przykład pokazana na ilustracji On Blue Axis (Na niebieskiej osi). To nie jest żaden duch w Twoim urządzeniu – tak działa mechanizm wnioskowania programu SketchUp, o którym dowiesz się więcej w dalszej części tego artykułu.
  3. Kliknij, aby ustawić punkt końcowy linii. Ten punkt końcowy może być również punktem początkowym innej linii. Po zakończeniu rysowania linii naciśnij klawisz Esc lub wybierz inne narzędzie. Po ustawieniu punktu końcowego można nacisnąć klawisze Ctrl + Z (Microsoft Windows) lub Command + Z (macOS), aby cofnąć linię i zacząć od nowa.

  4. (Opcjonalnie) Aby ustawić dokładną długość linii, wpisz wartość i naciśnij klawisz Enter (Microsoft Windows) lub Return (macOS). Zmieniaj tę wartość tyle razy, ile chcesz, aż narysujesz nową linię lub wybierzesz inne narzędzie. Jeśli nie wskażesz jednostki, program SketchUp użyje jednostek podanych w Twoim szablonie. Można jednak wpisać dowolną jednostkę imperialną lub metryczną dla danej linii. Można więc wpisać na przykład 3mm lub 5’2”. W trakcie wpisywania długość pojawi się w polu Measurements (Wymiary).

Uwaga: pole Measurements (Wymiary) akceptuje również współrzędne 3D dla linii:
  • Współrzędna bezwzględna, taka jak [3’, 5’, 7’], umieszcza koniec linii względem bieżących osi. Nawiasy kwadratowe wskazują współrzędną bezwzględną.
  • Współrzędna względna, taka jak <1.5m, 4m, 2.75m>, umieszcza koniec linii względem punktu początkowego linii. Nawiasy kątowe wskazują współrzędną względną.

Można edytować długość linii, o ile nie ogranicza ona powierzchni. Oto jak edytować linię:

  1. Wybierz narzędzie Move (Przesuń) ().
  2. Najedź kursorem narzędzia Move (Przesuń) na jeden z punktów końcowych linii.
  3. Kliknij i przeciągnij punkt końcowy, aby zmienić długość linii.

Wskazówka: możesz również zmieniać długość linii w oknie dialogowym Entity Info (Informacje o elemencie). Kliknij linię prawym przyciskiem myszy i wybierz Entity Info (Informacje o elemencie) z wyświetlonego menu. W polu Length (Długość) wpisz nową długość linii.

Tworzenie powierzchni

Po połączeniu kilku linii w kształt zostanie utworzona powierzchnia.

Domyślnie powierzchnie są płaskie, ale są bardzo ważne: stanowią drugą połowę krawędzi i powierzchni, bez których żaden model w programie SketchUp nie mógłby powstać.

Wskazówka: program SketchUp domyślnie dodaje cieniowanie do niektórych powierzchni, jak pokazano tutaj, a ściany są nieprzezroczyste. Dzięki temu wiadomo, że model ma rzeczywistą ścianę, podłogę lub cokolwiek, co ma reprezentować dana powierzchnia w modelu 3D. (Program SketchUp dysponuje jednak widokiem, który umożliwia widzenie przez ściany, tak jak Superman. Aby uzyskać szczegółowe, patrz punkt Wyświetlanie modelu).

Narzędzia kształtów – Rectangle (Prostokąt), Circle (Okrąg) i Polygon (Wielokąt) – również służą do tworzenia powierzchni. (Aby uzyskać więcej informacji na temat tych narzędzi, zobacz temat Rysowanie podstawowych kształtów).

Dzielenie powierzchni

Kiedy narysujesz linię (lub krzywą) na istniejącej powierzchni, dzielisz ją.

Wskazówka: zrozumienie tej funkcji jest ważne, ponieważ po podzieleniu powierzchni można użyć narzędzia Push/Pull (Wypchnij/Wyciągnij), aby wypchnąć lub wyciągnąć jedną część powierzchni, podczas gdy druga część pozostaje niezmieniona, jak pokazano tutaj. Aby uzyskać szczegółowe informacje na temat działania narzędzia Push/Pull (Wypchnij/Wyciągnij), zobacz punkt Wypychanie i wciąganie kształtów do formatu 3D.

Otwieranie kształtów 3D przez wymazywanie krawędzi i powierzchni

Można wymazać krawędź lub powierzchnię, aby utworzyć otwór w kształcie. Aby zobaczyć, jak wymazywanie krawędzi wpływa na model, najpierw wybierz narzędzie Eraser (Gumka) () na pasku narzędzi lub naciśnij klawisz E, a następnie kliknij krawędź:

  • Kliknięcie krawędzi powoduje wymazanie krawędzi i każdej powierzchni, która jej dotyka. Należy jednak pamiętać, że powierzchnia musi być ze wszystkich stron otoczona krawędziami.
  • Kliknięcie powierzchni prawym przyciskiem myszy i wybranie polecenia Erase (Wymaż) powoduje wymazanie tylko powierzchni.

Na ilustracji przedstawiamy kostkę oraz jej zmiany po usunięciu krawędzi lub powierzchni.

Wskazówka: jeśli chcesz ukryć linię zamiast ją wymazywać, przytrzymaj klawisz Shift podczas klikania linii za pomocą narzędzia Eraser (Gumka). Możesz też kliknąć linię prawym przyciskiem myszy i wybrać opcję Hide (Ukryj).

Przywracanie usuniętych powierzchni

Jeśli powierzchnia zostanie usunięta przez przypadek, oto jak można ją przywrócić:

  • Jeśli nie zostały wprowadzone inne zmiany, które chcesz zachować, wybierz z paska menu opcję Edit (Edycja) > Undo (Cofnij). Można też nacisnąć skrót klawiaturowy tego polecenia: Ctrl + Z (Microsoft Windows) lub Command + Z (macOS).
  • Narysuj ponownie linię, która spowodowała zniknięcie powierzchni, a program SketchUp ponownie utworzy powierzchnie.

Znajdowanie i blokowanie wnioskowania

Program SketchUp jest wyposażony w mechanizm wnioskowania, który ułatwia pracę w przestrzeni 3D. Na przykład, gdy kursor narzędzia Line (Linia) znajduje się nad punktem środkowym innej linii, mechanizm wnioskowania poinformuje Cię o tym, wyświetlając jasnoniebieską kropkę i wskazówkę ekranową z napisem „Midpoint” (Punkt środkowy), jak pokazano tutaj. Każde wnioskowanie ma własny kolor i wskazówkę ekranową. (Pełna lista została przedstawiona w temacie Poznawanie typów wnioskowania).

Mechanizm wnioskowania może również pomóc w znalezieniu zależności geometrycznych między liniami. Informuje na przykład, kiedy rysowana linia jest prostopadła do innej linii. Należy pamiętać, że na poniższej ilustracji kolorowa kropka pojawia się również w punkcie początkowym linii, podając jednocześnie krótką informację.

Ostrzeżenie: od czasu do czasu warto skorzystać z mechanizmu wnioskowania i narzędzia do orbitowania, aby sprawdzić swój rysunek z różnych punktów widzenia. Na poniższym rysunku może się wydawać, że linie są na czerwono-zielonej płaszczyźnie, dopóki nie spojrzymy na nie pod innym kątem. Aby uniknąć tej typowej pułapki, program SketchUp pomaga, obracając kierunek rysowania lub czerwoną, zieloną bądź niebieską płaszczyznę rysowania podczas tworzenia krawędzi lub płaszczyzn równoległych do tych osi (lub w kolorze magenta, jeśli rysowany element jest równoległy/prostopadły do krawędzi lub powierzchni w modelu).

Wskazówka: czasami potrzebne wnioskowanie może nie pojawić się natychmiast lub program SketchUp może wybrać wyrównanie do niewłaściwej geometrii. W takich przypadkach można zachęcić program do wnioskowania lub zwiększyć szanse na określone wyrównanie, zatrzymując kursor myszy nad lokalizacją, z której program SketchUp ma przeprowadzić wnioskowanie. Gdy pojawi się wskazówka wizualna, program SketchUp na krótko określi priorytet wyrównania, gdy będziesz kontynuować rysowanie.

Przełącznik wnioskowania liniowego

Nowa funkcja! – SketchUp 2020.2

Wnioskowanie to podstawowa funkcja programu SketchUp, z którą większość narzędzi jest w jakiś sposób powiązana. Jednak wnioskowanie może czasami przeszkadzać, zwłaszcza podczas pracy w obszarze modelu o dużej zawartości szczegółów. Przy korzystaniu z narzędzia Line (Linia) można wyłączać i ponownie włączać wnioskowanie liniowe za pomocą prostego działania.

Aby przełączyć wnioskowanie liniowe w narzędziu Line (Linia), trzeba kliknąć raz, aby rozpocząć rysowanie linii. Po rozpoczęciu rysowania linii (ale przed kliknięciem w celu jej zakończenia) wystarczy nacisnąć klawisz COMMAND na komputerze Mac lub klawisz ALT w systemie Windows, co spowoduje przełączenie pomiędzy następującymi stanami:

  • Wszystkie wnioskowania włączone
  • Wszystkie wnioskowania wyłączone
  • Tylko równolegle i prostopadle

Wszystkie wnioskowania włączone

Jest to domyślne zachowanie, które było stosowane w programie SketchUp od wersji 1. Narzędzie Line (Linia) zostanie przyciągnięte do osi czerwonej, zielonej i niebieskiej, a także do osi w kolorze magenta (równoległej/prostopadłej do określonej krawędzi).

Wszystkie wnioskowania wyłączone

W tym stanie narzędzie Line (Linia) ignoruje wszystkie wnioskowania liniowe. Zauważ, że kursor będzie poruszał się swobodniej po ekranie w miarę dodawania segmentów krawędzi. Pamiętaj, że nadal dostępne są inne typy wnioskowania, takie jak On face (Na powierzchni), Guide points (Punkty prowadzące), Midpoints (Punkty środkowe) i inne. Warto korzystać z tych innych typów wnioskowania, aby upewnić się, że linie są rysowane na żądanych płaszczyznach.

Tylko równolegle i prostopadle

W tym stanie, podczas używania narzędzia Line (Linia), wyświetlane są tylko równoległe i prostopadłe wnioskowania liniowe. Wybranie tej opcji umożliwia rysowanie linii z gwarancją, że są one równoległe lub prostopadłe do innej geometrii, bez rozpraszania się przez inne wnioskowania liniowe.

Blokowanie wnioskowania za pomocą klawiatury

Zablokowanie wnioskowania pozwala bezproblemowo rysować w dowolnie wybranym kierunku. Innym argumentem za zablokowaniem wnioskowania jest zachowanie jednego kierunku rysowania podczas odnoszenia się do geometrii z innej części modelu. To bardziej zaawansowany ruch, ale bardzo pomocny. Najłatwiejszym sposobem zablokowania wnioskowania do domyślnych kierunków osi jest użycie klawiszy strzałek:

>

Blokowanie kierunku rysowania za pomocą klawiszy strzałek
Klawisz Jak to wygląda
Blokuje kierunek rysowania lub płaszczyznę rysowania do osi niebieskiej.
Blokuje kierunek rysowania lub płaszczyznę rysowania do osi zielonej.
Blokuje kierunek rysowania lub płaszczyznę rysowania do osi czerwonej. Dobrym sposobem na zapamiętanie, która strzałka blokuje którą oś, jest powiedzenie „Right locks Red” (Prawa blokuje czerwoną).
Przełącz, aby zablokować równoległy/prostopadły kierunek rysowania lub równoległą/prostopadłą płaszczyznę rysowania do wywnioskowanej krawędzi lub płaszczyzny. W zasadzie chodzi tu o wszystko, co przybiera kolor magenta. Kierunek rysowania zmieni kolor na magentę, podobnie jak krawędź powierzchni będącej przedmiotem wnioskowania.
Shift Blokuje kierunek rysowania lub płaszczyznę rysowania do aktywnego kierunku/płaszczyzny rysowania. Jeśli więc rysujesz wzdłuż osi niebieskich i przytrzymasz klawisz Shift, wnioskowanie niebieskie zostanie zablokowane.
Shift + Alt (Windows) lub Shift + Command (MacOS) Przytrzymanie klawisza Shift, aby zablokować płaszczyznę rysowania, blokuje również narzędzie w odniesieniu do tej samej płaszczyzny, której dotyczy wnioskowanie. W przypadku narzędzi Rotate (Obróć) i Protractor (Kątomierz) można nacisnąć klawisz Alt (Microsoft Windows) lub Command (madOS), aby zwolnić blokowanie tych narzędzi i przenieść środek w inne miejsce w modelu, zachowując tę samą płaszczyznę rysowania.

Niektóre narzędzia, takie jak Circle (Okrąg) i Rotate (Obróć), można zablokować w odniesieniu do płaszczyzny (zamiast do kierunku rysowania), jak pokazano poniżej. W przypadku tych narzędzi płaszczyznę rysowania można zablokować, wybierając kolorowy kierunek osi narzędzia lub „normalny”.

Blokowanie płaszczyzny rysowania za pomocą klawiszy strzałek

Wyrównywanie krawędzi względem osi

Aby upewnić się, że krawędzie są wyrównane do osi, można zmienić kolor kursora na kolor osi. Można też zmienić kolor krawędzi na kolor osi, aby sprawdzić wyrównanie istniejącej geometrii.

Aby zmienić kolor kursora na kolor osi, wykonaj następujące kroki:

  • Wybierz polecenie Window (Okno) > Preferences (Preferencje) w systemie Microsoft Windows lub SketchUp > Preferences (Preferencje) w systemie macOS. Zostanie wyświetlone okno dialogowe „SketchUp Preferences” (Preferencje programu SketchUp).
  • Wybierz element Drawing (Rysunek) po lewej stronie.
  • W obszarze Miscellaneous (Różne) panelu Drawing (Rysunek) zaznacz pole wyboru Display cross hairs (Wyświetl krzyż nitkowy).
  • Kliknij przycisk OK, aby zamknąć okno dialogowe SketchUp Preferences (Preferencje programu SketchUp). Kursor wyświetla krzyż nitkowy w kolorze osi, jak pokazano tutaj.

Aby krawędzie w modelu odzwierciedlały kolor osi, do której są wyrównane, wykonaj następujące czynności:

  1. Wybierz polecenie Window (Okno) > Styles (Style).
  2. W oknie dialogowym Styles (Style) wybierz opcję In Model (W modelu) z rozwijanej listy bibliotek stylów.
  3. Kliknij kartę Edit (Edytuj).
  4. Kliknij pokazaną na ilustracji ikonę Edge Settings (Ustawienia krawędzi).
  5. Z listy rozwijanej Color (Kolor) wybierz polecenie By axis (Według osi). Kolory krawędzi w modelu zmieniają się, aby odzwierciedlić ich wyrównanie do osi (chyba że krawędź nie jest wyrównana do osi, a wtedy kolor krawędzi się nie zmienia). Poniższa ilustracja pokazuje, które krawędzie są (i nie są) wyrównane względem trzech osi.