Skip to Content
Help

업데이트 후 마이그레이션

최종 업데이트: 11월 2, 2026•3 분 읽음.

SketchUp을 새 버전으로 업데이트할 때 이전 설치에서 여러 설정과 사용자 지정을 마이그레이션할 수 있습니다. 

파일 마이그레이션

지원되는 버전의 SketchUp으로 만든 SketchUp 파일(.skp)에는 버전 정보가 없습니다. 이전에 지원되는 SketchUp 버전으로 생성한 모델을 Trimble Connect에 저장하면 SketchUp이 해당 모델에 있는 모든 분류, 컴포넌트, 재료, 스타일을 유지하고 통합합니다. 

각 요소를 수동으로 마이그레이션하려면 다음 단계를 따르세요.

새 버전을 설치하기 전에:

  1. SketchUp에서 Windows의 경우 Window > Preferences(Window > 기본 설정)를, MacOS의 경우 SketchUp Preferences(SketchUp 기본 설정)를 클릭합니다.

  2. Files(파일) 섹션으로 이동합니다.

  3. 새 버전으로 마이그레이션하려는 각 파일 형식을 엽니다.

  4. Explorer(탐색기) 또는 Finder 창에서 파일을 복사하고 찾기 쉬운 위치에 저장합니다.

새 버전을 설치한 후에:

  1. 복사한 파일의 위치를 지정합니다.

  2. SketchUp 새 버전을 열고 Preferences(기본 설정)를 엽니다.

  3. Files(파일) 섹션으로 이동합니다.

  4. 복사한 파일을 새 버전의 Files(파일) 대화 상자에 붙여 넣습니다.

Extension Migrator

Extension Migrator는 Extension Warehouse에서 제공되며 SketchUp에 기본적으로 포함되어 있습니다. Extension Migrator를 사용하면 확장 프로그램을 지원되는 SketchUp 이전 버전에서 새 버전으로 마이그레이션하는 데 유용합니다.

SketchUp을 업데이트하면 애플리케이션을 처음 실행할 때 마이그레이션을 진행하라는 메시지가 표시됩니다. 또한 Extension Migrator는 Migrate Preferences(기본 설정 마이그레이션) 유틸리티를 실행하여, 지원되는 이전 버전에서 기본 설정을 전송합니다. 확장 프로그램을 수동으로 실행해야 하는 경우 다음 단계를 따르세요.

  1. Extensions > Migrate Extensions(확장 프로그램 > 확장 프로그램 마이그레이션)를 클릭합니다.

  2. 표시되는 창에서 옵션을 사용해 장치에서 확장 프로그램 폴더를 검색합니다.

    migrate extensions popup window.png
  3. Next(다음)를 클릭합니다. 그러면 Extension Migrator가 해당 확장 프로그램을 모두 SketchUp 새 버전으로 가져옵니다.

  4. SketchUp을 다시 시작합니다.

기본 설정 마이그레이션

Migrate Preferences(기본 설정 마이그레이션) 유틸리티는 기본 설정에서 사용자 지정된 모든 설정을 빠르고 효율적으로 전송합니다. Extension Migrator를 실행할 때 기본 설정을 마이그레이션하도록 선택할 수 있습니다. 확장 프로그램을 이미 마이그레이션했지만 기본 설정은 마이그레이션하지 않은 경우 File(파일) 메뉴에서 Migrate Preferences(기본 설정 마이그레이션)를 실행할 수 있습니다.

desktop migrate preferences.jpeg

이 툴을 실행하면 기본 설정을 마이그레이션하려는 SketchUp 버전을 선택하라는 메시지가 표시됩니다. 버전을 선택한 후 Migrate(마이그레이션)를 클릭합니다. Migrate Preferences(기본 설정 마이그레이션)를 실행한 후 SketchUp을 다시 시작합니다.

이전 재료 라이브러리 찾기

SketchUp 2025에는 3D Warehouse의 SketchUp 재료 라이브러리가 확장되는 것은 물론, 새로운 기본 재료 라이브러리 세트가 도입되었습니다. SketchUp의 이전 버전에서 사용한 기존 재료 라이브러리에 액세스하여 모음으로 저장하려면 다음 단계를 따르세요.

Windows

  1. 파일 탐색기를 엽니다.

  2. C:\ProgramData\SketchUp\SketchUp[Version Number]\SketchUp\Materials로 이동합니다.

  3. 보관할 폴더를 기억하기 쉬운 위치에 저장합니다.

  4. 새 버전의 SketchUp에서 Materials(재료) 패널을 엽니다.

  5. Details(세부 정보)(icon details.png)를 클릭합니다.
  6. Add collection to favorites(즐겨찾기에 모음 추가)를 클릭합니다.

  7. 기존 재료를 저장한 폴더를 찾아서 Select Folder(폴더 선택)를 클릭합니다. 모음 목록에 새 모음이 계속해서 표시될 것입니다.

MacOS

  1. Finder를 엽니다. 이전에 설치한 SketchUp 버전으로 이동합니다.

  2. Finder에서 SketchUp 애플리케이션을 마우스 오른쪽 버튼으로 클릭하고 Show Package Contents(패키지 콘텐츠 표시)를 선택합니다.

  3. ~/SketchUp/Contents>Resources>Content>Materials로 이동합니다.

  4. SketchUp에서 계속 사용하고자 하는 개별 재료 모음 폴더를 복사합니다.

  5. 새 버전의 SketchUp에서 SketchUp > Settings(SketchUp > 설정)를 클릭하여 SketchUp 기본 설정을 엽니다.

  6. Files(파일) 섹션에서 Materials(재료) 옆에 있는 Open This Folder in Finder(Finder에서 이 폴더 열기)를 클릭합니다.

  7. 이때 열리는 Finder 창에 복사한 폴더를 붙여 넣습니다.

  8. 이제 SketchUp에서 Colors(색상) 패널에 해당 모음을 포함합니다.