绘图基础和概念简介

绘制 3D 模型与绘制 2D 图像是不同的。本绘画基础和概念简介介绍了多种创建边和面的方法。对于任何 SketchUp 模型而言,边和面都是基本的实体。此外,您还将了解 SketchUp 推导引擎如何帮助您在所需轴上放置这些线条和面。

提示:基本形状工具绘出的是细实线。要绘出虚线,请参见将虚线应用于图层

绘制一条直线

直线工具可用来绘制边(也称为“线条实体”)。边构成所有模型的结构基础。以下是绘制直线的方法:

  1. 从工具栏中选择直线工具 () 或按 L 键。此时光标将变为铅笔。
  2. 单击设定直线的起始点。如果点击了错误的位置,请按 Esc 键重新开始。当您在绘图区域移动光标时,请注意以下几点:
    • 光标后面会出现一条线。
    • 测量方框中将动态显示直线长度。(测量方框会使用模板中指定的单位。)
    • 当光标后出现的线条与红色轴、绿色轴或蓝色轴平行时,该线条会变成相应的红色、绿色或蓝色。如果您将鼠标悬停片刻,则会出现一个屏幕提示,例如图中所示的“在蓝色轴上”提示。您的机器中并没有什么魔法,而是 SketchUp 推导引擎的作用。本文稍后会详细加以介绍。
  3. 单击设置直线的终止点。此终止点也可以是另一条直线的起始点。完成直线绘制后,按 Esc 或选择其他工具。设置终止点后,您可以按 Ctrl + Z (Microsoft Windows) 或 Command + Z (macOS) 撤消您的直线并重新开始。

  4. (可选)要为直线设置精确的长度,请输入一个值,然后按 Enter (Microsoft Windows) 或 Return (macOS)。您可以根据需要多次重复此过程,直至您绘制新的直线或选择其他工具。如果您没有指定单位,SketchUp 会使用模板中指定的单位。但您可以为直线输入任何英制或公制单位。例如,您可以输入 3mm5'2”。输入时,您的值将出现在测量方框中。

注意:对于直线,测量方框也接受 3D 坐标:
  • 绝对坐标,例如 [3’, 5’, 7’],设定了直线终止点相对于当前坐标轴的位置。方括号表示绝对坐标。
  • 相对坐标,例如 <1.5m, 4m, 2.75m>,设定了直线终止点相对于直线起始点的位置。尖括号表示相对坐标。

只要直线未组成面,您就可以编辑该直线的长度。以下是编辑直线的方法:

  1. 选择移动工具 ()。
  2. 将移动工具光标悬停在直线的一个终止点上。
  3. 单击并拖动该终止点以更改直线的长度。

提示:您也可以在“实体信息”对话框中调整直线长度。右键单击直线,从出现的菜单中选择实体信息。在“长度”方框中,输入新的直线长度。

创建面

当您将多个直线连接成一个形状时,它们即构成一个面。

这个面不是指滑稽的面孔,也不是指可怕的小丑面孔,更不是指可爱的小狗面孔。默认情况下,这些面都是平的,但却很重要,它们是指构成任何 SketchUp 模型的边和面中的面。

提示:默认情况下,SketchUp 会给某些面添加阴影(如下图所示)且这些面是不透明的,确保您知道在模型中哪些是实际的墙体、地板或这些面在 3D 模型中代表什么含义。(不过,SketchUp 包含了一个视图,可让您看穿墙壁,就像超人一样。有关详细信息,请参见查看模型。)

形状工具(矩形、圆形和多边形)也可以创建面。(有关这些工具的详细信息,请参见绘制基本形状。)

分割面

在现有面上绘制一条直线(或一条曲线)时,便会拆分该面。

提示:这个概念很重要,因为在拆分面之后,您可以使用“推/拉”工具来推或拉这个面的一部分,并保持其他部分不动,如下图所示。有关“推/拉”工具的详细信息,请参见“将形状推拉至 3D”。

通过擦除边和面来打开 3D 形状

您可以通过擦除边或面,为形状建立开口。若想查看擦除边会对您的模型产生何种影响,请先选择橡皮擦工具 () 或按 E 键,然后单击该边:

  • 单击边会擦除该边以及所有接触该边的面。这就有点像 Billy Idol 在歌中所唱的,线可以不依赖于面而存在,但是面却必须由线构成。
  • 右键单击一个面,然后选择“擦除”可仅删除这个面。

在下图中,您可以看到原始的立方体,以及擦除边或面后给立方体带来何种变化。

提示:如果您想隐藏直线而不是擦除直线,请在使用橡皮擦单击该直线时按住 Shift 键。您也可以右键单击该直线,然后选择“隐藏”。

恢复已删除的面

如果您不小心删除了一个面,则可按以下步骤进行恢复:

  • 如果您尚未进行任何其他想要保留的更改,则只需从菜单栏中选择编辑 > 撤消。您也可以按以下键盘快捷键来执行撤消操作:Ctrl + Z (Microsoft Windows) 或 Command + Z (macOS)。
  • 重新绘制导致面消失的直线,SketchUp 将重新创建这些面。

查找并锁定推导

SketchUp 提供推导引擎,可帮助您在 3D 空间中绘图。例如,当直线工具光标悬停在另一条直线的中点时,推导引擎将通过一个浅蓝色的点和显示“中点”字样的屏幕提示来通知您,如下图所示。每个推导都有它自己的颜色和屏幕提示。(有关完整列表,请参见了解您的推导类型。)

推导引擎还可以帮助您找到直线之间的几何关系。例如,当绘制的直线垂直于另一条直线时,它就会告诉您。在下图中,请注意这条直线的起始点上也显示了一个彩色的点,同时还向您提供了一些信息。

警告:请密切注意推导引擎并时不时进行环绕观察,从不同的角度检查您的绘图。在下图中,这些直线看起来像在红色和绿色平面上,但在环绕观察后,您就会发现不同的视图。为了避免这种常见的陷阱,SketchUp 会在您创建与坐标轴平行的边或平面时,改变绘图的方向或将平面绘制为红色、绿色或蓝色(如果与模型中的边或面平行/垂直,则为洋红色)。

提示:有时,您需要的推导可能不会立即出现,或者 SketchUp 可能会选择错误的几何体进行对齐。在这类情况下,您可以将鼠标光标悬停在您希望 SketchUp 推导的位置上来鼓励推导或提升特定对齐的机会。当视觉提示出现时,SketchUp 会在您继续绘制时简要地确定该对齐的优先次序。

切换线性推导

新功能!- SketchUp 2020.2

推导是 SketchUp 的一项重要功能,大多数工具都在某种程度上依赖于这项功能。但推导有时也会给您带来困扰,尤其是在模型的繁忙区域绘图时。您可以通过直线工具,使用简单的修饰键操作来关闭和恢复线性推导。

要在直线工具中切换线性推导,您需要单击一次来开启直线绘制。在开始绘制直线之后,但在点击完成该直线之前,只需在 Mac 中按下 COMMAND 键,或在 Windows 中按下 ALT 键,即可切换以下状态:

  • 开启所有推导
  • 关闭所有推导
  • 仅开启平行和垂直推导

开启所有推导

此为 SketchUp 从第 1 版起就已提供的默认行为。直线工具将捕捉红色轴、绿色轴、蓝色轴以及洋红色轴(当平行/垂直于指定的边时)。

关闭所有推导

在这种状态下,直线工具将忽略所有的线性推导。注意,当您完成边的线段时,光标将在屏幕上更自由地移动。另请注意,您仍可发现其他推导类型,如在面上、引导点、中点等等。使用这些推导类型来确保在您想要的平面上绘制直线。

仅开启平行和垂直推导

在使用直线工具时,此状态只显示平行和垂直的线性推导。选择此选项将允许您绘制直线,确保它平行或垂直于其他几何体,而不会被其他可能影响该直线的线性推导所干扰。

使用键盘锁定推导

通过锁定推导,您可以放心地沿着您计划绘制的方向绘图。锁定推导的另一个原因是,当您从模型的另一部分引用几何体时,确保维持一个绘制方向。这是一个更为高级的操作,但非常有用。将推导锁定到默认轴方向的最简单方法是使用箭头键:

>

使用箭头键锁定绘图方向
定义
将绘图方向或绘图平面锁定在蓝色轴上
将绘图方向或绘图平面锁定在绿色轴上
将绘图方向或绘图平面锁定在红色轴上。记住从左到右的一个简单说法是“右锁红”。
切换以将平行/垂直的绘图方向或绘图平面锁定到推导的边或面,即基本上任何会变成洋红色的实体。绘图方向以及被推导的面的边将会变成洋红色。
Shift 将绘图方向或绘图平面锁定在活动绘图方向/平面上。如果您沿着蓝色轴绘制并按住 Shift,蓝色推导将会被锁定。
Shift+Alt (Windows) 或 Shift + Command (MacOS) 按住 shift 键可锁定绘图平面,也会将工具锁定到所推导的同一平面上。但是,对于旋转和量角器工具,按 Alt 键 (Microsoft Windows) 或 Command 键 (madOS) 可释放这些工具,这样您就可以在保持同一绘图平面的同时将中心移动到模型的另一个位置

有些工具,比如圆形工具和旋转工具,可以锁定到一个平面(但不是绘图方向),如下图所示。对于这些工具,您可以通过选择工具轴或“法线”的彩色方向来锁定绘图平面。

使用箭头键锁定绘图平面

确保边与轴对齐

为了确保边与轴对齐,将光标更改为轴的颜色可能会有所帮助。如果您需要检查现有几何体是否对齐,也可以将边更改为轴的颜色。

要将光标更改为轴的颜色,请按照以下步骤操作:

  • 选择窗口 > 首选项 (Microsoft Windows) 或 SketchUp > 首选项 (macOS)。此时将显示“SketchUp 首选项”对话框。
  • 选择左侧的绘图菜单项。
  • 在“绘图”面板的“杂项”区域中,选中显示十字准线复选框。
  • 单击确定,关闭“SketchUp 首选项”对话框。光标将显示与轴颜色相同的十字准线,如下图所示。

要让模型中的边反映其对齐的轴的颜色,请按照以下步骤操作:

  1. 选择窗口 > 样式
  2. 在“样式”对话框中,从样式库的下拉列表中选择在模型中
  3. 单击编辑选项卡。
  4. 单击边设置图标,如图所示。
  5. 从“颜色”下拉列表中,选择按轴。模型中边的颜色会发生改变,以反映它们与轴的对齐情况(若边没有与轴对齐,则边的颜色将不会改变)。下图显示了哪些边与(或不与)三条轴对齐。