SketchUp Help Center

How Can We Help?

Customizing Toolbars and Menus

Some things are perfect just as they are: clouds, your grandmother’s buttery homemade mashed potatoes, your favorite pair of jeans (which have stretched so they still fit after you eat those mashed potatoes). Toolbars and menus rarely make this list.

LayOut’s default toolbar is designed to help you start using the application, but after you use LayOut for a while, you may want to customize the default toolbar or create your own toolbars. For example, you can

  • Add a command or tool that you use all the time to the default toolbar.
  • Remove a tool you rarely use.
  • Create your own toolbars so that the tools you need for different workflows are there when you need them, hidden when you don’t.
  • Make the toolbar icons appear larger or smaller.

You can also make a few changes in the way menus and menu options appear. The following sections explain how to customize your toolbars and menus and what all the options do.

Table of Contents
  1. Customizing a toolbar
  2. Creating a new toolbar (Microsoft Windows)
  3. Setting toolbar options
  4. Setting menu options

Customizing a toolbar

To add, remove, or reorder tools on any toolbar, follow these steps, which reflect your current operating system (Microsoft Windows or Mac OS X):

  1. Make sure the toolbar you want to customize is displayed. When you select View > Toolbars, a check mark appears next to each displayed toolbar. If a toolbar isn’t displayed, select its name to display it.
  2. From the menu bar, select View > Toolbars > Customize. Or click the Toolbar Options drop-down menu (the down arrow at the end of each toolbar) and select Add or Remove Buttons > Customize. Either way, the Customize dialog box appears.
  3. Click the Commands tab, which displays a list of tools that you can add to a toolbar, as shown in the following figure. If you want to remove or move a tool, skip to Step 4.
  4. (Optional) By default, the All Commands option is selected in the Categories list. However, you can narrow down the tools displayed in the Commands list by selecting a category in the Categories list. For example, select Arrange in the Categories list to display only the arranging commands in the Commands list.
  5. Do any of the following:
    • Add a tool: Drag a tool or command from the Commands list to the toolbar. An insertion cursor indicates where the tool or command will appear on the toolbar when you release the mouse button.
    • Remove a tool: Drag a tool off the toolbar.
    • Move a tool: In the toolbar, drag any tool to a new location within the toolbar.
    • Copy a tool from one toolbar to another: In the toolbar, while pressing the CTRL key, drag any tool to a new location within the toolbar.
    • If you mess up a toolbar, you can select that toolbar in the "Toolbars..." dialog listing, and click the "Reset" button.

Note: A tool can appear on only one toolbar.
In the Customize dialog box, use the Commands tab to customize toolbars in LayOut.

Tip: To quickly hide a tool that’s already on a toolbar, click the Toolbar Options drop-down menu (the down arrow at the end of each toolbar), select Add or Remove Buttons and then the toolbar name, and deselect the tool you want to hide from the list. To display the tool again, simply select its name from the list. A check mark appears next to the name of each displayed tool.

To reset the default toolbar to its original tool set, select Toolbar Options > Add or Remove Buttons > Main Toolbar > Reset Toolbar, or on the Customize dialog box’s Toolbars tab, select Main Toolbar and click the Reset button.

  1. From the menu bar, select View > Customize Toolbar. The customize dialog box appears, as shown in the following figure.
  2. Do any of the following:
    • Add a tool: Drag a tool from the dialog box to the toolbar. The existing tools make room wherever the tool or command will appear on the toolbar when you release the mouse button.
    • Remove a tool: Drag a tool off the toolbar.
    • Move a tool: In the toolbar, drag any tool to a new location within the toolbar.

Tip: To reset the default toolbar, drag the default set from the bottom of the dialog box to the toolbar. To hide the toolbar altogether, select View > Hide Toolbar.
Drag tools you want to add to LayOuts default toolbar

Creating a new toolbar (Microsoft Windows)

If you use LayOut for Microsoft Windows, you can create your own toolbars. Here’s how:

  1. From the menu bar, select View > Toolbars > Customize. Or from the Toolbar Options drop-down list, select Add or Remove Buttons > Customize. Either way, the Customize dialog box appears.
  2. On the Toolbars tab, click the New button. The New Toolbar dialog box appears, as shown in the following figure.
    In LayOut, name your new toolbar in the New Toolbar dialog box.
  3. In the Toolbar Name box, type a name for the toolbar. For example, to create a toolbar for arranging and grouping items in the drawing area, you might name the toolbar Arrange and Group.
  4. (Optional) From the Location drop-down list, select whether you want the toolbar to be docked at the top (like the default toolbar), bottom, or right of the interface or just float in its own box.
  5. Click OK. Back in the Customize dialog box, the new toolbar appears in the Toolbars list on the Toolbars tab.
  6. Click the Commands tab and drag tools from the Commands list to the new toolbar.

    Tip: The new, empty toolbar may be hard to see. Look for its small gray move handle in the location you selected. For example, if your toolbar is docked at the top, you see the handle directly under the default toolbar, as shown in the following figure. After you place one tool on the new toolbar, it’s easier to see.
    Look for a new toolbars gray move handle.

Note: A tool can appear on only one toolbar.

Tip: After you create a toolbar, you can select it in the Customize dialog box’s Toolbars tab and rename, delete, or reset it. Click the Rename button to change the custom toolbar’s name. Click the Delete button to delete the selected toolbar. Click Reset to remove any customizations made to the toolbar.

Setting toolbar options

LayOut enables you to customize the toolbar appearance, with options such as large or small icons. (The available options are different on the Microsoft Windows and Mac OS X operating systems.)

The following steps, which reflect your current operating system, explain how to find your options.

  1. From the menu bar, select View > Toolbars > Customize. Or from the Toolbar Options drop-down list, select Add or Remove Buttons > Customize. Either way, the Customize dialog box appears.
  2. Click the Options tab, shown in the following figure.
  3. Select your desired options.
  4. When you’re done, click the Close button.
In LayOut for Microsoft Windows, you can select toolbar options on the Customize dialog boxs Options tab.

On Microsoft Windows, your toolbar options include the following:

  • Large Icons on Toolbars: LayOut displays large icons by default. To see small icons, deselect this checkbox.
  • Show ScreenTips on Toolbars: This option tells LayOut whether to display a tool’s name in a ScreenTip when you hover your mouse cursor over the tool. ScreenTips appear by default (because they’re pretty handy), but you can deselect this checkbox to make the ScreenTips go away.
  • Show Shortcut Keys in ScreenTips: When you select this checkbox, the keyboard shortcut assigned to the tool appears in the ScreenTip.
  • Floating Toolbar Fade Delay: Click the up or down arrows to increase or decrease the toolbar fade delay accordingly. The fade delay applies to a toolbar that has been undocked or moved away from its default location in LayOut.
  1. Select View > Customize Toolbar. The customize dialog box appears.
  2. Select your desired options at the bottom of the dialog box.
  3. When you’re finished, click Done.

On Mac OS X, your toolbar options include the following:

  • Show: From the drop-down list, you can select Icon Only (the default), Icon and Text, or Text Only.
  • Use Small Size: Select this checkbox if you want the toolbar to display small icons instead of large icons.

If you use LayOut for Microsoft Windows, you can choose a few options for how menus appear. To find the options, select View > Toolbars > Customize. Or from the Toolbar Options drop-down list, select Add or Remove Buttons > Customize. Either way, the Customize dialog box appears.

In the dialog box, you have the following menu options:

  • Always Show Full Menus: Select this checkbox to display all menu items when you click on a menu heading.
  • Show Full Menus After a Short Delay: By default, all menu items appear after a short delay. Deselect this checkbox to eliminate the delay.
  • Large Icons on Menus: By default, you see small icons on menus. Select this checkbox to display large icons instead.
  • Menu Animations: Select a menu animation to apply an animation effect to menus when you select a menu. Your options are None (the default), Random, Unfold, Slide, and Fade.
OS:

Need Help Fast?

SketchUp’s outstanding community of passionate experts have answers to your questions.