SketchUp Help Center

How Can We Help?

Typing, Importing, or Auto-Inserting Text

Although documents tend to include more visual elements than text, you likely want a little text to add headings, bullet points, or other text to your document.

In LayOut, you use the Text tool () to type text into a bounded or unbounded text box. Or you can import text that’s in a .txt or .rtf file. LayOut 2014 introduced Auto-Text, which can add your company name, the current date, or other predefined text anywhere you insert an Auto-Text tag.

In the following sections, you find out how all these text options work.

Tip: LayOut also has a Label tool and dimensions tools for adding labels with arrows and dimensions. Both labels and dimensions can automatically pick up details from to SketchUp model entities.
Table of Contents
  1. Typing into a bounded or unbounded text box
  2. Importing text into LayOut
  3. Inserting and customizing Auto-Text tags
  4. Customizing Auto-Text tags

Typing into a bounded or unbounded text box

You can type any text you like right into your document. In LayOut, the Text tool can create either a bounded or unbounded text box:

  • A bounded text box stays the same size, no matter how much text you type, but the text wraps automatically when the text reaches the end of the box. If you write a short novella, or the text simply exceeds the size of the box, some text is hidden and a red arrow appears in the lower-left corner of the text box, as shown in the following figure. To see all the hidden text, select the text box and drag out a side or corner until all the text appears inside the bounded box.

    Note: You can toggle the display of the clipped text warning arrows so that they're hidden. Select View > Warning Symbols > Clipped Text. When the clipped text warnings are hidden, no check mark appears next to the Clipped Text option on the menu.
  • An unbounded text box grows to accommodate all the text you type. However, text doesn’t wrap as you type; you have to press Enter to start a new line. Otherwise, the text just extends off the edge of the drawing area, as shown in the following figure.
In LayOut, you can create a bounded or unbounded text box.

To start making text boxes, simply follow these steps:

  1. Select the Text tool () from the default toolbar or by selecting Tools > Text.
  2. To create a bounded text box, click and drag to draw the size of the box and then release the mouse button. To create an unbounded text box, simply click where you want to start typing text.
  3. Type your text.
  4. Click outside the text box when you’re done typing.

Tip: You can press Esc anytime to abandon the text box and start over. To fix any typos, select the Select tool (), double-click the text box, and a text cursor appears, enabling you to edit the text.

When you draw a bounded text box, you can set the text’s vertical and horizontal alignment, too. The following table outlines your options. You can also format text later, using the Text Style panel, as explained in Formatting Text.

To Align Text Like This… Here’s How to Draw the Bounded Text Box
Top- and left-aligned Drag from top left to bottom right.
Top- and right-aligned Drag from top right to bottom left.
Bottom- and left-aligned Drag from bottom left to top right.
Botton- and right-aligned Drag from bottom right to top left.
Center aligned Hold down Ctrl (Microsoft Windows) or Option (Mac OS X) while dragging from center.

Importing text into LayOut

Typing right into a document isn’t always a great idea, especially if the text is already typed, proofread, and ready to insert into your document. Why redo all that work?

LayOut enables you to import text in Rich Text Format (an .rtf file) or plain text format (a .txt file). If your text is in a different format, most word-processing programs enable you to save a file to either of these formats.

When your text is ready to import, follow these steps:

  1. Select File > Insert. An Open dialog box appears.
  2. Navigate to the text file you want to import.

    Tip: In Microsoft Windows, to see only those text files that are compatible with LayOut, you can select Plain Text or RTF Text from the drop-down menu to the right of the File Name box. On Mac OS X, incompatible files are grayed out in the Open dialog box.
  3. Select the .rtf or .txt file, and click Open. The text of your document appears in the document area, as shown in the following figure.
In LayOut, you can import a Rich Text Format or plain text document into the drawing area.

Inserting Auto-Text tags

LayOut’s Auto-Text feature inserts text like the date, a page number, or custom text you define.

Tip: Use Auto-Text tags to improve accuracy and save yourself a little repetitive work.

To take advantage of Auto-Text, insert an Auto-Text tag that corresponds to the text you want to appear in your document. Just follow these steps:

  1. Select the Text tool from the default toolbar or by selecting Tools > Text from the menu bar.
  2. In the document area, click where you want to insert the Auto-Text tag.
  3. From the menu bar, select Text > Insert Auto-Text and then select a tag from the submenu that appears. The tag you select is inserted into the document area. Alternately, you can type the tag name, such as <PageNumber> and press Enter.
  4. Click outside the text area, and the Auto-Text tag displays the text that your audience will see in the document area.

Customizing Auto-Text tags

You can customize the preset tags or create your own Auto-Text tags in the Document Setup dialog box. For example, you can customize the <Company> tag with your company’s name, or create a custom tag for a specific project.

To customize a preset Auto-Text tag, follow these steps:

  1. Select File > Document Setup or Text > Customize Auto-Text from the menu bar. Either command opens the Document Setup dialog box.
  2. In the Document Setup dialog box, make sure Auto-Text is selected in the sidebar on the left.
  3. From the list of tags at the top, select the tag you want to customize.
  4. In the Settings For: TagName area at the bottom of the dialog box, do one of the following, depending on the type of tag you select:
    • Type the text that you want to appear wherever you insert the selected tag.
    • Select the page number style and start page.
    • Replace the date code in the Date Format box with your own settings. To do so, select the existing date code, click the + button (that is, the plus sign) next to the Date Format box, and select an option from the menu that appears. Insert as many date codes as you like, and type a comma or other separator if needed. The menu shows you examples of what each date code means.
  5. When you’re done, click the Close button.

To create a new Auto-Text tag, follow these steps:

  1. Click the + button (the plus sign) below the list of tags in the Document Setup dialog box, and from the menu that appears, select the type of tag you want to add. See the following list for details about your options. After you select an option, a new tag is highlighted in the list of tags at the top of the Document Setup Auto-Text pane.
  2. Type a name for the new tag, such as ProjectName, and press Enter. By default, the tag is called <NewTag1> or something similar, but that won’t help you remember what text the tag inserts, although the Auto-Text column next to the tag name does display a preview.
  3. In the Settings For: TagName area, use the controls for the type of tag you selected to set the text that the Auto-Text tag inserts.

When you create a new tag, you can choose from the following tag types:

  • File Name: Inserts the current file name.
  • Page Name: Uses page names that appear in the Pages panel. (See Managing and Navigating Pages for details about the Pages panel.)
  • Page Number: Uses the current page number, which is managed in the Pages panel.
  • Custom Text: This text tag can display any text you choose. The text updates in your LayOut document if you change the Auto-Text definition in the Document Setup dialog box.
  • Current Date: Displays today’s date. This tag updates on a daily basis.
  • Date Created: Inserts the date file was first created. This value only changes if you select File > Save As and save the file under a new name.
  • Date Modified: Inserts the last date saved. This tag updates whenever you save your document.
  • Date Published: Inserts the last date your LayOut document was exported or printed. If the document hasn’t been exported or printing, this tag displays Unpublished in your presentation.

Tip: To duplicate a tag, select it from the list of tags and select the Duplicate Selected Tag button. The steps for customizing a duplicated tag are similar to those for creating a new tag. To delete a tag, select it from the list of tags, and click the - button (the minus sign). Just remember that you can’t resurrect the tag after you delete it.
OS:

Need Help Fast?

SketchUp’s outstanding community of passionate experts have answers to your questions.