SketchUp Help Center

How Can We Help?

Creating and Editing a Style

 NOTICE: In observance of the Memorial Day in the U.S., Trimble employees will be home with friends and family on Monday, May 29th. All emails will experience a delayed response during this time.

In SketchUp, you can create and edit styles so that you can apply your preferred style settings with a single click.

Tip: If you want to develop a sketchy edges style, check out Style Builder.

To create a new style, follow these steps:

  1. Open the Styles browser by selecting Window > Styles.Open the Styles panel by toggling it open in the Default Tray. Or select Window > Default Tray > Styles so that the Styles option is selected. Open the Styles browser by selecting Window > Styles.
  2. In the upper right, click the Create New Style button (). SketchUp creates a copy of the currently active style in the In Model styles.
  3. Click the Select tab, click the In Model icon (), and in the list of styles that appears, select your new style so that it’s the active style.
  4. Click the Edit tab, click the Edge Settings icon (), and select your desired edge options.
  5. Click the Face Settings icon () and select your desired face options. The following figure shows the Edge Settings (Callout 1) and the Face Settings (Callout 2). In the following tables, you find a basic illustration and explanation of each setting.

    The Edge settings and Face Settings in SketchUp The Edge settings and Face Settings in SketchUp The Edge settings and Face Settings in SketchUp
    The Edge settings and Face Settings in SketchUp The Edge settings and Face Settings in SketchUp
  6. Select the Background Settings icon (), and choose how you’d like the background to appear. See Customizing a Model’s Background with Styles for details about these settings.
  7. (Optional) If you’d like to include a watermark in your style, click the Watermark Settings icon () and select your options. Your options are explained in Watermarking a Model.
  8. (Optional) Check that visual cues such as selection colors work well with your new style. If needed, you can use the Edit tab's Modeling Settings pane to change the colors for selections and other modeling color cues.
  9. Click the Update Style with Changes button () in the upper right of the Styles browser. If the Update Style with Changes button is grayed out, your style is up-to-date.

Tip: To edit a style (including any predefined style that comes with SketchUp), simply follow Steps 3–8 in the preceding steps.

Note: All the In Model styles are saved with your model; see Managing In Model Styles and Collections for details.
Option Example Good to Know
Edges Toggles the display of edges in your model. The example shows edges toggled on (selected).
Back Edges Displays edges obscured by other edges in your model. Obscured edges appear as dashed lines. When selected, this setting disables the X-Ray face style.
Profiles Emphasizes the outlines of major shapes in your model. This style borrows from a drawing technique that emphasizes the 3D nature of geometry. Enter a thickness, in pixels, for the profile lines.
Depth Cue Emphasizes foreground lines over background lines. Enter a foreground line thickness in pixels.
Extension Extends each line slightly past its endpoint for a hand-drawn appearance. This style does not affect inference behavior. Enter a length, in pixels, for the extension lines.
Endpoints Places additional line thickness at the endpoints of lines. Enter a length, in pixels, for the length of the emphasized endpoints.
Jitter Renders each line multiple times at a slight offset, giving your model hand-drawn sketched appearance. This edge rendering style does not affect inference behavior.
Color: All Same Displays all edges in the color defined in color swatch. This option does not actually change any edge color assignments you may have made, but preserves them if you choose to view them again.
Color: By Material Displays edges with an assigned material color, such as those painted with a color.
Color: By Axis Edges that aren't aligned with an axis are colored with the All Same color swatch. Also, an axis color doesn’t appear on hidden edges.

In the next table, you see all the ways you customize faces’ appearance.

Option Example Good to Know
Front Color, Back Color Sets the default color for all front and back sides of faces. Materials assigned to faces override this setting. Here a face was removed from the cube so that you can see the front color is yellow and the back color is blue.
Style: Wireframe Displays only the model’s lines. Because faces are not displayed, you can’t use face modification tools, such as the Push/Pull tool.
Style: Hidden Line Display faces without any shading or textures. Tip: This option is handy for printing only in black and white.
Style: Shaded Shades faces to simulate a light source.
Style: Shaded Using Textures Displays shading to simulate a light source and any textures applied to a face. Tip: Textures require more memory to render your model. If you experience performance problems, switch to a style without textures.
Style: Shaded Using All Same Displays faces with the default front and back face color.
X-Ray Makes all faces transparent so you can see through your model. Tip: In this mode, you can easily visualize, select, and snap to points and edges that would otherwise be hidden behind faces. However, you can’t select and infer faces that would otherwise be hidden. Faces cannot cast shadows in X-Ray mode, which is different from material transparency.
Enable Transparency Toggles global material transparency on or off.
Transparency Quality Choose among the Faster, Medium, and Nicer options. Choose between the Faster and Nicer option. Each differs in its speed and quality of transparency sorting. Faster sacrifices accuracy to provide faster rendering, whereas Nicer performs additional calculations to correctly display transparent surfaces. Tip: With Nicer selected, you can adjust the X-Ray opacity to create compelling presentation images, such as the one shown in the following figure.
With the edges in a SketchUp 3D model set to x-ray mode, you can adjust the opacity to create compelling images.

Note: X-Ray mode can be very sensitive to z-fighting, which makes overlapping faces flash or appear striped as you orbit. With opaque models, z-fighting only occurs on surfaces you can see. In X-Ray mode, you may see z-fighting on several surfaces. However, static images look quite nice.

Note: With the X-Ray faces mode set to Nicer, you may notice SketchUp running more slowly than when Faster is selected. SketchUp 2017 substantially improves SketchUp’s performance in X-Ray mode. To take advantage of these improvements, buy or upgrade your SketchUp Pro license. For details about buying or upgrading a license, as well as the different types of licenses available, see Buying or Upgrading a License in the SketchUp Make and SketchUp Pro area of the Help Center.
OS:

Need Help Fast?

SketchUp’s outstanding community of passionate experts have answers to your questions.