Skip to Content
Help
April 4, 202424.0.484 Win 64-bit24.0.483 Mac 64-bit

Новые возможности SketchUp 2024

SketchUp для ПК

  • Новый графический механизм — мы усовершенствовали механизм обработки графики в SketchUp! В этом графическом механизме используются преимущества новых аппаратных и программных технологий, что позволяет значительно улучшить навигацию по файлам и увеличить скорость отклика.

  • Ambient Occlusion (Окружающая затененность) — новый стиль граней, который добавляет в модели SketchUp визуальный акцент в местах взаимодействия ребер и граней, что позволяет добиться большей глубины и реалистичности изображения.

  • Trimble Connect и доступ по ссылкам — мы добавили в SketchUp для ПК встроенную интеграцию с Trimble Connect. Trimble Connect позволяет легко делиться ссылками для просмотра ваших моделей и быстро получать доступ к файлам .skp на различных устройствах.

  • Add Location (Добавить местоположение) — этот новый инструмент упрощает добавление точного рельефа в высоком качестве. Мы усовершенствовали процесс работы, добавили стрелку, указывающую на истинный север, и улучшили параметры импорта.

  • Оптимизация импорта и экспорта файлов IFC — импорт файлов IFC в SketchUp стал более быстрым и предсказуемым. Мы также улучшили параметры экспорта в формат IFC-4, чтобы обеспечить согласованность данных и оптимизировать файлы, в частности добавили возможность замощения плоскости правильными многоугольниками и усовершенствовали экспорт компонентов.

  • Функциональная совместимость USDZ и gITF — мы добавили функцию импорта и экспорта файлов USDZ и gITF, которая открывает новые возможности для высококачественной визуализации и обеспечивает совместимость с распространенными отраслевыми инструментами для создания цифрового контента.

  • Scan Essentials Ground Mesh1 (Сетка рельефа в Scan Essentials) — новый инструмент Ground Mesh в плагине Scan Essentials позволяет быстро и легко превратить трехмерное облако точек в точную полигональную сетку рельефа из четырехугольников (квадов), которую можно редактировать и изменять прямо в SketchUp.

  • Диалоговое окно ошибки расширения — теперь в случае проблем с загрузкой расширений при запуске SketchUp появляется новое диалоговое окно с ошибкой. В нем будет указано, какое расширение не открывается. Кроме того, вы сможете сразу же обновить такое расширение (при наличии обновлений) или удалить его.

  • Усовершенствование технологии создания моделей — мы внесли изменения в основные инструменты и функции проектирования, чтобы повысить производительность и оптимизировать ваш творческий процесс.

  • Средство импорта файлов Revit — мы обеспечили совместимость этого инструмента SketchUp с Revit 2024.

LayOut

  • LayoutOut без версий — начиная с версии 24.0 файлы LayOut можно открывать в поддерживаемых версиях LayOut (выпущенных за два года до текущей) без необходимости сохранять их в определенном формате. Это изменение относится ко всем файлам, созданным в 2024 году.

  • Performance (Производительность) — на новой вкладке Performance (Производительность) в разделе Preferences (Параметры) доступен режим Draft Mode (Черновик), который позволяет оптимизировать графику при работе с документом. Кроме того, вы можете воспользоваться экспериментальным графическим механизмом LayOut в рамках программы бета-тестирования [Labs].

  • Ambient Occlusion (Окружающая затененность) — новый стиль граней Ambient Occlusion (Окружающая затененность) распознаётся и отображается в области просмотра LayOut, что позволяет улучшить представление 2D-документации.

  • Улучшенный процесс логического вывода — блокировка выводов в LayOut теперь больше напоминает этот процесс в SketchUp. Кроме того, во время работы с документом LayOut ограничит доступные ориентиры при построении объектами, которые находятся ближе всего к месту последнего щелчка мыши. Это позволяет увеличить скорость отклика при перемещении и копировании объектов.

  • Немасштабируемые метки — для меток больше не отображаются ручки масштабирования, однако их масштаб можно будет изменять после привязки к геометрии LayOut или SketchUp. 

  • Оптимизация экспорта — при экспорте документа теперь можно выбрать сразу несколько диапазонов страниц. Экспортированные материалы теперь содержат не только имя файла, но и номера страниц.

Исправленные ошибки и другие улучшения

SketchUp

Новый графический механизм SketchUp

Что сделано

Мы обновили графический механизм SketchUp! Теперь в нем используются преимущества новых аппаратных и программных технологий, что позволяет существенно улучшить навигацию по файлам и увеличить скорость отклика.

Подробнее

Новый графический механизм SketchUp — это большой шаг вперед. Теперь вы можете пользоваться преимуществами новых аппаратных и программных технологий и сделать процесс проектирования еще более приятным. К заметным улучшениям относятся увеличение частоты кадров в секунду при вращении моделей, оптимизированная управляемость и повышенная отзывчивость. Новый графический механизм демонстрирует различные результаты в зависимости от устройства. В результате проведенных испытаний мы пришли к выводу, что на наиболее распространенных устройствах он работает примерно в 2,4 раза быстрее, чем классический графический механизм SketchUp. Для более мощных устройств скорость обработки повысилась в 8,4 раза (а в некоторых случаях и больше)!

При желании вы можете использовать и предыдущую версию графического механизма SketchUp. Это можно сделать в новом разделе Graphics (Графика) в окне Preferences (Параметры).

24ReleaseNotes1.png

Новый графический механизм поддерживают не все устройства, на которых можно запустить SketchUp для ПК. В таком случае (или если SketchUp обнаружит, что новый механизм будет работать на вашем устройстве медленно или нестабильно) появится уведомление о том, что SketchUp продолжит использовать классический графический механизм.

Подробнее

Чтобы узнать больше о новом графическом механизме и о других настройках в новом разделе Graphics (Графика) в окне Preferences (Параметры), перейдите в раздел Графика (Graphics) нашего Справочного центра.

Окружающая затененность

Что сделано

Ambient Occlusion (Окружающая затененность) — новая настройка стиля, которая добавляет в модели SketchUp визуальный акцент в местах взаимодействия ребер и граней, что позволяет добиться большей глубины и реалистичности изображения.

Подробнее

Ambient Occlusion (Окружающая затененность) — это новая настройка стиля, доступная при использовании нового графического механизма SketchUp. Она использует затенение и рендеринг для создания визуального акцента в местах взаимодействия ребер и граней. Это позволяет добавить в модели воспринимаемую глубину, делая их реалистичнее.

24ReleaseNotes2.png

Подробнее

Функция Ambient Occlusion (Окружающая затененность) — это глобальный параметр стиля, который можно включить через меню View (Вид): View > Face Style > Ambient Occlusion (Вид > Стиль граней > Окружающая затененность) или с помощью функции Search (Поиск). Вы также можете выбрать готовые стили с поддержкой Ambient Occlusion (Окружающая затененность) на панели Styles (Стили) или отрегулировать ползунки настроек окружающей затененности, чтобы создать собственный уникальный стиль на ее основе. Подробную информацию можно найти в статье Выбор стиля (Choosing a Style).

Trimble Connect и доступ по ссылкам

Что сделано

Теперь в SketchUp реализована встроенная интеграция с Trimble Connect. Trimble Connect позволяет легко делиться ссылками для просмотра ваших моделей и получать доступ к файлам .skp в версиях SketchUp для ПК, iPad и интернета.

Подробнее

Trimble Connect — это облачная среда общих данных (CDE) и платформа для совместной работы, предназначенная в первую очередь для строительной отрасли. Ваша подписка на SketchUp включает доступ к Trimble Connect с неограниченным облачным хранилищем. Ранее вы могли получать доступ к Trimble Connect с помощью соответствующего расширения в Extension Warehouse. Мы интегрировали Trimble Connect непосредственно в SketchUp для ПК, устранив необходимость в этом расширении. Мы добавили специальную панель Trimble Connect с базовыми функциями, а в меню File (Файл) доступно еще больше параметров.

24ReleaseNotes3.png

Новая интеграция Trimble Connect позволяет:

  • легко открывать и сохранять файлы в Trimble Connect;

  • отслеживать изменения и просматривать время последнего открытия файлов;

  • быстро перемещать модели между версиями SketchUp для ПК, интернета и iPad;

  • делиться ссылками для просмотра моделей, сохраненных в Trimble Connect.

Подробнее

Дополнительную информацию о том, как максимально эффективно использовать Trimble Connect, можно найти в статье Использование Trimble Connect со SketchUp (Using Trimble Connect with SketchUp).

Добавить местоположение

Что сделано

Новый инструмент «Добавить местоположение» упрощает добавление точного рельефа в высоком качестве. Мы усовершенствовали процесс работы, добавили стрелку, указывающую на истинный север, и улучшили параметры импорта.

Подробнее

Обновленный и улучшенный инструмент Add Location (Добавить местоположение) делает геопривязку модели и импорт подробных данных рельефа более простыми и предсказуемыми, особенно при работе с большими объемами данных.

24ReleaseNotes4.png

В новой версии Add Location (Добавить местоположение) появились следующие возможности:

  • Маркер местоположения, отображение которого можно включать и выключать.

  • Стрелка, указывающая на истинный север, которая позволяет точно ориентировать модель с учетом сторон света (это особенно полезно при имитации света и теней);

  • Полупрозрачный силуэт вашей модели, который помогает увидеть, как именно она вписывается в импортируемый рельеф.

  • Возможность импортировать участки большего размера независимо от их разрешения.

  • Независимая регулировка каждой стороны области выделения.

  • Ползунок, который позволяет настроить плотность сетки рельефа, который вы хотите импортировать.

  • Более высокое качество при импорте средних и крупных объемов данных.

  • Возможность просмотра всех предыдущих импортов при каждом последующем импорте.

  • Оптимизация работы с тегами.

Подробнее

Чтобы узнать больше о том, как работает новая функция Add Location (Добавить местоположение), ознакомьтесь с соответствующими статьями Справочного центра.

Оптимизация импорта и экспорта файлов IFC

Что сделано

Импорт файлов IFC в SketchUp стал более быстрым и предсказуемым. Мы также улучшили параметры экспорта в формат IFC-4, чтобы обеспечить согласованность данных и оптимизировать файлы, в частности добавили возможность замощения плоскости правильными многоугольниками и усовершенствовали экспорт компонентов.

Подробнее

Файлы IFC содержат систему классификации, используемую инструментом «Классификатор» в SketchUp. Мы внесли значительные улучшения в процесс импорта и экспорта файлов IFC, в том числе:

  • теперь можно импортировать файлы IFC со специальными символами, такими как «ã», «ó», «ğ»;

  • можно импортировать текст из языков с неарабскими символами, таких как японский, китайский или греческий;

  • мы также добавили параметр, который сохраняет исходную точку чертежа при импорте.

При экспорте файлов IFC4 в SketchUp теперь доступны дополнительные параметры, в том числе:

  • возможность экспорта замощения плоскости правильными многоугольниками — это позволяет оптимизировать данные и уменьшить файл экспорта вдвое;

  • экспорт атрибутов PredefinedTypes/Object Types; теперь они экспортируются как атрибуты классов;

  • сохранение атрибутов единиц измерения — теперь при экспорте сохраняются такие атрибуты британских и метрических единиц измерения, как Position (Положение) и Size (Размер);

  • экспорт динамических атрибутов — атрибуты из компонентов экспортируются в формат IFC4 как набор свойств PropertySet «SU_DynamicAttributes».

Подробнее

Дополнительные сведения о работе с файлами IFC в SketchUp приводятся в статье Классификация объектов (Classifying Objects).

Функциональная совместимость USDZ и gITF

Что сделано

Мы добавили функцию импорта и экспорта файлов USDZ и gITF, которая открывает новые возможности для высококачественной визуализации и обеспечивает совместимость с распространенными отраслевыми инструментами для создания цифрового контента.

Подробнее

Формат USDZ был разработан компанией Pixar и известен эффективным управлением сложными 3D-сценами и анимацией. Формат gITF называют «JPEG для 3D-файлов». Это надежная среду для передачи и загрузки 3D-моделей. Теперь в SketchUp импортировать и экспортировать оба этих формата, что открывает новые возможности кроссплатформенной совместимости и создания высококачественных 3D-визуализаций.

Подробнее

Подробную информацию можно найти в статье Использование данных SketchUp в других программах или инструментах для моделирования (Using SketchUp Data with Other Modeling Programs or Tools).

Сетка для земли в Scan Essentials

Что сделано

Новый инструмент Ground Mesh (Сетка рельефа) в плагине Scan Essentials позволяет быстро и легко превратить трехмерное облако точек в точную полигональную сетку рельефа из четырехугольников (квадов), которую можно редактировать и изменять прямо в SketchUp. В этом обновлении язык интерфейса Scan Essentials теперь автоматически синхронизируется с выбранным языком самого SketchUp.

Подробнее

Плагин Scan Essentials доступен пользователям с подпиской SketchUp Studio. Благодаря новому инструменту Ground Mesh (Сетка рельефа) в Scan Essentials появились новые способы генерации рельефа из 3D-облака точек: методы Fit Cloud (По облаку), Rectangular (Прямоугольный) или Bounded (Ограниченный).

При использовании метода Fit Cloud (Подогнать под облако) сетка будет подогнана под отсканированные данные рельефа и автоматически заполнит пустоты.

24ReleaseNotes6.png

При использовании метода Rectangular (Прямоугольный) вы можете выделить прямоугольную область на ваших данных сканирования, чтобы на ее основе построить сетку земли.

24ReleaseNotes7.png

Метод Bounded (Ограниченный) создает сетку рельефа, которая точно проецируется на выбранную грань в вашей модели.

24ReleaseNotes8.png

Подробнее

Подробную информацию о том, как работать с новым инструментом Ground Mesh (Сетка рельефа) и другими функциями для эффективного использования данных облака точек в моделях SketchUp, можно найти в статье Использование Scan Essentials (Using Scan Essentials).

Диалоговое окно ошибки расширения

Что сделано

Если при запуске SketchUp какое-либо из ваших расширений не удается загрузить, теперь на экране появится новое диалоговое окно ошибки. Оно поможет определить, какое именно расширение дало сбой, обновить его (если доступен апдейт) или удалить.

Подробнее

Расширения — это отличный способ настроить SketchUp в соответствии со своими потребностями и расширить возможности программы. К сожалению, иногда расширения не загружаются (обычно из-за того, что они немного устарели). Чтобы сделать работу в SketchUp более стабильной, при обнаружении ошибки расширений при запуске программы будет появляться такое сообщение об ошибке:

24ReleaseNotes9.png

При возникновении такой ошибки SketchUp автоматически проверяет каталог Extension Warehouse на наличие обновлений для проблемного расширения. После этого вы сможете просмотреть подробную информацию об ошибке, скопировать ее, а также обновить, отключить или полностью удалить данное расширение.

Подробнее

Дополнительные сведения о том, как устранять подобные неполадки, можно найти в статье Ошибки расширений (Extension Errors) в разделе «Устранение неполадок» (Troubleshooting) Справочного центра.

Усовершенствование технологии создания моделей

Что сделано

Мы внесли изменения в основные инструменты и функции проектирования, чтобы повысить производительность и оптимизировать ваш творческий процесс.

Подробнее

В этом обновлении мы также постарались улучшить часть основных инструментов SketchUp и встроенные функции для создания моделей. Ниже приводится краткий список изменений.

  • Ручки вращения инструмента Move (Перемещение). Теперь в разделе Drawing (Рисование) окна Preferences (Параметры) можно выключать или включать ручки поворота инструмента Move (Перемещение), чтобы ограничить визуальный шум и упростить работу с этим инструментом. Мы также добавили ярлык для этого нового параметра.

  • Отмена операции в процессе ее выполнения. Теперь при отмене операции отменяется текущее действие, а предыдущая операция остается без изменений.

  • Логический вывод по направляющим. Иногда вывод по направляющим был невозможен при проведении линии от объекта к направляющей. Теперь при рисовании можно более эффективно использовать направляющие в качестве логического вывода.

  • Логический вывод прямоугольника. При рисовании прямоугольника на грани теперь можно делать выведение по ребрам этой грани, то есть прямоугольник можно выровнять по любому ребру в той же плоскости, что и грань, на которой его рисуют.

  • Логический вывод приставной лестницы. Эта новая функция отображает символ «X», когда геометрический объект, который вы вращаете, пересекает грань, к которой вы «прислоняетесь» (как если бы вы приставляли лестницу к стене).

  • Несохраненные изменения* (Windows) — теперь в операционной системе Windows при наличии несохраненных изменений модели рядом с именем файла в строке заголовка окна будет отображаться символ «*». На компьютерах Mac индикатором несохраненных изменений служит серая точка в центре красной кнопки Close (Закрыть).

LayOut

LayOut без версий

Что сделано

Начиная с версии 23.0, файлы LayOut можно открывать в поддерживаемых версиях LayOut (выпущенных за два года до текущей) без необходимости сохранять их в определенном формате. Это изменение относится ко всем файлам, созданным в 2024 году.

Производительность

Что сделано

В разделе Preferences (Параметры) теперь доступны новые параметры, в частности, режим Draft Mode (Черновик), который позволяет оптимизировать графику при работе с документом.

Подробнее

На новой вкладке Performance (Производительность) в окне Preferences (Параметры) можно настроить способ обработки графики в LayOut, чтобы повысить общую производительность. Две основные функции — это режим Draft Mode (Черновик) и наш новый экспериментальный графический механизм.

24ReleaseNotes10.png

В режиме Draft Mode (Черновик) можно отложить прорисовку объектов на странице во время навигации. В этом режиме LayOut будет отображать упрощенные версии без окончательной толщины линий, штрихов и заливок по шаблонам. Вы можете включить режим черновика во время навигации по страницам или при работе со страницами с очень большим количеством объектов. Эти изменения видны только во время работы над документом. Благодаря уменьшению нагрузки повышается скорость навигации по файлу. При экспорте чертежей разрешение изображений будет оставаться высоким.

Экспериментальный графический механизм LayOut — это функция, разработанная в рамках программы SketchUp Labs. По умолчанию она отключена, но вы можете активировать ее, чтобы оценить прирост производительности за счет современной и гибкой графической архитектуры.

Подробнее

Подробнее об этих параметрах мы рассказываем в разделе Производительность (Performance).

Улучшенный процесс логического вывода

Что сделано

Работа системы привязок в LayOut теперь стала гораздо ближе к логике SketchUp. При работе над документом LayOut во время черчения будет ограничивать доступные привязки только теми объектами, которые находятся ближе всего к месту последнего щелчка мыши.

Подробнее

Те, кто привык к поведению привязок в SketchUp, будут рады узнать, что теперь эта система работает привычным для них образом.

24ReleaseNotes11.png

Кроме того, мы упростили активные выводы при перемещении и копировании объектов, чтобы LayOut строил выводы только на основании той точки, из которой вы взяли объекты. Вы заметите, что скорость отклика при перемещении, копировании и размещении объектов на странице увеличилась.

Подробнее

Подробную информацию о том, как работает система привязок в LayOut с учетом этого улучшения, можно найти в статье Использование привязок (Using Inferences).

Немасштабируемые метки

Что сделано

Метки больше не имеют маркеров масштабирования, но по-прежнему масштабируются, если они привязаны к геометрии LayOut или SketchUp.

Подробнее

Инструмент Label (Метка) в LayOut позволяет создавать объект выноски, состоящий из текстового поля, линии (в технической терминологии — линии-выноски), а также стрелки или конечной точки, указывающей на конкретный элемент в рабочей области. Мы обновили логику работы этих меток: теперь у них нет маркеров масштабирования, но их размер всё еще можно менять, если они привязаны к другой геометрии.

Подробнее

Подробное описание работы с метками приведено в статье Создание меток в документе (Labeling Items in Your Document).

Оптимизация экспорта

Что сделано

При экспорте документа теперь можно указывать несколько диапазонов страниц одновременно, а также автоматически добавлять названия страниц в имена файлов.

Подробнее

Теперь вы можете задавать для экспорта сразу несколько независимых диапазонов страниц. Это значит, что вы можете выгрузить конкретные страницы или целые диапазоны за один раз, не запуская процесс экспорта повторно для каждой части.

Кроме того, при экспорте в графические форматы имена файлов теперь включают названия соответствующих страниц — это значительно упрощает навигацию по готовым изображениям вне программы LayOut.

Подробнее

Подробные сведения приводятся в статье Экспорт и печать документов LayOut.

Исправленные ошибки и другие улучшения

SketchUp

Стабильность

  • Исправлен сбой, возникавший при открытии некоторых файлов, созданных в SketchUp 2023.1.

  • (Windows) Исправлен сбой, возникавший при отправке расширениями сообщений в SketchUp. Наиболее распространенный пример — изменение сцен после установки Scan Essentials.

  • Исправлен сбой, возникавший при вводе большого значения для количества сегментов в дуге.

Инструменты

  • В настройки добавлен параметр Show Move tool Rotation grips (Показывать ручки поворота для инструмента «Перемещение»). Кроме того, добавлен ярлык для быстрого включения и выключения этой функции.

  • Улучшена видимость привязок при использовании инструмента Move (Перемещение)

  • Улучшено управление привязками, которые находятся на вершинах (например, в конечных точках ребер)

  • Улучшены изменения ориентации существующих привязок

  • Оптимизирован процесс установки привязки

  • Пункт контекстного меню для изменения ориентации привязки теперь называется Reorient Snap (Изменить ориентацию привязки)

  • Теперь для некоторых инструментов (например, Move (Перемещение)) отображаются привязки для выбранного объекта (ранее для этого нужно было навести курсор на объект)

  • В контекстное меню добавлен пункт Reverse Snap (Обратная привязка)

  • Исправлена ошибка, из-за которой привязка стиралась при выборе и нажатии клавиши Escape

  • Исправлена ошибка, из-за которой проход в некоторых моделях осуществлялся в противоположном направлении

  • Исправлена ошибка, из-за которой не работала функция Undo (Отмена)

  • (Windows) Собственные инструменты на панели инструментов больше нельзя случайно удалить щелчком мыши, когда открыто диалоговое окно панели инструментов

  • (Windows) Теперь во время переименования сцены вкладка названия сцены остается активной

  • (Windows) Размер кнопки Add Tag (Добавить тег) на панели тегов увеличен для обеспечения единообразия размеров кнопок

  • (Windows) Нажатие клавиши Tab позволяет переключаться между полями во время изменения названия и описания сцены в области Scene (Сцена)

Scan Essentials

  • Расширение Scan Essentials обновлено до версии 1.2024.0318

Средство импорта файлов Revit

  • Средство импорта файлов Revit обновлено до версии 1.2024.0318

Окружающая затененность

  • На панель Styles (Стили) добавлена новая библиотека стилей по умолчанию — Ambient Occlusion (Окружающая затененность). Поэкспериментируйте с различными стилями окружающей затененности и создавайте свои собственные. Мы будем рады взглянуть на них!

  • Исправлена ошибка, из-за которой в меню Ambient Occlusion (Окружающая затененность) пункт Status (Состояние) не был переведен

Разное

  • Изменено расположение рабочих файлов SketchUp и LayOut, используемых для восстановления моделей:

  • Windows: C:\<ИмяПользователя>\AppData\Local\SketchUp\SketchUp 2024\SketchUp\working\Mac: /Library/Application Support/SketchUp 2024/SketchUp/working/

  • Исправлена ошибка, из-за которой пунктиры, созданные с помощью Ruby, отображались некорректно

  • Исправлена ошибка, из-за которой команда Fix Problems (Исправить ошибки) в меню Model Info > Statistics (Сведения о модели > Статистика) могла стирать грани рельефа

  • (Windows) Исправлена ошибка, из-за которой не применялись изменения в диалоговом окне отладки камеры

  • Исправлена ошибка, из-за которой в настройке сцены некорректно работал флажок Tags (Теги)

  • Добавлена возможность переключения графических процессоров в меню Preferences > Graphics (Параметры > Графика) в устройствах с дискретными видеокартами.

  • Исправлена ошибка, из-за которой после запуска SketchUp был установлен часовой пояс UTC-7, а в шаблоне по умолчанию часовой пояс не был задан

  • Исправлена ошибка, из-за которой при добавлении компонента из соответствующего окна обзора происходило аварийное завершение работы SketchUp

  • Исправлена ошибка, из-за которой добавление компонента из окна компонентов (Component Browser) приводило к аварийному завершению работы SketchUp.

  • Исправлена ошибка, из-за которой при использовании средства выбора в диалоговом окне Materials (Материалы) к геометрии вместо выбранного цвета применялся черный

  • Исправлена ошибка печати, из-за которой процесс не удавалось отменить

  • Исправлена ошибка, из-за которой выбранный текст тега отображался некорректно

  • Исправлена ошибка в диалоговом окне Styles (Стили), из-за которой ползунок X-ray (Рентген) для настройки прозрачности работал некорректно

  • Исправлена ошибка, из-за которой при нажатии кнопки Reset Workspace (Сбросить рабочее пространство) стыковка областей была некорректной

  • Исправлена ошибка в инструменте Text (Текст), из-за которой при наведении курсора на геометрию не отображалась активная точка

  • Исправлена ошибка, из-за которой нажатие клавиши ESC не приводило к выходу из диалогового окна компонента после редактирования

  • Исправлена ошибка с позиционированием окна Ruby, из-за которой оно работало некорректно

  • Исправлена ошибка, из-за которой при нажатии клавиши Tab переход между элементами во вкладке Entity Info (Информация об объекте) выполнялся в неправильном порядке

  • Исправлена ошибка, из-за которой геометрия без тегов отображалась во вкладке Entity Info (Информация об объекте) некорректно

  • Исправлена ошибка, из-за которой выбор тега в модели приводил к увеличению ширины области

  • Исправлена ошибка, из-за которой при использовании сочетаний клавиш, например для инструмента масштабирования, в поле Measurements (Измерения) появлялась буква «Z»

  • Исправлена ошибка, из-за которой описания сцен работали некорректно

  • Исправлена проблема при работе в области просмотра, из-за которой ширина диалоговых окон изменялась случайным образом

  • Исправлена ошибка, из-за которой при выборе меню File > New (Файл > Создать) исчезали теги

  • Для некоторых языков исправлены проблемы с переводом

  • (Windows) Исправлена ошибка, из-за которой классификатор, панель инструментов тегов и поле измерений отображались неправильно

  • (Windows) Исправлена ошибка, из-за которой вкладка Edit (Изменить) в диалоговом окне Material (Материал) отображалась неправильно при выборе параметра RGB

  • (Windows) Исправлены ошибки с установкой средства импорта файлов Revit. Кроме того, программа установки больше не отмечает расширения Scan Essentials и Revit по умолчанию.

  • (Mac) Исправлена ошибка, из-за которой в разрешении 32 x 32 не отображались активные точки курсора

  • Исправлена ошибка, из-за которой ответ на запрос HtmlDialog — Large POST формировался неправильно

  • (Windows) Исправлена ошибка, из-за которой текст названия эскиза сцены отображался некорректно

  • (Windows) Исправлена ошибка с диалоговым окном Save As (Сохранить как) в Trimble Connect, из-за которой переключение между приложениями с помощью комбинации клавиш Alt+TAB приводило к тому, что диалоговое окно отображалось поверх других приложений

  • (Windows) По умолчанию панель инструментов Trimble Connect теперь отображается в правой части верхней области панелей инструментов

  • (Windows) Исправлена ошибка, из-за которой часть границы меню панелей инструментов не отображалась в некоторых разрешениях экрана

  • (Windows) Исправлена ошибка, из-за которой некоторые разделители меню имели разную толщину

  • Исправлены ошибки с переводом для инструмента Offset (Смещение) и функций Share a Link (Поделиться ссылкой), Customize (Настроить), Location Pin (Булавка местоположения) и Model Info (Информация о модели)

LayOut

Стабильность

  • Повышена скорость загрузки документов. Падение производительности было связано со встроенной проверкой исправления ближней/дальней плоскости отсечения (Near/Far clipping plane) в SketchUp. Посмотрите, не возникает ли теперь эффект отсечения во вьюпортах моделей SketchUp. Кроме того, просим сообщить нам, если вы заметили улучшения в процессе загрузки файлов.

  • Теперь в наших шаблонах по умолчанию отключена функция Output Override (Переопределение вывода).

Области просмотра моделей SketchUp

  • Теперь при снятии флажка Background (Фон) в инспекторе моделей SketchUp в области просмотра не будут отображаться небо, земля и горизонт

  • Обновлено поведение размеров, чтобы предотвратить установку размеров в границах области просмотра модели SketchUp

  • Исправлена ошибка, из-за которой LayOut случайным образом требовал повторную прорисовку области просмотра модели SketchUp

  • Исправлена ошибка, из-за которой параметр Style Override (Переопределение стиля) сбрасывался при копировании и вставке области просмотра

Разное

  • Исправлена ошибка, из-за которой уменьшение количества нескольких объектов, выбранных с помощью клавиши Shift, не приводило к изменению размера ограничительной рамки

  • Исправлена ошибка, из-за которой нажатие клавиши Escape не приводило к закрытию диалогового окна Find Text (Найти текст)

  • Исправлена ошибка, из-за которой изменение полей бумаги и связанных с ними параметров приводило к смещению сеток

  • Исправлена ошибка, из-за которой после отмены действий Move (Перемещение) или Rotation (Поворот) тренога осей отображалась в неправильном месте

  • Исправлена ошибка, из-за которой в документах с текстом в формате RTF появлялись некорректные символы

  • Исправлена ошибка, из-за которой масштабирование меток и размеров приводило к неправильному размещению центра управления поворотом

  • Исправлена ошибка, связанная с ярлыком функции отмены создания неограниченного текстового поля, из-за которой на ярлык нужно было нажать дважды

  • Исправлена ошибка, приводившая к сбою при замене текста автотекстом в Windows

  • (Windows) Исправлена ошибка, из-за которой дуги и окружности без сплошных линий неправильно отображались при экспорте изображений

  • (Mac) Исправлена ошибка, из-за которой фокус мог застрять в инспекторе страниц до перезапуска LayOutOut

  • Для всех языков добавлен перевод параметров Pan and Zoom Redraw Delay (Панорамирование и задержка перерисовывания при изменении масштаба) в настройках LayOut

  • Исправлена ошибка, из-за которой при запуске LayOut из командной строки с параметром -lang программа не открывалась на указанном языке

Style Builder

Исправленные ошибки

  • (Mac) Исправлена ошибку, из-за которой приложение Style Builder аварийно завершало работу при закрытии

  • Исправлен сбой при закрытии приложения Style Builder (на компьютерах Mac)

SketchUp API

Наложения интерфейса C API

Мы представляем интерфейсы API C, которые позволяют расширениям рисовать поверх отображения в SketchUp. Эти API-интерфейсы дают возможность выполнять смешанное рисование с использованием информации о прозрачности и/или глубине. Новые функции наложения интерфейсов C API предоставляют возможности, которых нет в наложениях Ruby API.

В прошлом сложные расширения (например, расширения для прорисовки) должны были использовать специфичные для платформы методы для получения дескриптора отображения SketchUp и выполнения такой прорисовки. После появления нового графического механизма эти обходные пути не работают. Мы надеемся, что эти новые API-интерфейсы обеспечат стабильный и документированный способ продолжения работы этих замечательных расширений.

Пакет SDK включает в себя простой пример проекта (под названием Overlays), демонстрирующий возможности API-интерфейса. Пожалуйста, ознакомьтесь с ним и сообщите нам, если мы что-то упустили.

Ruby 3.2

Мы обновили встроенный язык программирования Ruby до версии 3.2.2.

Дополнительные изменения и улучшения в интерфейсе Ruby API

  • Библиотека OpenSSL в Ruby обновлена до версии 1.1.1w

  • Добавлена поддержка опции экспорта :page_range для Layout::Document#export

  • Добавлен тег Sketchup::View#graphics_engine

Исправлены ошибки в Ruby API

  • Исправлена ошибка на компьютерах Mac, из-за которой команда UI.create_cursor предоставляла неправильную активную точку

  • Исправлена регрессия в Sketchup.resize_viewport, которая появилась в SketchUp 2023.1 для Windows

  • Исправлена ошибка, из-за которой консоль Ruby не прокручивалась автоматически до конца после очистки

  • Исправлена ошибка, из-за которой некоторые алгоритмы наблюдения Ruby срабатывали при сохранении модели во время редактирования компонента. В частности, в этой ситуации больше не должны вызываться команды onOpen/onClose компонента InstanceObserver и onTransactionStart/onTransactionCommit компонента ModelObserver.