Skip to Content
Help
October 7, 2025SketchUp 2026.026.0.429 Win 64-bit26.0.428 Mac 64-bit

Vad Àr nytt i SketchUp 2026.0?

SketchUp Pro för stationÀra datorer

  • Samarbeta i SketchUp – Du kan nu dela SketchUp-modeller via en privat inbjudan eller genom att skapa och dela en offentlig lĂ€nk. De du delar din modell med kan navigera i din modell, göra mĂ€tningar, lĂ€mna kommentarer och till och med se uppdateringar i realtid.

  • Visualisering – SketchUp 26.0 introducerar en avstĂ„ndsmultiplikator och fĂ€rgkontroller för Ambient Occlusion (Omgivande ocklusion), möjligheten att invertera ett materials ojĂ€mnhetskarta och den mycket efterfrĂ„gade möjligheten att vĂ€lja den miniatyrbild du föredrar nĂ€r du tittar pĂ„ dina material.

  • Prestanda – Sketchup 2026.0 förbĂ€ttrar bĂ„de minne och arbetseffektivitet, vilket gör Sketchup effektivare, snabbare och mer pĂ„litlig. Dessa prestandauppdateringar Ă€r sĂ€rskilt mĂ€rkbara nĂ€r man arbetar med stora modeller.

  • Live Components (Livekomponenter) – SketchUp 2026.0 lĂ€gger till funktionalitet i verktyget Scale (Skala) ( icon scale ), vilket lĂ€gger till grepp som gör att du kan placera och dimensionera Live Components genom inferens. Eftersom du nu kan anvĂ€nda Paint Tool (MĂ„larverktyget) ( icon paint bucket.png ) för att tillĂ€mpa material utanför en komponents fördefinierade alternativ har vi lagt till flera förbĂ€ttringar av livskvaliteten vid mĂ„lning av Live Components (Livekomponenter).
  • Modelleringsarbetsflöden och grĂ€nssnittsuppdateringar – SketchUp 2026.0 innehĂ„ller flera anmĂ€rkningsvĂ€rda förbĂ€ttringar inom skalning, rotation, scener och inferens.

  • Hantera aktiveringar – Du kan nu Ă„terstĂ€lla alla aktiveringar och auktorisera din nuvarande enhet utan att lĂ€mna SketchUp för skrivbordet.

  • Interoperabilitet – SketchUp 2026.0 erbjuder nu flera förbĂ€ttringar av Ă„tergivning och effektivitet för import och export av DWG-filer. Detta inkluderar skuggstöd och bevarande av sektionsplaner. IFC-exportarbetsflödet har ocksĂ„ förbĂ€ttrats, vilket konsoliderar IFC 2x3 och IFC 4 till en enda filtyp med utökade exportalternativ.

  • Scan Essentials – Scan Essentials innehĂ„ller tvĂ„ nya arbetsflöden för punktmolnsmodellering, verktygen Texturprojektion och NĂ€tgenerering. Den nya scenhanteraren styr synligheten av punktmoln bĂ€ttre i bĂ„de SketchUp och Layout. Med den hĂ€r uppdateringen kan du ocksĂ„ enkelt Ă„tergĂ„ till det ursprungliga georefererade koordinatsystemet vid export.

LayOut

  • Uppdateringar av LayOut-grĂ€nssnittet och Prestanda – LayOut-grĂ€nssnittet i Windows ser ut och fungerar mer som SketchUp med uppdaterad ikonografi, konfigurationer för fack och paneler samt anpassning av verktygsfĂ€lt.

  • Layout-ritverktyg – Fyra nya ritverktyg, Trim (Trimma), Extend (Utöka), Fillet (Avrunda) och Chamfer (Avfasning), finns nu tillgĂ€ngliga. Dessa verktyg ger ett mer intuitivt och effektivt sĂ€tt att skapa och manipulera 2D-vektorer.

  • FörbĂ€ttringar av klippböcker – LayOuts standardbibliotek för klippböcker inkluderar nu fönster, dörrar, möbler, kök badrum och personer i 2D under kategorin Arkitektur.

  • FörbĂ€ttringar av import och export – LayOut 2026.0 ger flera uppdateringar av DWG-funktionaliteten, vilket förbĂ€ttrar effektiviteten i hur LayOut importerar och exporterar dina dokument med det filformatet, inklusive att behĂ„lla SketchUp-taggar och skicka dem som DWG-lager.

Buggfixar och andra förbÀttringar

SketchUp

Samarbeta i SketchUp

Vad vi har gjort

Du kan nu dela SketchUp-modeller via en privat inbjudan eller genom att skapa och dela en offentlig lÀnk. De du delar din modell med kan navigera i din modell, göra mÀtningar, lÀmna kommentarer och till och med se uppdateringar i realtid.

Detaljerad information

SketchUp 2026.0 introducerar flera nya funktioner som hjÀlper dig att dela dina modeller och samarbeta med dina kollegor och intressenter. De hÀr funktionerna, som finns i det nya samarbetsfÀltet, kan hjÀlpa dig att dela en modell, kontrollera ÄtkomstnivÄn för dem du har delat den med och bjuda in feedback frÄn andra.

Dela med Collaboration Bar (SamarbetsfÀltet)
Collaboration Bar ( web icon link sharing.png ) (SamarbetsfÀltet) finns tillgÀngligt i SketchUps standardverktygsfÀlt sÄvÀl som i den stora verktygsuppsÀttningen. Du kan ocksÄ klicka pÄ Window > Collaboration Bar (Fönster > SamarbetsfÀlt).
desktop dropdown collaboration bar.png

I samarbetsfÀltet klickar du pÄ Share (Dela) för att bjuda in andra att visa din modell. Om du inte redan har sparat din modell i Trimble Connect visas en frÄga som ber dig spara din modell dÀr.

För att skicka privata inbjudningar anger du e-postadresserna och tilldelar deras Ätkomst. Ett e-postmeddelande skickas med en privat lÀnk som tittaren kan anvÀnda för att komma Ät din modell. Om du stÀller in din modell pÄ General Access (AllmÀn Ätkomst) genereras en offentlig lÀnk om du klickar pÄ Copy Link (Kopiera lÀnk) som gör att alla med lÀnken kan se din modell.

desktop sharing popup.jpg

LÀnkarna du delar med andra öppnar din modell i deras webblÀsare. Dina tittare kommer att ha tillgÄng till grundlÀggande information och nÄgra andra alternativ beroende pÄ vilka ÄtkomstnivÄer du har angett. Du kan nÀr som helst stÀlla in eller Àndra tittarnas Ätkomst. Tittare som fÄtt en privat inbjudan har följande behörigheter:

  • Ägare – Modellens Ă€gare har alltid full Ă„tkomst till alla visningsfunktioner.

  • Visa scener – Kan visa scener i en modell, men kan inte navigera i modellen eller lĂ€mna kommentarer.

  • Kommentera – Kan lĂ€mna kommentarer, anvĂ€nda alla tillgĂ€ngliga kameraverktyg och fĂ„ Ă„tkomst till alla visningsprogram.

AllmÀnna Ätkomstbehörigheter definierar vad som hÀnder nÀr nÄgon som anvÀnder din offentliga lÀnk, eller har Ätkomst utan en privat inbjudan, försöker visa din modell. AllmÀn Ätkomst inkluderar inte möjligheten att kommentera en modell. En modells allmÀnna Ätkomst kan stÀllas in pÄ:

  • Ingen Ă„tkomst – NĂ€r andra försöker komma Ă„t modellen blir de ombedda att begĂ€ra Ă„tkomst frĂ„n dig. Du kan sedan bevilja eller avslĂ„ begĂ€ran, eller till och med ignorera den!

  • Visa scener – Tittare som öppnar via din offentliga lĂ€nk kan bara visa scener.

  • Visa modell – Besökare som besöker via din offentliga lĂ€nk kan navigera och göra mĂ€tningar.

Alla tittare kan se andra tittares markörer. Varje tittare kan dölja dessa markörer med hjÀlp av Hide Cursor (Dölj markör) ( icon hide cursor ) i samarbetsfÀltet.
Kommentarer
Det nya verktyget Comment (kommentar) skapar 3D-kommentarsmarkörer i din modell. För att lÀmna en kommentar i din egen modell aktiverar du verktyget Comment (Kommentera) ( icon comment.png ) frÄn verktygsfÀltet eller samarbetsfÀltet. Om du aktiverar kommentarsverktyget öppnas kommentarspanelen. FrÄn kommentarspanelen kan du granska kommentartrÄdar, lÀgga till svar och dölja kommentarsmarkörer.
desktop comments window.png

Tittare kan lÀmna kommentarer med kommentarsverktyget. NÀr funktionen Àr aktiverad kan du anvÀnda kommentarverktyget genom att hÄlla muspekaren över objekt och vÀlja en exakt plats dÀr du vill lÀgga in din kommentar. Förutom att utbyta textbaserade kommentarer kan du lÀgga till bilder, lÀnkar och till och med olika kamerapositioner i en kommentartrÄd.

Varje kommentar kan kopplas till en specifik scen. Det innebÀr att nÀr en tittare klickar pÄ en kommentarmarkör i modelleringsfönstret visar SketchUp den kommentarstrÄden, aktiverar den senast valda scenen och flyttar till kamerans position för kommentaren. Du kan ocksÄ vÀlja att koppla din kommentar till en annan scen, eller ingen scen alls.

Real Time Viewing (Realtidsvisning) and Camera Controls (Kamerakontroller)

Som standard ser dina tittare dina modelleringsuppdateringar i realtid. Alla Àndringar du gör kommer att visas för alla, och tittarna kan till och med se verktyget du anvÀnder för att göra Àndringar om markörer Àr synliga. Navigeringsverktygen som tittarna anvÀnder, som mÄttband, panorering eller rotering, Àr ocksÄ synliga för alla.

Om du vill att dina tittare ska se din modell frÄn en specifik synvinkel kan du klicka pÄ din avatar i samarbetsfÀltet. Varje tittares synvinkel kommer att flyttas till din. Om du vill se vad en annan tittare tittar pÄ kan du klicka pÄ deras avatar istÀllet.

LĂ€s mer

För mer information om alla SketchUps nya samarbetsfunktioner, se Connect and Collaborate (Anslut och samarbeta).

VisualiseringsförbÀttringar

Vad vi har gjort

SketchUp 26.0 introducerar en avstÄndsmultiplikator och fÀrgkontroller för omgivande ocklusion, möjligheten att invertera ett materials ojÀmnhetskarta och den mycket efterfrÄgade möjligheten att vÀlja den miniatyrbild du föredrar nÀr du tittar pÄ dina material.

Detaljerad information

Ambient Occlusion (Omgivande ocklusion)

Stilen Ambient Occlusion (Omgivande ocklusion) fick tvĂ„ stora förbĂ€ttringar – ett reglage för Distance Multiplier (AvstĂ„ndsmultiplikator) och en fĂ€rgprovskontroll.

desktop ambient occlusion choose color.png

Skjutreglaget Distance Multiplier (AvstÄndsmultiplikator) hjÀlper till att styra avstÄndet vid vilket ocklusionseffekter visas i dina modeller. Ett högre tal innebÀr att ocklusionseffekter fortfarande kommer att vara synliga Àven nÀr man zoomar ut.

ambient occlusion 25 vs 26.png

Den nya fÀrgprovskontrollen möjliggör dynamiska skuggningseffekter baserade pÄ en fÀrg du vÀljer. FÀrgeffekter visas i modellen nÀr du justerar fÀrgen med hjÀlp av fÀrghjulet, HLS-, HSB- eller RGB-kontrollerna.

Invertera grovhet

SketchUps Photoreal Materials (Fotorealistiska material) erbjuder mÄnga sÀtt att anpassa utseendet och kÀnslan i din modell. Med det nya alternativet Invert Roughness (Invertera ytjÀmnhet) kan du vÀnda de svartvita vÀrdena i ett materials ytjÀmnhetskarta. Att invertera ojÀmnheter ger ett annat alternativ för att bÀttre kontrollera hur slÀt eller grov du vill att en yta ska vara.

Materialminiatyrer (endast Windows)

Efter stor efterfrÄgan kan materialminiatyrer nu anpassas och erbjuda bÄde en kub och en platt 2D-bild.

NÀr du kontextklickar pÄ förhandsgranskningen av ett material kan du vÀlja mellan Auto (Automatisk miniatyrbild), Cube Thumbnail (Kubminiatyrbild) eller Flat Thumbnail (Platt miniatyrbild). NÀr du vÀljer Auto Thumbnail (Automatisk miniatyrbild) visas fotorealistiska texturer som en kub. Cube Thumbnail (Kubminiatyrbild) visar materialet som en kub. Flat Thumbnail (Platt miniatyrbild) visar miniatyrbilden som en klassiska 2D-bild.

LĂ€s mer

Se Materials, Textures, and Environments (Material, texturer och miljöer) för mer information om SketchUps visualiseringsfunktioner.

Prestanda

Vad vi har gjort

Sketchup 2026.0 förbÀttrar bÄde minne och arbetseffektivitet. Dessa förÀndringar gör Sketchup effektivare, snabbare och ökar tillförlitligheten, sÀrskilt nÀr man arbetar med stora modeller.

Detaljerad information

MinnesförbÀttringar

SketchUp hanterar nu minne bÀttre och optimerar hur programvaran allokerar och anvÀnder minne för olika element och processer, inklusive:

  • ModellinlĂ€sning – SketchUp lĂ€ser nu in modelldata mer effektivt och minskar initiala minnestoppar.

  • LĂ€gre minneskostnader – SketchUp optimerar mĂ€ngden minne som reserveras för komponenter, vilket resulterar i mindre slöseri med minne.

  • Effektivitet i Windows-grafik – Windows-anvĂ€ndare kan mĂ€rka en förbĂ€ttring av hanteringen av grafikresurser, vilket ökar minnesanvĂ€ndningens effektivitet.

Med dessa minnesförbÀttringar anvÀnder SketchUp mindre minne totalt sett. Detta innebÀr att:

  • FĂ€rre krascher och frysningar, sĂ€rskilt för enheter med mindre RAM som arbetar med stora modeller.

  • En mer stabil och responsiv miljö, vilket möjliggör lĂ€ngre arbete utan avbrott.

  • BĂ€ttre flyt och respons.

Arbetseffektivitet

SketchUp 2026.0 förbÀttrar hastigheten för ofta anvÀnda operationer och ger bÀttre flyt med förbÀttringar av:

  • Urval och slutsatser – En optimering av kĂ€rnkod för urval och manipulation vilket resulterar i högre hastighet för uppgifter som att göra val, öppna och stĂ€nga komponenter och dra slutsatser frĂ„n mindre mĂ„l.

  • ScenövergĂ„ngar – FörbĂ€ttrad logik för scenövergĂ„ngar vilket resulterar i jĂ€mnare scenbyten i större modeller och en förbĂ€ttring av bildrutor per sekund pĂ„ cirka 86 %.

  • ZoomförlĂ€ngningar – En hastighetsförbĂ€ttring pĂ„ cirka 90 % vid anvĂ€ndning av zoomförlĂ€ngningar.

  • Rensa oanvĂ€nda taggar – Tiden som krĂ€vs för att rensa oanvĂ€nda taggar har minskats drastiskt.

LĂ€s mer

För mer information om hur du kör SketchUp, se vÄra Hardware and Software Requirements (HÄrdvaru- och mjukvarukrav).

Live-komponenter

Vad vi har gjort

SketchUp 2026.0 lÀgger till ytterligare funktionalitet för att greppa livekomponenter t i skalverktyget. Dessa grepp lÄter dig placera och dimensionera Live Components (Livekomponenter) genom inferens. Vi har ocksÄ lagt till flera förbÀttringar av livskvaliteten vid mÄlning av Live Components (livekomponenter).

Detaljerad information

Skalning av Live Components (Livekomponenter)
Verktyget Scale ( icon scale ) (Skala) kan nu anvÀndas med Live Components (Livekomponenter), vilket ger mer flexibilitet nÀr du placerar komponenter i dina modeller.
GIF scale live components.gif

Dessa grepp Àr inte alltid lÄsta till komponentens grÀnser. Det innebÀr att du bÀttre kan identifiera vilken dimension du anvÀnder och hur du bÀst passar en komponent i din modell. Kolla in 3D Warehouses SketchUp-innehÄllsbibliotek för att blÀddra bland stora Live Components (Livekomponenter), tillgÀngliga för SketchUp-prenumeranter. Inte alla befintliga Live Components (Livekomponenter) komponenter har skalgrepp, men fler som har det kommer snart!

FörbÀttrade materialarbetsflöden

Verktyget Paint Bucket (FÀrghink) kan tillÀmpa anpassade material pÄ en livekomponent, Àven material som inte redan finns tillgÀngliga i den komponenten. Det hÀr uppdaterade arbetsflödet inkluderar nu bÀttre texturmappning, mÄlning medan en livekomponent Àr vald, ett bÀttre sÀtt att hantera material och nÄgra andra Àndringar bakom kulisserna för att förbÀttra kompatibiliteten med SketchUps materialbibliotek.

desktop live component materials.png

LĂ€s mer

För mer information, se SketchUp Live Components (SketchUps livekomponenter).

AllmÀnna modelleringsförbÀttringar

Vad vi har gjort

SketchUp 2026.0 innehÄller flera anmÀrkningsvÀrda förbÀttringar gÀllande skalning, rotation, scener och inferens.

Detaljerad information

SkalningsförbÀttringar

NÀr man skalar objekt kan det vara svÄrt att komma Ät grepp som Àr dolda av annan geometri utan att behöva orbitera, panorera och justera synligheten. I smÄ utrymmen kan skalning krÀva extra klick. Nu visas skalgrepp genom annan geometri, sÄ att du alltid kan se och klicka pÄ dem.

desktop scale grip display through geometry.png
FörbÀttringar av Rotera

SketchUp 2025 introducerade rotationshandtag till verktyget Rotate (Rotera). Dessa handtag möjliggör snabba rotationer med tvÄ klick, men orsakar ovÀntade resultat efter att rotationsplanet har lÄsts. För att undvika problem visas inte rotationsgrepp nÀr du har lÄst ett rotationsplan.

desktop 2025 rotation handles.png
Förflyttning frÄn en profilkant

NÀr du placerar objekt kan objektet du placerar skymma bakgrundselementen, vilket gör det svÄrt att justera saker. NÄgra lösningar inkluderar att visa bakkanter, aktivera röntgen eller vÀxla mellan grepp i avgrÀnsningsrutor.

För att ÄtgÀrda dessa problem kan grupper och komponenter nu skapas med hjÀlp av en av dess profilkanter. Objektet blir transparent, vilket gör det mycket lÀttare att se och vÀlja ditt placeringsmÄl. Profiler behöver inte vara synliga för att detta ska fungera, men det beror fortfarande pÄ kamerans position och geometrins komplexitet.

desktop profile edge.png
Ångra och Gör om scen

Att göra fel uppdatering av en scen kan vara frustrerande. Före 2026.0 kunde det ta timmar eller krĂ€va att man upptĂ€ckte nya tillĂ€gg för att fĂ„ en scen tillbaka till önskat lĂ€ge. För att Ă„tgĂ€rda problemet finns det nu möjlighet att Ă„ngra eller göra om scenuppdateringar. Undo (Ångra) och Redo (Gör om) fungerar precis som nĂ€r du redigerar andra delar av din modell och kommer Ă€ven att respektera Ă„tgĂ€rder för att skapa, byta namn och ta bort.

Purge Unused (Rensa oanvÀnda)

PÄminnelsen Purge Unused (Rensa oanvÀnda) som visas nÀr du sparar en modell kommer nu att vara avstÀngd som standard. Du kan fortfarande styra den hÀr pÄminnelsen i InstÀllningar. NÀr den Àr aktiverad kan du nu kontrollera exakt vad du vill rensa, vilket hjÀlper till att sÀkerstÀlla att du inte rensar anvÀndbara tillgÄngar. Purge Unused (Rensa oanvÀnda) visas ocksÄ i Redigera-menyn och kan tilldelas en genvÀg, sÄ att du kan rensa vad du vill, nÀr du vill.

Fack och paneler (Windows)

Som en del av det pÄgÄende arbetet med att uppdatera SketchUp-grÀnssnittet kan du styra synligheten för fack och paneler genom att högerklicka pÄ fack- och panelrubrikerna. Om du vÀljer en omarkerad panel syns den i det fack du klickade pÄ. Den hÀr nya funktionen Àr ett alternativ till att anvÀnda fönstermenyn nÀr du vill aktivera fack eller visa paneler i ett fack.

windows trays panels visibility.png

Dessutom kan paneler nu dras mellan fack eller ut i öppet utrymme för att bli ett oberoende fack. Om du vill göra om det nya fönstret till ett fack kan du kontextklicka pÄ det tillfÀlliga facket och klicka pÄ Make Tray (Skapa fack).

LĂ€s mer

För mer information om hur du anvÀnder dessa nya funktioner, se Drawing Lines, Shapes, and 3D Objects (Rita linjer, former och 3D-objekt).

Hantera aktiveringar

Vad vi har gjort

Du kan nu ÄterstÀlla alla aktiveringar och auktorisera din nuvarande enhet utan att lÀmna SketchUp för skrivbordet.

Detaljerad information

SketchUps End User License Agreement (Licensavtal för slutanvĂ€ndare)(EULA) begrĂ€nsar antalet installationer och auktoriseringar för varje program som ingĂ„r i din prenumeration till tvĂ„ instanser eller enheter. Om du försöker installera och auktorisera en applikation pĂ„ en tredje enhet eller öppna en tredje instans av en applikation ser du meddelandet ”Du har överskridit dina tillĂ„tna aktiveringar”.

Om du fÄr det meddelandet nÀr du öppnar SketchUp för skrivbordet visas nu ett alternativ som lÄter dig ÄterstÀlla alla aktiveringar och auktorisera din nuvarande enhet utan att behöva gÄ in pÄ din kontohanteringssida.

desktop authorize device modal.png

LĂ€s mer

För mer information om hur du kan hantera dina aktiveringar, se Managing Activations (Hantera aktiveringar).

SketchUp-interoperabilitet

Vad vi har gjort

SketchUp 2026.0 erbjuder nu flera förbÀttringar av Ätergivning och effektivitet för import och export av DWG-filer. Detta inkluderar skuggstöd och bevarande av sektionsplaner. IFC-exportarbetsflödet har ocksÄ förbÀttrats, vilket konsoliderar IFC 2x3 och IFC 4 till en enda filtyp med utökade exportalternativ.

Detaljerad information

DWG-importalternativ

NĂ€r du importerar en DWG-fil finns det nu tvĂ„ nya alternativ tillgĂ€ngliga – Import Layers as Group (Importera lager som grupper) och Import Linework Flattened (Importera utplattade linjer).

Om du vÀljer Import Layers as Groups (Importera lager som grupper) anger du att SketchUp ska skapa grupper som motsvarar den importerade DWG-filens lagerstruktur. Dessa importerade lager har fortfarande sin egen tagg, men har nu ocksÄ motsvarande, grupperad geometri vilket möjliggör förbÀttrad synlighetskontroll i din importerade modell.

desktop 2026 import dwg.png

Om du vÀljer Import Linework Flattened (Importera linjearbete utjÀmnat) stÀlls Z-vÀrdet för den importerade geometrin in pÄ 0, vilket minskar den vanliga rensningen efter import som behövs vid konvertering av 2D CAD-data till 3D-modeller. Genom att eliminera avvikelser i Z-axeln förhindrar verktyget störande problem som feljusteringar och hjÀlper dig att börja med en ren och exakt grund. Om du Àr bekant med annan CAD-programvara fungerar detta ungefÀr som funktionen Platta ut som finns i dessa program.

DWG-skuggstöd

SketchUp importerar nu skuggningar frÄn DWG-filer. Importerade solida skuggor blir ytor. Icke-solida skuggor blir kanter.

Exportera 3D-sektioner

SketchUp bevarar nu sektionsplaner vid export av 3D DWG-filer, vilket resulterar i DWG-sektioner. Dessa sektioner kan sedan anvÀndas med funktionerna Generate Section Block (Generera sektionsblock) och 2D Section / Elevation (2D-sektion/höjd) i AutoCAD.

Andra DWG-förbÀttringar

SketchUp 2026.0 innehÄller Àven följande DWG-förbÀttringar:

  • Polylinjer frĂ„n DWG-filer importeras nu som svetsade SketchUp-linjer.

  • SketchUp hanterar nu komponentinstansnamn bĂ€ttre, vilket minskar duplicerade data.

  • 3D-polylinjen visas nu som avsett i dialogrutan Import Results (Importera resultat).

  • BĂ€ttre resultat vid export av verkliga kurvor.

  • Flera problem med 3D AutoCAD-exportören har Ă„tgĂ€rdats.

  • 3D-polylinjer exporteras nu som avsett till 2D DWG.

IFC-exportförbÀttringar

NÀr du exporterar din modell konsolideras nu IFC 2x3- och IFC 4-alternativen till ett enda IFC-filalternativ i listan över filtyper. Du kan sedan vÀlja en specifik IFC-version i den nya dialogrutan Export Options (Exportalternativ).

desktop 2026 ifc export modal.png

Den nya dialogrutan IFC Export Options (IFC-exportalternativ) innehÄller Àven ett nytt alternativ för standard IFC-spatialhierarki. Om du vÀljer det hÀr alternativet skapas viktiga entiteter som IfcProject, IfcSite eller IfcBuilding, Àven om de inte Àr definierade i din modells Outliner-struktur.

LĂ€s mer

För mer information om att importera och exportera med SketchUp, se Using SketchUp Data with Other Modeling Programs or Tools (AnvÀnda SketchUp-data med andra modelleringsprogram eller verktyg).

Scan Essentials

Vad vi har gjort

Scan Essentials innehÄller tvÄ nya arbetsflöden för punktmolnsmodellering, verktygen Texture Projection (Texturprojicering) och Mesh Generation (NÀtgenerering), en ny Scene Manager (Scenhanterare) för att bÀttre kontrollera synligheten av punktmoln i bÄde SketchUp och Layout, och möjligheten att ÄterstÀlla transformationer till det ursprungliga georefererade koordinatsystemet vid export.

Detaljerad information

SketchUp-prenumeranter med tillgĂ„ng till Scan Essentials kan nu anvĂ€nda tvĂ„ nya verktyg – Texture Projection (Texturprojicering) och Surface Mesh (YtnĂ€t).

Du med texturprojektion kan extrahera en bildtextur frÄn skanningsdata och projicera den pÄ SketchUp-geometri. Projicerade texturer omvandlas till SketchUp-material som du kan ÄteranvÀnda i andra delar av din modell, eller till och med i andra modeller om du sparar dem.

GIF texture projection.gif

En annan ny funktion, verktyget Surface Mesh (YtrutnÀt), förenklar extraktion av SketchUp-geometri frÄn punktmoln enklare. Efter att du har valt verktyget Surface Mesh (YtnÀt) kan du vÀlja det omrÄde du vill extrahera frÄn, definiera hur du vill extrahera geometrin och skapa ett nÀt i bara nÄgra fÄ steg.

GIF surface mesh.gif

Tillsammans med dessa nya verktyg kan du nu spara synlighetsinstÀllningar frÄn Point Cloud Manager (Punktmolnshanteraren) som en scen i bÄde SketchUp och LayOut.

GIF point cloud visibility.gif

Slutligen, genom att klicka pĂ„ Reset Transformations (ÅterstĂ€ll omvandlingar) i punktmolnshanteraren Ă„terstĂ€lls nu alla omvandlingar, inklusive globala omvandlingar. Detta kan vara ett bra verktyg för dem som vill exportera sina originaldata för anvĂ€ndning med andra appar.

GIF point cloud reset transformation.gif

LĂ€s mer

För mer information, se Scan Essentials for SketchUp (Scan Essentials för SketchUp).

LayOut

LayOut-grÀnssnitt och prestandauppdateringar

Vad vi har gjort

LayOut-grÀnssnittet i Windows ser ut och fungerar mer som SketchUp med uppdaterad ikonografi, konfigurationer för fack och paneler samt anpassning av verktygsfÀlt.

Detaljerad information

LayOuts nya grÀnssnitt i Windows ger dina LayOut-dokument SketchUp-stil.

layout 2026 interface.png

LayOuts fack och paneler beter sig nu mycket mer som sina motsvarigheter i SketchUp. Du kan ordna dem i din arbetsyta, dra ut paneler och skapa nya fack som bÀst passar dina arbetsflöden. VerktygsfÀlten har fÄtt en liknande förbÀttring, vilket gör att du kan ordna dem hur du vill i din arbetsyta, ungefÀr som de fungerar i SketchUp.

Vektor- och hybridrenderingsprestanda

LayOuts HLR-kod (Hidden Line Rendering) genererar vektorlinjerna som anvÀnds i vektor- och hybrid-SketchUp-modellvyportar. Vi har förbÀttrat den hÀr processen vilket ger en betydande hastighetsökning.

LĂ€s mer

För mer information, se Creating Documents in LayOut (Skapa dokument i LayOut).

LayOut-ritverktyg

Vad vi har gjort

Fyra nya ritverktyg, Trim (Trimma), Extend (Utöka), Fillet (Avrunda) och Chamfer (Avfasning), finns nu tillgÀngliga. Dessa verktyg ger ett mer intuitivt och effektivt sÀtt att skapa och manipulera 2D-vektorer.

Detaljerad information

LayOuts nya ritverktyg kan hjÀlpa till att kringgÄ onödiga markeringar och eliminera extra rensning nÀr du utför enkla 2D-uppgifter som detaljering och diagram. Var och en av dessa verktyg utför en specifik funktion:

  • Verktyget Trim ( icon layout trim.png ) (Trimma) – Ă€r ett effektivt sĂ€tt att rensa linjer eller former utan att behöva rensa bort ytterligare vektorer. Trim (Trimma) tar bort överflödiga linjer och skapar rena korsningar, vilket förbĂ€ttrar bĂ„de hastighet och noggrannhet. StandardgenvĂ€gen för Trim (Trimma) Ă€r Skift + T.
  • Extend ( icon layout extend.png ) (Utöka) () – Verktyget Utöka förenklar 2D-ritning genom att erbjuda ett snabbt och enkelt sĂ€tt att förlĂ€nga linjer och andra enheter. StandardgenvĂ€gen för Extend (Utöka) Ă€r Skift + E.
  • Fillet ( icon layout fillet.png )(Avrundning) () – Avrundningsverktyget skapar exakt rundade hörn mellan tvĂ„ enheter baserat pĂ„ en definierad radie. StandardgenvĂ€gen för Fillet (Avrundning) Ă€r Skift + F.
  • Chamfer ( icon layout chamfer.png ) (Avfasning) () – Avfasningsverktyget lĂ€gger till en 45° vinkel mellan tvĂ„ linjer pĂ„ ett definierat avstĂ„nd. StandardgenvĂ€gen för Chamfer (Avfasning) Ă€r Skift + C.

Dessa verktyg finns i Main Toolbar (HuvudverktygsfÀltet). Trim (Trimma) och Extend (FörlÀng) delar samma plats i verktygsfÀltet med en rullgardinsmeny tillgÀnglig för att vÀxla mellan de tvÄ. Fillet (Avrunda) och Chamfer (Avfasning) delar ocksÄ en verktygsfÀltsikon.

LĂ€s mer

För mer information se Using the Drafting Tools (AnvÀnda ritverktygen).

FörbÀttringar av klippböcker

Vad vi har gjort

LayOuts bibliotek för standardklippböcker inkluderar nu 2D-fönster, dörrar, möbler, kök, badrum och personer under kategorin Architecture (Arkitektur).

Detaljerad information

Klippboksbiblioteken som medföljer LayOut tillhandahÄller vanliga ÄteranvÀndbara element som Àr enkla att lÀgga till och skala i dina teckningar. Vi har nu lagt till en ny klippbok som heter Architecture (Arkitektur). Denna nya klippbok erbjuder vanliga arkitektoniska sammansÀttningar som fungerar bra med modellvyer eller planer som ritats i LayOut.

layout scrapbook libraries.png

Denna nya arkitekturklippboken innehÄller element av följande typer:

  • Dörrar med vĂ€ggmask (dörrar skapade med en rektangel som ”maskerar” ut enheter nedan)

  • Dörrar

  • Windows

  • Vardagsrum

  • Sovrum

  • Kök

  • Badrum

Allt innehÄll i den arkitektoniska klippboken skapas som anpassningsbara skalade grupper.

LĂ€s mer

För mer information om befintliga och nya klippboksbibliotek, se Working with Scrapbooks (Arbeta med klippböcker).

FörbÀttringar av import och export av Layout

Vad vi har gjort

LayOut 2026.0 ger flera uppdateringar till DWG-funktionaliteten, vilket förbÀttrar effektiviteten i hur LayOut importerar och exporterar dina dokument med det filformatet.

Detaljerad information

Om du anvÀnder AutoCAD som en del av dina 2D-arbetsflöden kan LayOut hjÀlpa dig att skapa och underhÄlla ritningar. LayOut har fÄtt en hel del förbÀttringar som hjÀlper till vid arbete med DWG-filer:

  • Sidexport – NĂ€r du exporterar ett LayOut-dokument kan du nu exportera varje sida i dokumentet som en separat DWG-fil.

  • Taggbevarande – Export till DWG bevarar nu taggnamnstrukturerna för dina SketchUp-vyportar.

  • Staplade visningsportar – NĂ€r flera SketchUp-visningsportar finns pĂ„ samma position i ditt dokument, kommer dessa modeller nu ocksĂ„ att staplas ovanpĂ„ varandra i det exporterade DWG-modellutrymmet.

  • Text, skuggningar och tabeller – LayOut exporterar nu text, skuggningar och tabeller korrekt till DWG. Detta inkluderar korrekta AutoCAD-tabellelement med teckensnitts- och kantinstĂ€llningar. LayOut kĂ€nner ocksĂ„ igen och importerar dessa element bĂ€ttre nĂ€r man importerar en DWG till dokumentet.

  • Brutna linjer och kurvor – LayOut skapar nu korrekt kontinuerliga linjer för element som exporterats frĂ„n SketchUp-visningsportar.

LĂ€s mer

För mer information, se Importing CAD Data into LayOut (Importera CAD-data till LayOut) och Exporting CAD Data from LayOut (Exportera CAD-data frÄn LayOut).

Buggfixar och andra förbÀttringar

SketchUp

Stabilitet och prestanda

  • ÅtgĂ€rdade ett problem som orsakade en krasch nĂ€r fĂ€ltet Components (Komponenter) öppnades eller expanderades medan verktyg som Paste (Klistra in), Component (Komponent), Move (Flytta) (i lĂ€get Copy [Kopiera] eller Stamp [StĂ€mpel]), eller Rotate (Rotera) (i lĂ€get Copy [Kopiering]) anvĂ€ndes.

  • Lade till möjligheten att Ă€ndra förhandsgranskningen av materialet (flat [platt], cube [kub] eller automatic switching [automatisk vĂ€xling]) via en kontextmeny

  • Lade till möjligheten att ange en anpassad katalog för mallar i Preferences (InstĂ€llningar)

  • FörbĂ€ttrad automatisk association av .skp- filer. NĂ€r flera versioner av SketchUp Ă€r installerade öppnas .skp- filer nu som standard i den senast installerade versionen.

  • ÅtgĂ€rdade ett problem dĂ€r aviseringar kunde utlösas tre gĂ„nger via Ruby API, men misslyckades den fjĂ€rde.

  • ÅtgĂ€rdade intermittenta krascher vid redigering av Live-komponenter.

  • FörbĂ€ttringar har gjorts för att hantera modellkorruption som tidigare visade felet ”file invalid” (ogiltig fil), och fler fall Ă„tgĂ€rdas nu automatiskt.

  • Ett kraschproblem som kunde uppstĂ„ vid import av mycket stora bilder medan den nya grafikmotorn var aktiv har Ă„tgĂ€rdats.

  • FörbĂ€ttrad V-Ray-integration genom att tillĂ„ta versionsspecifikation pĂ„ nedladdningssidan.

  • ÅtgĂ€rdade en krasch som drabbade vissa exempelfiler nĂ€r specifika grupper valdes och sedan separerades frĂ„n snabbmenyn.

  • ÅtgĂ€rdade ett kraschproblem som kunde uppstĂ„ om en modell som öppnades hade en skadad Normal-karta.

  • Implementerade bĂ€ttre prestanda vid val av stora omrĂ„den av komplexa modeller.

  • ÅtgĂ€rdade en krasch som kunde uppstĂ„ vid kopiering av textobjekt som anvĂ€nde autotextfunktionen.

  • ÅtgĂ€rdade en krasch som kunde intrĂ€ffa nĂ€r tillĂ€gget Create Radius (Skapa radie) anvĂ€ndes.

  • Att dra en skadad komponent till modellscenen frĂ„n panelen Component (Komponent) kommer inte lĂ€ngre att orsaka en krasch.

  • Vissa komponenter kommer inte lĂ€ngre att flimra nĂ€r du anvĂ€nder Orbit-verktyget.

  • En krasch som intrĂ€ffade under importen av en specifik skugga har Ă„tgĂ€rdats. Dessutom löstes ett problem dĂ€r bak- och framsidorna pĂ„ viss geometri var omvĂ€nda under importen.

  • ÅtgĂ€rdade ett fel i dialogrutan Component Options (Komponentalternativ) dĂ€r standardattributvĂ€rden frĂ„n anpassade SKC-filer inte importerades genom att uppdatera importmekanismen för att korrekt analysera och tilldela dessa vĂ€rden frĂ„n XML-schemat.

  • ÅtgĂ€rdade ett problem dĂ€r aviseringar kunde utlösas tre gĂ„nger via Ruby API, men misslyckades den fjĂ€rde.

  • MacOS – ÅtgĂ€rdade ett problem dĂ€r CMD + Tab kunde orsaka verktygsavbrott vid rörelse bort frĂ„n och tillbaka till SketchUp. SketchUp kommer inte lĂ€ngre att förlora inferenser eller ritade linjer nĂ€r den hĂ€r Ă„tgĂ€rden utförs.

  • Windows – Lade till verktygsikoner bredvid mĂ„nga objekt i programmenyerna

  • Windows – ÅtgĂ€rdade ett problem dĂ€r Ruby SketchUp kraschade nĂ€r en HtmlDialog anropades frĂ„n en WebDialog.

  • Windows – ÅtgĂ€rdade ett problem i Windows dĂ€r SketchUp kraschade vid start efter en period av inaktivitet.

AnvÀndbarhet

  • Extension Migrator Ă€r nu förinstallerat och startas automatiskt vid din första installation, vilket uppmanar dig att migrera tillĂ€gg frĂ„n en tidigare installation.

  • Författaren har Ă€ndrats till ”SketchUp” för Extension Migrator för att sĂ€kerstĂ€lla överensstĂ€mmelse med andra levererade tillĂ€gg.

  • ÅtgĂ€rdade ett problem med Extension Migrator dĂ€r ”\r” visades i textstrĂ€ngar i vissa översĂ€ttningar, inklusive franska.

  • Reset Workspace (ÅterstĂ€ll arbetsyta) i Preferences > Workspace (InstĂ€llningar > Arbetsyta) Ă„terstĂ€ller nu SketchUps fĂ€rdiga arbetsyta som avsett.

  • Den ursprungliga importkatalogen sparas nu i File > Preferences (Arkiv > InstĂ€llningar) för alla alternativ för ”importera till modellbibliotek” (Materials, Environments, Styles [Material, Miljöer, Stilar]).

  • ÅtgĂ€rdade ett problem dĂ€r miljöer inte laddades ner direkt till modellen frĂ„n 3D Warehouse

  • ÅtgĂ€rdade ett problem dĂ€r nedladdning av en miljö frĂ„n 3D Warehouse och import av en .ske-fil anvĂ€nde fel namn.

  • ÅtgĂ€rdade ett problem med en avvikelse i den engelska resursmappens sökvĂ€g, vilket resulterade i ett fel i vĂ€lkomstfönstret.

  • Ett fel som kunde göra att Escape-tangenten inte kunde anvĂ€ndas frĂ„n grupp- eller komponentredigeringslĂ€ge har Ă„tgĂ€rdats.

  • ÅtgĂ€rdade ett problem dĂ€r scenminiatyrer visade ett ”?” istĂ€llet för att uppdateras nĂ€r Ă€ndringar gjordes i en Match Photo-scen (Matcha foto).

  • FörbĂ€ttrad statusfĂ€ltstext för att mĂ„la Live-komponenter. Live-komponenten kan nu vĂ€ljas vid mĂ„lningstillfĂ€llet.

  • ÅtgĂ€rdade ett problem dĂ€r komponenter med en skadad transformation försvann vid skalning.

  • FörbĂ€ttrade den tid det tar för konfigurationspanelen för Live-komponenter att visas nĂ€r man vĂ€xlar mellan olika Live-komponenter.

  • Text- eller dimensionselement visar nu den tilldelade taggfĂ€rgen korrekt nĂ€r du vĂ€ljer Color by Tag (FĂ€rglĂ€gg efter tagg).

  • Korrigerade en felaktig rapport om avgrĂ€nsningsrutor för grupper som hade transformerats med Ruby-kod.

  • ÅtgĂ€rdade ett problem dĂ€r material som anvĂ€ndes som taggfĂ€rger inte visades nĂ€r man anvĂ€nde ytstilen Hidden Line med den nya grafikmotorn aktiverad.

  • ÅtgĂ€rdade ett problem dĂ€r ett hjĂ€lptips om kvadrater visades nĂ€r man ritade en rektangel, men den resulterande rektangeln inte var en kvadrat.

  • StatusfĂ€ltstexten för Lasso-verktyget visas nu som avsedd pĂ„ andra sprĂ„k Ă€n engelska.

  • Objekt som ska limmas mot ytor kommer inte lĂ€ngre att rotera felaktigt 180 grader nĂ€r de placeras med verktyget Move (Flytta) i Stamp mode (StĂ€mpellĂ€ge).

  • ÅtgĂ€rdade ett problem i verktyg dĂ€r anvĂ€ndning av gradskivan kunde fĂ„ det att se större ut Ă€n normalt.

  • ÅtgĂ€rdade ett problem som ibland orsakade dolda navigeringsknappar nĂ€r 3D Warehouse eller Extension Warehouse startades.

  • ÅtgĂ€rdade ett problem dĂ€r dimensioner inuti en komponent som skalades inte uppdaterades, och dĂ€r pilarna sĂ„g utstrĂ€ckta ut.

  • ÅtgĂ€rdade en krasch som kunde intrĂ€ffa nĂ€r man öppnade en modell med en skadad stil, eller nĂ€r man valde alternativet Save Out > To 3D Warehouse (Spara ut > Till 3D Warehouse).

  • ÅtgĂ€rdade ett flimmerproblem som kunde uppstĂ„ vid animering mellan scener med olika sektionsplansinstĂ€llningar.

  • ÅtgĂ€rdade en krasch som kunde uppstĂ„ vid ritning med klick-dra-slĂ€pp nĂ€r man anvĂ€nde lĂ€get Stamp (StĂ€mpel) i verktyget Move (Flytta).

  • ÅtgĂ€rdade ett problem dĂ€r innehĂ„llet försvann om man Ă„terstĂ€llde skalan för en grupp.

  • ÅtgĂ€rdade ett problem dĂ€r vissa animationer inte alltid var synliga vid övergĂ„ngar mellan scener med den nya grafikmotorn.

  • ÅtgĂ€rdade ett problem dĂ€r vissa felmeddelanden var förvirrande eller saknade beskrivning av nĂ€sta Ă„tgĂ€rd.

  • Windows – En kortkommando har lagts till i Preferences (InstĂ€llningar) för att visa panelen Environment (Miljö).

  • Windows – Förhandsgranskningen av taggfĂ€rgen i taggpanelen visar nu texturer korrekt istĂ€llet för enbart enfĂ€rgad.

  • Windows – Ett problem som ledde till att fel scen valdes nĂ€r man klickade pĂ„ en flik om man hade mĂ„nga scenflikar har Ă„tgĂ€rdats.

  • Windows – Materialpanelen öppnas och rullar inte lĂ€ngre ovĂ€ntat nĂ€r du Ă„teraktiverar verktyget Paint Bucket (FĂ€rghink) efter att du har anvĂ€nt ett kameraverktyg.

  • Windows – Dialogrutorna Create Material (Skapa material) och Duplicate Material (Duplicera material) visar nu alla kontroller nĂ€r en rullningslist finns.

  • Windows – Om du trycker pĂ„ Enter/Return (Retur) i textredigeringsfĂ€lten i materialpanelen Ă„tergĂ„r fokus nu till huvudfönstret som förvĂ€ntat.

  • Windows – ÅtgĂ€rdade ett problem dĂ€r kopiering av text frĂ„n Ruby-konsolen ledde till att ytterligare en komponent lades till i visningsporten.

  • Windows – ÅtgĂ€rdade ett problem dĂ€r exporterade 2D-bilder visade bakgrundsfĂ€rgen genom hĂ„l i grunden nĂ€r den nya grafikmotorn var aktiverad.

  • MacOS – Ett problem som förhindrade att flera taggmappar separerades samtidigt har Ă„tgĂ€rdats.

  • MacOS – ÅtgĂ€rdade ett problem dĂ€r materialdialogrutan hoppade till toppen av skĂ€rmen nĂ€r man redigerade ett material i modellen.

  • MacOS – ÅtgĂ€rdade ett problem som innebar att om tvĂ„ material hade samma namn, visades det första felaktigt dĂ€r det andra anvĂ€ndes.

  • MacOS – ÅtgĂ€rdade problem i material som kunde leda till en krasch nĂ€r ett pĂ„verkat material duplicerades.

  • MacOS – ÅtgĂ€rdade ett problem dĂ€r miniatyrförhandsvisningar i filutforskaren inte genererades nĂ€r filer sparades.

  • MacOS – ÅtgĂ€rdade ett problem dĂ€r möjligheten att avsluta SketchUp blockerades om SketchUp-fönstret stĂ€ngdes, avsiktligt eller oavsiktligt, under en uppladdning till Trimble Connect, vilket krĂ€vde en tvĂ„ngsavslutning.

LayOut

Interoperabilitet och organisering

  • NĂ€r man exporterar LayOut-filer till DWG kommer taggnamnsstrukturen nu att bibehĂ„llas. – Befintliga filer krĂ€ver en ny rendering av SketchUp-modellvyportar för att det nya exportbeteendet ska trĂ€da i kraft.

  • ÅtgĂ€rdade ett problem som kunde orsaka en förskjutning av kameran vid skalenlig kopiering av SketchUp-modellvyer frĂ„n de övre eller vĂ€nstra greppen.

  • ÅtgĂ€rdade ett fel dĂ€r textjustering kunde Ă€ndras för dimensionstext nĂ€r en fil öppnades i en annan version av LayOut.

  • Ett fel som gjorde att en skalad ritning i en grupp kunde Ă€ndra storlek, vilket orsakade mĂ€tfel för pappersutrymme, har Ă„tgĂ€rdats.

  • ÅtgĂ€rdade ett problem som orsakade att linjebanor som anvĂ€ndes som bifogade ledare hoppade över om banan duplicerades och entiteten sedan flyttades.

  • ÅtgĂ€rdade ett problem med solens position dĂ€r solens position inte uppdaterades i en modell som var en viewport pĂ„ en LayOut-sida.

  • Du kan nu exportera varje LayOut-sida som en separat DWG-fil, namngiven enligt logiken: ”Layoutfilnamn_Sidnummer_Sidnamn.”

  • Lagrade SketchUp-modellvyportar i LayOut kommer nu att exporteras korrekt till samma position inom DWG-modellutrymmet.

  • ÅtgĂ€rdade ett fel som orsakade att text och hĂ€nvisningsenheter visades med felaktig storlek och position nĂ€r stora DWG-filer importerades till LayOut med en skala mindre Ă€n 1:1.

  • Windows – ÅtgĂ€rdade ett problem som visade referenser i dialogrutan Document Setup (DokumentinstĂ€llningar) för fel fil nĂ€r man arbetade med flera dokument i flikgrupper.

  • Windows – ÅtgĂ€rdade ett problem dĂ€r en modells sektionsplansymboler inte visades nĂ€r modellen fanns i en LayOut-dokumentvyport.

  • MacOS – ÅtgĂ€rdade ett problem dĂ€r autotext i dimensioner förkortades eller avkortades efter att en fil sparades och öppnades igen.

AnvÀndargrÀnssnitt och stabilitet

  • ÅtgĂ€rdade ett problem som kunde orsaka ett 107-fel nĂ€r en fil sparades efter att en mönsterfyllning som anvĂ€ndes i en urklippsmask hade rensats.

  • En krasch som kunde uppstĂ„ nĂ€r man uppdaterade en modellreferens pĂ„ en tom sida i dokumentet har Ă„tgĂ€rdats.

  • ÅtgĂ€rdade ett fel som tillĂ€mpade en dubbelklickningsförskjutning pĂ„ utsidan av en entitet istĂ€llet för inuti.

  • ÅtgĂ€rdade ett problem dĂ€r snapping och inferensering kunde intrĂ€ffa pĂ„ delar av en modell som var dolda av en urklippsmask.

  • Fler problem relaterade till teckenstorlek och justeringsskillnader vid anvĂ€ndning av Experimental Graphics Engine (Experimentell grafikmotor) har Ă„tgĂ€rdats.

  • Ett problem som förhindrade skapandet av horisontella eller vertikala linjĂ€ra dimensioner via Ruby API har Ă„tgĂ€rdats.

  • ÅtgĂ€rdade beteendet hos dimensioner pĂ„ textentiteter för att tillĂ„ta dimensionering av text nĂ€r det finns en linjestil tillĂ€mpad pĂ„ texten.

  • Windows – ÅtgĂ€rdade en krasch som orsakades av ett tredjepartsbibliotek vid inlĂ€sning av vissa bilder i LayOut.

  • Windows – ÅtgĂ€rdade ett problem dĂ€r vit text blev transparent vid redigering med Experimental Graphics Engine (Experimentella grafikmotorn).

AnmÀrkningsvÀrda kÀnda problem

  • Uppdatering av tabellreferenser kan resultera i att fel rad- eller kolumndata uppdateras. Detta kan Ă„tgĂ€rdas genom att stĂ€lla in cellomrĂ„det via dialogrutan Table Reference Options (Tabellreferensalternativ).

Lokalisering

  • ÅtgĂ€rdade ett antal lokaliseringsproblem, inklusive saknade översĂ€ttningar, felaktiga produktnamn och trasiga lĂ€nkar i vĂ„rt översatta slutanvĂ€ndarlicensavtal (EULA).

  • ÅtgĂ€rdade ett problem som orsakade att lokaliserade strĂ€ngar Ă„tergick till Ă€ldre översĂ€ttningar. Denna regression pĂ„verkade alla icke-engelska sprĂ„k och skrev över tidigare godkĂ€nda översĂ€ttningar.

  • ÅtgĂ€rdade ett problem som gjorde att klippböcker saknades vid installation pĂ„ andra sprĂ„k Ă€n engelska.

Interoperabilitet

Importörer och exportörer

  • DAE

    • Komponent- och materialnamn ignoreras inte lĂ€ngre av importören.

  • DWG/DXF

    • ÅtgĂ€rdade ett problem dĂ€r import av DWG-filer skapade duplicerade data genom att importera bĂ„de komponentinstans- och komponentdefinitionsnamn.

    • Polylinjer frĂ„n DWG-filer importeras nu som sammanfogade SketchUp-linjer för mer förutsĂ€gbart beteende.

    • ÅtgĂ€rdade ett problem som förhindrade att 3D DWG-filer exporterades korrekt. Även om DWG-filer nu bibehĂ„ller korrekt geometri och sektioner, Ă€r vi medvetna om att aktiva tvĂ€rsnitt som skapats i SketchUp kanske inte Ă€r synliga nĂ€r filen öppnas i AutoCAD. Vi fortsĂ€tter att undersöka detta beteende för att sĂ€kerstĂ€lla att hela avsnittet visas i alla kompatibla applikationer.

  • 3DS

    • ÅtgĂ€rdade ett underliggande problem som orsakade att export till 3DS-formatet misslyckades med vissa modeller.

  • IFC

    • Alla IfcSpace-attribut kan nu returneras.

    • ÅtgĂ€rdade ett problem som orsakade trasig eller saknad geometri vid import av vissa IFC-filer.

    • Anpassade SketchUp-metadata, som introducerades 2025, stöds nu i Trimble Connect.

    • Attribut för IFC-tak, -trappor och -ramper uppdaterades för att uppfylla kraven i buildingSMART Validation Service.

    • IFC-export: ÅtgĂ€rdade ett problem som orsakade att koreanska och japanska tecken blev skadade i IFC-exporter pĂ„ grund av felaktig bearbetning av flerbytestecken. Exportören hanterar nu dessa tecken korrekt med konsekvent UTF-8-kodning.

  • USDZ och TRB

    • ÅtgĂ€rdade ett fel som orsakade att texturer förlorades vid uppladdning av modeller till Trimble Connect.

    • USDZ-importbiblioteket har uppdaterats och har Ă„tgĂ€rdat ett problem dĂ€r filer frĂ„n telefonskanningar visades som svarta genom att anvĂ€nda emissiva texturer som reserv.

    • ÅtgĂ€rdade ett fel som skapade ogiltiga USDZ-filer som inte kunde lĂ€sas in i externa visningsprogram och korrigerade fĂ€rgmappningen för att sĂ€kerstĂ€lla att fĂ€rgerna matchar den ursprungliga SketchUp-filen.

    • Ett problem som orsakade att TrimBIM-filer (.TRB) ökade i storlek med varje exportförsök har lösts.

API-versionsinformation (Ruby & C API)

BrytningsförÀndringar

Ångerbara scenĂ„tgĂ€rder

I SketchUp 2026.0 Àr det nu möjligt att Ängra tillÀgg, borttagning och Àndringar av scener. Tidigare inkluderades inte dessa ÄtgÀrder i Ängra-stacken. Om ett tillÀgg nu modifierar scener med hjÀlp av API:et, lÀggs en ÄtgÀrd till i Ängra-stacken. Om dessa scenmodifieringar inte anropas inuti en Ängra-ÄtgÀrd kommer tillÀgg oavsiktligt att lÀgga till extra ÄtgÀrder i Ängra-stacken.
Vi ber utvecklare att uppdatera och testa sina tillÀgg som fungerar med scener. Se till att alla dina scenÄtgÀrder radbryts mellan Sketchup::Model#start_operation och Sketchup::Model#commit_operation sÄ att ditt tillÀgg inte översvÀmmar Ängra-stacken. Testa att du kan uppdatera ditt tillÀgg sÄ att det fungerar som förvÀntat och rapportera eventuella problem du kan hitta till Centercode tidigt i betacykeln.

  • Att Ă€ndra egenskaperna Sketchup::Axes, Sketchup::Camera, Sketchup::RenderingOptions och Sketchup::ShadowInfo för en Sketchup::Page Ă€r nu en Ă„ngerbar Ă„tgĂ€rd.

  • ScenĂ€ndringar mĂ„ste nu anropas mellan Sketchup::Model#start_operation och Sketchup::Model#commit_operation för att undvika att översvĂ€mma Ă„ngra-stacken. Detta Ă€r en viktig ny dynamik och vi kommer att börja krĂ€va detta för tillĂ€gg som skickas till Extension Warehouse. TillĂ€gg som inte följer detta kommer att avvisas frĂ„n Extension Warehouse.

Icke-inverterbara transformationer
  • {Sketchup::ComponentInstance#transformation=}, {Sketchup::ComponentInstance#transform!}, {Sketchup::Group#transformation=}, {Sketchup::Group#transform!}, {Sketchup::Image#transformation=} och {Sketchup::Image#transform!} accepterar inte lĂ€ngre icke-inversa transformationer (vanligtvis en transformation som skalar till 0 lĂ€ngs nĂ„gon axel).

  • {Sketchup::Entities#transform_entities} kan inte lĂ€ngre tillĂ€mpa icke-inverterbara transformationer pĂ„ {Sketchup::ComponentInstance}, {Sketchup::Group} och {Sketchup::Image}.

Kraschkorrigeringar

  • ÅtgĂ€rdade en krasch i Layout::SketchUpModel nĂ€r man försökte rendera en modell med en miljö innan vyporten hade lagts till i ett Layout::Document.

  • ÅtgĂ€rdade en krasch vid avslutning av Sketchup.send_action i en HTML-dialogruta med hĂ€ndelsen on_close.

  • ÅtgĂ€rdade en Ă„ngra-orsakad krasch relaterad till anvĂ€ndning av Sketchup::Classifications#load_schema och Sketchup::ComponentDefinition#add_classification i samma Ă„tgĂ€rd.

  • ÅtgĂ€rdade en krasch som intrĂ€ffade under en transaktionsĂ„terstĂ€llning som utlöstes av en Ă„ngra-manöver i anvĂ€ndargrĂ€nssnittet.

  • Windows – ÅtgĂ€rdade en krasch under model.place_component().

  • Windows – ÅtgĂ€rdade en krasch nĂ€r en Empty Component Definition (Tom komponentdefinition) placerades i SketchUp.

API-förbÀttringar

SketchUp Ruby API
  • Sketchup::Model#export anvĂ€nder nu en ny IFC-exportör med nya alternativ (:ifc_version, :standard_ifc_hierarchy, :selectionset_only, :tessellated_geometry) och alternativ som inte stöds (:doublesided_faces, :ifc_mapped_items, :ifc_types).

  • Lade till Sketchup::Model#active_section_planes och Sketchup::Page#active_section_planes.

  • Lade till Sketchup::Styles#remove_style och modifierade Sketchup::Styles#add_style för att returnera den tillagda stilen.

  • Lade till det valfria argumentet :show_version_warning_dialog till Sketchup.open_file.

  • Lade till Sketchup::Pages#unique_name.

  • Sketchup::Page#name= justerar nu automatiskt namnet för att göra det unikt om det angivna namnet redan anvĂ€nds.

  • Sketchup::ComponentDefinition#save_as och Sketchup::ComponentDefinition#save_copy returnerar nu falskt om sparandet misslyckas.

SketchUp C API
  • Lade till SUModelGetActiveSectionPlanes och SUModelGetNumActiveSectionPlanes.

  • SUEnvironmentCreateFromFile tillĂ„ter nu en tom namnparameter.

LayOut Ruby API
  • En ny valfri parameter för Layout::LinearDimension#initialize gör det möjligt att ange mĂ„ttlinjens justering vid skapandet (DIMENSION_LINE_ALIGNED, DIMENSION_LINE_VERTICAL, DIMENSION_LINE_HORIZONTAL).

  • Lade till Layout::LinearDimension#leader_line_visible?.

  • Lade till Layout::Style#text_strikethrough och Layout::Style#text_strikethrough= med konstanterna (STRIKETHROUGH_NONE, STRIKETHROUGH_SINGLE).

  • Lade till API för LayOut-attributstrukturer:

    • Layout::Document#set_attribute

    • Layout::Document#get_attribute

    • Layout::Document#delete_attribute

    • Layout::Document#attribute_dictionary

    • Layout::Entity#set_attribute

    • Layout::Entity#get_attribute

    • Layout::Entity#delete_attribute

    • Layout::Entity#attribute_dictionary

    • Layout::Page#set_attribute

    • Layout::Page#get_attribute

    • Layout::Page#delete_attribute

    • Layout::Page#attribute_dictionary

    • Tillagd {Layout::Dictionary}-lektion

LayOut C API
  • Lade till LOLinearDimensionCreateWithAlignment() och LOLinearDimensionAlignment-upprĂ€kningen.

  • Lade till LOLinearDimensionGetLeaderLineVisible().

  • Lade till LOStyleGetTextStrikeThrough(), LOStyleSetTextStrikeThrough() och LOTextStrikeThrough-upprĂ€kningen.

  • Lade till funktioner för SketchUp Model Camera och Viewport Overrides

    • LOSketchUpModelGetCamera(), LOSketchUpModelSetCamera()

    • LOSketchUpModelSetViewportOverridesOnModel()

    • LOSketchUpModelResetViewportOverridesOnModel()

    • Lade till API för LayOut-attributstrukturer:

    • LODocumentSetAttribute()

    • LODocumentGetAttribute()

    • LODocumentDeleteAttribute()

    • LOEntityCreateAttributeDictionaryCopy()

    • LOEntitySetAttribute()

    • LOEntityGetAttribute()

    • LOEntityDeleteAttribute()

    • LOPageCreateAttributeDictionaryCopy()

    • LOPageSetAttribute()

    • LOPageGetAttribute()

    • LOPageDeleteAttribute()

  • Lade till upprĂ€kningsvĂ€rdet LOTypedValueType::LOTypedValueType_Dictionary

  • Lade till LOTypedValueGetDictionary() och LOTypedValueSetDictionary()

IFC-export API
  • Ruby API har uppdaterats för att anpassas till den nya enhetliga IFC-exportören, vilket innebĂ€r att gamla metoder förĂ„ldras och nya funktioner lĂ€ggs till för att kontrollera IFC-version och hierarki.

API-buggkorrigeringar

Ruby API
  • ÅtgĂ€rdade en regressionsfel i Sketchup::Model#drawing_element_visible? som utlöste ett undantag.

  • {Geom::Transformation#inverse} och {Geom::Transformation#invert!} tar upp ArgumentError för icke-inverterbara transformationer (vanligtvis en transformationsskalning till 0 i valfri axel).

  • UI.inspector_names() listar nu korrekt panelen Environments (Miljöer).

  • ÅtgĂ€rdade ett problem dĂ€r filkorruption kunde uppstĂ„ om man sparade filer med SketchUp API.

  • Samma namn kan inte lĂ€ngre tilldelas flera scener via Ruby API.

  • Dokumentationen för renderingsalternativet visar nu det accepterade vĂ€rdet, och om kanttypen stĂ€lls in pĂ„ 1 kraschar inte SketchUp.

  • Dokumentationsuppdateringen för DWG-export visar nu materialalternativet.

  • NĂ„gra andra dokumentationsproblem har Ă„tgĂ€rdats

C API
  • SUModelAddLayers() sĂ€kerstĂ€ller nu att lagernamn Ă€r unika.

KĂ€nda problem

  • {Sketchup::Image#transformation=} och {Sketchup::Image#transform!} misslyckas tyst för icke-inverterbara transformationer.

  • {Sketchup::Entities#transform_entities} misslyckas tyst för icke-inverterbara transformationer pĂ„ {Sketchup::CompoenntInstance}, {Sketchup::Group} och {Sketchup::Image}.