Novità di SketchUp 2024
SketchUp per Desktop
Nuovo motore grafico – Il motore grafico di SketchUp è stato aggiornato. Il nuovo motore grafico sfrutta le tecnologie hardware e software emergenti, migliorando notevolmente la navigazione tra i file e i livelli di reattività.
Ambient Occlusion (Occlusione ambientale) – È un nuovo stile per le facce, che permette di vedere più chiaramente le interazioni di bordi e facce all'interno dei modelli, assicurando profondità e realismo in SketchUp.
Trimble Connect e condivisione dei collegamenti – Ora SketchUp per Desktop include un'integrazione nativa con Trimble Connect, che permette di condividere agevolmente un collegamento a una versione di sola visualizzazione del modello e di accedere rapidamente ai file SKP tramite dispositivi diversi.
Add Location (Aggiungi posizione) – La nuova opzione Add Location (Aggiungi posizione) semplifica l'aggiunta di informazioni precise di alta qualità sui terreni, offrendo anche un flusso di lavoro aggiornato, una freccia che indica chiaramente il Nord geografico e opzioni di importazione migliorate.
Miglioramento delle funzioni di importazione ed esportazione dei file IFC – Ora l'importazione dei file IFC in SketchUp è più rapida e prevedibile. Abbiamo inoltre aggiornato in vari modi le funzioni per l'esportazione in formato IFC-4, nell'intento di garantire la coerenza dei dati e ottimizzare i file, ad esempio aggiungendo un'opzione di tessellatura della geometria e apportando diverse modifiche alla modalità di esportazione dei componenti.
Interoperabilità con i file USDZ e gITF – La nuova funzionalità di importazione ed esportazione per i file USDZ e gITF apre le porte a nuove possibilità, per flussi di lavoro di visualizzazione avanzati e transizioni fluide da e verso gli strumenti standard del settore per la creazione dei contenuti digitali.
Ground Mesh (Mesh del terreno) in Scan Essentials – Il nuovo strumento Ground Mesh (Mesh del terreno) di Scan Essentials consente di trasformare in modo semplice e rapido la scansione di una nuvola di punti 3D in una precisissima mesh solida del terreno, modificabile e manipolabile in SketchUp.
Finestra di dialogo di errore delle estensioni – Se una delle estensioni non viene caricata all'avvio di SketchUp, viene visualizzata una nuova finestra di dialogo di errore, che può aiutarti a identificare l'estensione che non funziona e consentirti di aggiornarla, se è disponibile un aggiornamento, oppure di disinstallarla.
Miglioramenti della modellazione – Sono stati apportati alcuni miglioramenti agli strumenti e alle funzionalità di base per la modellazione, nell'intento di aumentare la produttività e aiutare l'utente a mantenere la concentrazione sul flusso creativo.
Importatore Revit – Ora l'Importatore Revit di SketchUp è compatibile con Revit 2024.
LayOut
File di LayOut senza versione – Apartire dalla versione 24.0, i file di LayOut sono senza versione. In questo modo, i file creati con la versione 2024 possono essere aperti nelle versioni di LayOut supportate (fino a due anni prima della versione corrente) senza essere prima salvati in una versione specifica dell'anno in questione.
Scheda Performance (Prestazioni) – Nella nuova scheda Performance (Prestazioni) della finestra Preferences (Preferenze) è stata introdotta la modalità Draft (Bozza), per migliorare le prestazioni grafiche mentre si lavora su un documento. E puoi anche prorvare il motore grafico sperimentale di LayOut [Labs].
Ambient Occlusion (Occlusione ambientale): nei riquadri di visualizzazione di LayOut viene riconosciuto e utilizzato il nuovo stile per le facce Ambient Occlusion (Occlusione ambientale), per una documentazione 2D più completa.
Miglioramento dell'inferenza – Inferenza Ora il blocco dell'inferenza in LayOut è più simile a quello di SketchUp. Inoltre, mentre lavori su un documento, LayOut limita i riferimenti disponibili quando disegni sulle entità più vicine all'ultimo clic del mouse, per aumentare la reattività in caso di spostamento e copia delle entità.
Etichette non ridimensionabili – Ora le etichette non dispongono più di cursori per il ridimensionamento, ma possono essere comunque ridimensionate quando sono collegate alla geometria di LayOut o di SketchUp.
Miglioramenti della funzione di esportazione – Ora, quando si esporta un documento, è possibile scegliere diversi intervalli di pagine contemporaneamente. Oltre al nome del file, le esportazioni includono anche i nomi delle pagine.
Correzioni di bug e altri miglioramenti
SketchUp
Nuovo motore grafico di SketchUp
Cosa abbiamo fatto
Il motore grafico di SketchUp è stato aggiornato. Il nuovo motore grafico sfrutta le tecnologie hardware e software emergenti, assicurando notevoli miglioramenti in termini di navigazione tra i file e reattività.
I dettagli
Il nuovo nuovo motore grafico di SketchUp è estremamente avanzato, e consente di sfruttare le tecnologie hardware e software emergenti per offrire un'esperienza di modellazione ancora più fluida. I miglioramenti principali includono l'aumento della frequenza di fotogrammi durante l'orbita di modelli con dimensioni e livelli di complessità variabili, oltre a maneggevolezza e reattività superiori. Anche se i risultati possono variare, i nostri test interni hanno dimostrato che le configurazioni più comuni risultano di circa 2,4 volte più veloci, rispetto al motore grafico classico di SketchUp. Per le configurazioni di fascia alta, abbiamo registrato una velocità 8,4 volte superiore, e in alcuni casi anche di più.
Se necessario, è ancora possibile utilizzare il motore grafico classico di SketchUp, utilizzando le opzioni della nuova sezione Graphics (Grafica) della finestra Preferences (Preferenze) per passare in qualsiasi momento da un motore grafico all'altro.

Il nuovo motore grafico non è supportato da tutte le configurazioni hardware in grado di eseguire SketchUp per Desktop. Per le configurazioni non supportate, o se SketchUp riconosce che il nuovo motore risulterà più lento o instabile sul dispositivo in uso, viene visualizzata una notifica per segnalare che SketchUp continuerà a utilizzare il motore grafico classico.
Ulteriori informazioni
Per ulteriori informazioni sul nuovo motore grafico e sulle opzioni disponibili nella nuova sezione Graphics (Grafica) della finestra Preferences (Preferenze), leggi l'articolo Grafica nel nostro Help Center.
Funzione Ambient Occlusion (Occlusione ambientale)
Cosa abbiamo fatto
La nuova impostazione di stile Ambient Occlusion (Occlusione ambientale) permette di vedere più chiaramente le interazioni di bordi e facce all'interno dei modelli, assicurando profondità e realismo in SketchUp.
I dettagli
Ambient Occlusion (Occlusione ambientale) è una nuova impostazione di stile disponibile con il nuovo motore grafico di SketchUp, che utilizza tecniche di ombreggiatura e rendering per mostrare più chiaramente le interazioni di bordi e facce, per aumentare la percezione della profondità nei modelli, aumentandone il realismo.

Ulteriori informazioni
Ambient Occlusion (Occlusione ambientale) è un'impostazione di stile globale che può essere attivata dal menu View (Visualizza): View > Face Style > Ambient Occlusion (Visualizza > Stile viso > Occlusione ambientale) oppure tramite la funzione di ricerca. Utilizzando questa funzionalità puoi anche selezionare stili di occlusione ambientale predefiniti nel pannello Styles (Stili) oppure modificare i cursori delle impostazioni di Ambient Occlusion (Occlusione ambientale) e creare nuovi stili. Per ulteriori informazioni, leggi l'articolo Scelta di uno stile.
Trimble Connect e condivisione dei collegamenti
Cosa abbiamo fatto
SketchUp ora include un'integrazione nativa con Trimble Connect da cui è possibile condividere facilmente un collegamento a una versione di sola visualizzazione di un modello e accedere rapidamente ai file .skp su tutti i dispositivi, tramite SketchUp per Desktop, per iPad e per il Web.
I dettagli
Trimble Connect è un ambiente dati comune (CDE, Common Data Environment) basato su cloud e una piattaforma di collaborazione espressamente progettata per il settore dell'edilizia. L'abbonamento SketchUp include l'accesso a Trimble Connect, con spazio di archiviazione illimitato sul cloud. In passato Trimble Connect era accessibile tramite l'estensione Trimble Connect, disponibile in Extension Warehouse, ma ora non è più necessario ricorrere a tale estensione, perché Trimble Connect è stato integrato direttamente in SketchUp per Desktop. Trimble Connect offre una barra degli strumenti dedicata, e nel menu File sono disponibili anche altre opzioni.

La nuova integrazione Trimble Connect consente di:
Aprire e salvare facilmente i file in Trimble Connect.
Tenere traccia delle revisioni e controllare quando è stato effettuato l'ultimo aggiornamento a un file.
Scambiare rapidamente modelli fra SketchUp per Desktop, SketchUp per il Web e SketchUp per iPad.
Condividere un collegamento di sola visualizzazione a un modello salvato in Trimble Connect.
Ulteriori informazioni
Per ulteriori informazioni su come ottenere il massimo da Trimble Connect, leggi l'articolo Utilizzo di Trimble Connect con SketchUp.
Aggiungi posizione
Cosa abbiamo fatto
La nuova opzione Add Location (Aggiungi posizione) rende più semplice l'aggiunta di terreni accurati e di alta qualità, mettendo a disposizione un flusso di lavoro aggiornato, rendendo visibile il Nord geografico e offrendo opzioni di importazione migliorate.
I dettagli
La nuova opzione Add Location (Aggiungi posizione) è stata ottimizzata in modo da semplificare al massimo la geolocalizzazione di un modello e l'importazione di informazioni dettagliate sul terreno, con risultati più prevedibili, soprattutto quando vengono importate grandi quantità di dati.

La nuova opzione Add Location (Aggiungi posizione) include:
Un indicatore di posizione che può essere attivato e disattivato.
Una freccia che indica il Nord geografico per aiutare a orientare correttamente il modello in base al nord nel progetto. Utile per chi deve generare simulazioni di sole e ombre.
Una versione ghost del modello, che consente di verificare se si adatta al terreno da importare.
Aree di importazione più ampie, indipendentemente dalla risoluzione.
Possibilità di regolare in modo indipendente ogni lato dell'area selezionata.
Un cursore che permette di regolare la densità della tessellatura del terreno da importare.
Dati di qualità superiore per importazioni di grandi e medie dimensioni.
Possibilità di visualizzare tutte le importazioni precedenti durante ogni importazione successiva.
Gestione più efficace dei tag.
Ulteriori informazioni
Dai un'occhiata ai nostri articoli relativi ad Add Location (Aggiungi posizione) per ulteriori informazioni sul funzionamento di questa nuova opzione.
Miglioramento delle funzioni di importazione ed esportazione dei file IFC
Cosa abbiamo fatto
Ora l'importazione dei file IFC in SketchUp è più rapida e prevedibile. Abbiamo inoltre aggiornato in vari modi le funzioni per l'esportazione in formato IFC-4, nell'intento di garantire la coerenza dei dati e ottimizzare i file, ad esempio aggiungendo un'opzione di tessellatura della geometria e apportando diverse modifiche alla modalità di esportazione dei componenti.
I dettagli
I file IFC contengono un sistema di classificazione utilizzato dal Classificatore di SketchUp. Sono stati apportati diversi miglioramenti importanti al processo di importazione ed esportazione dei file IFC, ad esempio:
Ora è possibile importare file IFC contenenti caratteri speciali, come "ã"”, "ó" e "g".
È possibile importare testo da lingue con caratteri non arabi come giapponese, cinese o greco.
È stata inoltre aggiunta un'opzione che consente di preservare l'origine del disegno durante l'importazione.
Per l'esportazione di file IFC4, SketchUp ora offre opzioni aggiuntive, tra cui:
Esportazione della tessellatura della geometria. La tessellatura contribuisce a ottimizzare i dati, dimezzando le dimensioni del file esportato.
Esportazione di tipi PredefinedTypes/Object. Ora questi attributi vengono esportati come attributi di classe.
Preservazione delle unità di misura degli attributi. Ora il valore Imperial (Imperiale) o Metric (Metrico) delle unità di misura di attributi come "Position" ("Posizione") e "Size" ("Dimensione") viene mantenuto durante l'esportazione.
Esportazione di attributi dinamici. Tutti gli attributi dinamici dei componenti vengono esportati nel file IFC4, in un set di proprietà di nome "SU_DynamicAttributes".
Ulteriori informazioni
Per ulteriori informazioni sull'utilizzo dei file IFC in SketchUp, leggi l'articolo Classificazione di oggetti.
Interoperabilità tra USDZ e gITF
Cosa abbiamo fatto
La funzionalità di importazione ed esportazione è ora disponibile sia per i file USDZ che gITF e apre nuove possibilità per flussi di lavoro di visualizzazione avanzati e transizioni fluide da e verso strumenti di creazione di contenuti digitali standard del settore.
I dettagli
Il formato USDZ, sviluppato da Pixar, è noto per la possibilità di gestire in modo efficiente le scene e le animazioni 3D complesse. Il formato gITF, il "cosiddetto JPEG del 3D", offre un metodo efficace per trasmettere e caricare i modelli 3D. Ora SketchUp offre la possibilità di importare ed esportare entrambi i formati, aumentando i livelli di interoperabilità fra le piattaforme per garantire una visualizzazione 3D avanzata.
Ulteriori informazioni
Per ulteriori informazioni, leggi l'articolo Utilizzo dei dati di SketchUp con altri programmi o strumenti di modellazione.
Ground Mesh (Mesh del terreno) in Scan Essentials
Cosa abbiamo fatto
Il nuovo strumento Ground Mesh (Mesh del terreno) di Scan Essentials consente di trasformare in modo semplice e veloce la scansione di una nuvola di punti 3D in una precisissima mesh solida del terreno, che puoi modificare e manipolare in SketchUp. Inoltre, con questo aggiornamento, Scan Essentials utilizza lo stesso linguaggio di SketchUp.
I dettagli
Scan Essentials è disponibile con l'abbonamento SketchUp Studio. Il nuovo strumento Ground Mesh (Mesh del terreno) di Scan Essentials offre i nuovi metodi Fit Cloud (Adatta nuvola), Rectangular (Rettangolare) o Bounded (Delimitato) per creare un terreno a partire da una nuvola di punti 3D.
Con il metodo Fit Cloud (Adatta nuvola), la mesh si adatterà ai dati del terreno scansionato e i buchi si riempiranno automaticamente.

Il metodo Rectangular (Rettangolare) consente di designare un'area rettangolare all'interno dei dati scansionati, per definire una mesh del terreno.

Il metodo Bounded (Delimitato) consente di creare una mesh del terreno da mappare alla faccia selezionata di un modello.

Ulteriori informazioni
Per informazioni dettagliate su come utilizzare il nuovo strumento Ground Mesh (Mesh del terreno) e le altre funzionalità, per sfruttare al meglio i dati della nuvola di punti nei modelli di SketchUp, leggi l'articolo Utilizzo di Scan Essentials.
Finestra di dialogo di errore delle estensioni
Cosa abbiamo fatto
Se una delle estensioni non viene caricata all'avvio di SketchUp, viene visualizzata una nuova finestra di dialogo di errore che può aiutarti a identificare l'estensione malfunzionante e consentirti di aggiornarla, se è disponibile un aggiornamento, oppure di eliminarla.
I dettagli
Le estensioni sono un'ottima soluzione per personalizzare SketchUp ed espanderne le funzionalità. A volte, però, può succedere che non vengano caricate (in genere perché non sono aggiornate). Per una maggiore stabilità di SketchUp, in caso di errore di una o più estensioni all'avvio dell'applicazione, viene visualizzato il seguente messaggio di errore:

Quando viene visualizzato questo errore, SketchUp verifica la presenza di un aggiornamento dell'estensione problematica in Extension Warehouse. È quindi possibile visualizzare i dettagli dell'errore, copiarli, scegliere di aggiornare l'estensione, disabilitarla o disinstallarla.
Ulteriori informazioni
Nell'articolo Errori delle estensioni della sezione Risoluzione dei problemi dell'Help Center puoi trovare ulteriori informazioni su come procedere quando si verifica uno di questi errori.
Miglioramenti alla modellazione
Cosa abbiamo fatto
Sono stati apportati alcuni miglioramenti agli strumenti e alle funzionalità di base per la modellazione, nell'intento di aumentare la produttività e aiutare l'utente a mantenere la concentrazione sul flusso creativo.
I dettagli
Con questo aggiornamento, abbiamo migliorato anche alcuni degli strumenti più importanti di SketchUp e delle principali funzionalità native di modellazione. Ecco una panoramica delle modifiche apportate:
Maniglie di rotazione dello strumento Move (Sposta): ora è possibile attivare o disattivare le maniglie di rotazione dello strumento Move (Sposta) nella sezione Drawing (Disegno) di Preferences (Preferenze) per limitare il rumore visivo e rendere più facile la navigazione nello strumento di spostamento. È inoltre disponibile una scorciatoia per questa nuova preferenza di disegno.
Applicazione del comando Undo (Annulla) a un'operazione in corso – Ora la funzione Undo (Annulla) consente di annullare l'operazione in corso, senza annullare l'azione precedente.
Inferenza sulle guide: a volte, quando si disegnava una linea da un oggetto a una guida, l'inferenza sulle guide non funzionava. Ora è possibile utilizzare le guide come inferenza in modo più efficace durante il disegno.
Inferenze in un rettangolo – Quando si disegna un rettangolo su una faccia, ore è possibile usare l'inferenza sui bordi all'interno della faccia stessa, per allineare il rettangolo a qualunque bordo sullo stesso piano della faccia su cui viene disegnato.
Inferenza con scala inclinata – Questa nuova funzionalità visualizza una "X" quando la geometria che stai ruotando interseca la faccia a cui la stai "appoggiando", proprio come quando si appoggia una scala contro un muro.
Modifiche non salvate* (Windows) – In Windows, se il modello contiene modifiche che non sono ancora state salvate, viene visualizzato un asterisco ("*") dopo il nome del file sulla barra del titolo dell'applicazione. Su Mac la presenza di modifiche non salvate è indicata da un punto grigio al centro del pulsante rosso Chiudi.
LayOut
LayOut senza versione
Cosa abbiamo fatto
I file di LayOut a partire dalla versione 23.0 ora sono senza versione, quindi i file creati nel 2024 possono essere aperti nelle versioni di LayOut dell'anno precedente senza dover essere salvati in un formato specifico.
Performance (Prestazioni)
Cosa abbiamo fatto
Nella finestra Preferences (Preferenze) è stato introdotto un nuovo gruppo di opzioni, che include ad esempio la modalità Draft (Bozza), con lo scopo di migliorare le prestazioni grafiche mentre si lavoro su un documento.
I dettagli
La nuova scheda Performance (Prestazioni) della finestra Preferences (Preferenze) fornisce opzioni per la gestione della grafica in LayOut, che possono contribuire a migliorare le prestazioni complessive. La modalità Draft (Bozza) e il nuovo motore grafico sperimentale sono due funzioni molto importanti.

La modalità Draft (Bozza) consente di posticipare il rendering delle entità nella pagina durante la navigazione. In modalità Draft (Bozza) LayOut visualizza una versione semplificata, senza spessori di linea, trattini o motivi di riempimento finali. Puoi abilitare la modalità Draft (Bozza) quando devi spostarti fra le pagine oppure attivarla/disattivarla quando lavori su pagine con una grafica pesante. Queste modifiche si notano solo mentre si lavora sul documento, perché si limitano ad alleggerire il carico per migliorare la velocità di spostamento all'interno dei file, continuando a mantenere una risoluzione elevata in caso di esportazione del disegno.
Il motore grafico sperimentale di LayOut è una funzionalità di SketchUp Labs disabilitata per impostazione predefinita. Tuttavia, puoi attivarla per capire come migliorare le prestazioni, assicurando al tempo stesso un'infrastruttura grafica moderna ed estremamente flessibile.
Ulteriori informazioni
Queste opzioni sono illustrate in modo più dettagliato nell'articolo Prestazioni.
Inferenza migliorata
Cosa abbiamo fatto
Ora, il funzionamento dell'inferenza in LayOut è più simile a quello di SketchUp. Mentre lavori su un documento, LayOut limita i riferimenti disponibili quando disegni sulle entità più vicine all'ultimo clic del mouse,
I dettagli
offrendo un contesto più familiare agli utenti che sono abituati a utilizzare l'inferenza in SketchUp.

Inoltre, le inferenze attive durante lo spostamento e la copia delle entità sono state semplificate, in modo che LayOut esegua l'inferenza solo rispetto al punto da cui è stata prelevata un'entità. Potrai notare una maggiore reattività durante lo spostamento, la copia e il posizionamento delle entità in una pagina.
Ulteriori informazioni
Per informazioni dettagliate sul funzionamento delle inferenze in LayOut in seguito a questo miglioramento, leggi l'articolo Utilizzo delle inferenze.
Etichette non scalabili
Cosa abbiamo fatto
Ora le etichette non dispongono più di cursori per il ridimensionamento, ma possono essere comunque ridimensionate quando sono collegate alla geometria di LayOut o di SketchUp.
I dettagli
Lo strumento Label (Etichetta) di LayOut () consente di creare un'entità etichetta con una casella di testo, una linea (tecnicamente chiamata direttrice) e una freccia o un'estremità che punta a un elemento specifico nell'area di disegno. Abbiamo aggiornato il funzionamento di queste etichette eliminando i cursori di ridimensionamento, ma consentiamo di ridimensionarle comunque quando sono collegate a un'altra geometria.
Ulteriori informazioni
Per una descrizione più dettagliata delle etichette, leggi l'articolo Etichettatura di elementi in un documento.
Miglioramenti della funzione di esportazione
Cosa abbiamo fatto
Ora, quando esporti un documento, puoi selezionare più intervalli di pagine contemporaneamente e/o eseguire l'esportazione includendo i nomi delle pagine nei nomi dei file.
I dettagli
Ora puoi specificare più intervalli di pagine da esportare contemporaneamente, ovvero esportare più pagine o intervalli di pagine specifici contemporaneamente senza eseguire esportazioni separate.
Inoltre, i nomi delle pagine vengono inclusi nei nomi dei file di immagine esportati, per consentirti di individuarle più facilmente all'esterno di LayOut.
Ulteriori informazioni
Per ulteriori informazioni, leggi l'articolo Esportazione o stampa di un documento di LayOut.
Correzioni di bug e altri miglioramenti
SketchUp
Stabilità
È stato risolto un arresto anomalo che poteva verificarsi aprendo determinati file creati con SketchUp 2023.1.
(Windows) È stato risolto un arresto anomalo che si verificava quando le estensioni inviavano messaggi a SketchUp, soprattutto quando si cambiavano scene con Scan Essentials installato.
È stato risolto un arresto anomalo che si verificava in caso di immissione di un valore elevato per il numero di segmenti in un arco.
Strumenti
È stata aggiunta la possibilità di mostrare le maniglie di rotazione dello strumento Move (Sposta) come preferenza, disattivabile e attivabile tramite scelta rapida
È stata migliorata la visibilità degli snap durante l'utilizzo dello strumento Move (Sposta)
È stata migliorata la manipolazione degli snap che si trovano sopra un vertice (ad esempio, i vertici dei bordi)
Sono state migliorate le modifiche all'orientamento di uno snap esistente
Miglioramenti ai passaggi necessari per posizionare uno snap
È stata modificata la voce del menu di scelta rapida per modificare l'orientamento dello snap. Ora è Reorient Snap (Riorienta snap)
In alcuni strumenti, ad esempio Move (Sposta), gli snap ora sono visibili per qualsiasi oggetto selezionato. In precedenza era necessario posizionare il puntatore del mouse sull'oggetto per visualizzarne gli snap
È stata aggiunta la voce Reverse Snap (Snap inverso) al menu di scelta rapida
È stato risolto un problema che causava la cancellazione di uno snap se questo veniva selezionato e poi si premeva Esc
È stato risolto un problema a causa del quale camminare in determinati modelli portava nella direzione opposta
È stato risolto un problema a causa del quale Undo (Annulla) non aveva alcun effetto
(Windows) Gli strumenti nativi nella barra degli strumenti non possono più essere rimossi involontariamente facendo clic mentre la finestra di dialogo della barra degli strumenti è aperta
(Windows) Ora è possibile fare clic in un punto qualsiasi della scheda con il nome della scena quando la si rinomina
(Windows) È stata aumentata la dimensione del pulsante "Add Tag" (Aggiungi tag) nella barra dei tag in modo che sia più simile alle dimensioni degli altri pulsanti
(Windows) Per migliorare l'efficienza della funzionalità di modifica, durante la modifica del nome e della descrizione di una scena nella barra delle scene, premendo il tasto Tab si avanza tra i campi
Scan Essentials
Scan Essentials è stato aggiornato alla versione 1.2024.0318
Importatore Revit
Importatore Revit è stato aggiornato alla versione 1.2024.0318
Funzione Ambient Occlusion (Occlusione ambientale)
Il pannello Styles (Stili) ora offre una nuova libreria di stili predefinita, Ambient Occlusion (Occlusione ambientale). Prova queste varianti e mostraci gli stili che crei con Ambient Occlusion (Occlusione ambientale)!
È stato risolto un bug per cui Status (Stato) non risultava tradotto nel menu Ambient Occlusion (Occlusione ambientale)
Varie
Sia in SketchUp che in LayOut è stata modificata la posizione dei file di lavoro che servono per recuperare modelli e documenti. Ora si trovano nel seguente percorso:
Windows: C:\<UserName>\AppData\Local\SketchUp\SketchUp 2024\SketchUp\working\Mac: /Library/Application Support/SketchUp 2024/SketchUp/working/
È stato risolto un problema per cui i puntini creati con Ruby non erano visualizzati correttamente
È stata corretta una situazione in cui l'opzione Fix Problems (Risolvi problemi) in Model Info/Statistics (Informazioni/Statistiche modello) poteva cancellare i bordi del terreno
(Windows) È stato risolto un problema a causa del quale le modifiche nella finestra di dialogo di debug della fotocamera non avevano effetto
È stato risolto un problema a causa del quale le prestazioni della casella di controllo Tags (Tag) erano inadeguate nell'impostazione della scena
È stata aggiunta la possibilità di cambiare GPU in Preferences > Graphics (Preferenze > Grafica) nelle configurazioni con schede grafiche dedicate
È stato risolto un problema a causa del quale, dopo l'avvio, SketchUp mostrava il fuso orario UTC-7 e nel modello predefinito non era impostato nessun fuso orario
È stato risolto un problema che causava l'arresto anomalo di SketchUp quando veniva aggiunto un componente dal pannello dei componenti
È stato risolto un problema che causava l'arresto anomalo di SketchUp in seguito all'aggiunta di un componente dal pannello dei componenti
È stato risolto un problema per cui quando veniva utilizzata la selezione dei colori nella finestra di dialogo Materials (Materiali), la geometria selezionata diventava nera anziché del colore corretto
È stato risolto un problema che impediva di annullare il processo di stampa
È stato risolto un problema per cui il testo di un tag selezionato non veniva visualizzato correttamente
È stato risolto un problema relativo alla finestra di dialogo Styles (Stili) a causa del quale il cursore dei raggi X per la trasparenza non funzionava correttamente
È stato risolto un problema a causa del quale le barre non si agganciavano correttamente quando veniva selezionato il pulsante Reset workspace (Ripristina area di lavoro)
È stato risolto un problema relativo allo strumento di testo a causa del quale l'hotspot non veniva visualizzato quando si passava il mouse sulla geometria
È stato risolto un problema a causa del quale il tasto ESC non permetteva di uscire dalla finestra di dialogo del componente dopo la modifica
È stato risolto un problema relativo al posizionamento della finestra di Ruby a causa del quale la nuova posizione della finestra di dialogo non veniva impostata correttamente
È stato risolto un problema a causa del quale l'uso del tasto Tab in Entity Info (Informazioni entità) non seguiva l'ordine corretto.
È stato risolto un problema a causa del quale la geometria senza tag non veniva visualizzata correttamente in Entity Info (Informazioni entità)
È stato risolto un problema a causa del quale la selezione di un tag nel modello causava un aumento della larghezza della barra
È stato risolto un problema a causa del quale l'utilizzo di scelte rapide, ad esempio per lo strumento zoom, causava la visualizzazione della lettera "Z" nella casella Measurements (Misure)
È stato risolto un problema a causa del quale le descrizioni delle scene non funzionavano correttamente
È stato risolto un problema a causa del quale, durante l'utilizzo del riquadro di visualizzazione, la larghezza del pannello nella finestra di dialogo cambiava in modo casuale
È stato risolto un problema a causa del quale i tag scomparivano quando si selezionava File/New (File/Nuovo)
Sono state corrette diverse traduzioni errate nelle interfacce localizzate
(Windows) È stato risolto un problema a causa del quale il classificatore, la barra degli strumenti dei tag e la casella Measurements (Misure) non venivano visualizzati correttamente
(Windows) È stato risolto un problema a causa del quale la scheda Edit (Modifica) nella finestra di dialogo Material (Materiale) non veniva visualizzata correttamente se era selezionato RGB
(Windows) Sono stati risolti i problemi relativi all'installazione dell'Importatore Revit. Inoltre, il programma di installazione non seleziona più per impostazione predefinita le estensioni Scan Essentials e Revit.
(Mac) È stato risolto un problema a causa del quale gli hotspot del cursore a 32x32 non venivano visualizzati
È stato risolto un problema a causa del quale la risposta alla richiesta HtmlDialog - Large POST aveva un formato non valido
(Windows) È stato risolto un problema a causa del quale il testo del nome della miniatura della scena non era allineato
(Windows) È stato risolto un problema relativo alla finestra di dialogo Save as (Salva con nome) di Trimble Connect, a causa del quale se si usava Alt+Tab tra le applicazioni, la finestra di dialogo non risultava più modale e si sovrapponeva ad altre applicazioni
(Windows) È stato apportato un miglioramento per fare in modo che la barra degli strumenti di Trimble Connect venga visualizzata per impostazione predefinita a destra della barra degli strumenti superiore
(Windows) È stato risolto un bug a causa del quale, con alcune risoluzioni dello schermo, mancava parte del bordo del menu delle barre degli strumenti
(Windows) È stato risolto un bug che causava la visualizzazione di spessori diversi per alcuni separatori di menu
Sono stati risolti problemi relativi a traduzioni mancanti o errate, ad esempio per il testo associato allo strumento Offset, a Share a Link (Condividi un collegamento), Customize (Personalizza), Location Pin (Indicatore posizione) e Model Info Units (Unità Informazioni modello)
LayOut
Stabilità
Le prestazioni di caricamento dei documenti sono state migliorate. Il rallentamento era dovuto a un controllo che stavamo eseguendo per correggere un problema di taglio che si verificava durante l'interazione con piani vicini e lontani in SketchUp, quindi potrebbero essere presenti istanze in cui il riquadro di visualizzazione dei modelli di SketchUp risulta tagliato. Ti invitiamo anche a comunicarci se noti un miglioramento nel caricamento dei file.
I nostri modelli predefiniti ora hanno l'override dell'output disabilitato.
Riquadri di visualizzazione dei modelli di SketchUp
Ora, quando si deseleziona lo sfondo nella finestra di ispezione dei modelli di SketchUp, il cielo, il terreno e l'orizzonte non vengono più visualizzati nel riquadro di visualizzazione.
È stato aggiornato il comportamento delle dimensioni per impedire il dimensionamento ai limiti del riquadro di visualizzazione dei modelli di SketchUp
È stato risolto un problema a causa del quale LayOut richiedeva un nuovo rendering di un riquadro di visualizzazione dei modelli di SketchUp in momenti casuali
È stato risolto un problema a causa del quale una sostituzione di stile non veniva mantenuta quando un riquadro di visualizzazione veniva copiato e incollato
Varie
È stato risolto un problema a causa del quale non veniva ridimensionato il rettangolo di selezione quando si riduceva il numero di entità selezionate contemporaneamente tramite il tasto Maiusc
È stato risolto un problema a causa del quale il tasto Esc non chiudeva la finestra di dialogo Find Text (Trova testo)
È stato risolto un comportamento che causava lo spostamento delle griglie quando si modificavano i margini della carta e le relative impostazioni
È stato risolto un problema per cui lo strumento gizmo di precisione veniva visualizzato nella posizione sbagliata quando si annullava uno spostamento o una rotazione
È stato risolto un problema a causa del quale nei documenti con testo RTF venivano inseriti caratteri imprevisti
È stato risolto un problema a causa del quale il ridimensionamento di etichette e dimensioni causava una posizione errata del centro di controllo della rotazione
È stato risolto un bug relativo all'annullamento di una scelta rapida di testo non assegnata, a causa del quale era necessario digitare la scelta rapida due volte in caso di annullamento del comando
È stato risolto un bug che causava un arresto anomalo quando il testo veniva sostituito da testo automatico in Windows
(Windows) È stato risolto un problema che causava il rendering errato di archi e cerchi senza linee continue in caso di esportazioni delle immagini
(Mac) È stato risolto un problema a causa del quale lo stato attivo poteva rimanere bloccato nella finestra di ispezione delle pagine fino al riavvio di LayOut
È stato risolto un problema di localizzazione delle preferenze di LayOut in tutte le lingue, dove Pan and Zoom Redraw Delay (Ritardo ridisegno panoramica e zoom) non era tradotto
È stato risolto un problema a causa del quale l'avvio di LayOut dalla riga di comando con l'opzione -lang non apriva LayOut nella lingua specificata
Style Builder
Correzioni di bug
(Mac) È stato risolto un problema per cui Style Builder si arrestava in modo anomalo quando veniva chiuso
È stato risolto un arresto anomalo alla chiusura di Style Builder (Mac)
API SketchUp
Overlay con API C
Stiamo introducendo API C che consentono alle estensioni di disegnare sulla vista di SketchUp, permettendo il disegno combinato tramite informazioni sulla trasparenza e/o sulla profondità. Le nuove funzionalità di overlay delle API C assicurano funzioni che gli overlay delle API Ruby non permettevano di avere.
In passato, le estensioni avanzate (ad esempio per il rendering) dovevano utilizzare tecniche specifiche della piattaforma per ottenere un handle alla vista di SketchUp ed eseguire il disegno. Queste soluzioni alternative non funzionano più dopo l'introduzione del nuovo motore grafico. Ci auguriamo che queste nuove API rappresentino un metodo stabile e documentato per consentire il funzionamento di queste utili estensioni.
Il pacchetto SDK include un semplice progetto di esempio (denominato "Overlays") che dimostra il funzionamento delle API. Dopo averlo esaminato, facci sapere se manca qualcosa.
Ruby 3.2
Abbiamo eseguito l'aggiornamento a Ruby 3.2.2.
Ulteriori aggiunte e miglioramenti all'API Ruby
La versione di OpenSSL in Ruby è stata aggiornata a OpenSSL 1.1.1w
È stato aggiunto il supporto dell'opzione di esportazione :page_range per Layout::Document#export
È stato aggiunto Sketchup::View#graphics_engine
Correzione dei bug della API Ruby
È stato risolto un problema su Mac a causa del quale UI.create_cursor forniva un hotspot errato
È stata corretta la regressione in Sketchup.resize_viewport aggiunta in SketchUp 2023.1 in Windows
È stato risolto un problema a causa del quale la console Ruby non scorreva automaticamente fino alla fine dopo la cancellazione dei contenuti
È stato risolto un problema a causa del quale venivano attivati determinati tipi di observer Ruby se il modello veniva salvato durante la modifica di un componente. Nello specifico, onOpen/onClose di InstanceObserver e onTransactionStart/onTransactionCommit di ModelObserver non devono più essere richiamati in tale situazione.