SketchUp 2026.0 有哪些新功能?
Desktop 版 SketchUp
在 SketchUp 協同合作 – 您現在可以透過私人邀請,或建立並分享公開連結來分享 SketchUp 模型。被分享者可以瀏覽模型、進行測量、留言評論,甚至能即時看到更新內容。
視覺化 – SketchUp 26.0 新增環境光遮蔽的距離倍增器與顏色控制、可反轉材質粗糙度貼圖,以及材質縮圖自選等備受期待的功能。
效能 – SketchUp 2026.0 全面提升記憶體管理與運作效率,讓 SketchUp 更高效、更快速、更穩定。這些效能更新在處理大型模型時效果尤為顯著。
- Live Components – SketchUp 2026.0 為比例工具新增了掣點功能 (
),讓您能依據推算,輕鬆定位並調整 Live Components 的尺寸。現在您也能利用油漆桶工具 (
),將材質套用至元件預設選項外的部位,因此我們針對繪製 Live Components 新增了多項使用者體驗改進。 建模流程與介面更新 – SketchUp 2026.0 在縮放、旋轉、場景及推算等功能上都有多項顯著改善。
管理授權啟用 – 您現在可直接在 Desktop 版 SketchUp 內重設所有授權啟用,並授權目前的裝置。
互通性 – SketchUp 2026.0 現在針對匯入與匯出 DWG 檔案,在保真度及效率上帶來多項升級。這些提升包括支援填充圖案,同時保留剖面平面。IFC 匯出流程亦已升級,將 IFC 2x3 與 IFC 4 統整為單一檔案類型,並擴展了匯出選項。
Scan Essentials – Scan Essentials 新增兩種點雲建模流程:材質投影與網格生成工具。此全新場景管理器能充分控制點雲於 SketchUp 與 LayOut 中的可見性。這次更新還讓您在匯出時,可輕鬆回復至原始的地理參考座標系統。
LayOut
LayOut 介面與效能更新 – Windows 版 LayOut 介面外觀與操作更貼近 SketchUp,且圖示風格、工具盤和面板設定,以及工具列自訂等皆已更新。
LayOut 製圖工具 – 現已推出四項全新製圖工具:修剪、延伸、圓角與倒角。讓您以更直覺、更高效的方式建立與操控 2D 向量繪圖。
剪貼簿增強 – LayOut 預設剪貼簿現於「建築」分類下新增 2D 窗戶、門、家具、廚房、衛浴圖庫,另外也新增了平面圖人物元件庫。
匯入與匯出增強 – LayOut 2026.0 針對 DWG 功能進行多項更新,全面強化 LayOut 匯入與匯出 DWG 文件的效率,包括保留 SketchUp 標籤並自動轉換成 DWG 圖層。
錯誤修復和其他功能改進
SketchUp
在 SketchUp 協同合作
我們做了什麼
您現在可以透過私人邀請,或建立並分享公開連結來分享 SketchUp 模型。被分享者可以瀏覽模型、進行測量、留言評論,甚至能即時看到更新內容。
詳細資料
SketchUp 2026.0 推出多項新功能來協助您分享模型,並與同儕、利害相關人協同合作。這些功能都整合在全新的協作工具列中,可協助您分享模型、控管分享對象的存取權限,並邀請他人提供回饋意見。
使用協作工具列進行分享

在協作工具列中,點選「Share(分享)」即可邀請他人檢視您的模型。若尚未將模型儲存至 Trimble Connect,系統會跳出提示,請您先儲存。
欲傳送私人邀請時,請輸入電子郵件地址並設定其存取權限。檢視者將收到帶有私人連結的電子郵件,點選即可存取您的模型。若模型設為公開存取,點選「Copy Link(複製連結)」即會產生供任何人使用的公開連結,點選即可檢視您的模型。

檢視者點開您分享給他人的連結,便會在他們的網頁瀏覽器中打開您的模型。檢視者有權存取基本資訊,並根據您設定的存取權限看到其他選項。您隨時都能設定或變更檢視者的存取權限。收到私人邀請的檢視者擁有以下權限:
擁有者 – 模型擁有者一律可完整存取全部的檢視功能。
檢視場景 – 能檢視模型中的各個場景,但無法自由瀏覽模型或留言評論。
評論 – 可留言評論、使用所有相機工具,並存取檢視者的所有公用程式。
「公開存取」權限則定義了當某人使用您的公開連結,或在無私人邀請的前提下,試圖存取並檢視您的模型時會怎麼樣。公開存取不包含在模型中留言評論的功能。模型的公開存取可設定為:
無權限 – 當他人嘗試存取您的模型時,他們會收到向您請求存取權限的提示。您可接著同意、拒絕其要求,甚或忽視!
檢視場景 – 透過公開連結存取的檢視者僅可瀏覽場景。
檢視模型 – 透過公開連結存取的檢視者可自由瀏覽與測量模型。
評論

檢視者可透過評論工具留言評論。啟用評論工具後,您可以將游標懸停在物件上,並選擇要留言評論的精確位置。除了文字評論的交流外,您也能在留言串中新增圖片、連結,甚至不同的相機位置。
每則評論都能與特定場景建立關聯。這意味著每當檢視者點選建模視窗的評論標記時,SketchUp 將顯示該留言串、啟用最後選取的場景,並切換至該評論的相機位置。您也可選擇將評論與其他場景相關聯,或完全不指定場景。
即時檢視與相機控制
預設狀態下,檢視者可即時看到您的建模更新。您所做的任何變更都會對任何人顯示,若能看到游標,檢視者甚至能看到您正在使用的工具。檢視者正在使用的導覽工具,例如捲尺、平移或旋轉工具,也會對所有人顯示。
若您希望檢視者從特定視角查看您的模型,您可在協作工具列點選您的頭像。每位檢視者的視角都會切換成您的視角。如想查看其他檢視者看到的畫面,只需改點他們的頭像即可。
深入了解
如欲深入了解 SketchUp 提供的所有新增協作功能,請參閱「Connect and Collaborate(連結與協作)」。
視覺化增強
我們做了什麼
SketchUp 26.0 新增環境光遮蔽的距離倍增器與顏色控制、可反轉材質粗糙度貼圖,以及材質縮圖自選等備受期待的功能。
詳細資料
環境光遮蔽
環境光遮蔽面樣式有兩項重大增強 – 包括距離倍增器滑桿與顏色樣本控制。

距離倍增器滑桿可精細控制模型中遮蔽效果的呈現距離。數值愈高,畫面縮小時仍可看到遮蔽效果。

全新顏色樣本控制可依您選擇的顏色產生動態陰影效果。當您使用色輪、HLS、HSB 或 RGB 等控制項調整顏色,色彩效果將即時呈現在模型中。
反轉粗糙度
SketchUp 的「逼真材質」提供了自訂模型表面的外觀和質感的許多選項。透過新增的「反轉粗糙度」選項,您可以翻轉材質粗糙度貼圖的黑白值。反轉粗糙度為您提供了其他選擇,讓您充分控制表面的平滑或粗糙度。
材質縮圖(僅限 Windows)
因應大量用戶需求,材質縮圖現可自訂,同時支援立方體和 2D 平面圖像的顯示方式。
在材質預覽上按一下右鍵,即可於「Auto Thumbnail(自動縮圖)」、「Cube Thumbnail(立方體縮圖)」或「Flat Thumbnail(平面縮圖)」間進行選擇。選取「自動縮圖」時,逼真紋理將顯示為立方體;「立方體縮圖」則強制以立方體顯示材質;「平面縮圖」則以經典的 2D 圖像顯示縮圖。
深入了解
如需了解更多 SketchUp 的視覺化功能,請參閱「材質、紋理與環境」。
效能
我們做了什麼
SketchUp 2026.0 全面提升記憶體管理與運作效率。這些變更讓 SketchUp 更有效率、更快速且更穩定,特別是在處理大型模型時。
詳細資料
記憶體增強
SketchUp 現已強化記憶體管理,針對多種元素與流程的記憶體配置與運用方式皆進行了優化,包括:
模型載入 – SketchUp 現在能以更高的效率載入模型資料,並縮減初始記憶體高峰。
降低記憶體負擔 – SketchUp 優化了元件的記憶體預留空間,從而減少記憶體浪費。
Windows 圖形資源效率 – Windows 使用者將注意到圖形資源分配的改進,進一步提升了記憶體使用效率。
經由這些記憶體改進,SketchUp 耗用的整體記憶體更低。這意味著:
特別是在記憶體空間較少的裝置上處理大型模型時,當機與凍結情形將減少。
系統更穩定、反應更即時,讓您安心長時間工作不中斷。
操作更流暢、反應更迅速。
工作效率提升
SketchUp 2026.0 強化了多項常用操作的速度,為下列增強功能提供了更流暢的操作體驗:
選取與推算 – 優化核心選取及操作代碼,大幅提升如選取、開啟或關閉元件,以及推算小型目標等作業速度。
場景切換 – 增強場景切換邏輯,讓大型模型的場景切換更順暢,並讓每秒畫格提升約 86%。
縮放範圍 – 使用「縮放範圍」時,速度提升約 90%。
清除未使用項目 – 清理未用標籤所需時間大幅縮短。
注意:效能預估乃基於在不同硬體配置上以各種複雜度的模型進行的內部基準測試。實際體驗會依您的硬體及模型數據而異。
深入了解
欲進一步了解 SketchUp 系統需求,請參閱我們的「硬體與軟體需求」。
Live Components
我們做了什麼
SketchUp 2026.0 在比例工具中另增了 Live Components 的掣點功能。這些掣點讓您能透過推算來定位並調整 Live Components 尺寸。我們也針對繪製 Live Components 新增了多項使用者體驗改進。
詳細資料
縮放 Live Components

這些掣點並不總是鎖定於元件邊界。這代表您能充分識別您正在調整的元件及其在模型中的最佳擺放位置。查看 3D Warehouse 的 SketchUp 內容庫,瀏覽專為 SketchUp 訂閱戶提供的可縮放 Live Components。並非所有現有 Live Components 都具備縮放掣點,未來將有更多元件陸續支援此功能!
改進材質工作流程
顏料桶工具現可對 Live Components 項套用自訂材質,甚至是該元件本身未提供的新材質。此更新流程現在包含:改良材質貼圖、選取 Live Components 項時直接繪製、優化材質處理方式,以及一系列幕後變動,以增進與 SketchUp 材質庫的相容性。

深入了解
欲了解詳情,請參閱「SketchUp Live Components」。
一般建模改進
我們做了什麼
SketchUp 2026.0 在縮放、旋轉、場景與推算功能上都有多項顯著改進。
詳細資料
縮放改進
在縮放物件時,其掣點若被其他幾何物遮蔽,常常需來回旋轉、平移或調整可見性方能操縱。在小空間內,縮放往往需要額外的點擊動作。縮放掣點現在會穿透其他幾何物顯示,讓您隨時都能清楚看見並點選它們。

旋轉改進
SketchUp 2025 首次於旋轉工具加入旋轉控制手把。這些手把支援快速的雙擊旋轉,但在鎖定旋轉平面後會造成非預期的結果。為了避免這些問題,當您鎖定旋轉平面時,旋轉掣點將不再顯示。

從輪廓邊緣移動元件
放置物件時,您要放置的物件可能會遮蔽背景元素,導致對齊變得困難。有些變通做法包括顯示背面邊緣、開啟 X 光模式,或切換週框方塊掣點。
為了解決這些問題,現在可以利用群組和元件的一條輪廓邊緣來操作。該物件將變為透明,讓您更容易觀察並選擇您的擺放目標。即使沒顯示輪廓邊緣,此功能依然有效,但仍取決於相機位置與幾何複雜度。

場景復原與重做
錯誤更新場景可能令人沮喪。在 2026.0 版本之前,您可能需要花費數小時,或需尋找新擴充程式,才能將場景恢復到您想要的位置。為了解決這個問題,現在已提供場景更新的復原與重做功能。復原與重做的操作方式就跟編輯模型的其他部分一樣,同時也支援建立、重新命名與刪除等操作。
清除未使用項目
儲存模型時出現的「清除未使用項目」提醒,現在預設為關閉。您仍可在偏好設定中管理此提醒。啟用時,您現在可以精確控制要清除哪些項目,有助於避免誤刪有用資源。「清除未使用項目」亦出現在「Edit(編輯)」選單中,且可自訂快捷鍵,讓您隨時依需求清除任何內容。
工具盤與面板 (Windows)
作為持續更新 SketchUp 介面的一環,您現在可以直接在工具盤與面板標題上按右鍵,以管理其可見性。選取尚未勾選的面板,即可在所選工具盤中顯示此面板。當您想啟用工具盤,或在工具盤中顯示面板時,這項新功能可替代「視窗」選單。

此外,面板現在也能在不同工具盤間拖曳,或拖至工作區成為獨立工具盤。如欲將新視窗轉為工具盤,您可於暫時工具盤上按右鍵並點選「Make Tray(建立工具盤)」。
深入了解
如需這些新功能的詳細教學,請參閱「繪製線條、形狀與 3D 物件」。
管理授權啟用
我們做了什麼
您現在可以直接在 Desktop 版 SketchUp 內重設所有授權啟用,並授權目前的裝置。
詳細資料
SketchUp 的終端使用者授權協議 (EULA) 限制了訂閱內包含的各應用程式的安裝和授權數,僅限於兩個實例或裝置。如您嘗試在第三台裝置上安裝並授權應用程式,或開啟第三個應用程式實例,將跳出「您已超過允許的授權啟用」訊息。
若您於啟動 Desktop 版 SketchUp 時看到此訊息,現在會顯示某選項,讓您無需存取帳戶管理頁,即可重設所有授權啟用,並授權當前裝置。

深入了解
如需更多管理授權啟用的說明,請參閱「管理授權啟用」。
SketchUp 互通性
我們做了什麼
SketchUp 2026.0 現在針對匯入與匯出 DWG 檔案,在保真度及效率上帶來多項升級。這些提升包括支援填充圖案,同時保留剖面平面。IFC 匯出流程亦已升級,將 IFC 2x3 與 IFC 4 統整為單一檔案類型,並擴展了匯出選項。
詳細資料
DWG 匯入選項
匯入 DWG 檔時,現在新加入「Import Layers as Groups(將圖層匯入為群組)」及「Import Linework Flattened(匯入扁平化的線條)」兩選項。
選擇「Import Layers as Groups(將圖層匯入為群組」時,SketchUp 會根據匯入的 DWG 檔圖層結構建立相對應群組。這些匯入的圖層既有自己的標籤,現在也有對應的群組幾何體,讓您能更有效地管理匯入模型的可見性。

選擇「Import Linework Flattened(匯入扁平化的線條)」後,匯入幾何體的 Z 值將設為 0,可減少將 2D CAD 數據轉為 3D 模型時常見的匯入後清理工作。此工具能消除 Z 軸差異,避免產生錯位等破壞性問題,有助於您從乾淨且精準的基礎開始建模。如您熟悉其他 CAD 軟體,此功能與那些軟體中的「Flatten(扁平化)」很像。
DWG 填充圖案支援
SketchUp 現在可直接匯入 DWG 檔案中的填充圖案。匯入的實心填充圖案會轉換為面。非實心填充圖案會轉換為邊線。
匯出 3D 剖面
匯出 3D DWG 檔時,SketchUp 現已能保留剖面平面,產生 DWG 剖面。這些剖面可接著用於 AutoCAD 內的「Generate Section Block(產生剖面方塊)」及「2D Section / Elevation(2D 剖面/立面)」等功能。
其他 DWG 增強
SketchUp 2026.0 還納入了以下 DWG 改進:
DWG 檔中的多段線,現可匯入為焊接 SketchUp 線段。
SketchUp 現在能妥善處理元件實例名稱,減少重複資料。
3D 多段線會如預期般顯示於匯入結果對話框中。
匯出真實曲線時效果更佳。
多項 3D AutoCAD 匯出器的問題皆已修正。
3D 多段線匯出成 2D DWG 時將更貼近預期效果。
IFC 匯出器增強
匯出模型時,IFC 2x3 與 IFC 4 選項現已整合為檔案類型清單中的一項 IFC 檔案格式。您可接著在全新「Export Options(匯出選項)」對話框中選擇特定 IFC 版本。

全新的 IFC 匯出選項對話框亦新增了「Standard IFC Spatial Hierarchy(標準 IFC 空間階層)」選項。勾選後,即使模型的大綱結構中未定義,也會建立 IfcProject、IfcSite 或 IfcBuilding 等必要實體。
深入了解
如需更多 SketchUp 匯入與匯出的操作說明,請參閱「搭配其他建模程式或工具使用 SketchUp 資料」。
Scan Essentials
我們做了什麼
Scan Essentials 新增兩種點雲建模流程:材質投影與網格生成工具,此全新場景管理器能充分控制點雲於 SketchUp 與 LayOut 中的可見性,還可在匯出時將轉換設定重設為原始的地理參考座標系統。
詳細資料
擁有 Scan Essentials 權限的 SketchUp 訂閱戶,現在可以使用兩項新工具:材質投影與表面網格。
透過材質投影,您可從掃描資料中擷取影像紋理,並投影至 SketchUp 幾何體。投影紋理會轉為 SketchUp 材質,可重複用於模型其他部分,若儲存下來,甚至還能用於其他模型。

全新的表面網格工具,讓您更輕鬆從點雲中擷取 SketchUp 幾何體。選擇表面網格工具後,您可決定擷取區域、定義擷取幾何體的方式,僅需幾個步驟即可建立網格。

除了這些新工具之外,現在還能將點雲管理器的可見性設定儲存為場景,適用於 SketchUp 與 LayOut。

最後,於點雲管理器點選「Reset Transformations(重設轉換)」時,現在會重設所有轉換設定,包括全域轉換。對於想將其原始數據匯出至其他應用程式的用戶而言相當實用。

深入了解
如需詳細資訊,請參閱「SketchUp 的 Scan Essentials」。
LayOut
LayOut 介面與效能更新
我們做了什麼
Windows 版 LayOut 介面外觀與操作更貼近 SketchUp,且圖示風格、工具盤和面板設定,以及工具列自訂等皆已更新。
詳細資料
Windows 版 LayOut 的新介面為您的 LayOut 文件注入了 SketchUp 風格。

LayOut 的工具盤與面板現在的操作方式非常類似 SketchUp 的對應工具。您可根據個人工作流程,於工作區任意擺放這些工具、拖出面板並建立新工具盤。工具列也做了類似的改進,可如 SketchUp 般在工作區內隨意擺放。
向量與混合渲染效能
LayOut 的隱藏線渲染 (HLR) 運算會生成向量線稿,供向量與混合模式的 SketchUp 檢視區使用。我們已大幅提升此流程的處理速度。
深入了解
如需詳細資訊,請參閱「在 LayOut 建立文件」。
LayOut 製圖工具
我們做了什麼
現已推出四項全新製圖工具:修剪、延伸、圓角與倒角,讓您以更直覺、更高效的方式建立與操控 2D 向量繪圖。
詳細資料
LayOut 的全新繪圖工具可協助在執行細部設計和圖表繪製等簡單 2D 任務時,繞過不必要的選擇,並消除額外的清理工作。每項工具的具體功能如下:
- 修剪 (
) – 修剪工具能有效清除線段或圖形,無需清理其他向量圖。修剪會移除多餘線段、產生俐落交集,提升操作速度與準確度。預設快捷鍵:Shift + T。 - 延伸 (
) – 延伸工具讓 2D 製圖更簡單,可快速、輕鬆地延伸線段與其他實體。預設快捷鍵:Shift + E。 - 圓角 (
) – 圓角工具可在兩個實體間,依指定半徑建立精確圓弧角。預設快捷鍵:Shift + F。 - 倒角 (
) – 倒角工具會在兩條線之間,以指定距離新增 45° 斜角。預設快捷鍵:Shift + C。
這些工具均可於主工具列中找到。修剪與延伸共用同一工具列位置,可透過下拉選單切換。圓角與倒角則共用另一個工具列圖示。
深入了解
如需更多資訊,請參閱「使用製圖工具」。
剪貼簿增強
我們做了什麼
LayOut 預設剪貼簿圖庫現於「建築」分類下新增 2D 窗戶、門、家具、廚房、衛浴和人物。
詳細資料
LayOut 隨附的剪貼簿圖庫提供了常見的可重複利用元素,可輕鬆加到您的製圖並隨意縮放。我們現已新增全新的「建築」剪貼簿。這本新剪貼簿提供了常見的建築組件,可與模型檢視區或您在 LayOut 內繪製的平面圖搭配使用。

全新「建築」剪貼簿包含以下元素類型:
帶牆體遮罩的門(以矩形「遮罩」蓋掉下方實體的門)
門
Windows
客廳
臥室
廚房
浴室
所有建築剪貼簿內容皆建立為可自訂之按比例縮放群組。
深入了解
如需更多現有及新剪貼簿圖庫的資訊,請參閱「使用剪貼簿」。
LayOut 匯入與匯出增強
我們做了什麼
LayOut 2026.0 針對 DWG 功能進行多項更新,全面強化 LayOut 匯入與匯出 DWG 文件的效率。
詳細資料
如您將 AutoCAD 當成 2D 流程的一環,LayOut 可協助您建立與維護製圖。LayOut 強化了幾項 DWG 檔案的相關操作:
頁面匯出 – 匯出 LayOut 文件時,現可將每一頁分別匯出為獨立的 DWG 檔案。
標籤保留 – 匯出為 DWG 時,現在會保留 SketchUp 檢視區之標籤命名結構。
堆疊檢視區 – 當文件中的多個 SketchUp 檢視區位於同一處時,這些模型現在也會在匯出 DWG 檔的模型空間相互堆疊。
文字、填充圖案與表格 – LayOut 現可正確匯出文字、填充圖案與表格至 DWG。包括支援正確含字型與邊界設定的 AutoCAD 表格元素。將 DWG 匯入文件時,LayOut 也能充分辨識與匯入這些元素。
中斷線與曲線 – LayOut 現已可針對由 SketchUp 檢視區匯出的元素,正確建立連續線段。
深入了解
如需更多詳情,請參閱「在 LayOut 匯入 CAD 資料」及「從 LayOut 匯出 CAD 資料」。
錯誤修復和其他功能改進
SketchUp
穩定性與效能
修正了使用貼上、元件、移動(複製或壓印模式)或旋轉(複製模式)等工具時,開啟或展開元件工具盤會導致當機的問題。
新增可透過右鍵選單變更材質預覽樣式(平面、立方體或自動切換)的功能
新增可在偏好設定中自訂範本目錄的功能
改進 .skp 檔案的自動關聯功能。當系統中安裝多個 SketchUp 版本時,.skp 檔案現在會自動以最新版本開啟。
修正了使用 Ruby API 觸發通知時,前三次可成功觸發,但第四次會失效的問題。
修復了編輯 Live Components 時偶發的當機問題。
改善了模型損毀的處理機制,原本顯示「檔案無效」的錯誤情況,現在可自動修復更多案例。
修正了啟用新圖形引擎時匯入過大影像會導致當機的問題。
改進了 V-Ray 整合,現在可在下載頁面指定版本。
修復了某些範例檔中,選取特定群組後透過右鍵選單執行分解時發生的當機問題。
修正了開啟含有損毀法線貼圖的模型時可能發生的當機問題。
改善了選取複雜模型大範圍區域時的效能表現。
修正了複製使用自動文字功能的文字物件時可能發生的當機問題。
修復了使用 Create Radius(建立半徑)擴充程式時可能導致的當機問題。
從元件面板拖曳損毀元件至模型場景時,不再導致當機。
修正了部分元件在使用環繞移動工具時閃爍的問題。
修復了匯入特定填充圖案時的當機問題。並解決了匯入過程中某些幾何體正反面顛倒的情況。
修正了元件選項對話框中的錯誤,現在自訂 SKC 檔案的預設屬性值可正確匯入。匯入機制已更新,可依 XML 架構正確解析與套用屬性值。
修正了使用 Ruby API 觸發通知時,前三次可成功觸發,但第四次會失效的問題。
MacOS – 修正了使用 CMD + Tab 切換至其他應用程式再返回 SketchUp 時,工具可能中斷的問題。現在切換後 SketchUp 將不再遺失推論與繪圖內容。
Windows – 在應用程式選單中的多個項目旁新增了工具圖示
Windows – 修正了從 WebDialog 呼叫 HtmlDialog 時,Ruby SketchUp 可能當機的問題。
Windows – 修正了長時間閒置後啟動 SketchUp 可能導致當機的 Windows 問題。
易用性
Extension Migrator 現在已預先安裝,並會在首次安裝時自動執行,提示您從先前版本移轉擴充套件。
為保持與其他內建擴充程式一致,Extension Migrator 的作者已統一變更為「SketchUp」。
修正了 Extension Migrator 在部分語言(如法文)翻譯中,文字字串出現「\r」符號的問題。
「Preferences > Workspace(偏好設定 > 工作空間)」中的「Reset Workspace(重設工作空間)」功能,現在會正常復原 SketchUp 的預設工作空間。
初始匯入目錄現在會儲存在「File > Preferences(檔案 > 偏好設定)」,適用於所有「匯入至模型庫」選項(材質、環境、樣式)。
修正了從 3D Warehouse 下載環境時,無法直接匯入至模型的問題
修正了從 3D Warehouse 下載環境並匯入 .ske 檔時使用不正確名稱的問題。
修正了英文資源資料夾路徑設定錯誤,導致歡迎視窗出錯的問題。
修正了按下 Escape 鍵時無法退出群組或元件編輯模式的問題。
修正了在「Match Photo(相片比對)」場景中進行修改時,場景縮圖顯示「?」而未更新的問題。
改良了 Live Components 上色時的狀態列文字。現在可在上色時直接選取 Live Components 項。
修正了元件的轉換內容損毀時,縮放後會消失的問題。
改善了在不同 Live Components 項間切換時,顯示設定面板的反應速度。
選擇「Color by Tag(依標籤顏色)」顯示時,文字與尺寸現在會正確顯示所屬標籤顏色。
修正了使用 Ruby 程式碼轉換群組時,邊框報告不正確的問題。
修正了在新圖形引擎下使用隱藏線的面樣式時,標籤顏色材質未顯示的問題。
修正了繪製矩形時出現提示「正方形」但實際繪出的形狀並非正方形的問題。
套索工具的狀態列文字在非英文介面中已可正常顯示。
使用移動工具的壓印模式放置貼附於面的物件時,物件不再被錯誤旋轉 180 度。
修正了使用量角器時,其顯示尺寸異常放大的問題。
修正了啟動 3D Warehouse 或 Extension Warehouse 時,導覽按鈕有時會消失的問題。
修正了縮放元件時,內部尺寸未更新且箭頭變形的問題。
修正了開啟含有損毀樣式的模型,或選擇「Save Out > To 3D Warehouse(存檔匯出 > 至 3D Warehouse)」時可能發生的當機問題。
修正了切換不同剖面平面設定的場景時,場景動畫閃爍的問題。
修正了使用移動工具的壓印模式進行拖曳繪製時可能發生的當機問題。
修正了重設群組縮放比例後內容消失的問題。
修正了在使用全新圖形引擎時,部分場景轉換動畫未正確顯示的問題。
修正了部分錯誤訊息內容模糊或未清楚指示後續步驟的問題。
Windows – 在偏好設定中新增了可開啟環境面板的鍵盤快捷鍵。
Windows – 標籤面板中的標籤顏色預覽現在會正確顯示紋理,而不僅是實色。
Windows – 修正了有多個場景分頁時,點擊分頁可能選錯場景的問題。
Windows – 使用相機工具後重新啟用顏料桶工具時,材質面板不會再自動展開並滾動。
Windows – 建立或複製材質對話框出現捲軸時現在會顯示所有控制項。
Windows – 在材質面板的文字編輯欄中按下 Enter/Return 後,焦點現在會正常返回主視窗。
Windows – 修正了從 Ruby 控制台複製文字時,檢視區會新增元件的問題。
Windows – 修正了匯出 2D 圖像時,在啟用新圖形引擎的情況下,地面開孔區域顯示背景色的問題。
MacOS – 修正了無法同時展開多個標籤資料夾的問題。
MacOS – 修正了編輯模型內材質時,材質對話方塊會跳至畫面頂端的問題。
MacOS – 修正了兩個材質名稱相同時,第一個材質會錯誤地顯示在應用第二個材質的位置的問題。
MacOS – 修正了複製異常材質時可能導致當機的問題。
MacOS – 修正了儲存檔案時,File Explorer(檔案總管)中未生成縮圖預覽的問題。
MacOS – 修正了在上傳至 Trimble Connect 期間關閉 SketchUp 視窗(無論是主動關閉或誤觸)後,導致無法正常退出 SketchUp,而需要強制結束的問題。
LayOut
互通性與組織性
匯出 LayOut 檔案為 DWG 時,現在會保留標籤名稱結構。- 現有檔案必須重新渲染 SketchUp 模型檢視區,新的匯出行為才會生效。
修正了從上方或左側掣點進行縮放複製 SketchUp 模型檢視區時,攝影機位置可能偏移的問題。
修正了在不同版本的 LayOut 開啟檔案時,尺寸文字的對齊方式可能改變的問題。
修復了當群組中包含縮放繪圖時,縮放可能導致紙上空間測量誤差的問題。
修正了當附帶引線的線條路徑被複製後,再移動實體時,該線條路徑會發生跳動的問題。
修正了太陽位置未在 LayOut 頁面中的模型檢視區內更新的問題。
現在可將每個 LayOut 頁面單獨匯出為 DWG 檔案,命名規則為「LayOut 檔案名稱_頁碼_頁面名稱」。
在 LayOut 中堆疊的 SketchUp 模型檢視區現在匯出至 DWG 模型空間時,將能正確維持相同堆疊位置。
修正了當匯入比例小於 1:1 的大型 DWG 檔案至 LayOut 時,文字與引線顯示尺寸與位置錯誤的問題。
Windows – 修正了在標籤群組中開啟多個文件時,文件設定對話方塊顯示錯誤檔案參照的問題。
Windows – 修正了當模型位在 LayOut 文件檢視區時,模型的剖面平面符號未顯示的問題。
MacOS – 修正了在儲存並重新開啟檔案後,尺寸中的自動文字會被截短或省略的問題。
使用者介面與穩定性
修正了清理用於裁剪遮罩的圖樣填滿後儲存檔案時,可能導致 107 錯誤的問題。
修復了在文件空白頁面上更新模型參考時可能發生的當機問題。
修正了雙擊位移操作套用在實體外側,而非內側的問題。
修正了裁剪遮罩遮蔽部分模型時,貼齊與推算仍作用於被遮蔽區域的問題。
修復了使用實驗性圖形引擎時,字體大小與對齊不一致的多項問題。
修正了透過 Ruby API 無法建立水平或垂直線性尺寸的問題。
修正了當文字套用 Stroke(筆觸)樣式時的尺寸標註問題,現在可對具有 Stroke 樣式的文字建立尺寸標註。
Windows – 修正了在 LayOut 載入特定圖像時,由第三方資料庫導致的當機問題。
Windows – 修正了使用實驗性圖形引擎時,白色文字在編輯時會變透明的問題。
已知重大問題
更新表格參考時,可能導致錯誤的列或欄資料被更新。此情況可使用 Table Reference Options(表格參考選項)的右鍵選單對話方塊重新設定儲存格範圍來修正。
本地化
修正了多項本地化問題,包括漏譯、產品名稱錯誤,以及翻譯版終端使用者授權協議 (EULA) 連結失效。
已緩解導致在地化字串回復為舊版翻譯的問題。此回歸錯誤影響了所有非英文語言,覆蓋了先前審核通過的翻譯內容。
修正了安裝非英文版本時剪貼簿消失的問題。
互通性
匯入與匯出
DAE
匯入時不會再忽略元件與材質名稱。
DWG/DXF
修正了匯入 DWG 檔案時,因同時匯入元件實例與元件定義名稱而導致資料重複的問題。
從 DWG 檔案匯入的聚合線現在會作為焊接的 SketchUp 線段匯入,並具有更可預測的行為模式。
修正了 3D DWG 檔案無法正確匯出的問題。雖然 DWG 檔案現在能維持正確的幾何體與剖面,但我們也發現 SketchUp 建立的使用中剖面透過 AutoCAD 開啟時可能無法顯示。我們目前正持續調查以確保所有相容應用程式都能完整顯示剖面。
3DS
修正了導致部分模型無法成功匯出為 3DS 格式的潛在問題。
IFC
所有 IfcSpace 屬性現在都能完整來回轉換。
修正了匯入特定 IFC 檔案時幾何體損毀或缺失的問題。
2025 版引入的自訂 SketchUp 中繼資料現在已在 Trimble Connect 中支援。
IFC 屋頂、樓梯與坡道屬性已更新,以符合 buildingSMART 驗證服務規範。
IFC 匯出:修正了在匯出 IFC 檔案時,因多位元組字元處理錯誤導致韓文與日文出現問題的狀況。匯出功能現在使用一致的 UTF-8 編碼,可正確處理這些字元。
USDZ 與 TRB
修正了上傳模型至 Trimble Connect 時,紋理遺失的問題。
已更新 USDZ 匯入資料庫,修正了手機掃描的檔案會呈現全黑的問題。現在系統會使用發光紋理作為解決方案。
修正了導致無效 USDZ 檔案(在外部檢視器中無法開啟)的錯誤,並修正了顏色對應,使顏色與原始 SketchUp 模型一致。
修正了 TrimBIM (.TRB) 檔案在每次匯出後檔案大小持續增加的問題。
API 版本資訊(Ruby 與 C API)
重大變更
可復原的場景操作
在 SketchUp 2026.0 中,新增、刪除與修改場景現在都屬於可復原的操作。以往這些操作不會被加入至復原堆疊中。現在,如果擴充程式透過 API 修改場景,這些變更都會新增至復原堆疊。若這些場景修改未在可復原操作中執行,擴充程式將無意間在復原堆疊中加入其他的操作。
我們請求開發人員更新並測試其與場景相關的擴充程式。請務必將所有場景操作包在 Sketchup::Model#start_operation 與 Sketchup::Model#commit_operation 之間,以避免過度堆疊復原操作。請測試您是否能夠順利將擴充程式更新至能依預期運作,並於 Beta 測試期間若發現任何問題,請儘早向 Centercode 回報。
修改 Sketchup::Page 的屬性(Sketchup::Axes、Sketchup::Camera、Sketchup::RenderingOptions、Sketchup::ShadowInfo)現在也成為可復原的操作。
場景變更操作必須在 Sketchup::Model#start_operation 與 Sketchup::Model#commit_operation 之間進行,以避免復原堆疊超載。這是一項重要的新規範,我們將開始要求提交至 Extension Warehouse 的擴充程式必須遵守此規定。未遵守此規定的擴充程式將被拒絕上架至 Extension Warehouse。
不可逆的轉換
{Sketchup::ComponentInstance#transformation=}、{Sketchup::ComponentInstance#transform!}、{Sketchup::Group#transformation=}、{Sketchup::Group#transform!}、{Sketchup::Image#transformation=} 及 {Sketchup::Image#transform!} 不再接受不可逆轉換(通常指任一軸上縮放值為 0 的轉換)。
{Sketchup::Entities#transform_entities} 無法再將不可逆轉換套用至 {Sketchup::ComponentInstance}、{Sketchup::Group} 及 {Sketchup::Image}。
當機修復
修正了在將檢視區新增至 Layout::Document 前,LayOut::SketchUpModel 嘗試渲染模型環境時發生的當機問題。
修正了在 HTML 對話方塊 on_close 事件中使用 Sketchup.send_action 時退出程式發生的當機問題。
修正了在同一操作中同時使用 Sketchup::Classifications#load_schema 與 Sketchup::ComponentDefinition#add_classification 導致復原時當機的問題。
修正了在使用者介面執行復原操作時,因觸發交易回溯而導致的當機問題。
Windows – 修正了執行 model.place_component() 時可能發生的當機問題。
Windows – 修正了在 SketchUp 放置 Empty Component Definition(空白元件定義)時發生的當機問題。
API 改進
SketchUp Ruby API
Sketchup::Model#export 現在使用全新的 IFC 匯出功能,並新增了新選項 (:ifc_version, :standard_ifc_hierarchy, :selectionset_only, :tessellated_geometry),以及停止支援選項 (:doublesided_faces, :ifc_mapped_items, :ifc_types)。
新增 Sketchup::Model#active_section_planes 與 Sketchup::Page#active_section_planes。
新增 Sketchup::Styles#remove_style,並修改 Sketchup::Styles#add_style 以回傳新增樣式。
新增 :show_version_warning_dialog 可選引數至 Sketchup.open_file。
新增 Sketchup::Pages#unique_name。
Sketchup::Page#name= 現在若設定的名稱已被使用,會自動調整為唯一名稱。
Sketchup::ComponentDefinition#save_as 與 Sketchup::ComponentDefinition#save_copy 現在會於儲存失敗時會回傳 false。
SketchUp C API
新增 SUModelGetActiveSectionPlanes 與 SUModelGetNumActiveSectionPlanes。
SUEnvironmentCreateFromFile 現在允許名稱參數為空值。
LayOut Ruby API
Layout::LinearDimension#initialize 新增可選參數,可在建立時指定尺寸線的對齊方式 (DIMENSION_LINE_ALIGNED, DIMENSION_LINE_VERTICAL, DIMENSION_LINE_HORIZONTAL)。
新增 Layout::LinearDimension#leader_line_visible?。
新增 Layout::Style#text_strikethrough 與 Layout::Style#text_strikethrough=,並新增常數 (STRIKETHROUGH_NONE, STRIKETHROUGH_SINGLE)。
新增 LayOut 屬性字典 API:
Layout::Document#set_attribute
Layout::Document#get_attribute
Layout::Document#delete_attribute
Layout::Document#attribute_dictionary
Layout::Entity#set_attribute
Layout::Entity#get_attribute
Layout::Entity#delete_attribute
Layout::Entity#attribute_dictionary
Layout::Page#set_attribute
Layout::Page#get_attribute
Layout::Page#delete_attribute
Layout::Page#attribute_dictionary
新增 {Layout::Dictionary} 類別
LayOut C API
新增 LOLinearDimensionCreateWithAlignment() 與 LOLinearDimensionAlignment 列舉。
新增 LOLinearDimensionGetLeaderLineVisible()。
新增 LOStyleGetTextStrikeThrough()、LOStyleSetTextStrikeThrough(),以及 LOTextStrikeThrough 列舉。
新增 SketchUp 模型相機與檢視區覆寫的相關函數
LOSketchUpModelGetCamera(), LOSketchUpModelSetCamera()
LOSketchUpModelSetViewportOverridesOnModel()
LOSketchUpModelResetViewportOverridesOnModel()
新增 LayOut 屬性字典 API:
LODocumentSetAttribute()
LODocumentGetAttribute()
LODocumentDeleteAttribute()
LOEntityCreateAttributeDictionaryCopy()
LOEntitySetAttribute()
LOEntityGetAttribute()
LOEntityDeleteAttribute()
LOPageCreateAttributeDictionaryCopy()
LOPageSetAttribute()
LOPageGetAttribute()
LOPageDeleteAttribute()
新增 LOTypedValueType::LOTypedValueType_Dictionary 列舉值
新增 LOTypedValueGetDictionary() 與 LOTypedValueSetDictionary()
IFC 匯出 API
Ruby API 已更新以配合新的統一 IFC 匯出功能,舊方法已淘汰,並新增控制 IFC 版本與階層結構的新功能。
API 錯誤修復
Ruby API
修正了 Sketchup::Model#drawing_element_visible? 拋出例外的回歸情況。
{Geom::Transformation#inverse} 與 {Geom::Transformation#invert!} 遇到不可逆轉換(通常是將任一軸縮放為 0 的轉換)時,會引發 ArgumentError。
UI.inspector_names() 現在會正確列出環境面板。
修正了使用 SketchUp API 儲存檔案時可能造成檔案損毀的問題。
不再允許透過 Ruby API 將相同名稱分配給多個場景。
渲染選項的文件現在會顯示可接受的值,且設定邊緣類型為 1 時不會導致 SketchUp 當機。
DWG 匯出文件已更新,現在會顯示材質選項。
其他幾個文件錯誤亦已修正
C API
SUModelAddLayers() 現在會確保圖層名稱不重複。
已知問題
{Sketchup::Image#transformation=} 與 {Sketchup::Image#transform!} 遇到不可逆轉換時會無提示地失敗。
{Sketchup::Entities#transform_entities} 對 {Sketchup::CompoenntInstance}、{Sketchup::Group} 及 {Sketchup::Image} 套用不可逆轉換時會無提示地失敗。