新增材質的顏色和紋理

SketchUp 可讓您在模型的各個表面塗上材質,使您的模型更具細節度和真實感。材質實質上是具有顏色和可選紋理的顏料(在影像檔案中定義)。舉例來說,在下圖中,屋頂材質為藍色,並具有模擬金屬屋頂的紋理。牆板和草坪也是具有顏色和紋理的材質。

像這樣在模型上套用材質後,SketchUp 材質的特殊功能可以幫助您完成以下任一操作:

  • 替換材質:如果您想要顯示金屬屋頂,而不是木瓦屋頂。您可以快速又輕鬆地替換掉屋頂材質的木瓦。
  • 編輯材質:因為顏色和紋理是分開的,您可以各自獨立進行變更。舉例來說,您可以變更牆板的顏色(黃色看起來怎麼樣?)但保留相同的紋理。您也可以編輯材質的不透明度,來控制材質的透明程度。
  • 計算所需的材質數量:SketchUp 可以告訴您所有木瓦或牆板的面積。當然,如果要讓計算結果有意義,您就需要建立精確的模型,計算出的數字才會反映模型的實際尺寸。
提示:SketchUp 包含多種材質收藏庫:地毯、瓷磚、地被植物、玻璃、木材等。然而,如果沒有您所需的特定材質,您可以製作自己的材質。如果您是需要向客戶展示精確飾面的室內設計師或建築師,這項功能會非常實用。

您可以在 SketchUp 介面中,使用顏料桶工具()和材質面板(Microsoft Windows)或顏色面板(macOS)來為材質建模。您也可以使用材質或顏色面板檢視、管理和整理材質。材質或顏色面板會追蹤模型中的材質,您也可以在此處製作用於特定專案或工作流程的自訂材質收藏庫。

注意:如果您交替使用執行 Microsoft Windows 和 macOS 的電腦,請注意,材質面板介面及顏色面板介面僅適用於各自的作業系統。在以下部分中,您會依據在說明中心的任一頁面上,從下拉式功能表中所選的作業系統,看見 Microsoft Windows 或 macOS 的說明。

在下方的影片中,您會看到套用材質及進行部分常見變更的方式,例如將某一材質替換成另一種材質。如需要逐步引導您使用材質的詳細步驟,請查看以下部分。

套用材質

將材質套用至模型的方法非常簡單:選取一個或多個表面,接著選取您想要使用的材質。如果要將材質塗上群組或元件,請查看本部分最後的訣竅,便能更輕鬆地套用材質。

您可以使用顏料桶工具來套用材質),這項工具可以在 SketchUp 介面的以下部分中找到:

    Windows
  • 入門工具列
  • 大型工具集工具列
  • 主體工具列
  • 功能表上的工具 > 顏料桶

如要開始將材質套用至您的模型,請按照以下步驟操作:

  1. 選取顏料桶工具()。
  2. 在開啟的材質面板中,按一下選取標籤。如果材質面板沒有在選單中開啟,對話方塊有可能會在隱藏式選單裡。遇到這種情況時,請將游標移到隱藏式選單標籤上方。選單便會展開。接著,您就可以在選單中開啟材質面板。
  3. 從下拉式清單中選取一種材質收藏庫。
  4. 按一下您想要使用的材質。
    提示:如要對已在您模型中的材質取樣,請按住 Alt 鍵以暫時切換至取樣工具。使用取樣工具的滴管游標,按一下您想要取樣的材質表面。放開 Alt 鍵以返回至顏料桶工具。
  5. 返回至繪圖區域,按一下一個或多個表面來套用材質。

在 Windows 版 SketchUp 中套用材質

提示:如果要還原預設顏色,請按照上述的步驟操作,但不要點選材質,而是要在右上方按一下將材質設定為預設顏料),並點選您模型中的表面來套用預設顏色。

    MacOS
  • 大型工具集工具列
  • 功能表上的工具 > 顏料桶
  • 工具調色盤

如要開始將材質套用至您的模型,請按照以下步驟操作:

  1. 選取顏料桶工具()。您可以在出現的顏色面板中,從四個顏色選取器標籤中選擇一個顏色,或使用材質收藏庫。
  2. 如果要瀏覽材質收藏庫,請按一下有磚塊圖示的紋理調色盤標籤。(如果要深入瞭解選取顏色用的其他標籤使用方式,請參閱在顏色選取器中混合顏色。)
  3. 從下拉式清單中選取一種材質收藏庫。下圖中,已經選取了屋頂收藏庫。
  4. 按一下您想要套用至模型的材質。
    提示:如要對已在您模型中的材質取樣,請按一下紋理調色盤標籤底部的滴管工具。使用大圓形游標,按一下您想要取樣的材質表面。按下後,材質便會載入至樣本,接著您就會再次看見顏料桶游標。
  5. 返回至繪圖區域,按一下一個或多個表面來套用材質。

此外,也可以在紋理調色盤的主要區域中按一下材質樣本,並拖曳至模型中的表面上。(您無法從 macOS 顏色面板的底部的調色盤中拖曳樣本。如要深入瞭解這些已儲存樣本的使用方式,請參閱在顏色選取器中混合顏色)。

提示:如要還原為預設顏色,請從模型內的顏色收藏庫選取預設樣本。

提示:如果您點選表面後,選取的材質並未出現,則有可能是您的模型使用的樣式不會顯示紋理。如要檢查, 請開啟樣式面板,選取編輯標籤,再按一下表面設定圖示。請確保您在樣式區域中已選取顯示使用紋理的光影選項。

如果您的樣式會顯示紋理,則可能是您的電腦記憶體不足,所以無法在模型中顯示材質。請參閱修正 SketchUp 中的問題以取得協助。

您可以一次著色多個表面和邊緣。做法是使用選取工具()來選取您想要著色的邊緣和表面。接著切換到顏料桶工具,並套用一種材質。(選取幾何體提供了進行選擇的提示。)

當您將材質一次套用至多個表面時,請記住以下事項:

  • 表面有兩面:正面和反面。您可以為所有選取表面的正面或反面著色,但不能兩面都一起著色。要著色哪一面,會由您用顏料桶游標所點選的那一面決定。在下圖中,即使您看見的是兩個正面和兩個反面,點選表面的正面,就只會著色選取表面的所有正面。
  • 使用樣式控制反面邊緣的外觀。當您選取一個表面和所有邊緣,並著色表面的正面時,所有選取的邊緣都會上色。然而,著色表面的反面時,並不會讓任何邊緣上色。如果要將反面的邊緣塗上材質,請開啟樣式面板,按一下編輯標籤,按一下邊緣設定圖示,再從顏色下拉式功能表中選取以材質選取

您可以將材質套用至整個群組或元件,或套用至群組或元件中的特定幾何體:

  • 如果要著色整個群組或元件,請先選取後,再套用材質。當您選取群組或元件並套用材質後,只有預設材質中的表面會上色。
  • 如果要著色群組或元件中的幾何體,請雙擊以開啟內容。接著選取您想要塗上材質的表面。

下方的影片示範了將材質套用至元件的多個提示和訣竅。或者您也可以繼續閱讀,逐步瞭解著色全部或部分元件的方式。

提示:如果要快速又輕鬆地對材質中的不同部分進行建模,請結合使用著色全部和部分元件的技巧。

為了瞭解此提示的含意,讓我們假設您正在使用一個木框和兩個靠枕建模一張椅子,而您想要展示四種靠枕顏色。此處出現的大綱視窗,顯示椅子的每個元素(木框和兩個靠枕)是一個群組,所有元素都巢狀進一個群組內,群組又巢狀進一個元件內。(請參閱整理模型,瞭解有關大綱視窗的詳細資訊。)

以下步驟說明了套用材質和顯示四種顏色選項最簡易的方法:

  1. 因為每把椅子的框架都相同,請選取框架的群組並套用木頭材質,如下所示。
  2. 建立每種靠枕顏色的副本。(複製您繪製的內容中有說明方法。)
  3. 選取一個元件,並套用靠枕顏色材質。因為框架已經上色,但靠枕仍是預設顏色,所以只有靠枕會塗上顏色材質。框架會保持為木頭材質。
  4. 對每個顏色選項都重複上述步驟。您可以在下圖中看到成果。

提示:有多個群組或元件巢狀進其他群組或元件時,SketchUp 可能無法讓您透過點選最上方的群組或元件來著色。如果遇到此問題,請嘗試套用材質至一個巢狀階層較低的群組或元件。大綱視窗可以協助您查看所選內容位於哪個階層。

替換材質

因為 SketchUp 能讓您替換材質,所以您可以快速又輕鬆地實驗材質的效果。在廚房中,您可以預覽不同流理台材質的效果,例如黑色花崗岩、藍色瓷磚和白色複合材料。如果要挑選房屋油漆的顏色,您可以比較黃色壁板搭配深綠色飾條,以及藏青色壁板搭配淡黃色飾條的效果。當您瞭解鍵盤的輔助按鍵如何使用後,這個過程就會非常簡單。請在下表中查看輔助按鍵。

要替換的材質… 輔助按鍵(Microsoft Windows) 輔助按鍵(macOS)
在相鄰表面上 Ctrl Option
在目前內容中的所有表面上(如相同群組或元件) Shift Shift
在所有連接的表面上 Ctrl + Shift Option + Shift

下方為協助您瞭解每個快速鍵如何運作的影像範例。假設您正嘗試要決定兩面分開的牆壁上抽象壁畫的顏色。下圖展示了以顏色命名的收藏庫中材質模擬的壁畫。

如果要查看以紅色取代綠色的效果,請選取顏料桶工具,接著從材質面板(Microsoft Windows)或顏色面板(macOS)中選取綠色。如果您按住 Ctrl 或 Option 鍵,再按一下左上方的紅色三角形,則只有與紅色材質相鄰的表面會被綠色取代,如下圖所示。

如果您按住的是 Shift 鍵,則所有紅色表面都會變成綠色:

但是,如果您按住 Ctrl + Shift 或 Option + Shift 鍵後再按一下,則只有左邊的牆上的紅色表面會變成綠色:

編輯材質

SketchUp 能讓您編輯材質。進行變更時,任何塗上編輯中材質的表面都會自動更新。因為每個材質都有顏色和可選的紋理,所以您可以獨立編輯每個材質的顏色和紋理。


當您使用同一材質套用多個表面時,在 SketchUp 中編輯材質就會非常好用。以編輯的方式改變材質,而不是直接從表面上替換,就可以讓任何塗上編輯中材質的表面都自動更新。因為每個材質都有顏色和可選的紋理,所以您可以獨立編輯每個材質的顏色和紋理。

注意:編輯材質功能包含在 Web 版 SketchUp 應用程式的付費訂閱中。SketchUp for Schools 使用者也可以使用此功能。

在編輯材質前,您必須先將材質與模型一起儲存。如果要查看與模型一起儲存的材質,請在畫面右側的工具選單中開啟材質面板。

如果要編輯材質,請從模型內材質中選取該材質(在首頁圖示下方),或在建模視窗使用滴管工具取樣,便會自動選取材質面板中的材質。選取材質後,請按一下材質縮圖旁邊的編輯圖示。

編輯材質時,您可以設定:

  • 材質名稱:為材質輸入新名稱,更改已編輯材質的名稱。
  • 顏色:您可以使用 SketchUp 的顏色選取器手動選取,或輸入特定 RGB、HSL 或 HEX 值來自訂材質的顏色。改變顏色時,您會看見您的編輯動作即時反映在材質上。
  • 影像:新增或變更與材質相關的影像紋理。新增或變更影像紋理可能會取代您為材質選擇的顏色。您也可以按一下「X」來完全移除材質中的影像紋理。
  • 材質大小:當您將影像紋理套用至表面上時,影像紋理會以圖磚的方式填滿表面。在寬度或高度框中輸入數值,以變更紋理圖磚的大小。影像的高寬比會預設為保持不變。因此,如果您在寬度尺寸框中輸入 2,高度框的數值會自動更新以維持高寬比。按一下鎖鏈圖示以斷開鎖鏈(和佛利伍麥克(Fleetwood Mac)樂團說聲抱歉),接著您就可以不按照高寬比,隨心改變數值。如果您對於結果不滿意(而且再也不會回心轉意),您可以按一下功能表底部的「取消」,或按下 CTRL/Command + Z 來復原變更。
  • 不透明度:您也可以編輯材質的透明程度。將不透明度滑動軸向右滑動會增加不透明度,滑動至 100 時材質會是完全不透明的。將軸向左滑動會增加透明度,滑動至 0 時材質會是完全透明的。此外,您也可以在不透明度欄位中輸入 0 至 100 之間的數字。

注意:在編輯材質時按一下編輯材質面板底部的「取消」,便會捨棄所有材質編輯。如果您接受對材質編輯的變更,您也可以使用復原和重做指令,在原始和編輯過的材質之間來回變換。

Windows

在編輯材質前,您必須先將材質與模型一起儲存。如果要查看與模型一起儲存的材質,請開啟材質面板,並按一下模型內圖示()來顯示您的模型內收藏庫,如下圖所示。

如果您想編輯的材質沒有在模型內收藏庫中,您可以將一種材質與您的模型內收藏庫一起儲存,不論該材質目前是否有套用於模型中。如果要在模型內收藏庫中新增材質,請按照以下步驟操作:

  1. 在材質面板的右上方按一下顯示輔助選擇窗格)。
  2. 在底部的輔助窗格中瀏覽收藏庫,找到您想編輯的材質。
  3. 將該材質拖曳至您的模型內收藏庫裡。

如果要編輯材質,請在模型內收藏庫中選取該材質後,按一下編輯標籤,如下圖所示。

以下是所有編輯材質顏色的工具簡介:

  • 選取器下拉式清單:使用選取器下拉式清單來從 HLS(色相、亮度、飽和度)、HSB(色相、飽和度和亮度)、RGB(紅、綠、藍)和色輪顏色選取器之間選取。請參閱在顏色選取器中混合顏色,瞭解顏色選取器的詳細資訊。
  • 復原顏色變更樣本:按一下此樣本以復原所有您在編輯階段中進行的變更。
  • 在模型內配對物體顏色按鈕:按一下此按鈕,將游標轉換為滴管。使用滴管游標按一下實體以取樣其顏色,並將該顏色套用至您正在編輯的材質。
    提示:如果您對具有紋理的材質進行取樣,則紋理的變化可能會稍微掩蓋住材質的顏色。如果要從紋理中取樣特定顏色,請使用配對畫面上的顏色按鈕來取得更精確的結果。
  • 配對畫面顏色按鈕:按一下此按鈕,接著用滴管游標按一下畫面上任一處來取樣像素的顏色。接著,SketchUp 會將該顏色套用至目前選取的材質。

以下工具可供您調整材質紋理:

  • 使用紋理影像核取方塊:勾選此核取方塊時,您可以加入代表紋理的影像檔案。清除該核取方塊則會移除紋理影像檔案。(請注意,再次勾選核取方塊並不會還原影像檔案,而是會出現讓您選取新影像檔案的提示。)
  • 紋理影像檔案及瀏覽按鈕:紋理檔案欄位包含(代表紋理的)影像檔案與目前材質相關的名稱(若有)。如果要變更紋理,請將影像檔案拖曳至此欄位中,或按一下瀏覽按鈕以顯示選擇影像對話方塊,以瀏覽硬碟上的影像檔案。套用紋理後,您也可以在模型上調整紋理的排列方式。如需更多資訊,請參閱下一部分的調整紋理位置
  • 在外部編輯器中編輯紋理影像按鈕:按下此按紐時,SketchUp 會在您預設的影像編輯器中開啟紋理影像檔案。
    注意:您的影像編輯器是在應用程式面板中的 SketchUp 偏好設定對話方塊中所定義。請參閱自訂您的工作空間,瞭解設定此偏好設定的詳細資訊。如果您尚未指定影像編輯器,SketchUp 會啟動您作業系統的預設編輯器或影像顯示應用程式。
  • 著色核取方塊:勾選此核取方塊,可將相同色相套用至整個紋理。顏色是在編輯標籤中的顏色區域中定義的。對於未顯示正確顏色的檔案來說,這個選項很實用。
  • 重設顏色樣本:按一下顏色樣本,將材質重設為紋理影像檔案中的顏色。
  • 尺寸欄位:當您將紋理塗上表面時,紋理影像會以圖磚的方式填補表面。在寬度或高度框中輸入數值,以變更紋理圖磚的大小。影像的高寬比會預設為保持不變。因此,如果您在寬度尺寸框中輸入 2,高度框的數值會自動更新以維持高寬比。按一下鎖鏈圖示以斷開鎖鏈(和佛利伍麥克(Fleetwood Mac)樂團說聲抱歉),接著您就可以變更高寬比。如果您對於結果不滿意(而且再也不會回心轉意),請按一下水平和垂直的箭頭按鈕來復原至之前的寬度和高度設定。
  • 不透明度滑動軸:不透明度指的是影像有多透明或多不透明的程度。將不透明度滑動軸向右滑動會增加不透明度,滑動至 100 時材質會是完全不透明的。將軸向左滑動會增加透明度,滑動至 0 時材質會是完全透明的。此外,您也可以在不透明度欄位中輸入 0 至 100 之間的數字。

MacOS

在編輯材質前,您必須先將材質與模型一起儲存。如果要查看與模型一起儲存的材質,請選取視窗 > 材質以開啟顏色面板。在紋理調色盤標籤(磚塊圖示)上按一下模型內顏色圖示()或從下拉式清單中選取模型內顏色,便會顯示您的模型內顏色收藏庫,如下圖所示。

如果您想編輯的材質沒有在模型內收藏庫中,請將材質套用至模型內的表面上。(請注意,如果您之後用另一種材質將其替換,在您清除未使用的材質前,原始的材質仍會留在您的模型內收藏庫中。)

當您準備好要編輯材質時,請按照以下步驟操作:

  1. 在紋理調色盤標籤(磚塊圖示)上開啟您的模型內顏色收藏庫。
  2. 選取您想要編輯的材質。
  3. 在顏色下拉式清單中選取編輯。或按住 Control 鍵並點選材質,接著在出現的功能表中選取編輯
  4. 出現如下圖的編輯材質面板後,在上面選擇您想要的編輯。
  5. 完成時,按一下關閉按鈕。

以下是編輯材質面板上的選項介紹:

  • 名稱:為材質輸入新名稱,更改已編輯材質的名稱。
  • 在外部編輯器中編輯紋理影像:按一下此按紐後,紋理影像檔案便會在您的預設影像編輯器或預覽程式中開啟。對檔案進行編輯並儲存,變更就會反映在材質中。
  • 紋理下拉式功能表:您可以透過此下拉式選單的選項,在 SketchUp 中編輯紋理。選取載入,可為紋理選取一個新的影像檔案。選取移除,可刪除紋理影像檔案。(移除紋理影像時,會顯示遭移除影像的扁平化顏色相近色。)如果您已經為紋理著色,請選擇重設顏色以移除著色。選擇編輯便會開啟您預設影像編輯器或預覽程式中的紋理影像檔案。套用紋理後,您也可以在模型上調整紋理的排列方式。如需更多資訊,請參閱下一部分的調整紋理位置
  • 寬度和高度:當您將影像紋理套用至表面上時,影像紋理會以圖磚的方式填補表面。在寬度或高度框中輸入數值,以變更紋理圖磚的大小。影像的高寬比會預設為保持不變。因此,如果您在寬度尺寸框中輸入 2,高度框的數值會自動更新以維持高寬比。按一下鎖鏈圖示以斷開鎖鏈(和佛利伍麥克(Fleetwood Mac)樂團說聲抱歉),接著您就可以不按照高寬比,隨心改變數值。如果您對於結果不滿意(而且再也不會回心轉意),您必須要記得原始的尺寸並手動輸入數值,才能還原為原始的影像尺寸。
  • 著色:編輯材質面板為開啟狀態時,您可以為紋理檔案著色。使用任何顏色標籤選取顏色,並套用至編輯材質版面上的材質預覽。或按一下顏色面板底部的滴管工具,並按一下模型中或紋理調色盤(磚塊)標籤上的任何材質。
    提示:著色是實驗材質顏色變化的好方法。
  • 不透明度:編輯材質面板為開啟狀態時,您也可以編輯材質的不透明度,也就是影像有多透明或多不透明的程度。將不透明度滑動軸向右滑動會增加不透明度,滑動至 100 時材質會是完全不透明的。將軸向左滑動會增加透明度,滑動至 0 時材質會是完全透明的。此外,您也可以在不透明度欄位中輸入 0 至 100 之間的數字。

調整紋理位置

在 3D 模型中套用紋理至一個或多個表面後,您可以調整紋理圖磚在表面上的排列方式。為此,您需要使用調整紋理位置工具,此工具有兩種模式:

  • 鎖定圖釘模式:在此模式中,您可以移動、旋轉、縮放或扭曲紋理。舉例來說,在此模式中,您可以調整某一表面上的紋理,使其與另一表面上的相同紋理對齊,如一棟建築兩個表面上的牆板。
  • 自由圖釘模式:如果您需要拉伸或縮小紋理,請使用自由圖釘模式。

以下是在鎖定圖釘模式中調整紋理的方法:

  1. 在材質上按一下右鍵,並在出現的功能表中選取紋理 > 位置。您會看見代表紋理的各個圖磚的虛線矩陣。游標也會變為手的形狀,並顯示四個圖釘。
  2. 如果您看見四個彩色圖釘,如下圖所示,請繼續操作下一步驟。如果沒有看見,請在材質上按一下右鍵並選取鎖定圖釘
  3. 使用手型游標和/或圖釘來調整紋理。在此範例中的目標是要移動綠色圖釘,讓櫥櫃上方的木頭方向與側面相符。以下是所有選項的快速簡介:
    • 使用手型游標按住並拖曳,重新調整整個紋理的位置。
    • 按一下圖釘以將其選取,並再次點擊以將圖釘放在紋理的其他地方。
    • 拖曳圖釘以變更紋理。拖曳藍色圖釘以縮放或剪切紋理。拖曳黃色圖釘以扭曲紋理。拖曳綠色圖釘縮放紋理,或繞著移動圖釘的軸旋轉。拖曳紅色圖釘(即為移動圖釘)以移動紋理。
    提示:在鎖定圖釘模式中,您也可以在紋理上按一下右鍵以查看其他選項:將紋理向左或向右或向上或向下翻轉、將紋理正向旋轉 90 度。重設選項會將紋理還原至原始狀態,而復原選項只會復原上一個指令。如果您復原了一個動作,就會出現重做選項。
  4. 當您完成變更紋理後,請在紋理上按一下右鍵,並選取完成。或者您可以直接在紋理外面按一下以退出鎖定圖釘模式。

在自由圖釘模式中,您可以依據模型來設定紋理圖磚的大小。以下是流程進行方式:

  1. 在材質上按一下右鍵,並在出現的功能表中選取紋理 > 位置。系統會預設為鎖定圖釘模式。
  2. 在紋理上按一下右鍵,並清除鎖定圖釘選項,即可切換到自由圖釘模式。在自由圖釘模式中,您會看見四個白色圖釘,如下圖所示。
  3. 按一下圖釘以將其選取,並再次點擊以將圖釘放置在新地方。對所有四個圖釘都進行此操作,設定紋理圖磚的四個角出現的位置。如果您放置的圖釘配置不是長方形,便會扭曲紋理。
  4. 當您完成變更紋理後,請在紋理上按一下右鍵,並選取完成。或者您可以直接在紋理外面按一下以退出自由圖釘模式。
提示:在自由圖釘模式中,您只會看見所選表面上的紋理圖磚大小。如果要改變整個模型的紋理圖磚大小,請使用材質面板(Microsoft Windows)或顏色面板(macOS)。如需更多資訊,請參閱前一部分的編輯材質

自動計算材質面積

如果您想讓 SketchUp 計算塗有材質的表面面積,您可以在材質上按一下右鍵,並選取面積 > 材質。在 Windows 系統中,您也可以在材質面板中,在材質上按一下右鍵,並從功能表中選取面積。(如果面積功能表項目為灰色,則表示材質並未套用在任何表面上。)

不論使用哪種方式,面積對話方塊都會顯示已套用所選材質之表面的總面積。單位(如平方英尺或平方公尺)是依據範本中指定的單位而定。如需改變預設單位的詳細資訊,請參閱設定範本

如果使用 IFC 分類,您就可以產生關於整個模型中材質的報告。如需詳細資訊,請參閱分類物體(尤其是產生報告的部分)。

管理及整理材質

材質面板(Microsoft Windows)或顏色面板(macOS)可以協助您尋找並整理材質。下表說明了如何使用您在說明中心所選的作業系統來管理材質。

Windows

  • 瀏覽包含的收藏庫:在選取標籤上,從下拉式清單中選取一個收藏庫以查看材質。
  • 追蹤模型中的材質:按一下模型內圖示()來查看您已套用至模型的所有材質。
  • 清除不需要的材質:即使您將材質用另一種替換,原始的材質已經不在模型中顯示,但直到您在上面按一下右鍵並選取刪除之前,原始的材質還是會留在您的模型內收藏庫中。如果要移除模型中所有未使用的材質,請確保已選取模型內收藏庫。接著按一下詳細資訊箭頭)並選取清除未使用項目。或者,您也可以選取全部刪除來移除模型上和模型內收藏庫的所有材質。
  • 建立自己的收藏庫:您可以為特定的專案建立一個收藏庫,或為您製作的材質建立收藏庫,如特定顏色主題、織品樣本、景觀選項,或任何您重複使用的材質。在選取標籤上,按一下詳細資訊箭頭)並選擇開啟或建立收藏庫。在選取收藏庫資料夾或建立新資料夾對話方塊中,瀏覽您想要儲存收藏庫的資料夾。按一下新資料夾按鈕,為您的資料夾命名(該名稱將成為您的收藏庫名稱),並按一下選取資料夾。建立收藏庫後,您可以瀏覽至該資料夾以開啟收藏庫。如果要將材質新增至收藏庫中,請將材質從輔助選取窗格中拖曳至您的收藏庫中,或將您製作的材質儲存至收藏庫中。
  • 將常用收藏庫新增至您的最愛:在選取標籤上,按一下詳細資訊箭頭,並選擇將收藏庫新增至最愛。接下來,目前選取的收藏庫便會出現在下拉式清單底部的最愛清單中。如果您不想讓收藏庫出現在最愛清單中,您可以選取該收藏庫,按一下詳細資訊箭頭,並選擇從最愛中移除收藏庫
    注意:按一下詳細資訊箭頭,您便可以選擇要以小、中、大或超大圖磚來查看材質。選擇清單選項可查看材質名稱,而非預覽樣本。

MacOS

  • 瀏覽包含的收藏庫:如果要查看 SketchUp 中包含的材質,請按一下紋理調色盤圖示(磚塊)並在下拉式功能表中選擇收藏庫,如磚塊與覆面、柵欄、屋頂、半透明或木材。收藏庫中的每個材質都會顯示為一個樣本,您可以使用顏料桶游標按一下後套用至模型。
  • 追蹤模型中的材質:顏色面板中有名為「模型內顏色」的特殊材質收藏庫,其中包含您的模型中目前使用的所有材質。此收藏庫的內容為您新增材質至 SketchUp 模型時自動產生。如要查看此模型,請從材質收藏庫下拉式功能表中選取模型內顏色,或直接按一下模型內顏色圖示()。
  • 清除不需要的材質:即使您將材質用另一種替換,原始的材質已經不在模型中顯示,但直到您在上面按一下右鍵並選取移除之前,原始的材質還是會留在您的模型內顏色收藏庫中。如果要移除模型中所有未使用的材質,請確保已選取模型內顏色收藏庫。接著選取清單 > 清除未使用項目。或者,您也可以選取全部刪除來移除模型上和模型內顏色收藏庫的所有材質。
  • 建立自己的收藏庫:您可以為特定的專案建立一個收藏庫,或為您製作的材質建立收藏庫,如特定顏色主題、織品樣本、景觀選項,或任何您重複使用的材質。選取清單 > 新項目。在出現的清單名稱對話方塊中輸入名稱,接著按一下確定。現在,您便能在收藏庫的下拉式清單中看見您輸入的名稱。
    如果要將材質新增至新的收藏庫,您可以將位於顏色面板底部、滴管旁邊的樣本拖曳至新收藏庫的樣本窗格中。或者您也可以製作新紋理並儲存至收藏庫。如果要移除收藏庫,請選取清單 > 移除。
注意:如果您習慣使用 Windows 的材質面板,請注意,macOS 的顏色面板無法讓您將常用的收藏庫加入最愛清單中。

製作自己的材質

SketchUp 中包含的材料可協助您開始使用材質,並探索其運用方式。如果要套用特定於您自己的設計或建築使用的材質,您可能需要製作自己的材質。過程非常簡單:先使用一張影像來製作紋理圖磚,接著依需求指定顏色。

Windows

如果要從您自己的檔案或色碼製作新材質,請按照以下步驟操作:

  1. 在材質面板中的右上方按一下製作材質圖示()。
  2. 在開啟的製作材質對話方塊中,於頂部的文字欄位中輸入新材質的名稱。
  3. 選取新材質的顏色、紋理和透明度選項。這些選項的運作方式與編輯面板中的選項相同。如需更多資訊,請參閱前一部分的編輯材質。或者參閱在顏色選取器中混合顏色也可以幫助您瞭解顏色選項。
  4. 點選確定。您的新材質會在模型內收藏庫中顯示為已選取。

MacOS

如果要製作紋理的新材質,請按照以下步驟操作:

  1. 在顏色面板中按一下材質調色盤標籤(有磚塊圖示的標籤)。
  2. 選取您想要加入新材質的收藏庫。
  3. 選取顏色 > 新紋理
  4. 在出現的對話方塊中選取紋理的影像檔案。
  5. 在出現的面板中輸入紋理的名稱、設定圖磚尺寸的寬度和高度,接著按一下確定。如果您想要替紋理著色,請按照上一部分編輯材質的步驟操作。

以下是將特定顏色儲存為材質的方法:

  1. 使用任一顏色標籤建立您想要的顏色,該顏色會出現在顏色面板底部的顏色樣本中。請參閱在顏色選取器中混合顏色以瞭解詳細資訊。
  2. 選取材質調色盤標籤(也就是磚塊圖示)。
  3. 找到您想要儲存顏色的收藏庫。
  4. 將顏色樣本從顏色面板的底部拖曳至收藏庫的樣本區域。
提示:您也可以下載材質來擴增您的材質收藏庫。請參閱 SketchUpdate 部落格的這篇貼文以瞭解詳細資訊。