Happy Holidays! Trimble is closed November 22nd & 23rd for the Thanksgiving Holiday - We will get back to you as soon as possible after the break, thank you in advance for your patience while we spend this time with our friends and families.

Troubleshooting hardware-accelerated Vector rendering in LayOut

The Problem

An improvement was made to LayOut 2014 that uses the video graphics card to help process SketchUp models that render in Vector mode. This improvement requires extra video memory, however. It will use as much memory as the graphics card can support up to a certain limit. For most users, this will not be a problem, but problems can occur if the graphics card incorrectly reports that it can support more video memory than it really can. Some users can run into issues where SketchUp or LayOut will consistently crash when trying to vector render large models (10,000 faces or higher), in particular, users with laptops or other types of machines with the video card built into the motherboard.

The Symptoms

Affected users won't be able to use Vector rendering in SketchUp or LayOut for large models with 10,000 faces or higher. They will probably get a crash and potentially an error message from their video driver.

Troubleshooting

  • Save the LayOut file in 2013 format by clicking File > Save As > click File Format > click LayOut Version 2013 > Save. You can then open the resulting file with LayOut 2013.
  • Disable hardware acceleration in SketchUp, which will also disable hardware acceleration in LayOut:
    1. Click Window (Microsoft Windows) or SketchUp (Mac OS X) > Preferences > OpenGL.
    2. Uncheck Use hardware acceleration.
    3. Click OK.
    4. Close SketchUp.
    5. Open LayOut. Hardware acceleration should now be disabled in LayOut.
    6. Reduce your SketchUp model to contain less than 10,000 faces.

Advanced Solution

There is a way to completely work around this feature. However, we only recommend these steps to users who are comfortable manipulating system files and settings. You should defer to an IT or computer administrator if you're not comfortable with the steps below:

There is a hidden preference called HLRItemBufferMaxSize to control the size of the raster texture that the vector renderer uses for hardware acceleration. This setting can be used to:

  • Render missing faces: The larger the texture size, the less likely you are to see missing faces.
  • Reduce the size of the raster texture so that hardware accelerated vector rendering doesn’t require as much video memory. The internal default is 8192. Try setting it to 4096, 2048, or 1024 and see if the problem goes away. Note that this lower resolution may occasionally produce small missing faces.
  • Turn off hardware accelerated vector rendering entirely by setting HLRItemBufferMaxSize to 0. Vector rendering will take as long as it does in LayOut 2013.

Windows Instructions

In the Start menu Search programs and files box, type in regedit.exe , and then run it by hitting the Enter key. It's best practice to make a backup copy of the registry before making changes. To do so, click File > Export and then save the backup file somewhere convenient.

  1. In RegEdit, navigate to HKey_CURRENT_USER/Software/SketchUp/SketchUp 2014/Preferences
  2. Click Edit > New > DWORD to create a new value.
  3. Name it HLRItemBufferMaxSize and make sure the value is set to 0 to disable the feature - a number between 0 and 8192 to lower the limit, or 16384 to raise the limit and get even better quality.

Mac Instructions

Edit your com.sketchup.SketchUp.2014.plist which is located under ~/Library/Preferences. Under the Preferences section of this plist, add a new row HLRItemBufferMaxSize of type Number. Give it a value such as 0 to disable it, a number between 0 and 8192 to lower the limit, or 16384 to raise the limit and get even better quality.

TAGS