使用实体工具为复杂的 3D 形状建模

使用 SketchUp 的实体工具,您可以通过组合或切割一个形状与另一个形状来创建新的形状,从而对轮廓或细木工制品轻松建模。

注意:实体工具也包含在 SketchUp for Web 的 Shop 订阅中。如需了解更多关于 Shop 订阅功能的信息,请参阅 SketchUp for Web: Free vs. Shop

在 SketchUp 中,实体是任何具有有限封闭体积的 3D 模型(组件或组)。SketchUp 实体不能有任何漏洞(缺失的面或没有在边缘相交的面)。下图包含多个实体。

提示:如要检查您的组或组件是否为实体,请右键单击它并选择实体信息。在出现的“实体信息”对话框中,左上角显示所选内容是否为实体,如图所示。如果无法确定导致模型无法作为实体运行的漏洞,请尝试在 Extensions Warehouse 中搜索旨在帮助解决此问题的第三方插件。
提示:如要检查您的组或组件是否为实体,请右键单击它并选择实体信息。在出现的“实体信息”对话框中,左上角显示所选内容是否为实体,如图所示。如果无法确定导致模型无法作为实体运行的漏洞,则可以使用 Solid Inspector(付费用户可用的实用程序)来检查和修复实体建模问题。

查看下表关于“实体工具”的简要介绍,包括此工具的功能,以及在 SketchUp Free 中是否提供。

工具 名称 功能 SketchUp Free 中是否包含?
轮廓 (Outer Shell) 仅保留重叠实体的外表面。
并集 (Union) 将两个或多个实体合并为单个形状。 仅限付费订阅
移除 (Subtract) 一个实体移除另一个实体的一部分,而后再被删除。 仅限付费订阅。在 SketchUp Free 中,使用“与模型相交”。
修剪 (Trim) 一个实体修剪另一个实体,但仍保留在模型中。 仅限付费订阅
相交 (Intersect) 仅保留相交的几何图形。 仅限付费订阅
拆分 (Split) 沿相交的几何形状拆分实体。 仅限付费订阅

若要查找实体工具,请查看 SketchUp 界面的以下部分:

  • 实体工具栏
  • 工具菜单(选择“工具 > 轮廓”,或选择“工具 > 实体工具”,然后从子菜单中选择其他工具)
  • 工具面板 (macOS)
  • 左侧托盘中的实体工具栏
  • 右侧面板中的 Solid Inspector 实用程序

在下面的视频中,您将看到实体工具的应用实例。本文以下章节将介绍使用每种工具的步骤和详细信息。(但是请注意,您无法再将 SketchUp 模型放置在 Google Earth 中。)

创建轮廓

轮廓工具()删除重叠的组或组件内部的几何图形,仅保留外表面。

提示:由于轮廓会减少模型的几何图形,因此当您需要提高 SketchUp 的性能时,创建一个轮廓将非常有用。

例如,假设您有两个模型:一个是详细的建筑内部和外部模型。另一个模型则从街景视图展示该建筑,视图显示了周围的建筑、街道和景观。您可以将详细的建筑模型导入街景视图。然而,所有这些几何形状都可能拖慢街景模型的速度,而且并非必要。在街景视图中,创建建筑物的轮廓可以消除不需要的内部几何图形,从而使街景模型更轻巧,并且在处理时可以更快渲染。

要从重叠的组或组件创建一个轮廓,请按照以下步骤操作:

  1. 使用“选择”工具(),选中要包含在轮廓中的所有相交的组或组件。
  2. 右键单击选中的组或组件,然后从出现的菜单中选择“轮廓”,如图所示。外表面将保留下来。

您也可以通过以下步骤创建一个轮廓:

  1. 选择“轮廓”工具()。

    提示:将鼠标悬停在实体组或组件上之前,您会看到一个带有圆圈和斜线的箭头光标。当光标悬停在实体组或组件上时,红色圆圈和斜线变为一个圆圈中带一个黑色的 1,此时您会看到实体组或实体组件屏幕提示。

  2. 单击选择轮廓中的第一个组或组件。
  3. 单击第二个组或组件。SketchUp 将您的选择组合成一个轮廓,这样只有外表面保留。
  4. (可选)继续单击其他组或组件,将它们添加到轮廓中,如图所示。
  1. 从左侧的工具托盘中选择轮廓工具()。
    提示:将鼠标悬停在实体组或组件上之前,您会看到一个带有圆圈和斜线的箭头光标。当光标悬停在实体组或组件上时,红色圆圈和斜线变为一个圆圈中带一个黑色的 1,此时您会看到实体组或实体组件屏幕提示。
  2. 单击选择轮廓中的第一个组或组件。
  3. 单击第二个组或组件。SketchUp 将您的选择组合成一个轮廓,这样只有外表面保留。
  4. (可选)继续单击其他组或组件,将它们添加到轮廓中,如图所示。

注意:轮廓的结果与并集的结果相似。但是,轮廓的结果仅包含外表面,而并集还可以包含内部几何图形。下面最左侧图片显示了两根方管,中间图片是二者并集的结果,最右侧图片则是二者的轮廓。

将实体合并为单个形状

并集将两个或多个实体合并为一个实体。

并集的结果与轮廓的结果相似。但是,并集的结果可以包含内部几何图形,而轮廓仅包含外表面。(见上图示例。)

下面是使用并集工具合并实体的方法:

  1. 选择“并集”工具()。

    提示:将鼠标悬停在实体组或组件上之前,您会看到一个带有圆圈和斜线的箭头光标。当光标悬停在实体组或组件上时,红色圆圈和斜线变为一个圆圈中带一个黑色的 1,此时您会看到实体组或实体组件屏幕提示。

  2. 单击选择并集的第一个组或组件。
  3. 单击第二个组或组件。所得的几何并集将保留。
  4. (可选)继续单击其他组或组件,将它们添加到并集中,如下图所示,该图使用 X 射线视图,以便您查看每个实体中的几何图形。

提示:除上述步骤之外,您还可以使用“选择”工具预先选择组或组件,然后右键单击选中的组或组件,从出现的菜单中选择“实体工具 > 并集”。

从一个实体中移除另一个实体(或使用“与模型相交”)

借助移除工具,您可以使用一个实体来切割另一个实体。然后,您的原始实体将从模型中移除。要使移除有效,两个实体必须重叠。

提示:使用移除工具时,选择每个实体的顺序很重要。在选择第一个实体时,脑中只需要想着“用这个实体去切割另一个。”换句话说,您选择的第一个实体是您的切割工具,而第二个实体则是被切割的对象。

要进行移除,请按照以下步骤操作:

  1. 选择移除工具()。

    提示:将鼠标悬停在实体组或组件上之前,您会看到一个带有圆圈和斜线的箭头光标。当光标悬停在实体组或组件上时,红色圆圈和斜线变为一个圆圈中带一个黑色的 1,此时您会看到实体组或实体组件屏幕提示。

  2. 单击以选择切割组或组件。在此处显示的例子中,首先选择短桩,以便在板上打孔。完成选择后,光标旁边的 1 变成了 2。
  3. 单击要切割的组或组件。切割组消失,但在第二个选择对象中开了一个孔。在此示例中,您可以在板上看到一个短桩大小的孔。

提示:除上述步骤之外,您还可以预先选择实体,右键单击选中对象,然后从菜单中选择“实体工具 > 移除”。SketchUp 通过您选择实体的顺序来确定哪个是切割实体,哪个是被切割实体。

如果您使用的是 SketchUp Free,则可以使用“与模型相交”命令来创建移除效果。使用“与模型相交”时,两个形状不需要是实体。(事实上,如果您的形状是实体,则“与模型相交”会产生不同的效果,这将在本节的后面进行解释。)然而,当您使用“与模型相交”命令创建移除时,这个过程会比使用 SketchUp Pro 的移除工具多几个步骤。

以下是使用“与模型相交”命令实现移除的方法:

  1. 创建两个不同的立体,例如一个盒子和一个圆柱体。(如需帮助,请参阅“绘制基本形状”和“将形状推拉至 3D”。)
  2. 使用“选择”工具(),在第一个立体上单击三次,这将是您的切割对象。在此示例中,切割对象为圆柱体,如图所示。
  3. 移动和旋转您的切割形状,使其与待切割的形状相交。(如需帮助,请参阅“移动实体”及“翻转和旋转”。)如图所示,保持切割形状处于选中状态。
  4. 右键单击切割形状,然后从出现的菜单中选择“与模型相交”。此命令指示 SketchUp 在两个形状相交的地方创建边。
  5. 使用“橡皮擦”工具(),擦除或移动您不想保留的几何图形。在下图中,您将看到在擦除圆柱体后,盒子的形状会发生哪些变化。

    提示:记住,可以按住鼠标上的滚轮来临时切换到环绕观察工具,这样您就可以进行环绕观察,找到要删除的所有几何图形。(有关橡皮擦工具的详细信息,请参阅“擦除和撤销”。)

“与模型相交”会在当前环境中创建边。如果形状是组或组件,则可以在组内或组外创建相交线。在组的环境外部创建相交线时,可以轻松地将原始形状与 SketchUp 创建的边分开,如下图所示。有关组的详细信息,请参阅“组织模型”;有关组和组件的介绍,请参阅“添加预制组件和动态组件”。

用一个实体修剪另一个实体

借助修剪工具,您可以使用一个实体去切割另一个实体,就像移除一样。但是,使用修剪工具时,切割实体将保留在模型中。因此,如果使用短桩去修剪木板,则短桩在切割木板后仍会保留。与所有实体工具一样,修剪工具仅在两个实体重叠时起作用。

提示:使用修剪工具时,选择每个实体的顺序很重要。在选择第一个实体时,脑中只需要想着“用这个实体去切割另一个。”换句话说,您选择的第一个实体是您的切割工具,而第二个实体则是被切割的对象。

要进行修剪,请按照以下步骤操作:

  1. 选择“修剪”工具()。

    提示:将鼠标悬停在实体组或组件上之前,您会看到一个带有圆圈和斜线的箭头光标。当光标悬停在实体组或组件上时,红色圆圈和斜线变为一个圆圈中带一个黑色的 1,此时您会看到实体组或实体组件屏幕提示。

  2. 单击以选择切割组或组件。在此处显示的例子中,首先选择短桩,以便在板上打孔。完成选择后,光标旁的 1 变成了 2。
  3. 单击要切割的组或组件。切割组保留,但在第二个选择对象中开了一个孔。起初很难看清结果(请参阅插图 1)。但是,如插图 2 所示,将短桩移出孔外,您就能看到板上的孔了。

仅保留相交的几何图形

使用 SketchUp Pro 的相交工具(),您可以选择两个或多个重叠的实体,而最后只留下相交的几何图形。

要执行相交,请按照以下步骤操作:

  1. 选择“相交”工具()。

    提示:将鼠标悬停在实体组或组件上之前,您会看到一个带有圆圈和斜线的箭头光标()。当光标悬停在实体组或组件上时,红色圆圈和斜线变为一个圆圈中带一个黑色的 1,此时您会看到实体组或实体组件屏幕提示。

  2. 选择一个要在相交中使用的实体。
  3. 选择一个或多个与初始选择重叠的其他实体。所得的几何相交图形将保留。在这个例子中,方盒和球体的相交面(插图 1)创建了一个圆形底面(插图 2)。

提示:您也可以预先选择要相交的实体。右键单击您的选择,然后从出现的菜单中选择“实体工具 > 相交”。

拆分实体

您可以使用拆分工具()沿着相交的边缘分割重叠的实体。要进行拆分,请按照以下步骤操作:

  1. 选择“拆分”工具 ()。

    提示:将鼠标悬停在实体组或组件上之前,您会看到一个带有圆圈和斜线的箭头光标。当光标悬停在实体组或组件上时,红色圆圈和斜线变为一个圆圈中带一个黑色的 1,此时您会看到实体组或实体组件屏幕提示。

  2. 单击一个实体。
  3. 单击与选择的第一个实体相交的另一个实体。SketchUp 沿所选实体相交的边缘拆分所有几何图形。例如,如下图所示,左图中的两个组被拆分成了右图中的 3 个组。

使用 Solid Inspector 修复模型

随着几何形状变得越来越复杂,小误差可能会阻碍模型的多样化。SketchUp for Web 中的 Solid Inspector 是一种实用程序,可以查找和修复阻止 SketchUp 将模型按实体分类的问题,从而帮助您准备 3D 打印模型。这一检查也有助于修复 3D 模型,用于实体工具操作。

注意:Solid Inspector 是为付费订阅用户提供的。在 SketchUp Pro 中,Solid Inspector 扩展程序也有类似的功能。

激活 Solid Inspector

在 SketchUp for Web 右侧面板菜单底部找到 Solid Inspector 实用程序。激活该实用程序时,系统将提示您选择一个组或组件。选择对象后,单击 Run Inspector 继续运行。一旦发现错误,请单击错误的名称,了解更多信息。使用箭头图标将 SketchUp 相机转到模型中的各个问题。

注意:无法检查未分组的几何图形。

可自动修复的错误

Solid Inspector 检测到的一些错误可以自动修复。Solid Inspector 错误由用红色突出显示的几何图形来标识,因此,您可以在给予 Solid Inspector“确定”自动修复错误的指示之前仔细检查。可自动修复的错误包括:

  • 反转面:Solid Inspector 是一个可确保表面法线朝外的便捷实用程序。
  • 杂散边:不定义任何面的多余几何边。
  • 内部和外部面:模型内部或外部的杂散几何形状。
  • 表面孔:外部表面上的孔。Solid Inspector 可轻松修复。

可手动修复的错误

有些错误无法通过 Solid Inspector 自动修复,必须使用 SketchUp 的绘图(或橡皮擦)工具进行手动修复。手动修复错误之后,最好重新运行 Inspector,查看您的修改是否已对模型进行完全清理,以便执行自动修复。可手动修复的错误包括:

  • 边界孔:这些孔与实体的表面共享至少一条边。这些错误可以通过覆盖或擦除突出显示的几何图形来手动修复。执行此操作时,请尝试重新运行检查器,查看您是否做了足够的修复,可以让 Solid Inspector 自动修复模型的其余部分。
  • 嵌套的组/组件:组或组件中的嵌套对象可能导致 3D 打印机的 STL 导出混乱。Solid Inspector 不会手动修复这些问题,但您可以使用 Inspector 来查看每个嵌套实例,并决定是否删除它或将几何图形分解到您的模型中。
  • 图像实体:导入到 SketchUp 中的图像无法导出到 STL 文件,同时也禁止实体工具操作。Solid Inspector 将提示您这些错误,但您需要手动删除它们。考虑将图像实体转变为组件。这样,它们就很容易从模型中临时删除。同样,用图像纹理绘制面不会影响压实度。
  • 短边:非常小的几何形状会在 3D 打印或实体操作中引发问题。由于这些问题是不可预测的,而在 SketchUp 中,短边并不影响对象作为实体的资格,因此 Solid Inspector 不会自动修复这些错误。不过,Solid Inspector 是发现和评估这些问题区域的好方法。

显示错误

当您遇到多个无法自动修复的错误时,可以使用“显示错误”命令在需要手动修复的单个问题之间浏览,这一功能非常有用。使用左右箭头来循环检查 Solid Inspector 识别出的特定类型的所有错误;SketchUp 相机将放大问题区域。

提示:在操作时,适当更改“样式”或“显示”选项可能会有所帮助。切换为 X 射线样式,或启用“隐藏的几何图形”来辅助模型修复。