Introducing Drawing Basics and Concepts

Drawing a model in 3D is different from drawing an image in 2D. This introduction to drawing basics and concepts explains a few ways you can create edges and faces (the basic entities of any SketchUp model). You also discover how the SketchUp inference engine helps you place those lines and faces on your desired axis.

Tip: The basic shape tools use a thin solid line. To create dashed lines, see Applying Dashed Lines to Layers.

Drawing a line

Use the Line tool to draw edges (also called line entities). Edges form the structural foundation of all models. Here’s how to draw a line:

  1. Select the Line tool () on the toolbar (or press the L key). The cursor changes to a pencil.
  2. Click to set the starting point of your line. If you click the wrong place, press the Esc key to start over. As you move your cursor around the drawing area, notice the following:
    • A line follows your cursor.
    • The line length is displayed dynamically in the Measurements box. (The Measurements box uses the units specified in your template.)
    • The line that’s following your cursor turns red, green, or blue whenever the line is parallel with the red, green, or blue axis, respectively. If you hover for a moment, a ScreenTip appears, like the On Blue Axis tip shown in the figure. There is no ghost in your machine; that’s the SketchUp inference engine, which you learn more about later in this article.
  3. Click to set the line’s end point. This end point can also be the starting point of another line. Press Esc or select a different tool when you’re done drawing lines. After you set the end point, you can press Ctrl+Z (Microsoft Windows) or Command+Z (macOS) to undo your line and start over.

  4. (Optional) To make your line a precise length, type a value and press Enter (Microsoft Windows) or Return (macOS). You can repeat this process as many times as you like until you draw a new line or select another tool. If you don’t specify a unit, SketchUp uses the unit specified in your template. However, you can type any imperial or metric unit for your line. So you can type 3mm or 5’2” for example. Your value appears in the Measurements box as you type.

Note: The Measurements box also accepts 3D coordinates for lines:
  • An absolute coordinate, such as [3’, 5’, 7’], places the end of the line relative to the current axes. Square brackets indicate an absolute coordinate.
  • A relative coordinate, such as <1.5m, 4m, 2.75m>, places the end of the line relative to the starting point of your line. Angle brackets indicate a relative coordinate.

You can edit the length of a line as long as it doesn’t bound a face. Here’s how to edit a line:

  1. Select the Move tool ().
  2. Hover the Move tool cursor over one of the line’s end points.
  3. Click and drag the end point to change the line’s length.

Tip: You can also adjust the length in the Entity Info dialog box. Context-click the line, and choose Entity Info from the menu that appears. In the Length box, type a new line length.

Creating a face

When you join several lines into a shape, they form a face.

Not a funny face, or a scary clown face, or even a cute puppy face. By default, faces are plain, but super important: They’re the other half of the duo, edges and faces, which enable every SketchUp model ever made to exist.

Tip: By default, SketchUp adds shading to some faces, as shown here, and the faces are opaque, so you know your model has an actual wall, floor, or whatever your face is supposed to represent in your 3D model. (However, SketchUp does include a view that enables you to see through walls, just like Superman. See Viewing a Model for details.)

The shape tools — Rectangle, Circle, and Polygon — also create faces. (See Drawing Basic Shapes for more about those tools.)

Dividing faces

When you draw a line (or a curve) on an existing face, you split the face.

Tip: This concept is important because, after you split a face, you can use the Push/Pull tool to push or pull one part of the face while the other part stays put, as shown here. See Pushing and Pulling Shapes into 3D for details about the Push/Pull tool.

Opening 3D shapes by erasing edges and faces

You can erase an edge or face to create an opening in a shape. To see how erasing an edge affects your model, first select the Eraser tool () in the toolbar or press the E key, and then click an edge:

  • Clicking an edge erases the edge and any face that touched that edge. As Billy Idol almost sang, you can have lines without a face. However, a face must be completely bound by edges.
  • Context-clicking a face and choosing Erase deletes only the face.

In the figure, you see the original cube and how erasing an edge or face changes the cube.

Tip: If you want to hide a line instead of erasing it, hold down the Shift key as you click the line with the Eraser. Or context-click the line and select Hide.

Healing deleted faces

If you accidentally delete a face, here’s how to bring it back:

  • If you haven’t made any other changes that you’d like to keep, simply select Edit > Undo from the menu bar. Or press the keyboard shortcut for Undo, Ctrl+Z (Microsoft Windows) or Command+Z (macOS).
  • Redraw the line that caused the faces to disappear, and SketchUp will re-create the faces.

Finding and locking an inference

SketchUp has an inference engine that helps you work in 3D space. For example, when the Line tool cursor is hovering over the midpoint of another line, the inference engine tells you by displaying a light blue dot and ScreenTip that says, “Midpoint,” as shown here. Every inference has its own color and ScreenTip. (See Knowing your inference types for a full list.)

The inference engine can also help you find geometric relationships between lines. For example, it tells you when a line you’re drawing is perpendicular to another line. In the following figure, notice that a colored dot also appears at the start point of the line, giving you a few bits of information all at once.

Warning: Pay close attention to the inference engine and orbit occasionally to check your drawing from different viewpoints. In the following figure, the lines might appear to be on the red and green plane until you orbit to a different view. To avoid this common pitfall, SketchUp helps by turning your drawing direction or drawing plane red, green, or blue when you're creating edges or planes parallel to those axes (or magenta if you're parallel/perpendicular to an edge or face in your model).

Tip: At times, the inference you need may not come up immediately or SketchUp might choose alignments with the wrong geometry. In these cases, you can encourage an inference, or increase the chances of a particular alignment by pausing your mouse cursor over the location that you want SketchUp to infer from. When the visual cue appears, SketchUp will briefly prioritize that alignment as you continue drawing.

Linear Inferencing Toggle

New Feature! - SketchUp 2020.2

Inferencing is a fundamental feature of SketchUp with most tools depending on it in some manner.. However, inferencing can sometimes get in your way, especially when working in a busy area of a model. With the Line tool, you can turn linear inferencing off and back on using a simple modifier action.

To toggle linear inferencing in the Line tool, you’ll need to click once to start drawing your line. Once you’ve started your line, but before clicking to finish it, simply press the COMMAND key on the Mac or ALT key on Windows which will toggle through the following states:

  • All Inferences On
  • All Inferences Off
  • Parallel and Perpendicular Only

All Inferences On

This is the default behavior and what you’ve experienced in SketchUp since Version 1. The Line tool will snap to the red, green, and blue axes, as well as the magenta axis (parallel/perpendicular to a specified edge.)

All Inferences Off

In this state, the Line tool will ignore all linear inferences. Notice that your cursor will move more freely around the screen as you complete edge segments. Note that you can still find other inference types such as On face, Guide points, Midpoints, and more.. Use these other inference types to make sure your lines are drawn on the planes you want.

Parallel and Perpendicular Only

This state shows only parallel and perpendicular linear inferences when using the Line tool. Selecting this option will allow you to draw your line, making sure it is parallel or perpendicular to other geometry, while not getting distracted by other linear inferences that might be tempted to steal your line.

Locking inferences with a keyboard

By locking inferences, you can confidently draw along the direction you intend to draw. Another reason to lock an inference is to maintain one drawing direction while you reference geometry from another part of the model. That’s a more advanced move, but very helpful. The easiest way to lock an inference to the default axes directions is to use the arrow keys:

>

Locking the drawing direction with arrow keys

Key What it looks like
Locks the drawing direction or drawing plane to the Blue axis
Locks the drawing direction or drawing plane to the Green axis
Locks the drawing direction or drawing plane to the Red axis. A good way to remember left from right is to say “Right locks Red.”
Toggle to lock the parallel/perpendicular drawing direction or drawing plane to an inferenced edge or plane. Basically, anything that turns magenta. The drawing direction will turn magenta in color as well as the edge of face that is being inference.
Shift Locks the drawing direction or drawing plane to the active drawing direction/plane. So if you’re drawing along the Blue axes and hold down Shift, the Blue inference will lock.
Shift+Alt (Windows) or Shift + Command (MacOS) Holding shift to lock the drawing plane also locks the tool to the same face plane that is inferenced. For the Rotate and Protractor tools, however, press the Alt key (Microsoft Windows) or Command key (madOS) to free those tools so that you can move the center to another place in the model while maintaining the same drawing plane

Some tools, like the circle and rotate tools, can lock to a plane (instead of a drawing direction) as shown below. For these tools you can lock the drawing plane by choosing the colored direction for the tool’s axis or “normal”.

Locking the drawing plane with arrow keys

Ensuring edges are aligned to axes

To ensure your edges align to axes, you may find it helpful to change the cursor to the axes colors. Or if you need to check the alignment of existing geometry, change your edges to the axes colors.

To change your cursor to axes colors, follow these steps:

  • Select Window > Preferences (Microsoft Windows) or SketchUp > Preferences (macOS). The SketchUp Preferences" dialog box appears.
  • Select the Drawing item on the left.
  • In the Miscellaneous area of the Drawing panel, select the Display cross hairs checkbox.
  • Click OK to close the SketchUp Preferences dialog box. The cursor displays cross hairs that are the color of the axes, as shown here.

To make the edges in your model reflect the axis color to which it is aligned, follow these steps:

  1. Select Window > Styles.
  2. In the Styles dialog box, select In Model from the drop-down list of styles libraries.
  3. Click the Edit tab.
  4. Click the Edge Settings icon, shown in the figure.
  5. From the Color drop-down list, select By axis. The colors of the edges in your model change to reflect their alignment to the axes (unless an edge isn’t aligned to an axis, and then the edge color does not change). The following figure shows which edges are (and are not) aligned to the three axes.

TAGS