Release Notes

SketchUp Desktop 2019.3

Released: October 14th, 2019

Version:
19.3.253 (Win 64-bit)
19.3.252 (Mac 64-bit)

Sign In Workflow Changes

What has changed?

Users will now sign into our desktop applications via an external web browser, instead of an embedded web browser. This change impacts both subscription and classic license users.

The change in 2019.3 that will impact classic license users: Users need to be signed in before accessing the 3D Warehouse, Extension Warehouse and Add Location, which they didn't need to do in previous builds. Accessing these features will go through the new sign-in workflow, which means classic license users need Trimble IDs (or Google IDs) to access them.

Why?

This past April, Google announced that it will no longer support Google Sign In through embedded browser frameworks. In order to continue supporting Google Sign In, we’re following one of Google’s recommended solutions: to have users sign in through their default web browsers and capture the sign in information via a web server on their local machine (127.0.0.1).

What does this mean from a user’s point of view?
  • All users need to be signed in to access the 3D Warehouse, Extension Warehouse, Trimble Connect and Add Location from within the desktop apps.
  • When a user selects a ‘Sign In’ command from within a desktop app, the user’s default web browser will open a new tab in order for them to sign in.

SketchUp Release Notes

Fixes

macOS Catalina Support

Added support for macOS Catalina, which included the following updates:

  • Implemented the notarization process that will be required for macOS Catalina.
  • Fixed an issue where the Welcome Window’s templates panel sometimes loaded slowly.
  • Fixed an issue where text was displayed with a black background on some configurations.

Other
  • Changed our internet connection tests to work more robustly across the globe.
  • (Win) Updated libcrypto and libssl dlls to 1.1.1c.
SketchUp Desktop 2019.2

Released: July 18th, 2019

Version:
19.2.222 (Win 64-bit)
19.2.221 (Mac 64-bit)

Enhancing your professional workflow—it's the small things that count!

We are excited to announce our second desktop product update since releasing SketchUp 2019. We've been hanging out on the forum and researching at 3D Basecamp to get some insight into your workflows. With your feedback, we've worked hard to update some top features in SketchUp Pro 2019 and LayOut. Try out these new updates, and see how they impact your professional outputs and workflows.

What's new in SketchUp 2019.2

The name of the game (update) is ease of use. This release has made SketchUp more intuitive — and more fun to use. With more focus on improvements to imagery exports, usability, and a seamless LayOut connection — your professional workflow will greatly benefit. Check out the top features below.

Professional output enhancements

Exporting images. Exporting 2D graphics, raster files, and animations just got better. You can now control the overall line thicknesses of exported images with our new line scale multiplier, found in the export options dialogs. Before this change, line weights stayed the same as the viewport which could make the line weight too small or too large. So, if you are experiencing line weights that are too thick, you can make those line weights thinner. Also, .png images now export with transparency so you can see what is behind the material while compositing.

Customizable unit settings. Have you ever needed to use different unit measurements for a model? Now your model can be customized to show different unit measurements for area and volume. For example, in a model of a room, you can use inches for the wall and feet for volume. Available unit types: inches, feet, millimeters, centimeters, and meters.

Workflow improvements

Invert Selection. Just like the title suggests, it's the small things that help your workflow! This new feature will allow you to select anything, then invert the selection of objects. This makes it simple to select items and then perform actions on their inverse. The keyboard shortcut for this will be: CTRL + SHIFT + I (Windows) or CMD + SHIFT + I (Mac).

Importing files. The days of picking out your import file format from a long list are over. You can now drag and drop ALL supported file types directly into your modeling window. By default, you'll now see all supported file types available for import. Additionally, the DWG and DXF importers now bring in fewer duplicate and messy edges.

Eraser Tool. Have you ever accidentally erased too much in your model? To make your detailing workflow a little smoother and seamless, we added alt & cmd as modifier keys to remove any unnecessarily highlighted lines that you might have accidentally captured during your modeling efforts.

Section Planes. Cutting a model along a plane so that you can peer inside the model? We just made this way smoother. Section planes now ask the user to name them after placing them in the model. Simply place, then name.

Send to LayOut. Clearly, we want to make LayOut even better to use! You can now send your models directly to LayOut from the large toolset in the left-hand toolbar. If you haven't used LayOut before, you should check it out now!

Large Area Imports for Add Location. You can now easily import large sites at full resolution. How can you take advantage of this new feature? Simply zoom out a bit, then select the level from which you want to import. Be aware that, importing very large areas with lots of imagery can adversely affect performance in your SketchUp model. Check out our help center to be sure you're aware of how to best handle lots of data in your models. Note that this feature is only available to SketchUp Pro and Studio subscription holders.

What's new in LayOut 2019.2

The overall changes for LayOut can be summed up in a few words: improved overall interaction for construction documentation. We focused on making the usability of LayOut more natural and consistent with that of SketchUp. Check out these life-changing updates.

Professional output enhancements

Isometric dimensioning. It is now possible to make linear dimensions align with an isometric viewpoint. This one is huge! Since an isometric drawing is a primary type of drawing in LayOut, we wanted to make it smoother and more straightforward. You can now control extension lines, gap distance, and align dimensions with isometric angles.

Auto-text. Similar to “smart labels”, you can now add text to dimensions without breaking the automatic measurement. For example, let's say you create a wall dimension. You can dimension a wall, add the word “height”, and the dimension measurement will still update if the measurement changes. Pro tip: make sure your string has <> in it. For example, Height <>' will turn into 'Height 132in'.

Workflow enhancements

Rotating dimensions. Now, when your dimensions are off-axis, the bounding box will remain aligned with the object so you can continue to scale it in the right orientation.

Scaling dimensions. All connected dimensions will move and scale with the parent object. Just select the SketchUp model or Scaled Drawing or anything a dimension is attached to and connected dimensions will come along for the ride.

Quicker editing. Staying consistent with SketchUp usability, you can now hit the return key to edit SketchUp model views, groups, dimensions, or labels! Just select, press return, and start typing!

SketchUp Release Notes

Bug fixes/small features added

We have fixed a good deal of bugs with this release and added some small features, including:

Stability
  • Fixed a crash that could occur when offsetting a chain of edges that resulted in a smaller number of edges.
  • Fixed a crash that could occur when fixing validity errors in a model where the length in a dynamic component is set to infinity.
  • Fixed a crash that could occur when copy/pasting certain section planes and saving the model.
  • Fixed a crash that could occur when deleting a line with the Dimension, Rotate or Protractor tools active.
  • Fixed a crash that could occur when offsetting open arcs so that they almost disappear.
  • [Win] Fixed a crash that sometimes occurred when changing scenes.
Model Display
  • Fixed an issue where guides that are coincident with a section plane were not drawing.
  • Fixed an issue where profile lines for softened back edges were displaying as solid vs with the dashed back edge stipple pattern.
  • [Win] Fixed an issue where SU could open with a blank workspace when using Intel graphics cards with certain Intel drivers.
  • [Mac] Fixed an issue where line weight thickness was sometimes rendered incorrectly on systems with two monitors.
  • [Mac] Fixed an issue where arrowheads incorrectly resized when clicking between low-res and Retina displays.
Tools/Inferencing
  • Fixed an issue where zoom could be too sensitive when zooming into a filled section plane.
  • Removed the display of radial lines and centers when offsetting arcs, circles and polygons to make interactions cleaner.
  • Fixed an issue where inferencing could not find an endpoint of a recently created edge.
  • Fixed an issue where, when offsetting a single painted face outward, the newly created faces did not inherit the material of the original face.
  • Fixed an issue where the offset could be larger than expected when offsetting a circle using the “allow overlap” modifier key.
  • Fixed an issue where, when offsetting a three pointed star, the offset could shift incorrectly.
  • Fixed an issue where drawing small rectangles on small faces could cause the loss of materials and/or faces.
  • Improved how the offset tool works with certain arcs to ensure arcs are retained in more situations after an offset operation.
  • Fixed an issue where the Measure tool still showed the units of a face's area when the display of units was turned off in Model Info.
Image export
  • Fixed an issue where sketchy edges in an image exported using the transparent background option could display with a white halo.
  • Fixed an issue where transparent faces in an image exported with the transparent background option displayed without transparency in other applications.
  • Fixed an issue where the width and height values in the Options dialog for image export would not update when edited.
  • Changed image export to give consistent results for text and dimensions regardless of the DPI of the display from which the export occurs.
  • [Mac] Fixed an issue where setting certain format-specific image export options had no effect.
Miscellaneous
  • Fixed an issue where extensions licenses could not be obtained for users with a SketchUp Subscription license. Extension licenses should be correctly obtained during extension installation in all cases now.
  • Added a warning message when SU launches and is not using an available AMD or NVIDIA graphics card.
  • Fixed an issue where guide points made by typing a length of 0 couldn't be selected.
  • Fixed an issue where sampling with the Material Browser's eye dropper picked the default material vs the sampled material when picking through a section plane.
  • Fixed an issue where the user could not import the JPEG file format.
  • Added timestamp and path name tool tip text to the Welcome Window's Recent Files tab.
  • Changed the messaging in the "Oops...That didn't look like valid licensing info..." error message for Classic licensing, to provide more precise instructions for resolution.
  • Updated the Trimble Connect extension to utilize a newer Connect API version.
  • Fixed an issue where the Help Center for errors on startup did not go to a language specific link.
  • Fixed an issue where the Unit combo boxes were editable in Model Info.
  • Improved formatting of file location tool tip text in the Welcome Window.
  • [Win] Fixed an issue where recovered files were sometimes deleted during a revert operation.
  • [Win] Fixed an issue where the SketchUp 'Send to LayOut' command did not work if LayOut was already open with certain configurations.
  • [Win] SketchUp now displays backup (.skb) files when the user selects File > Open.
  • [Win] Fixed an issue where the STL Import Option choices for units did not persist when closing and re-opening the Options dialog.
  • [Mac] Added the ability to save as older versions for Save A Copy As.
  • [Mac] Changed the "Length" label in Entity info to be more accurate depending on which entity type is selected.
  • [Mac] Fixed an incorrect Japanese translation in the Styles tray.

Known Issues

Certain extensions are not yet compatible with SketchUp 2019.2. We are not able to know every extension that is affected, but we don’t believe that the number of extensions affected is large.

We know that Thea is not yet compatible with SketchUp 2019.2. If you require Thea Renderer, we recommend that you not upgrade at this time, until they are able to release a compatible version.

Please see this SketchUp Forum post for more information.

LayOut Release Notes

Bug fixes/small features added

We have fixed a good deal of bugs with this release and added some small features, including:

Stability
  • Improved the way we handle selection and multiple select.
SketchUp Model View
  • Render Mode and Scene can no longer be changed when selecting multiple Locked SU model viewports.
DWG Export
  • Fixed an issue where a SketchUp model view that was grouped would export at 1:1 PaperSpace scale.
Miscellaneous
  • Addressed a problem where auto-render could cause an infinite loop or latency in the application when a model failed to render.
  • Fixed a problem where LayOut and Style Builder did not display offline Action Manager notifications.
  • Fixed an issue where the clipping mask would be lost after editing.
  • Improved Welcome Window load time.
  • Changed the warning message when a model fails to render to provide instructions on how to resolve the rendering failure.
  • [Win] Fixed an issue where the Welcome Window would not scroll.
  • [Win] Fixed an issue where the LayOut window would lose focus when using the label tool and multi component component names.
  • [Win] Corrected an inconsistency where the list of available versions in Save As were in a different order from the way they were displayed on the Mac or in SketchUp.
  • [Win] Removed the "All Files(*.*)" entry from the File > Save and File > Save As file picker dialogs.
  • [Mac] We have restored the “Space” and “List” functionality for text editing.

SketchUp API Release Notes

What's New?

Ruby Version Upgrade

The SketchUp application and the SDK have been updated to Ruby version 2.5.5. This was done to address an optimization bug in 'if' and 'jump' and to improve security.

Mouse Wheel in the Ruby API!

In addition to exposing new functionality in SketchUp we exposed the mouse wheel event to custom Ruby tools. This opens up new possibilities for interacting with the viewport and UI and could make for some exciting new Ruby extensions.

Textures - Export Performance and other Improvements

Exporting texture data and performance was a theme across both APIs. For anyone exporting textures, we fixed two specific issues.

  1. In the C API, previously we were re-writing all images, even if SketchUp itself was not altering the image (ie. with a colorization effect). This significantly increased export times. We've changed it to now just dump the original file.
  2. In the Ruby and the C API, we've made a change to how we export colorized png's. Previously we were using the highest (and slowest) compression setting. We've adjusted this setting to a more moderate compression. Our 4k x 4k image export test reduced from ~50 seconds to only ~6 seconds.

A number of missing "Remove" functions were added to the C API, further improving the feature parity with the Ruby API.

Ruby API Additions and Improvements
  • Added onMouseWheel event to the Tool interface.
  • Added Sketchup::Selection#invert
  • Added :scale_factor to view.write_image to allow the API user to control the scaling factor of viewport dependent elements such as line weights.
  • Added the new area and volume unit settings to Sketchup::OptionsProvider.
    • Added Sketchup.format_volume.
    • Added constants to the Length class for area and volume units to be used with the OptionsProvider.
  • Documented :source => :framebuffer option in Sketchup::View#write_image that dumps the current frame as drawn in viewport. This has existed since SketchUp 7.
Ruby API Bug Fixes
  • Update Ruby Version to 2.5.5 to fix optimization bug in Ruby 2.5.1.
  • Fixed possible crash in Sketchup::Entities#clear.
  • Added checks to prevent Image materials from being assigned to normal drawing elements. Doing so will now throw an ArgumentError.
  • It is no longer possible to assign Sketchup::Image materials to entities.
  • onViewChanged now triggers when the viewport changes size.
  • Dynamic Component no longer throws an error on deleted entity.
SketchUp C API Additions and Improvements
  • Added SUApplicationGetActiveModel
  • Added SULengthFormatterGetAreaUnits
  • Added SULengthFormatterSetAreaUnits
  • Added SULengthFormatterGetVolumeUnits
  • Added SULengthFormatterSetVolumeUnits
  • Added SUMaterialGetColorizeDeltas
  • Added SUMaterialGetColorizeType
  • Added SUMaterialSetColorizeType
  • Added SUMaterialGetOwnerType
  • Added SUModelGetAllMaterials
  • Added SUModelGetNumAllMaterials
  • Added SUModelGetGuid
  • Added SUModelLoadDefinition
  • Added SUModelRemoveComponentDefinitions
  • Added SUModelRemoveLayers
  • Added SUModelRemoveMaterials
  • Added SUModelRemoveScenes
  • Added SUStylesRemoveStyle
  • Added SUStylesSetSelectedStyle
  • Added SUTextureWriteOriginalToFile
  • Removed Deprecated C++ Com Interface.
  • Updated SDK docs on VC++ runtime versions.
  • It is now possible to use the C API to get the active model using SUApplicationGetActiveModel. This is for Read Only access to the model. Mac builds were missing the symbols for Live C API. They are now included in this build.
  • For more information about the Read Only Live C API, how to link correctly - read this forum post.
SketchUp C API Bug Fixes
  • Fixed a bug where SUModelSaveToFileWithVersion and SUModelSaveToFile weren't updating the model's GUID.
  • Fixed SUStylesAddStyle where it would fail to load some .style files.
  • SUComponentInstanceFromEntity returns NULL if underlying entity is a Group
  • Fixed a performance regressions where SUTextureWriteToFile would rasterize non-colorized texture instead of just dumping the original file data.
  • It is no longer possible to assign Sketchup::Image materials to entities
Ruby API and C API
  • Increased performance of PNG image export for colorized materials. Previously, it used to use max compression. Now we use a more balanced compression setting. This affects SUTextureWriteToFile/Sketchup::Texture#write as well as the texture writer. We also added some general optimizations for SUTextureWriteToFile/Sketchup::Texture#write. On a 4Kx4K texture we saw the processing time drop from ~50 seconds to ~6 seconds.

C++ API (SkpReader) Removal

We recently announced that we had done the work to remove the C++ API from the SketchUp SDK. This is our first release that does not support the C++ API. See this forum post for more information.
https://forums.sketchup.com/t/developer-announcement-c-api-removal/94943" target="_blank">https://forums.sketchup.com/t/developer-announcement-c-api-removal/94943

Who does this affect?

This change should not affect most people, as most people are using our C API. However, anyone that is still using the C++ API which has been included in the “deprecated” folder in the SDK since SketchUp 2013 will need to migrate their code to the C API. You will still be able to read and write SketchUp 2019 and earlier .skp files using the C++ API that we released with previous versions of SketchUp 2019. But you will not be able to add a custom exporter that uses the C++ API to SketchUp. The bridge that connects the C++ exporters to the SketchUp exporter interface has been completely removed in this and all future versions of SketchUp.

SketchUp Desktop 2019.1

Released: April 8th, 2019

Version:
19.1.174 (Win 64-bit)
19.1.173 (Mac 64-bit)

SketchUp Release Notes

Fixes:
  • Fixed an issue where the classic and trial licensing information displayed to the user in the Welcome Window could be confusing. Specifically:
    • When a user enters a classic license alongside an active SketchUp trial, they are still be eligible to try other products in the Studio bundle.
    • The licensing panel now defaults to the Classic tab if the user has entered a Classic license.
    • If the user has entered a Classic license, we no longer show trial expiration text in the upper right corner of the Files panel.
  • Fixed an issue where exporting using AutoCAD 2018 file format would create a "Student Version" plot stamp for both SketchUp and LayOut when the file was opened in AutoCAD 2019.
  • Fixed an issue where text would not export with a 2D DWG/DXF export.
  • Fixed an issue where auto-save files did not persist on the Mac after a reboot or shutdown.
    • On Windows, recovered files are now saved here: C:\Users\YourUserName\AppData\Local\SketchUp\SketchUp 2019\SketchUp\working\SKETCHUP\RecoveredFiles
    • On the Mac, recovered files are now saved here: ~/Library/Application Support/SketchUp 2019/working/SKETCHUP/Recovered Files
  • (Win) Fixed an issue where models would open slowly with the Materials dialog expanded.
  • (Win) Fixed an issue where the Add License button was not working for Windows OS usernames having an apostrophe.

LayOut Release Notes

Fixes:
  • Fixed an issue where LayOut could crash when opening a file. This was caused by corrupt paths not being removed when they were detected.

SketchUp API Release Notes

Fixes:
  • Fixed the accepted types for the "point" in entities.add_text
  • Fixed Model.save for VERSION_2019
  • Fixed crash when rendering_options["RenderMode"] = 4
SketchUp Desktop 2019

Released: February 5th, 2019

Version:
19.0.685 (Win 64-bit)
19.0.684 (Mac 64-bit)

SketchUp Pro 2019 Release Notes

A New Way to SketchUp

Subscriptions and Classic Licenses

Users now have the choice to buy a SketchUp subscription or a classic license of SketchUp Pro for desktop. Learn more about our subscription offerings in this Help Center article.

Trimble ID

A Trimble ID (TID) will be the gateway to access any SketchUp products. A TID will allow you to download a trial, buy a classic license or subscribe. You can sign up using an existing Gmail account or you can create a TID using a valid email address.

Launch Experience

We’ve refreshed the launch experience on SketchUp’s desktop applications—SketchUp Pro for Desktop, LayOut, and Style Builder. To access these applications, just sign in with a Trimble ID or enter an active classic license.

30 day Trials

There are a number of products you can explore during your 30-day trial of SketchUp Studio. The free trial currently includes:

  • SketchUp for Web
  • SketchUp desktop applications: SketchUp Pro for Desktop, LayOut, Style Builder.
  • Trimble Connect Personal (5 collaborators, 2 projects, and up to 10 GB of cloud storage)
  • Sefaira (building performance analysis software).
  • Augmented reality viewing on SketchUp Viewer for iOS and Android
  • Viewing on XR applications: HTC Vive, Oculus Rift, Hololens, and HP Windows Mixed Reality

What’s New in SketchUp Pro for Desktop?

Welcome Panel (SketchUp Pro for Desktop + LayOut)

We’ve made some updates to our Files, Learn, and Licensing tabs to make it easier to manage projects and licenses. While we were at it, we added links to learning resources directly into SketchUp and LayOut.

Files tab: When you launch SketchUp or LayOut, you’ll see a Files panel where you can manage default templates and access new, recent and recovered files. To change to a different template when opening a new file, select the “New From Template” option in the File pulldown menu.

Learn tab: We are introducing a new portal for training content, appropriately named, the SketchUp Campus. This is the hub for both beginner and advanced learning through video courses that will eventually cover the entire SketchUp family and many professional industry work flows.

Licensing tab: You can still easily access your licensing information from within SketchUp and LayOut. When you select the licensing tab, you can choose to view either your classic license or subscription information.

Default Toolbar Changes

We’ve made some new updates to the toolbars in SketchUp Pro and LayOut. You’ll notice a “My Account” icon in the top upper-right hand side of the screen. Here, you can access your licensing information, sign in and sign out.

Dashes

Solid lines don’t always tell the full story. Sometimes you need a dash pattern to convey your design idea. Whether you need to demarcate a property boundary, identify what is proposed, or identify walls for demolition, adding a stipple might be your best solution.

Supported Dashes in SketchUp (imperial and metric equivalents
Supported Dashes in SketchUp (imperial and metric equivalents

That’s why we’ve incorporated dashed lines into SketchUp Pro 2019. These dashes are properties of Layers and can be controlled from the Layers panel. Even better, components on layers will inherit the dash pattern. In LayOut, your dashes will show in the viewport at any screen scale and in all render modes with the ability to edit the dash width and scale.

When you’re ready to export, SketchUp can convert your dashed pattern into a bunch of file formats: PDF, EPS (vector), images (raster), and DWG/DXF.

SketchUp Tape Measure Tool

Upgrades to the Tape Measure tool mean less time you’ll spend opening up Entity Info or looking at the Measurements box. Now, you can get the length of edges, area of faces, and coordinates of midpoints and intersections straight from an inference tip.

Compatibility Mode for Windows 10

It is no longer necessary to run SketchUp in compatibility mode. Compatibility mode was employed for several SketchUp releases as a workaround for problems with older Intel HD 2000 and HD 3000 GPUs on Windows 10. These GPUs have been deprecated by Intel on Windows 10 and because this workaround introduced problems of its own, it has been removed. As a result SketchUp, LayOut, and Style Builder will no longer run with Intel HD 2000 and HD 3000 GPUs on Windows 10.

Support for macOS Mojave

Our QA team has smashed and banged on Apple’s newest operating system, macOS Mojave, enough to say that SketchUp 2019 is fully compatible.

What’s New in LayOut?

LayOut File Locking

We’ve made it harder to overwrite your LayOut files with unintentional edits. If you have multiple people working in the same file or if you’ve opened a file in two separate LayOut instances, we’ll temporarily lock your file and let you know it’s “read only.” Simple.

SketchUp Dashes Control

With the introduction of Dashes in SketchUp, LayOut now has the ability to modify how those lines styles are displayed. With the SketchUp model viewport selected, the SketchUp Model inspector will allow for modification.

LayOut’s SketchUp Model inspector
LayOut’s SketchUp Model inspector
Export for SketchUp feature

SketchUp has always played nice with others. We’ve been hard at work making it even easier for you to move between the software you need. In LayOut we have added a ‘Export for SketchUp’ feature to the DWG/DXF exporter that places all LayOut entities into the Model Space so that SketchUp can now ‘play’ with all LayOut data. As part of this feature Groups are sent over as SketchUp Components, Fills and Patterns are sent over as SketchUp faces for easy Push/Pull’n.

LayOut’s DWG/DXF Export Options dialog
LayOut’s DWG/DXF Export Options dialog
Plan and Elevation created in LayOut
Plan and Elevation created in LayOut
Plan and Elevation imported into SketchUp via the new “Export to SketchUp” option
Plan and Elevation imported into SketchUp via the new “Export to SketchUp

With the 2019 release, you can now import and export AutoCAD 2018 DWG files in SketchUp Pro and LayOut. In LayOut, we’ve made it easier to export to DWG, and added the ability to adjust the Model Space Units when you import a DWG.

LayOut’s DWG/DXF Import dialog
LayOut’s DWG/DXF Import dialog
Mouse Scroll Speed Controller

We now provide users the ability set their mouse scroll speed within LayOut. With so many variances in systems, this is a helpful way to improve your LayOut experience.

LayOut’s Mouse Scroll Speed Dialog
LayOut’s Mouse Scroll Speed Dialog

Bug Fixes/Small Improvements in SketchUp

In addition to the above, we’ve been heads down fixing bugs and adding some smaller features:

Stability
  • Fixed a crash that could occur when exporting models with section planes to PDF.
  • Fixed an issue where deleting lines could cause invalid text entities that corrupted the camera view / made the model unusable.
  • Improved the overall stability of 2D and 3D DWG importing and exporting.
  • (Win) Fixed a crash that occurred when importing shortcuts with certain key combinations (including arrow keys, Ctrl -, Ctrl =).
  • (Mac) Fixed a very frequent crash that could occur when working with multiple documents, one of which has shadows on.
  • (Mac) Fixed a frequent crash that could occur when doing certain actions during scene transitions.
  • (Mac) Fixed a frequent crash that could occur when cancelling out of certain tools and switching documents.
  • (Mac) Fixed a crash that could occur when painting a face after closing a document.
  • (Mac) Fixed a crash that occurred on exit if a material was added to a material list created outside of SketchUp.
  • (Mac) Fixed a crash that occurred when exporting to IFC in JA.
  • (Mac) Fixed a crash that occurred when adding a new texture to a newly created materials list in Materials dialog.
  • (Mac) Fixed a crash when deleting the values in the Style Browser.
Model Display
  • Improved the rendering of stipple patterns when there is rotation so that the stipple pattern is always perpendicular to the line.
  • Added anti-aliasing to stipple patterns.
  • Changed the alpha value for back edges.
  • Improved filled section cut rendering, allowing a section to be filled when one hidden face surrounded by two visible faces is cut.
  • Added the ability to allow soft profiles to be displayed as back edges.
  • Added a space between a number and metric units when formatting lengths displayed in SketchUp - e.g. 10 mm.
  • Fixed an issue where diagonal lines did not display well with faster transparency + 0x MSAA.
  • Fixed an issue where lines could be clipped/disappear when zooming in with a section cut.
Tools/Inferencing
  • Enhanced the Measure tool to show the length of an edge and area of a face in the “On edge” and “On face” tooltips.
  • Enhanced the Measure tool to show the coordinates of vertices in the Measurements toolbar (VCB) and a tooltip.
  • Fixed an issue where Offset could give unexpected results when offsetting shapes with rounded corners.
  • Fixed an issue where selection was slow on some Windows 10 machines.
  • Fixed an issue where you could not enter Imperial inches units into the Measurements toolbar (VCB) when model units were set to metric.
  • Fixed an issue where you would sometimes get an unwanted component origin inference.
  • Fixed an issue where you could pick up an unexpected "On Section" inference with a hidden section plane.
  • Fixed an issue where zooming could lag on some machines with Intel GPUs at higher MSAA settings.
  • Fixed an issue where zooming could be very slow when the mouse is not over any geometry.
  • Fixed an issue with the Rectangle tool where midpoints could not always be inferred when using locking.
  • Fixed an issue with the Rectangle tool where the alignment preview icon was incorrect when inside a rotated component.
  • Fixed an issue where the Offset tool sometimes based its offset on vertices and not edges.
  • Fixed an issue with the Measure tool where lines did not always turn bold when Shift or the arrow keys were used to constrain lines.
  • Fixed an issue with the Move tool where lines did not turn bold when the cursor was directly in front of the dashed lines when the arrow keys were used to move an object in one of the x,y,z axis directions.
  • Fixed an issue where the picking order was incorrect for a rectangle on top of an image, resulting in unexpected behavior when using the Text tool on the rectangle.
  • (Win) Fixed an issue where some of our standard shortcuts unexpectedly changed the drawing mode for the Rectangle tool to “Draw about center”.
  • (Win) Fixed an issue where 3D Text dialog checkboxes were difficult to use when scaling was greater than 100%.
  • (Mac) Fixed an issue in which the default extrusion value changed each time 3D Text was placed if not using units of Inches.
DWG Import

In SketchUp you now have the ability to Import and Export Materials improving interoperability for CAD and BIM workflows.

  • Fixed an issue where polylines with arcs would import with extraneous geometry.
  • We now import entities on frozen layers as non-visible.
  • We revised the precision of our importer to better allow for import of small entities, faces and solids.
  • We revised our importer to adaptively calculate the scale factor on imported geometry.
DWG Export
  • We fixed an issue where geometry could get lost at a very small scale.
  • We improved the precision of Arcs and Circles so that they would be more accurate and created for most conditions.
  • (Mac) We fixed an issue where wide polylines were not being created when exporting 2D DWG with automatic width checked.
Vector Output (PDF export, Vector printing, Vector and Hybrid rendering modes in LayOut)
  • Fixed an issue where extra lines were seen when a section cut is coincident with a face.
  • Fixed an issue where extra lines were seen when extruded circles are cut along their center.
  • Fixed an issue where hidden divided edges on top of faces drew as if they were visible.
  • Fixed an issue where images incorrectly showed a border around them.
  • Fixed an issue where lines were missing with some plan view models.
  • (Win) Fixed an issue with .PDF Export where the actual line widths were not exporting correctly.
  • (Win) Simplified the .PDF and .EPS dialogs and added control over the Line Scale.
  • (Mac) Wording with Export to .PDF and the Print dialog has changed from ‘Line Weight’ to ‘Line Scale’.
Layers Dialog
  • Updated the active layer and visible icons in the Layers dialog to align across LayOut & SketchUp.
  • Adjusted layer panel column ordering to address issues where the active layer may be changed unintentionally for new users, and to reduce the prominence of the active layer controls.
  • Layer Name sorting logic has changed -
    • For context, this would occur when sorting by name previously:
      Layer1
      Layer10
      Layer11
      Layer2
      Layer22
      Layer3
      Now this will occur:
      Layer1
      Layer2
      Layer3
      Layer10
      Layer11
      Layer22
Miscellaneous
  • Fixed an issue where SketchUp models performed slowly in some models with a section plane.
  • Fixed an issue where the Entity Info "Toggles" icons did not update visually when tab was pressed.
  • Added the ability to edit a selected component by pressing Enter.
  • Fixed an issue where text/dimensions set with the “height” property scaled incorrectly on high DPI machines.
  • Fixed an issue where models with lots of construction points performed very poorly.
  • Fixed an issue where exploding a classified component instance produced an extra hidden classified entity.
  • Fixed an issue where Entity Info did not report area for surfaces.
  • Fixed a strange jump that could occur when editing component instances far from the origin.
  • Fixed an issue where Component Definitions in Model Info > Statistics were not updating properly when adding or deleting a component.
  • Fixed an issue where the shadows date and time controls do not scale properly on high DPI displays.
  • Fixed an issue where SketchUp would take focus during start up preventing work in other apps.
  • Fixed an issue where Add location terrain failed to import for some locations.
  • Fixed an issue where a "SketchUp Make" dialog was appearing in SketchUp Pro.
  • Fixed an Add Location issue where terrain import failed when a location has gaps in terrain coverage.
  • Added the ability to see a full shortcut description in the Preferences dialog.
  • Improved sorting of layers to be more intuitive.
  • Fixed an issue where Activating Shadows via the View menu would not require that the model be saved.
  • Upgraded the version of Chromium that SketchUp uses.
  • Updated error messages to refer to component definition instead of component name for consistency with Entity Info terminology.
  • Updated template names to reduce redundancy with Units specifications.
  • Fixed an issue where the "Enable length snapping" option could not be disabled when using the Architectural units format.
  • Fixed an issue where whole numbers were not displayed consistently when using the Engineering units format.
  • Fixed an issue where validity checking did not occur when saving/opening a SU 2015 or newer model in some cases.
  • Fixed an issue where you could have unexpected results when changing the number of segments of a polygon or arc.
  • Removed the ability to sign out from the 3D Warehouse and Extension Warehouse pages within SketchUp to avoid signing users out of SketchUp and thus losing access to their subscription.
  • Fixed miscellaneous language translation and truncation issues in localized builds.
  • Fixed an issue to provide dynamic block support for DWG imports.
  • Fixed an issue where certain .STL files would fail to load.
  • (Win) Fixed an issue where the Scene tab’s Rename item context menu was missing.
  • (Win) Fixed an issue where SketchUp did not display area for curved surfaces.
  • (Win) Fixed an issue in which a Tray context menu would appear when clicking within a context menu that was outside of the drawing window.
  • (Win) Fixed an issue in which tray dialogs would flicker when resized.
  • (Win) Fixed an issue in which 3D Warehouse and Extension Warehouse dialogs would flicker when resized.
  • (Win) Fixed an issue where the user was not alerted that autosave files existed when opening files via double-clicking.
  • (Win) Changed the “Length” label in Entity Info when circles, polygons and arcs are selected.
  • (Win) Changed the error message you see when running the CheckUp application and the RAM can’t be determined to be more accurate.
  • (Win) Updated the File > 3D Warehouse menu to show Share Component instead of Get Models.
  • (Mac) Fixed an issue where autosave files were not deleted after reopening SketchUp after a crash and taking actions.
  • (Mac) Fixed an issue in Image Export where the Resolution set by the user would not persist on Mac.
  • (Mac) Fixed an issue where the user was not prompted to save an autosaved file after a crash.
  • (Mac) Fixed an issue with the default file name supplied when downloading Unicode models outside of SketchUp.
  • (Mac) Fixed an issue where files saved to folder names containing special characters would cause autosave to fail.
  • (Mac) Fixed an issue in which materials were temporarily displayed in 3d Printing library when a materials list was removed.
  • (Mac) Fixed an issue in which user could overwrite their entire Templates folder.
  • (Mac) Fixed an issue in which the Soften/Smooth Edges dialog initially displayed angle of 360 degrees instead of 36 degrees.
  • (Mac) Fixed an issue where templates saved with names containing unicode characters displayed an incorrect template name.
  • (Mac) Fixed an issue where exported animation used the incorrect size.
  • (Mac) Fixed an issue where the icon for the Section Fill button was missing in SketchUp Viewer.
  • (Mac) We changed ‘Line Weight’ to ‘Line Scale’ in the Print and Export to 2D Graphic… dialogs.
  • (Mac) We now allow assign entities color ‘Bylayer’ on 2D Section Slice.
  • (Mac) Fixed an issue in which the Aspect Ratio for Animation export wasn’t saving.
  • (Mac) Changed SketchUp to not reopen crashed models on re-launch.
  • (Mac) Fixed an issue where the paint bucket cursor changed back to OS cursor after painting a face.
  • (Mac) Fixed issue in which 3D Warehouse window would show up blank when trying to access while offline. Now a message appears indicating you are offline.

Bug Fixes/Small Improvements in LayOut and Style Builder

In addition to the above, we’ve been heads down fixing bugs and adding some smaller features:

Stability
  • Fixed a crash that could occur when rendering or re-rendering a SketchUp viewport in LayOut using Vector or Hybrid mode.
  • We had an issue where LayOut could lose the association to file references (SketchUp models and images). We found this to be related to the users temp folder being removed or over written possibly by an anti-virus utility or disk clean up process. This seemed to be most obvious when a copy paste was used to import files. To remedy this we have moved the active working file outside of your system temp folder.

    Your working LayOut files will now exist in the following location:

    Windows: c:\Users\<username>\AppData\local\SketchUp\SketchUp 2019\LayOut\working

    Mac: /Users/<username>/Library/Application Support/SketchUp 2019/LayOut/working

  • We fixed a crash when opening a document with the units set to Points.
  • We fixed an issue where Path entities could get corrupt.
  • (Win) We fixed a crash when exporting to .PDF if the file type extension was removed.
  • (Mac) We fixed a crash if you would enter an empty value in the ‘Line Width’ field of the SketchUp Model inspector.
  • (Mac) We fixed a crash when purging file references.
  • (Mac) We fixed an issue where a crash would occur when accessing ‘Other’ on the Text Styles pulldown when rulers are active. We are preventing the accessory view from coming up and now Text edits can only be done from the Fonts panel.
  • (Mac) We fixed a crash in the Label editor flyout.
SketchUp Model View
  • We fixed an issue where the SketchUp actual font height would display at the LayOut Paper Space height.
  • We fixed the Hotspot on SketchUp models to better correspond with the cursor location.
  • Fixed an issue where internal lines would disappear when Vector rendering with the ‘Wireframe’ style.
  • (Win) Vector and Hybrid render has been improved to fix a number of issues where either the background color or the section fill color would ‘flood’ beyond the SketchUp Model view.
  • (Win) We fixed an issue where Raster rendered viewports would not display line weights correctly especially on high resolution monitors.
  • (Mac) We fixed an issue when exporting to .PDF where lightened images would be produced with Mac OS 10.13.4 and higher.
Table Tool
  • You can now copy and paste a pattern fill within a Table.
  • Copy and pasting Table data is now text and not an image.
DWG Import
  • We fixed an issue where Dimensions could get misaligned on import.
  • We fixed an issue where an import would fail if the Viewport layer was not visible in AutoCAD (off or frozen).
  • We improved our importer to better support non-rectangular viewports.
  • We fixed a bug where an import would fail with certain non-uniform scaled blocks.
  • We have improved our precision with small objects so that the import would not fail or produce strange artifacts.
  • We fixed how underlined text is imported.
  • We now respect the visibility state of a Dynamic View Block.
  • Fixed an issue where LayOut text with fill was not being converted to AutoCAD filled text.
DWG Export
  • Fixed an issue where text fill was not being exported on Text, Labels and Dimensions.
  • Fixed an issue where text was being exported too large.
  • We had a bug where text size was lost on user modified dimensions.
  • Fixed an issue where the text style and height within a Table would lost on export.
  • We had an issue where exported arcs could be drawn inside out.
  • (Mac) Fixed a crash when exporting with an attached .PDF.
Vector and Hybrid rendering in LayOut
  • Fixed an issue where extra lines were seen when a section cut is coincident with a face when using Vector/Hybrid rendering in LayOut.
  • Fixed an issue where extra lines were seen when extruded circles are cut along their center when using Vector/Hybrid rendering in LayOut.
  • Fixed an issue where hidden divided edges on top of faces drew as if they were visible when using Vector/Hybrid rendering in LayOut.
  • Fixed an issue where images incorrectly showed a border around them when using Vector/Hybrid rendering in LayOut.
  • Fixed an issue where lines were missing when Vector rendering some plan view models in LayOut.
  • Fixed an issue where extension lines were not drawn when using Vector/Hybrid rendering in LayOut.
Scaled Drawing
  • We fixed an issue where the paper space dimension was being used with certain arc types.
Miscellaneous
  • We now allow users to convert the leader type on multiple selected dimensions from the rt. click context menu.
  • We fixed a bug where labels would not align text correctly.
  • An issue has been fixed with dimensions where the manual set scale would always default to Auto Scale.
  • We added a new ‘Hidden’ style dash pattern to be consistent with SketchUp’s dash patterns.
  • We fixed an issue where click dragging would pick up the transform gizmo.
  • An issue with the Path tool has been fixed where inferences would be lost if esc or undo was performed during input.
  • We fixed an issue where manipulating a copied Rectangle would give disproportionate results.
  • We fixed an issue where Rounded rectangles would not scale proportionally.
  • We fixed an issue where ‘Sample’ would go away during with the Style tool when the cursor was moved.
  • The text tool has been fixed to allow highlighted text to be underlined individually.
  • Fixed an issue where the Align vertical icon was not aligned vertically.
  • Fixed an issue where Run of Dimensions would display the wrong value with entities that are off axis.
  • (Win) We fixed an issue with the Text tool so that the Anchor point and Alignment correspond with start location and mouse sweep direction.
  • (Win) Fixed an issue in presentation mode when changing pages would cause the display to zoom in when your resolution was set to anything but 100%.
  • (Win) A crash has been fixed when switching between inspectors.
  • (Mac) We fixed an issue where the Format option will not be visible on the exporter dialog when dialog is maximized on macOS High Sierra.
  • (Mac) We fixed an issue with Dimensions where editing the text color settings from the font panel would not take effect.

SketchUp and LayOut API Release Notes

Upgrade to Ruby 2.5.1

We have upgraded from Ruby 2.2.4 to Ruby 2.5.1. These upgrades tend to introduce subtle changes to the Ruby language that sometimes are difficult for us to find in our internal testing. Our testing has not found any major compatibility issues between Ruby 2.2.4 and the new 2.5.1 and we expect the upgrade for most developers should be relatively straightforward.

Dashes

Stipples and dots and dotted stipples, oh my! SketchUp has added a Dashes feature that allows for unique line styles to be applied and controlled at the Layer level. We have exposed this new feature in the Ruby and C APIs. See the Improvements and Fixes sections of each API for a list of classes and methods we’ve added. See the documentation for each API for complete documentation on how to use these features.

Materials Bug Fixes and Improvements

The Extensibility team has done some code refactoring around how materials are named, created, and duplicated in both the UI and in the core SketchUp code. The main change that will be visible to developers is that we fixed a bug that was introduced in SketchUp 2018 where if Ruby tried to name a material to its current name ie: material.name = material.name it would fail, which was unexpected and unnecessary. There was also a bug where fetching a material by using its string name could fail due to a syncing error in the internally cached list of materials. We improved it so that scenario no longer fails. We also did some other code cleanup around disallowing duplicate material names via the UI which should not affect the Ruby API.

InstancePath Support for Dimensions and Text

In SketchUp 2019 we have added InstancePath support to our existing DimensionLinear and Text classes. Now when creating a Linear Dimension, or an attached Text object, you can attach it to a nested entity by providing a valid InstancePath object, or an array version of an instance path. This will allow you to create a dimension in model space, but attach it to a valid nested entity. The linear dimension or text will then be attached to that entity, exactly how it is when linear dimensions and text are created via the UI.

Ruby API Breaking Changes
  • SketchUp changed how it presents units. Now it adds a space between the number and the unit indicator. If your extension uses a method of your own creation to interpret strings formatted by SketchUp you might find it doesn't work anymore if you don't account for the extra space. For example:
    • Before 2019: "2.5mm"
    • Now in 2019: "2.5 mm"
  • Ruby Version Upgrade - Ruby 2.5 removed the method: Dir::Tmpname.make_tmpname If you were using that method, you will need to find an alternative
  • Entity.delete_attribute no longer returns “true” when attempting to delete a non-existing dictionary key
Ruby API Additions and Improvements
  • Update Ruby on Windows to use the right location for cacert.pem
  • Ensure Ruby uses a recent OpenSSL version
  • Fixed a regression on the Mac where renaming a material via the API will create duplicate materials
  • Upgraded ruby version from 2.2.4 to 2.5.1 for both mac and windows
  • Added Sketchup::Tools#active_tool that returns the active Ruby tool
  • Added import_materials option to Sketchup::Model#import for dwg importer
  • Added instance path support for Sketchup::Entities#add_text
  • Added instance path support for Sketchup::Entities#add_dimension_linear
  • Added Sketchup::LineStyles class
  • Added Sketchup::LineStyle class
  • Added Sketchup::Layer#line_style=
  • Added Sketchup::Model#line_styles
  • Improved String.to_l which parses a String into a Length is now able to parse strings that have a space between the number and unit. It can parse both "2.5mm" and "2.5 mm"
  • Improved Sketchup::InstancePath.new now accepts a path that includes a Sketchup::Image object
Ruby API Bug Fixes
  • Fixed a crash upon exit on Mac when a FrameChangeObserver is active
  • Fixed an issue where Sketchup::Model could become unusable after calling .singleton_class.
  • Fixed Ruby-created dimensions don't highlight when non-associated
  • Fixed Ruby-created dimensions don’t hide correctly when “Hide Foreshortened” is enabled
  • Fixed SketchUp crash when constructing Geom::PolygonMesh with negative values
  • Fixed Ruby DWG Importer units were not working correctly
  • Fixed Geom::PolygonMesh will not accept negative numbers as parameter
  • Fixed Extensions are loaded in a non-deterministic order on High Sierra
  • Fixed SketchUp crashes when attempting to load component made in newer version
  • Fixed typo concerning merge_coplanar_faces in the Importer Options documentation
  • Fixed regression in SU 2018 when renaming a material with the same name
  • This used to throw an error when it should have been a no-op
  • Fixed regression in SU 2018 were model.materials["MaterialName"] might fail
  • Fixed a crash when loading a component made in a newer version of Sketchup
  • Fixed an issue where the Ruby Console would fail with some ascii characters
  • Fixed UI::HtmlDialog such that non-resizable dialog doesn't use width and height from preferences.
  • View.write_image should throw an error if there are more than 5 params passed in.
Miscellaneous
  • Fixed: Advanced Camera Tools - Subsequent Frustums are additive and can get quite large.
  • (Mac) Fixed Extension Warehouse Icons appearing on web dialogs on Mac Mojave.
SketchUp C API Additions and Improvements
  • Added SUDimensionGetFont()
  • Added SUDimensionSetFont()
  • Added SUDimensionLinearGetAlignment()
  • Added SUDimensionLinearGetTextPosition()
  • Added SUFontFromEntity()
  • Added SUFontToEntity()
  • Added SULayerGetLineStyle()
  • Added SULayerSetLineStyle()
  • Added SULengthFormatterGetForceInchDisplay()
  • Added SULengthFormatterSetForceInchDisplay()
  • Added SULineStyleGetName()
  • Added SULineStylesGetLineStyleByName()
  • Added SULineStylesGetLineStyleNames()
  • Added SULineStylesGetNumLineStyles()
  • Added SUModelGetImageDefinitions()
  • Added SUModelGetLineStyles()
  • Added SUModelGetNumImageDefinitions()
  • Added SUTransformationIsMirrored()
  • Added Return value SU_ERROR_SERIALIZATION for method SUStylesAddStyle()
  • Fixed SUDimensionLinear bug with setting a hidden property
  • Fixed SUDimensionRadiaul bug with setting a hidden property
  • Fixed SUTypedValueGetArray bug where the `out` param wasn't being set.
  • Fixed SUTypedValueGetArray memory leak.
DWG Importers and Exporters
  • Upgraded to TEIGHA 4.3.2
Layout Ruby API for SketchUp
  • Document.save will now throw an error if the file is already open in LayOut
  • Added Layout::Path#winding to get the current winding direction of the path. Returns one of the new constants Layout::Path::PATH_WINDING_NONE, Layout::Path::PATH_WINDING_CLOCKWISE, or
  • Layout::Path::PATH_WINDING_COUNTER_CLOCKWISE.
  • Added Layout::SketchUpModel#dash_scale to get the current scale value of stipples in a SketchUp Model Ref. A value of 0.0 indicates the dash scale is automatically determined based on the line weight.
  • Added Layout::SketchUpModel#dash_scale= to set the scale value of stipples for the SketchUp Model Ref. A value at or below 0.0 will cause the scale to automatically be determined by the line weight.
  • Fix documentation of Layout::Path#append_point. When appending a bezier path segment, the params should have been (control_1, control_2, point) and not (point, control_1, control_2).
LayOut C API Additions and Improvements
  • LODocumentSaveToFile will now return an SU_ERROR_SERIALIZATION when trying to save a .layout file that is currently open in LayOut.
  • Added LOPathGetWindingType
  • Added LOSketchUpModelGetDashScale
  • Added LOSketchUpModelSetDashScale
Chromium (CEF)
Chromium Version:

2019: Chrome/64.0.3282.119
2018: Chrome/56.0.2924.76

TAGS