Como selecionar geometrias

A ferramenta Selecionar (Ferramenta Selecionar) especifica as entidades que você deseja modificar com outras ferramentas ou comandos do SketchUp. Caso queira alterar o comprimento de uma linha, primeiro selecione a linha. Se quiser dimensionar uma caixa, primeiro selecione a caixa. Caso queira mover uma linha e uma caixa, comece selecionando ambos, criando o que chamamos de conjunto de seleção.

Veja aqui onde encontrar a ferramenta Selecionar no SketchUp:

  • Barra de ferramentas Introdução (exibida aqui), barra de ferramentas Grande Conjunto de Ferramentas e barra de ferramentas Principal (Microsoft Windows)
  • Paleta de ferramentas (macOS)
  • Menu Ferramentas

Barra de ferramentas Introdução

Dica: a ferramenta Selecionar é tão importante para a modelagem em 3D no SketchUp que conta também com um atalho bem simples no teclado: basta pressionar a barra de espaço para ativar a ferramenta Selecionar.

Como selecionar uma única entidade

Para selecionar uma única entidade:

  1. Ative a ferramenta Selecionar (Ferramenta Selecionar). O cursor se transforma em uma seta.
  2. Clique em uma entidade. Qualquer item que você selecionar (borda, face ou componente, por exemplo) será destacado, assim como a almofada do sofá neste exemplo.
A almofada é selecionada

Se não selecionar o item certo na primeira vez, tente novamente. Se não quiser que nada fique selecionado, clique em qualquer espaço vazio na janela de desenho.

Como selecionar várias entidades

Quando precisar selecionar mais de um item, o SketchUp oferece algumas outras opções de seleção. Assista o vídeo para saber como essas opções funcionam e aprender truques para agilizar e simplificar as seleções complicadas. Ou continue lendo sobre as maneiras de selecionar várias entidades.

Dica: independentemente da ferramenta que estiver ativa, selecioneEditar > Selecionar tudo, na barra de menu, ou pressione Ctrl+A (Microsoft Windows) ou Command+A (macOS) para selecionar tudo no modelo.
Para garantir que não haja nada selecionado, selecione Editar > Desmarcar tudo, pressione Ctrl+T (Microsoft Windows) ou Shift+Command+A (macOS) ou clique em qualquer espaço vazio na área de desenho.

Com a ferramenta Selecionar ativa, você pode selecionar várias entidades de qualquer uma das maneiras a seguir:

  • Clique e arraste para criar uma caixa de seleção. Com a ferramenta Selecionar ativa, clique e arraste para criar uma caixa temporária em torno dos itens que quiser selecionar. Quando soltar o botão do mouse, seus itens serão selecionados. Se clicar e arrastar para a esquerda (seleção cruzada), qualquer item que estiver total ou parcialmente dentro da caixa será selecionado. Se clicar e arrastar para a direita (seleção de janela, indicado na imagem), você selecionará somente o que estiver completamente dentro da caixa. Por exemplo, veja como apenas uma almofada vermelha é selecionada, mesmo a segunda estando parcialmente dentro da caixa de seleção da janela.

    Seleção de uma janela
  • Clique duplo ou triplo. Dependendo do item em que clicar, você poderá selecionar combinações de bordas e faces. A tabela a seguir descreve as opções que você tem.
    Faça isso... ... Para selecionar isto
    Clique duas vezes em uma faceA face e todas as suas bordas delimitadoras (1)
    Clique duas vezes em uma bordaNa borda e na face conectada a ela (2)
    Clique três vezes em uma entidadeTodas as entidades conectadas. Por exemplo, se clicar três vezes na face de um cubo, todo o cubo será selecionado. (3)

    Clique duas vezes em uma face ou borda. Clique três vezes para selecionar uma entidade.
  • Clique com o botão de contexto em uma borda. Quando clicamos com o botão de contexto em uma borda, o menu de contexto apresenta as seguintes opções:
    • Selecionar > Faces conectadas: seleciona todas as faces conectadas à entidade selecionada.
    • Selecionar > Tudo conectado: seleciona todas as entidades conectadas à entidade selecionada. (O resultado é o mesmo do clique triplo na entidade.)
    • Selecionar > Tudo na mesma camada: seleciona todas as entidades que estiverem na mesma camada que a entidade selecionada. Se o seu modelo não contiver nenhuma camada, o resultado também será o mesmo do clique triplo.
  • Clique com o botão de contexto em uma face. Quando clicamos com o botão de contexto em uma face, o menu de contexto traz todas as opções exibidas quando se clica com o botão de contexto em uma borda, além de duas outras opções:
    • Selecionar > Bordas delimitadoras: seleciona todas as bordas delimitadoras da face selecionada.
    • Selecionar > Tudo com o mesmo material: seleciona todas as entidades que têm o mesmo material que a face selecionada. Se quiser selecionar todas as faces com material de tijolo ou tinta vermelha, por exemplo, e trocar esse material por outro, este método facilitará e agilizará essa ação.

Como adicionar e subtrair de um conjunto de seleção

Durante a seleção de várias entidades, é fácil pegar uma entidade não desejada ou perder uma entidade desejada. Para adicionar ou remover entidades de um conjunto de seleção, confirme se a ferramenta Selecionar está ativa. Depois, ajuste a seleção com os modificadores pelo teclado indicados na tabela a seguir. Por exemplo, para selecionar ambas as almofadas vermelhas conforme mostrado aqui, selecione uma e mantenha a tecla Ctrl pressionada enquanto seleciona a outra almofada.

Duas entidades são selecionadas.

Dica: quando ativamos uma tecla modificadora, o cursor da ferramenta Selecionar exibe um sinal de adição ou subtração (O cursor da ferramenta Selecionar quando uma tecla modificadora é selecionada) ao lado da seta.

Para fazer isso... Pressione e segure esta(s) tecla(s) Enquanto...
Adicionar ao conjunto de seleção, uma entidade de cada vez Ctrl (Microsoft Windows) ou Opção (macOS) Clica em entidades não selecionadas
Alterar o status da seleção de uma entidade. (selecionar uma entidade não selecionada ou desmarcar uma entidade selecionada)Shift Clica em uma entidade
Subtrair do conjunto de seleção Shift+Ctrl (Microsoft Windows) ou Shift+Opção (macOS) Clica em entidades selecionadas

Dica: se precisar de uma forma temporária de seleção rápida do mesmo grupo de itens, transforme a seleção em um grupo. Consulte Como organizar modelos para ver os detalhes sobre como criar grupos.

Como inverter uma seleção

A inversão das seleções pode simplificar edições complicadas, como remover folhas de uma árvore. Neste exemplo, selecionaríamos o tronco e os galhos e inverteríamos a seleção para selecionar todas as folhas.

Para inverter uma seleção, faça a seleção inicial e pressione Ctrl+Shift+I.

Para inverter uma seleção, faça a seleção inicial e pressione Command+Shift+I.

Ou selecione Editar > Inverter seleção na barra de menus.